用户指南 取消(C)

创建和记录动作

  1. Photoshop 用户指南
  2. Photoshop 简介
    1. 有梦想,去实现
    2. Photoshop 的新增功能
    3. 编辑第一张照片
    4. 创建文档
    5. Photoshop | 常见问题
    6. Photoshop 系统要求
    7. 了解 Photoshop
  3. Photoshop 和其他 Adobe 产品和服务
    1. 在 Photoshop 中使用 Illustrator 图稿
    2. 在 InDesign 中处理 Photoshop 文件
    3. 适用于 Photoshop 的 Substance 3D 素材
    4. 在 Photoshop 中使用 Capture 应用程序内扩展
  4. Photoshop iPad 版(在中国大陆不可用)
    1. Photoshop iPad 版 | 常见问题
    2. 了解工作区
    3. 系统要求 | Photoshop iPad 版
    4. 创建、打开和导出文档
    5. 添加照片
    6. 处理图层
    7. 使用画笔进行绘图和绘画
    8. 建立选区并添加蒙版
    9. 修饰复合
    10. 使用调整图层
    11. 使用曲线调整复合图像的色调
    12. 应用变换操作
    13. 裁剪和旋转复合图像
    14. 旋转、平移、缩放和重置画布
    15. 使用文字图层
    16. 使用 Photoshop 和 Lightroom
    17. 在 Photoshop iPad 版中获取缺失字体
    18. Photoshop iPad 版中的日文文本
    19. 管理应用程序设置
    20. 触控快捷键和手势
    21. 键盘快捷键
    22. 编辑图像大小
    23. 在 Photoshop iPad 版上创作直播
    24. 使用修复画笔校正瑕疵
    25. 在 Capture 中创建画笔并将其用在 Photoshop 中
    26. 使用 Camera Raw 文件
    27. 创建和使用智能对象
    28. 使用减淡和加深调整图像中的曝光度
  5. Photoshop Web 版(在中国大陆不可用)
    1. 常见问题
    2. 系统要求
    3. 键盘快捷键
    4. 支持的文件类型
    5. 工作区简介
    6. 打开并处理云文档
    7. 生成式 AI 功能
    8. 编辑的基本概念
    9. 快速操作
    10. 处理图层
    11. 修饰图像并去除瑕疵
    12. 快速建立选区
    13. 使用调整图层改进图像
    14. 移动、变换和裁切图像
    15. 绘制和绘图
    16. 使用文字图层
    17. 与 Web 上的任何人协作
    18. 管理应用程序设置
  6. Photoshop (Beta)(在中国大陆不可用)
    1. 开始使用 Creative Cloud Beta 版应用程序
    2. Photoshop (Beta) 桌面版
  7. 生成式 AI(在中国大陆不可用)
    1. Photoshop 中生成式 AI 的常见问题
    2. Photoshop 桌面版中的生成式填充
    3. Photoshop 桌面版中的生成式扩展
    4. Photoshop iPad 版中的生成式填充
    5. Photoshop iPad 版中的生成式扩展
    6. Photoshop iPad 版中的生成式变体
    7. Photoshop Web 版中的生成式 AI 功能
  8. 内容真实性(在中国大陆不可用)
    1. Photoshop 中的内容凭据
    2. NFT 的身份和来源
    3. 连接帐户进行创意归因
  9. 云文档(在中国大陆不可用)
    1. Photoshop 云文档 |常见问题
    2. Photoshop 云文档 | 工作流程问题
    3. 在 Photoshop 中管理和使用云文档
    4. 升级 Photoshop 的云存储空间
    5. 无法创建或保存云文档
    6. 解决 Photoshop 云文档错误
    7. 收集云文档同步日志
    8. 邀请其他人参与编辑云文档
    9. 完成文件和应用程序内注释的共享
  10. 工作区
    1. 工作区基础知识
    2. 首选项
    3. 使用 Photoshop“发现”面板加快学习速度
    4. 创建文档
    5. 置入文件
    6. 默认键盘快捷键
    7. 自定义键盘快捷键
    8. 工具库
    9. 性能首选项
    10. 使用工具
    11. 预设
    12. 网格和参考线
    13. 触控手势
    14. 将 Touch Bar 与 Photoshop 结合使用
    15. 触摸功能和可自定义的工作区
    16. 技术预览
    17. 元数据和注释
    18. 触摸功能和可自定义的工作区
    19. 将 Photoshop 图像置入其他应用程序
    20. 标尺
    21. 显示或隐藏不打印的额外内容
    22. 指定图像的列
    23. 还原和历史记录
    24. 面板和菜单
    25. 使用对齐功能定位元素
    26. 用标尺工具定位
  11. Web、屏幕和应用程序设计
    1. Photoshop 设计功能
    2. 画板
    3. 设备预览
    4. 从图层拷贝 CSS
    5. 将 Web 页切片
    6. 切片的 HTML 选项
    7. 修改切片版面
    8. 使用 Web 图形
    9. 创建 Web 照片画廊
  12. 图像和颜色基础知识
    1. 如何调整图像大小
    2. 处理栅格图像和矢量图像
    3. 图像大小和分辨率
    4. 从相机和扫描仪获取图像
    5. 创建、打开和导入图像
    6. 查看图像
    7. 无效的 JPEG 标记错误 | 打开图像
    8. 查看多个图像
    9. 自定拾色器和色板
    10. 高动态范围图像
    11. 匹配图像中的颜色
    12. 在颜色模式之间转换
    13. 颜色模式
    14. 抹除图像的部分内容
    15. 混合模式
    16. 选择颜色
    17. 自定索引颜色表
    18. 图像信息
    19. 扭曲滤镜不可用
    20. 关于颜色
    21. 使用通道进行颜色和单色调整
    22. 在“颜色”和“色板”面板中选择颜色
    23. 取样
    24. 颜色模式或图像模式
    25. 色调
    26. 向动作添加条件模式更改
    27. 从 HTML、CSS 和 SVG 添加色板
    28. 位深度和首选项
  13. 图层
    1. 图层基础知识
    2. 非破坏性编辑
    3. 创建和管理图层和组
    4. 选择、编组和链接图层
    5. 将图像置入图框中
    6. 图层不透明度和混合
    7. 蒙版图层
    8. 应用智能滤镜
    9. 图层复合
    10. 移动、堆叠和锁定图层
    11. 使用矢量蒙版遮盖图层
    12. 管理图层和组
    13. 图层效果和样式
    14. 编辑图层蒙版
    15. 抽出资源
    16. 显示带有剪贴蒙版的图层
    17. 从图层生成图像资源
    18. 使用智能对象
    19. 混合模式
    20. 将多个图像组合到人像组中
    21. 使用自动混合图层组合图像
    22. 对齐和分布图层
    23. 从图层拷贝 CSS
    24. 载入图层或图层蒙版边界上的选区
    25. 显示其他图层中内容的挖空效果
  14. 选择
    1. 选区快速入门
    2. 在复合图像中建立选区
    3. “选择并遮住”工作区
    4. 使用选框工具进行选择
    5. 使用套索工具进行选择
    6. 调整像素选区
    7. 移动、拷贝和删除选定的像素
    8. 创建临时快速蒙版
    9. 选择图像中的颜色范围
    10. 在路径和选区边界之间转换
    11. 通道基础知识
    12. 存储选区和 Alpha 通道蒙版
    13. 选择位于焦点中的图像区域
    14. 复制,拆分,和合并通道
    15. 通道计算
  15. 图像调整
    1. 替换对象颜色
    2. 透视变形
    3. 减少相机抖动模糊
    4. 修复画笔示例
    5. 导出颜色查找表
    6. 调整图像锐化程度和模糊程度
    7. 了解颜色调整
    8. 应用亮度/对比度调整
    9. 调整阴影和高光细节
    10. 色阶调整
    11. 调整色相和饱和度
    12. 调整自然饱和度
    13. 调整图像区域中的颜色饱和度
    14. 快速调整色调
    15. 对图像应用特殊颜色效果
    16. 通过色彩平衡调整增强图像
    17. 高动态范围图像
    18. 查看直方图和像素值
    19. 匹配图像中的颜色
    20. 裁剪并拉直照片
    21. 将彩色图像转换为黑白图像
    22. 调整图层和填充图层
    23. 曲线调整
    24. 混合模式
    25. 设置用于印刷的图像目标值
    26. 使用色阶和曲线吸管工具调整颜色和色调
    27. 调整 HDR 曝光度和色调
    28. 减淡或加深图像区域
    29. 调整可选颜色
  16. Adobe Camera Raw
    1. Camera Raw 的系统要求
    2. Camera Raw 新增功能
    3. Camera Raw 简介
    4. 创建全景图
    5. 支持的镜头
    6. Camera Raw 中的晕影、颗粒和去除薄雾效果
    7. 默认键盘快捷键
    8. Camera Raw 中的自动透视校正功能
    9. Camera Raw 中的径向滤镜
    10. 管理 Camera Raw 设置
    11. 在 Camera Raw 中打开、处理和保存图像
    12. 在 Camera Raw 中使用增强型污点去除工具修复图像
    13. 旋转、裁切和调整图像
    14. 在 Camera Raw 中调整颜色显示
    15. Camera Raw 中的处理版本
    16. 在 Camera Raw 中进行局部调整
  17. 图像修复和图像恢复
    1. 通过“内容识别填充”从照片中移去对象
    2. 内容识别修补和移动
    3. 修饰和修复照片
    4. 校正图像扭曲和杂色
    5. 用于修复大多数问题的基本故障排除步骤
  18. 图像增强和变换
    1. 替换图像中的天空
    2. 变换对象
    3. 调整裁剪、旋转和画布大小
    4. 如何裁剪并拉直照片
    5. 创建并编辑全景图图像
    6. 变形图像、外形和路径
    7. 消失点
    8. 内容识别缩放
    9. 变换图像、形状和路径
  19. 绘图和绘画
    1. 绘制对称图案
    2. 绘制矩形并修改描边选项
    3. 关于绘图
    4. 绘制和编辑形状
    5. 绘画工具
    6. 创建和修改画笔
    7. 混合模式
    8. 为路径添加颜色
    9. 编辑路径
    10. 使用混合器画笔绘画
    11. 画笔预设
    12. 渐变
    13. 渐变插值
    14. 填充和描边选区、图层和路径
    15. 用钢笔工具绘图
    16. 创建图案
    17. 使用图案生成器创建图案
    18. 管理路径
    19. 管理图案库和预设
    20. 使用绘图板绘图或绘画
    21. 创建纹理画笔
    22. 将动态元素添加到画笔中
    23. 渐变
    24. 使用“历史记录艺术画笔”绘制风格化描边
    25. 使用图案进行绘画
    26. 在多个设备上同步预设
    27. 迁移预设、动作和设置
  20. 文本
    1. 添加和编辑文本
    2. 统一文本引擎
    3. 使用 OpenType SVG 字体
    4. 设置字符格式
    5. 设置段落格式
    6. 如何创建文字效果
    7. 编辑文本
    8. 行距和字距
    9. 阿拉伯语和希伯来语文字
    10. 字体
    11. 解决字体问题
    12. 亚洲文字
    13. 创建文字
  21. 滤镜和效果
    1. 使用液化滤镜
    2. 使用模糊画廊
    3. 滤镜基础知识
    4. 滤镜效果参考
    5. 添加光照效果
    6. 使用自适应广角滤镜
    7. 使用油画滤镜
    8. 使用液化滤镜
    9. 图层效果和样式
    10. 应用特定的滤镜
    11. 涂抹图像区域
  22. 存储和导出
    1. 在 Photoshop 中存储文件
    2. 在 Photoshop 中导出文件
    3. 支持的文件格式
    4. 以图形格式存储文件
    5. 在 Photoshop 和 Illustrator 之间移动设计
    6. 存储和导出视频和动画
    7. 存储 PDF 文件
    8. Digimarc 版权保护
  23. 色彩管理
    1. 了解色彩管理
    2. 保持颜色一致
    3. 颜色设置
    4. 双色调
    5. 使用颜色配置文件
    6. 对要联机查看的文档进行色彩管理
    7. 打印时对文档进行色彩管理
    8. 对导入的图像进行色彩管理
    9. 校样颜色
  24. Web、屏幕和应用程序设计
    1. Photoshop 设计功能
    2. 画板
    3. 设备预览
    4. 从图层拷贝 CSS
    5. 将 Web 页切片
    6. 切片的 HTML 选项
    7. 修改切片版面
    8. 使用 Web 图形
    9. 创建 Web 照片画廊
  25. 视频和动画
    1. Photoshop 中的视频编辑
    2. 编辑视频和动画图层
    3. 视频和动画概述
    4. 预览视频和动画
    5. 在视频图层中绘制帧
    6. 导入视频文件和图像序列
    7. 创建帧动画
    8. Creative Cloud 3D 动画(预览)
    9. 创建时间轴动画
    10. 创建视频图像
  26. 打印
    1. 打印 3D 对象
    2. 从 Photoshop 打印
    3. 使用色彩管理进行打印
    4. 联系表和 PDF 演示文稿
    5. 以图片包版面的形式打印照片
    6. 打印专色
    7. 将图像打印到商业印刷机
    8. 改进 Photoshop 中的色彩打印
    9. 解决打印问题 | Photoshop
  27. 自动化
    1. 创建动作
    2. 创建数据驱动图形
    3. 脚本
    4. 处理一批文件
    5. 播放和管理动作
    6. 添加条件动作
    7. 关于动作和“动作”以显示“动作”面板
    8. 记录动作中的工具
    9. 向动作添加条件模式更改
    10. Photoshop 中有关增效工具和脚本的 UI 工具包
  28. 疑难解答
    1. 修复的问题
    2. 已知问题
    3. 优化 Photoshop 性能
    4. 基本故障诊断
    5. 对崩溃或冻结问题进行故障诊断
    6. 对程序错误进行故障诊断
    7. 对“暂存盘已满”错误进行故障诊断
    8. 对 GPU 和显卡驱动程序问题进行故障诊断
    9. 查找缺失的工具
    10. Photoshop | 围绕即将中断的 3D 功能的常见问题

通过轻松记录经常执行的任务对应的动作,提高工作效率。

本文主题:

动作记录原则

记录动作时请记住以下原则:

  • 可以在动作中记录大多数(而非所有)命令。

  • 您可以记录用“选框”、“移动”、“多边形”、“套索”、“魔棒”、“裁剪”、“切片”、“魔术橡皮擦”、“渐变”、“油漆桶”、“文字”、“形状”、“注释”、“吸管”和“颜色取样器”工具执行的操作,也可以记录在“历史记录”、“色板”、“颜色”、“路径”、“通道”、“图层”、“样式”和“动作”面板中执行的操作。

  • 结果取决于文件和程序设置变量,如现用图层和前景色。例如,3 像素高斯模糊在 72 ppi 文件上创建的效果与在 144 ppi 文件上创建的效果不同。“色彩平衡”也不适用于灰度文件。

  • 如果记录的动作包括在对话框和面板中指定设置,则动作将反映在记录时有效的设置。如果在记录动作的同时更改对话框或面板中的设置,则会记录更改的值。

注意:

大多数对话框会保留上次使用时所指定的设置。请仔细检查,看这些值是否是要记录的值。

  • 模态操作和工具以及记录位置的工具都使用当前为标尺指定的单位。模态操作或工具要求按 Enter 键或 Return 键才可应用其效果,例如变换或裁剪。记录位置的工具包括“选框”、“切片”、“渐变”、“魔棒”、“套索”、“形状”、“路径”、“吸管”和“注释”工具。
注意:

如果记录将在大小不同的文件上播放的动作,应将标尺单位设置为百分比。这样,动作将始终在图像中的同一相对位置播放。

  • 可以记录“动作”面板菜单上列出的“播放”命令,使一个动作播放另一个动作。

记录动作的步骤

创建新动作时,您所用的命令和工具都将添加到动作中,直到停止记录。

注意:

为了防止出错,请在副本中进行操作:在动作开始但尚未应用其他命令之前,记录“文件”>“存储为”命令并选择“作为副本”。或者,也可以单击“历史记录”面板上的“新建快照”按钮,以便在记录动作之前拍摄图像快照。 

  1. 打开文件。
  2. 在“动作”面板中,单击“创建新动作”按钮 ,或从“动作”面板菜单中选择“新建动作”。
  3. 输入一个动作名称,选择一个动作集,然后设置附加选项:

    功能键

    为该动作指定一个键盘快捷键。您可以选择功能键、Ctrl 键 (Windows) 或 Command 键 (Mac OS) 和 Shift 键的任意组合(例如,Ctrl+Shift+F3),但有如下例外:在 Windows 中,不能使用 F1 键,也不能将 F4 或 F6 键与 Ctrl 键一起使用。

    注意:

    如果指定动作与命令使用同样的快捷键,快捷键将适用于动作而不是命令。

    使用颜色字段指定在“按钮”模式下显示的颜色。

    使用“颜色”字段指定在“按钮”模式下显示的颜色。

  4. 单击“开始记录”。“动作”面板中的“开始记录”按钮 变为红色。
    注意:

    记录“存储为”命令时,不要更改文件名。如果输入新的文件名,每次运行动作时,都会记录和使用该新名称。在存储之前,如果浏览到另一个文件夹,则可以指定另一位置而不必指定文件名。

  5. 执行要记录的操作和命令。

    并不是动作中的所有任务都可以直接记录;不过,可以用“动作”面板菜单中的命令插入大多数无法记录的任务。

  6. 要停止记录,请单击“停止播放/记录”按钮,或从“动作”面板菜单中选择“停止记录”,或按 Esc 键。

注意:

要在同一动作中继续开始记录,请从“动作”面板菜单中选择“开始记录”。

记录动作中的工具

使用 Photoshop 可以记录动作中的工具,如画笔工具。要启用此功能,请从“动作”面板菜单中选取“允许工具记录”。

请注意以下两点:

  • 在记录工具时,选取您的画笔作为动作的一部分,否则 Photoshop 将使用当前所选的画笔。
  • 如果记录的是要在大小不同的文件上播放的动作,则将 Photoshop 的测量单位设置为百分比,不要在画笔预设中定义画笔大小。

专家演示:工具记录

Photoshop 讲师 Howard Pinsky 展示如何在创建动作时使用“允许工具记录”命令。

记录路径

“插入路径”命令使您可以将复杂的路径(用钢笔工具创建的或从 Adobe Illustrator 粘贴的路径)作为动作的一部分包含在内。播放动作时,工作路径被设置为所记录的路径。在记录动作时或动作记录完毕后可以插入路径。

  1. 执行下列操作之一:
    • 开始记录动作。

    • 选择一个动作的名称,在该动作的最后记录路径。

    • 选择一个命令,在该命令之后记录路径。

  2. 从“路径”面板中选择现有的路径。
  3. 从“动作”面板菜单中选择“插入路径”。

如果在单个动作中记录多个“插入路径”命令,则每一个路径都会替换目标文件中的前一个路径。要添加多个路径,请在记录每个“插入路径”命令之后,使用“路径”面板记录“存储路径”命令。

注意:

播放插入复杂路径的动作可能需要大量的内存。如果遇到问题,请增加 Photoshop 的可用内存量。

插入停止

您可以在动作中包含停止,以便执行无法记录的任务(例如,使用绘图工具)。完成任务后,单击“动作”面板中的“播放”按钮即可完成动作。

也可以在动作停止时显示一条简短消息,提醒在继续执行动作之前需要完成的任务。可以在消息框中包含“继续”按钮,以防止万一出现不需要完成其他任务的情况。

  1. 通过执行下列操作之一,选取插入停止的位置:
    • 选择一个动作的名称,在该动作的最后插入停止。

    • 选择一个命令,在该命令之后插入停止。

  2. 从“动作”面板菜单中选择“插入停止”。
  3. 键入希望显示的信息。
  4. 如果希望该选项继续执行动作而不停止,则选择“允许继续”。
  5. 单击“确定”。
注意:

在记录动作时或动作记录完毕后可以插入停止。

播放动作时更改设置

默认情况下,使用最初记录动作时指定的值来完成动作。如果要更改动作内的命令的设置,可以插入一个模态控制。模态控制可使动作暂停以便在对话框中指定值或使用模态工具。(模态工具需要按 Enter 或 Return 才能生效 — 一旦按下 Enter 或 Return,动作将继续执行它的任务。)

模态控制由“动作”面板中命令、动作或组左侧的对话框图标 表示。红色的对话框图标 表示动作或组中的部分(而非全部)命令是模态的。不能在“按钮”模式中设置模态控制。

  1. 执行下列操作之一:
    • 若要为动作中某个命令启用模态控制,请单击该命令名称左侧的框。再次单击可停用模态控制。

    • 若要为动作中所有命令启用或停用模态控制,请单击动作名称左侧的框。

    • 若要为组中所有动作启用或停用模态控制,请单击组名称左侧的框。

从动作中排除命令

可以排除不想作为已记录动作的一部分播放的命令。不能在“按钮”模式中排除命令。

  1. 如果需要,可通过单击“动作”面板中的动作名称左侧的三角形,展开动作中的命令列表。
  2. 执行下列操作之一:
    • 若要排除单个命令,请单击以清除命令名称左边的选中标记。再次单击可包括该命令。

    • 若要排除或包括一个动作或动作组中的所有命令或动作,请单击该动作名称或动作组名称左侧的选中标记。

    • 若要排除或包括所选命令之外的所有命令,请按住 Alt 键 (Windows) 或 Option 键 (Mac OS) 并单击该命令的选中标记。

      为表示动作中的有些命令已被排除,父级动作的勾选标记会变成红色。

插入不可记录的菜单命令

您可以使用“插入菜单项目”命令将许多不可记录的命令插入到动作中。

在记录动作时或动作记录完毕后可以插入命令。插入的命令直到播放动作时才执行,因此插入命令时文件保持不变。命令的任何值都不记录在动作中。如果命令打开一个对话框,在播放期间将显示该对话框,并且暂停动作,直到单击“确定”或“取消”为止。

注意:

在使用“插入菜单项目”命令插入一个打开对话框的命令时,不能在“动作”面板中停用模态控制。

  1. 选取插入菜单项目的位置:
    • 选择一个动作名称,在该动作的最后插入项目。

    • 选择一个命令,在该命令的最后插入项目。

  2. 从“动作”面板菜单中选择“插入菜单项目”。
  3. “插入菜单项目”对话框打开后,从它的菜单中选取一个命令。
  4. 单击“确定”。

编辑和重新记录动作

您可以调整动作中任何特定命令的设置,向现有动作添加命令或遍历整个动作并更改任何或全部设置。

覆盖单个命令

  1. 在“动作”面板中双击该命令。
  2. 输入新值,然后单击“确定”。

向动作添加命令

  1. 执行下列操作之一:
    • 选择动作的名称,在该动作的最后插入新命令。

    • 选择动作中的命令,在该命令之后插入命令。

  2. 单击“开始记录”按钮,或从“动作”面板菜单中选择“开始记录”。
  3. 记录其它命令。
  4. 完成时,单击“动作”面板中的“停止播放/记录”按钮或从面板菜单选择“停止记录”。

重新排列动作中的命令

  1. 在“动作”面板中,将命令拖动到同一动作中或另一动作中的新位置。当突出显示行出现在所需的位置时,松开鼠标按钮。

再次记录动作

  1. 选择动作,然后从“动作”面板菜单选择“再次记录”。
  2. 如果出现模态工具,请使用此工具以创建不同的结果并按下 Enter 或 Return,或仅按下 Enter 或 Return 以保留相同设置。
  3. 如果出现对话框,请更改设置并单击“确定”来记录值,或单击“取消”以保留相同值。

 Adobe

更快、更轻松地获得帮助

新用户?