Photoshop 提供各种工具、滤镜和蒙版,让您能够精细地控制图像锐化程度(或模糊程度)。

视频 | 在 Photoshop 中进行锐化

视频 | 在 Photoshop 中进行锐化
Pete Collins 向您演示 Photoshop 中改进的智能锐化功能...
Pete Collins

视频 | Photoshop 中的选择性对焦

视频 | Photoshop 中的选择性对焦
Photoshop 首席产品经理 Bryan O'Neil Hughes 介绍如何在 Photoshop 中使用模糊画廊来模糊背景并突显主体。
Bryan O'Neil Hughes

锐化建议

锐化可增强图像中的边缘定义。无论您的图像来自数码相机还是扫描仪,大多数图像都受益于锐化。所需的锐化程度取决于数码相机或扫描仪的品质。请记住,锐化无法校正严重模糊的图像。

更好地进行锐化的提示:

  • 请在单独的图层上对图像进行锐化,以便能够在将图像输出到不同介质的情况下重新锐化它。

  • 如果在单独图层上对图像进行锐化,请将图层的混合模式设置为“明亮度”,以避免边缘上出现颜色变化。

  • 锐化会增强图像对比度。如果发现高光或阴影在锐化后被剪切,请使用图层混合控件(如果锐化单独的图层)来防止锐化高光和阴影。请参阅指定用于混合图层的色调范围

  • 请在锐化之前减少图像杂色,以便不会增加杂色。

  • 按小幅度对图像进行多次锐化。第一次锐化以校正由于捕获图像(扫描或使用数码相机拍照)而导致的模糊。校正了图像颜色并调整了图像大小后,再次对图像(或图像的副本)进行锐化,以便针对输出介质增加适当的锐化量。

  • 如有可能,通过将其输出到最终介质来判断锐化效果。所需的锐化量因输出介质的不同而异。

锐化图像时,请使用“USM 锐化”滤镜或“智能锐化”滤镜以便更好地进行控制。尽管 Photoshop 还有“锐化”、“锐化边缘”和“进一步锐化”滤镜选项,但是这些滤镜是自动的,不提供控制和选项。

可以锐化整个图像,也可以只锐化使用选区或蒙版的一部分图像。由于“USM 锐化”和“智能锐化”滤镜一次只能应用于一个图层,因此,您可能需要合并图层或者拼合文件,以便锐化多图层文件中的所有图像图层。

注意:

“USM 锐化”名称来自于传统胶片摄影中使用的一种暗室技术。该滤镜将锐化图像,而不是使图像模糊。

使用智能锐化进行锐化

“智能锐化”滤镜具有“USM 锐化”滤镜所没有的锐化控制功能。您可以设置锐化算法,或控制在阴影和高光区域中进行的锐化量。

Photoshop“智能锐化”对话框
(Photoshop)“智能锐化”对话框
  1. 将文档窗口缩放到 100%,以便精确地查看锐化效果。
  2. 选择“滤镜”>“锐化”>“智能锐化”。

  3. 设置“锐化”选项卡中的控件:

    数量

    设置锐化量。较大的值将会增强边缘像素之间的对比度,从而看起来更加锐利。

    半径

    决定边缘像素周围受锐化影响的像素数量。半径值越大,受影响的边缘就越宽,锐化的效果也就越明显。

    减少杂色

    (仅 Photoshop )减少不需要的杂色,同时保持重要边缘不受影响。

    移去

    设置用于对图像进行锐化的锐化算法。

    • “高斯模糊”是“USM 锐化”滤镜使用的方法。
    • “镜头模糊”将检测图像中的边缘和细节,可对细节进行更精细的锐化,并减少了锐化光晕。
    • “动感模糊”将尝试减少由于相机或主体移动而导致的模糊效果。如果选取了“动感模糊”,请设置“角度”控件。

    角度

    为“移去”控件的“动感模糊”选项设置运动方向。

    更加准确

    (仅 CS6)用更慢的速度处理文件,以便更精确地移去模糊。

  4. 使用“阴影”和“高光”选项卡调整较暗和较亮区域的锐化。(单击“高级”按钮可显示这些选项卡。) 如果暗的或亮的锐化光晕看起来过于强烈,可以使用这些控件减少光晕,这仅对于 8 位/通道和 16 位/通道的图像有效:

    渐隐量

    调整高光或阴影中的锐化量。

    色调宽度

    控制阴影或高光中色调的修改范围。向左移动滑块会减小“色调宽度”值,向右移动滑块会增加该值。较小的值会限制只对较暗区域进行阴影校正的调整,并只对较亮区域进行“高光”校正的调整。

    半径

    控制每个像素周围的区域的大小,该大小用于决定像素是在阴影还是在高光中。向左移动滑块会指定较小的区域,向右移动滑块会指定较大的区域。

  5. 单击“确定”。

使用 USM 锐化进行锐化

“USM 锐化”通过增加图像边缘的对比度来锐化图像。“USM 锐化”不检测图像中的边缘。相反,它会按您指定的阈值找到值与周围像素不同的像素。然后,它将按指定的量增强邻近像素的对比度。因此,对于邻近像素,较亮的像素将变得更亮,而较暗的像素将变得更暗。

另外,您可以指定每个像素相比较的区域半径。半径越大,边缘效果越明显。

Photoshop USM 锐化
原图像和应用了“USM 锐化”的图像

应用到图像的锐化程度通常取决于个人的喜好。请记住,如果对图像进行过度锐化,就会在边缘周围产生光晕效果。

Photoshop USM 锐化
如果对图像进行过度锐化,就会在边缘周围产生光晕效果。

“USM 锐化”滤镜的效果在屏幕上比在高分辨率输出时显著得多。如果最终的目的是打印,请试验确定最适合图像的设置。

  1. (可选)如果您的图像是多图层图像,请选择包含要想锐化的图像的图层。即使这些图层是链接图层或组合图层,也只能一次向一个图层应用“USM 锐化”。在应用“USM 锐化”滤镜之前,可以合并图层。
  2. 选取“滤镜”>“锐化”>“USM 锐化”。确保“预览”选项已被选中。

    注意:

    在预览窗口中单击图像,并按住鼠标查看图像在未锐化时的外观。在预览窗口中拖动,查看图像的不同部分,然后单击 + 号或 - 号放大或缩小。

    尽管在“USM 锐化”对话框中有一个预览窗口,但最好移动该对话框,以便您可以在文档窗口中预览该滤镜的效果。

  3. 拖动“半径”滑块或输入一个值,确定边缘像素周围影响锐化的像素数目。半径值越大,边缘效果的范围越广, 而边缘效果的范围越广,锐化也就越明显。

    “半径”值随主体、最终复制品的大小以及输出方法的不同而不同。对于高分辨率图像,通常建议使用 1 和 2 之间的“半径”值。较低的数值仅锐化边缘像素,较高的数值则锐化范围更宽的像素。这种效果在打印时没有在屏幕上时明显,因为 2 像素的半径在高分辨率输出图像中表示更小的区域。

  4. 拖动“数量”滑块或输入一个值,确定增加像素对比度的数量。对于高分辨率的打印图像,建议使用 150% 和 200% 之间的数量。
  5. 拖动“阈值”滑块或输入一个值,确定锐化的像素必须与周围区域相差多少,才被滤镜看作边缘像素并被锐化。例如,如果阈值为 4,则会影响 0 到 255 的刻度上色调值差异为 4 或更多的所有像素。因此,如果相邻像素的色调值为 128 和 129,它们将会不受到影响。为了避免带入杂色或出现海报化效果(举例来说,在色调较饱和的图像中),请使用边缘蒙版,或尝试用 2 和 20 之间的“阈值”值进行试验。默认的阈值 (0) 将锐化图像中的所有像素。

注意:

如果应用 USM 锐化使亮色出现过度饱和,请选取“编辑”>“渐隐 USM 锐化”并从“模式”菜单中选取“明度”。

有选择地进行锐化

可以通过使用蒙版或选区对图像的局部进行锐化,以防止锐化图像的某些其他部分。例如,您可以在肖像上将边缘蒙版和“USM 锐化”滤镜结合使用,以便锐化眼睛、嘴部、鼻子和头部的轮廓,但不锐化皮肤的纹理。

Photoshop 有选择地进行锐化
使用边缘蒙版将“USM 锐化”仅应用于图像中的特定特征

锐化选区

  1. 在“图层”面板中选定图像图层的情况下,绘制一个选区。
  2. 选取“滤镜”>“锐化”>“USM 锐化”。调整选项并单击“确定”。

    只有选区会被锐化,图像的其余部分将保持不变。

使用边缘蒙版锐化图像

  1. 创建一个蒙版,以便有选择地应用锐化。可通过多种方法来创建边缘蒙版。使用您最喜欢的方法,或尝试这个方法:
    • 打开“通道”面板,并选择显出文档窗口中对比度最高的灰度图像的通道。通常,此通道是绿色或红色通道。
    Photoshop 边缘蒙版
    选择对比度最高的通道

    • 复制选定通道。
    • 在复制通道处于选定状态时,选择“滤镜”>“风格化”>“查找边缘”。
    • 选取“图像”>“调整”>“反相”,使图像反相。
    Photoshop 应用了“边缘”滤镜并对图像进行了反相
    应用了“查找边缘”滤镜并对图像进行了反相

    • 在反相图像仍处于选定状态时,选取“滤镜”>“其它”>“最大值”。将半径设置为较小的数字并单击“确定”,即可使边缘变粗并使像素随机出现。
    • 选取“滤镜”>“杂色”>“中间值”。将半径设置为较小的数字并单击“确定”。这将对相邻的像素求平均值。
    • 选取“图像”>“调整”>“色阶”,将黑场设置为较高的值以去掉随机像素。如有必要,还可以用黑色绘画以便修饰最终的边缘蒙版。
    Photoshop 边缘蒙版黑场
    在“色阶”中将黑场设置为较高的值,即可消除边缘蒙版中的随机像素

    • 选取“滤镜”>“模糊”>“高斯模糊”以羽化边缘。

    注意:

    “最大值”、“中间值”和“高斯模糊”滤镜会柔化边缘蒙版,这样,锐化效果就会更好地混合在最终图像中。尽管此过程中使用了全部三个滤镜,但您也可以只使用一个或两个滤镜进行试验。

  2. 在“通道”面板中,按住 Ctrl 键 (Windows) 或 Command 键 (Mac OS) 并单击复制通道,以使边缘蒙版成为选区。
  3. 在“图层”面板中,选择该图像图层。确保仍然能够在图像上看到选区。
  4. 选取“选择”>“反向”。
  5. 当选区在图像图层中处于现用状态时,选取“滤镜”>“锐化”>“USM 锐化”。设置所需选项,然后单击“确定”。

    要查看结果,请在“通道”面板中选择 RGB 通道,然后取消选择图像中的选区。

    注意:

    您可以创建一个动作来方便地应用该过程中的所有步骤。

添加镜头模糊

向图像中添加模糊以产生更窄的景深效果,以便使图像中的一些对象在焦点内,而使另一些区域变模糊。可以使用简单的选区来确定哪些区域变模糊,或者可以提供单独的 Alpha 通道深度映射来准确描述希望如何增加模糊。

“镜头模糊”滤镜使用深度映射来确定像素在图像中的位置。在选择了深度映射的情况下,也可以使用十字线光标来设置给定模糊的起点。您可以使用 Alpha 通道和图层蒙版来创建深度映射;Alpha 通道中的黑色区域被视为好像它们位于照片的前面,白色区域被视为好像它们位于远处的位置。

注意:

要实现渐变模糊效果(从无(底部)到最大(顶部)),请创建一个新的 Alpha 通道并应用渐变,以便在该通道中,图像的顶部为白色,底部为黑色。然后,选择“镜头模糊”滤镜并从“源”弹出式菜单中选取该 Alpha 通道。要更改渐变的方向,请选择“反相”复选框。

模糊的显示方式取决于您选取的光圈形状。叶片的数量将确定光圈形状。您可以通过弯曲(使它们更圆)或旋转它们来更改光圈的叶片。还可以通过单击减号按钮或加号按钮,缩小或放大预览。

  1. 选取“滤镜”>“模糊”>“镜头模糊”。
  2. 对于“预览”,选择“更快”可提高预览速度。选取“更加准确”可查看图像的最终版本。“更加准确”预览需要的生成时间较长。

  3. 对于“深度映射”,从“源”弹出式菜单中选取一个源(如果有的话)。拖动“模糊焦距”滑块以设置位于焦点内的像素的深度。例如,如果将焦距设置为 100,则深度为 1 和 255 的像素完全模糊,而接近 100 的像素比较清晰。如果单击预览图像,“模糊焦距”滑块将随之更改以反映单击位置,并调准单击位置焦距。
  4. 要反相用作深度映射来源的选区或 Alpha 通道,请选择“反相”。
  5. 从“形状”弹出式菜单中选取光圈。可以根据需要,拖动“叶片弯度”滑块对光圈边缘进行平滑处理;或者拖动“旋转”滑块来旋转光圈。要添加更多的模糊效果,请拖动“半径”滑块。
  6. 对于“镜面高光”,拖动“阈值”滑块来选择亮度截止点;比该截止点值亮的所有像素都被视为镜面高光。要增加高光的亮度,请拖动“亮度”滑块。
  7. 要向图像中添加杂色,请选取“平均分布”或“高斯分布”。要在添加杂色时不影响颜色,请选择“单色”。拖动“数量”滑块来增加或减少杂色。

    注意:

    模糊处理将移去原始图像中的胶片颗粒和杂色。为使图像看上去逼真和未经修饰,可以恢复图像中某些被移去的杂色。

  8. 单击“确定”以应用对图像所做的更改。

模糊图像区域

模糊工具可柔化硬边缘或减少图像中的细节。使用此工具在某个区域上方绘制的次数越多,该区域就越模糊。

  1. 选择模糊工具
  2. 在选项栏中执行下列操作:
    • 在选项栏中选取画笔笔尖,并为混合模式和强度设置选项。
    • 选择选项栏中的“对所有图层取样”以使用所有可见图层中的数据进行模糊处理。如果取消选择此选项,则该工具只使用现有图层中的数据。
  3. 在要进行模糊处理的图像部分上拖动。

锐化图像区域

锐化工具用于增加边缘的对比度以增强外观上的锐化程度。用此工具在某个区域上方绘制的次数越多,增强的锐化效果就越明显。

  1. 选择锐化工具 。(如果该工具未显示,请按住“模糊”工具 。)
  2. 在选项栏中执行下列操作:
    • 选择一个画笔笔尖,并设置用于混合模式和强度的选项。
    • 选择“对所有图层取样”以使用所有可见图层中的数据进行锐化处理。如果取消选择该选项,则该工具只使用现有图层中的数据。
    • 选择“保护细节”可以增强细节并使因像素化而产生的不自然感最小化。如果要产生更夸张的锐化效果,请取消选择此选项。
  3. 在要锐化的图像部分拖动。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略