I canali alfa e i mascherini

Le informazioni dei colori in After Effects sono contenute in tre canali: rosso (R), verde (G) e blu (B). Inoltre, un’immagine può contenere un quarto canale invisibile denominato canale alfa, il quale contiene le informazioni della trasparenza. Talvolta, tale immagine viene definita immagine RGBA, a indicare che contiene un canale alfa.

Panoramica sui canali
Panoramica sui canali

A. Canali di colore separati B. Canale alfa rappresentato come immagine in scala di grigi C. Composto utilizzando tutti e quattro i canali alfa con uno sfondo visibile attraverso aree trasparenti 

Molti formati file possono includere un canale alfa, compresi Adobe Photoshop, ElectricImage, FLV, TGA, TIFF, EPS, PDF e Adobe Illustrator. I formati AVI e QuickTime (salvati a una profondità di bit Milioni di colori+) possono anche contenere canali alfa, a seconda del codec (codificatore) utilizzato per generare le immagini memorizzate in tali contenitori. Per i file EPS e PDF di Adobe Illustrator, After Effects converte automaticamente le aree vuote in un canale alfa.

Quando si specifica la profondità colore di un’immagine di output, il segno più (come in Milioni di colori+) indica un canale alfa. Allo stesso modo, l’output a 32 bit per pixel implica una profondità di output di 8 bit per canale per ciascuno dei quattro canali, RGBA.

Alcuni programmi possono memorizzare più canali alfa in un’unica immagine, ma After Effects interpreta solo il quarto canale come canale alfa.

Nota:

Tecnicamente, il termine canale alfa si riferisce al quarto canale (A) di un file di immagine RGBA, a prescindere dal fatto che il canale sia usato per comunicare informazioni sulla trasparenza. Tuttavia, poiché il quarto canale è usato molto spesso per comunicare informazioni sulla trasparenza, nell’uso comune i termini alfa e trasparenza sono diventati praticamente quasi sinonimi. È importante ricordare, tuttavia, che questo collegamento è essenzialmente arbitrario. Alcuni formati potrebbero usare altri canali per le informazioni sulla trasparenza, mentre altri ancora potrebbero usare il quarto canale per qualcosa di diverso dalle informazioni sulla trasparenza.

Il plug-in Knoll Unmult può essere utilizzato per creare un canale alfa dalle aree scure di un livello. Questa procedura funziona bene con un effetto di luce (come un riflesso di lente o un fuoco) che desiderate comporre al di sopra di un altro livello. Per informazioni in merito, visitate il sito Web Red Giant Software.

Quando visualizzate il canale alfa nel pannello Composizione, il bianco indica l’opacità completa, il nero indica la trasparenza completa e le tonalità di grigio indicano la trasparenza parziale.

Un mascherino è un livello (o un canale di un livello) che definisce le aree trasparenti dello stesso livello o di un altro livello. Il bianco definisce le aree opache e il nero le aree trasparenti. Un canale alfa viene usato spesso come mascherino; tuttavia, potete usare un mascherino diverso dal canale alfa se è disponibile un canale o un livello che definisce l’area di trasparenza desiderata in maniera migliore rispetto al canale alfa, oppure nei casi in cui l’immagine sorgente non contiene un canale alfa.

Le maschere

Una maschera di After Effects è un tracciato usato come parametro per la modifica di attributi, effetti e proprietà dei livelli. L’utilizzo più comune di una maschera consiste nel modificare un canale alfa di un livello, il che determina la trasparenza del livello in ciascun pixel. Un altro comune utilizzo di una maschera è un tracciato per l’animazione del testo. Consultate Creare e animare il testo su un tracciato.

Per ulteriori informazioni sui tracciati in generale, consultate I tracciati.

Maschere
Comportamento predefinito di una maschera tracciata (a sinistra); stessa maschera invertita (a destra)

Le maschere dei tracciati chiusi possono creare aree trasparenti per un livello. I tracciati aperti non possono creare aree trasparenti per un livello ma si rivelano utili come parametri di un effetto. Gli effetti possono utilizzare come input un tracciato maschera aperto o chiuso, incluso Tratto, Testo tracciato, Forma d’onda audio, Spettro audio e Vegas. Gli effetti che possono utilizzare maschere chiuse (ma non maschere aperte) come input includono Riempimento, Macchia, Nuova forma, Ambiente particelle e Trasparenza interno/esterno.

Una maschera appartiene a un livello specifico. Ciascun livello può contenere più maschere.

Potete disegnare maschere con comuni forme geometriche, come poligono, ellissi e stelle, mediante gli strumenti forma, oppure potete utilizzare lo strumento Penna per disegnare un tracciato arbitrario.

Per molti aspetti, disegnare tracciati maschere è simile a disegnare tracciati forme su livelli forme, anche se per la modifica e l’interpolazione dei tracciati maschere sono disponibili alcune funzioni aggiuntive. Potete collegare un tracciato maschera a una forma mediante le espressioni, il che consente di portare i vantaggi offerti dalle maschere nei livelli forma e viceversa. Consultate Creare forme e maschere e Gestione e animazione di tracciati forma e maschere.

La posizione di una maschera nell’ordine di sovrapposizione nel pannello Timeline ha effetto sulla relativa interazione con le altre maschere. Potete trascinare una maschera in una diversa posizione all’interno del gruppo di proprietà Maschere nel pannello Timeline.

La proprietà Opacità maschera relativa a una maschera determina l’influenza che un maschera chiusa ha sul canale alfa del livello all’interno dell’area della maschera. Un valore di Opacità maschera pari a 100% corrisponde a un’area interna completamente opaca. L’area esterna alla maschera è sempre completamente trasparente. Per invertire quello che è considerato l’interno e quello che è considerato l’esterno per una maschera specifica, selezionate Inverti di fianco al nome della maschera nel pannello Timeline.

Risorse online sulle maschere

Questo capitolo di esempio tratto da After Effects CS5 Classroom in a Book e disponibile nel sito Web di Peachpit Press mostra come creare, usare e modificare le maschere.

Copiare, tagliare, salvare, riutilizzare ed eliminare maschere

Potete riutilizzare le maschere in altri livelli e composizioni, il che risulta particolarmente utile per le maschere Bezier al cui perfezionamento avete dedicato un tempo notevole. I tracciati maschere vengono memorizzati all’interno di una composizione in un file progetto.

Nota:

Mathias Möhl condivide lo script CopyMask2Layers con cui potete copiare maschere da un livello ad altri livelli mantenendone posizione e forma.

Copiare, tagliare, duplicare o incollare una maschera

Nota:

quando lavorate con un tracciato maschera (invece che con l’intera maschera, comprese le sue altre proprietà) selezionate la proprietà Tracciato maschera. Questo risulta particolarmente importante quando trasferite i tracciati maschera ai tracciati forma, ai tracciati movimento e così via.

  • Per copiare o tagliare le maschere selezionate negli Appunti, scegliete Modifica > Copia o Modifica > Taglia.
  • Per duplicare le maschere selezionate, scegliete Modifica > Duplica.
  • Per incollare una maschera in un livello, selezionate il livello e scegliete Modifica > Incolla. Se è selezionata una maschera, questa operazione sostituisce la maschera selezionata.

Salvare una maschera

  1. Nel pannello Timeline della composizione contenente il livello e la maschera da salvare espandete il livello e le relative proprietà di maschera.
  2. Effettuate una delle seguenti operazioni:
    • Per salvare una maschera animata, selezionate i fotogrammi chiave della maschera da salvare.
    • Per salvare una maschera non animata, selezionate la maschera.
  3. Copiate la maschera o i fotogrammi chiave e incollateli su un nuovo livello. Il nuovo livello può essere un semplice solido.

Nota:

Create un progetto con composizioni solo per memorizzare maschere complesse. Se desiderate utilizzare una maschera di un progetto diverso, importate il progetto nel progetto corrente.

Nota:

Potete inoltre salvare le maschere come predefiniti dell’animazione. Consultate Predefiniti di animazione.

Riutilizzare una maschera

  1. Aprite la composizione contenente la maschera da riutilizzare. Se avete salvato la maschera in un altro progetto, importate il progetto, quindi aprite la composizione contenente la maschera.
  2. Nel pannello Timeline espandete le proprietà del livello e della maschera per la maschera.
  3. Selezionate la maschera o i fotogrammi chiave.
  4. Copiate la maschera o i fotogrammi chiave e incollateli nel livello sul quale desiderate applicare la maschera.

Eliminare maschere

  • Per eliminare una maschera, selezionate la maschera nel pannello Timeline e premete Canc.
  • Per eliminare tutte le maschere, selezionate il livello contenente le maschere da rimuovere e scegliete Livello > Maschere > Rimuovi tutte le maschere.

Controllare il colore dei tracciati maschere

Per agevolare l’identificazione e l’uso delle maschere, nei pannelli Composizione e Livello il tracciato di una maschera viene delineato con un contorno colorato e nel pannello Timeline lo stesso colore viene visualizzato accanto al nome della maschera. Per impostazione predefinita, After Effects usa il colore giallo per tutte le maschere. Per rendere più distinta ciascuna maschera, potete modificare manualmente il colore di una maschera mediante il pannello Timeline, oppure potete impostare After Effects in modo che passi in rassegna i colori della maschera per le nuove maschere.

Quando è selezionata la preferenza Usa colore in contrasto per tracciato maschera (in Preferenze > Aspetto), After Effects analizza i colori vicino al punto in cui iniziate a disegnare una maschera. After Effects sceglie quindi un colore etichetta diverso dai colori in tale regione. Inoltre evita il colore dell'ultima maschera disegnato.

Cambiare il colore dei tracciati maschere

  1. Selezionate la maschera nel pannello Timeline.
  2. Fate clic sul campione colori a sinistra del nome della maschera, selezionate un nuovo colore e fate clic su OK.

Scorrere i colori dei tracciati delle maschere

  1. Scegliete Modifica > Preferenze > Aspetto.
  2. Selezionate Alterna ciclicamente colori maschera.

Modalità maschera

I metodi di fusione per le maschere (modalità maschera) controllano il modo in cui le maschere di un livello interagiscono tra loro. Per impostazione predefinita, tutte le maschere sono impostate sull’opzione Aggiungi, con la quale vengono combinati i valori delle maschere che si sovrappongono nello stesso livello. Potete applicare una modalità a ciascuna maschera, ma non potete animare la modalità di una maschera—ossia, non potete impostare i fotogrammi chiave o le espressioni per una proprietà della modalità maschera al fine di farla cambiare nel tempo.

Potete selezionare una modalità maschera per una maschera dal menu accanto al nome della maschera nel pannello Timeline.

La prima maschera creata interagisce con il canale alfa del livello. Se tale canale non definisce l’intera immagine come opaca, la maschera interagisce con il fotogramma del livello. Ogni maschera aggiuntiva creata interagisce con le maschere posizionate prima nell’ordine di sovrapposizione nel pannello Timeline. Gli effetti prodotti dalle modalità maschera variano a seconda delle modalità impostate per le maschere che si trovano più in alto nell’ordine di sovrapposizione. Le modalità maschera funzionano solo tra maschere dello stesso livello.

L’uso delle modalità maschera consente di creare maschere composte complesse con più aree trasparenti. Ad esempio, potete impostare una modalità maschera con cui unire due maschere e impostare l’area opaca sulle aree di intersezione delle due maschere.

Maschere composte
Maschere composte ottenute applicando modalità diverse alla maschera circolare. Le maschere nell’illustrazione hanno valori di Opacità maschera diversi.

A. Maschere originali B. Nessuno C. Aggiungi D. Sottrai E. Interseca F. Schiarisci G. Scurisci H. Differenza 

Nessuno

La maschera non ha nessuna influenza diretta sul canale alfa del livello. Questa opzione è utile quando utilizzate il tracciato della maschera per effetti tipo Tratto o Riempimento o se utilizzate il tracciato maschera come base per la forma di un tracciato.

Aggiungi

La maschera viene aggiunta alle maschere sovrastanti nell’ordine di sovrapposizione. L’influenza della maschera si aggiunge a quella delle maschere sopra di essa.

Sottrai

L’influenza della maschera viene sottratta da quelle delle maschere sopra di essa. Questa opzione si rivela utile nella creazione dell’aspetto di un foro al centro di un’altra maschera.

Interseca

La maschera viene aggiunta alle maschere sovrastanti nell’ordine di sovrapposizione. Nelle aree in cui la maschera si sovrappone alle maschere sovrastanti, l’influenza della maschera si aggiunge a quella delle maschere sopra di essa. Nelle aree in cui la maschera non si sovrappone alle maschere sovrastanti, il risultato è una completa opacità.

Schiarisci

La maschera viene aggiunta alle maschere sovrastanti nell’ordine di sovrapposizione. Quando più maschere si intersecano, viene utilizzato il valore di trasparenza più alto.

Scurisci

La maschera viene aggiunta alle maschere sovrastanti nell’ordine di sovrapposizione. Quando più maschere si intersecano, viene utilizzato il valore di trasparenza più basso.

Differenza

La maschera viene aggiunta alle maschere sovrastanti nell’ordine di sovrapposizione. Nelle aree in cui la maschera non si sovrappone alle maschere sovrastanti, la maschera funziona come se i trovasse da sola sul livello. Nelle aree in cui la maschera si sovrappone alle maschere sovrastanti, l’influenza della maschera viene sottratta da quella delle maschere sopra di essa.

Espandere o contrarre i bordi di una maschera

Per espandere o contrarre l’area influenzata da una maschera, usate la proprietà Espansione maschera.

L’espansione della maschera agisce sul canale alfa, ma non sul tracciato della maschera sottostante; l’espansione della maschera è essenzialmente uno spostamento che determina da quale distanza rispetto al tracciato della maschera, in pixel, si estende l’influenza della maschera sul canale alfa.

  1. Nel pannello Timeline espandete le proprietà Maschera del livello da regolare.
  2. Trascinate il valore sottolineato di Espansione maschera.

Nel blog di Todd Kopriva disponibile nel sito Web Adobe potete trovare una dimostrazione e ulteriori spiegazioni relative all’espansione delle maschere e sul perché essa crea angoli arrotondati.

Attenuare (sfumare) i bordi di una maschera

Le sfumature attenuano i bordi di una maschera con una riduzione di trasparenza lungo una distanza definita dall’utente. La proprietà Sfumatura maschera consente di rendere i bordi netti o di attenuarli (sfumatura). Per impostazione predefinita, la larghezza della sfumatura attraversa il bordo della maschera, risultando per metà all’interno e per metà all’esterno della maschera. Ad esempio, se impostate la larghezza della sfumatura su 25, la sfumatura si estende per 12,5 pixel all’interno del bordo della maschera e per 12,5 pixel all’esterno della stessa.

Risultati per i vari valori di Sfumatura maschera
Risultati per i vari valori di Sfumatura maschera

A. Livello maschera con una sfumatura di 5 pixel B. Livello maschera con una sfumatura di 40 pixel C. Risultato con sfumatura di 5 pixel D. Risultato con sfumatura di 40 pixel 

Potete inoltre estendere o comprimere i bordi della maschera usando la proprietà Espansione maschera in modo da determinare la posizione in cui deve apparire la sfumatura della maschera. Consultate Espandere o contrarre i bordi di una maschera.

La sfumatura della maschera avviene soltanto entro le dimensioni del livello. Pertanto, è necessario che il tracciato di una maschera con sfumatura sia sempre leggermente più piccolo dell’area del livello e che non venga mai spostato sul bordo estremo del livello. Se la sfumatura di una maschera si estende oltre l’area del livello, il bordo con sfumatura termina in maniera improvvisa.

  1. Per visualizzare la proprietà Sfumatura maschera per i livelli selezionati, premete F.
  2. (Facoltativo) Perché la sfumatura orizzontale e verticale cambi in modo proporzionale, selezionate lo switch Mantieni proporzioni  accanto alla proprietà Sfumatura maschera.
  3. Modificate la proprietà Sfumatura maschera come qualsiasi altra proprietà, trascinando il valore sottolineato o facendo clic sul valore sottolineato e specificando un valore nel campo di immissione testo.

Nota:

Poiché la sfumatura maschera determina la variazione dei valori di opacità in base alla distribuzione gaussiana, l’area influenzata dalla sfumatura in pratica si estende oltre il numero di pixel specificato. L’intensità dell’influenza della sfumatura oltre l’intervallo di sfumatura specificato è molto piccola. Questa graduale attenuazione gaussiana appare più naturale rispetto a un’attenuazione lineare.

Sfumatura maschera di larghezza variabile

Nelle versioni precedenti di After Effects era possibile aggiungere un bordo sfumato a una maschera chiusa, ma la larghezza (lo spessore) della sfumatura era uniforme lungo l’intero bordo della maschera. Con il nuovo strumento Sfumatura maschera (disponibile nello stesso menu dello strumento Penna) è possibile definire dei punti lungo una maschera chiusa per impostarne uno spessore variabile.

In questo video di Todd Kopriva e video2brain viene presentata la funzionalità di sfumatura della maschera di larghezza variabile. Assegnate più punti di sfumatura a un oggetto per mostrare come i punti di sfumatura interagiscono per creare effetti interessanti.

Creare un punto bordo sfumato:

Un punto di bordo sfumato selezionato presenta un piccolo punto nero in corrispondenza della maniglia.

I punti di bordo sfumato definiscono i bordi interno ed esterno della sfumatura. Se all’interno della maschera non sono presenti maniglie di distanza della sfumatura, il bordo interno della sfumatura corrisponde al tracciato della maschera. La sfumatura della maschera si estende dal suo bordo interno al suo bordo esterno.

Selezionare più punti di bordo sfumato:

Con lo strumento Selezione o Sfumatura maschera, tenete premuto Maiusc e fate clic sulle maniglie di distanza dei punti di bordo sfumato.

Selezionare o deselezionare un punto di bordo sfumato:

Tenete premuto Maiusc e fate clic sul punto di bordo sfumato.

Per spostare un punto di bordo sfumato, effettuate una delle seguenti operazioni:

  • Con lo strumento Selezione o Sfumatura maschera, trascinate la maniglia di distanza della sfumatura.

Per spostare più punti di bordo sfumato selezionati, trascinate uno di essi; per ridimensionare più distanze di sfumatura, trascinate una delle maniglie di distanza della sfumatura.

Potete “spingere” i punti di bordo sfumato attorno ai punti d’angolo di una maschera.

  • Con lo strumento Sfumatura maschera attivato, premete la freccia Sinistra o Destra per spostare la sfumatura lungo il tracciato o la freccia Su o Giù per estendere o ridurre la larghezza della sfumatura.

Per spostare più punti di bordo sfumato selezionati e definire distanze/larghezze superiori, tenete premuto il tasto Maiusc.

Allineare un punto di bordo sfumato al tracciato maschera:

Trascinate la maniglia di distanza della sfumatura sul tracciato maschera. Si interrompe in corrispondenza del tracciato maschera.

Controllare il decadimento della sfumatura:

Scegliete Livello > Maschera > Decadimento bordo sfumato e selezionate una delle seguenti opzioni:

  • Uniforme (predefinito)
  • Lineare

Regolare la tensione (curvatura) di un bordo della sfumatura su un punto di bordo sfumato:

Tenete premuto il tasto Alt (Windows) o Opzione (Mac OS) e trascinate una maniglia di distanza della sfumatura per regolare la tensione. Nel pannello Informazioni viene riportata la tensione corrente di una maniglia.

Impostare l’interpolazione Blocco per un punto di bordo sfumato (per un raggio di sfumatura costante fino al punto di bordo sfumato successivo):

Tenete premuto il tasto Alt (Windows) o Opzione (Mac OS) e trascinate una maniglia di distanza della sfumatura per regolare la tensione. Nel pannello Informazioni viene riportata la tensione corrente di una maniglia.

Impostare l’interpolazione Blocco per un punto di bordo sfumato (per un raggio di sfumatura costante fino al punto di bordo sfumato successivo):

Abilitate l’opzione Blocco dal menu di scelta rapida sul punto di bordo sfumato. La maniglia del punto di bordo sfumato cambia e punta in direzione del raggio costante.

Creare rapidamente un bordo sfumato per un segmento specifico della maschera:

Tenete premuto il tasto Maiusc e fate clic sul segmento della maschera (tra i vertici, non sopra ad essi). Il puntatore cambia aspetto per indicare la modalità impostata. Trascinate il segmento per regolare la distanza. Notate il comportamento seguente:

  • Se sono selezionati solo due vertici della maschera, il bordo sfumato rappresenta i segmenti contigui tra tali vertici.
  • Se sono selezionati entrambi i vertici del segmento scelto (ovvero, il segmento è selezionato), il bordo sfumato si espande per includere i segmenti selezionati contigui.
  • Se sono selezionati tutti i vertici sulla maschera, se non ne è selezionato nessuno oppure se le prime due condizioni non sono valide, il bordo sfumato interessa solo il segmento selezionato.

Eliminare un punto di bordo sfumato:

Con lo strumento Selezione o Sfumatura maschera, selezionate una maniglia di distanza della sfumatura, quindi premete Canc. Potete eliminare più punti di bordo sfumato selezionati.

Nota:

Se posizionato sul vertice di una maschera, il puntatore passa alla modalità di selezione anziché alla modalità di eliminazione del vertice.

Suggerimenti per la sfumatura della maschera di larghezza variabile (strumento Sfumatura maschera)

  • Per passare temporaneamente dallo strumento Penna allo strumento Sfumatura maschera e viceversa, tenete premuto il tasto di scelta rapida “G”.

Potete disattivare questo comportamento in Modifica > Preferenze > Generali (Windows) o After Effects > Preferenze > Generali (Mac OS).

  • Potete visualizzare le informazioni sul numero di punti di bordo sfumato di una maschera, la lunghezza della distanza, la posizione e la tensione di una sfumatura e l’impostazione del decadimento della sfumatura nel pannello Informazioni.
  • Per nascondere i bordi della sfumatura per una vista specifica, deselezionate l’opzione “Limiti bordo sfumato maschera” nella finestra di dialogo Opzioni di visualizzazione. Potete comunque interagire con i bordi (ad esempio, aggiungere nuovi punti di bordo sfumato) nel punto in cui sarebbero stati disegnati.
  • Per controllare la quantità di punti di bordo sfumato tra i fotogrammi chiave del tracciato maschera, usate l’opzione “Mantieni conteggio vertici e bordi sfumati costante durante la modifica delle maschere” in Preferenze > Generali.
  • Per impostare il valore della tensione, del raggio e dell’angolo di un punto di bordo sfumato da una finestra di dialogo, usate i controlli del menu di scelta rapida per un punto di bordo sfumato.
    Per cambiare il comportamento dello strumento Selezione, tenete premuto il tasto Ctrl (Windows) o Comando (Mac OS) mentre passate il cursore del mouse sopra il vertice di una maschera.
  • Per passare allo strumento Converti vertice, tenete premuto il tasto Ctrl (Windows) o Comando (Mac OS) mentre passate il cursore del mouse sopra la maniglia di una tangente.

Mascherini traccia e mascherini mobili

Per fare in modo che un livello sia visibile attraverso i fori definiti da un altro livello, impostate un mascherino traccia. Ad esempio, potete usare un livello testo come mascherino traccia per un livello video per fare in modo che il video sia visibile solo attraverso le forme definite dai caratteri di testo. Il livello sottostante (il livello di riempimento) ottiene i suoi valori di trasparenza dai valori di determinati canali nel livello mascherino traccia—il suo canale alfa oppure la luminanza dei suoi pixel.

Definire la trasparenza di un livello in base alla luminanza dei pixel del mascherino traccia è utile per creare un mascherino traccia utilizzando un livello senza canale alfa, oppure un livello importato da un programma che non è in grado di creare un canale alfa. In entrambi i casi—utilizzando mascherini del canale alfa e mascherini della luminanza—i pixel con valori più alti sono più trasparenti. Nella maggior parte dei casi potete usare un mascherino ad alto contrasto in modo che le aree risultino completamente trasparenti o completamente opache. Le tonalità intermedie devono apparire solo quando occorre usare una trasparenza parziale o graduale, ad esempio, lungo un bordo attenuato.

Mascherino mobile
Mascherino mobile

A. Mascherino traccia, livello: un solido con una maschera rettangolare, impostare su Mascherino luminanza. La maschera viene animata per spostarsi attraverso lo schermo. B. Riempimento, livello: un solido con un effetto pattern. C. Risultato: il pattern è visibile nella forma del mascherino traccia. Esso viene quindi composto su un livello di immagine aggiuntivo. 

Un mascherino traccia si applica solo al livello direttamente sotto di esso. Per applicare un mascherino traccia a più livelli, precomponete prima i diversi livelli e applicate quindi il mascherino traccia al livello precomposizione.

After Effects conserva l’ordine di un livello e del relativo mascherino traccia dopo la duplicazione o la divisione del livello. All’interno dei livelli duplicati o divisi, il livello del mascherino traccia rimane sopra il livello di riempimento. Ad esempio, se la composizione contiene i livelli A e B, dove A è il mascherino traccia e B è il mascherino di riempimento, la duplicazione o la divisione di questi livelli determina l’ordine dei livelli ABAB.

Se animate la posizione o altre trasformazioni del livello mascherino traccia, ottenete un mascherino mobile. Se desiderate animare il mascherino traccia e i livelli di riempimento adottando impostazioni identiche, prendete in considerazione l’uso della precomposizione.

Convertire un livello in un mascherino traccia

Il menu Masch. traccia ha in comune una colonna con il menu dei metodi di fusione. Per visualizzare il menu Masch. traccia, assicuratevi che la colonna Modalità sia visibile. Consultate Colonne.

  1. Nel pannello Timeline, trascinate il livello da usare come mascherino traccia direttamente al di sopra del livello da usare come livello di riempimento.
  2. Definite la trasparenza per il mascherino traccia scegliendo una delle opzioni seguenti dal menu TrkMat per il livello di riempimento:

    Nessun mascherino traccia

    Non viene creata alcuna trasparenza; il livello successivo sovrastante funziona come un normale livello.

    Mascherino alfa

    È opaco quando il valore di pixel del canale alfa è 100%.

    Mascherino alfa invertito

    È opaco quando il valore di pixel del canale alfa è 0%.

    Mascherino luminanza

    Opaco, quando il valore di luminanza di un pixel è pari al 100%.

    Mascherino luminanza invertito

    Opaco, quando il valore di luminanza di un pixel è pari allo 0%.

Se scegliete un’opzione diversa da Nessun mascherino traccia, After Effects converte il livello successivo sovrastante in mascherino traccia, disattiva il video del livello del mascherino traccia e aggiunge un’icona di mascherino traccia  accanto al nome del livello del mascherino traccia nel pannello Timeline.

Nota:

sebbene il video del livello del mascherino sia disattivato, è tuttavia possibile selezionare il livello per riposizionarlo, scalarlo o ruotarlo. Selezionate il livello nel pannello Timeline, quindi trascinate il centro (indicato da un cerchio con una X) del livello nel pannello Composizione.

Usare un mascherino traccia equivale a usare l’opzione Mantieni trasparenza sottostante, la quale fa sì che un livello derivi la sua trasparenza dalla trasparenza del composto dei livelli al di sotto di esso nell’ordine di sovrapposizione del livello. Consultate Mantenere la trasparenza sottostante durante la composizione.

Suggerimenti per lavorare con i mascherini traccia

  • Utilizzate l’effetto Livelli per aumentare il contrasto tra le parti chiare e scure del livello mascherino. Questo riduce il problema di avere numerosi valori intermedi, che comporta una trasparenza parziale. Di solito, i mascherini sono particolarmente utili quando definiscono le aree come interamente trasparenti o interamente opache, tranne che nei bordi.
  • Per utilizzare come mascherino un canale diverso dal canale alfa del livello mascherino, utilizzate uno degli effetti Canale (come l’effetto Scorrimento canali) per ruotare il valore del canale desiderato nel canale alfa.
  • Per animare un mascherino traccia da spostare con il livello al quale viene applicato il mascherino, rendere il mascherino traccia secondario rispetto al livello al quale viene applicato il mascherino. Consultate Livello superiore e inferiore.

Mantenere la trasparenza sottostante durante la composizione

L’opzione Mantieni trasparenza sottostante fa sì che un livello ottenga la propria trasparenza dalla trasparenza del composto dei livelli al di sotto di esso nell’ordine di sovrapposizione dei livelli. In altri termini, le aree opache del livello con questa opzione selezionata appaiono solo quando sono posizionate al di sopra delle aree opache nei livelli sottostanti. Questo comportamento è simile al comportamento di un mascherino traccia, con la differenza che un mascherino traccia può essere soltanto un livello singolo e un mascherino traccia deve trovarsi al di sopra del livello nell’ordine di sovrapposizione del livello. Consultate Mascherini traccia e mascherini mobili.

Questa opzione si rivela utile nella creazione di risultati quali riflessi luminosi provenienti da una superficie lucida.

Il comportamento di un livello con l’opzione Mantieni trasparenza sottostante selezionata è simile al comportamento di una maschera di ritaglio in Adobe Photoshop.

  • Selezionate l’opzione T nella colonna Modalità relativa al livello.

Aharon Rabinowitz fornisce una breve esercitazione video sull’opzione Mantieni trasparenza sottostante nel Sito Web Creative COW.

Nel suo sito Web, Tim Clapham spiega e mostra come utilizzare lo switch Mantieni trasparenza sottostante.

Risorse per Imagineer mocha shape for After Effects

After Effects include Imagineer Systems mocha for After Effects (mocha-AE), un’applicazione autonoma in grado di esportare i dati di tracciamento da usare nelle composizioni di After Effects. Consultate Risorse per mocha per After Effects (mocha-AE).

After Effects include anche il plug-in mocha shape for After Effects (mocha shape), per la conversione di tracciati da mocha-AE in mascherini di After Effects.

L’effetto mocha shape non può essere applicato direttamente a un livello. Piuttosto, copiate i dati del tracciato negli Appunti nell’applicazione mocha-AE, quindi incollatelo in un livello in After Effects. I tracciati da mocha-AE vengono convertiti in istanze dell’effetto mocha shape per creare un mascherino.

Nel sito Web di Imagineer sono disponibili varie esercitazioni video e altre risorse per imparare a usare mocha-AE e mocha shape con After Effects.

Nel sito Web ProVideo Coalition è disponibile un articolo di Chris e Trish Meyer con consigli su mocha-AE e mocha shape, compresi suggerimenti sulla sfumatura dei bordi con spessore variabile.

Questo prodotto è concesso in licenza in base alla licenza di Attribuzione-Non commerciale-Condividi allo stesso modo 3.0 Unported di Creative Commons.  I post su Twitter™ e Facebook non sono coperti dai termini di Creative Commons.

Note legali   |   Informativa sulla privacy online