Guida utente Annulla

Dynamic Link e After Effects

  1. Guida utente di After Effects
  2. Versioni beta
    1. Panoramica del programma beta
    2. After Effects Beta Home
    3. Funzioni in versione beta
      1. Pannello Proprietà (Beta)
      2. Importazione di modelli 3D (beta)
      3. Gestione del colore OpenColorIO e ACES (Beta)
  3. Guida introduttiva
    1. Introduzione ad After Effects
    2. Novità di After Effects 
    3. Note sulla versione | After Effects
    4. Requisiti di sistema di After Effects
    5. Scelte rapide da tastiera di After Effects
    6. Formati di file supportati | After Effects
    7. Consigli sull’hardware
    8. After Effects per Apple Silicon
    9. Pianificazione e impostazione
  4. Spazi di lavoro
    1. Elementi generali dell’interfaccia utente
    2. Interfaccia di After Effects
    3. Flussi di lavoro
    4. Spazi di lavoro, pannelli e visualizzatori
  5. Progetti e composizioni
    1. Progetti
    2. Nozioni di base sulla composizione
    3. Effettuare la precomposizione, la nidificazione e il pre-rendering
    4. Visualizzare informazioni dettagliate sulle prestazioni con Profilo composizione
    5. Modulo di rendering per composizioni CINEMA 4D
  6. Importazione del metraggio
    1. Preparazione e importazione di immagini fisse
    2. Importazione da After Effects e Adobe Premiere Pro
    3. Importazione e interpretazione di video e audio
    4. Preparazione e importazione di file di immagine 3D
    5. Importazione e interpretazione degli elementi di metraggio
    6. Operazioni con gli elementi di metraggio
    7. Rilevare i punti di modifica utilizzando Rilevamento modifiche scena
    8. Metadati XMP
  7. Testo e grafica
    1. Testo
      1. Formattazione dei caratteri e pannello Carattere
      2. Effetti Testo
      3. Creazione e modificazione di livelli testo
      4. Formattazione paragrafi e pannello Paragrafo
      5. Estrusione di livelli di testo e forma
      6. Animazione del testo
      7. Esempi e risorse per l’animazione del testo
      8. Modelli di testo dinamico
    2. Grafica animata
      1. Utilizzare modelli di grafica animata in After Effects
      2. Utilizzare le espressioni per creare elenchi a discesa nei modelli di grafica animata
      3. Utilizzare Proprietà essenziali per creare modelli di grafica animata
      4. Sostituire immagini e video in modelli di grafica animata e in Proprietà essenziali
  8. Disegni, colori e tracciati
    1. Panoramica su livelli forma, tracciati e grafica vettoriale
    2. Strumenti di disegno: Pennello, Timbro clona e Gomma
    3. Assottigliare i tratti forma
    4. Attributi forma, operazioni di disegno e operazioni con i tracciati per i livelli forma
    5. Usare l’effetto forma Sposta tracciati per modificare le forme
    6. Creazione delle forme
    7. Creare maschere
    8. Rimuovere oggetti dai video con Riempimento in base al contenuto
    9. Pennello a rotoscopio e Migliora mascherino
  9. Livelli, marcatori e fotocamera
    1. Selezione e disposizione di livelli
    2. Modalità di fusione e stili di livello
    3. Livelli 3D
    4. Proprietà dei livelli
    5. Creazione livelli
    6. Gestione livelli
    7. Marcatori livello e marcatori composizione
    8. Videocamere, luci e punti di interesse
  10. Animazione, fotogrammi chiave, tracciamento del movimento e tipo di trasparenza
    1. Animazione
      1. Fondamenti di animazione
      2. Animazione con gli strumenti Marionetta
      3. Gestione e animazione di tracciati forma e maschere
      4. Animazione di forme create con Sketch e Capture con After Effects
      5. Strumenti di animazione assortiti
      6. Utilizzare l’animazione basata sui dati
    2. Fotogramma chiave
      1. Interpolazione fotogrammi chiave
      2. Impostare, selezionare ed eliminare i fotogrammi chiave
      3. Modifica, spostamento e copia di fotogrammi chiave
    3. Tracciamento del movimento
      1. Tracciamento e stabilizzazione del movimento
      2. Tracciamento dei volti
      3. Tracciamento maschera
      4. Riferimento maschera
      5. Velocità
      6. Dilatazione e modifica del tempo
      7. Codice di tempo e unità per la visualizzazione del tempo
    4. Trasparenza
      1. Tipo di trasparenza
      2. Effetti Trasparenza
  11. Trasparenza e composizione
    1. Composizione e trasparenza: panoramica e risorse
    2. Canali alfa e maschere
    3. Mascherini traccia e mascherini mobili
  12. Regolazione del colore
    1. Concetti di base sul colore
    2. Gestione colore
    3. Effetti di correzione del colore
  13. Effetti e predefiniti di animazione
    1. Panoramica sugli effetti e sui predefiniti di animazione
    2. Elenco di effetti
    3. Effetti di simulazione
    4. Effetti di stilizzazione
    5. Effetti audio
    6. Effetti di distorsione
    7. Effetti di prospettiva
    8. Effetti canale
    9. Effetti di generazione
    10. Effetti di transizione
    11. Effetto di riparazione scansione lineare
    12. Effetti sfocatura e nitidezza
    13. Effetti canale 3D
    14. Effetti di utilità
    15. Effetti mascherino
    16. Effetti di disturbo e granulosità
    17. Effetto mantieni dettagli (ingrandimento)
    18. Effetti obsoleto
  14. Espressioni e automazione
    1. Espressione
      1. Concetti di base sull’espressione
      2. Informazioni sul linguaggio dell’espressione
      3. Utilizzo dei controlli di espressione
      4. Differenze di sintassi tra i motori di espressione JavaScript e Legacy ExtendScript
      5. Modifica di espressioni
      6. Errori nelle espressioni
      7. Utilizzo dell’editor espressioni
      8. Utilizzo delle espressioni per modificare e accedere alle proprietà di testo
      9. Riferimenti del linguaggio delle espressioni
      10. Esempi di espressione
    2. Automazione
      1. Automazione
      2. Script
  15. Video immersivo, VR e 3D
    1. Creare ambienti VR in After Effects
    2. Applicare effetti video immersivi
    3. Strumenti di composizione per i video VR/360
    4. Tracciamento del movimento della videocamera 3D
    5. Lavorare in Design Space 3D
    6. Gizmo Trasformazione 3D
    7. Ulteriori informazioni sull’animazione 3D
    8. Anteprima delle modifiche apportate ai progetti 3D con il sistema Mercury 3D
    9. Aggiungere grafica reattiva agli elementi grafici 
  16. Visualizzazioni e anteprime
    1. Visualizzazione in anteprima
    2. Anteprima video con Mercury Transmit
    3. Modifica e utilizzo di visualizzazioni
  17. Rendering ed esportazione
    1. Nozioni di base su rendering ed esportazione
    2. Codifica H.264 in After Effects
    3. Esportare un progetto After Effects come progetto Adobe Premiere Pro
    4. Convertire filmati
    5. Rendering di più fotogrammi
    6. Rendering automatico e rendering di rete
    7. Rendering ed esportazione di immagini fisse e sequenze di immagini fisse
    8. Utilizzo del codec GoPro CineForm in After Effects
  18. Lavorare con altre applicazioni
    1. Dynamic Link e After Effects
    2. Utilizzo di After Effects con altre applicazioni
    3. Impostazioni sincronizzazione in After Effects
    4. Creative Cloud Libraries in After Effects
    5. Plug-in
    6. Cinema 4D e Cineware
  19. Collaborazione: Frame.io e Progetti team
    1. Collaborazione in Premiere Pro e After Effects
    2. Frame.io
      1. Installare e attivare Frame.io
      2. Utilizzare Frame.io con Premiere Pro e After Effects
      3. Domande frequenti
    3. Progetti team
      1. Introduzione ai Progetti team
      2. Creare un progetto team
      3. Collaborare con Progetti team
  20. Memoria, archiviazione, prestazioni
    1. Memoria e archiviazione
    2. Come After Effects gestisce i problemi di memoria insufficiente durante la visualizzazione dell’anteprima    
    3. Migliorare le prestazioni
    4. Preferenze
    5. Requisiti di GPU e driver GPU per After Effects

Dynamic Link

In precedenza, la condivisione di risorse multimediali tra applicazioni di post-produzione richiedeva in genere l’esecuzione del rendering e l’esportazione del materiale da un’applicazione prima di consentirne l’importazione in un’altra. Tale flusso di lavoro era poco efficiente e particolarmente lungo. Per apportare modificare alla risorsa originale, era necessario eseguire nuovamente il rendering e l’esportazione della risorsa. Inoltre, più versioni di una risorsa sottoposta a rendering ed esportata occupano molto spazio su disco e possono essere di difficile gestione.

Dynamic Link offre un’alternativa a questo flusso di lavoro, Potete creare collegamenti dinamici tra After Effects e Adobe Premiere Pro. La semplicità della creazione di un collegamento dinamico è paragonabile all’importazione di qualsiasi tipo di risorsa. Le risorse collegate dinamicamente sono contrassegnate da icone e colori di etichetta specifici che ne facilitano l’identificazione. I collegamenti dinamici vengono salvati in progetti generati da tali applicazioni.

Creare e collegare composizioni After Effects con Dynamic Link

Potete creare nuove composizioni di After Effects e creare collegamenti dinamici alle stesse da Adobe Premiere Pro. Potete anche creare collegamenti dinamici a composizioni di After Effects esistenti da Adobe Premiere Pro.

Creare una composizione da clip in Adobe Premiere Pro

Potete sostituire le clip selezionate in Adobe Premiere Pro con composizioni di After Effects collegate dinamicamente basate su tali clip. La nuova composizione eredita le impostazioni di sequenza da Adobe Premiere Pro.

  1. Aprite Premiere Pro e selezionate le clip da sostituire.

  2. Fate clic con il pulsante destro del mouse su una delle clip selezionate.
  3. Seleziona Sostituisci con composizione After Effects.

    Viene aperto After Effects (se non è già aperto) e viene creata una nuova composizione collegata.

Creare una composizione collegata dinamicamente da Adobe Premiere Pro

La creazione di una nuova composizione collegata dinamicamente da Adobe Premiere Pro avvia After Effects. In After Effects viene quindi creato un progetto e una composizione con le dimensioni, le proporzioni pixel, la frequenza fotogrammi e la frequenza di campionamento audio del progetto di origine (se After Effects è già in esecuzione, viene creata una composizione nel progetto corrente). Il nome della nuova composizione è basato sul nome del progetto di Adobe Premiere Pro seguito da Composizione collegata [x].

  1. In Adobe Premiere Pro, scegliete File > Adobe Dynamic Link > Nuova composizione After Effects. Nella versione 2014 di Premiere Pro, potete importare composizioni mediante Browser multimediale. Per ulteriori informazioni, consultate le sezioni seguenti di Premiere Pro:

  2. Se viene visualizzata la finestra di dialogo Salva con nome di After Effects, immettete un nome e un percorso per il progetto di After Effects e fate clic su Salva.

    Nota:

    Quando create una composizione di After Effects collegata dinamicamente, la durata della composizione è impostata su 30 secondi. Per modificare la durata, selezionate la composizione in After Effects e scegliete Composizione > Impostazioni composizione. Fare clic sulla scheda Base e specificare un nuovo valore per Durata.

Per ottenere risultati migliori, fare corrispondere le impostazioni di composizione (come le dimensioni, le proporzioni pixel, la frequenza fotogrammi) a quelle usate nel progetto Adobe Premiere Pro.

  1. Effettua una delle seguenti operazioni:
    • In Adobe Premiere Pro, scegli File > Adobe Dynamic Link > Importa composizione After Effects. Scegli un file di progetto di After Effects (.aep), quindi seleziona una o più composizioni.

    • In Adobe Premiere Pro, scegli un file di progetto After Effects e fai clic su Apri. Seleziona quindi una composizione nella finestra di dialogo visualizzata e fa clic su OK.

    • Trascinare una o più composizioni dal pannello Progetto di After Effects al pannello Progetto di Adobe Premiere Pro.

    • Trascinare un file di progetto di After Effects nel pannello Progetto di Premiere Pro. Se il file di progetto di After Effects contiene più composizioni, si apre la finestra di dialogo Importa composizione.

Nota:

Puoi collegarti più volte a una singola composizione di After Effects in uno specifico progetto di Adobe Premiere Pro.

Modificare una composizione collegata dinamicamente in After Effects

Usa il comando Modifica originale di Adobe Premiere Pro per modificare una composizione di After Effects collegata. Dopo l’apertura della composizione in After Effects, puoi apportare modifiche alla composizione senza dovere usare nuovamente il comando Modifica originale.

  1. Selezionare la composizione di After Effects in Adobe Premiere Pro oppure scegliere una clip collegata nella timeline e selezionare Modifica > Modifica originale.

  2. Modificare la composizione in After Effects. Quindi, passare ad Adobe Premiere Pro per visualizzare le modifiche.

Le modifiche apportate in After Effects appaiono in Adobe Premiere Pro. Adobe Premiere Pro smette di utilizzare eventuali file di anteprima di cui è stato eseguito il rendering per la clip prima delle modifiche.

Nota:

Puoi modificare il nome della composizione in After Effects dopo aver creato un collegamento dinamico alla stessa da Adobe Premiere Pro. Adobe Premiere Pro non aggiorna il nome della composizione collegata nel pannello Progetto, ma conserva comunque il collegamento dinamico.

Eliminare una composizione o una clip collegata dinamicamente

Puoi eliminare una composizione collegata da un progetto di Adobe Premiere Pro in qualsiasi momento, anche se la composizione è in uso nel progetto.

In qualsiasi momento puoi eliminare le clip collegate dalla timeline di una sequenza o timeline di Adobe Premiere Pro.

  1. In Adobe Premiere Pro, seleziona la composizione o la clip collegata e premi il tasto Canc.

Creare una sequenza collegata in Adobe Premiere Pro con Dynamic Link

La creazione di una sequenza di Adobe Premiere Pro da After Effects avvia Adobe Premiere Pro. In Adobe Premiere Pro vengono quindi creati un progetto e una sequenza con le dimensioni, le proporzioni pixel, la frequenza fotogrammi e la frequenza di campionamento audio del progetto di origine (se Adobe Premiere Pro è già in esecuzione, viene creata una sequenza nel progetto corrente).

  1. In After Effects, scegliere File > Adobe Dynamic Link > Nuova sequenza Premiere Pro.

Per ottenere risultati migliori, fate corrispondere le impostazioni di sequenza e le impostazioni di progetto in Adobe Premiere Pro (ad esempio, dimensioni, proporzioni pixel, frequenza fotogrammi) a quelle nel progetto After Effects.

Effettua una delle seguenti operazioni:

  • In After Effects, scegliete File > Adobe Dynamic Link > Importa sequenza Premiere Pro. Scegliere un progetto di Adobe Premiere Pro, quindi selezionare una o più sequenze.

  • Trascinare una o più sequenze dal pannello Progetto di Adobe Premiere Pro al pannello Progetto di After Effects.

Prestazioni Dynamic Link

Una clip collegata può fare riferimento a una composizione sorgente complessa. Le azioni eseguite sulla composizione sorgente richiedono tempi di elaborazione maggiori a seconda della complessità. After Effects applica le azioni e rende i dati finali disponibili per Adobe Premiere Pro mediante le funzioni di cache per prestazioni globali e cache del disco persistente. Queste funzioni consentono di migliorare le prestazioni di After Effects utilizzando i fotogrammi memorizzati nella cache quando Premiere Pro richiede i fotogrammi.

Per ridurre i ritardi di riproduzione, effettuare una delle seguenti operazioni:

  • Portare offline la composizione collegata

  • Disattivare una clip collegata per interrompere temporaneamente il riferimento a una composizione

  • Sostituisci la composizione collegata dinamicamente con il file renderizzato utilizzando la funzione Esegui rendering e sostituisci di Premiere Pro (Clip > Esegui rendering e sostituisci).

Se solitamente lavorate con composizioni sorgente complesse, provate ad aumentare la RAM o a dotare il sistema di un processore più potente.

Esportare in Adobe Media Encoder

Per codificare le composizioni After Effects, aggiungerle alla coda di codifica in Adobe Media Encoder, quindi selezionare i predefiniti di codifica o creare le impostazioni di codifica personalizzate. In After Effects, puoi aggiungere una composizione alla coda di Media Encoder utilizzando una delle seguenti opzioni:

  • File > Esporta > Aggiungi alla coda di Media Encoder
  • Composizione > Aggiungi alla coda di Media Encoder

Quando aggiungerai una composizione o un progetto alla coda di Adobe Media Encoder, After Effects avvia Adobe Media Encoder con le composizioni elencate nella coda.

Il processo di codifica è descritto nei seguenti articoli:

Logo Adobe

Accedi al tuo account