Leggi questo documento per saperne di più sui tipi di progetto in After Effects

I progetti

Un progetto di After Effects è costituito da un singolo file contenente composizioni e riferimenti a tutti i file sorgente utilizzati dagli elementi di metraggio nel progetto. Le composizioni sono raccolte di livelli. Molti livelli utilizzano elementi di metraggio (come filmati o immagini fisse) come sorgente, benché taluni, come i livelli forma e testo, contengano grafica che può essere creata all’interno di After Effects.

Un file di progetto ha un'estensione del tipo .aep o .aepx. Un file di progetto con estensione .aep è un file di progetto binario. Un file di progetto con estensione .aepx è un file di progetto XML basato su testo.

Il nome del progetto corrente viene visualizzato nella parte superiore della finestra dell’applicazione.

Un file di progetto modello ha un'estensione .aet. Consultate Modelli ed esempi di progetti.

File di progetto XML

I file di progetto XML basati su testo contengono alcune informazioni relative al progetto, come ad esempio i dati binari con codifica esadecimale, ma gran parte delle informazioni di un progetto è presentata sotto forma di testo leggibile esposto in elementi string. Potete aprire un file di progetto XML in un editor di testo e apportare modifiche ad alcuni dettagli senza aprire il progetto in After Effects. Potete anche scrivere degli script che modificano le informazioni sul progetto nei file di progetto XML nell’ambito di un flusso di lavoro automatizzato.

Gli elementi di un progetto che possono essere modificati in un file di progetto XML:

  • Attributi dei marcatori, compresi i commenti, parametri dei marcatori capitoli e dei punti cue

  • Percorsi degli elementi del metraggio sorgente, compresi i proxy

  • Nomi di composizioni, elementi di metraggio, livelli, cartelle e commenti

Nota:

I nomi degli elementi di metraggio sono esposti negli elementi string nei file di progetto XML solo se i nomi sono stati personalizzati. I nomi degli elementi di metraggio derivati automaticamente dai nomi dei file sorgente e i nomi dei colori pieni non sono esposti negli elementi string

Alcune stringhe, come ad esempio i nomi degli spazi di lavoro e delle visualizzazioni, sono leggibili, ma le modifiche apportate a tali stringhe non vengono rispettate quando After Effects apre il file di progetto.

Nota:

Non utilizzate il formato file di progetto XML come formato file principale. Il formato file di progetto principale per After Effects è il formato file di progetto binario (.aep). Usate il formato file di progetto XML per salvare una copia di un progetto e come formato intermedio per i flussi di lavoro di automazione.

Nota:

Per salvare un file di progetto XML (.aepx) come file di progetto binario (.aep), scegliete File > Salva con nome e immettete un nome di file con estensione .aep, senza la x. Consultate Salvare ed eseguire il backup dei progetti in After Effects.

Collegamenti al progetto incorporati nei file QuickTime, video per i file Windows

quando eseguite il rendering di un filmato e lo esportate in un formato contenitore, potete incorporare un collegamento al progetto After Effects nel file contenitore.

Per importare il progetto, importate il file contenitore e scegliete Progetto dal menu Importa come nella finestra di dialogo Importa file. Se il file contenitore contiene un collegamento a un progetto che è stato spostato, potete cercare e individuare il progetto.

Creare e aprire progetti

Potete aprire soltanto un progetto per volta. Se create o aprite un altro file di progetto mentre è già aperto un progetto, After Effects chiede di salvare le modifiche nel progetto aperto, dopodiché lo chiude. Dopo la creazione, potete importare il metraggio nel progetto.

  • Per creare un nuovo progetto, scegliete File > Nuovo > Nuovo progetto.

  • Per aprire un progetto, scegliete File > Apri progetto, individuate il progetto e fate clic su Apri.

Potete anche creare e aprire un progetto dalla schermata iniziale.

  • Per creare un progetto, fate clic su Nuovo progetto.
  • Per aprire un progetto, fate clic su Apri progetto e individuate il percorso del progetto.

Jeff Almasol, nel suo sito Web redefinery, mette a disposizione uno script che crea e salva un nuovo progetto per ciascuna composizione selezionata nel progetto corrente.

Modelli ed esempi di progetti

Un modello di progetto è un file con estensione .aet. Potete creare nuovi modelli basati su progetti esistenti.

Nota:

After Effects CC non installa alcun modello di progetto.

Quando aprite un modello di progetto, After Effects crea un nuovo progetto senza titolo sulla base del modello. Il salvataggio delle modifiche in questo nuovo progetto non influenza il modello di progetto.

Nota:

Per comprendere appieno il modo in cui gli utenti più esperti possono utilizzare After Effects, aprite uno dei modelli di progetto inclusi in After Effects, aprite una composizione per attivarlo e premete U o UU per mostrare unicamente le proprietà animate o del livello. Visualizzando le proprietà animate e modificate potete visualizzare le modifiche eseguite dall’autore del modello di progetto per creare il modello.

Spesso, chi crea un modello di progetto ne blocca i livelli che dovrebbero rimanere immutati, mentre lascia sbloccati quelli che possono essere modificati. Si tratta di un modo pratico per impedire modifiche accidentali o inadeguate.

Per altri fonti di esempi di progetti e modelli di progetti After Effects, consultate le risorse della comunità di After Effects nel sito Web di Adobe.

Guardate questa esercitazione video di Andrew Devis disponibile nel sito Web Creative Cow per informazioni su dove trovare i progetti modello ed esempi di espressioni forniti con After Effects.

Aprire un modello di progetto

  • Per aprire un modello di progetto esistente, scegliete File > Apri progetto. In Windows, scegliete Modello di progetto di Adobe After Effects dal menu Tipo file.

Creare un modello di progetto

  • Per convertire un progetto in un modello di progetto, cambiate l’estensione del nome file da .aep in .aet.
  • Per salvare una copia di un progetto come modello di progetto, scegliete File > Salva una copia, quindi rinominate la copia con l’estensione .aet.

Impostare un modello per i nuovi progetti

Potete creare un modello con le impostazioni di progetto preferite, quali gestione del colore e struttura delle cartelle, e usarlo come base per ogni nuovo progetto.

Per impostare un modello per i nuovi progetti After Effects:

  1. Scegliete Modifica > Preferenze > Nuovo progetto.
  2. Selezionate la casella di controllo Modello di caricamento nuovo progetto.
  3. Fate clic su Scegli modello di progetto e selezionate un file di modello.

Nota:

Il modello può essere in formato .aet, .aep o .aex.

Progetti team

Progetti team è un servizio di collaborazione in hosting per gli utenti di CC for enterprise e CC for teams, che consente agli editor di collaborare senza ostacoli e in tempo reale al flusso di lavoro dell’editing. Con Progetti team, gli editor e i professionisti dell’animazione grafica possono lavorare contemporaneamente a progetti team condivisi in Adobe Premiere Pro CC, After Effects CC e Adobe Prelude CC, senza dover ricorrere ad hardware aggiuntivo.

Gli aggiornamenti del progetto sono gestiti in modo sicuro nel cloud e i file sorgente vengono salvati in locale o come proxy leggeri e condivisi. Il servizio Progetti team offre inoltre potenti funzioni di collaborazione, come la cronologia delle versioni e la risoluzione avanzata di conflitti.

  • Per creare un progetto team, scegliete File > Nuovo > Nuovo progetto team.
  • Per aprire un progetto team, scegliete File > Apri progetto team.

Per informazioni dettagliate su come utilizzare i progetti team in un flusso di lavoro di collaborazione, consultate Lavorare contemporaneamente su progetti video condivisi.

Convertire un progetto team in progetto di Adobe After Effects

Un progetto team può essere convertito in un normale progetto locale di Adobe After Effects (.aep). Selezionate Modifica > Progetti team > Converti progetto team in progetto.

Conversione di un progetto team in progetto di Adobe After Effects
Conversione di un progetto team in progetto di Adobe After Effects

Salvare ed eseguire il backup dei progetti in After Effects

  • Per salvare un progetto, scegliete File > Salva.
  • Per salvare una copia del progetto con un nuovo nome generato automaticamente, scegliete File > Incrementa e salva o premete Ctrl+Alt+Maiusc+S (Windows) o Comando+Opzione+Maiusc+S (Mac OS).
  • Una copia del progetto corrente viene salvata nella stessa cartella del progetto originale. Il nome della copia è il nome dell’originale seguito da un numero. Se il nome dell’originale termina con un numero, tale numero verrà aumentato di 1.
  • Per salvare il progetto con un nome diverso o in un percorso diverso, scegliete File > Salva con nome > Salva con nome. Il progetto aperto assume il nuovo nome e la nuova posizione, mentre il nome e la posizione del file originale rimangono invariati.
  • Per salvare una copia del progetto nel formato file di progetto XML, scegliete File > Salva con nome > Salva una copia come XML. Consultate I progetti.
  • Per salvare una copia del progetto con un nome diverso o in un percorso diverso, scegliete File > Salva con nome > Salva una copia. Il progetto aperto mantiene il nome e la posizione originali, viene creata una copia con le nuove impostazioni ma non viene aperta.
  • Per salvare una copia di un progetto in modo che possa essere aperta nella versione principale precedente, scegliete File > Salva con nome > Salva una copia come <versione principale precedente>. Per ulteriori informazioni, visitate questo blog.

Nota:

Le nuove funzioni della versione esistente di After Effects usate in un progetto verranno ignorate nel progetto che viene salvato in un formato delle versioni precedenti di After Effects.

Per salvare una copia del progetto e le copie delle risorse utilizzate nel progetto in una singola cartella su disco, utilizzate il comando Raccogli file. Consultate Raccogliere i file in una posizione.

Pannello Diagramma di flusso

Nel diagramma di flusso di ciascun progetto o composizione, le singole caselle (o porzioni) rappresentano ogni composizione, elemento di metraggio e livello. Le frecce direzionali rappresentano le relazioni tra i componenti.

Nota:

Il pannello Diagramma di flusso mostra soltanto le relazioni esistenti. Non potete usarlo per modificare le relazioni tra gli elementi.

Le composizioni nidificate e gli altri elementi che costituiscono la composizione appaiono quando espandete una porzione della composizione.

Le linee mediane grigie tra le porzioni del diagramma di flusso indicano che lo switch Video o Audio di tali elementi è disattivato nel pannello Timeline. Le linee nere o grigie indicano che lo switch è selezionato, a seconda dell’impostazione Luminosità nelle preferenze di Aspetto.

  • Per aprire il diagramma di flusso del progetto, premete Ctrl+F11 (Windows) o Comando+F11 (Mac OS), oppure fate clic sul pulsante Diagramma di flusso progetto nella parte superiore della barra di scorrimento verticale sul bordo destro del pannello Progetto.
  • Per aprire il diagramma di flusso di una composizione, selezionate la composizione e scegliete Composizione > Diagramma di flusso composizione, oppure fate clic sul pulsante Diagramma di flusso  composizione in fondo al pannello Composizione.
  • Per attivare (selezionare) un elemento, fate clic sulla relativa porzione nella pannello Diagramma di flusso.

    Quando fate clic su una composizione nel diagramma di flusso, essa diventa attiva nei pannelli Progetto e Timeline. Quando fate clic su un livello, esso diventa attivo nel pannello Timeline. Quando fate clic su un elemento di metraggio, esso diventa attivo nel pannello Progetto.

  • Per personalizzare l’aspetto del diagramma di flusso, usate il menu e i pulsanti del pannello Diagramma di flusso nella parte inferiore del pannello stesso.

Nota:

Per visualizzare le descrizioni comandi che identificano i pulsanti nel pannello Diagramma di flusso, posizionate il puntatore sopra un pulsante in modo da visualizzarne la descrizione.

  • Per eliminare gli elementi, selezionateli e premete Canc. Se l’elemento selezionato è un elemento di metraggio o una composizione, viene eliminato dal progetto e non appare più nei pannelli Timeline e Progetto. Se l’elemento selezionato è un livello, viene eliminato dalla composizione in cui appare.
  • Per accedere al menu di scelta rapida di un elemento selezionato, fate clic con il pulsante destro del mouse (Windows) o tenendo premuto il tasto Control (Mac OS) sull’icona a sinistra del nome nella porzione dell’elemento. Le icone hanno aspetti diversi, a seconda del tipo di elemento, ad esempio livelli  e composizioni . Ad esempio, potete accedere al menu di scelta rapida di un livello per utilizzare maschere ed effetti o per cambiare switch, applicare trasformazioni e regolare la qualità dell’immagine del livello.

Nota:

Se modificate le proprietà degli elementi nel pannello Diagramma di flusso, assicuratevi di fare clic sull’icona della porzione e non sul nome dell’elemento per far apparire il menu di scelta rapida. Il menu di scelta rapida associato all’icona dell’elemento è diverso da quello che viene aperto dal nome dell’elemento.

Nel sito Web After Effects Portal Rich Young offre ulteriori informazioni sul pannello Diagramma di flusso e sul Mini diagramma di flusso composizione.

Questo prodotto è concesso in licenza in base alla licenza di Attribuzione-Non commerciale-Condividi allo stesso modo 3.0 Unported di Creative Commons.  I post su Twitter™ e Facebook non sono coperti dai termini di Creative Commons.

Note legali   |   Informativa sulla privacy online