Selezionare i livelli

I livelli selezionati che presentano anche proprietà selezionate vengono indicati con una evidenziazione vuota nel pannello Timeline. Un livello selezionato che non presenta proprietà viene indicato con una evidenziazione piena.

Livello superiore selezionato, ma senza proprietà selezionate; livello inferiore selezionato con proprietà selezionate
Livello superiore selezionato, ma senza proprietà selezionate; livello inferiore selezionato con proprietà selezionate.

Nota:

Per scorrere il livello selezionato più in alto fino alla parte superiore del pannello Timeline, premete X.

  • Per selezionare un livello, fate clic su di esso nel pannello Composizione, fate clic sul suono nome o sulla barra di durata nel pannello Timeline, oppure fate clic sul suo nome nel pannello Diagramma di flusso.
  • Per selezionare un livello oscurato nel pannello Composizione, fate clic con il pulsante destro del mouse (Windows) o tenendo premuto il tasto Control (Mac OS) su un livello e scegliete Seleziona > [nome livello].
  • Per selezionare un livello se questo appare aperto nel relativo pannello, scegliete il nome del livello nel menu Finestra o nel menu del visualizzatore del pannello Livello.
  • Per selezionare un livello in base al numero di posizione, digitate il numero desiderato sul tastierino numerico. Se il numero del livello è composto da più cifre, digitate i numeri rapidamente in modo che After Effects li riconosca come un unico numero.
  • Per selezionare il livello successivo nell’ordine di sovrapposizione, premete Ctrl+Freccia giù (Windows) o Comando+Freccia giù (Mac OS). Per selezionare il livello precedente, premete Ctrl+Freccia su (Windows) o Comando+Freccia su (Mac OS).
  • Per estendere la selezione al livello successivo nell’ordine di sovrapposizione, premete Ctrl+Maiusc+Freccia giù (Windows) o Comando+Maiusc+Freccia giù (Mac OS). Per estendere la selezione al livello precedente nell’ordine di sovrapposizione, premete Ctrl+Maiusc+Freccia su (Windows) o Comando+Maiusc+Freccia su (Mac OS).
  • Per selezionare tutti i livelli, scegliete Modifica > Seleziona tutto mentre è attivo il pannello Timeline o Composizione. Per deselezionare tutti i livelli, scegliete Modifica > Deseleziona tutto. Se lo switch Nascondi livelli inattivi della composizione è selezionato, usando Seleziona tutto quando il pannello Timeline è attivo, i livelli inattivi non vengono selezionati. (Consultate Mostrare e nascondere i livelli nel pannello Timeline.)
  • Per deselezionare i livelli correntemente selezionati e selezionare tutti gli altri livelli: con almeno un livello selezionato, scegliete Inverti selezione dal menu di scelta rapida nel pannello Composizione o Timeline.
  • Per selezionare tutti i livelli che usano la stessa etichetta di colore, fate clic sull’etichetta di colore nel pannello Timeline e scegliete Seleziona gruppo etichetta, oppure selezionate un livello con tale etichetta di colore e scegliete Modifica > Etichetta > Seleziona gruppo etichetta.
  • Per selezionare tutti i livelli inferiori assegnati a un livello superiore, selezionate il livello superiore e scegliete Seleziona inferiore dal menu di scelta rapida nel pannello Composizione o Timeline. I livelli inferiori vengono aggiunti alla selezione esistente.
  • Potete selezionare più livelli nel pannello Composizione . Trascinate con lo strumento Selezione per creare un rettangolo di selezione attorno ai livelli desiderati. Tenete premuto Maiusc mentre fate clic o trascinate per aggiungere o togliere dei livelli dalla selezione.

Nel sito Web After Effects Scripts di Lloyd Alvarez potete trovare uno script che consente di associare tag ai livelli e quindi di selezionare, nascondere o isolare i livelli in base ai rispettivi tag. I tag vengono aggiunti ai commenti nel campo Commenti del pannello Timeline.

Modificare l’ordine di sovrapposizione per i livelli selezionati

La disposizione verticale dei livelli nel pannello Timeline è l’ordine di sovrapposizione dei livelli, che è direttamente correlato all’ordine di rendering. Potete modificare l’ordine in cui i livelli vengono composti gli uni rispetto agli altri modificando l’ordine di sovrapposizione dei livelli.

Nota:

a causa delle proprietà di profondità, l’ordine di sovrapposizione dei livelli 3D nel pannello Timeline non indica necessariamente la rispettiva posizione spaziale nella composizione.  

  • Nel pannello Timeline, trascinate i nomi dei livelli in una nuova posizione nell’ordine di sovrapposizione.
  • Per spostare in alto di un livello i livelli selezionati nell’ordine di sovrapposizione, premete Ctrl+Alt+Freccia su (Windows) o Comando+Opzione+Freccia su (Mac OS); per spostare in basso di un livello i livelli selezionati, premete Ctrl+Alt+Freccia Giù (Windows) o Comando+Opzione+Freccia giù (Mac OS).
  • Per spostare i livelli selezionati in cima all’ordine di sovrapposizione dei livelli, premete Ctrl+Alt+Maiusc+Freccia su (Windows) o Comando+Opzione+Maiusc+Freccia su (Mac OS); per spostare in fondo i livelli selezionati, premete Ctrl+Alt+Maiusc+Freccia Giù (Windows) o Comando+Opzione+Maiusc+Freccia giù (Mac OS).
  • Scegliete Livello > Ordina, quindi Porta avanti livello, Porta indietro livello, Porta livello in primo piano o Porta livello in secondo piano.

Nota:

Quando copiate (o tagliate) e incollate i livelli, essi vengono incollati in modo tale da apparire dall’alto verso il basso nel pannello Timeline, nello stesso ordine in cui erano stati selezionati prima dell’operazione di copia (o taglio). Potete tenere premuto Ctrl (Windows) o Comando (Mac OS) e fare clic per selezionarli in qualsiasi ordine arbitrario, tagliarli, quindi incollarli immediatamente per riordinare i livelli nell’ordine in cui erano stati selezionati.

Jeff Almasol, nel suo sito Web redefinery, mette a disposizione uno script con il quale potete modificare l’ordine di sovrapposizione dei livelli in una composizione, ordinandoli in base al punto di attacco, al punto di stacco, all’ordine di selezione, al nome del livello o casualmente.

Sistemi di coordinate: spazio della composizione e spazio del livello

Il sistema di coordinate per ciascun livello è lo spazio del livello. Il sistema di coordinate per ciascuna composizione è lo spazio di composizione. I valori delle proprietà per gli elementi presenti all’interno di un livello (come i punti di controllo e di ancoraggio dell’effetto) sono presenti nello spazio livello e vengono misurati dall’origine nello spazio del livello di quel livello. Tuttavia, la proprietà Posizione di un livello descrive la posizione del livello all’interno di una composizione e pertanto viene misurata nello spazio di composizione della composizione.

Mentre spostate il puntatore sul fotogramma del livello nel pannello Livello, il pannello Info visualizza le coordinate del pixel sotto il puntatore nello spazio del livello. La coordinata X rappresenta la posizione sull’asse orizzontale e la coordinata Y rappresenta la posizione sull’asse verticale. I valori di queste coordinate sono espressi in pixel. Le coordinate X e Y sono relative all’origine (0,0), che è fissata nell’angolo superiore sinistro del livello.

Potete modificare il punto zero dei righelli, ma non l’origine dello spazio del livello. Se il punto zero differisce dall’origine, le coordinate X’ e Y’ vengono visualizzate nel pannello Info al di sotto delle coordinate X e Y, a indicare le coordinate in base al punto zero dei righelli.

Quando spostate il puntatore sul fotogramma della composizione nel pannello Composizione, nel pannello Info vengono visualizzate le coordinate nello spazio di composizione. Trascinando un livello, la porzione inferiore del pannello Info visualizza le coordinate del punto di ancoraggio del livello.

Spostare i livelli nello spazio

Quando spostate un livello nello spazio, ne modificate la proprietà Posizione.

Potete separare i componenti di una proprietà Posizione in singole proprietà (Posizione X, Posizione Y e (per i livelli 3D) Posizione Z) in modo da poter modificare o animare ciascuno di essi in modo indipendente. (Consultate Dimensioni separate della posizione per animare i componenti individualmente.)

Jeff Almasol, nel suo sito Web redefinery, mette a disposizione uno script che inserisce un nuovo livello nullo nella linea tra i punti di ancoraggio di due livelli selezionati. Per riposizionare il livello nullo lungo questa linea è previsto l’uso di un controllo cursore sul livello nullo stesso.

Nota:

Per spostare i livelli selezionati in modo che i relativi punti di ancoraggio si trovino al centro della finestra corrente, scegliete Livello > Trasformazione > Centra nella finestra, oppure premete Ctrl+Inizio (Windows) o Comando+Inizio (Mac OS).

Nota:

Per spostare un livello in modo tale che il suo punto di ancoraggio si trovi al centro della composizione, fate clic con il pulsante destro del mouse (Windows) o tenendo premuto il tasto Control (Mac OS) sulla proprietà Posizione, scegliete Modifica valore, scegliete % della composizione nel menu Unità e immettete 50 per ciascuno dei componenti della proprietà Posizione.

Per evitare di sfumare un’immagine che non è in movimento, assicuratevi che i valori Posizione di un livello siano valori non frazionari. Questo evita il ricampionamento utilizzato quando un livello con qualità di immagine impostata su Alta viene inserito sui subpixel.

Spostare i livelli trascinandoli nel pannello Composizione

Nota:

Per agganciare i bordi del livello alle griglie o alle guide mentre eseguite il trascinamento, scegliete Visualizza > Griglia calamitata oppure Visualizza > Guide calamitate.

  • Selezionate uno o più livelli, quindi trascinate un livello selezionato tramite lo strumento Selezione .

    Quando spostate un livello trascinandolo nel pannello Composizione, il pannello Info mostra la modifica nella proprietà Posizione mano a mano che eseguite il trascinamento.

Spostare i livelli modificando direttamente la proprietà Posizione

  1. Selezionate uno o più livelli.
  2. Premete P per mostrare la proprietà Posizione nel pannello Timeline.
  3. Modificate la proprietà Posizione nel pannello Timeline.

Spostare i livelli con i tasti freccia

  1. Selezionate uno o più livelli.
  2. Per spostare i livelli selezionati di un pixel a sinistra, a destra, in alto o in basso, premete un tasto freccia. Per spostarlo di 10 pixel, tenete premuto Maiusc mentre premete il tasto freccia.

    Nota:

    Con i tasti freccia è possibile spostare il livello di un pixel all’ingrandimento corrente. Per spostare un livello con maggior precisione con i tasti freccia, effettuate uno zoom in nel pannello Composizione. (Consultate Zoom in un’immagine per l’anteprima.)

Dimensioni separate della posizione per animare i componenti individualmente

Per impostazione predefinita, ciascuna proprietà Posizione dispone di due o tre componenti, ciascuno dei quali ha il valore relativo a una delle dimensioni spaziali (assi). Potete separare i componenti di una proprietà Posizione in singole proprietà (Posizione X, Posizione Y e, per i livelli 3D, Posizione Z). Separando le dimensioni è possibile modificare o animare la posizione di un livello lungo l’asse x, l’asse y e l’asse z in modo indipendente.

Per scomporre le proprietà Posizione selezionate in singole proprietà Posizione X, Posizione Y e (per i livelli 3D) Posizione Z, effettuate una delle seguenti operazioni:

  • Scegliete Animazione > Dimensioni separate.
  • Fate clic con il pulsante destro del mouse (Windows) o tenendo premuto il tasto Control (Mac OS) su una proprietà Posizione e scegliete Dimensioni separate dal menu di scelta rapida.
  • Fate clic sul pulsante Dimensioni separate nella parte inferiore dell’Editor grafico.

Per ricomporre un insieme di proprietà Posizione singole in una proprietà Posizione singola con più componenti, usate gli stessi comandi utilizzati per dimensioni separate.  

Nota:

quando ricomponete le proprietà Posizione separate in un’unica proprietà Posizione, alcune informazioni sul tracciato animato e sulla velocità vanno perdute, in quanto le curve Bezier multiple utilizzate per rappresentare i singoli componenti vengono ridotte in un’unica curva Bezier in ciascun fotogramma chiave. Quando separate le dimensioni, alcune informazioni sulla velocità vanno perdute, ma il tracciato animato non cambia. È opportuno lavorare con dimensioni separate o senza dimensioni separate per ciascuna proprietà di un intero progetto, invece che cambiare in continuazione.

La decisione se lavorare o meno con dimensioni separate dipende dall’operazione che state tentando di eseguire. L’utilizzo di una proprietà per la posizione ha il vantaggio di fornire più facilmente un movimento uniforme. Inoltre, l’utilizzo di una singola proprietà per la posizione consente di utilizzare fotogrammi chiave vaganti, i quali forniscono una velocità uniforme. Lavorare con dimensioni separate per la posizione va a discapito dell’uniformità automatica, al fine di guadagnare un maggiore controllo sull’animazione spaziale. Inoltre, lavorare con dimensioni separate semplifica alcune simulazioni, specialmente nei casi in cui le forze che agiscono su un livello sono ortogonali (perpendicolari) le une alle altre.

Ad esempio, se animate un palla che vola orizzontalmente e rimbalza verticalmente, potete farlo più facilmente separando le dimensioni. La proprietà della posizione X può essere animata con due fotogrammi chiave, uno per la posizione iniziale e uno per la posizione finale. Questa animazione orizzontale rappresenta la velocità del lancio. La proprietà Posizione Y può essere animata con una singola espressione che simula l’accelerazione dovuta alla gravità e il rimbalzo verticale dal pavimento. Un esempio simile è costituito da una barca che scende lungo un fiume con vento trasversale variabile.

Nota:

After Effects CS3 includeva un predefinito di animazione Posizione XYZ separata che eseguiva un’operazione simile a quella della funzione Dimensioni separate, anche se il predefinito di animazione non è altrettanto robusto.

Allineare o distribuire i livelli nello spazio 2D

Usate il pannello Allinea per allineare o distanziare in maniera uniforme i livelli selezionati. Potete allineare o distribuire i livelli in verticale o in orizzontale.

  1. Selezionate i livelli da allineare o distribuire.
  2. Dal menu Allinea livelli a, scegliete Selezione o Composizione.

    Selezione

    Allinea i livelli selezionati in base ai bordi dei livelli selezionati.

    Navigatore

    Allinea i livelli selezionati in base ai bordi del fotogramma della composizione.

  3. Nel pannello Allinea fate clic sul pulsante che rappresenta il tipo di allineamento o distribuzione desiderato.
  • Per la distribuzione, è necessario selezionare almeno tre livelli. Se nel menu Allinea livelli a è selezionato Selezione, è necessario selezionare almeno due livelli da allineare. Se nel menu Allinea livelli a è selezionato Composizione, è necessario selezionare almeno un livello da allineare.

  • Se nel menu Allinea livelli a è selezionato Selezione, ciascuna opzione di allineamento allinea i livelli selezionati al livello che più si avvicina al nuovo allineamento. Ad esempio, per l’allineamento al bordo destro, tutti i livelli selezionati si allineano al livello selezionato il cui bordo destro si trova più a destra rispetto agli altri.

  • Un’opzione di distribuzione assegna una spaziatura uniforme ai livelli selezionati tra i due livelli più esterni. Ad esempio, per un’opzione di distribuzione verticale, i livelli selezionati vengono distribuiti tra il livello selezionato più in alto e quello più in basso.

  • Quando distribuite livelli di dimensioni diverse, è possibile che gli spazi tra i livelli non siano uniformi. Ad esempio, se distribuite i livelli rispetto al loro centro, viene creato uno spazio uguale tra i centri, ma i livelli di dimensioni diverse vengono distanziati in misura diversa tra i livelli.

  • Le opzioni di allineamento o distribuzione non possono spostare i livelli bloccati.

  • Il pannello Allinea non influisce sull’allineamento dei caratteri all’interno di un livello di testo.

Nota:

Per spostare i livelli selezionati in modo che i relativi punti di ancoraggio si trovino al centro della finestra corrente, scegliete Livello > Trasformazione > Centra nella finestra, oppure premete Ctrl+Inizio (Windows) o Comando+Inizio (Mac OS).

Nel sito Web After Effects Scripts è disponibile uno script realizzato da Charles Bordenave (nab) che consente di distribuire i livelli in uno spazio 3D.

Tagliare, estendere o eseguire il montaggio con scivolamento di un livello

L’inizio della durata di un livello coincide con il suo attacco e la sua fine coincide con il suo stacco. La durata è l’intervallo tra l’attacco e lo stacco e la barra che si estende dall’attacco allo stacco è la barra durata del livello.

Tagliare un livello consiste nel modificarne l’attacco e lo stacco in modo tale che abbia una durata diversa. Quando tagliate un livello basato sul metraggio sorgente in movimento, agite sui fotogrammi dell’elemento del metraggio sorgente visualizzati nel livello. Il primo fotogramma ad apparire si trova in corrispondenza dell’attacco, mentre l’ultimo si trova allo stacco. Quando si taglia un livello non si tagliano i fotogrammi dall’elemento di metraggio, ma si determina solo quali fotogrammi verranno riprodotti per quel livello.

Tagliare i livelli nel pannello Timeline
Tagliare i livelli nel pannello Timeline

A. Punto di attacco originale B. Indicatore del tempo negativo per il livello di immagine fissa C. Punto di attacco originale D. Barra di montaggio con scivolamento con i fotogrammi scartati per il livello di metraggio con movimento E. Nuovi punti di attacco 

Quando usate un elemento del metraggio come origine per i vari livelli, potete tagliare ciascun livello in modo diverso per visualizzare le diverse porzioni dell’origine. Tagliando un livello non si modifica l’elemento del metraggio né il file sorgente originale.

Potete tagliare un livello modificando i punti di attacco e stacco nel pannello Livello o nel pannello Timeline. (Potete anche tagliare un elemento del metraggio prima di utilizzarlo per creare un livello. Consultate Creare livelli da elementi del metraggio o cambiare sorgente del livello.)

I valori di attacco , stacco , e durata relativi a un livello sono visualizzati nella parte inferiore del pannello Livello. Per visualizzare queste informazioni per tutti i livelli nel pannello Timeline, fate clic sul pulsante Attacco/Stacco/Durata/Dilatazione nell’angolo inferiore sinistro del pannello Timeline. La durata, il punto di attacco e il punto di stacco per il livello selezionato sono visualizzati anche nel pannello Info.

Nel pannello Livello, i punti di attacco e stacco sono espressi in tempo livello. Nel pannello Timeline, i punti di attacco e stacco sono espressi in tempo composizione. La durata è identica in entrambi i casi (a meno che la modifica del tempo o la dilatazione del tempo non sia attivata per il livello).

È possibile estendere molti tipi di livelli per qualsiasi durata, estendendone i punti di attacco e stacco oltre i tempi originali. Questa funzionalità vale per i livelli con il tempo modificato, i livelli di forma, i livelli basati su elementi del metraggio di immagini fisse, livelli videocamera, livelli luce e livelli testo. Se estendete un livello indietro nel tempo in modo tale che si estenda nel tempo negativo del livello (tempo zero oltre il livello), una serie di simboli di cancelletto nella parte inferiore della barra del livello indica le porzioni del livello che si trovano nel tempo negativo del livello. Questa indicazione è utile se al livello avete applicato degli effetti (come ad esempio Ambiente particelle o Esplosione) che utilizzano il tempo del livello per calcolare i rispettivi risultati.

Risorse online sul taglio, l’estensione e la modifica dei livelli

Jeff Almasol, nel suo sito Web redefinery, mette a disposizione un versatile script che crea un pannello munito di controlli per spostare nel tempo le varie combinazioni di elementi: punto di attacco e punto di stacco del livello, fotogrammi sorgente del livello, fotogrammi chiave e marcatori.

Tagliare o estendere i livelli nel pannello Timeline

Trascinamento del punto di stacco della barra durata di un livello
Trascinamento del punto di stacco della barra durata di un livello.

  1. Selezionate uno o più livelli nel pannello Timeline.
  2. Effettuate una delle seguenti operazioni:
    • Trascinate una delle estremità della barra della durata del livello.

    • Spostate l’indicatore del tempo corrente sul punto temporale su cui desiderate impostare il punto di attacco o di stacco. Per impostare il punto di attacco sul tempo corrente, premete Alt+[ (Windows) o Opzione+[ (Mac OS). Per impostare il punto di stacco sul tempo corrente, premete Alt+] (Windows) o Opzione+] (Mac OS).

Tagliare o estendere un livello nel pannello Livello

  • Aprite il livello nel pannello Livello e trascinate una delle estremità della barra della durata livello.
  • Spostate l’indicatore del tempo corrente del pannello Livello fino alla posizione temporale in cui desiderate che il metraggio inizi o termini, quindi fate clic sul pulsante Attacco o Stacco per impostare il punto di attacco o stacco sul tempo corrente.

Eseguire il montaggio con scivolamento di un livello

Dopo aver tagliato un livello basato sul metraggio di movimento, una barra di montaggio con scivolamento molto chiara rappresenta i fotogrammi dell’elemento di metraggio che state escludendo dalla composizione. Questo rettangolo di colore chiaro non appare per un livello tagliato in base a un elemento del metraggio fisso. Potete scegliere quali fotogrammi vengono riprodotti nei limiti di una durata tagliata mediante trascinamento della barra di montaggio con scivolamento. I punti di attacco e stacco del livello non vengono influenzati.

Spostando solo il punto di attacco o di stacco di un livello, i fotogrammi chiave non vengono spostati. Trascinando la barra della durata del livello, si spostano tutti i fotogrammi chiave. Trascinando la barra di montaggio con scivolamento, si spostano i fotogrammi chiave selezionati, ma non si spostano i fotogrammi chiave non selezionati.

Nota:

Quando esegui un montaggio con scivolamento, probabilmente desideri spostare alcuni fotogrammi chiave con il metraggio sorgente, ad esempio i fotogrammi chiave della maschera. Altri fotogrammi chiave dovrebbero restare nella posizione temporale in cui si trovano. Premete Maiusc+F2 per deselezionare i fotogrammi chiave e lasciare selezionato il livello.

  • Trascinate la barra di montaggio con scivolamento verso sinistra o verso destra.
  • Trascinate il livello verso sinistra o verso destra con lo strumento Sposta sotto (Punto di ancoraggio).

Rimuovere una parte della durata di un livello

  1. Nel pannello Timeline, impostate l’area di lavoro per includere solo la porzione della durata dei livelli da rimuovere. Spostate l’indicatore del tempo corrente sull’ora in cui deve iniziare l’area di lavoro e premete B. Spostate l’indicatore del tempo corrente sull’ora in cui deve finire l’area di lavoro e premete N.
  2. Effettuate una delle seguenti operazioni:
    • Selezionate i livelli dai quali rimuovere una sezione.

    • Selezionate lo switch Blocca  per i livelli che non desiderate vengano interessati dall’estrazione. Premete F2 per deselezionare tutti i livelli.

    Nota:

    se non viene selezionato nessun livello, la seguente procedura consente di rimuovere la sezione da tutti i livelli non bloccati.

  3. Effettuate una delle seguenti operazioni:
    • Per rimuovere la sezione e lasciare uno spazio vuoto della stessa durata della sezione rimossa, scegliete Modifica > Asporta area di lavoro.

    • Per rimuovere la sezione, scegliete Modifica > Estrai area di lavoro. Lo spazio vuoto viene chiuso mediante eliminazione dei salti.

Posizionare o spostare un livello nel tempo

La barra durata del livello rappresenta in maniera grafica la durata dei livelli. Le colonne Attacco, Stacco e Durata del pannello Timeline rappresentano numericamente la durata del livello.

Nota:

per scegliere quali colonne sono visibili nel pannello Timeline, scegliete Colonne dal menu del pannello, oppure fate clic con il pulsante destro del mouse (Windows) o tenendo premuto il tasto Control (Mac OS) su un’intestazione di colonna.

Queste procedure spostano nel tempo l’intero livello.

  • Per impostare numericamente il punto di attacco e il punto di stacco, fate clic sul numero nella colonna Attacco o Stacco relativa al livello nel pannello Timeline.
  • Per spostare il punto di attacco e il punto di stacco nel tempo corrente, premete Alt (Windows) o Opzione (Mac OS) e fate clic sul numero nella colonna Attacco o Stacco relativa al livello nel pannello Timeline.
  • Per spostare i punti di attacco dei livelli selezionati sull’inizio della composizione, premete Alt+Inizio (Windows) o Opzione+Inizio (Mac OS).
  • Per spostare i punti di stacco dei livelli selezionati sulla fine della composizione, premete Alt+Fine (Windows) o Opzione+Fine (Mac OS).
  • Per spostare i livelli selezionati in avanti di un fotogramma, premete Alt+PgGiù (Windows) o Opzione+PgGiù (Mac OS). Per spostare i livelli selezionati in avanti di 10 fotogrammi, premete Alt+Maiusc+PgGiù (Windows) o Opzione+Maiusc+PgGiù (Mac OS).
  • Per spostare i livelli selezionati indietro di un fotogramma, premete Alt+PgSu (Windows) o Opzione+PgSu (Mac OS). Per spostare i livelli selezionati indietro di 10 fotogrammi, premete Alt+Maiusc+PgSu (Windows) o Opzione+Maiusc+PgSu (Mac OS).
  • Per spostare nel tempo l’intero livello mediante trascinamento, trascinate la barra durata del livello verso sinistra o verso destra. Per allineare la barra durata del livello a determinati punti specifici nel tempo (ad esempio, i marcatori o l’inizio o la fine della composizione), tenete premuto Maiusc e trascinate la barra durata del livello.

Nota:

durante il trascinamento di un livello nel pannello Timeline, nel pannello Info vengono visualizzati il nome, la durata, il cambiamento nel tempo e i punti di attacco e di stacco per il livello.  

Prima e dopo il trascinamento della barra durata
Prima e dopo il trascinamento della barra durata

Jeff Almasol, nel suo sito Web redefinery, mette a disposizione uno script con il quale potete spostare i livelli selezionati come se fossero un gruppo, allineando il gruppo a un tempo specifico nella composizione.

Disporre i livelli nel tempo sequenzialmente

Usate l’assistente fotogramma chiave Livelli sequenza per disporre automaticamente in sequenza i livelli. Quando applicate l’assistente fotogramma chiave, il primo livello selezionato rimane nella posizione temporale iniziale e gli altri livelli selezionati si spostano su tempi nuovi nel pannello Timeline in base all’ordine in cui li avete selezionati.

Livelli selezionati nel pannello Timeline
Livelli selezionati nel pannello Timeline (in alto) e livelli ordinati in sequenza applicando l’assistente fotogramma chiave Livelli sequenza (in basso)

Livelli sovrapposti
I livelli sovrapposti possono presentare fotogrammi chiave di opacità impostati automaticamente per creare una dissolvenza incrociata.

Per inserire un livello in una sequenza, è necessario che la sua durata sia inferiore alla lunghezza della composizione in modo da lasciare tempo per altri livelli. (Consultate Tagliare, estendere o eseguire il montaggio con scivolamento di un livello.)

  1. Nel pannello Timeline tenete premuto Ctrl (Windows) o Comando (Mac OS) e selezionate i livelli in ordine sequenziale, iniziando dal livello che desiderate fare apparire per primo.
  2. Scegliete Animazione > Assistente fotogramma chiave > Livelli sequenza.
  3. Nella finestra di dialogo Livelli sequenza, effettuate una delle seguenti operazioni:
    • Per affiancare i livelli, lasciate che l’opzione Sovrapponi rimanga non selezionata.

    • Per sovrapporre i livelli, selezionate Sovrapponi, immettete un valore Durata per la durata della sovrapposizione e selezionate una transizione. Selezionate Dissolvenza incrociata livelli anteriore e posteriore per usare la trasparenza dei livelli selezionati; altrimenti, scegliete Dissolvenza livello anteriore.

    • Per lasciare degli spazi vuoti tra i livelli, selezionate Sovrapponi e immettete un valore Durata negativo.

Copiare o duplicare un livello

Quando copiate un livello, vengono copiate anche le relative proprietà, compresi gli effetti, i fotogrammi chiave, le espressioni e le maschere.

La duplicazione di un livello costituisce una scorciatoia che vi consente di copiarlo e incollarlo con un solo comando. La duplicazione di un livello con un mascherino traccia mantiene l’ordinamento relativo del livello e il suo mascherino traccia.

Quando incollate i livelli, essi vengono collocati nell’ordine in cui li avevate selezionati prima di copiarli. Il primo livello selezionato è l’ultimo da posizionare, quindi va a collocarsi in cima all’ordine di sovrapposizione dei livelli. Se selezionate i livelli iniziando da quello che si trova in cima, i livelli si collocano nello stesso ordine di sovrapposizione in cui si trovavano quando erano stati incollati.

Nota:

Se quando copiate è selezionato un componente di un livello, come una maschera o un fotogramma chiave, potete copiare solo quel componente. Prima di copiare, premete Maiusc+F2 per deselezionare tutti i componenti di un livello e lasciare selezionato il livello stesso.

  • Per copiare i livelli selezionati e inserire gli attacchi delle copie nel tempo corrente, scegliete Modifica > Copia e premete quindi Ctrl+Alt+V (Windows) o Comando+Opzione+V (Mac OS).
  • Per copiare i livelli selezionati e inserire le copie con gli stessi tempi degli originali, scegliete Modifica > Copia e scegliete quindi Modifica > Incolla.

Nota:

Per inserire le copie nella parte superiore della pila di livelli nel pannello Timeline invece che immediatamente al di sopra degli originali, premete F2 per deselezionare gli originali prima di incollare.

  • Per duplicare i livelli selezionati, scegliete Modifica > Duplica o premete Ctrl+D (Windows) o Comando+D (Mac OS).

Dividere un livello

Nel pannello Timeline potete dividere un livello in qualsiasi punto nel tempo, in modo da creare due livelli indipendenti. Dividere un livello è un’alternativa più rapida della duplicazione e del taglio del livello, che può essere adottata quando desiderate modificare la posizione del livello nell’ordine di sovrapposizione all’interno della composizione.

Nota:

Per far apparire nuovi livelli divisi al di sopra del livello originale nel pannello Timeline, selezionate Crea livelli suddivisi sopra livello originale (Modifica > Preferenze > Generali (Windows) o After Effects > Preferenze > Generali (Mac OS)). Deselezionate questa opzione per far apparire i livelli al di sotto del livello originale.

  1. Selezionate uno o più livelli.
  2. Spostate l’indicatore del tempo corrente sul punto temporale in cui desiderate dividere i livelli.
  3. Scegliete Modifica > Dividi livello.

Quando dividete un livello, entrambi i livelli ottenuti contengono tutti i fotogrammi chiave che erano presenti nel livello originale nelle posizioni originali. I mascherini traccia applicati conservano il proprio ordine, ossia sopra il livello.

Dopo la divisione di un livello, la durata del livello originale termina in corrispondenza del punto di divisione, mentre il nuovo livello inizia da quel punto nel tempo.

Se quando scegliete Modifica > Dividi non è selezionato nessun livello, tutti i livelli vengono divisi nel tempo corrente.

Paul Tuersley, nel forum AE Enhancers, mette a disposizione uno script per dividere i livelli in corrispondenza dei marcatori di livello.

Lloyd Alvarez, nel suo sito Web After Effects Scripts, mette a disposizione uno script che rileva automaticamente le modifiche in un livello di metraggio e le divide in un livello separato per ciascuna modifica (oppure inserisce un marcatore di livello in ciascuna modifica).

Opzioni di orientamento automatico

Le opzioni di orientamento automatico (Livello > Trasformazione > Orientamento automatico) per ciascun livello specificano in che modo l’orientamento dipende dai tracciati animati, dai punti di interesse e dalle videocamere.

Disattivato

Il livello ruota liberamente, indipendente dal tracciato animato, dal punto di interesse e dagli altri livelli.

Orienta lungo il tracciato

Il livello è rivolto nella direzione del tracciato animato. Ad esempio, usate questa opzione per una videocamera, per rappresentare la prospettiva del conducente mentre guarda la strada lungo la quale sta guidando.

Orienta verso la videocamera

Il livello è sempre orientato in modo che sia rivolto verso la videocamera attiva. Questa opzione è disponibile per i livelli 3D; non è disponibile per i livelli 2D, le videocamere e le luci. I livelli di testo 3D dispongono di un’ulteriore opzione, Orienta ogni carattere indipendentemente, con cui è possibile orientare ciascun carattere attorno al proprio punto di ancoraggio. Quando si seleziona l’opzione Orienta ogni carattere indipendentemente, vengono attivate le proprietà 3D per singoli caratteri per il livello di testo qualora non fossero già attivate. (Consultate Proprietà testo 3D per carattere.)

Orienta verso punto di interesse

La videocamera o la luce è rivolta sempre verso il suo punto di interesse. Questa opzione non è disponibile per i livelli diversi da videocamere e luci. (Consultate Videocamere, luci e punti di interesse.)

Nota:

se specificate un’opzione di orientamento automatico per un livello e quindi ne modificate l’orientamento, oppure le proprietà X, Y o Z, l’orientamento del livello viene scostato in base ai nuovi valori. Ad esempio, potete impostare una videocamera con Orienta lungo il tracciato e quindi ruotarla di 90 gradi verso destra per rappresentare la prospettiva di un passeggero che guarda fuori dal finestrino di un’automobile mentre è in movimento.

L’orientamento automatico sul punto di interesse si verifica prima dell’applicazione delle trasformazioni Rotazione e Orientamento. Per animare una videocamera o una luce con l’opzione Orienta verso punto di interesse per allontanare temporaneamente lo sguardo dal punto di interesse, animate le proprietà di trasformazione Rotazione e Orientamento.

Dan Ebberts mette a disposizione un’espressione nel suo sito Web MotionScript che orienta automaticamente un livello lungo un solo asse. Questa possibilità risulta utile, ad esempio, per fare in modo che i personaggi si voltino da un lato all’altro per seguire la videocamera, restando in piedi.

Ulteriori risorse sulla selezione e la disposizione dei livelli

Jeff Almasol, nel suo sito Web redefinery, mette a disposizione un versatile script che crea un pannello munito di controlli per spostare nel tempo le varie combinazioni di elementi: punto di attacco e punto di stacco del livello, fotogrammi sorgente del livello, fotogrammi chiave e marcatori.

Questo prodotto è concesso in licenza in base alla licenza di Attribuzione-Non commerciale-Condividi allo stesso modo 3.0 Unported di Creative Commons.  I post su Twitter™ e Facebook non sono coperti dai termini di Creative Commons.

Note legali   |   Informativa sulla privacy online