Effetto Trasparenza differenza colori

Nota:

anche se gli effetti di trasparenza incorporati in After Effects possono risultare utili per alcuni scopi, è opportuno cercare di applicare la trasparenza con Keylight prima di tentare di utilizzare questi effetti di trasparenza incorporati. Alcuni effetti di trasparenza sono stati sostituiti da effetti più avanzati come Keylight.

Per informazioni generali sulla trasparenza, compresi i collegamenti alle esercitazioni e ad altre risorse, consulta Introduzione alla trasparenza e relative risorse.

L’effetto Trasparenza differenza colori crea una trasparenza dai punti iniziali opposti dividendo un’immagine in due mascherini, Mascherino parziale A e Mascherino parziale B. Il Mascherino parziale B basa la trasparenza sul colore chiave specificato, mentre il Mascherino parziale A basa la trasparenza sulle aree dell’immagine che non contengono un secondo colore diverso. Combinando i due mascherini in un terzo, chiamato mascherino alfa , Trasparenza differenza colori crea valori di trasparenza ben definiti.

Trasparenza differenza colori genera tipi di trasparenza di alta qualità per tutti gli elementi di metraggio ripresi contro uno schermo blu o verde e fornisce risultati ottimali con le immagini che contengono aree trasparenti o semitrasparenti, come il fumo, le ombre o il vetro.

Questo effetto funziona con colori a 8-bpc e 16-bpc.

Usare l’effetto Trasparenza differenza colori

  1. Selezionate il livello da rendere parzialmente trasparente e scegliete Effetto > Trasparenza > Trasparenza differenza colori.

    Nota:

    Per usare i contagocce nel pannello Livello, selezionate Trasparenza differenza colori dal menu Visualizza nel pannello Livello.

  2. Nel pannello Controlli effetti, scegliete Mascherino corretto dal menu Visualizza. Per visualizzare e confrontare l’immagine sorgente, entrambi i mascherini parziali e il mascherino finale contemporaneamente, selezionate [A, B, mascherino] Corretto, Finale dal menu Visualizza. Le altre visualizzazioni disponibili nel menu Visualizza sono descritte al punto 10.
  3. Selezionate il colore chiave adeguato: per rendere trasparente uno schermo blu, usate il colore blu predefinito. Per rendere trasparente uno schermo non blu, scegliete un colore trasparenza seguendo una delle procedure sotto descritte:
    • Contagocce della miniatura: selezionate il contagocce delle miniature, quindi fate clic sull’area desiderata nel pannello Composizione o sull’immagine in miniatura originale.

    • Contagocce del colore chiave: selezionate il contagocce del colore chiave, poi fate clic nel pannello Composizione o Livello nell’area desiderata.

    • Campione del colore chiave: fate clic per selezionare un colore dello spazio di colore specificato.

    Nota:

    Gli strumenti del contagocce sposteranno di conseguenza i cursori. Utilizzate i cursori nel punto 9 per perfezionare i risultati di applicazione di trasparenza.

  4. Fate clic sul pulsante del mascherino  per visualizzare il mascherino combinato finale nella miniatura del mascherino.
  5. Selezionate il contagocce nero, quindi fate clic all’interno della miniatura del mascherino sull’area più chiara di nero per specificare le zone trasparenti. I valori della trasparenza nella miniatura e nel pannello Composizione vengono regolati di conseguenza.
  6. Selezionate il contagocce bianco, quindi fate clic all’interno della miniatura del mascherino sull’area più scura di bianco per specificare le zone opache. I valori dell’opacità nella miniatura e nel pannello Composizione vengono regolati di conseguenza.

    Nota:

    Per realizzare la trasparenza migliore, differenziate quanto più possibile le zone bianche e le zone nere cosicché l’immagine conservi quante più tonalità di grigio possibile.

  7. Selezionate una precisione di corrispondenza dal menu Precisione corrispondenza colore. Scegliete Più rapida, a meno che non usiate uno schermo che non sia di un colore primario (rosso, blu o giallo). Per questi schermi, selezionate Più precisa; il tempo di rendering sarà maggiore, ma i risultati che otterrete saranno migliori.
  8. Per regolare ulteriormente i valori della trasparenza, ripetete i punti 5 e 6 per uno o entrambi i mascherini parziali. Fate clic sul pulsante Mascherino parziale B o sul pulsante Mascherino parziale A per selezionare un mascherino parziale, quindi ripetere la procedura.
  9. Regolate i valori della trasparenza per ogni mascherino parziale e per il mascherino finale trascinando uno o più dei seguenti dispositivi di scorrimento nella sezione dei controlli del mascherino:
    • I dispositivi di scorrimento neri regolano i livelli di trasparenza di ogni mascherino. Gli stessi livelli possono essere regolati usando il contagocce nero.

    • I dispositivi di scorrimento bianchi regolano i livelli di opacità di ogni mascherino. Gli stessi livelli possono essere regolati usando il contagocce bianco.

    • I dispositivi di scorrimento gamma permettono di determinare in quale misura i valori di trasparenza seguano una progressione lineare. Il valore 1 (predefinito) indica una progressione lineare. Altri valori producono progressioni non lineari per determinate regolazioni o effetti visivi.

  10. Durante la regolazione di mascherini singoli scegliete le visualizzazioni del menu Visualizza per vedere le differenze con e senza regolazioni:
    • Scegliete Non corretto per visualizzare un mascherino senza regolazioni.

    • Scegliete Corretto per visualizzare un mascherino con tutte le regolazioni.

  11. Prima di chiudere il pannello Controlli effetti, scegliete Output finale dal menu Visualizza. Affinché After Effects effettui il rendering della trasparenza, Output finale deve essere selezionato.

    Nota:

    Per rimuovere dall’immagine tracce di colore trasparenza riflesso, applicate Soppressione macchie, usando Migliore per Precisione colore. Se il colore è ancora molto, applicate l’effetto Riduzione semplice o l’effetto Riduzione mascherino.

Effetto Trasparenza colore

Nota:

A partire dalla release di ottobre 2013 di After Effects CC, l’effetto Trasparenza colore è stato spostato nella categoria degli effetti Obsoleti. Utilizzare altri effetti come l'effetto Keylight.

Per informazioni generali sulla trasparenza, compresi i collegamenti alle esercitazioni e ad altre risorse, consulta Introduzione alla trasparenza e relative risorse.

L’effetto Trasparenza colore fa scomparire tutti i pixel dell’immagine che sono simili al colore chiave specificato. Questo effetto modifica solo il canale alfa di un livello.

Questo effetto funziona con colori a 8-bpc e 16-bpc.

Escludere un singolo colore con l’effetto Trasparenza colore

  1. Selezionate il livello da rendere parzialmente trasparente e scegliete Effetto > Trasparenza > Trasparenza colore.
  2. Nel pannello Controlli effetti, specificate un colore trasparenza seguendo una delle seguenti procedure:
    • Fate clic sul campione del colore trasparenza per aprire la finestra di dialogo Colore e specificare un colore.

    • Fate clic sul contagocce, quindi fate clic su un colore a video.

  3. Trascinate il cursore di Tolleranza colore per specificare l’intervallo di colore da rendere trasparente. Valori bassi escludono una gamma di colore prossima al colore trasparenza ridotta. Valori alti escludono una gamma di colore più ampia.
  4. Trascinate il cursore di Assottigliamento bordo per regolare la larghezza del bordo dell’are interessata. Valori positivi ingrandiscono il mascherino, ingrandendo così la zona trasparente. Valori negativi riducono le dimensioni del mascherino, riducendo così anche le dimensioni della zona trasparente.
  5. Trascinate il cursore di Sfumatura bordo per specificare la morbidezza del bordo. Valori elevati danno origine a un bordo più morbido, ma il loro rendering richiede più tempo.

Effetto Intervallo colori

Nota:

anche se gli effetti di trasparenza incorporati in After Effects possono risultare utili per alcuni scopi, è opportuno cercare di applicare la trasparenza con Keylight prima di tentare di utilizzare questi effetti di trasparenza incorporati. Alcuni effetti di trasparenza sono stati sostituiti da effetti più avanzati come Keylight.

Per informazioni generali sulla trasparenza, compresi i collegamenti alle esercitazioni e ad altre risorse, consulta Introduzione alla trasparenza e relative risorse.

L’effetto Intervallo colori crea la trasparenza applicando un intervallo specificato dei colori nello spazio colore Lab, YUV o RGB. Questo intervallo colori può essere usato sugli schermi che consistono in più di un colore oppure sugli schermi blu o verdi che sono stati illuminati in modo non uniforme e contengono sfumature diverse dello stesso colore.

Questo effetto funziona con colori a 8 bpc.

Effetto Intervallo colori
Schermo verde poco illuminato (in alto a sinistra) e livello di sfondo (in basso a sinistra) vengono combinati mediante la trasparenza dell’intervallo di colori (in basso a destra).

Usare l’effetto Intervallo colori

  1. Selezionate il livello da rendere parzialmente trasparente e scegliete Effetto > Trasparenza > Intervallo colori.
  2. Scegliete Lab, YUV o RGB dal menu Spazio colore. Se riscontrate dei problemi nell’isolare il soggetto usando uno spazio colore, provate a usarne uno diverso.
  3. Selezionate il contagocce del colore trasparenza quindi fate clic sulla miniatura del mascherino per selezionare la zona corrispondente al colore che volete rendere trasparente nel pannello Composizione. In genere questo primo colore è quello che occupa la zona più vasta dell’immagine.

    Nota:

    Per usare i contagocce nel pannello Livello, selezionate Intervallo colore lineare dal menu Visualizza nel pannello Livello.

  4. Selezionate il contagocce Più, quindi fate clic su altre aree nella miniatura del mascherino per aggiungere altri colori all’intervallo di colori da rendere trasparenti.
  5. Selezionate il contagocce meno, quindi fate clic su altre aree nella miniatura del mascherino per sottrarre altri colori od ombre dall’intervallo di colori resi trasparenti.
  6. Trascinate il cursore di Tolleranza per ammorbidire lo stacco fra regioni trasparenti e regioni opache.
  7. Usate i dispositivi di scorrimento nei controlli Min e Max per regolare ulteriormente l’intervallo colore che avete selezionato con i contagocce Più e Meno. I dispositivi di scorrimento L, Y e R controllano il primo componente dello spazio colore, mentre i dispositivi di scorrimento a, U e G controllano il secondo componente e, infine, i dispositivi di scorrimento b, V e B controllano il terzo componente. Trascinate i dispositivi di scorrimento Min per affinare l’inizio dell’intervallo colori. Trascinate i dispositivi di scorrimento Max per affinare la fine dell’intervallo colori.

Effetto Mascherino differenza

L’effetto Mascherino differenza crea una trasparenza confrontando un livello di origine con un livello di differenza e quindi applicando la trasparenza ai pixel del livello di origine che corrispondono sia alla posizione che al colore del livello della differenza. Questo effetto in genere viene usato per escludere uno sfondo statico dietro un oggetto in movimento, da inserire poi su uno sfondo diverso. Spesso il livello di differenza è semplicemente un fotogramma del metraggio di sfondo (prima che l’oggetto in movimento entri sulla scena). Per questo motivo, l’effetto Mascherino differenza è indicato per le scene riprese con una telecamera fissa e uno sfondo immobile.

Questo effetto funziona con colori a 8-bpc e 16-bpc.

Effetto Trasparenza Mascherino differenza
Effetto Trasparenza Mascherino differenza

A. Immagine originale B. Immagine di sfondo C. Nuova immagine di sfondo D. Immagine composita finale 

Usare l’effetto Mascherino differenza

  1. Selezionate un livello di un metraggio con movimento come livello sorgente.
  2. Trovate un fotogramma nel livello sorgente composto esclusivamente da uno sfondo e salvatelo come fotogramma di sfondo in un file di immagine. Consultate Rendering ed esportazione di un singolo fotogramma di una composizione.
  3. Importate il file di immagine in After Effects e aggiungetelo a una composizione.

    L’immagine importata diventa il livello di differenza. Assicuratevi che la durata sia almeno pari a quella del livello sorgente.

    Nota:

    Se la ripresa non contiene un fotogramma di sfondo completo, potete assemblare lo sfondo completo combinando parti di più fotogrammi in After Effects o in Photoshop. Potete ad esempio usare lo strumento Timbro clone di per ricavare un campione dello sfondo di un fotogramma, quindi riprodurre il campione sullo sfondo di un altro fotogramma.

  4. Per disattivare la visualizzazione del livello di differenza fate clic sull’opzione Video nel pannello Timeline.
  5. Accertatevi che il livello sorgente da cui siete partiti sia selezionato, quindi selezionate Effetto > Trasparenza > Mascherino differenza.
  6. Nel pannello Controlli effetti, scegliete Output finale o Solo mascherino dal menu Visualizza. (La visualizzazione Solo mascherino serve per individuare i fori nella trasparenza. Per riempire i fori indesiderati dopo aver applicato la trasparenza, consultaChiudere un foro in un mascherino.)
  7. Selezionate il file dello sfondo dal menu Livello differenza.
  8. Se il livello di differenza non ha le stesse dimensioni del livello sorgente, selezionate uno dei seguenti controlli dal menu Se le dimensioni del livello sono diverse:

    Centro

    Posiziona il livello di differenza al centro del livello sorgente. Se il livello di differenza è più piccolo del livello sorgente, la zona restante del livello viene riempita di nero.

    Allunga e adatta

    Allunga o riduce il livello di differenza portandolo alle dimensioni del livello sorgente. Le immagini dello sfondo possono risultare distorte.

  9. Spostate il cursore di Tolleranza corrispondenza per specificare la quantità di trasparenza in base a quanto i colori debbano rassomigliarsi fra livelli. Valori bassi producono meno trasparenza, valori alti ne producono di più.
  10. Trascinate il cursore di Morbidezza corrispondenza per ammorbidire lo stacco fra regioni trasparenti e regioni opache. Valori elevati rendono i pixel corrispondenti più trasparenti, ma non aumentano il valore di pixel corrispondenti.
  11. Se il mascherino contiene ancora pixel estranei, intervenite sul dispositivo di scorrimento Sfocatura prima di differenza. Questo dispositivo di scorrimento sopprime il disturbo sfocando leggermente entrambi i livelli prima che venga effettuato il confronto.

    Nota:

    La sfocatura avviene solo per il confronto e non sfoca il risultato finale.

  12. Prima di chiudere il pannello Controlli effetti, accertatevi di selezionare Output finale dal menu Visualizza per fare in modo che After Effects effettui il rendering della trasparenza.

Effetto Estrai

L’effetto Estrai crea la trasparenza applicando il tipo di trasparenza a un determinato intervallo di luminosità in base a un istogramma di un canale specificato. Il metodo ottimale per creare trasparenza in una fotografia scattata contro uno sfondo nero o bianco oppure contro uno sfondo scuro o chiaro, ma composto da più di un colore.

Nota:

I controlli per questo effetto sono simili a quelli dell’effetto Estrai in Adobe Premiere Pro, ma lo scopo e i risultati dell’effetto sono diversi.

Questo effetto funziona con colori a 8-bpc e 16-bpc.

Usare l’effetto Estrai

Nel pannello Controlli effetti, l’effetto Estrai mostra un istogramma di un canale specificato nel menu Canale. L’istogramma visualizza una rappresentazione del livello di luminosità del livello, mostrando il numero relativo di pixel a ogni livello. Da sinistra a destra l’istogramma passa dal più scuro (valore 0) al più chiaro (valore 255).

Usando la barra di controllo della trasparenza sotto l’istogramma, potete regolare l’intervallo di pixel che vengono resi trasparenti. La posizione e la forma della barra in rapporto all’istogramma determina la trasparenza. I pixel corrispondenti alla zona coperti dalla barra rimangono opachi, mentre quelli corrispondenti alle zone non coperte dalla barra vengono resi trasparenti.

  1. Selezionate il livello che desiderate rendere parzialmente trasparente e scegliete Effetto > Trasparenza > Estrai.
  2. Se state rendendo trasparenti zone chiare o scure, selezionate Luminanza dal menu Canale. Per creare effetti visivi, selezionate Rosso, Verde, Blu o Alfa.
  3. Regolate la quantità di trasparenza trascinando la barra di controllo della trasparenza come segue:
    • Trascinate le maniglie di selezione in alto a destra o in alto a sinistra per regolare la lunghezza della barra e accorciare o allungare l’intervallo di trasparenza. Potete anche regolare la lunghezza spostando i dispositivi di scorrimento Punto nero e Punto bianco. I valori sopra al punto bianco e sotto al punto nero vengono resi trasparenti.

    • Trascinate le maniglie di selezione in basso a destra o in basso a sinistra per assottigliare la barra. Assottigliando la barra a sinistra viene regolata la morbidezza della trasparenza nelle zone più scure delle immagini, mentre assottigliandola a destra viene regolata la morbidezza nelle zone più chiare. Potete anche regolare i livelli di morbidezza regolando Morbidezza bianco (zone più chiare) e Morbidezza nero (zone più scure).

    Nota:

    Per assottigliare i bordi della barra di controllo della trasparenza, dovete innanzitutto accorciare la barra della trasparenza.

    • Trascinate l’intera barra a sinistra o a destra per posizionarla sotto l’istogramma.

Effetto Trasparenza interno/esterno

Nota:

anche se gli effetti di trasparenza incorporati in After Effects possono risultare utili per alcuni scopi, è opportuno cercare di applicare la trasparenza con Keylight prima di tentare di utilizzare questi effetti di trasparenza incorporati. Alcuni effetti di trasparenza sono stati sostituiti da effetti più avanzati come Keylight.

Per informazioni generali sulla trasparenza, compresi i collegamenti alle esercitazioni e ad altre risorse, consulta Introduzione alla trasparenza e relative risorse.

L’effetto Trasparenza interno/esterno isola un oggetto in primo piano dallo sfondo.

Questo effetto funziona con colori a 8-bpc e 16-bpc.

Usare l’effetto Trasparenza interno/esterno

Per usare Trasparenza interno/esterno, create una maschera per definire il bordo interno ed esterno dell’oggetto da isolare. La maschera può essere anche approssimativa; non deve seguire esattamente i contorni dell’oggetto.

Oltre a mascherare un oggetto dai bordi morbidi dallo sfondo, Trasparenza interno/esterno modifica i colori attorno al bordo per eliminare colori di sfondo estranei. Questo processo di decontaminazione dei colori determina il contributo dello sfondo al colore di ogni pixel del bordo, ed elimina tale contributo, rimuovendo così l’alone che può comparire se un oggetto dai bordi morbidi viene sovrapposto a un nuovo sfondo.

  1. Selezionate il bordo dell’oggetto da estrarre seguendo una di queste procedure:
    • Disegnate una maschera chiusa attorno al bordo dell’oggetto, quindi selezionate questa maschera dal menu Primo piano e lasciate il menu Sfondo impostato su Nessuno. Regolate Raggio luce singola maschera per modificare le dimensioni del bordo attorno a questa maschera. (Questo metodo funziona bene solo sugli oggetti con bordi semplici).

    • Disegnate due maschere chiuse: una maschera interna appena all’interno dell’oggetto e una maschera esterna appena all’esterno dell’oggetto. Accertatevi che le zone sfocate o indistinte dell’oggetto si trovino entro queste due maschere. Selezionate la maschera interna nel menu Primo piano e la maschera esterna nel menu Sfondo.

    Nota:

    Accertatevi che la modalità di maschera per tutte le maschere sia impostata su Nessuna.

  2. Se desiderate, spostate le maschere per trovare la posizione che offre i risultati migliori.
  3. Per estrarre più di un oggetto, oppure per creare un foro in un oggetto, disegnate ulteriori maschere, quindi selezionatele dai menu Primo piano aggiuntivo e Sfondo aggiuntivo. Ad esempio, per rendere trasparenti i capelli di una persona che svolazzano al vento sullo sfondo di un cielo azzurro, disegnate la maschera interna all’interno della testa, disegnate la maschera esterna attorno al bordo esterno dei capelli e disegnate un ulteriore maschera attorno allo spazio fra i capelli in cui è possibile vedere il cielo. Selezionate la maschera aggiuntiva dal menu Primo piano aggiuntivo per estrarre lo spazio ed eliminare l’immagine di sfondo.
  4. Create ulteriori maschere aperte o chiuse per ripulire altre zone dell’immagine, quindi selezionatele dal menu Ripulisci primo piano o dal menu Ripulisci sfondo. Ripulisci primo piano accresce l’opacità attorno alla maschera, Ripulisci sfondo riduce l’opacità attorno alla maschera. Usate le opzioni Raggio pennello e Pressione pennello per modificare le dimensioni e la densità di ogni tratto.

    Nota:

    Potete selezionare la maschera Sfondo (esterno) come maschera di Ripulisci sfondo per rimuovere il disturbo dalle zone di sfondo dell’immagine.

  5. Impostate Assottigliamento bordo per specificare in che misura il bordo del mascherino sia modificato dalla trasparenza. Un valore positivo fa ritrarre il bordo dalla zona trasparente, mentre questa diventa più grande. Un valore negativo spinge il bordo verso la zona trasparente e fa aumentare le dimensioni della zona in primo piano.
  6. Aumentate i valori di Sfumatura bordo per ammorbidire i bordi della zona resa trasparente. Il rendering richiede più tempo in caso di elevati valori di Sfumatura bordo.
  7. Specificate la Soglia bordo, che è un taglio delicato per rimuovere i pixel poco opachi che potrebbero provocare disturbi indesiderati sullo sfondo dell’immagine.
  8. Selezionate Inverti estrazione per invertire le zone in primo piano e lo sfondo.
  9. Impostate Fondi con originale per specificare il grado in cui l’immagine estratta ottenuta si fonde con l’immagine originale.

Effetto Trasparenza colore lineare

Nota:

anche se gli effetti di trasparenza incorporati in After Effects possono risultare utili per alcuni scopi, è opportuno cercare di applicare la trasparenza con Keylight prima di tentare di utilizzare questi effetti di trasparenza incorporati. Alcuni effetti di trasparenza sono stati sostituiti da effetti più avanzati come Keylight.

Per informazioni generali sulla trasparenza, compresi i collegamenti alle esercitazioni e ad altre risorse, consulta Introduzione alla trasparenza e relative risorse.

Le trasparenze lineari creano un intervallo di trasparenza in un’immagine. Una trasparenza lineare confronta ogni pixel dell’immagine con il colore trasparenza che avete specificato. Se il colore di un pixel corrisponde esattamente al colore della trasparenza, diventerà totalmente trasparente. I pixel che non corrispondono in modo altrettanto esatto risulteranno meno trasparenti, e i pixel che non corrispondono rimarranno opachi. L’intervallo di valori di trasparenza forma quindi una progressione lineare.

L’effetto Trasparenza colore lineare usa le informazioni relative al canale RGB, alla tonalità o al croma per creare la trasparenza a partire da una trasparenza colore specificata.

Questo effetto funziona con colori a 8, 16 e 32 bpc.

Applicare l’effetto Trasparenza colore lineare

Nel pannello Controlli effetti, l’effetto Trasparenza colore lineare visualizza due immagini in miniatura. Quella a sinistra rappresenta l’immagine originale inalterata, quella a destra rappresenta la visualizzazione scelta nel menu Visualizza.

Potete regolare il colore trasparenza, la tolleranza della corrispondenza e la morbidezza della corrispondenza. La tolleranza della corrispondenza specifica quanto debba essere il livello di corrispondenza del colore dei pixel con quello del colore trasparenza prima che i pixel comincino a diventare trasparenti. La morbidezza della corrispondenza regola la morbidezza dei bordi fra l’immagine e il colore trasparenza.

Potete anche riapplicare questa trasparenza per conservare un colore reso trasparente dalla prima applicazione della trasparenza. Se ad esempio si rende trasparente uno schermo blu chiaro, potrebbe andar perduto un pezzo del vestito azzurro (o tutto il vestito) indossato dal soggetto. Per far ricomparire l’azzurro è sufficiente applicare un’altra istanza di Trasparenza colore lineare e scegliere Mantieni questo colore dal menu Operazione trasparenza.

  1. Selezionate un livello come livello sorgente e selezionate Effetto > Trasparenza > Trasparenza colore lineare.
  2. Nel pannello Controlli effetti, selezionate Trasparenza colori dal menu Operazione trasparenza.
  3. Selezionate uno spazio colore dal menu Corrispondenza colori. Nella maggior parte dei casi sarà opportuno utilizzare l’impostazione predefinita RGB. Se riscontrate dei problemi nell’isolare il soggetto usando uno spazio colore, provate a usarne uno diverso.
  4. Nel pannello Controlli effetti, scegliete Output finale dal menu Visualizza. La visualizzazione scelta comparirà nella miniatura di destra e nel pannello Composizione. Per visualizzare altri risultati, lavorate in una delle altre visualizzazioni:

    Solo sorgente

    Mostra l’immagine originale senza la trasparenza applicata.

    Solo mascherino

    Mostra il mascherino del canale alfa. Questa visualizzazione serve per individuare i fori nella trasparenza. Per riempire i fori indesiderati dopo aver applicato la trasparenza, consulta Chiudere un foro in un mascherino.

  5. Selezionate un colore trasparenza seguendo una delle seguenti procedure:
    • Selezionate il contagocce delle miniature, quindi fate clic sull’area desiderata nel pannello Composizione o sull’immagine in miniatura originale.

    • Selezionate il contagocce del colore trasparenza, quindi fate clic sulla zona desiderata nel pannello Composizione o Livello.

    • Per visualizzare in anteprima le trasparenze di diversi colori, selezionate il contagocce del colore trasparenza, tenete premuto il tasto Alt (Windows) o il tasto Opzione (Mac OS) e spostate il puntatore Su aree diverse nel pannello Composizione o sull’immagine in miniatura originale. La trasparenza dell’immagine le pannello Composizione cambia a ogni spostamento del puntatore su diversi colori o tonalità. Fate clic per selezionare il colore.

    • Fate clic sul campione del colore trasparenza per selezionare un colore nello spazio colore specificato. Il colore selezionato diventerà trasparente.

      nota: gli strumenti del contagocce sposteranno di conseguenza i cursori. Utilizzate i cursori nei punti 6 e 7 per perfezionare i risultati di applicazione di trasparenza. Per usare i contagocce nel pannello Livello, selezionate Trasparenza colore lineare dal menu Visualizza nel pannello Livello.

  6. Per regolare la tolleranza della corrispondenza, seguite una delle procedure sopra elencate:
    • Selezionate il contagocce Più (+) o Meno (-), quindi fate clic su un colore nell’immagine in miniatura a sinistra. Il contagocce Più aggiunge il colore specificato alla gamma del colore trasparenza, aumentando la tolleranza della corrispondenza e il livello di trasparenza. Il contagocce Meno sottrae il colore specificato alla gamma del colore trasparenza, riducendo la tolleranza della corrispondenza e il livello di trasparenza.

    • Trascinate il cursore della tolleranza della corrispondenza. Un valore pari a 0 rende opaca l’intera immagine; un valore pari a 100 rende l’intera immagine trasparente.

  7. Trascinate il dispositivo di scorrimento della morbidezza della corrispondenza per attenuare la tolleranza della corrispondenza riducendo gradualmente il valore della tolleranza. In genere i valori inferiori al 20% permettono di ottenere i risultati migliori.
  8. Prima di chiudere il pannello Controlli effetti, accertatevi di selezionare Output finale dal menu Visualizza per fare in modo che After Effects effettui il rendering della trasparenza.

Conservare un colore dopo aver applicato Trasparenza colore lineare

  1. Nel pannello Controlli effetti o nel pannello Timeline, disattivate tutte le istanze correnti di trasparenze o mascherini deselezionando l’opzione Effetto a sinistra del nome della trasparenza o dello strumento. Deselezionando l’opzione verrà visualizzata l’immagine originale nel pannello Composizione, cosicché possiate scegliere un colore da conservare.
  2. Selezionate Effetto > Trasparenza > Trasparenza colore lineare. Verrà visualizzata un’ulteriore serie di controlli di Trasparenza colore lineare nel pannello Controlli effetti, appena sotto la prima serie.
  3. Nel pannello Controlli effetti, selezionate Mantieni colori dal menu Operazione trasparenza.
  4. Selezionate il colore da conservare.
  5. Nella prima applicazione dell’effetto Trasparenza colore lineare, scegliete Output finale dal menu Visualizza nel pannello Controlli effetti, quindi riattivate le altre istanze dell’effetto Trasparenza colore lineare per esaminare la trasparenza. Potreste dover regolare i colori o riapplicare una terza volta la trasparenza per ottenere i risultati desiderati.

Effetto Luminanza

Nota:

A partire dalla release di ottobre 2013 di After Effects CC, l'effetto Luminanza è stato spostato nella categoria Effetti Obsoleto e si consiglia agli utenti di utilizzare altri effetti come l'effetto Keylight.

Per informazioni generali sulla trasparenza, compresi i collegamenti alle esercitazioni e ad altre risorse, consulta Introduzione alla trasparenza e relative risorse.

L’effetto Luminanza rende trasparenti tutte le aree di un livello con una determinata luminanza o luminosità. L’impostazione della qualità del livello non influisce sull’effetto Trasparenza luminanza.

Usate questo effetto se l’oggetto da cui volete creare un mascherino ha valore di luminanza molto diverso da quello dello sfondo. Se ad esempio volete creare un mascherino per le note musicali su uno sfondo bianco, potete escludere i valori più chiari. Le note musicali nere diventano le uniche aree opache.

Questo effetto funziona con colori a 8-bpc e 16-bpc.

Effetto Luminanza
Lo sfondo bianco dell’originale (in alto a sinistra e in basso a sinistra) viene rimosso mediante Luma Key e composito sopra il livello sottostante (in basso a destra).

Escludere un valore di luminanza con l’effetto Trasparenza luminanza

  1. Selezionate il livello da rendere parzialmente trasparente e scegliete Effetto > Trasparenza > Trasparenza luminanza.
  2. Selezionate un tipo di trasparenza per specificare l’intervallo da rendere trasparente.
  3. Trascinate il dispositivo di scorrimento Soglia nel pannello Controlli effetti per impostare il valore di luminanza su cui desiderate si basi il mascherino.
  4. Trascinate il cursore di Tolleranza colore per specificare l’intervallo di valori da rendere trasparente. Valori bassi escludono un intervallo inferiore di valori prossimi alla soglia. Valori alti escludono un intervallo di valori più ampio.
  5. Trascinate il cursore di Assottigliamento bordo per regolare la larghezza del bordo dell’are interessata. Valori positivi ingrandiscono il mascherino, ingrandendo così la zona trasparente. Valori negativi rimpiccioliscono la maschera.
  6. Trascinate il cursore di Sfumatura bordo per specificare la morbidezza del bordo. Valori elevati danno origine a un bordo più morbido, ma il loro rendering richiede più tempo.

Effetto Soppressione macchie

Nota:

a partire dalla versione di After Effects CC di giugno 2014, l’effetto Soppressione macchie è stato spostato nella categoria effetti obsoleti e si consiglia agli utenti di utilizzare l’effetto Soppressione macchie avanzato.

Effetto Pulizia trasparenza ed Effetto Soppressione macchie avanzato

Effetto Pulizia trasparenza

L’effetto Pulizia trasparenza recupera i dettagli di un canale alfa da una scena alla quale è stata applicato un effetto di trasparenza tipico, compresi i dettagli persi a causa di artefatti di compressione.

Nota:

Se vengono visualizzati effetti di semitrasparenza non desiderati lungo i bordi che avrebbero dovuto essere nitidi, utilizzate una maschera effetto (con una piccola Sfumatura maschera) per limitare gli effetti di Pulizia trasparenza all’area desiderata.

Effetto Soppressione macchie avanzato

L’effetto Soppressione Macchie avanzato rimuove la fuoriuscita di colore di un oggetto in primo piano da uno sfondo colorato utilizzato per la trasparenza colore.

L’effetto Soppressione Macchie avanzato offre due metodi per eliminare le macchie:

  1. Standard - Il metodo Standard è il più semplice, rileva automaticamente il colore chiave dominante e richiede meno input dell’utente.
  2. Ultra - Il metodo Ultra si basa sulla funzione di soppressione macchie dell’effetto Ultra in Premiere Pro. Consultate la sezione Tasto Ultra in Premiere Pro per informazioni sul tasto Ultra.

Un modo semplice per applicare questi effetti consiste nell’utilizzare il predefinito di animazione Keylight + Pulizia trasparenza + Soppressione macchie.

Nota:

a partire dalla versione di After Effects CC di giugno 2014, l’effetto Soppressione macchie è stato spostato nella categoria effetti obsoleti e si consiglia agli utenti di utilizzare l’effetto Soppressione macchie avanzato.

Effetto Keylight

In After Effects sono inclusi diversi effetti di trasparenza incorporati, oltre all’effetto Keylight (premiato con l’Academy Award), che consente un’eccellente applicazione della trasparenza al colore di qualità professionale. Per informazioni sull’effetto Keylight, consultate la relativa documentazione nella cartella in cui è installato il plug-in dell’effetto. Consulta Plug-in.

Per informazioni generali sulla trasparenza, compresi i collegamenti alle esercitazioni e ad altre risorse, consulta Introduzione alla trasparenza e relative risorse.

Nota:

La proprietà Colore chiave è già collegata con un’espressione alla proprietà Colore schermo dell’effetto Keylight, quindi non è necessario modificarla a meno che non si desideri usare un colore diverso per il processo di despill. Per usare un colore diverso per il processo di despill, disattivare o rimuovere l’espressione Keylight.

Utilizzo del predefinito di animazione Keylight + Pulizia trasparenza + Soppressione macchie avanzato

Predefinito Keylight
Predefinito Keylight

Effetti Keylight, Pulizia trasparenza e Soppressione macchie avanzata
Effetti Keylight, Pulizia trasparenza e Soppressione macchie avanzata

Seguite i passaggi successivi per applicare l’effetto Keylight con Pulizia trasparenza e Soppressione macchie avanzato:

  1. Usate il predefinito di animazione Keylight + Key Cleaner + Soppressione macchie avanzato (nella cartella Utilità immagine sotto Predefiniti di animazione) per applicare i tre effetti al livello nell'ordine dato. L'effetto Soppressione macchie avanzato è disattivato per impostazione predefinita per consentire di campionare il colore chiave nell'effetto Keylight oppure, se il metraggio non ha macchie di colore, per rimuoverlo.
  2. Usate il contagocce Colore schermo dell’effetto Keylight per campionare il colore chiave dal livello nel pannello Composizione . Regolate le altre impostazioni dell’effetto Keylight per ottenere risultati ottimali.
  3. Attivate lo switch Effetto per l’effetto Soppressione macchie avanzato per rimuovere le macchie di colore dalla scena.

Nota:

Se viene visualizzata una semitrasparenza indesiderata lungo i bordi che dovrebbero essere nitidi, utilizzate una maschera effetto (con un poco di sfumatura del bordo della maschera) per limitare Pulizia trasparenza all’area desiderata.

Consulta gli articoli Sfumatura di una maschera a larghezza variabile e Ammorbidire i bordi di una maschera per informazioni su come sfumare le maschere

Utilizzo degli effetti Pulizia trasparenza e Soppressione macchie avanzato con altri effetti Trasparenza   

Seguite i passaggi successivi per applicare l'effetto Pulizia trasparenza e Soppressione macchie avanzata a un effetto trasparenza diverso da quello keylight:

  1. Applicate l’effetto di trasparenza al livello.
  2. Impostate l’effetto all’equivalente dell’impostazione Risultato intermedio dell’effetto Keylight in modo che l’effetto di trasparenza fornisca il risultato RGB senza tentare di eseguire alcuna eliminazione macchie.
  3. Applicate l’effetto Pulizia trasparenza dopo l’effetto di trasparenza.
  4. Applicate l’effetto Soppressione macchie avanzato dopo l’effetto Pulizia trasparenza.

Esercitazione

Soppressione macchie

Guardate questo video per apprendere come ottenere risultati di trasparenza migliori da riprese con sfondo verde compresse o danneggiate con il nuovo effetto Pulizia trasparenza e come rimuovere macchie di colore con i comandi Soppressione macchie.

Questo prodotto è concesso in licenza in base alla licenza di Attribuzione-Non commerciale-Condividi allo stesso modo 3.0 Unported di Creative Commons.  I post su Twitter™ e Facebook non sono coperti dai termini di Creative Commons.

Note legali   |   Informativa sulla privacy online