Il video sulla gestione del colore di After Effects fornisce un’introduzione alla gestione del colore, spiegando come funziona e come usarla.

Gestione del colore e profili colore

Panoramica sulla gestione dei colori

Le informazioni sul colore vengono comunicate usando dei numeri. Dato che dispositivi diversi usano metodi diversi per registrare e visualizzare il colore, gli stessi numeri possono essere interpretati in modo diverso e ci appaiono come colori diversi. Un sistema di gestione del colore tiene traccia di tutti i vari modi di interpretare il colore ed esegue le conversioni per far sì che le immagini mantengano lo stesso aspetto a prescindere dal dispositivo usato per visualizzarle.

In genere, un profilo colore è una descrizione di uno spazio colore specifico per un dispositivo in termini delle trasformazioni richieste per convertire le sue informazioni sul colore in uno spazio colore indipendente dal dispositivo.

Nel caso specifico in cui si lavori in After Effects, i profili colore ICC sono usati per la conversione in e da lo spazio cromatico di lavoro nel seguente flusso di lavoro generale:

  1. Un profilo colore di input viene usato per convertire ogni elemento di metraggio dal proprio spazio colore nello spazio cromatico di lavoro. Un elemento di metraggio può contenere un profilo colore di input incorporato oppure potete assegnare il profilo colore di input nella finestra di dialogo Interpreta metraggio o nel file delle regole di interpretazione. Consultate Interpretare un elemento di metraggio assegnando un profilo colore di input.

  2. After Effects esegue tutte le operazioni che interessano il colore nello spazio cromatico di lavoro. Assegnate uno spazio cromatico di lavoro (spazio di lavoro del progetto) nella finestra di dialogo Impostazioni progetto. Consultate Scegliere uno spazio cromatico di lavoro e attivare la gestione del colore.

  3. I colori vengono convertiti dallo spazio cromatico di lavoro allo spazio cromatico del monitor del computer usando il profilo del monitor. Questa conversione assicura che la composizione avrà lo stesso identico aspetto su due monitor diversi, a condizione che il loro profilo sia stato creato correttamente. Questa conversione non cambia i dati all’interno della composizione. Potete scegliere se convertire i colori per il monitor usando il comando del menu Visualizza > Usa gestione del colore per visualizzazione. Consultate Attivare o disattivare la gestione del colore di visualizzazione.

  4. In via opzionale, After Effects usa un profilo di simulazione per mostrare sul monitor del computer quale sarà l’aspetto della composizione nel formato di output finale su un dispositivo diverso. Potete controllare la simulazione dell’output per ogni visualizzazione tramite il menu Visualizza > Simula output. Consultate Simulare l’aspetto dei colori su un dispositivo di output diverso.

  5. Un profilo colore di output per ogni modulo di output viene usato per convertire la composizione sottoposta a rendering dallo spazio cromatico di lavoro in quello del supporto di output. Potete scegliere il profilo del colore di output nella finestra di dialogo Impostazioni modulo di output. Consultate Assegnare un profilo dei colori di output.

Per impostazione predefinita, quando utilizzate la gestione del colore, After Effects regola automaticamente i colori per compensare le differenze di gamma tra i profili di colore riferiti alla scena e i profili di colore riferiti all’output. Consultate Risposta tonale e gamma.

Nota:

Un altro approccio alla gestione del colore consiste nell’applicare manualmente delle trasformazioni di colori mediante delle tavole di consultazione dei colori, o LUT. Consultate Effetto Applica LUT colori.

Vantaggi della gestione dei colori

La gestione del colore offre numerosi benefici, tra cui:

  • I colori nelle immagini importate rispecchiano fedelmente le intenzioni dell’autore.

  • Disponete di un maggior controllo sul modo in cui i colori vengono fusi nel progetto, dall’effetto movimento all’anti-alias.

  • I filmati creati saranno fedeli alle vostre intenzioni quando vengono visti su dispositivi diversi dal monitor del computer.

Se non attivate la gestione del colore per il vostro progetto, i colori nella composizione dipenderanno dalle caratteristiche di colore del monitor: i colori che vedete sono quelli visualizzati dal monitor in base ai numeri RGB negli elementi di metraggio. Dato che spazi di colore diversi usano gli stessi numeri RGB per rappresentare colori diversi, i colori che vedete e quelli della composizione potrebbero non essere i colori voluti dall’autore del metraggio. Di fatto, i colori potrebbero essere molto diversi da quelli voluti.

Impostando uno spazio cromatico di lavoro per il progetto (che permette la gestione del colore), fate due cose:

  • Definite uno spazio di colore comune per la composizione e altre operazioni che interessano il colore.

  • Controllate l’aspetto dei colori nella composizione.

Se un elemento di metraggio ha un profilo colori incorporato (ad esempio l’elemento di metraggio è un file PSD di Photoshop), i colori voluti dall’autore dell’immagine possono essere riprodotti accuratamente nella composizione. Il profilo colori contiene le informazioni che determinano come convertire i numeri RGB nel file immagine in uno spazio di colore indipendente dal dispositivo; il profilo colori del monitor può quindi essere usato per determinare quali numeri RGB nello spazio colore del monitor rappresentano i colori destinati all’elemento di metraggio. Questa conversione automatica diventa ancor più importante quando si importano elementi di metraggio con numerosi profili di colore diversi, da sorgenti diverse.

Il processo di conversione del colore non richiede alcun intervento da parte vostra. I colori vengono semplicemente visualizzati sul monitor com’erano nel momento in cui l’immagine è stata creata. Il vostro monitor potrebbe, avere un gamut limitato rispetto allo spazio di colore che avete scelto per lo spazio di lavoro e i colori possono venire tagliati quando vengono visualizzati sul monitor. Tuttavia, dispone comunque dell’intervallo completo dei dati cromatici nel progetto e i colori non vengono tagliati internamente.

Quando siete pronti per eseguire l’output della vostra composizione, potete usare la gestione del colore per trasformare i colori nello spazio appropriato per il vostro supporto di output. In questa fase, state preservando l’aspetto dei colori desiderato.

Profili colore

Il formato file per i profili colore è standardizzato da ICC (International Color Consortium) e i file che li contengono in genere terminano con l’estensione .icc. After Effects ha in dotazione numerosi profili colore per spazi colore per tipi di input e output comuni (e anche non molto comuni).

After Effects carica i profili colore da diverse posizioni, tra cui:

  • Mac OS: Liberia/ColorSync/Profiles

  • Mac OS: Libreria/Supporto applicazione/Adobe/Colore/Profili

  • Windows: WINDOWS\system32\spool\drivers\color

  • Windows: Programmi\File comuni\Adobe\Color\Profiles

Nota:

Potete creare un profilo ICC personalizzato usando Adobe Photoshop. In Photoshop, scegliete Modifica > Impostazioni colori. Nei menu RGB e CMYK dell’area Spazi di lavoro della finestra di dialogo Impostazioni colore Photoshop, sono disponibili le opzioni per salvare e caricare i profili ICC e per definire i profili personalizzati.

Tutti i profili di colore utilizzati in un progetto vengono salvati nel progetto, quindi non dovete trasferirli manualmente da un sistema all’altro per aprire il progetto in un altro sistema.

Nota:

il profilo di colore NTSC (1953) corrisponde ad apparecchi televisivi obsoleti ed è consigliabile non usarlo. Per apparecchi televisivi NTSC a definizione standard, usare uno dei profili colore SDTV NTSC.

Al momento di scegliere un profilo (per l’input, l’output o la simulazione), i profili per la pellicola cinematografica saranno visibili solo se il metraggio è Cineon o se selezionate Mostra tutti i profili disponibili. In caso di metraggio Cineon, appariranno solo i profili della pellicola cinematografica, a meno che non selezioniate Mostra tutti i profili disponibili.

Suggerimenti sulla gestione del colore

Non dimenticatevi di leggere le indicazioni nelle finestre di dialogo Interpreta metraggio, Impostazioni progetto e Impostazioni modulo di output. Il testo in esse contenuto vi aiuta a capire le conversioni di colore che verranno eseguite quando interpretate il metraggio, eseguite la composizione e l’output dei filmati sottoposti a rendering.

Assicuratevi che l’ambiente di lavoro fornisca un livello di luce e una temperatura cromatica uniforme. Ad esempio, le caratteristiche cromatiche della luce solare cambiano durante il giorno e possono alterare l’aspetto dei colori sullo schermo, per questo motivo tenete le imposte chiuse o lavorate in una stanza senza finestre.

Risorse online sulla gestione del colore

Trish e Chris Meyer mettono a disposizione una panoramica sulla gestione del colore in un articolo nel sito Web Artbeats.

Nel sito Web di Johan Steen è disponibile un articolo in cui viene spiegata dettagliatamente la gestione del colore in After Effects. Viene inoltre spiegato come effettuare la calibrazione e il profilo di un monitor, come usare la gestione del colore in Photoshop e come lavorare in uno spazio colore lineare.

Per informazioni sui profili di colore, consultate il sito Web International Color Consortium.

Calibrare e creare il profilo del monitor

Quando calibrate il monitor, l’utilità di creazione del profilo consente di salvare un profilo di colore che descrive il comportamento del colore del monitor. Il profilo contiene informazioni su quali colori possono essere riprodotti e in che modo devono essere convertiti i valori numerici di colore di un’immagine in modo da ottenere una visualizzazione accurata dei colori. After Effects e il sistema operativo possono utilizzare queste informazioni per assicurarsi che i colori visibili sul monitor siano simili ai colori del filmati creati.

Nota:

le prestazioni del monitor cambiano e peggiorano nel tempo; ripetete la calibrazione del monitor e la creazione del profilo più o meno ogni mese. Se la calibrazione del monitor allo standard appropriato risulta difficile o impossibile, è probabile che il monitor sia troppo vecchio e che i colori rappresentati appaiano sbiaditi.

  1. Assicuratevi che il monitor sia rimasto acceso per almeno mezz’ora, fornendogli il tempo sufficiente a riscaldarsi e generare output più omogenei.
  2. Controllate che il monitor visualizzi milioni di colori (24 bit per pixel) o più.
  3. Se non possedete un software di creazione dei profili che utilizza un dispositivo di misurazione, rimuovete i pattern di sfondo colorati dal desktop del monitor e impostate il desktop in modo che visualizzi i grigi neutri. I pattern complessi o i colori vivaci intorno a un documento disturbano la percezione accurata dei colori.
  4. Effettuate una delle seguenti operazioni per calibrare il monitor e creare il relativo profilo:
    • Per ottenere risultati ottimali usate software e dispositivi di misurazione di altri produttori. In generale, l’uso di un dispositivo di misurazione quale un colorimetro insieme al software permette di creare profili più precisi perché uno strumento è in grado di misurare i colori visualizzati su un monitor con maggiore precisione rispetto all’occhio umano.

      La maggior parte dei programmi software di creazione dei profili assegna automaticamente un nuovo profilo come profilo predefinito del monitor. Per istruzioni su come assegnare manualmente il profilo del monitor, consultate la documentazione relativa al sistema operativo.

    • In Mac OS, utilizzate l’utilità di calibrazione ubicata nella scheda Preferenze di Sistema > Monitor >Colore.

Scegliere uno spazio cromatico di lavoro e attivare la gestione del colore

Per attivare la gestione del colore per un progetto, scegliete uno spazio cromatico di lavoro (Spazio di lavoro) per il progetto nella finestra di dialogo Impostazioni progetto. Potete controllare la gestione del colore per ogni elemento di metraggio tramite la finestra di dialogo Interpreta metraggio o tramite il file delle regole di interpretazione. Potete controllare la gestione del colore per ogni elemento di output nella finestra di dialogo Impostazioni modulo di output.

Se lo spazio di lavoro è impostato su Nessuno nella finestra di dialogo Impostazioni progetto, la gestione del colore non è attivata per il progetto.

La scelta di uno spazio cromatico di lavoro è un passo essenziale nella gestione del colore in un progetto. I colori degli elementi di metraggio vengono convertiti nello spazio cromatico di lavoro come comune spazio di colore per la composizione.

Per ottimizzare i risultati, quando lavorate con colore a 8 bpc, abbinate lo spazio cromatico di lavoro allo spazio cromatico dell’output. Se state eseguendo il rendering su più di uno spazio cromatico, dovete impostare la profondità colore del progetto a 16 bpc o 32 bpc, almeno per il rendering per l’output finale. Lo spazio cromatico di lavoro deve corrispondere allo spazio cromatico di output con il gamut più ampio. Se ad esempio prevedete di eseguire l’output in Adobe RGB e sRGB, utilizzate Adobe RGB come spazio cromatico di lavoro poiché Adobe RGB ha un gamut più ampio e può pertanto rappresentare colori più saturi. Per mantenere valori di intervallo superiore, lavorate con colore a 32 bpc per i suoi valori elevati di intervallo dinamico.

Suggerimenti per scegliere gli spazi cromatici di lavoro:

  • SDTV NTSC o SDTV PAL è una buona scelta se state realizzando un filmato per trasmissione televisiva a definizione standard, incluso DVD a definizione standard.

  • HDTV (Rec. 709) è una buona scelta se state realizzando un filmato per la televisione ad alta definizione. Questo spazio colore usa gli stessi primari di sRGB, ma ha un gamut più ampio, per cui è adatto per molti tipi di lavori.

  • RGB ProPhoto con una curva di risposta tonale lineare (gamma pari a 1.0) è una buona scelta per il lavoro cinematografico digitale.

  • sRGB IEC61966-2.1 è una buona scelta se state realizzando un filmato per il Web, specie disegni animati.

Gli spazi cromatici disponibili in After Effects variano in base ai profili cromatici installati sul computer in uso. Consultate Profili colore.

  1. Scegliete File > Impostazioni progetto.
  2. Scegliete uno spazio cromatico di lavoro nel menu Spazio di lavoro.

Gestione del colore e Mercury Transmit

I valori di colore inviati al monitor video provengono dallo spazio cromatico di lavoro del progetto. Per visualizzare in anteprima i colori video, scegliete un valore per Spazio di lavoro nella finestra di dialogo Impostazioni progetto corrispondente allo spazio colore del dispositivo di visualizzazione in anteprima.

Le anteprime video inviate a un monitor video esterno mediante Mercury Transmit sono sottoposte alla gestione del colore. Per informazioni dettagliate, consultate la sezione Anteprima su un monitor video esterno.

Nota:

Per gestire i colori in una composizione collegata dinamicamente o per le anteprime video, create una nuova composizione e nidificate la vostra composizione al suo interno; applicate quindi l’effetto Convertitore profilo colori alla nuova composizione con Profilo di input impostato su Spazio di lavoro progetto. Per le anteprime video, impostate Profilo di output per abbinare lo spazio colore del dispositivo di anteprima video. Consultate Effetto Convertitore profilo colori.

Gestione del colore e Dynamic Link

Quando la gestione colore è attivata per un progetto After Effects, le composizioni visualizzate tramite Dynamic Link vengono trasformate con il profilo colore Rec. 709. Ciò impedisce uno scostamento di colore o di gamma all’interno delle composizioni in Premiere Pro e Adobe Media Encoder.

Dynamic Link presuppone sempre che tutti i fotogrammi in ingresso siano ricevuti nel profilo colore Rec. 709. Alla composizione, come ultimo passaggio, viene applicata una trasformazione del colore prima che le immagini vengano passate a Dynamic Link per utilizzarle in Premiere Pro o in Adobe Media Encoder. Questo corregge l’immagine della composizione nello spazio colore usato da Dynamic Link, in modo analogo a come l’opzione Visualizza > Abilita gestione del colore per visualizzazione di After Effects corregge l’immagine per il monitor.

Esportare profili colore in Adobe Media Encoder

Adobe Media Encoder può incorporare i profili colore nei file JPEG di cui è stato eseguito il rendering da una composizione di After Effects.

Per incorporare i profili colore, effettuate le seguenti operazioni:

 

  1. Per abilitare la gestione del colore, specificate un profilo di spazio colore di lavoro nelle impostazioni del progetto. Per aprire le impostazioni del progetto, selezionate Modifica > Impostazioni progetto.

  2. Nella finestra di dialogo Impostazioni progetto fate clic su Spazio di lavoro e scegliete uno spazio colore di lavoro nell’elenco a discesa.

    Selezione dello spazio colore di lavoro
    Selezione dello spazio colore di lavoro

  3. Dopo aver specificato uno spazio colore di lavoro, aggiungete la composizione alla Coda di rendering. Per aggiungere la composizione, scegliete File > Esporta > Aggiungi a coda di rendering.

    Aggiunta alla coda di rendering
    Aggiunta alla coda di rendering

  4. Nel pannello Coda di rendering fate clic su Impostazioni modulo di output.

  5. Nella finestra di dialogo Impostazioni modulo di output fate clic su Opzioni principali e impostate Formato su JPEG.

    Modifica del formato in JPEG
    Modifica del formato in JPEG

  6. Dopo aver impostato il formato, fate clic su Gestione colore, scegliete Profilo di output e abilitate l’opzione Incorpora profilo.

    Incorporamento del profilo colore
    Incorporamento del profilo colore

  7. Nel pannello Coda di rendering fate clic sul pulsante Coda AME.

  8. La composizione viene avviata in Adobe Media Encoder. In Adobe Media Encoder impostate Formato di output su JPEG.

    Impostazione del formato di output su JPEG
    Impostazione del formato di output su JPEG

Nota:

Se l’opzione Incorpora profilo non è abilitata, in Adobe Media Encoder verrà incorporato il profilo HDTV (Rec. 709).

Linearizzare lo spazio di lavoro e attivare la fusione lineare

Se avete attivato la gestione del colore (specificando uno spazio cromatico di lavoro), potete eseguire tutte le operazioni di colore in luce lineare linearizzando lo spazio cromatico di lavoro. Uno spazio cromatico linearizzato usa gli stessi primari e lo stesso punto del bianco della versione non lineare; la curva dello spazio cromatico linearizzato è una semplice linea retta. Consultate Risposta tonale e gamma.

Se non avete attivato la gestione del colore, potete eseguire comunque operazioni di fusione usando un valore gamma di 1.0.

Eseguendo operazioni in uno spazio cromatico lineare, potete evitare artefatti quali bordi irregolari o aloni o margini sbavati che appaiono quando vengono fusi colori a elevato contrasto e saturazione. Numerose operazioni che interessano il colore traggono vantaggio quando si lavora in uno spazio colore lineare, comprese quelle interessate nel ricampionamento immagine, nella fusione tra livelli con modalità di fusione, effetto movimento e anti-alias.

Se desiderate usare uno spazio cromatico di lavoro linearizzato, fatelo quando impostate il progetto. In caso contrario, i colori scelti nel selettore colore cambieranno quando si passa a uno spazio cromatico di lavoro lineare poiché all’interno di After Effects vengono interpretati come se fossero nello spazio cromatico di lavoro.

Nota:

lo spazio cromatico di lavoro linearizzato è particolarmente indicato con profondità di colore superiori, 16 e 32 bpc; non è consigliato per colore a 8 bpc.

  1. Scegliete File > Impostazioni progetto ed effettuate una delle seguenti operazioni:
    • Per linearizzare lo spazio cromatico di lavoro, scegliete Linearizza spazio di lavoro.

    • Per fondere i colori in uno spazio colore lineare, scegliete Fusione colori con gamma 1.0. Questa opzione influenza solo la fusione tra i livelli. Il risultato è che l’opacità si dissolve, con ripercussioni sull’effetto movimento e sulle altre caratteristiche che si basano sulle modalità di fusione.

Ulteriori risorse su spazi colore lineare e fusione lineare

Il blog ProLost di Stu Maschwitz contiene numerosi messaggi che sono utili per imparare come, quando e perché lavorare in uno spazio colore lineare piuttosto che in uno spazio colore non lineare. In questo articolo, Stu riassume le ragioni e le tecniche alla base dell’utilizzo di uno spazio colore lineare e della fusione lineare.

Interpretare un elemento di metraggio assegnando un profilo colore di input

Potete controllare la gestione del colore per ogni elemento di metraggio tramite la finestra di dialogo Interpreta metraggio.

Il profilo del colore di input determina quali calcoli vengono eseguiti durante la conversione dei colori di un elemento di metraggio nello spazio cromatico di lavoro per il progetto. Se lo spazio di lavoro non è stato impostato, ovvero se la gestione colore non è attiva per il progetto, non è possibile assegnare un profilo colore di input.

In alcuni casi, nei file importati saranno incorporati i profili ICC. Al momento di importare questi file, potete avere la certezza che i colori che vedete corrispondono alle intenzioni originali del produttore del metraggio. After Effects è in grado di leggere e scrivere i profili di colore incorporati per file Photoshop (PSD), TIFF, PNG e JPEG.

Se un elemento di metraggio non contiene un profilo colore incorporato, potete assegnare un profilo colore di input tramite la finestra di dialogo Interpreta metraggio o aggiungendo o modificando una regola nel file delle regole di interpretazione (interpretation rules.txt). After Effects interpreta l’elemento di metraggio come se il metraggio sorgente fosse stato creato usando questo profilo colore; accertatevi pertanto di assegnare un profilo che corrisponda a (o quanto meno approssimi) quello usato per creare il metraggio sorgente.

Nota:

Se un elemento del metraggio è stato creato da un’applicazione che non utilizza la gestione del colore, ad esempio un filmato sottoposto a rendering da un’applicazione 3D, il profilo del colore di input è essenzialmente il profilo del monitor del sistema in cui l’immagine è ideata e creata.

  1. Selezionate un elemento di metraggio nel pannello Progetto.
  2. Scegliete File > Interpreta metraggio > Principale.
  3. Nella scheda Gestione colore della finestra di dialogo Interpreta metraggio, scegliete un valore dal menu Assegna profilo.

    Se non vedete il profilo desiderato nel menu Assegna profilo, selezionate Mostra tutti i profili disponibili.

  4. Leggete le informazioni nell’area Descrizione della finestra di dialogo per controllare che la conversione sia quella desiderata, quindi fate clic su OK.

A elementi di metraggio non RGB (come CMYK, Y’CbCr e immagini Raw) non è possibile assegnare un profilo di input. Il loro spazio colore nativo viene visualizzato nella finestra di dialogo Interpreta metraggio. La conversione di valori di colore non RGB in valori di colore RGB viene gestita automaticamente per ogni formato.

Se non assegnate un profilo di colore di input e After Effects non ha una regola nel file delle regole di interpretazione con cui eseguire un’interpretazione, si presume che i colori dell’elemento di metraggio siano nello spazio di colore del progetto.

Quando la gestione del colore è attivata, il profilo colore di input per un elemento di metraggio viene visualizzato nell’area delle informazioni nella parte superiore del pannello Progetto.

L’opzione Interpreta come luce lineare determina se il profilo colore di input assegnato viene interpretato come lineare (gamma uguale a 1,0). Questa opzione funziona anche quando la gestione del colore è disattivata per il progetto. Consultate Risposta tonale e gamma.

Potete impedire la conversione dei colori nello spazio cromatico di lavoro per un singolo elemento di metraggio selezionando Mantieni RGB nella scheda Gestione del colore della finestra di dialogo Interpreta metraggio. Questa opzione mantiene i numeri RGB, non l’aspetto dei colori. La disattivazione della gestione del colore per uno specifico elemento di metraggio è utile quando tale elemento non è destinato alla visualizzazione ma per essere usato come livello di controllo, ad esempio come mappa di spostamento.

Assegnare un profilo dei colori di output

Potete controllare la gestione del colore per ogni elemento di output nella finestra di dialogo Impostazioni modulo di output.  

Nota:

quando esportate nel formato SWF, utilizzate il menu Esporta e non il pannello Coda di rendering, in modo che le impostazioni del modulo di output non siano disponibili per questo tipo di output. Se per il progetto è stata attivata la gestione dei colori, After Effects converte in automatico i colori dallo spazio cromatico di lavoro del progetto allo spazio cromatico sRGB IEC61966-2.1 quando si effettua l’esportazione nel formato SWF.

Il profilo dei colori di output per un elemento sottoposto a rendering determina i calcoli che vengono eseguiti quando si convertono i colori di una composizione sottoposta a rendering dallo spazio cromatico di lavoro del progetto allo spazio colore per il supporto di output. Se non è stato impostato uno spazio di lavoro del progetto, ovvero se per il progetto non è attiva la gestione colore, non potete assegnare un profilo dei colori di output.

Ad esempio, dopo aver creato un filmato in uno spazio cromatico di lavoro HDTV (Rec. 709) per l’output su pellicola, probabilmente vorrete eseguire l’output in uno spazio colore Cineon/DPX codificato nel registro usando un profilo colore di output su pellicola. Se, invece state creando un filmato per televisione ad alta definizione, scegliete un profilo di output HDTV (Rec. 709).

Il profilo dei colori di output dell’elemento di rendering è parte di un modulo di output e viene visualizzato nel gruppo del modulo di output nel pannello Coda di rendering. Potete assegnare più moduli di output a un elemento di rendering, ognuno con il proprio profilo dei colori di output, per poter creare filmati di output per vari supporti da un filmato sottoposto a rendering.

L’opzione Converti in luce lineare determina se i colori vengono convertiti in un profilo dei colori lineare (gamma corrisponde a 1.0) Raramente è consigliabile eseguire l’output in luce lineare per colore a 8 bpc o 16 bpc, pertanto l’impostazione predefinita per Converti in luce lineare è Attiva per 32 bpc. Consultate Risposta tonale e gamma.

Alcuni formati file, ad esempio Photoshop (PSD), PNG, TIFF e JPEG, consentono di incorporare un profilo colori. Se incorporate un profilo colori in un file di output, potete avere una maggiore certezza che i programmi che usano il file interpreteranno correttamente le sue informazioni sui colori.

After Effects sceglie un intento di rendering in base al profilo cromatico di output selezionato. Per la maggior parte dei tipi di output, l’intento di rendering è colorimetrico relativo (con compensazione punto nero); per l’output in negativo della pellicola, l’intento di rendering è colorimetrico assoluto.

Potete impedire la conversione dei colori dallo spazio cromatico di lavoro per un singolo elemento di output selezionando Mantieni RGB nella scheda Gestione del colore della finestra di dialogo Impostazioni modulo di output. Questa opzione mantiene i numeri RGB, non l’aspetto dei colori. La disattivazione della gestione del colore per uno specifico elemento di metraggio è utile quando tale elemento non è destinato alla visualizzazione ma per essere usato come livello di controllo, ad esempio come mappa di spostamento.

  1. Fate clic sul testo sottolineato accanto all’intestazione Modulo di output relativa all’elemento di rendering nel pannello Coda di rendering.
  2. Nella scheda Gestione colore della finestra di dialogo Impostazioni modulo di output, scegliete un valore dal menu Profilo di output.

    Se nel menu Profilo di output non vedete il profilo desiderato, selezionate Mostra tutti i profili disponibili. Questa opzione mostra i profili di colore delle pellicole cinematografiche.

  3. Leggete le informazioni nell’area Descrizione della finestra di dialogo per controllare che la conversione sia quella desiderata, quindi fate clic su OK.

Attivare o disattivare la gestione del colore di visualizzazione

Quando la gestione del colore è attivata, il comportamento predefinito prevede che i valori dei pixel RGB vengano convertiti nello spazio colore del monitor del computer dallo spazio cromatico di lavoro per il progetto. L’aspetto dei colori viene mantenuto, non i numeri RGB. Questo comportamento è adeguato per la maggior parte degli usi ma talvolta è necessario vedere quale sarà l’aspetto effettivo dei colori quando vengono visualizzati per mezzo di un sistema che non usa la gestione del colore. Ad esempio, potrebbe essere necessario vedere quale sarà l’aspetto dei colori quando vengono visualizzati in un browser Web.

Quando la gestione dei colori di visualizzazione è disattivata, i valori dei colori RGB vengono inviati direttamente al monitor, senza alcuna conversione attraverso il profilo del monitor. I numeri RGB vengono mantenuti, non l’aspetto dei colori.

Quando la gestione del colore di visualizzazione è attiva per un visualizzatore, nel pulsante Mostra impostazioni di gestione canali e colori in fondo al visualizzatore appare un segno più giallo.

Per ogni visualizzatore (pannello Composizione, Livello o Metraggio), potete scegliere di gestire i colori di visualizzazione, il che implica la conversione dei colori dallo spazio cromatico di lavoro nello spazio colore del monitor.

  1. Attivate un pannello Composizione, Livello o Metraggio.
  2. Effettuate una delle seguenti operazioni per alternare tra l’attivazione e la disattivazione della gestione del colore di visualizzazione:
    • Fate clic sul pulsante Mostra impostazioni di gestione canali e colori  nella parte inferiore del visualizzatore e scegliete Usa gestione del colore per visualizzazione.

    • Scegliete Visualizza > Usa gestione del colore per visualizzazione.

    • Premete Maiusc+ (sul tastierino numerico).

Le impostazioni di simulazione dell’output (compresa Nessuna simulazione output) rimangono in memoria.

Simulare l’aspetto dei colori su un dispositivo di output diverso

Spesso, dovete visualizzare in anteprima come si presenterà un filmato su un dispositivo diverso dal monitor del computer. Uno degli scopi della gestione del colore è assicurare che i colori mantengano lo stesso aspetto su qualsiasi dispositivo, ma in After Effects non è tuttavia in grado di risolvere ad esempio i seguenti problemi:

  • Un dispositivo di output per il quale state creando il filmato ha un gamut più piccolo dello spazio cromatico di lavoro del progetto, pertanto il dispositivo non è in grado di rappresentare alcuni colori.

  • I colori del filmato vengono visualizzati da un dispositivo o da un software che non usa la gestione del colore per convertire i colori.

Ad esempio, se state creando un filmato usando il monitor di un computer e un monitor video ad alta definizione, potreste avere la necessità di vedere quale sarà il suo aspetto una volta trasferito su una specifica pellicola e proiettato nelle condizioni di visualizzazione di una sala cinematografica standard.

In queste situazioni è opportuno visualizzare un’anteprima dei colori quando vengono visualizzati su un dispositivo diverso dal monitor del computer. La simulazione dell’output richiede la gestione del colore di visualizzazione.

Durante la simulazione dell’output, i colori vengono convertiti dallo spazio cromatico di lavoro per il progetto allo spazio colore del monitor attraverso il seguente flusso.

1. I colori vengono convertiti dallo spazio cromatico di lavoro per il progetto allo spazio colore dell’output.

I colori vengono convertiti dallo spazio cromatico di lavoro nello spazio colore del tipo di output usando il profilo del colore di output (lo stesso che verrà usato per il rendering nell’output finale).

2. I colori vengono convertiti dallo spazio colore di output allo spazio colore del dispositivo di riproduzione simulato.

Se l’opzione Mantieni RGB non è selezionata, i colori vengono convertiti dallo spazio colore di output nello spazio colore del supporto di presentazione usando il profilo di simulazione. Questa impostazione presuppone che il dispositivo simulato esegua anche la gestione del colore e converta i colori per la visualizzazione. L’aspetto dei colori viene mantenuto, non i numeri RGB.

Se l’opzione Mantieni RGB è selezionata, in questa fase i valori di colore non vengono convertiti. Per contro, i valori dei colori RGB numerici vengono preservati e reinterpretati in modo da rientrare nello spazio colore del dispositivo simulato. Questa simulazione viene ad esempio usata per vedere come si presenterà un filmato quando viene riprodotto su un dispositivo diverso da quello per il quale era destinato o che non esegue la gestione del colore.

Nota:

usate Mantieni RGB quando simulate la combinazione di una pellicola di acquisizione e di una pellicola di stampa.

3. I colori vengono convertiti dallo spazio colore di un dispositivo di riproduzione simulato allo spazio colore del monitor.

I colori vengono convertiti dallo spazio colore del dispositivo di presentazione nello spazio colore del monitor del computer usando il profilo del monitor.

Quando create un predefinito di simulazione dell’output, potete scegliere il profilo da usare per ognuna di queste fasi.

Nota:

Anche se state usando una simulazione di output preimpostata, potete scegliere l’opzione Personale nel menu Visualizza > Simula output dopo aver selezionato il predefinito per vedere una rappresentazione delle conversioni di colore e delle reinterpretazioni in corso per quel tipo di simulazione.

La simulazione dell’output si applica solo a un visualizzatore specifico (pannello Composizione, Livello o Metraggio) e funziona solo per le visualizzazioni in anteprima. Le conversioni di colore per la simulazione dell’output vengono eseguite quando i valori vengono inviati alla visualizzazione. I numeri di colore effettivi nel progetto non vengono modificati.

Come con tutte le conversioni dello spazio colore, la simulazione dell’output riduce alquanto le prestazioni per cui potreste non volerla quando eseguite attività che richiedono un’interazione in tempo reale.

Nota:

la mera applicazione dei profili corretti non può compensare i diversi gamut di colore per i vari dispositivi. Ad esempio, i normali monitor LCD per i personal computer non hanno il gamut necessario per simulare completamente l’output HDTV.

Potete premere Maiusc+/ (sul tastierino numerico) per attivare o disattivare la gestione del colore di visualizzazione. Disattivando la gestione del colore di visualizzazione, si disattiva anche la simulazione dell’output. Quando la gestione dei colori dello schermo è disattivata, le impostazioni di simulazione (tra cui Nessuna simulazione output) vengono memorizzate.

Simulare l’output per le anteprime

  1. Attivate un pannello Composizione, Livello o Metraggio.
  2. Scegliete Visualizza > Simula Output e scegliete un tipo di output da simulare.

    Nota:

    la simulazione dell’output poggia sulla gestione del colore di visualizzazione che, per impostazione predefinita, è attivata. Se la visualizzazione della gestione del colore è disattivata, scegliete Visualizza > Usa gestione del colore per visualizzazione.

    Nessuna simulazione output

    La visualizzazione della gestione del colore è attiva ma non viene eseguita alcuna conversione per simulare un tipo di output.

    RGB Macintosh precedente (Gamma 1.8)

    Mostra l’aspetto che avranno i colori una volta visualizzati da un’applicazione senza gestione del colore su un computer Macintosh con un gamma 1.8 (il valore utilizzato dalle versioni Mac OS precedenti a Mac OS X 10.6). Questa opzione non è disponibile qualora sia selezionata l’opzione Linearizza spazio di lavoro.

    RGB Internet standard (sRGB)

    Mostra l’aspetto che avranno i colori una volta visualizzati da un’applicazione senza gestione del colore su un computer Macintosh con un gamma 2.2. Questa opzione non è disponibile qualora sia selezionata l’opzione Linearizza spazio di lavoro.

    Kodak 5218 a Kodak 2383

    Mostra quale sarà l’aspetto dei colori in caso di output su pellicola negativa Kodak 5218 e successivamente proiettati da pellicola positiva Kodak 2383 in una sala cinematografica.

    Nota:

    i profili Anteprima cinematografica DPX e Videocamera standard DPX disponibili in After Effect 7.0 per il comando Prova colori sono stati sostituiti dai profili Kodak 2383 e Kodak 5218 da usare per il comando Simula output.

    Personale

    Se non vedete una voce per il tipo di output che desiderate simulare, potete creare un predefinito personalizzato di simulazione dell’output scegliendo Personale. Potete specificare un profilo da usare per ogni fase di conversione o di reinterpretazione.

    • Per visualizzare in anteprima quale sarà l’aspetto di un filmato in caso di output su un dispositivo e per visualizzarlo su quel dispositivo, usate lo stesso valore per Profilo di output e per Profilo simulazione.

    • Per visualizzare in anteprima quale sarà l’aspetto di un filmato in caso di output su un dispositivo e per visualizzarlo poi su un altro con gestione dei colori, usate valori diversi per Profilo di output e per Profilo simulazione e deselezionate Mantieni RGB.

    • Per visualizzare in anteprima quale sarà l’aspetto di un filmato in caso di output su un dispositivo e di visualizzazione su un altro, usate valori diversi per Profilo di output e per Profilo simulazione e selezionate Mantieni RGB.

Potete scegliere un predefinito di simulazione dell’output per ogni visualizzazione. Le impostazioni personalizzate di simulazione dell’output sono condivise tra tutte le visualizzazioni.

Nota:

Per alternare tra l’assenza di simulazione di output e la simulazione di output utilizzata più di recente, fate clic sul pulsante Mostra impostazioni di gestione canali e colori nella parte inferiore del visualizzatore e scegliete Simula output.

Simulare un tipo di output in un filmato sottoposto a rendering per l’output finale

La gestione colore per la simulazione dell’output riguarda solo le anteprime, ma potete eseguire il rendering di un filmato con un aspetto che simula un particolare tipo di output. Ad esempio, potete eseguire il rendering di un filmato per HDTV che simuli l’aspetto di un film, possibilità che risulta particolarmente utile per le creazione di metraggi non tagliati durante la lavorazione di un film.

  1. Scegliete Livello > Nuovo > Livello di regolazione per creare un nuovo livello di regolazione all’inizio della composizione.
  2. Scegliete Effetto > Utilità > Convertitore profilo colori per applicare il Convertitore profilo colori al livello di regolazione.
  3. Scegliete Modifica > Duplica per duplicare l’effetto.
  4. Nel pannello Controlli effetti, impostate le seguenti opzioni per la prima istanza dell’effetto:

    Profilo di input

    Spazio di lavoro progetto

    Profilo di output

    Il tipo di output da simulare; ad esempio un profilo di densità stampa pellicola, come ad esempio la densità di stampa Kodak 5218/7218

    Intento

    Colorimetrico assoluto

  5. Nel pannello Controlli effetti, impostate le seguenti opzioni per la seconda istanza dell’effetto:

    Profilo di input

    Il tipo di riproduzione da simulare, ad esempio un profilo di visualizzazione in anteprima per sala cinematografica

    Profilo di output

    Lo spazio colore del supporto di output, ad esempio HDTV (Rec. 709)

    Intento

    Colorimetrico relativo

Per attivare e disattivare questo tipo di simulazione dell’output, potete attivare e disattivare il livello di regolazione selezionando e deselezionando il relativo switch Video nel pannello Timeline.

Colori adatti alla trasmissione

L’ampiezza del segnale video analogico è espressa in unità IRE (o volt in video PAL). I valori compresi tra 7,5 e 100 unità IRE sono considerati a prova di trasmissione; i colori compresi in questo intervallo non causano artefatti indesiderati quali disturbi audio e macchie di colore (in pratica, alcuni picchi oltre 100 IRE sono ammessi, ma per semplicità qui è ammesso un valore massimo di 100 IRE). Questo intervallo di 7,5-100 IRE equivale a un intervallo dal nero al bianco di 64-940 in valori a 10 bpc per Y’ in Y’CbCr, che corrisponde a 16-235 in valori a 8 bpc. Pertanto, numerosi dispositivi video e sistemi software comuni interpretano 16 come nero e 235 come bianco, invece di 0 e 255. Questi numeri non corrispondono direttamente a valori RGB.

Se notate che i colori del metraggio importato non sono corretti (i neri non sono sufficientemente neri e i bianchi non sono sufficientemente bianchi) controllate di aver assegnato il profilo dei colori di input corretto. I profili dei colori video comuni in dotazione con After Effects comprendono varianti che rappresentano questi intervalli limitati, ad esempio il profilo dei colori 16-235 HDTV (Rec. 709) che interpreta 16 come nero e 235 come bianco.

Nota:

alcune schede video ed encoder presumono che l’output si trovi nell’intervallo 0-255, pertanto la limitazione dei colori nella composizione e nel filmato sottoposto a rendering può essere ridondante e comportare una compressione indesiderata dell’intervallo di colori. Se i colori del filmato di output sembrano spenti, provate ad assegnare un profilo dei colori di output che usa l’intero intervallo di colori.

Nota:

Se il colore ha un aspetto sfumato, applicate l’effetto Livelli e osservate l’istogramma per vedere se i valori di colore più bassi e più elevati corrispondono o sono simili a 16 e 235. In tal caso, questo metraggio dovrebbe venire interpretato utilizzando uno dei profili di colore di input tra 16 e 235.

Potete usare Colori diffusione televisiva per ridurre la luminanza o la saturazione a un livello sicuro, ma il modo migliore per limitare i colori di output all’intervallo a prova di trasmissione consiste nel creare la composizione in modo che non utilizzi colori al di fuori di questo intervallo. Consultate Effetto Colori diffusione televisiva.

Tenete presenti le seguenti indicazioni:

  • Evitate di usare valori di nero puro e bianco puro.

  • Evitate di usare colori ad elevata saturazione.

  • Eseguite il rendering di un filmato di prova e riproducetelo su un monitor video per essere certi che i colori vengano rappresentati in modo accurato.

Nota:

Invece di utilizzare l’effetto Colori diffusione televisiva per ridurre la luminanza o la saturazione dei colori, potete utilizzare questo effetto con l’opzione Rendi trasparenti pixel non sicuri o Rendi trasparenti pixel sicuri. Applicate l’effetto a un livello di regolazione nella parte superiore della sovrapposizione di livelli per mostrare quali parti dell’immagine si trovano al di fuori dell’intervallo sicuro per la trasmissione.

Il plug-in Color Finesse in dotazione con After Effects include strumenti eccellenti che possono aiutarvi a mantenere i colori entro l’intervallo a prova di trasmissione. Per ulteriori informazioni, consultate la documentazione di Color Finesse nella cartella contenente il plug-in Color Finesse. Consultate Correzione colore, regolazione cromatica e regolazione del colore.

Nota:

After Effects 7.0 disponeva di un’opzione Espandi livelli di luminanza ITU-R 601 nella finestra di dialogo Interpreta metraggio. Quando vengono aperti in After Effects CS3 o versioni successive, agli elementi di metraggio nei progetti creati con questa opzione verrà assegnato un profilo corrispondente.

Questo prodotto è concesso in licenza in base alla licenza di Attribuzione-Non commerciale-Condividi allo stesso modo 3.0 Unported di Creative Commons.  I post su Twitter™ e Facebook non sono coperti dai termini di Creative Commons.

Note legali   |   Informativa sulla privacy online