Panoramica della funzione di tracciamento dei volti

La funzione di tracciamento dei volti consente di individuare e seguire con precisione i volti di persone. Il semplice tracciamento delle maschere consente di applicare rapidamente gli effetti al solo volto, ad esempio per la correzione colore selettiva o la sfocatura del volto di una persona.

Il tracciamento dei volti permette invece di seguire punti specifici del volto, ad esempio le pupille, la bocca e il naso, in modo da poter isolare e intervenire in maggior dettaglio su questi particolari. Ad esempio, potete cambiare il colore degli occhi o esagerare i movimenti della bocca senza dover ricorrere a regolazioni fotogramma per fotogramma.

After Effects consente ora di misurare le caratteristiche facciali. Inoltre il tracciamento delle misurazioni facciali fornisce dettagli come ad esempio entità di apertura della bocca o di un occhio. Ogni punto di dati è isolato e può essere usato per migliorare notevolmente il contenuto. Inoltre, i dati di tracciamento dettagliati possono essere esportati in Adobe Character Animator per l’animazione di personaggi basata sulla recitazione.

La funzione di tracciamento dei volti è prevalentemente automatica, ma potete ottenere risultati migliori avviando l’analisi da un fotogramma contenente un’inquadratura frontale del volto. La precisione di rilevamento dipende inoltre dal livello di illuminazione del volto.

Nel pannello Tracciatore sono disponibili due opzioni di tracciamento:

  • Tracciamento volto (solo contorno): utilizzate questa opzione se desiderate seguire solo il contorno del volto.
  • Tracciamento volto (particolari): utilizzate questa opzione se desiderate individuare la posizione di occhi (comprese sopracciglia e pupille), naso e bocca ed eventualmente estrarre le misure dei vari particolari. Questa opzione è richiesta se desiderate utilizzare i dati di tracciamento in Character Animator.

    Con questa funzione, viene applicato al livello un effetto Punti tracciamento volto. Questo effetto contiene diversi punti di controllo 2D con fotogrammi chiave, ciascuno dei quali è associato a uno dei particolari rilevati (gli angoli degli occhi e della bocca, la posizione delle pupille, la punta del naso ecc.).

Tracciamento del contorno di un volto

  1. In After Effects, scegliete File > Importa > File. Individuate il percorso in cui è stato salvata la ripresa e aggiungetela al progetto.

    Pannello Progetto
  2. Trascinate la ripresa dal pannello Progetto a una composizione per aggiungere un livello.

    Aggiungere un livello alla composizione
  3. Posizionate l’indicatore del tempo corrente (CTI) su un fotogramma contenente un’inquadratura frontale e dritta del volto da seguire.

    Nota:

    Il rilevamento dei volti funziona meglio se il primo fotogramma da seguire contiene una veduta frontale ed eretta del volto.

    Rilevamento volti
  4. Tracciate una maschera attorno al volto, non troppo precisa ma tale da racchiudere gli occhi e la bocca. La maschera definisce l’area in cui verranno cercati i particolari del volto. Se sono selezionate più maschere, viene utilizzata quella superiore.

    Disegnare una maschera
  5. Con la maschera selezionata, scegliete Finestra > Tracciatore per aprire il pannello Tracciatore. Impostate il metodo Tracciamento volto (solo contorno).

    Scegliere un metodo di tracciamento
  6. Nel pannello Tracciatore, eseguite il tracciamento in avanti o indietro di un fotogramma per volta, per verificare che il tracciamento funzioni correttamente; quindi fate clic sul pulsante per iniziare ad analizzare tutti i fotogrammi.

  7. Una volta completata l’analisi, i dati di tracciamento diventano disponibili nella composizione.

    Dati di tracciamento dei volti nella composizione

Tracciamento dei particolari ed estrazioni delle misurazioni facciali

  1. In After Effects, scegliete File > Importa > File. Individuate il percorso in cui è stato salvata la ripresa e aggiungetela al progetto.

  2. Trascinate la ripresa dal pannello Progetto a una composizione per aggiungere un livello.

  3. Posizionate l’indicatore del tempo corrente su un fotogramma contenente un’inquadratura frontale e dritta del volto da seguire.

    Nota:

    Il rilevamento dei volti funziona meglio se il primo fotogramma da seguire contiene una veduta frontale ed eretta del volto.

  4. Tracciate una maschera attorno al volto, non troppo precisa ma tale da racchiudere gli occhi e la bocca. La maschera definisce l’area in cui verranno cercati i particolari del volto. Se sono selezionate più maschere, viene utilizzata quella superiore.

  5. Con la maschera selezionata, scegliete Finestra > Tracciatore per aprire il pannello Tracciatore. Impostate il metodo Tracciamento volto (particolari).

  6. Nel pannello Tracciatore, eseguite il tracciamento in avanti o indietro di un fotogramma per volta, per verificare che il tracciamento funzioni correttamente; quindi fate clic sul pulsante per iniziare ad analizzare tutti i fotogrammi.

  7. Una volta completata l’analisi, i dati di tracciamento diventano disponibili in un nuovo effetto, Punti tracciamento volto. Potete accedere ai dati di tracciamento del volto nella composizione oppure nel pannello Effetti (Finestra > Controllo effetti).

    Controllo effetti Punti tracciamento volto
  8. Portate l’indicatore del tempo corrente su un fotogramma contenente il volto con un’espressione neutra (posa a riposo). Le misurazioni dei volti in altri fotogrammi saranno relative al fotogramma della posa a riposo. Nel pannello Tracciatore, fate clic su Imposta posa a riposo.

  9. Nel pannello Tracciatore, fate clic su Estrai e copia misurazioni volto. Al livello viene aggiunto l’effetto Misurazioni volto e vengono creati fotogrammi chiave in base ai calcoli eseguiti con i dati dei fotogrammi chiave Punti tracciamento volto. Tali dati vengono copiati negli Appunti del sistema e possono essere utilizzati in Character Animator.

    Nota:

    I fotogrammi chiave per le misurazioni del volto sono generati in base ai dati del fotogramma chiave Punti tracciamento volto, in relazione alla posa a riposo (ved. il passaggio 8).

    Controllo effetti Misurazioni volto

Riferimento dei dati di tracciamento dei volti

Punti tracciamento volto

L’effetto Tracciatore volti consente di creare dei punti di controllo per varie caratteristiche facciali, che è possibile visualizzare nel pannello Timeline.

Misurazioni volto

Se avete usato l’opzione Particolari, potete estrarre ulteriori informazioni sotto forma di misurazioni parametriche delle caratteristiche facciali, o Misurazioni volto. Tutte le misurazioni riportate per il volto oggetto del tracciamento sono relative al fotogramma Posa a riposo.

Spostamento volto

Indica la posizione del volto, con uno spostamento dello 0% in corrispondenza del fotogramma Posa a riposo. I dati seguenti sono forniti con valori di spostamento sugli assi x, y e z:

  • Spostamento X
  • Spostamento Y
  • Spostamento Z

Orientamento volto

Indica l’orientamento tridimensionale del volto. L’orientamento è misurato utilizzando i seguenti punti di dati, indicativi degli assi x, y e z:

  • Orientamento X
  • Orientamento Y
  • Orientamento Z

Occhio sx

Indica i vari punti di misurazione per l’occhio sinistro e comprende i seguenti punti:

  • Distanza sopracciglio sx
  • Apertura palpebra sx
  • Sguardo occhio sx X
  • Sguardo occhio sx Y

Occhio dx

Indica i vari punti di misurazione per l’occhio destro e comprende i seguenti punti:

  • Distanza sopracciglio dx
  • Apertura palpebra dx
  • Sguardo occhio dx X
  • Sguardo occhio dx Y

Bocca

Indica i vari punti di misurazione per la bocca e comprende i seguenti punti:

  • Spostamento bocca X
  • Spostamento bocca Y
  • Scala larghezza bocca
  • Altezza scala bocca

Questo prodotto è concesso in licenza in base alla licenza di Attribuzione-Non commerciale-Condividi allo stesso modo 3.0 Unported di Creative Commons.  I post su Twitter™ e Facebook non sono coperti dai termini di Creative Commons.

Note legali   |   Informativa sulla privacy online