Photoshop en Catalina | macOS 10.15

Welke Photoshop-versies zijn compatibel met macOS Catalina?

Photoshop 21.0 & Photoshop 20.0.7 werken met macOS 10.15 (Catalina), maar hebben deze bekende compatibiliteitsproblemen. Het is misschien een goed idee uw huidige versie van macOS te blijven gebruiken totdat deze problemen zijn opgelost.

Adobe raadt klanten aan om hun eigen tests uit te voeren op een partitie die niet voor productiedoeleinden wordt gebruikt, om te controleren of hun huidige hardware en stuurprogramma's werken met het nieuwe besturingssysteem (zoals bijvoorbeeld de printer). 

Als u problemen ondervindt die nog niet zijn gedocumenteerd, rapporteer ze dan op onze feedback-site.

Zijn oudere of doorlopende versies van Photoshop compatibel met macOS Catalina?

Nee, oudere/doorlopende versies van Photoshop zijn niet gemaakt voor of getest op macOS 10.15 (Catalina). Ze worden op geen enkele manier ondersteund voor gebruik op macOS Catalina.

Adobe raadt klanten die oude versies van Photoshop gebruiken niet aan om bij te werken naar macOS Catalina.

Incompatibele versies (versie 19.x en eerder) worden niet weergegeven in de lijst 'Oudere versies' in de Creative Cloud-desktopapp.

Oudere versies maken gebruik van 32-bits licentieonderdelen en installatieprogramma's. Daarom kunnen ze niet worden geïnstalleerd en geactiveerd na een upgrade naar macOS Catalina. Wanneer u een upgrade uitvoert naar macOS Catalina en er al een oudere versie van Photoshop op uw computer is geïnstalleerd, kan Photoshop tot op zekere hoogte werken. U kunt het echter niet opnieuw installeren of activeren na de macOS-upgrade.

Verwijder een oudere versie voordat u een upgrade naar macOS Catalina uitvoert. Het verwijderingsprogramma werkt na de upgrade namelijk niet meer. Als u al een upgrade naar macOS Catalina hebt uitgevoerd, kunt u de Creative Cloud Cleaner Tool gebruiken om oudere versies te verwijderen.

GPU-problemen in macOS Catalina

Probleem

Tijdelijke oplossing

Er kunnen GPU-problemen optreden bij het gebruik van Photoshop in macOS 10.15.7.

Upgrade macOS naar versie 11.3 (Big Sur).
Als u de macOS-versie niet kunt bijwerken naar 11.3, volgt u de tijdelijke oplossing die wordt beschreven in Photoshop en Catalina.

Inhoud van het document kan niet worden bijgewerkt wanneer tussen tabbladen wordt geschakeld en/of andere deelvensters leeg zijn

Probleem

Tijdelijke oplossing

Op macOS 10.15 Catalina wordt het documentvenster niet bijgewerkt met de juiste inhoud van de afbeelding wanneer tussen tabbladen wordt geschakeld of het documentvenster en/of de documentdeelvensters leeg/zwart zijn.

Bijwerken naar macOS 10.15.4

Fout met Opslaan voor web van Adobe

Wanneer u Photoshop op macOS 10.15.x gebruikt en Bestand > Exporteren > Opslaan voor web selecteert, ziet u de fout "Fout met Opslaan voor web van Adobe: kan deze bewerking niet voltooien. Er heeft zich een onbekende fout voorgedaan."

Tijdelijke oplossing

Zorg ervoor dat de naam van het geopende bestand, de naam van het bestand dat u exporteert vanuit Opslaan voor web en de map waarnaar u opslaat alfanumeriek is (alleen cijfers en letters) en geen speciale tekens zoals # en % bevat.

Oplossing

Update Photoshop naar de laatste versie en update macOS naar de huidige versie.

Fout met Opslaan voor web van Adobe: kan deze bewerking niet voltooien. Er heeft zich een onbekende fout voorgedaan.
Fout met Opslaan voor web van Adobe: kan deze bewerking niet voltooien. Er heeft zich een onbekende fout voorgedaan.

Renderen van video start maar wordt nooit voltooid

Wanneer u Bestand> Exporteren> Video renderen... selecteert, wordt het proces nooit voltooid.

Oplossing

Voer een update uit naar Photoshop 21.x

Tijdelijke oplossing voor 20.0.7 of eerder

Start Systeemvoorkeuren in Finder en ga naar Beveiliging en privacy > tabblad Privacy > Volledige schijftoegang. Klik in de linkerbenedenhoek van het dialoogvenster op het vergrendelingspictogram en voer uw beheerdersnaam en -wachtwoord in. Klik op het pictogram + en voeg Photoshop toe om toegang tot uw harde schijf te verlenen.

Beveiliging en privacy

Opties voor bestandsnaamgeving werken niet correct in het dialoogvenster Opslaan als

Als u in Photoshop 20.0.6 de bestandsindeling wijzigt, wordt de extensie van het bestand in het naamveld niet gewijzigd.

Oplossing

Voer een update uit naar Photoshop 21.x of Photoshop 20.0.7. De bestandsextensie wordt standaard verborgen maar zal automatisch overeenkomen met de indeling die is geselecteerd in het pop-upvenster Indeling.

Opmerking:

Photoshop kan een bestand niet openen als de extensie niet overeenkomt met de bestandsindeling, waardoor de volgende fouten optreden:

Als een bestand al is opgeslagen met een niet-overeenkomende extensie, kunt u dit aanpassen zodat het bestand wordt geopend in Photoshop.

Als u zich niet kunt herinneren welk bestandstype het bestand moet zijn, raadpleegt u: Het bestandstype van een document bepalen.

 

Droplets werken niet

Droplets worden gestart maar worden niet uitgevoerd.

Oplossing

Voer een update uit naar Photoshop 21.x of Photoshop 20.0.7 en maak droplets opnieuw.

Apple-kleurkiezer veroorzaakt crash

Als u Voorkeuren > Algemeen... selecteert en Kleurkiezer instelt op 'Apple', crasht Photoshop de tweede keer dat u de kleurkiezer opent.

Oplossing

Voer een update uit naar Photoshop 21.x of Photoshop 20.0.7.

 

Aanvullende opgeloste problemen

Zie Opgeloste problemen in de release van oktober 2019 (versie 20.0.7) voor extra informatie.

Bekende compatibiliteitsproblemen

Adobe heeft de onderstaande compatibiliteitsproblemen gevonden bij het uitvoeren van Photoshop 20.0.7 of later met macOS 10.15 (Catalina).

Photoshop loopt vast bij het opstarten of op een willekeurig moment tijdens het gebruik

Photoshop op macOS 10.15.7 loopt vast bij het opstarten of op een willekeurig moment tijdens het gebruik.

Oplossing

Werk macOS bij naar versie 11.3.

Tijdelijke oplossing

Als u macOS niet kunt bijwerken naar 11.3, doet u het volgende:

  1. Start Photoshop op.
  2. Ga naar Voorkeuren > Prestaties > Geavanceerde instellingen en schakel het selectievakje OpenCL gebruiken uit.
  3. Start Photoshop opnieuw op.

Als u Photoshop niet kunt opstarten om stap 2 hierboven te voltooien, start u uw computer opnieuw op en probeert u het opnieuw.

Aanvullende informatie

OpenCL-gegevens op macOS 10.15.7 kunnen beschadigd raken en fouten veroorzaken in toepassingen die voor het verbeteren van functies afhankelijk zijn van OpenCL. Dit probleem is opgelost in macOS 11.3.

Wanneer u Als kopie inschakelt, wordt 'kopie' niet toegevoegd aan de bestandsnaam

Wanneer u Als kopie inschakelt in het dialoogvenster Opslaan als, wordt 'kopie' niet toegevoegd aan de bestandsnaam.

Oplossing

Werk bij naar Photoshop 22.4 of hoger en gebruik de nieuwe opdracht Kopie opslaan.

Zie Uw bestanden opslaan in Photoshop voor meer informatie.

Tijdelijke oplossing

Bewerk de naam handmatig en voeg 'kopie' toe of verander de naam in een unieke naam.

Kan een bestaand bestand niet overschrijven bij het opslaan met dezelfde bestandsnaam

Photoshop slaat een kopie op in plaats van een bestaand bestand met dezelfde naam te overschrijven.

Oplossing

Werk bij naar Photoshop 22.4 of hoger en gebruik de nieuwe opdracht Kopie opslaan.

Zie Uw bestanden opslaan in Photoshop voor meer informatie.

Tijdelijke oplossingen

Ga als volgt te werk:

  • Geef het opgeslagen bestand handmatig een nieuwe naam en verwijder de tekst 'copy' uit de bestandsnaam.
  • Sla het bestand op een andere locatie op.

Opslaan wordt niet voltooid wanneer op een met exFAT geformatteerde schijf wordt opgeslagen

Het programma kan vastlopen wanneer u bestanden opslaat op met exFAT geformatteerde externe schijven voordat het bestand wordt opgeslagen.

Tijdelijke oplossingen

  • Bestand opslaan op een externe schijf die is geformatteerd met een ander bestandssysteem dan exFAT
  • Sla het bestand op de lokale schijf op en sleep het via de Finder naar de met exFAT geformatteerde schijf.
Opmerking:

We werken met Apple aan een oplossing voor dit probleem.

Plug-ins niet gevonden of kunnen niet worden geverifieerd

Nieuw in Mac 10.15 (Catalina) is dat plug-ins die in quarantaine zijn geplaatst, de Photoshop-fout geven dat 'het bestand niet is gevonden' of een OS-fout dat de plug-in 'niet kan worden geopend omdat de integriteit niet kan worden geverifieerd'.

Dialoogvensters met plug-in-fouten

Dit gebeurt met niet-officiële plug-ins die van internet worden gedownload of op andere manieren worden geïnstalleerd, zoals met slepen en neerzetten.

Oplossing

Gebruik bijgewerkte plug-ins van externe ontwikkelaars die zijn goedgekeurd voor macOS 10.15. Photoshop laadt plug-ins die door Apple zijn erkend.

 

Aanvullende informatie

Klanten die al plug-ins hebben geïnstalleerd en vervolgens upgraden naar macOS 10.15 zouden geen last moeten hebben van dit probleem.

Klanten die upgraden naar macOS 10.15 en vervolgens proberen een plug-in te downloaden en te installeren, kunnen problemen ondervinden.

Opmerking:

Het lijkt alsof plug-ins correct zijn geladen wanneer u bij Help > Systeeminfo kijkt. Dit komt omdat we bij het opstarten alleen basisinformatie over de plug-in verzamelen, zoals de naam. De quarantainecontrole vindt pas plaats als een klant de plug-in probeert te gebruiken, vaak in de vorm van een filter van derden, of een bestand opslaat met behulp van een optionele/externe plug-in voor bestandsindeling.

Tijdelijke oplossing voor oude plug-ins die niet zijn gemaakt voor macOS 10.15

Voor oudere plug-ins die niet door Apple zijn erkend, kunnen klanten met beheerdersbevoegdheden de quarantaine-vlag verwijderen met de volgende opdracht, als de plug-in is geïnstalleerd in de plug-inmap van Photoshop:

sudo xattr -r -d com.apple.quarantine /Applications/Adobe\ Photoshop\ 2019/Plug-ins/<plug-in-name>

Of gebruik de volgende opdracht als de plug-in is geïnstalleerd in de gedeelde plug-inmap van Creative Cloud:

sudo xattr -r -d com.apple.quarantine /Library/Application\ Support/Adobe/Plug-Ins/CC/<plug-in-name>

Lens Profile Creator wordt niet uitgevoerd

De Lens Profile Creator is momenteel 32-bits, maar we onderzoeken of het kan worden bijgewerkt naar een 64-bits hulpprogramma.

Gummetje werkt niet met het aanpassingspenseel

Nadat u de optie Gummetje hebt ingeschakeld voor het aanpassingspenseel, wordt deze uitgeschakeld zodra u schildert en wordt de aanpassing toegevoegd in plaats van gewist.

Oplossing

Dit probleem wordt momenteel door engineering onderzocht.

Wanneer u Nieuw selecteert bij gebruik van een aanpassingspenseel, wordt dit toegevoegd aan een eerder geselecteerd penseel

Door Nieuw te selecteren bij gebruik van een aanpassingspenseel worden de volgende penseelstreken verder gebruikt voor het eerder geselecteerde aanpassingspenseel in plaats van een nieuw penseel.  

Tijdelijke oplossing

Het is mogelijk om op een andere tool te klikken en vervolgens weer op het aanpassingspenseel om een nieuw penseel toe te voegen. 

Oplossing

Dit probleem wordt momenteel door engineering onderzocht.

Kan het penseel niet gebruiken op een verloopaanpassing

Nadat u een verloopaanpassing hebt gemaakt  , kunt u het penseel niet selecteren om iets aan het verloop toe te voegen

Oplossing

Dit probleem wordt momenteel door engineering onderzocht.

Kan Binnen in Radiale aanpassing niet selecteren

Het is niet mogelijk om de optie Binnen te selecteren bij het tekenen van een radiale aanpassing. Als u een radiale aanpassing tekent met de optie Buiten geselecteerd, kunt u de aanpassing niet schakelen naar de optie Binnen.

Oplossing

Dit probleem wordt momenteel door engineering onderzocht.

Extendscript Toolkit werkt niet

De ExtendScript Toolkit, een 32-bits toepassing, werkt niet meer op macOS 10.15.

Oplossing

De ExtendScript Toolkit is vervangen door ExtendScript Debugger 1.1.0.

Crash met alleen terminalopdrachten voor donkere menubalk en Dock

Adobe-logo

Aanmelden bij je account