Create panoramic images with Photomerge

About Photomerge

The Photomerge™ command combines several photographs into one continuous image. For example, you can take five overlapping photographs of a city skyline, and then merge them into a panorama. The Photomerge command can assemble photos that are tiled horizontally as well as vertically.

Source images (top), and completed Photomerge composition (bottom)
Source images (top), and completed Photomerge composition (bottom)

Take pictures for Photomerge

Your source photographs play a large role in panoramic compositions. To avoid problems, follow these guidelines when taking pictures for use with Photomerge:

Overlap images sufficiently

Images should overlap by approximately 40%. If the overlap is less, Photomerge may not be able to automatically assemble the panorama. However, keep in mind that the images shouldn’t overlap too much. If images overlap by 70% or more, Photomerge may not be able to blend the images. Try to keep the individual photos at least somewhat distinct from each other.

Use one focal length

If you use a zoom lens, don’t change the focal length (zoom in or out) while taking your pictures.

Keep the camera level

Although Photomerge can process slight rotations between pictures, a tilt of more than a few degrees can result in errors when the panorama is assembled. Using a tripod with a rotating head helps maintain camera alignment and viewpoint.

Stay in the same position

Try not to change your position as you take a series of photographs, so that the pictures are from the same viewpoint. Using the optical viewfinder with the camera held close to the eye helps keep the viewpoint consistent. Or try using a tripod to keep the camera in the same place.

Avoid using distortion lenses

Distortion lenses can interfere with Photomerge. However, the Auto option adjusts for images taken with fish-eye lenses.

Maintain the same exposure

Avoid using the flash in some pictures and not in others. The blending features in Photomerge helps smooth out different exposures, but extreme differences make alignment difficult. Some digital cameras change exposure settings automatically as you take pictures, so you may need to check your camera settings to be sure that all the images have the same exposure.

Create a Photomerge composition

  1. Choose File > Automate > Photomerge.

  2. Under Source Files in the Photomerge dialog box, choose one of the following from the Use menu:

    Files

    Generates the Photomerge composition using individual files.

    Folders

    Uses all the images stored in a folder to create the Photomerge composition.

  3. Specify which images to use by doing one of the following:
    • To select image files or a folder of images, click the Browse button and navigate to the files or folder.

    • To use the images currently open in Photoshop, click Add Open Files.

    • To remove images from the Source File list, select the file and click the Remove button.

  4. Select a Layout option:

    Auto

    Photoshop analyzes the source images and applies either a Perspective, Cylindrical, and Spherical layout, depending on which produces a better photomerge.

    Perspective

    Creates a consistent composition by designating one of the source images (by default, the middle image) as the reference image. The other images are then transformed (repositioned, stretched or skewed as necessary) so that overlapping content across layers is matched.

    Cylindrical

    Reduces the “bow‑tie” distortion that can occur with the Perspective layout by displaying individual images as on an unfolded cylinder. Overlapping content across files is still matched. The reference image is placed at the center. Best suited for creating wide panoramas.

    Apply cylindrical mapping
    Applying Cylindrical Mapping

    Spherical

    Aligns and transforms the images as if they were for mapping the inside of a sphere, which simulates the experience of viewing a 360-degree panorama. If you have taken a set of images that cover 360 degrees, use this for 360 degree panoramas. You might also use Spherical to produce nice panoramic results with other file sets.

    Collage

    Aligns the layers and matches overlapping content and transforms (rotate or scale) any of the source layers.

    Reposition

    Aligns the layers and matches overlapping content, but does not transform (stretch or skew) any of the source layers.

  5. Select any of the following options:

    Blend Images Together

    Finds the optimal borders between the images and creates seams based on those borders, and color matches the images. With Blend Images Together turned off, a simple rectangular blend is performed. This may be preferable if you intend to retouch the blending masks by hand.

    Vignette Removal

    Removes and performs exposure compensation in images that have darkened edges caused by lens flaws or improper lens shading.

    Geometric Distortion Correction

    Compensates for barrel, pincushion, or fisheye distortion.

    Content Aware Fill Transparent Areas

    Seamlessly fill the transparent areas with similar image content nearby.

  6. Click OK.

Photoshop creates one multi‑layer image from the source images, adding layer masks as needed to create optimal blending where the images overlap. You can edit the layer masks or add adjustment layers to further fine-tune the different areas of the panorama.

Note:

To replace empty areas around image borders, use a content-aware fill. (See Use Content-aware, pattern, or history fills.)

Create 360-degree panoramas

Devices such as the Ricoh Theta V and Insta360One let you capture full 360 panoramic images in a single take. Alternatively, you can combine Photomerge with 3D features to create a 360-degree panorama. First, you stitch together the images to create a panorama; then you use the Spherical Panorama command to wrap the panorama so it’s continuous.

Be sure to photograph a full circle of images with sufficient overlap. Photographing with a pano head on a tripod helps produce better results.

  1. Choose File > Automate > Photomerge.
  2. In the Photomerge dialog box, add the images you want to use.

    Do not include images that cover the top (zenith) or bottom (nadir) of the scene. You’ll add these images later.

  3. Select Spherical for the Layout.

    Note:

    If you photographed with a fisheye lens, select the Auto layout and Geometric Distortion Correction. If Photoshop cannot automatically identify your lens, download the free Adobe Lens Profile Creator from the Adobe website.

  4. (Optional) Select Vignette Removal or Geometric Distortion for the Lens Correction.
  5. (Optional) Select Content Aware Fill Transparent Areas to avoid transparent pixels on the edges of the panoramic image.

  6. Click OK.

  7. Choose 3D > New Shape From Layer > Spherical Panorama.
  8. (Optional) Manually add the top and bottom images into the sphere. You could also paint out any remaining transparent pixels in the 3D spherical panorama layer.

Edit panoramas

Introduced in the October 2017 release of Photoshop CC.

You can edit equirectangular spherical panoramas in Photoshop. With the panorama asset imported and its layer selected, invoke the panoramic viewer by choosing 3D > Spherical Panorama > New Panorama Layer From Selected Layer. Alternatively, directly load a spherical panorama from your system into the viewer by selecting 3D > Spherical Panorama > Import Panorama.

Once you've opened a panorama in the viewer, you can perform a variety of operations on it.

Rotate the camera view around

Photoshop lets you adjust the camera view for your panoramic image.

  1. Select the Move tool.
  2. Click and drag in the view to look around inside the panoramic image.
panorama_rotate-view
Rotate the camera view using the Move tool in Photoshop

Adjust the field of view

The Properties Panel in Photoshop displays the camera properties. Here, you can adjust the field of view of the camera in mm (as in a 35mm camera) or degrees.

You can also click and drag the Axis widget controls available in the lower-left corner of the document window in Photoshop to rotate the camera without switching back to the Move tool.

panorama-adjust-field-view
Adjust the field of view using the Axis widget controls

Paint on the panorama

You can use the painting and adjustment tools available in Photoshop such as the Healing Brush and the Spot Healing Brush to edit the panorama. Filters work only on the visible portion of the panorama. Accordingly, it is recommended that you isolate the image outside the 3D view to apply the filters to your panoramic image.

The workflow given below uses the Spot Healing Brush tool as an example.

  1. Choose File > Open and select the name of the file you want to open.

  2. Choose 3D > Spherical Panorama > New Panorama Layer From Selected Layer.

  3. Select the Spot Healing Brush tool. Ensure that Projection is selected as the Paint System in the Properties panel.

  4. Click the area you want to fix, or click and drag to smooth over imperfections in a larger area. For details, see Retouch with the Spot Healing Brush tool.

    Note:

    • To improve the quality and performance while painting your panoramic image, create a new layer above the panoramic layer. After editing this layer, choose the Merge Down option from the Layers panel menu or press CtrlCommand+E.
    • To apply filters to the entire panorama, double-click the layer titled Spherical Map in the Layers panel, edit as desired, and then save the file. The image automatically gets updated in the spherical layout.

  5. To export the image, choose 3D > Spherical Panorama > Export Panorama.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy