Match colors

Match the color in different images

The Match Color command matches colors between multiple images, between multiple layers, or between multiple selections. It also lets you adjust the colors in an image by changing the luminance, changing the color range, and neutralizing a color cast. The Match Color command works only in RGB mode.

Note:

When you use the Match Color command, the pointer becomes the Eyedropper tool. Use the Eyedropper tool while adjusting the image to view the color pixel values in the Info panel. This panel gives you feedback about changes in color values as you use the Match Color command. See View color values in an image.

The Match Color command matches the colors in one image (the source image) with colors in another image (the target image). Match Color is useful when you’re trying to make the colors in different photos consistent, or when certain colors (such as skin tones) in one image must match the colors in another image.

In addition to matching the color between two images, the Match Color command can match the color between different layers in the same image.

Match the color between two images

  1. (Optional) Make a selection in the source and target images.

    If you don’t make a selection, then the Match Color command matches the overall image statistics between images.

  2. Make the image that you want to change active, and then choose Image > Adjustments > Match Color.

    If you’re applying the Match Color command to a specific layer in the target image, make sure that layer is active when you choose the Match Color command.

  3. From the Source menu in the Image Statistics area of the Match Color dialog box, choose the source image whose colors you’ll be matching in the target image. Choose None when you don’t want to reference a different image to calculate the color adjustment. With None chosen, the target image and the source image are the same.

    If necessary, use the Layer menu to choose the layer from the source image whose colors you want to match. You can also choose Merged from the Layer menu to match the colors from all the layers in the source image.

  4. If you made a selection in the image, do one or more of the following:
    • In the Destination Image area, select Ignore Selection When Applying Adjustment if you’re applying the adjustment to the entire target image. This option ignores the selection in the target image and applies the adjustment to the entire target image.

    • In the Image Statistics area, select Use Selection In Source To Calculate Colors if you made a selection in the source image and want to use the colors in the selection to compute the adjustment. Deselect this option to ignore the selection in the source image, and use the colors from the entire source image to compute the adjustment.

    • In the Image Statistics area, select Use Selection In Target To Calculate Adjustment if you made a selection in the target image and want to use the colors in the selection to calculate the adjustment. Deselect this option to ignore the selection in the target image and compute the adjustment by using the colors of the entire target image.

  5. To automatically remove a color cast in the target image, select the Neutralize option. Make sure that the Preview option is selected so that your image is updated as you make adjustments.
  6. To increase or decrease the brightness in the target image, move the Luminance slider. Alternatively, enter a value in the Luminance box. The maximum value is 200, the minimum is 1, and the default is 100.
  7. To adjust the color saturation in the target image, adjust the Color Intensity slider. Alternatively, enter a value in the Color Intensity box. The maximum value is 200, the minimum is 1 (which produces a grayscale image), and the default is 100.
  8. To control the amount of adjustment applied to the image, move the Fade slider. Moving the slider to the right reduces the adjustment.
  9. Click OK.

Match the color of two layers in the same image

  1. (Optional) Make a selection in the layer you want to match. Use this method when matching a color region (for example, facial skin tones) in one layer with a region in another.

    If you don’t make a selection, then the Match Color matches the colors of the entire source layer.

  2. Make sure that the layer you want to target (apply the color adjustment to) is active, and then choose Image > Adjustments > Match Color.
  3. From the Source menu in the Image Statistics area of the Match Color dialog box, make sure that the image in the Source menu is the same as the target image.
  4. Use the Layer menu to choose the layer whose colors you want to match. You can also choose Merged from the Layer menu to match the colors from all the layers.
  5. If you made a selection in the image, do one or more of the following:
    • In the Destination Image area, select Ignore Selection When Applying Adjustment if you’re applying the adjustment to the entire target layer. This option ignores the selection in the target layer and applies the adjustment to the entire target layer.

    • In the Image Statistics area, select Use Selection In Source To Calculate Colors if you made a selection in the source image and want to use the color in the selection to compute the adjustment. Deselect this option to ignore the selection in the source layer and use the colors in the entire source layer to compute the adjustment.

    • In the Image Statistics area, select Use Selection In Target To Calculate Adjustment if you want to use only the colors in the selected area of the target layer to compute the adjustment. Deselect this option to ignore the selection and use the colors of the entire target layer to compute the adjustment.

  6. To automatically remove a color cast in the target layer, select the Neutralize option. Make sure that the Preview option is selected so that your image is updated as you make adjustments.

  7. To increase or decrease the brightness in the target layer, move the Luminance slider. Alternatively, enter a value in the Luminance box. The maximum value is 200, the minimum is 1, and the default is 100.
  8. To adjust the range of color pixel values in the target layer, adjust the Color Intensity slider. Alternatively, enter a value in the Color Intensity box. The maximum value is 200, the minimum is 1 (which produces a grayscale image), and the default is 100.
  9. To control the amount of adjustment applied to the image, adjust the Fade slider. Moving the slider to the right reduces the amount of adjustment.
  10. Click OK.

Save and apply settings in the Match Color command

  • In the Image Statistics area of the Match Color dialog box, click the Save Statistics button. Name and save the settings.
  • In the Image Statistics area of the Match Color dialog box, click the Load Statistics button. Locate and load the saved settings file.

Replace colors

Replace the color of objects in an image

Photoshop provides several techniques that let you replace the colors of objects. For great flexibility and results, apply a Hue/Saturation adjustment to selected objects. For less flexibility but a convenient grouping of options, use the Replace Color dialog box. For speed but less precision, try the Color Replacement tool.

Video tutorial: Change the color of an object

Video tutorial: Change the color of an object
Deke McClelland

Apply a Hue/Saturation adjustment to selected objects

In most cases, this flexible technique best replaces colors. Because masks and adjustment layers are non-destructive, you can later fine-tune the results with complete freedom. A unique Colorize option makes absolute, rather than relative, color changes (avoiding tinting from original colors).

  1. Select the object you want to change. The Quick Selection tool  often produces good results. For additional techniques, see Select a color range and Refine selection edges.

  2. In the Adjustments panel, click the Hue/Saturation icon.

    The selection becomes a mask on the adjustment layer.

  3. In the Properties panel, change Hue and Saturation settings to replace the object’s color. If the original color tints the new color, select Colorize, and readjust settings. (See Adjust hue and saturation.)

    Note:

    Leave the Lightness setting at zero to maintain contrast. To maintain both contrast and saturation, select the Hue blending mode for the adjustment layer.

  4. If necessary, enlarge or reduce the affected area by painting on the mask with white or black. (See Edit a layer mask.)

For more information, see Adjustments panel overview.

Use the Replace Color dialog box

The Replace Color dialog box combines tools for selecting a color range with HSL sliders for replacing that color. You can also choose the replacement color in the Color Picker.

Replace Color lacks the Colorize option from the Hue/Saturation adjustment, which may be needed for a complete color change. You may also find the adjustment layer technique easier for changing specific objects. However, the Replace Color command is good for global color changes—especially changing out-of-gamut colors for printing.

  1. Choose Image > Adjustments > Replace Color.
  2. (Optional) If you are selecting similar, contiguuous colors in the image, select Localized Color Clusters to build a more accurate mask.
  3. Select a preview option:

    Selection

    Displays the mask in the preview box. Masked areas are black, and unmasked areas are white. Partially masked areas (areas covered with a semitransparent mask) appear as varying levels of gray according to their opacity.

    Image

    Displays the image in the preview box. This option is useful when you are working with a magnified image or have limited screen space.

  4. To select the colors that you want to replace, use the Eyedropper tool  to click in the image or in the preview box to select the areas exposed by the mask.
  5. To refine the selection, do any of the following:
    • Shift-click or use the Add To Sample Eyedropper tool  to add areas.

    • Alt-click (Windows), Option-click (Mac OS), or use the Subtract From Sample Eyedropper tool  to remove areas.

    • Click the Selection Color swatch to open the Color Picker. Use the Color Picker to target the color you want replaced. As you select a color in the Color Picker, the mask in the preview box is updated.

  6. Drag the Fuzziness slider or enter a Fuzziness value to control the degree to which related colors are included in the selection.
  7. Specify a Replacement color by doing either of the following:
    • Drag the Hue, Saturation, and Lightness sliders (or enter values in the text boxes).

    • Double-click the Result swatch and use the Color Picker to select the replacement color.

    Note:

    You cannot replace pure gray, black, or white with a color. However, you can change the Lightness setting. (The Hue and Saturation settings are relative to existing color, so they have no effect.)

  8. (Optional) Click Save to store settings you will later load for other images.

Use the Color Replacement tool

The Color Replacement tool paints over a targeted color with a replacement color. While this tool is good for quick edits, it often proves unsatisfactory, particularly with dark colors and black. If you don’t get good results after experimenting with tool options, see Adjust hue and saturation.

The Color Replacement tool doesn’t work in Bitmap, Indexed, or Multichannel color mode.

  1. Select the Color Replacement tool . (If the tool isn’t visible, access it by holding down the Brush tool.)
  2. In the options bar, choose a brush tip. Generally, you should keep the blending mode set to Color.
  3. For the Sampling option, choose one of the following:

    Continuous 

    Samples colors continuously as you drag.

    Once 

    Replaces the targeted color only in areas containing the color that you first click.

    Background Swatch 

    Replaces only areas containing the current background color.

  4. From the Limits menu, select one of the following:

    Discontiguous

    Replaces the sampled color wherever it occurs under the pointer.

    Contiguous

    Replaces colors that are contiguous with the color immediately under the pointer.

    Find Edges

    Replaces connected areas containing the sampled color while better preserving the sharpness of shape edges.

  5. For Tolerance, choose a low percentage to replace colors very similar to the pixel you click, or raise the percentage to replace a broader range of colors.
  6. To produce a smooth edge in the corrected areas, select Anti-aliased.
  7. Choose a foreground color to replace the unwanted color. (See Choose colors in the toolbox.)
  8. Click the color you want to replace in the image.
  9. Drag in the image to replace the targeted color.

Note:

If the range of replaced colors is too small, increase the Tolerance setting in the options bar.

Mix colors selectively

Make selective color adjustments

Selective color correction is a technique used by high-end scanners and separation programs to change the amount of process colors in each of the primary color components in an image. You can modify the amount of a process color in any primary color selectively—without affecting the other primary colors. For example, you can use selective color correction to dramatically decrease the cyan in the green component of an image while leaving the cyan in the blue component unaltered.

Even though Selective Color uses CMYK colors to correct an image, you can use it on RGB images.

  1. Make sure that the composite channel is selected in the Channels panel. The Selective Color adjustment is available only when you’re viewing the composite channel.
  2. Do one of the following:
    • Click the Selective Color icon  in the Adjustments panel.

    • Choose Layer > New Adjustment Layer > Selective Color. Click OK in the New Layer dialog box.

    Note:

    You can also choose Image > Adjustments > Selective Color. But keep in mind that this method makes direct adjustments to the image layer and discards image information.

  3. Do one of the following:
    • Choose the color you want to adjust from the Colors menu in the Properties panel. You can also choose a Preset that you’ve saved.

    • In the Properties panel, choose a Selective Color preset from the Preset menu.

  4. Select a method in the Properties panel:

    Relative

    Changes the existing amount of cyan, magenta, yellow, or black by its percentage of the total. For example, if you start with a pixel that is 50% magenta and add 10%, 5% is added to the magenta (10% of 50% = 5%) for a total of 55% magenta. (This option cannot adjust pure specular white, which contains no color components.)

    Absolute

    Adjusts the color in absolute values. For example, if you start with a pixel that is 50% magenta and add 10%, the magenta ink is set to a total of 60%.

    Note:

    The adjustment is based on how close a color is to one of the options in the Colors menu. For example, 50% magenta is midway between white and pure magenta and receives a proportionate mix of corrections defined for the two colors.  

  5. Drag the sliders to increase or decrease the components in the selected color.

    You can also save the settings you make for the Selective Color adjustment and reuse the settings on other images.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy