For tasks you perform frequently, you can easily record a number of actions to help you work more efficiently.

Video tutorial: Record actions

Video tutorial: Record actions
Train Simple

Guidelines for recording actions

Keep in mind the following guidelines when recording actions:

  • You can record most—but not all—commands in an action.

  • You can record operations that you perform with the Marquee, Move, Polygon, Lasso, Magic Wand, Crop, Slice, Magic Eraser, Gradient, Paint Bucket, Type, Shape, Notes, Eyedropper, and Color Sampler tools—as well as those that you perform in the History, Swatches, Color, Paths, Channels, Layers, Styles, and Actions panels.

  • Results depend on file and program setting variables, such as the active layer and the foreground color. For example, a 3‑pixel Gaussian blur won’t create the same effect on a 72‑ppi file as on a 144‑ppi file. Nor will Color Balance work on a grayscale file.

  • When you record actions that include specifying settings in dialog boxes and panels, the action will reflect the settings in effect at the time of the recording. If you change a setting in a dialog box or panel while recording an action, the changed value is recorded.

Note:

Most dialog boxes retain the settings specified at the previous use. Check carefully that those are the values you want to record.

  • Modal operations and tools—as well as tools that record position—use the units currently specified for the ruler. A modal operation or tool is one that requires you to press Enter or Return to apply its effect, such as transforming or cropping. Tools that record position include the Marquee, Slice, Gradient, Magic Wand, Lasso, Shape, Path, Eyedropper, and Notes tools.

Note:

If you record an action that will be played on files of different sizes, set the ruler units to percentages. As a result, the action will always play back in the same relative position in the image.

  • You can record the Play command listed on the Actions panel menu to cause one action to play another.

Record an action

When you create a new action, the commands and tools you use are added to the action until you stop recording.

Note:

To guard against mistakes, work in a copy: At the beginning of the action before applying other commands, record the File > Save As command and select As A Copy. Alternatively, you can click the New Snapshot button on the History panel to make a snapshot of the image before recording the action.  

  1. Open a file.
  2. In the Actions panel, click the Create New Action button , or choose New Action from the Actions panel menu.
  3. Enter an action name, select an action set, and set additional options:

    Function Key

    Assigns a keyboard shortcut to the action. You can choose any combination of a function key, the Ctrl key (Windows) or Command key (Mac OS), and the Shift key (for example, Ctrl+Shift+F3), with these exceptions: In Windows, you cannot use the F1 key, nor can you use F4 or F6 with the Ctrl key.

    Note:

    If you assign an action the same shortcut that is used for a command, the shortcut will apply the action rather than the command.

    Color

    Assigns a color for display in Button mode.

  4. Click Begin Recording. The Begin Recording button in the Actions panel turns red .

    Note:

    When recording the Save As command, do not change the filename. If you enter a new filename, that new name is recorded and used each time you run the action. Before saving, if you navigate to a different folder, you can specify a different location without having to specify a filename.

  5. Perform the operations and commands you want to record.

    Not all tasks in actions can be recorded directly; however, you can insert most nonrecordable tasks using commands in the Actions panel menu.

  6. To stop recording, either click the Stop Playing/Recording button, or choose Stop Recording from the Actions panel menu, or press the Esc key.

Note:

To resume recording in the same action, choose Start Recording from the Actions panel menu.

Record a path

The Insert Path command lets you include a complex path (a path created with a pen tool or pasted from Adobe Illustrator) as part of an action. When the action is played back, the work path is set to the recorded path. You can insert a path when recording an action or after it has been recorded.

  1. Do one of the following:
    • Start recording an action.

    • Select an action’s name to record a path at the end of the action.

    • Select a command to record a path after the command.

  2. Select an existing path from the Paths panel.
  3. Choose Insert Path from the Actions panel menu.

If you record multiple Insert Path commands in a single action, each path replaces the previous one in the target file. To add multiple paths, record a Save Path command using the Paths panel after recording each Insert Path command.

Note:

Playing actions that insert complex paths may require significant amounts of memory. If you encounter problems, increase the amount of memory available to Photoshop.

Insert a stop

You can include stops in an action that let you perform a task that cannot be recorded (for example, using a painting tool). After you complete the task, click the Play button in the Actions panel to complete the action.

You can also display a short message when the action reaches the stop as a reminder of what needs to be done before continuing with the action. You can include a Continue button in the message box in case no other task needs to be done.

  1. Choose where to insert the stop by doing one of the following:
    • Select an action’s name to insert a stop at the end of the action.

    • Select a command to insert a stop after the command.

  2. Choose Insert Stop from the Actions panel menu.
  3. Type the message you want to appear.
  4. If you want the option to continue the action without stopping, select Allow Continue.
  5. Click OK.

Note:

You can insert a stop when recording an action or after it has been recorded.

Change settings when playing an action

By default, actions are completed using the values specified when they were originally recorded. If you want to change the settings for a command within an action, you can insert a modal control. A modal control pauses an action so that you can specify values in a dialog box or use a modal tool. (A modal tool requires pressing Enter or Return to apply its effect—once you press Enter or Return, the action resumes its tasks.)

A modal control is indicated by a dialog box icon  to the left of a command, action, or set in the Actions panel. A red dialog box icon  indicates an action or set in which some, but not all, commands are modal. You can’t set a modal control in Button mode.

  • Do one of the following:
    • To enable a modal control for a command within an action, click the box to the left of the command name. Click again to disable the modal control.

    • To enable or disable modal controls for all commands in an action, click the box to the left of the action name.

    • To enable or disable modal controls for all actions in a set, click the box to the left of the set name.

Exclude commands from an action

You can exclude commands that you don’t want to play as part of a recorded action. You can’t exclude commands in Button mode.

  1. If necessary, expand the listing of commands in the action by clicking the triangle to the left of the action name in the Actions panel.
  2. Do one of the following:
    • To exclude a single command, click to clear the check mark to the left of the command name. Click again to include the command.

    • To exclude or include all commands or actions in an action or set, click the check mark to the left of the action or set name.

    • To exclude or include all commands except the selected command, Alt-click (Windows) or Option-click (Mac OS) its check mark.

      To indicate that some of the commands within the action are excluded, the check mark of the parent action turns red.

Insert a non-recordable menu command

You cannot record the painting and toning tools, tool options, View commands, and Window commands. However, you can insert many non-recordable commands into an action using the Insert Menu Item command.

You can insert a command when recording an action, or after it has been recorded. An inserted command doesn’t execute until the action is played, so the file remains unchanged when the command is inserted. No values for the command are recorded in the action. If the command opens a dialog box, the dialog box appears during playback, and the action pauses until you click OK or Cancel.

Note:

When you use the Insert Menu Item command to insert a command that opens a dialog box, you cannot disable the modal control in the Actions panel.

  1. Choose where to insert the menu item:
    • Select an action’s name to insert the item at the end of the action.

    • Select a command to insert the item at the end of the command.

  2. Choose Insert Menu Item from the Actions panel menu.
  3. With the Insert Menu Item dialog box open, choose a command from its menu.
  4. Click OK.

Edit and rerecord actions

You can tweak the settings of any specific command within an action, add commands to an existing action, or step through an entire action and change any or all settings.

Overwrite a single command

  1. In the Actions panel, double-click the command.
  2. Enter the new values, and click OK.

Add commands to an action

  1. Do one of the following:
    • Select the action name to insert a new command at the end of the action.

    • Select a command in the action to insert a command after it.

  2. Click the Begin Recording button, or choose Start Recording from the Actions panel menu.
  3. Record the additional commands.
  4. When finished, click the Stop Playing/Recording button in the Actions panel or choose Stop Recording from the panel menu.

Rearrange commands within an action

  • In the Actions panel, drag a command to its new location within the same or another action. When the highlighted line appears in the desired position, release the mouse button.

Record an action again

  1. Select an action, and choose Record Again from the Actions panel menu.
  2. If a modal tool appears, use the tool to create a different result, and press Enter or Return, or just press Enter or Return to retain the same settings.
  3. If a dialog box appears, change the settings, and click OK to record them, or click Cancel to retain the same values.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy