Hasarlı veya bozuk InDesign dosyalarıyla nasıl sorun giderme yapacağınızı öğrenin.

Sadece belgede çalışırken bir hata veya beklenmeyen başka bir davranış oluşursa InDesign belgesi hasar görebilir. InDesign, sistem çökmesi veya güç kesintilerinin neden olabileceği hasarı önleyebilecek bir otomatik belge kurtarma özelliğine sahiptir. Ancak yazılım çakışmaları, düşük disk alanı veya virüslerin neden olduğu diğer sistem düzeyindeki sorunlardan kaynaklana hasarı önleyemez. Bu sorun giderme kılavuzu, InDesign belgelerindeki hasarı belirlemenize ve düzeltmenize yardımcı olabilir. Ayrıca belge hasarı olduğu gözüken ancak diğer nedenlerle ilgili olan sistem düzeyindeki sorunları belirlemenize ve çözmenize de yardımcı olabilir.

Sistem düzeyindeki sorunları kontrol edin

Sistem düzeyindeki sorunlar, hatalara ve başka beklenmeyen davranışa neden olabilir. Bir belgenin hasarlı olduğunu varsaymadan önce, sisteminizin nispeten sorunsuz olduğundan emin olun. Aşağıdaki belge hasarı sorun giderme işlemlerine devam etmeden önce örneğin bir disk onarım aracını çalıştırmayı ve düzelip düzelmediğini kontrol etmek için belgeyi yeniden açmayı düşün.

Windows: Sabit diskinizi hatalara karşı denetleyin.

Mac OS: Başlatma sorunlarını giderme ve disk bakımı yapma bölümüne bakınız.

Belge hasarı sorunlarını çözme

Aşağıdaki işlemleri sırayla gerçekleştirin. Sorunu belirlediğinizde durun. 

Not:

Tamamladığınız her bir sorun çözme işleminin ardından, InDesign'ı yeniden başlatın ve sorunun düzeltilip düzeltilmediğini görmek için belgenizi açın. Belgeyi şu şekilde açın:

Dosya > Aç'ı seçin, belgenizi seçin ve ardından Kopyala'yı seçin. Belgenizi yeni adla kaydedin ve düzeltilip düzeltilmediğini kontrol edin.

1. Belgenizi yedekleyin.

Sorun çözmeye başlamadan önce, hasarlı belgenizin bir yedek kopyasını oluşturun. Aşağıdaki işlemlerin bir kısmı, belgedeki bilgileri değiştirmenizi veya silmenizi gerektirir. Belgenin bir yedek kopyası, bilgileri kolayca geri yüklemenizi sağlar. Bir belge ağ sürücüsünde veya kaldırılabilir ortamdaysa (örn. CD veya flash bellek), yedeği yerel diske taşıyın.

2. En son InDesign güncellemesini yükleyin.

  • InDesign'da, Yardım > Güncellemeler'i seçin.

-veya-

-veya-

3. Tercih dosyalarınızı yeniden oluşturun.

InDesign eklentiler, özellikler ve uygulamanın kendisi hakkındaki bilgileri tercih dosyalarına kaydeder: InDesign SavedData ve InDesign Defaults dosyaları. Hasarlı bir InDesign tercih dosyası, InDesign belgesi ile beklenmeyen bir davranışa neden olabilir. Tercih dosyalarını yeniden oluşturarak sorunun tercih dosyaları ile ilgili olup olmadığını kolayca belirleyebilirsiniz.

Not:

InDesign tercih dosyalarını yeniden oluşturmak, ayarları varsayılan ayarlara geri yükler böylece eski tercih dosyalarıyla ilişkilendirilen özel ayarları kaybedersiniz. Bu özel ayarları korumak için, eski tercih dosyalarının adını değiştirin.

InDesign tercih dosyalarını yeniden oluşturmak için:

  1. InDesign'dan çıkın.

  2. InDesign'ı yeniden başlatın ve İşletim Sisteminiz için ilgili tuşları basılı tutun:

    • Mac OS X: Control+Option+Command+Shift
    • Windows: Control+Alt+Shift
  3. InDesign tercih dosyalarını silmeniz istendiğinde, Evet'e tıklayın. InDesign, varsayılanlarla ve yeniden oluşturulan tercih dosyalarıyla başlatılır.

    Not:

    Tercih dosyalarını silmeniz istenirse,  tercihlerinizi manuel olarak silebilirsiniz.

  4. Belgeyi açıp düzeltilip düzeltilmediğini kontrol edin. Sorun devam ederse, aşağıdaki 4 adıma geçin.

    Tercih dosyalarınızı manuel olarak silin veya yeniden adlandırın

    Alternatif veya ek olarak:

    • Tercih dosyalarınızı silebilirsiniz (örn. önceki prosedürde olduğu gibi InDesign'ı başlatırken tercihleri silmeniz otomatik olarak istenirse)

    -veya-

    • Tercih dosyalarınızın adını manuel olarak değiştirebilirsiniz (örn. kaybetmek istemediğiniz eski tercih dosyalarıyla ilişkili özel ayarlarınız varsa)

    Bu dosyaları nerede bulabileceğinizi görmek için aşağıdaki tablodan işletim sisteminizi bulun.

    İşletim Sistemi Tercih Dosyalarının Konumları
    Mac OS X

    InDesign Defaults

    Users/[kullanıcı]/Library/Preferences/Adobe InDesign/Version [sürüm]/[dil]/InDesign Defaults

    InDesign SavedData

    Users/[kullanıcı]/Library/Caches/Adobe InDesign/Version [sürüm]/InDesign SavedData

    Windows XP

    InDesign Defaults

    C:\Documents and Settings\[kullanıcı]\Application Data\Adobe\InDesign\Version [sürüm]\InDesign Defaults

    Varsayılan olarak gizlidir. Gizli dosyaların nasıl gösterileceğini öğrenin.

    InDesign SavedData

    C:\Documents and Settings\[kullanıcı]\Local Settings\Application Data\Adobe\InDesign\Version[sürüm]\Caches\InDesign SavedData

    Windows 7/8

    InDesign Defaults

    C:\Users\[kullanıcı]\AppData\Adobe\InDesign\Version[sürüm]\[dil]\InDesign Defaults

    Varsayılan olarak gizlidir. Gizli dosyaların nasıl gösterileceğini öğrenin.

    InDesign SavedData

    C:\Users\[kullanıcı]\AppData\Local\Adobe\InDesign\Version[sürüm]\[dil]\Caches\InDesign SavedData

    Silmeyi veya yeniden adlandırmayı tamamladıktan sonra tercih dosyalarınızı yeniden oluşturmak için InDesign'ı yeniden başlatın ve ardından düzeltilip düzeltilmediğini görmek için belgenizi açın.

    Sorun devam ederse, yeni dosyaları silerek ve eski tercihler dosyalarını orijinal adlarına geri çevirerek orijinal tercihleri geri yükleyin.

4. Belgeyi IDML (InDesign CS4 ve üzeri sürümler) veya INX (InDesign CS3 ve önceki sürümler) biçiminde kaydedin.

  1. Dosyayı InDesign'da açın.

  2. Dosya > Dışa aktar'ı seçin.

  3. Kayıt Türü menüsünden, InDesign Markup (CS4 ve üzeri) veya InDesign Interchange (CS3 ve önceki sürümler) seçeneğini seçin.

  4. Dosya adı ve konumunu belirleyip Kaydet'e tıklayın.

  5. InDesign'da dışa aktarılan IDML veya INX dosyasını açın.

    Sorun çözüldüyse, orijinal belgenizin yerine IDML veya INX dosyasını kullanmaya devam edin. Sorun devam ederse, başka bir adıma geçin.

5. Dönüştürülen belge için kaynak uygulamasında sorun düzeltme yapın.

Belge Adobe PageMaker, QuarkXPress veya InDesign'ın önceki bir sürümünden dönüştürüldüyse, belgeyi yeniden dönüştürmeyi deneyin. Sorun tekrarlanırsa, tekrar dönüştürmeden önce kaynak uygulamada orijinal belgenin hasarını düzeltin. Hasarlı bir PageMaker veya QuarkXPress belgesi, dönüştürdükten sonra da muhtemelen hasarlı kalmaya devam eder.

Hasarlı bir PageMaker yayınında sorun çözmeyle ilgili bilgi için, Hasarlı yayınlarda sorun çözme bölümüne bakınız. Hasarlı QuarkXPress belgesindesorun çözme hakkında daha fazla bilgi için Quark web sitesi'ni ziyaret edin.

6. Karakter ve paragraf stillerini silin.

InDesign'da oluşturduğunuz stiller veya diğer uygulamalarda oluşturduğunuz dosyalarla içe aktarılan stiller hasar görebilir. Bu durumu kontrol etmek için stilleri silin ve belgenizi yeniden kaydedin.

Karakter stillerini silmek için:

  1. InDesign'da belgeyi açın ve Yazım > Karakter Stilleri'ni seçin.

  2. Karakter Stilleri bölmesinde, [Karakter stili yok] hariç bütün stilleri seçin. Birden çok stil seçmek için, Ctrl (Windows) veya Command (Mac OS) tuşunu basılı tutarak stilleri seçin.

  3. Karakter Stilleri menüsünden, Stilleri Sil seçeneğini seçin.

  4. Belgeyi kaydedip, düzeltilip düzeltilmediğini kontrol edin. Sorun devam ederse, paragraf stillerini silmeye çalışın.

Paragraf stillerini silmek için:

  1. InDesign'da belgeyi açın ve Yazım > Paragraf Stilleri'ni seçin.

  2. Paragraf Stilleri bölmesinde, [Karakter stili yok] hariç bütün stilleri seçin. Birden çok stil seçmek için, Ctrl (Windows) veya Command (Mac OS) tuşunu basılı tutarak stilleri seçin.

  3. Paragraf Stilleri menüsünden, Stilleri Sil seçeneğini seçin.

  4. Belgeyi kaydedip, düzeltilip düzeltilmediğini kontrol edin. Sorun devam ederse, aşağıdaki 7. adıma geçin.

7. Font hasarını kontrol edin.

Sorunun hasarlı bir fonttan kaynaklanıp kaynaklanmadığını kontrol etmek için, belgede kullanılan bütün fontları, Arial veya Times New Roman gibi standart bir fontla değiştirin.

Fontları değiştirdikten sonra sorun tekrarlanırsa, fontla ilgili değildir. Sorun tekrarlanmazsa, orijinal font veya fontlar hasar görmüş veya güncelliğini kaybetmiş olabilir. Orijinal fontları yeniden yüklemeyi veya font üreticisinden güncellenmiş sürümleri almayı deneyin.

8. Nesne ve grafiklerde hasar olup olmadığını kontrol edin.

Ana sayfa veya belge sayfasında belirli bir öğenin soruna neden olup olmadığını belirleyin. Öğeleri ayırmak amacıyla öncelikle yapıştırma alanı veya gizli katmandaki gibi gereksiz öğeleri ve boş sayfaları silin.

Sayfaları silmek için:

  1. InDesign'da belgeyi açın ve Pencere > Sayfalar'ı seçin.

  2. Sayfalar panelinde, silmek istediğiniz sayfaları seçmek için Seçim aracını kullanın. Çok sayıda sayfa seçmek için Ctrl (Windows) veya Command (Mac OS) tuşuna basın veya sürekli bir sayfa aralığı seçmek için Shift tuşuna basın.

    Sayfaları silme
    Silmek istediğiniz sayfaları, Sayfalar panelinde seçin.

  3. Sayfalar panelinde, Sil simgesine tıklayın.

  4. Silme işlemini onaylamak için Tamam'a tıklayın.

Bazı sayfaları sildikten sonra sorun tekrarlanırsa, kalan sayfaların yarısını silin ve belgeyi yeni bir adla kaydedin. Sorunu yeniden oluşturmaya çalışın.

  • Sorun tekrarlanırsa, kalan sayfalardan biri hasarlı bir öğe içerebilir. Soruna neden olan sayfayı bulana kadar sayfaları silmeye devam edin.
  • Sorun tekrarlanmazsa, silinen sayfalardan biri hasarlı bir öğe içerebilir. Soruna neden olan sayfayı bulana kadar silinen sayfaları değiştirin.

Soruna neden olan sayfayı bulduktan sonra, içe aktarılan grafikler, InDesign'da çizilen nesneler ve sayfadaki metin çerçeveleri dahil üzerindeki öğeleri kaldırın ve değiştirin.

9. Sayfa öğelerini yeni bir belgeye kopyalayın.

Sayfa öğelerinin yeni bir belgeye kopyalanması yapısal (dahili) hasarı geride bırakır. Sayfa öğelerini yeni bir belgeye kopyaladıktan sonra sorun tekrarlanırsa, öğelerden birinde sorun olup olmadığını görmek için öğeleri teker teker silin.

Sayfa öğelerini yeni bir belgeye kopyalamak için:

  1. InDesign'da orijinal belgeyi açın.

  2. Dosya > Yeni'yi seçin ve Yeni Belge iletişim kutusunda Tamam'a tıklayın.

  3. Her iki belgeyi görüntülemek için Pencere > Döşe'yi seçin.

  4. Etkinleştirmek için orijinal belgeye tıklayın.

  5. Sayfalar panelini açmak için Pencere > Sayfalar'ı seçin.

  6. Yeni belge penceresine bir sayfa veya forma belge sürükleyin. InDesign sayfayı veya forma belgeyi yeni belgeye kopyalayarak, gereken şekilde sayfa ekler.

  7. Yeni belgeyi yeni bir adla kaydedin (orijinal belge adından farklı) ve sorunu yeniden oluşturmaya çalışın.

    • Sorun tekrarlanmazsa, hasar yapısal (örn. ana sayfalarda veya belge sayfalarında) değildir. Öğelerden birinin soruna neden olup olmadığını belirlemek için öğeleri teker teker silin.
    • Sorun tekrarlanmazsa, hasar muhtemelen yapısaldır. Kalan her bir sayfa veya forma sayfa için 4'ten 7'ye kadar olan adımları tekrarlayın.

10. Belgenin başka bir kopyasını alın.

Belgeyi e-posta, FTP veya kaldırılabilir ortam (CD gibi) vasıtasıyla aldıysanız, farklı yolla bir kopya alın. Veya belgenin yeniden gönderilmesini isteyin. Hasarlı ortam veya hatalı e-posta iletimi belgede hasara neden olabilir. Belge e-postayla gönderilirse, verileri korumak için göndericiden (örn. WinZip veya Smith Micro'dan StuffIt kullanarak) belgeyi sıkıştırmasını isteyin.

Diğer öneriler

Hala sorun mu yaşıyorsunuz? Bunları deneyin.

Üçüncü taraf eklentileri kaldırın.

InDesign'dan üçüncü taraf eklentileri kaldırmayı düşünün. Eklentiler bazen dosya bozulmasına neden olabilir. InDesign üçüncü taraf eklenti sorunlarını giderme bölümüne bakınız.

Belgeyi açmak için farklı bir bilgisayar kullanın.

Farklı bir sistem ortamına geçerek, soruna neden olan değişkenleri kaldırabilirsiniz.

Adobe kullanıcılar arası forumlarını ziyaret edin.

Yalnız değilsiniz! Diğer kullanıcılar bir belgede benzer sorunlar yaşamış ve bir çözüm yayınlamış olabilir. InDesign forumları'na bakınız.

Belgeyi yeniden oluşturun.

Tüm çözümler başarısız olursa, belgeyi yeniden oluşturun. Düzenli olarak yedek kopyalar oluşturun ve içe aktarılan öğelerin soruna neden olmadığından emin olmak için belgeyi periyodik olarak test edin.

Bu çalışma Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License kapsamında lisanslanmıştır  Creative Commons şartları, Twitter™ ve Facebook sitelerinde paylaşılanları kapsamaz.

Yasal Uyarılar   |   Çevrimiçi Gizlilik İlkesi