Comptage des objets dans les images

Dernière mise à jour le 29 oct. 2026

Servez-vous du comptage par clics ou des méthodes de sélection pour quantifier les éléments d’image et enregistrer les totaux dans le Journal des mesures.

Le comptage des objets dans les images vous aide à quantifier les éléments pour l’analyse scientifique, la gestion de l’inventaire, le contrôle qualité ou les workflows de collecte de données.Adobe Photoshop propose deux approches de comptage qui enregistrent les résultats dans le Journal des mesures à des fins de suivi et d’export.

Servez-vous de l’Outil Comptage pour les workflows de comptage manuel par clic lorsque les objets sont visuellement distincts mais varient en couleur ou en forme.Servez-vous du comptage automatique avec des sélections lorsque les objets partagent des couleurs similaires et se distinguent bien de l’arrière-plan.Les deux méthodes nécessitent d’activer le point de données Comptage avant d’enregistrer les mesures.

L’Outil Comptage suit chaque clic effectué sur une image et affiche des repères numérotés à chaque emplacement.Vous pouvez créer plusieurs groupes de comptage pour organiser différents types d’objets dans une même image, chacun avec des couleurs et des tailles de repère personnalisables.Les repères de comptage restent modifiables et sont enregistrés avec le document.

Le comptage automatique utilise des outils de sélection pour identifier et compter des zones distinctes en fonction de la similitude des couleurs.Cette méthode fonctionne mieux avec des objets uniformes qui se distinguent de leur environnement, comme les cellules dans les images de microscopie ou les produits sur des tapis convoyeurs.

Comptage manuel des objets avec l’Outil Comptage

Sélectionnez l’Outil Comptage dans la barre d’outils, regroupé avec l’Outil Pipette.

Dans la barre d'options, configurez les paramètres du groupe de comptage en sélectionnant un groupe existant dans le menu Groupe de comptage ou en créant un nouveau groupe à l'aide de l'icône de dossier.

Définissez la couleur, la taille de repère (1-10) et la taille du libellé (8-72) pour les repères de comptage.

Cliquez sur chaque objet de l’image pour ajouter des repères de comptage numérotés.Maintenez Maj enfoncée et faites glisser pour contraindre le déplacement du repère horizontalement ou verticalement lors du repositionnement.

Sélectionnez Analyse > Sélectionner des points de données > Personnalisé, puis activez le point de données Comptage dans la zone Outil Comptage.

Sélectionnez Fenêtre > Journal des mesures pour ouvrir le panneau du journal.

Sélectionnez Analyse > Enregistrer les mesures, ou sélectionnez Enregistrer les mesures dans le panneau Journal des mesures pour enregistrer les données de comptage.

Conseil

Sélectionnez Affichage > Afficher > Comptage pour activer ou désactiver la visibilité des repères de comptage. Appuyez sur Alt et cliquez (Windows) ou sur Option et cliquez (macOS) sur un repère pour le supprimer et mettre à jour le nombre total.

Le Journal des mesures enregistre tous les comptages effectués, avec les noms de documents, les dates et heures, ainsi que les informations d’échelle.Chaque groupe de comptage conserve son propre total cumulé et apparaît en tant qu’entrée distincte lors de l’enregistrement.Pour plus d’informations sur la configuration du Journal des mesures et la définition des échelles de mesure, consultez Utiliser le journal des mesures pour effectuer des mesures.

Comptage automatique d’objets à l’aide de sélections

Sélectionnez l'outil Baguette magique ou sélectionnez Sélection > Plage de couleurs pour créer votre méthode de sélection.

Créez une sélection qui comprend tous les objets que vous souhaitez compter.Pour la Baguette magique, ajustez la Tolérance afin d’optimiser la sélection des objets, puis désactivez les options Anticrènelage et Contigu.Pour la Plage de couleurs, ajustez la Tolérance et les couleurs sélectionnées afin d'affiner les zones sélectionnées.

Sélectionnez Analyse > Sélectionner les points de données > Personnalisé.

Dans la zone Sélections, activez le point de données Comptage, puis sélectionnez OK.

Sélectionnez Fenêtre > Journal des mesures pour ouvrir le panneau correspondant, s’il n’est pas déjà visible.

Passez à un autre outil que l'outil Comptage, puis sélectionnez Analyse > Enregistrer les mesures, ou sélectionnez Enregistrer les mesures dans le panneau Journal des mesures.

Annotation

Lorsque vous enregistrez des comptages à partir de sélections, veillez à ne plus utiliser l’Outil Comptage, sinon l’option Enregistrer les mesures ne sera pas disponible.

Adobe Photoshop compte chaque zone de sélection distincte et enregistre le total dans la colonne Comptage.Plusieurs zones de sélection créent une ligne de synthèse unique affichant les données cumulées, suivie de lignes individuelles pour chaque zone.Chaque zone de sélection est répertoriée comme une entité distincte dans la colonne Libellé et se voit attribuer un numéro unique.

Pour des techniques de sélection avancées utilisant l'outil Baguette magique ou la commande Plage de couleurs, consultez Sélectionner des zones par couleur avec l'outil Baguette magique.