Corriger l’erreur du générateur au lancement d’Adobe Photoshop

Dernière mise à jour le 29 oct. 2026

Découvrez comment corriger l’erreur du générateur dans Adobe Photoshop en vérifiant les paramètres de sécurité, en supprimant les plug-in en conflit et en consultant les journaux.

Generator est une application Node.js qui gère la communication entre Photoshop et les plug-ins Generator.Il fournit la logique de création de ressource pour Exporter sous et Ressources d’image.

Lorsque vous lancez Photoshop ou sélectionnez Fichier > Exporter > Exporter sous, une boîte de dialogue s’affiche avec le message suivant : « Generator rencontre un problème.Quittez Photoshop et réessayez. Si le problème persiste, supprimez tous les plug-ins tiers ou essayez de réinstaller Photoshop. »

Essayez l’une des solutions suivantes dans l’ordre de la liste.

Le logiciel de sécurité bloque Generator

Le logiciel de sécurité ou l’antivirus peut bloquer la communication de Generator sur le port 8010 ou empêcher l’exécution du processus node.

Ouvrez les paramètres du logiciel de sécurité ou de l’antivirus.

Ajoutez Photoshop à la liste des applications autorisées.

Assurez-vous que le port 8010 est ouvert pour Generator.

Ajoutez node.exe à la liste des applications autorisées à l’emplacement C:\Program Files\Adobe\Adobe Photoshop <version>\node.exe sous Windows.

Sous macOS, autorisez le processus node à l’emplacement /Applications/Adobe Photoshop <version>/Adobe Photoshop <version>.app/Contents/MacOS/node.

Sous Windows, autorisez Photoshop à accéder aux dossiers contrôlés.

Redémarrez Photoshop, puis sélectionnez Fichier > Exporter > Exporter sous pour tester Generator.

Un plug-in tiers entre en conflit avec Generator

Les plug-in tiers du dossier Photoshop Generator peuvent être incompatibles avec la version actuelle ou entrer en conflit avec le plug-in par défaut Image Assets.

Windows : C:\Program Files\Adobe\Adobe Photoshop <version>\Plug-ins\Generator

macOS : /Applications/Adobe Photoshop <version>/Plug-ins/Generator

Créez un dossier temporaire sur le bureau nommé Disabled Generator Plug-ins.

Déplacez les dossiers de plug-in tiers vers le dossier temporaire. Laissez le plug-in Image Assets par défaut dans le dossier Generator.

Démarrez Photoshop et sélectionnez Fichier > Exporter > Exporter sous.

Si l’erreur a disparu, rajoutez les plug-in un par un et redémarrez Photoshop après chaque ajout jusqu’à ce que l’erreur réapparaisse.

Laissez le plug-in Image Assets par défaut dans le dossier Generator.Déplacez uniquement les modules que vous avez installés séparément.

Le générateur ne parvient pas à démarrer et vous n’en avez pas besoin

Si vous n’utilisez pas Export As ni Image Assets, désactivez Generator comme solution de contournement.

Lancez Photoshop.

Sous Windows, sélectionnez Édition > Préférences > Modules externes. Sous macOS, sélectionnez Photoshop > Paramètres > Modules externes.

Désélectionnez l’option Activer Generator.

Sélectionnez OK, puis redémarrez Photoshop.

Sélectionner Fichier > Exporter > Export As réactive Generator. Si vous avez besoin de Export As, corrigez l’erreur de Generator au lieu de laisser Generator désactivé.

Les journaux de Generator affichent des erreurs de démarrage

Les journaux de Generator peuvent contenir des informations sur les modules qui ne parviennent pas à se charger ou sur des problèmes système qui empêchent le démarrage de Generator.

Sous Windows, accédez à C:\Users\<username>\AppData\Roaming\Adobe\Adobe Photoshop <version>\Logs\Generator.

Sous macOS, accédez à /Users/<username>/Library/Logs/Adobe/Adobe Photoshop <version>/Generator.

Ouvrez le journal Generator le plus récent et recherchez les messages d’erreur.

Si le dossier Generator n’existe pas, vérifiez que vous disposez de l’autorisation d’écriture pour le dossier parent.

Si vous avez besoin d’une aide supplémentaire, servez-vous de Adobe Log Collector Tool pour collecter les journaux de diagnostic.

Les dossiers Windows AppData et macOS Library sont masqués par défaut. Les instructions pour afficher les fichiers et dossiers masqués dans Windows peuvent vous aider à localiser les journaux Windows.

Des erreurs de Generator se produisent sur Apple Silicon

Si le générateur continue d'échouer sur un Mac avec Apple silicon, exécuter Photoshop avec Rosetta peut aider à déterminer si le problème est lié à la compatibilité du mode natif.

Quittez Photoshop.

Dans Finder, ouvrez Applications et localisez Adobe Photoshop.

Maintenez la touche Control enfoncée et cliquez sur Adobe Photoshop, puis sélectionnez Lire les informations.

Sélectionnez Ouvrir avec Rosetta, puis démarrez Photoshop et testez le générateur.

Si l'erreur persiste, fournissez les journaux du générateur lorsque vous contactez l'assistance Adobe pour obtenir de l'aide.Pour les problèmes liés à Export As sans rapport avec Generator, consultez le guide de dépannage des opérations d’exportation et d’enregistrement.