L'aggiornamento di After Effects CC 2015 (13.6) è ora disponibile.°Karl Soule illustra le funzionalità nuove e modificate introdotte in questovideo.

Per una panoramica sulle novità relative a tutti i servizi e le applicazioni video e audio professionali di Adobe, fate riferimento a°questa pagina. Per dettagli in merito a tutti gli altri aggiornamenti per le varie applicazioni video e audio professionali di Adobe, consultate questa pagina.

Se disponete di un abbonamento Creative Cloud, potete scaricare la nuova versione mediante l'applicazione desktop Creative Cloud. Per informazioni sull'acquisto di un abbonamento Creative Cloud, visitate la pagina dei piani e la pagina con le offerte promozionali attuali.

Se avete domande sulle novità e modifiche descritte in questo documento, visitate il forum degli utenti di After Effects.  Se desiderate inviare richieste di nuove funzioni o segnalazioni di bug, potete farlo qui.

Comportamenti e opzioni di anteprima aggiornati del pannello Anteprima

Dalla versione di After Effects CC 2015 (13.5), il team di After Effects ha ascoltato attentamente il feedback degli utenti sulle modifiche ai comportamenti di anteprima e i controlli del pannello Anteprima. Per dare seguito a tale feedback sono state apportate numerose modifiche nell'ambito dell'aggiornamento di After Effects CC 2015 (13.6).

Le anteprime possono richiedere quasi il doppio del tempo per lo stesso contenuto (rispetto alle versioni precedenti)

È stato ottimizzato il modo in cui i fotogrammi vengono memorizzati e trasformati per il monitor, in modo che sia necessaria solo la metà della memoria per contenuti tipici. Sebbene questa modifica riguardi principalmente l'efficienza della memoria, può contribuire a migliorare il rendering e le prestazioni della riproduzione.

Comportamenti e controlli di caching migliorati

Il controllo Priorità anteprima è stato rimosso.°Questa opzione non esprimeva chiaramente l'azione di modifica del comportamento di caching, quindi veniva usata molto poco. Ora è disponibile un unico comportamento di caching. Il nuovo comportamento di caching è un ibrido tra i comportamenti precedenti di Priorità anteprima, ovvero Frequenza fotogrammi e Lunghezza:

  • Come l'impostazione Frequenza fotogrammi di Priorità anteprima, After Effects esegue il rendering e la memorizzazione di fotogrammi nella cache fino a quando la cache è piena; a quel punto il caching si interrompe. Non è più disponibile un'opzione che consente ad After Effects di estendere un'anteprima oltre i fotogrammi memorizzati nella cache scartando i fotogrammi meno recenti, come avveniva quando Priorità anteprima era impostato su Lunghezza.
  • Come per l'opzione Lunghezza, il nuovo comportamento di caching memorizza solo la cache del monitor (una cache secondaria utilizzata per trasformare i fotogrammi da visualizzare sullo schermo) per un periodo breve prima dell'indicazione di tempo dell'anteprima. In After Effects CC 2015 (13.5), la modalità Frequenza fotogrammi di Priorità anteprima manteneva la cache del monitor per tutti i fotogrammi memorizzati nella cache; ciò non era sufficiente e poteva dare luogo a un'anteprima di breve durata.

È stata aggiunta una nuova opzione Cache prima della riproduzione. Se attivata, After Effects memorizza i fotogrammi nella cache prima di avviare la riproduzione. Questo comportamento è simile all'anteprima RAM nelle versioni precedenti di After Effects. Tuttavia, tenete presente che i fotogrammi non vengono visualizzati nei pannelli Composizione, Livello o Metraggio man mano che vengono memorizzati nella cache. Questa opzione non è attivata per impostazione predefinita per i collegamenti di anteprima. Se si fa clic tenendo premuto il tasto Opzione (MAC) o Alt (Windows) e sul pulsante Ripristina nel pannello Anteprima, l'opzione Cache prima della riproduzione è attivata per TastNum-0.

Modifiche all'anteprima audio

Il controllo Durata anteprima audio in Preferenze > Anteprime è stato rimosso. Questa opzione era in conflitto con l'opzione Intervallo nel pannello anteprima. Se dovete effettuare il rendering dell'audio per un'anteprima, l'audio ora viene sottoposto a rendering per la durata definita dal controllo Intervallo. La nuova opzione di intervallo Riproduci attorno a ora corrente viene utilizzata per emulare il comportamento della preferenza Durata dell'Anteprima audio.

Indipendentemente dall'intervallo, le sequenze audio di lunga durata richiedono più memoria per archiviare l'audio sottoposto a rendering per la riproduzione. Ciò può dare luogo ad anteprime di durata inferiore, oltre a tempi di preparazione dell'anteprima audio più lunghi (nel pannello Informazioni viene visualizzato il messaggio "Mixaggio audio per anteprima in corso").

I comandi Composizione > Anteprima > Anteprima audio sono stati rimossi. Questi comandi di menu, Anteprima audio (da qui in avanti) e Anteprima audio (area di lavoro) descrivevano i comportamenti che ora possono essere modificati nel pannello Anteprima, ora che è possibile configurare le scelte rapide da tastiera per le anteprime solo audio nel pannello Anteprima (vedere di seguito). Per ridurre la confusione, sono stati rimossi. Il comando rimanente, Composizione > Anteprima > Riproduci anteprima corrente può comunque avviare un'anteprima di solo audio, se si tratta dello stato corrente del pannello Anteprima.

Il pulsante Disattiva audio nella parte superiore del pannello Anteprima attiva o disattiva l'audio durante la riproduzione. Inoltre, attiva o disattiva il pulsante Includi audio per la scelta rapida da tastiera che avete utilizzato per avviare l'anteprima.

Per impostare la riproduzione dell'audio all'avvio di un'anteprima, utilizzate il nuovo pulsante Includi audio, descritto di seguito.

Nuovi comandi per determinare cosa succede quando si interrompe un'anteprima

Nelle versioni precedenti di After Effects, fra cui After Effects CC 2015 (13.5), i comportamenti che si verificano quando si interrompeva un'anteprima dipendevano dal tipo di caching utilizzato dall'anteprima e dai tasti di scelta rapida utilizzati per interrompere l'anteprima. Tuttavia, questi comportamenti non potevano essere configurati dall'utente.

Con l'aggiornamento di After Effects CC 2015 (13.6) è possibile configurare i comportamenti di interruzione per ciascun tasto di scelta rapida mediante nuovi controlli nella parte inferiore del pannello Anteprima. Nella sezione del comportamento di interruzione per specifici tasti, è possibile attivare le seguenti opzioni:

  • Se è in corso la memorizzazione in cache, riproduci i fotogrammi memorizzati: se attivate questa opzione e utilizzate questa scelta rapida da tastiera per interrompere un'anteprima prima che venga completata la memorizzazione in cache, viene interrotta solo quest'ultima. La riproduzione dei fotogrammi memorizzati nella cache riprenderà dall'inizio dell'intervallo. Se disattivate questa opzione, quando interrompete un’anteprima con questa scelta rapida, verranno interrotte sia la memorizzazione nella cache, sia la riproduzione.
  • Passa a tempo di anteprima:  se attivate questa opzione e utilizzate questa scelta rapida per interrompere un'anteprima, il tempo corrente viene impostato sulla posizione del tempo di anteprima (ovvero l'ultimo fotogramma di cui è stata eseguita l'anteprima). Se questa opzione è disattivata, il tempo corrente resta nella posizione precedente.

Ora, per la scelta rapida tramite barra spaziatrice, l'opzione "Se è in corso la memorizzazione in cache, riproduci i fotogrammi memorizzati" è disattivata per impostazione predefinita. In After Effects CC (13.5), questo comportamento risultava attivato per la scelta rapida tramite barra spaziatrice e provocava confusione in alcuni utenti.

Nuovi pulsanti Includi per video, audio, sovrapposizioni e controlli di livello

Sotto il controllo di scelta rapida sono disponibili tre pulsanti che controllano se la scelta rapida da tastiera avvia un'anteprima che riproduce il video, l'audio o mostra sovrapposizioni e controlli di livello. Ora potete configurare qualsiasi scelta rapida in modo da avviare un'anteprima con o senza video, audio o sovrapposizioni e controlli di livello.

  • Includi video è una nuova opzione fornita con l'aggiornamento di After Effects CC 2015 (13.6). Quando questa opzione è attivata, nell'anteprima viene riprodotto il video. Quando è disattivata, nell'anteprima non viene riprodotto il video.
  • Includi audio sostituisce la funzionalità precedentemente assegnata al pulsante di Disattiva audio.Quando questa opzione è attivata, nell'anteprima viene riprodotto l'audio. Quando è disattivata, nell'anteprima non viene riprodotto l'audio.
  • Includi sovrapposizioni e controlli livello sostituisce l'opzione Controlli livello nel pannello Anteprima. Quando questa opzione è attivata, l'anteprima mostra le sovrapposizioni (ad esempio griglie e guide) e i controlli di livello per i livelli selezionati come definito nella finestra di dialogo Visualizza > Opzioni di visualizzazione. Quando è disattivato, l'anteprima non mostra le sovrapposizioni. Tenete presente che questa opzione può essere attivata in modo indipendente da Includi video.

Non è possibile disattivare tutte e tre le opzioni contemporaneamente: è necessario mantenere almeno un pulsante abilitato. Se provate a disattivare il terzo pulsante, uno degli altri pulsanti verrà attivato.

Nuove scelte rapide da tastiera configurabili per le anteprime

  • Scelte rapide per l'anteprima del solo audio:°le scelte rapide da tastiera per le anteprime del solo audio, ovvero .(punto decimale) da tastierino numerico e tasto Opzione/Alt/opzione +.(punto decimale) da tastierino numerico sono ora configurabili nel pannello Anteprima.
  • Maiusc + barra spaziatrice: una nuova scelta rapida da tastiera, Maiusc + barra spaziatrice, è stata aggiunta alle scelte rapide da tastiera per l'anteprima. Per impostazione predefinita la scelta rapida Maiusc + barra spaziatrice è configurata in modo simile a 0 da tastierino numerico, eccetto che Riproduci da è impostato su Tempo corrente.
  • Nuove opzioni dell'intervallo, tra cui l'opzione Riproduci attorno a ora corrente.

    La preferenza di durata anteprima audio nella categoria di preferenze per l'anteprima è stata rimossa. Questa opzione era in conflitto con l'opzione Intervallo nel pannello anteprima. Se dovete effettuare il rendering dell'audio per un'anteprima, l'audio ora viene sottoposto a rendering per la durata definita dal controllo Intervallo. La nuova opzione di intervallo Riproduci attorno a ora corrente (vedete di seguito) viene utilizzata per emulare il comportamento della preferenza Durata dell'anteprima audio. Indipendentemente dall'intervallo, le sequenze audio di lunga durata richiedono più memoria per archiviare l'audio sottoposto a rendering per la riproduzione. Ciò può dare luogo ad anteprime di durata inferiore, oltre a tempi di preparazione dell'anteprima audio più lunghi (nel pannello Informazioni viene visualizzato il messaggio "Mixaggio audio per anteprima in corso").

    Il controllo Intervallo include una nuova opzione, Riproduci attorno a ora corrente. Questa si comporta in modo simile al comando Riproduzione continua di Premiere Pro. All’avvio di un'anteprima con Riproduci attorno a ora corrente, il valore di preroll viene sottratto dall'ora corrente, il valore di postroll viene aggiunto all'ora corrente e i fotogrammi intermedi vengono visualizzati in anteprima.

    Per impostare i valori di preroll e postroll, scegliete Riproduci attorno a ora corrente dal menu Intervallo. Impostate i valori di preroll e postroll desiderati, in secondi, quindi fate clic su OK.

    Riproduci attorno a ora corrente è attivato per impostazione predefinita per la scelta rapida dell'anteprima solo tramite . (punto decimale) da tastierino numerico,con valori di preroll pari a 0 secondi e di postroll pari a 30 secondi. Ciò emula la durata della cache predefinita specificata dalla preferenza Durata anteprima audio che è stata rimossa.

    Cambiamento di colore dell'indicatore del tempo corrente

    L’indicatore del tempo corrente (CTI) ora è sempre interamente blu, anche quando l’anteprima viene interrotta. Questo risolve un problema di coerenza tra il CTI e l'indicatore del tempo di anteprima rosso (PTI), che viene visualizzato solo durante l'anteprima per visualizzare il fotogramma sottoposto ad anteprima.

    Miglioramenti dell'interfaccia utente per gli schermi touch, i dispositivi multitouch e schermi di piccole dimensioni

    Man mano che sempre più persone utilizzano After Effects su laptop di piccole dimensioni e tablet, molti dei quali dispongono di schermi touch e dispositivi multitouch, è sempre più fondamentale che After Effects funzioni correttamente anche su piccoli schermi e che sia in grado di sfruttare appieno il potenziale di questi sistemi con input tramite tocco.

    Gruppi di pannelli sovrapposti

    I gruppi di pannelli sovrapposti forniscono l'accesso ai pannelli con un solo clic, lasciando l'area di lavoro pulita e in ordine. I gruppi di pannelli sovrapposti funzionano in modo analogo ai pannelli di Adobe Lightroom.

    I pannelli in un gruppo di pannelli sovrapposti vengono ridotti a icona nelle schede dei pannelli e sono sovrapposti verticalmente. Se fate clic su una scheda del pannello, quest'ultimo si espande; per impostazione predefinita verrà visualizzata solo la scheda selezionata, mentre gli altri pannelli del gruppo verranno ridotti a icona.

    I gruppi di pannelli sovrapposti vengono usati soprattutto per mostrare e nascondere rapidamente i pannelli che vengono visualizzati in genere lungo il lato destro dell'area di lavoro di After Effects, ad esempio Carattere, Paragrafo, Disegno, Pennelli, Tracker e altri pannelli non utilizzati in modo continuativo.

    Per creare un gruppo di pannelli sovrapposti, fate clic sul menu del pannello nella scheda di un pannello qualsiasi del gruppo, quindi scegliete Gruppo di pannelli sovrapposti nel menu Impostazioni gruppo di pannelli.

    Per annullare la sovrapposizione di un gruppo di pannelli, disattivate l'opzione Gruppo di pannelli sovrapposti.

    Potete spostare e ridimensionare i pannelli all'interno di un gruppo di pannelli sovrapposti.

    Quando fate clic su un pannello in un gruppo di pannelli sovrapposti, gli altri pannelli vengono ridotti alle relative schede (modalità singola). Per espandere più di un pannello appartenente a un gruppo contemporaneamente, disattivate Pannelli singoli sovrapposti nel menu Impostazioni gruppo di pannelli per il gruppo in questione.

    A prescindere dalla modalità singola, potete espandere o ridurre simultaneamente tutti i pannelli di un gruppo di pannelli sovrapposti tenendo premuto il tasto Comando (Mac OS) o Ctrl (Windows) e facendo clic sulla scheda di un pannello del gruppo.

    Aree di lavoro e barra dell'area di lavoro

    La nuova barra dell'area di lavoro consente di accedere con un solo clic ad aree di lavoro predefinite o personalizzate. Funziona in modo simile al pannello Aree di lavoro di Premiere Pro CC 2015. Leggete°questo articolo nell'Aiuto di Premiere Pro per imparare come modificare, ordinare e scegliere le aree lavoro nella barra dell'area di lavoro.

    Nelle versioni precedenti di After Effects, le aree di lavoro erano disponibili tramite il menu Area di lavoro sul lato destro del pannello Strumenti. Questa funzione è stata sostituita dalla barra dell'area di lavoro, che occupa il lato destro del pannello Strumenti. Le aree di lavoro che non rientrano nello spazio disponibile vengono visualizzate nel menu Overflow (> >) sul lato destro della barra dell'area di lavoro.

    Quando il pannello strumenti viene spostato dalla posizione iniziale nella parte superiore dell'area di lavoro, la barra dell'area di lavoro viene sostituita dal menu Area di lavoro.

    Potete accedere alle aree di lavoro e la nuova finestra di dialogo Modifica aree di lavoro anche tramite il menu Finestra > Area di lavoro.

    Le nuove aree di lavoro sono state aggiunte per sfruttare i gruppi di pannelli sovrapposti e la barra dell'area di lavoro; inoltre, l'ordine delle aree di lavoro è stato modificato. Per impostazione predefinita, nella barra dell'area di lavoro vengono visualizzate tre aree di lavoro: Pannelli essenziali, Standard e Schermo piccolo. Altre aree di lavoro sono disponibili nel menu Overflow della barra dell'area di lavoro.

    • Ora l'area di lavoro predefinita è Pannelli essenziali. Il layout è simile all'area di lavoro Standard, salvo per il fatto che i pannelli sul lato destro dell'area di lavoro si trovano in un gruppo di pannelli sovrapposti.
    • Standard è la stessa area di lavoro che era disponibile nelle versioni precedenti di After Effects.
    • L'area Schermo piccolo è ottimizzata per l'utilizzo su dispositivi con schermi di piccole dimensioni, compresi portatili, proiettori e notebook touch.

    Nota:

    A causa delle modifiche alle aree di lavoro, non è possibile migrare le aree di lavoro personalizzate da versioni precedenti di After Effects.

    Altri miglioramenti relativi a schede e pannelli

    Le schede dei pannelli possono essere impostate su una dimensione maggiore per una selezione più semplice sui dispositivi touch. Per attivare questa possibilità per tutte le schede in un gruppo di pannelli, fate clic sul menu del pannello di una qualsiasi scheda del gruppo, scegliete Impostazioni gruppo di pannelli, quindi disattivate Schede piccole.

    Quando ridisponete i pannelli in un gruppo di pannelli a schede, gli altri pannelli ora si spostano automaticamente per fare spazio al pannello trascinato. Ciò include lo scorrimento automatico quando trascinate i pannelli nascosti alla fine di un gruppo di pannelli completo.

    Il menu Overflow per i gruppi di pannelli a schede ora mostra tutti i pannelli del gruppo.

    Gesti multitouch per zoom e scorrimento

    Quando utilizzate un dispositivo con input multitouch, come uno schermo tattile (ad esempio Microsoft Surface o Wacom Cintiq Touch) o un trackpad multitouch, potete eseguire zoom e scorrimento nei pannelli Composizione, Livello, Metraggio e Timeline utilizzando i gesti multitouch.

    • zoom: avvicinate le dita tra di loro per diminuire lo zoom o allontanatele per ingrandire l'immagine. Nei pannelli del visualizzatore, questo gesto è simile all'azione che si ottiene tenendo premuto il tasto Alt (Windows) o Opzione (Mac OS) per eseguire lo zoom attorno al puntatore del mouse.
    • panoramica e scorrimento: trascinate con due dita per eseguire la panoramica o scorrere in alto, in basso, a sinistra o a destra nella vista corrente del pannello. Questo gesto consente di eseguire la panoramica come con lo strumento Mano.

    Maggiore fedeltà dei colori

    Con l'aggiornamento di After Effects CC 2015 (13.6) sono state apportate numerose modifiche per ampliare il set di funzioni di gestione del colore di After Effects e migliorare la possibilità di importare risorse da sorgenti diverse, mantenendo le informazioni cromatiche il più fedeli possibile. Ulteriori informazioni sui miglioramenti che stiamo apportando alle applicazioni per colori ultra UH e a intervallo dinamico elevato (HDR) sono disponibili sul blog di Premiere Pro,°qui.

    Tra le piccole modifiche alla gestione del colore, l'interpretazione automatica dei dati del colore è stata ottimizzata in diversi modi: ad esempio, i formati con pixel di colori lineari vengono ora riconosciuti automaticamente e il metraggio HD a mezza risoluzione non viene più identificato con profili colore SD.

    Effetto colore Lumetri

    L'aggiornamento di After Effects CC 2015 (13.6) comprende l'effetto colore Lumetri, che viene aggiunto in modo che la correzione del colore eseguita in Premiere Pro possa essere mantenuta in After Effects quando copiate clip da Premiere Pro ad After Effects, importate un progetto di Premiere Pro in After Effects, oppure utilizzate il comando Sostituisci con composizione After Effects in Premiere Pro.

    IMPORTANTE: lo scopo dell'effetto colore Lumetri in After Effects consiste nel mantenere le regolazioni di colore nelle clip acquisite da Premiere Pro in After Effects. Consultate la documentazione per flussi di lavoro del colore in Premiere Pro per una descrizione dei vari controlli. Potete applicare l'effetto colore Lumetri a qualsiasi livello in After Effects, ma in questo caso noterete che non tutti i comandi vengono duplicati completamente.

    Per ottenere i migliori risultati, impostate la profondità colore del progetto su 32 bit per canale se attivate l'opzione High Dynamic Range nell'effetto colore Lumetri.

    Ulteriori profili ICC per la gestione del colore

    L'aggiornamento di After Effects CC 2015 (13.6) comprende diversi nuovi profili ICC per interpretare correttamente i colori provenienti da diverse sorgenti, compreso il metraggio ARRIRAW, oltre a nuovi profili per la simulazione dell'output di colore e la scelta di uno spazio cromatico di lavoro per il progetto:

    • Profili ARRI Log con ampia gamma di colori
    • Profili di visualizzazione HDTV e UHDTV, che sostituiscono i vecchi profili videocamera 709
    • Profili di DCI e DCDM P3, con più punti bianchi, che sostituiscono i vecchi profili non precisi
    • Profili per aree di lavoro ACES e ACEScg
    • Profili di visualizzazione SDTV, consigliati da utilizzare al posto dei precedenti profilo Rec. Profili 601

    Nuovi moduli di importazione per formati e codec aggiuntivi

    Con l’aggiornamento After Effects CC 2015 (13.6), puoi ora importare riprese HEVC (H.265) e file QuickTime (.mov) con codec Avid DNxHR.

    Flusso di lavoro ottimizzato per l'utilizzo di CC Libraries e Adobe Stock

    La grafica e le risorse video possono essere trascinate direttamente dal pannello Librerie ai pannelli Composizione e Timeline. La risorsa viene importata automaticamente nel progetto; non è più necessario importare e aggiungere la composizione in due passaggi distinti.

    Nella parte superiore del pannello Librerie si trova un nuovo campo di ricerca; dal menu a discesa potete scegliere se eseguire la ricerca nelle librerie o in Adobe stock. Quando eseguite una ricerca in Adobe Stock, i risultati vengono visualizzati nel pannello Librerie.

    Quando passate il mouse sopra i risultati, pulsanti Acquista e Salva anteprima vengono visualizzati sopra l'immagine o il video. Acquista consente di acquistare una licenza per una data risorsa e salvarla nelle librerie, mentre Salva anteprima aggiunge un'anteprima con filigrana di tale risorsa alle librerie. In questa finestra è possibile aggiungere le risorse al progetto After Effects.

    Se desiderate acquistare la licenza di un'immagine o un video di anteprima dopo averli aggiunti alle librerie, fate clic con il pulsante destro del mouse su una risorsa nella libreria, quindi scegliete Acquista immagine o Acquista video. L'immagine o il video di anteprima vengono automaticamente sostituiti con la versione con licenza, senza filigrana.

    IMPORTANTE: in After Effects CC 2015 (13.6), le immagini fisse con licenza non sostituiscono automaticamente le immagini fisse di anteprima. Il problema verrà risolto in una versione futura. Se in una composizione avete utilizzato un'immagine di anteprima fissa per la quale avete acquistato una licenza, potete aggirare il problema in questo modo: aggiungete l'immagine ora coperta da licenza al progetto, quindi tenete premuto il tasto Opzione (MAC) o Alt (Windows) e trascinate l'immagine coperta da licenza dal pannello Progetto sull'immagine di anteprima all'interno della composizione per sostituirla.

    Quando aggiungete un video di Adobe al vostro progetto After Effects, il video viene inizialmente visualizzato come segnaposto (barre colorate) durante il download del file. Una volta completato il download, il segnaposto viene sostituito con il file video. Potete controllare l'avanzamento del download nel nuovo pannello Avanzamento (Finestra > Pannello Avanzamento). Quando acquistate la licenza di un video già utilizzato come anteprima nel progetto, dovrete scaricare anche il video con licenza prima di sostituire l'anteprima.

    Accesso mediante script alle linee di base del testo

    Con l'aggiornamento di After Effects CC 2015 (13.6) potete leggere da uno script le coordinate X,Y della linea di base per un livello di testo. Il nuovo attributo°sourceText.value.baselineLocs°per gli oggetti°TextDocument°restituisce un array di valori a virgola mobile. L’attributo indica l’origine dei valori X e Y della linea di base di ogni riga di testo.

    Il testo che scorre in una casella di testo paragrafo è trattato come più righe di testo.

    L’array restituisce valori a virgola mobile nel seguente formato: line0.start_x, line0.start_y, line0.end_x, line0.end_y, line1.start_x, line1.start_y, line1.end_x, line1.end_y… lineN-1.start_x, lineN-1.start_y, lineN-1.end_x, lineN-1.end_y

    Nota: se una riga non ha caratteri, i valori x e y per l'inizio e la fine saranno il valore a virgola mobile massimo (3.402823466e+38F).

    Nuovo metodo di scripting per generare numeri casuali

    C'è un nuovo metodo di scripting per generare numeri casuali, generateRandomNumber. Vi consigliamo di utilizzare questa funzione invece di Math.random quando volete generare numeri casuali da applicare come valori a un progetto (ad esempio quando utilizzate°setValue).

    Questo nuovo metodo evita il problema che si verificava con°Math.random°: a causa di un problema di contemporaneità di esecuzione con thread CPU multipli, in After Effects CC 2015 (13.5.x) non venivano restituiti valori casuali.

    Esempio di utilizzo del metodo del generateRandomNumber:°


    // cambia la posizione X di tutti i livelli con numeri casuali

    var myComp = app.project.activeItem;
    var x = 0;

    per(var i = 1; i <= myComp.numLayers; i++){

    // Se utilizzate Math.random(), lo script non funziona
    // x = 400*(Math.random()) – 200;
    // utilizzate generateRandomNumber()

    x = 400*(generateRandomNumber()) – 200;
    currentPos = myComp.layer(i).property(“Position”).value;
    myComp.layer(i).property(“Position”).setValue([currentPos[0]+x,currentPos[1]]);
    }

    Plug-in effetto CycoreFX HD 1.8.1

    Il pacchetto di plug-in CycoreFX HD 1.8.1 comprende nuovi effetti, tra cui:

    • CC Vignette: consente di aggiungere o rimuovere una vignettatura. È disponibile un'opzione per mantenere (fissare) le zone di luce per un risultato più realistico.
    • CC HexTile: consente di generare pattern a nido d'ape. Ripete un pattern esagonale, con diverse opzioni compreso un controllo di tipo sfumino unico. Può essere considerato come un'estensione dell’effetto CC Kaleida per generare effetti dinamici negli sfondi.

    Miglioramenti apportati ad Adobe Media Encoder

    I miglioramenti che verranno apportati con la prossima versione di Adobe Media Encoder comprendono novità molto interessanti per gli utenti di After Effects, compresa la possibilità di utilizzare le sequenze di immagini in cartelle esaminate, di pubblicare direttamente in Facebook (oltre a Vimeo e YouTube) e di esportare video HEVC (H.265). Per informazioni dettagliate, fate riferimento a°questa pagina.

    Miglioramenti apportati a Character Animator (Preview 3)

    Character Animator (Preview 3) aggiunge diverse nuove funzionalità e migliora prestazioni e utilizzo in diverse aree. Per informazioni dettagliate, fate riferimento a°questa pagina.

    Varie funzioni nuove e modificate

    • L'opzione Accelerazione hardware per pannelli Composizione, Livello e Metraggio in Preferenze > Visualizzazione è ora attivata. Questa funzione è stata disattivata durante il lavoro di riorganizzazione iniziato con After Effects CC 2015 (13.5), al fine di migliorare le prestazioni.
    • Il fotogramma di cui state eseguendo il rendering nella coda viene visualizzato anche nel pannello Composizione. Questa funzione è stata disattivata durante il lavoro di riorganizzazione iniziato con After Effects CC 2015 (13.5), al fine di migliorare le prestazioni.
    • La libreria OptiX di Nvidia è stata aggiornata. Ora è possibile utilizzare GPU con architettura Maxwell (ad esempio, GTX 970, GTX 980) per il rendering 3D ray tracing su Windows.
    • Il comando Taglia composizione in base all'area di lavoro è ora accessibile mediante una scelta rapida da tastiera: Comando + Maiusc + X (Mac OS) o Ctrl + Maiusc + X (Windows).
    • Il comando Nuova composizione da selezione è ora accessibile mediante una scelta rapida da tastiera: Opzione + \ (Mac OS) o Alt + \ (Windows)
    • Il formato MXF OP1a è stato rimosso dalla coda di rendering di After Effects. Per esportare nel formato MXF OP1a, utilizzate Adobe Media Encoder.
    • I file possono essere trascinati dal finder (Mac OS) o da Esplora risorse (Windows) direttamente sui pannelli Composizione e Timeline. Il file viene importato automaticamente nel progetto e viene creato un livello in base all'elemento di metraggio; non è più necessario incorporare il file e aggiungere un livello basato sul metraggio in passaggi separati.
    • L’indicatore del tempo corrente (CTI) ora è sempre interamente blu, anche quando l'anteprima viene interrotta. Questo risolve un problema di coerenza tra il CTI e l'indicatore del tempo di anteprima rosso (PTI), che viene visualizzato solo durante l'anteprima.
    • I fotogrammi chiave vaganti utilizzano una nuova icona, più facilmente riconoscibile.
    • Aggiornamento del plug-in Synthetic Aperture Color Finesse (3.0.14) con diverse correzioni di bug

    Principali correzioni di bug

    • Quando si esporta dalla coda di rendering, le tracce audio non sono più mute.
    • Il tracciamento del movimento (tracciatore movimento 2D) non causa più il blocco di After Effects in determinate condizioni, soprattutto con fotogrammi ad alta risoluzione (ad esempio 4K).
    • I pannelli ScriptUI ora vengono visualizzati e ridimensionati correttamente su monitor con valori DPI alti su Windows.
    • Lo scorrimento orizzontale nel pannello Timeline funziona nuovamente quando il pannello viene visualizzato su un monitor secondario posizionato a sinistra di quello principale.
    • Ora non dovrebbero più verificarsi ritardi nello spostamento verso l'alto del puntatore del mouse quando trascinate fotogrammi chiave o punti di attacco e stacco del livello nel pannello Timeline.
    • La barra di avanzamento del processo di rendering nei pannelli Composizione e Livello è più reattiva durante il rendering di fotogrammi di lunga durata.
    • La modifica del testo di origine di un livello di testo non causa più la mancata riuscita delle espressioni quando viene fatto riferimento al nome del livello di testo.
    • Quando il file utilizzato dal progetto aperto risulta mancante, After Effects ora avvisa l'utente una sola volta, non due.
    • Le viste N-up nel pannello Composizione ora mostrano i triangoli di campo attivo in blu anziché in giallo.
    • Con lo strumento Sposta sotto è di nuovo possibile agganciare gli assi 3D in un livello 3D.
    • I pulsanti di direzione per definire la forma del livello nel pannello Timeline ora includono funzioni di evidenziazione e contrasto distinte, in modo che sia chiara la differenza tra stati selezionati e non selezionati.
    • L'annullamento dell'azione dopo avere utilizzato Modifica originale su file Camera Raw non causa più l'arresto anomalo di After Effects.
    • Le sequenze DNG create dal firmware Magic Lantern per le fotocamere Canon ora vengono aggiornate correttamente quando si modificano le impostazioni di Camera Raw tramite la finestra di dialogo Interpreta metraggio.
    • Quando si ricarica una sequenza Camera Raw dopo aver modificato le impostazioni di Camera Raw della sequenza in un'altra applicazione, (ad esempio Photoshop) ora le impostazioni aggiornate vengono caricate correttamente.
    • Modifica originale ora funziona di nuovo correttamente per i file di Camera Raw singoli (non appartenenti a una sequenza).
    • Quando si applicano impostazioni memorizzate per Interpreta metraggio a una sequenza di immagini fisse che utilizza file collaterali XMP (ovvero i formati Camera Raw), tali impostazioni vengono ora applicate anche al primo fotogramma della sequenza.
    • Quando impostate un livello di metraggio come livello guida, se avete modificato la relativa frequenza fotogrammi Interpreta metraggio, non viene più visualizzato il messaggio di errore {nessun contesto corrente}.
    • L'applicazione di un valore di animazione predefinito che contiene l'effetto Lampi obsoleto non causa più l'arresto anomalo di After Effects.
    • La sostituzione del metraggio duplicato non causa più la visualizzazione della cache relativa al metraggio sostituito.
    • L'applicazione dell'effetto Intervallo colori a una composizione nidificata in cui è attivata l'opzione Comprimi trasformazioni e che contiene un livello in cui la scala è impostata su 0% non causa più l'arresto anomalo di After Effects.
    • L'applicazione dell'effetto Intervallo colori a un livello di regolazione per cui l'opzione Rasterizza in modo continuo è attivata non causa più l'arresto anomalo di After Effects.
    • I controlli per gli effetti Livelli, Estrai, Trasparenza colore lineare e Intervallo colore ora vengono aggiornati correttamente durante le interazioni.
    • I tratti di Clone Stamp non subiscono più offset inaspettati nel tempo.
    • L'utilizzo del metodo di scripting copyToComp°non causa più l'arresto anomalo di After Effects quando il livello ha un livello superiore.
    • Il metodo di scripting°valueAtTime(time, false)°ora aspetta che le espressioni che richiedono più tempo per l'elaborazione, ad esempio sampleImage, terminino la valutazione prima di restituire il risultato.
    • After Effects non si arresta più in modo anomalo quando si fa clic sui pulsanti OK o Annulla in una finestra di dialogo di scriptUI con pannelli a schede.
    • I collegamenti simbolici nella cartella degli script di After Effects in Mac OS ora si caricano correttamente.
    • After Effects ora viene avviato correttamente anche se vengono utilizzate le virgolette singole o doppie invece delle frecce doppie bidirezionali nel file Interpretation Rules.txt. (Si tratta di una situazione comune quando si utilizza TextEdit per modificare il file senza disattivare l'opzione Virgolette smart).
    • La risoluzione della mappa dell'ombra non viene più ripristinata alle dimensioni della composizione dopo aver fatto clic su OK nella finestra di dialogo delle opzioni del modulo di rendering 3D classico.
    • After Effects non si blocca più quando l'editor grafico viene visualizzato durante l'elaborazione di un'espressione di nuova mappatura del tempo.
    • L'esportazione nel codec Photo-JPEG di QuickTime non causa più scostamenti nei colori. È stato risolto un problema per i codec Motion JPEG A and B di QuickTime. In entrambi i casi viene usato il formato di pixel corretto per i codec (YUV o Rec.601 Rec.709).
    • I canali alfa premoltiplicati nel codec Apple ProRes 4444 per il metraggio ora vengono sottoposti al rendering nel modo corretto.
    • L'audio non viene più sottoposto a rendering quando viene avviata un'anteprima con audio disattivato. Non viene più visualizzato il messaggio "Mixaggio audio per anteprima in corso" nel pannello Informazioni se l'audio è disattivato. Se l'audio viene attivato durante l'anteprima, il rendering dell'audio ha inizio.
    • I cursori per regolare i punti di attacco e stacco dell'area di lavoro non risultano più sfasati.
    • È stato corretto un problema per cui, se un plug-in causava l'arresto anomalo di After Effects, la causa dell'errore non veniva segnalata e l'utente non poteva salvare il progetto.
    • Le proporzioni dei pixel non quadrati nei file DPX ora vengono riconosciute.
    • Se si incollano i dati delle forme di mocha AE, l'effetto mocha shape viene applicato correttamente.
    • La descrizione comandi sul pulsante Riproduci/Stop del pannello Anteprima ora diventa Riproduci/Interrompi rendering/Interrompi riproduzione se l'opzione "Se è in corso la memorizzazione in cache, riproduci i fotogrammi memorizzati" è attivata.
    • Il metraggio HD a mezza risoluzione non viene più identificato con profili colore SDTV.
    • Sono state migliorate le prestazioni delle espressioni sui livelli con nuova mappatura del tempo. In questo modo si riduce il tempo di rendering per l'audio sui livelli con nuova mappatura del tempo ed espressioni.
    • La duplicazione degli elementi nel pannello Progetto non determina più un risultato di rendering non corretto nelle composizioni.
    • È stato corretto un problema per cui le anteprime di fotogrammi con rendering lento non potevano essere interrotte.
    • Sono state migliorate le prestazioni durante l'applicazione dell'assistente per fotogrammi chiave Scala esponenziale a più fotogrammi chiave.
    • Mercury Transmit ora mostra anche il secondo monitor quando passate a un'altra applicazione e poi tornate ad After Effects in Mac OS X v10.11 (El Capitan).
    • Se trascinate il tempo nel pannello Metraggio, il software non tenterà più di passare al downsampling con risoluzione adattata.
    Se desiderate inviare dei suggerimenti relativi a problemi da risolvere in un aggiornamento successivo, compilate una segnalazione bug o una richiesta di funzionalità qui. Potete inoltre contattarci tramite il forum utenti di After Effects

    Questo prodotto è concesso in licenza in base alla licenza di Attribuzione-Non commerciale-Condividi allo stesso modo 3.0 Unported di Creative Commons.  I post su Twitter™ e Facebook non sono coperti dai termini di Creative Commons.

    Note legali   |   Informativa sulla privacy online