用户指南 取消(C)

管理形状路径和蒙版并对其进行动画制作

  1. After Effects 用户指南
  2. Beta 版
    1. Beta 版项目概述
    2. After Effects Beta 版主页
    3. Beta 版中的功能
      1. “属性”面板(Beta 版)
  3. 快速入门
    1. After Effects 快速入门
    2. After Effects 的新增功能 
    3. 发行说明 | After Effects
    4. After Effects 系统要求
    5. After Effects 中的键盘快捷键
    6. 支持的文件格式 | After Effects
    7. 硬件建议
    8. 适用于 Apple Silicon 的 After Effects
    9. 规划和设置
    10. 设置和安装
  4. 工作区
    1. 常规用户界面项
    2. 了解 After Effects 界面
    3. 工作流程
    4. 工作区、面板和查看器
  5. 项目与合成
    1. 项目
    2. 合成基础知识
    3. 预合成、嵌套和预渲染
    4. 使用合成分析器查看详细的性能信息
    5. CINEMA 4D 合成渲染器
  6. 导入素材
    1. 准备并导入静止图像
    2. 从 After Effects 和 Adobe Premiere Pro 导入
    3. 导入和解释视频与音频
    4. 准备和导入 3D 图像文件
    5. 导入和解释素材项目
    6. 使用素材项目
    7. 使用“场景编辑检测”检测编辑点
    8. XMP 元数据
  7. 文本和图形
    1. 文本
      1. 设置字符格式和“字符”面板
      2. 文本效果
      3. 创建和编辑文本图层
      4. 设置段落格式和“段落”面板
      5. 凸出文本和形状图层
      6. 为文本设置动画
      7. 文本动画的示例和资源
      8. 实时文本模板
    2. 动态图形
      1. 在 After Effects 中使用动态图形模板
      2. 使用表达式在动态图形模板中创建下拉列表
      3. 使用“基本属性”创建动态图形模板
      4. 替换动态图形模板和基本属性中的图像和视频
  8. 绘图、绘画和路径
    1. 形状图层、路径和矢量图形的概述
    2. 绘画工具:笔刷、仿制图章和橡皮擦
    3. 将形状描边椎体化的方法
    4. 形状图层的形状属性、绘画操作和路径操作
    5. 使用“位移路径”形状效果更改形状
    6. 创建形状
    7. 创建蒙版
    8. 使用内容识别填充面板,移除视频中的对象
    9. Roto 笔刷和调整遮罩
  9. 图层、标记和摄像机
    1. 选择和排列图层
    2. 混合模式和图层样式
    3. 3D 图层
    4. 图层属性
    5. 创建图层
    6. 管理图层
    7. 图层标记和合成标记
    8. 摄像机、光和目标点
  10. 动画、关键帧、运动跟踪和抠像
    1. 动画
      1. 动画基础知识
      2. 使用人偶工具制作动画
      3. 管理形状路径和蒙版并对其进行动画制作
      4. 使用 After Effects 为 Sketch 和 Capture 形状制作动画
      5. 分类动画工具
      6. 使用数据驱动的动画
    2. 关键帧
      1. 关键帧插值
      2. 设置、选择和删除关键帧
      3. 编辑、移动和复制关键帧
    3. 运动跟踪
      1. 跟踪和稳定运动
      2. 人脸跟踪
      3. 蒙版跟踪
      4. 蒙版引用
      5. 速度
      6. 时间拉伸和时间重映射
      7. 时间码和时间显示单位
    4. 抠像
      1. 抠像
      2. 抠像效果
  11. 透明度与合成
    1. 合成和透明度概述及资源
    2. Alpha 通道、蒙版和遮罩
  12. 调整颜色
    1. 颜色基础知识
    2. 使用 Adobe Color Themes 扩展
    3. 色彩管理
    4. 颜色校正效果
  13. 效果和动画预设
    1. 效果和动画预设概述
    2. 效果列表
    3. 模拟效果
    4. 风格化效果
    5. 音频效果
    6. 扭曲效果
    7. 透视效果
    8. 通道效果
    9. 生成效果
    10. 过渡效果
    11. 果冻效应修复效果
    12. 模糊和锐化效果
    13. 3D 通道效果
    14. 实用效果
    15. 遮罩效果
    16. 杂色和颗粒效果
    17. 保留细节放大效果
    18. 旧版效果
  14. 表达式和自动化
    1. 表达式
      1. 表达式基础知识
      2. 了解表达式语言
      3. 使用表达式控件
      4. JavaScript 与旧版 ExtendScript 表达式引擎之间的语法差别
      5. 正在编辑表达式
      6. 表达式错误
      7. 使用表达式编辑器
      8. 使用表达式编辑和访问文本属性
      9. 表达式语言引用
      10. 表达式示例
    2. 自动化
      1. 自动化
      2. 脚本
  15. 沉浸式视频、VR 和 3D
    1. 在 After Effects 中构造 VR 环境
    2. 应用沉浸式视频效果
    3. 用于 VR/360 视频的合成工具
    4. 跟踪 3D 摄像机运动
    5. 使用 3D 设计空间
    6. 3D 变换 Gizmo
    7. 使用 3D 动画执行更多操作
    8. 使用实时引擎实时预览对 3D 设计的更改
    9. 向图形添加响应式设计 
  16. 视图和预览
    1. 预览
    2. 使用 Mercury Transmit 进行视频预览
    3. 修改和使用视图
  17. 渲染和导出
    1. 渲染和导出基础知识
    2. 将 After Effects 项目导出为 Adobe Premiere Pro 项目
    3. 转换影片
    4. 多帧渲染
    5. 自动渲染和网络渲染
    6. 渲染和导出静止图像及静止图像序列
    7. 在 After Effects 中使用 GoPro CineForm 编解码器
  18. 使用其他应用程序
    1. Dynamic Link 和 After Effects
    2. 使用 After Effects 和其他应用程序
    3. After Effects 中的同步设置
    4. After Effects 中的 Creative Cloud Libraries
    5. 增效工具
    6. CINEMA 4D 和 Cineware
  19. 协作:Frame.io 和团队项目
    1. 在 Premiere Pro 和 After Effects 中协作
    2. Frame.io
      1. 安装和激活 Frame.io
      2. 将 Frame.io 与 Premiere Pro 和 After Effects 配合使用
      3. 常见问题解答
    3. 团队项目
      1. 开始使用团队项目
      2. 创建团队项目
      3. 使用团队项目进行协作
  20. 内存、存储、性能
    1. 内存和存储
    2. 提高性能
    3. 首选项
    4. After Effects 的 GPU 和 GPU 驱动程序要求

您对蒙版路径和形状路径进行动画制作的方式与对以下属性进行动画制作的方式大致相同:为“蒙版路径”或“路径”属性设置关键帧,在每个关键帧处设置路径,及 After Effects 将在这些指定值之间插值。

转描简介和资源

转描(通常称为 Roto)是使用影片中的视觉元素作为参考,在影片的帧上进行绘制或绘画。一种常用的动态抠像是围绕影片中的对象跟踪路径并使用该路径作为将对象与其背景分开的蒙版。这允许您将对象和背景分开处理,以便执行一些操作,如将不同效果应用于对象而非其背景,或替换背景。

注意:

After Effects 包括“旋转画笔”和“调整边缘”工具,可用于完成与常规转描一样的许多任务,但耗时大为减少。有关使用“旋转画笔”工具的信息,请参阅旋转画笔、调整边缘和优化遮罩

注意:

如果背景或前景对象颜色一致清楚,您可以使用颜色抠像而非动态抠像删除背景或对象。如果拍摄素材时考虑到颜色抠像,与动态抠像相比颜色抠像更简单。(请参阅抠像简介和工作流程。)

After Effects 中的转描主要是绘制蒙版、对蒙版路径进行动画制作,然后使用这些蒙版定义遮罩。许多其他任务和技术使此任务更容易,如先在对象上使用运动跟踪,再开始绘制蒙版,然后使用运动跟踪数据来使蒙版或遮罩自动跟随对象。

动态抠像技巧

  • 开始绘制蒙版之后,立即按下 Alt+Shift+M (Windows) 或 Option+Shift+M (Mac OS) 打开该蒙版的关键帧,然后设置关键帧。这样,您不会逐帧编辑蒙版几分钟(或更长时间),才意识到您因为忘记单击秒表以对蒙版路径进行动画设置,而丢失了上一帧上的所有工作。
  • 在(锁定的)素材图层上方,关闭视频(眼球)开关,在白色纯色图层上绘制蒙版。这样,在您操作蒙版时,不会出现意外移动素材图层的风险,您也可以更轻松地将跟踪数据应用于蒙版。(您将跟踪数据应用于持有蒙版的不可见纯色图层。)这也意味着,您每次操作蒙版时,不会失去缓存的预览帧。(请参阅切换图层或属性组的可见性或影响锁定或解锁图层。)
  • 打开“保持固定顶点计数”首选项。(请参阅为贝塞尔曲线路径指定第一个顶点。)
  • 如果可能,变换(旋转、缩放、移动)整个蒙版或一组蒙版顶点,而不是分别移动各个顶点。这一方面是为了提高效率,另一方面是为了避免跨帧的不一致运动所产生的震颤。(请参阅在自由变换模式中移动顶点。)
  • 与手动动态抠像相比,手动运动跟踪不那么费时。您对获取现场和对象的各部分的良好跟踪数据花费的精力越多,花费在绘制和微调蒙版上的时间就越少。(请参阅跟踪和稳定运动。)
  • 羽化对象时,使用可变宽度蒙版羽化功能进行更多控制。

查看蒙版路径和形状

  • 要在“时间轴”面板中查看选定图层的蒙版路径,请按 M。
  • 要在“时间轴”面板中查看选定蒙版或形状,请按 SS(按 S 键两次)。
  • 要在“合成”面板中查看蒙版和形状路径,请单击“合成”面板底部的“切换蒙版和形状路径可见性” 按钮。
  • 要在“图层”面板中查看蒙版路径,请从“图层”面板“视图”菜单选择“蒙版”。
  • 要隐藏某个蒙版路径而显示其他蒙版路径,请在“时间轴”面板中选择蒙版的“锁定”开关 来锁定蒙版,然后选择“图层”>“蒙版”>“隐藏锁定的蒙版”。
  • 要隔离选定的蒙版和隐藏其他蒙版,请选择“图层”>“蒙版”>“锁定其他蒙版”,然后选择“图层”>“蒙版”>“隐藏锁定的蒙版”。

选择形状路径、形状和形状组

您可以在任意四个选择级别中选择形状图层及其组件,称为选择模式

图层选择模式

将选择整个形状图层。在与“内容”属性组处于同一级别的“变换”属性组中,变换适用于图层的变换属性。

组选择模式

将选择整个形状组。在“时间轴”面板中形状组内的“变换”属性组中,变换适用于组的变换属性。

自由变换模式

将选择一个或多个贝塞尔曲线路径上的多个顶点。在“合成”面板中的顶点周围显示自由变换定界框。通过在此框上进行操作,您可以用单个变换移动多个顶点。变换适用于顶点本身,顶点包含在“时间轴”面板的“路径”属性之中。

路径编辑模式

只选择顶点。在此模式下,您可以执行路径编辑操作,如将顶点添加到路径中及移动单个顶点。

注意:

钢笔工具处于活动状态时,路径编辑模式处于活动状态。要停留在路径编辑模式中,请选择钢笔工具;按 V 或 Ctrl 键 (Windows) 或 Command 键 (Mac OS) 在需要时暂时激活选择工具。

形状图层上形状的选择模式

A. 图层选择 B. 组选择 C. 自由变换 D. 路径编辑 

有关选择蒙版的信息,请参阅选择蒙版、段和顶点

注意:

选择某个形状顶点后按 Ctrl+A (Windows) 或 Command+A (Mac OS) 可选择该路径上的所有顶点。再按一次可选择所有形状。重按可选择所有图层。

选择形状图层

  • 单击“时间轴”面板中的图层名称或图层持续时间条。
  • 使用选择工具,在“合成”面板中的图层边界内部单击。
  • 要取消选择图层上的所有形状,但将形状图层保留为选定,请在图层边界之内而又在所有图形路径之外单击。

在组选择模式中选择形状组

  • 使用选择工具,在“合成”面板中双击组的成员。每次双击都会在组层级中降低一级。
  • 要激活直接选择工具 ,请在选择工具处于选定状态时按住 Ctrl (Windows) 或 Command (Mac OS)。无论形状在组层级中嵌套有多深,请利用直接选择工具单击“合成”面板中的形状来直接选择该形状的组。
  • 要选择包含在已选择组内的组,请单击要选择的组。
  • 要将组添加到选择中,请按住 Shift 并单击该组。您可以结合使用 Shift 键和双击以及直接选择工具,将嵌套更深的组添加到选择中。

在路径编辑模式中选择路径和顶点

注意:

要为蒙版和形状指定贝塞尔曲线方向手柄和顶点的大小,请选择“编辑”>“首选项”>“常规”(Windows) 或“After Effects”>“首选项”>“常规”(Mac OS),然后编辑“路径点大小”值。

  • 要选择顶点,请使用选择工具单击顶点。要将顶点添加到选择中,请按住 Shift 并单击顶点。
  • 要选择路径段,请使用选择工具单击该段。要将段添加到选择中,请按住 Shift 并单击该段。
  • 要选择整个路径,请使用选择工具按住 Alt 单击 (Windows) 或按住 Option 单击 (Mac OS) 路径的段或顶点,或选择路径的任意部分并按 Ctrl+A (Windows) 或 Command+A (Mac OS)。
  • 要通过拖动来选择顶点,请选择路径或路径的某个部分以进入路径编辑模式,然后使用框选工具 拖动,以便在要选择的顶点周围绘制一个选框。要将顶点添加到选择中,请在绘制其他选框时按住 Shift 键。

选择路径上的所有点并进入自由变换模式

  • 处于路径编辑模式或单个形状的组选择模式时,双击路径段。
  • 在“时间轴”面板中选择“路径”属性并按 Ctrl+T (Windows) 或 Command+T (Mac OS)。

选择蒙版、段和顶点

与图层不同,蒙版可以有多个级别的选择。您可以选择蒙版作为整个路径,这适用于移动蒙版或调整蒙版大小。但如果要更改蒙版的路径,请在其上选择一个或多个点。选定的点看起来是实心的,未选定的点看起来是空心的。

注意:

要为蒙版和形状指定贝塞尔曲线方向手柄和顶点的大小,请选择“编辑”>“首选项”>“常规”(Windows) 或“After Effects”>“首选项”>“常规”(Mac OS),然后编辑“路径点大小”值。

在“图层”或“合成”面板中选择或取消选择蒙版

  • 要选择蒙版上的顶点,请使用选择工具 单击顶点。要将顶点添加到选择中,请按住 Shift 并单击顶点。
  • 要选择蒙版段,请使用选择工具单击段。要将段添加到选择中,请按住 Shift 并单击段。
  • 要选择整个蒙版,请使用选择工具按住 Alt 单击 (Windows) 或按住 Option 单击 (Mac OS) 蒙版的段、顶点或手柄,或者选择蒙版的任意部分并选择“编辑”>“全选”或按 Ctrl+A (Windows) 或 Command+A (Mac OS)。要将蒙版添加到选择中,请按住 Alt+Shift 并单击 (Windows) 或按住 Option+Shift 并单击 (Mac OS) 蒙版。
  • 要通过拖动来选择蒙版,请选择蒙版或部分蒙版来进入蒙版编辑模式,然后利用选择工具拖动,在要选择的顶点或蒙版周围完整地绘制选框。要将蒙版或顶点添加到选择中,请在绘制其他选框时按住 Shift 键。
  • 要选择图层上的所有蒙版,请选择图层上的蒙版,并选择“编辑”>“全选”,或者按 Ctrl+A (Windows) 或 Command+A (Mac OS)。
  • 要取消选择所有蒙版,请按 Ctrl+Shift+A (Windows) 或 Command+Shift+A (Mac OS)。
  • 要选择图层上的相邻蒙版,请按 Alt+重音符 (`) (Windows) 或 Option+重音符 (`) 来选择下一个蒙版,或者按 Shift+Alt+重音符 (`) (Windows) 或 Shift+Option+重音符 (`) (Mac OS) 来选择上一个蒙版。
  • 要取消选择蒙版,请单击除蒙版之外的任何位置。
  • 要从选择中删除顶点或段,请按住 Shift 并单击顶点或段。
注意:

要在选择钢笔工具后使用选择工具,请按住 Ctrl (Windows) 或 Command (Mac OS)。

在“时间轴”面板中选择蒙版

  1. 单击图层名称旁的向右箭头可将其展开。
  2. 单击蒙版标题旁的向右箭头可将其展开,显示该图层上的所有蒙版。
  3. 执行以下任一操作:
    • 要选择蒙版,请单击其名称。
    • 要选择连续范围内的蒙版,请按住 Shift 并单击范围中第一个和最后一个蒙版的名称。
    • 要一起选择不连续的蒙版,请按住 Ctrl (Windows) 单击或按住 Command 单击 (Mac OS) 您要包括的任何蒙版的名称。
注意:

您可以在“时间轴”面板中仅选择整个蒙版。要在蒙版上选择单个顶点,请使用“合成”或“图层”面板。

锁定或解锁蒙版

锁定蒙版可以防止您在“时间轴”、“合成”和“图层”面板中选择该蒙版或者将其设为“图层”面板中的目标。使用此功能可避免对蒙版进行不必要的更改。

  1. 在“时间轴”面板中,展开“蒙版”属性组。
  2. 在“A/V 功能”列中,单击您想锁定或解锁的蒙版旁边的“锁定”图标 下面的框。当蒙版的“锁定”开关处于选定状态时,也就是说,“锁定”图标出现在框中时,蒙版被锁定并且无法选择。
注意:

要同时解锁多个蒙版,请选择一个或多个图层,然后选择“图层”>“蒙版”>“解锁所有蒙版”。

注意:

要隔离选定的蒙版和隐藏其他蒙版,请选择“图层”>“蒙版”>“锁定其他蒙版”,然后选择“图层”>“蒙版”>“隐藏锁定的蒙版”。

在自由变换模式下移动顶点

您可以使用“自由变换点”命令来缩放和旋转整个蒙版或形状路径(或一个或多个路径中选定的顶点)。在使用此命令时,自由变换定界框围绕选定的顶点,锚点显示在定界框的中心以标记当前变换的锚点。您可以通过拖动定界框或其手柄,来缩放和旋转选定的顶点。您也可以通过移动定界框锚点,更改旋转或缩放顶点的参考点。自由变换定界框手柄和锚点独立于图层的手柄和锚点而存在。

注意:

在使用“自由变换点”对旋转进行动画制作时,蒙版顶点的插值位于一条从关键帧到关键帧的直线中。鉴于此,结果可能与您的预期不同。

  1. 显示包含要在“合成”或“图层”面板中变换的路径的图层。
  2. 通过使用选择工具,执行以下操作之一:
    • 要变换任意数量的顶点,请选择要变换的顶点,然后选择“图层”>“蒙版和形状路径”>“自由变换点”。
    • 要变换整个蒙版或形状路径,请在“时间轴”面板中选择该蒙版或形状路径,然后选择“图层”>“蒙版和形状路径”>“自由变换点”。
  3. 要移动定界框的锚点,请将选择工具放置在定界框锚点 上方,直到选择工具更改为移动锚点图标 。拖动以定位锚点。
  4. 执行以下任一操作组合:
    • 要移动路径或选定的顶点,请将指针放置在定界框内并拖动。
    • 要缩放路径或选定的顶点,请将指针放置在定界框手柄上,当指针变为笔直的双向箭头 时,拖动以调整为新大小。在拖动以约束缩放时,按住 Shift。在拖动以在定界框的锚点周围缩放时,按住 Ctrl (Windows) 或 Command (Mac OS)。
    • 要旋转路径或选定的顶点,请将指针放置在自由变换定界框的外部,当指针变为弯曲的双向箭头 时,拖动以旋转。
  5. 要退出自由变换模式,请按 Esc、Enter (Windows) 或 Return (Mac OS)。

在手动贝塞尔曲线和旋转贝塞尔曲线之间转换路径

您可以将任何手动贝塞尔曲线蒙版路径或手动贝塞尔曲线形状路径转换成旋转贝塞尔曲线路径。如果手动贝塞尔曲线路径的方向手柄经过调整,此转换将更改路径的形状,因为 After Effects 自动计算旋转贝塞尔曲线段的曲度。

将旋转贝塞尔曲线路径转换为手动贝塞尔曲线路径不会更改路径的形状。

  1. 在“图层”、“合成”或“时间轴”面板中选择蒙版,或在“合成”或“时间轴”面板中选择形状路径。
  2. 选择“图层”>“蒙版和形状路径”>“旋转贝塞尔曲线”。

修改贝塞尔曲线蒙版路径或形状路径

您可以使用“图层”或“合成”面板中的选择工具和钢笔工具更改贝塞尔曲线蒙版路径。您可以使用“合成”面板中的选择工具和钢笔工具更改贝塞尔曲线形状路径。

钢笔工具(“添加顶点”、“删除顶点”以及“转换顶点”工具)划分在“工具”面板中的钢笔工具下。要在“工具”面板中显示这些工具,请在“工具”面板中单击并按住钢笔工具。

注意:

在大多数情况下,当您将钢笔工具指针置于特定上下文中时,相应的钢笔工具会变为活动状态。例如,在将钢笔工具指针置于现有顶点上方时,“删除顶点”工具会变为活动状态,在将钢笔工具指针置于路径段上方时,“添加顶点”工具会变为活动状态。要手动激活及循环切换这些工具,请按 G。

在修改路径时,请务必仅单击现有顶点或段;否则,可能会创建新路径。

移动、添加或删除顶点

  1. 执行以下操作之一:
    • 要移动顶点,请使用选择工具 拖动顶点。
    注意:

    要暂时从钢笔工具切换到选择工具,请按 V 或 Ctrl (Windows) 或 Command (Mac OS)。

    • 要将顶点添加到蒙版中,请使用“添加顶点”工具 单击两个现有顶点之间的段。
    • 要从蒙版中删除顶点,请使用“删除顶点”工具 单击顶点。

调整路径段

  1. 使用选择工具执行下列操作之一:
    • 拖动顶点。
    • 拖动方向手柄从邻近的平滑顶点扩展。
    • 拖动曲线段。
    注意:

    在旋转贝塞尔曲线蒙版上拖动曲线段还会移动顶点。

在平滑点和边角点之间切换顶点

  1. 使用“转换顶点”工具 单击顶点。
    注意:

    要在选择钢笔工具后激活“转换顶点”工具,请按住 Alt (Windows) 或 Option (Mac OS)。

调整 RotoBezier 蒙版的张力

  1. 如果要同时调整多个顶点的张力,请选择这些顶点。
  2. 使用“转换顶点”工具 ,拖动顶点。
    注意:

    要在选择钢笔工具后激活“转换顶点”工具,请按住 Alt (Windows) 或 Option (Mac OS)。

    在拖动 RotoBezier 蒙版的顶点时,将出现调节张力指针

    单击顶点(而非拖动)会将顶点设置为边角点(100% 张力);再次单击会将顶点设置为平滑点(33% 张力)。向上或向右面拖动会减少选择项的张力,同时增加邻近路径段的曲度;向下或向左拖动会增加选择项的张力,同时减少邻近路径段的曲度。

    注意:

    要查看顶点的张力值,可在调整张力时在“信息”面板中查看。

按数字顺序更改蒙版路径

  1. 选择蒙版。
  2. 在“时间轴”面板中,展开“蒙版”属性。
  3. 在“蒙版路径”属性旁边,单击带下划线的单词,然后在“蒙版形状”对话框指定所需更改。

为贝塞尔曲线路径指定第一个顶点

要对路径进行动画制作,After Effects 会将初始关键帧的最高顶点指定为第一个顶点,并且从第一个顶点开始,以升序方式对各个连续顶点编号。然后,After Effects 会将相同的编号分配给所有连续关键帧的相应顶点。After Effects 会将各个顶点的移动从一个关键帧的初始位置插入到下个关键帧的相应编号的顶点的位置。在动画制作期间,您可以将其他顶点指定为第一个顶点;这将导致 After Effects 对路径的顶点重新编号。对顶点重新编号将导致路径动画更改,因为 After Effects 会将新顶点编号映射到仍保存在连续关键帧的相应旧顶点编号。

在将封闭路径复制到运动路径时,会将指定为封闭路径的第一个顶点的顶点用作运动路径的开始。所有运动路径都是开放路径。

一些形状路径操作(如修剪路径),还将第一个顶点用作输入,以确定修改路径的方式。

注意:

默认情况下,在您向路径添加顶点时,在整个路径期间,新顶点出现在路径上,但仅在添加路径时改变路径形状。在特定时间点从路径中删除顶点时,将在整个路径期间从路径中删除顶点。通过以下方法防止 After Effects 在整个路径期间添加和删除顶点:选择“编辑”>“首选项”>“常规”(Windows) 或“After Effects”>“首选项” >“常规”(Mac OS),并取消选择“在编辑蒙版时保持固定的顶点数”。

注:在 After Effects CC 和 CS6 中,“在编辑蒙版时保持固定的顶点数”称为“在编辑蒙版时保持固定的顶点和羽化数”。

  1. 创建动画路径。
  2. 在“时间轴”面板中,将当前时间指示器移动到您要指定新的第一个顶点的位置。
  3. 选择要指定为第一个顶点的顶点。
  4. 选择“图层”>“蒙版和形状路径”>“设置第一个顶点”。
    注意:

    被指定为第一个顶点的顶点看起来比“合成”面板中的其他顶点稍微大一些。

利用智能蒙版插值动画显示蒙版路径

智能蒙版插值提供了高级控制,可用于创建蒙版路径关键帧和平滑逼真的动画。在您选择要插入的蒙版路径关键帧后,智能蒙版插值将基于您提供的设置创建中间关键帧。“信息”面板显示插入的进度和创建的关键帧数。

  1. 选择“窗口”>“蒙版插值”。
  2. 选择至少两个邻近的蒙版路径关键帧。
  3. 设置“蒙版插值”面板中的选项,然后单击“应用”。
    注意:

    要中断插值进程,请按 Esc 键。“信息”面板指示进程已中断并报告创建的关键帧数。

    关键帧速率

    指定智能蒙版插值每秒在选定关键帧之间创建的关键帧数目。例如,值为 10 则每 1/10 秒创建一个新关键帧。选择“自动”将关键帧率设置为等于合成帧率,后者显示在圆括号内。创建较多关键帧可实现更平滑的动画;创建较少关键帧可减少渲染时间。

    注意:

    不管您选择的关键帧率是多少,智能蒙版插值始终在正好位于第一个蒙版路径关键帧之后的帧处以及在正好位于第二个蒙版路径关键帧之前的帧处添加关键帧。例如,如果您在关键帧率为每秒 10 个关键帧的 30 fps 合成中的 0 秒和 1 秒处的关键帧之间插值,会在帧编号 1、3、6、9、12、15、18、21、24、27 和 29 处添加蒙版路径关键帧。

    “关键帧”字段

    使关键帧率加倍。选择此选项,并且关键帧率设为合成帧率后,将在每个视频字段中添加关键帧。选择此选项用于隔行视频的动画蒙版。如果不选择此选项,蒙版可能从您尝试抠出的对象滑落。有关隔行视频中的画面的更多信息,请参阅隔行视频和分离画面

    使用线性顶点路径

    指定第一个关键帧中的顶点沿直线路径移动到第二个关键帧中相应的顶点。如果您希望一些顶点沿着弯曲路径插入,请不要选择此选项;例如,当所需的插值涉及旋转部分时。如果未选择此选项,智能蒙版插值将为蒙版创建自然路径。

    抗弯强度

    指定插入的蒙版路径容易弯曲而不是拉伸的程度。在蒙版路径进行动画制作时,值 0 指定弯曲程度超过拉伸;值 100 指定蒙版路径拉伸程度超过弯曲。

    质量

    指定智能蒙版插值匹配一个关键帧到另一个关键帧的顶点时的严格程度。值 0 指定,第一个关键帧中的特定顶点仅与第二个关键帧中编号相同的顶点匹配。例如,第一个关键帧中的第十个顶点必须与第二个关键帧中的第十个顶点匹配。值 100 是指第一个关键帧中的顶点可以与第二个关键帧中的任意顶点匹配。通常值越高产生的插值越好;但值越高,处理时间越长。

    添加蒙版路径顶点

    指定智能蒙版插值添加顶点以促进高品质插补。通常,当蒙版路径具有密集的顶点集时,智能蒙版插值最适合。此外,第一个蒙版路径上的顶点无法匹配第二个蒙版路径上的曲线或直线段中间,因此有时您必须添加顶点,然后才能匹配以生成所需结果。智能蒙版插值不修改原始关键帧。只有由智能蒙版插值计算的新蒙版路径关键帧具有其他顶点。

    您设置的值指定细分输入蒙版路径的细微程度。顶点之间的像素指定细分之后更大的外围蒙版路径上的顶点之间的距离(以像素为单位)。“总顶点数”指定插值蒙版路径上的顶点数。“轮廓的百分比”指定以蒙版路径轮廓长度的各个指示的百分比添加顶点。例如,值 5 是指在占总外围 5% 的轮廓的各个连续段处添加顶点。要只使用第一个帧的路径上的顶点,请不要选择此选项。

    注意:

    即使未选择“添加蒙版路径顶点”,智能蒙版插值也可能在现有顶点位置添加顶点。如果一个蒙版路径上的两个顶点与另一个路径上的单个顶点匹配,则在相同位置复制该单个顶点,以便上面两个顶点之间的段收缩到该位置。

    配合法

    指定智能蒙版插值用于将一个蒙版路径上的顶点与另一个路径上的顶点进行匹配的算法。如果两个选定关键帧中的任何一个具有曲线段,则会自动将匹配的算法应用于曲线;否则会应用折线算法。曲线将应用具有曲线段的蒙版路径的算法。折线将应用只有直线段的蒙版路径的算法。

    注意:

    如果选择“多角线”配合法,则无论输入蒙版路径是否包含曲线段,由智能蒙版插值添加的蒙版路径关键帧都是多角线。

    使用 1:1 顶点匹配

    指定智能蒙版插值在一个蒙版路径上创建与另一个蒙版路径上相同编号的顶点匹配的顶点。在每个输入蒙版路径上,智能蒙版插值匹配第一顶点、第二顶点、第三顶点等等。如果两个路径的顶点数不相等,此操作可能会产生不良结果。

    第一顶点匹配

    指定智能蒙版插值匹配两个蒙版路径关键帧中的第一个顶点。如果未选择,智能蒙版插值将在两个输入蒙版路径之间搜索最佳的第一顶点匹配。

    注意:

    要确保得到正确的结果,请确保输入蒙版路径的第一个顶点匹配,然后选择“第一顶点匹配”。

移动蒙版或将图层平移到蒙版之后

通过移动“图层”或“合成”面板中的蒙版,或在“合成”面板中将图层平移(移动)到蒙版之后,您可以调整可通过蒙版看见的区域。在移动蒙版时,蒙版图层的“位置”值保持不变,蒙版相对于“合成”面板的其他对象移动。

在您使用向后平移(锚点)工具将图层平移到蒙版后时,蒙版的位置在“合成”面板中保持不变,但在“图层”面板中有更改。蒙版图层的“位置”值相对于合成进行更改。当您移过图层帧的边缘时,图层上的“蒙版路径”值也会更改。使用向后平移(锚点)工具保存步骤;如果没有该工具,您必须手动更改蒙版图层的“位置”和“蒙版路径”属性。您可以通过为蒙版图层的“位置”和“蒙版路径”属性设置关键帧,以将图层动画制作为平移到其他图层之后。

您在“合成”面板中使用向后平移(锚点)工具时,After Effects 将自动进行两次调整。在“图层”面板中,蒙版相对于其图层移动(上图),在“合成”面板中,图层相对于合成移动(下图)。

移动蒙版

  1. 选择要移动的一个或多个蒙版。
  2. 在“合成”面板中,将一个或多个蒙版拖动到新位置。要将一个或多个蒙版约束为水平或垂直移动,可在开始拖动后按住 Shift。

将图层平移到其蒙版之后

  1. 在“工具”面板中选择向后平移(锚点)工具。

  2. 在“合成”面板中的蒙版区域内单击,并将图层拖动到新位置。

人脸跟踪和蒙版跟踪

您可以使用蒙版跟踪器来变换蒙版,使其跟随影片中对象的动作。有关更多信息,请参阅蒙版跟踪

您还可以使用蒙版跟踪器来准确检测和跟踪人脸。有关更多信息,请参阅人脸跟踪

使用表达式访问蒙版、贝塞尔曲线形状和画笔描边上的路径点

您可以针对以下对象使用表达式读写路径点或顶点的 x 坐标和 y 坐标:

  • 图层蒙版
  • 贝塞尔曲线形状   
  • 使用“绘画”和“旋转画笔和调整边缘”效果的画笔描边。

表达式方法类似于通过脚本访问路径顶点。出于熟悉的角度,表达式方法命名为 points() 而不是 vertices()。

访问表达式方法

您可以通过以下步骤访问表达式方法:

  1. 要创建纯色图层,请选择图层 > 纯色

  2. 创建纯色图层后,再创建一个蒙版。单击形状工具,例如一个多边形,并在纯色图层上创建一个蒙版。

  3. 时间轴面板中,旋转打开蒙版属性,按住 Alt 并单击蒙版路径

  4. 此时会显示表达式字段。在时间轴面板中,单击表达式语言菜单,然后选择路径属性

    “表达式语言”菜单
    “表达式语言”菜单

  5. 从路径点表达式方法列表中选择表达式方法。

    要了解有关表达式方法的更多信息,请参阅使用表达式访问形状、蒙版和画笔描边上的路径点(表达式引用)

下面列出了以下路径对象的示例表达式方法:

  • “图层”蒙版路径:layer("Dark Gray Solid 1").mask("Mask 1").path or .maskPath
  • “贝塞尔曲线”形状路径:layer("Shape Layer 1").content("Shape 1").content("Path 1").path
  • “绘画”效果描边路径:layer("Dark Gray Solid 1").effect("Paint").stroke("Brush 1").path
  • “旋转画笔和调整边缘”效果描边路径:layer("Dark Gray Solid 1").effect("Roto Brush & Refine Edge").stroke("Foreground 1").path

使用这些表达式方法的提示:

  • 点和切线值作为顶点坐标的 [x,y] 数偶数组的数组返回。坐标值四舍五入到小数点后四位。
  • 点和切线数组从路径上的第一个顶点开始。您可以通过图层 > 蒙版和形状路径 > 设置第一个顶点命令来更改图层蒙版路径和贝塞尔曲线形状路径的第一个顶点。
  • 图层蒙版路径点的坐标相对于其左上角的图层的原点。
  • 贝塞尔曲线形状路径点的坐标相对于路径形状组的锚点(例如 Transform: Shape 1 > Anchor Point)。
  • 笔刷描边路径点的坐标相对于描边的开始;第一个点为 [0,0]。
  • 将坐标从不同图层转换到公共空间,或仅返回相对于合成空间的坐标时,toComp() 方法或其他图层空间变换方法会变得十分有用。
  • 由于贝塞尔曲线形状路径相对于其局部形状组的锚点而不是图层,因此其值可能偏离预期的位置。要解决此问题,请将形状组中的所有“变换”属性设置为零。请记住,将参数形状转换为贝塞尔曲线形状可能会影响形状组的位置。
  • createPath() 方法可以是同一路径或其他路径传递的点、切线和 isClosed 方法。您可以在不更改这些方法的前提下传递这些方法来复制路径,或者在传递这些方法之前变换点和切线值以修改或动画显示路径。

“通过路径创建空白”面板

通过路径创建空白 scriptUI 面板,您可以通过该面板创建由表达式驱动的直观动画,而无需手动编写表达式。您可以直接将不同的路径链接到形状、将形状链接到纯色图层等。“通过路径创建空白”面板使用表达式访问路径点来自动链接 空白, 因此您无需自己编写表达式。

该面板可为蒙版路径或贝塞尔曲线形状路径上的每个路径点创建空白。您可以使用该面板中的以下按钮指示空白的执行方式:

  • 点跟随空白:该按钮创建控制路径点位置的空白。路径点附加到空白,并且您可以动画显示空白来驱动路径点。
  • 空白跟随点:该按钮创建由路径点的位置控制的空白。空白附加到路径点,并且您可以动画显示路径点来移动空白。
  • 跟踪路径:该按钮创建跟随路径的单个空白。空白的位置链接到路径的坐标。空白的旋转自动定向以跟随路径。跟踪路径控制空白沿路径的移动以及它是否会循环。默认情况下,将关键帧设置为 1 秒内跟踪路径,并 启用循环 已启用。

使用面板

  1. 要打开面板,请选择窗口 > 通过路径创建空白.jsx

  2. 要添加形状蒙版,请选择图层 > 新建 > 形状图层。向图层添加形状蒙版。

    注意:

    此面板可使用贝塞尔曲线形状,因此所有参数形状(如矩形、椭圆形和星形)都必须转换为贝塞尔曲线形状。要将参数形状转换为贝塞尔曲线形状,请旋转打开形状图层,然后右键单击形状 路径 (例如,矩形 1),然后选择转换为贝塞尔曲线路径

    重复步骤 2 以添加更多形状。

  3. 每个贝塞尔曲线形状和蒙版都有一个路径。在“时间轴”面板中,旋转打开图层以查看路径。如果您要使空白跟随路径点,请在“时间轴”面板中选择一个路径,然后在通过路径创建空白面板中单击空白跟随点

    脚本为路径上的每个点生成一个空白。您可以删除任何不需要的空白。

    注意:

    当您将参数形状转换为贝塞尔曲线形状时,After Effects 会调整形状的“位置”属性。这会在计算空白的位置时导致偏移。要避免此问题,请在创建空白之前将形状的“变换”属性(例如“变换: 椭圆形 1”)的值设置为零。

  4. 如果您想要路径点跟随空白,请在“时间轴”面板中选择一个路径。然后,在通过路径创建空白面板中单击点跟随空白

  5. 为所有路径点创建空白后,您可以将它们 相互附加 来创建动画。使用“点跟随空白”按钮创建的空白和使用“空白跟随点”按钮创建的空白具有不同的颜色要附加空白,可选择一个空白,按住 Shift,同时使用关联器选择一个父级图层,然后将空白的坐标跳转到父级图层。

    将所有空白附加在一起后,预览您的动画以查看其运行情况。

Adobe 徽标

登录到您的帐户