使用 Adobe Bridge 和 After Effects

使用 Adobe Bridge 可运行动画预设;运行跨产品工作流程自动化脚本;查看和管理文件和文件夹;通过将关键字、标签和等级分配给您的文件来组织这些文件;搜索文件和文件夹;以及查看、编辑和添加元数据。

  • 要从 After Effects 打开 Adobe Bridge,请选择“文件”>“在 Bridge 中浏览”。
  • 要在 Adobe Bridge 中显示文件,请在“项目”面板中选择文件,并选择“文件”>“在 Bridge 中显示”。
  • 要使用 Adobe Bridge 浏览动画预设,请选择“动画”>“浏览预设”。

Adobe Bridge 是 Creative Cloud 应用程序包的一部分,可通过 Creative Cloud 下载和安装。有关更多信息,请参阅帮助文档Adobe Bridge CC 产品页面。

请观看此视频,以了解 Adobe Bridge CC 的概略信息。

使用 Photoshop 和 After Effects

如果使用 Photoshop 创建静止图像,可以使用 After Effects 将这些静止图像放到一起,并移动和更改它们。在 After Effects 中,您可以为整个 Photoshop 图像制作动画,也可以为其任何图层制作动画。您甚至可以为 Photoshop 图像的单个属性(如图层样式的属性)制作动画。如果使用 After Effects 创建影片,您可以使用 Photoshop 优化这些影片的单个帧。

完成特定任务的相对优势

After Effects 的优势在于其动画和自动化功能。这意味着 After Effects 在逐帧自动执行任务方面表现不俗。例如,您可以使用 After Effects 的运动跟踪功能跟踪麦克风架的运动,然后将该运动自动应用于使用仿制图章工具生成的描边。采用这种方式,您可以从镜头的每个帧中移除麦克风,而无需在每个帧上手动涂掉麦克风。

相比之下,Photoshop 具有出色的绘画和绘图工具。

根据具体任务决定用于绘画的应用程序。Photoshop 中的绘画描边直接影响图层的像素。After Effects 中的绘画描边是效果的元素,可打开或关闭其中每个描边或随时对其进行修改。如果您要在应用每个绘画描边后对其进行完全控制,或要为绘画描边本身制作动画,请使用 After Effects 绘画工具。如果应用绘画描边的目的是永久修改静止图像,请使用 Photoshop 绘画工具。如果您要手动应用几个绘画描边以去除灰尘,请考虑使用 Photoshop 绘画工具。

Photoshop 中的动画和视频功能包括简单的基于关键帧的动画。After Effects 使用类似的界面,但其动画功能的广度和灵活性更大。

After Effects 也可以自动创建 3D 图层,以模仿由 Photoshop 消失点功能创建的平面。

交换静止图像

After Effects 可以采用许多格式导入和导出静止图像,但您通常希望使用本机 Photoshop PSD 格式在 After Effects 和 Photoshop 之间传输单个帧或静止图像序列。

在导入或导出 PSD 文件时,After Effects 可以保留单个图层、蒙版、图层样式以及多数其他属性。在将 PSD 文件导入 After Effects 时,您可以选择是将该文件作为拼合图像,还是作为其图层独立且完整的合成导入。

通常最好先在 Photoshop 中准备静止图像,然后再将其导入 After Effects。此类准备的示例包括校正颜色、缩放和裁剪。通常,您最好在 Photoshop 中对源图像执行某项操作一次,而不是让 After Effects 在其渲染每个帧以实现预览或最终输出时每秒执行同一操作多次。

通过从 Photoshop“新建文件”对话框使用“胶片和视频”预设创建您的新 PSD 文档,您可以从为特定视频输出类型正确设置的文档开始。如果您已经在 After Effects 中工作,则可以通过选择“文件”>“新建”>“Adobe Photoshop 文件”来创建一个与您的合成和项目设置匹配的新 PSD 文档。

交换影片

您也可以在 Photoshop 和 After Effects 之间交换视频文件,如 QuickTime 影片。当您在 Photoshop 中打开影片时,将创建一个引用源素材文件的视频图层。视频图层允许您在影片的帧上进行非破坏性绘画,就像 After Effects 处理将影片作为其源的图层一样。保存包含视频图层的 PSD 文件时,所保存的是您对视频图层所做的编辑,而不是对源素材本身所做的编辑。

您也可以直接从 Photoshop 渲染影片。例如,您可以从 Photoshop 创建 QuickTime 影片,然后将该影片导入 After Effects。

颜色

After Effects 采用 RGB(红色、绿色、蓝色)颜色空间在内部处理颜色。虽然 After Effects 可将 CMYK 图像转换为 RGB,但您应当在 Photoshop 中以 RGB 模式执行视频和动画工作。

如果与最终输出相关,那么再将图像导入 After Effects 之前,最好确保图像中的颜色在 Photoshop 中是可安全播放的颜色。实现此目的的最佳方式是为 Photoshop 文档指定适当的目标颜色空间,例如 SDTV (Rec. 601)。After Effects 根据文档(包括导入的 PSD 文件)中嵌入的颜色配置文件执行色彩管理。

Animate CC 与 After Effects 配合使用

如果使用 Adobe Animate(以前称为 Flash Professional)创建视频或动画,则可以使用 After Effects 来编辑和优化视频。例如,从 Adobe Animate 中可以将动画和应用程序导出为 QuickTime 影片、.mp4 和其他标准视频格式。然后可使用 After Effects 来编辑和优化视频。

如果使用 After Effects 编辑和合成视频,则之后可使用 Animate 发布该视频。

Animate 和 After Effects 对一些共有概念使用不同的术语。下表列出用于两个应用程序之间的术语差异:

After Effects 动画
合成 影片剪辑
合成帧(合成面板) 阶段
“项目”面板 “Library”面板
项目文件 FLA 文件
渲染和导出影片 发布 SWF 文件

其他资源

以下文章提供了有关 Animate 与 After Effects 配合使用的其他信息:

从 Animate 导出 QuickTime 视频

如果使用 Animate 创建动画或应用程序,则可以使用 Animate 中的“文件”>“导出”>“导出影片”命令将其导出为 QuickTime 影片。对于 Animate 动画,您可以优化动画的视频输出。对于 Animate 应用程序,Animate 将在应用程序运行时渲染其视频,从而使用户能够对其进行操作。这样,您就可以捕捉要包括在视频文件中的应用程序分支或状态。

在 Animate 中导入和发布视频

将影片文件导入 Animate 时,可以使用不同的技术(如脚本或 Animate 组件)来控制视频周围的可视界面。例如,可加入回放控件或其他图形。也可在影片顶层添加图形图层,以制作合成效果。

复合图形、动画和视频

Animate 和 After Effects 均包含很多用于执行复杂的视频和图形合成操作的功能。具体选用哪个应用程序取决于您的个人喜好以及要创建的最终输出类型。

在这两个应用程序中,Animate 更面向于 Web,并且最终文件较小。Animate 还允许对动画进行运行时控制。After Effects 专门面向视频和影片制作,提供了丰富多样的视觉效果,通常用于创建视频文件作为最终输出。

这两个应用程序都可以用来创建原始图形和动画。它们都使用时间轴,并且提供了脚本功能以按编程方式控制动画。After Effects 包含的效果数量更多。

两个应用程序都允许将图形放在单独的图层中以进行合成。可以根据需要打开或关闭这些图层。两个应用程序还允许对各个图层上的内容应用效果。

在 Animate 中,合成不会直接影响视频内容;它们仅影响视频在 Flash Player 中回放时的外观。相比之下,在 After Effects 中使用导入的视频进行合成时,导出的视频文件实际上包含着合成的图形和效果。

由于在 After Effects 中,所有绘制和绘画都是在与导入视频无关的图层上完成的,因此它始终是非破坏性的。Animate 则具有破坏性和非破坏性两种绘制模式。

 

将 SWF 文件导入到 After Effects

Animate 具有一套独特的矢量图形工具,可以完成很多在 After Effects 或 Adobe® Illustrator® 中无法完成的绘制任务。您可以将 SWF 文件导入到 After Effects 中,与其它视频进行合成,或者作为具有创意效果的视频进行呈现。不保留交互内容和脚本动画。保留了关键帧定义的动画。

导入到 After Effects 中的每个 SWF 文件都将拼合到一个连续栅格化的图层中,并保留其 Alpha 通道。连续栅格化意味着图形在进行放大时会保持清晰。使用这种导入方法,您可以在 After Effects 中将 SWF 文件的根图层或对象用作平滑呈现的元素,从而让每个工具发挥出最佳功能。

将 FLA 文件导入到 After Effects

您可以将 Animate FLA 文件作为 .swf 分层文件的合成导入 After Effects。您可以将它们与视频合成或使用其他创意效果将其渲染为视频。

要使用此功能,请确保在同一台计算机上安装 Animate 19.0。

将 Animate 文档导入 After Effects 时,Animate 会将各个图层导出为 .swf 文件,并将这些文件添加到合成中。在导入期间,请通过“导入首选项”对话框选择用于导入文件的位置。

如果启用了“导入音频”选项,Animate 会将音频图层导出为 .wav 文件。

注意:

仅支持 ActionScript 3.0 文档。要将 HTML5 Canvas 或 WebGL 文档转换为 ActionScript 3.0,请在 Animate 中打开文档,然后选择“文件”>“转换为”>“ActionScript 3.0”

使用 Adobe XD 和 After Effects

您可以从 Adobe XD 将图层和画板导出到您的 After Effects 项目。此功能可增强 XD 和 After Effects 之间的资源传输,支持图层、画板、矢量、文本和图稿的本机映射。作为 Adobe XD 设计人员,您可以将图层组发送到 After Effects,并定义高级微交互或画板,以创建复杂和精细的过渡和交互。如果您的计算机上尚未安装 After Effects,则 XD 菜单中的 After Effects 选项将灰显。

要将设计资源从 XD 导出到 After Effects:

  1. 在 XD 中,选择要在 After Effects 中制作动画的图层或画板。

  2. 选择“文件”>“导出”> After Effects。After Effects 启动(如果已关闭)或移至前台(如果在后台打开)。

  3. 在新的合成中,图层和画板将作为本机形状、文本、资源和嵌套合成添加到 After Effects 项目中。

支持的 XD 功能列表

After Effects 支持以下 XD 功能:

  • 矢量形状
  • 路径
  • 文本图层
  • 位图
  • 蒙版
  • 分组
  • 画板
  • 符号
  • 布尔运算
  • 描边
  • 填充
  • 阴影
  • 不透明度
  • 对象模糊
  • 背景模糊和亮度
  • 作为图像渐变
  • 重复网格

使用 Adobe Premiere Pro 和 After Effects

Adobe Premiere Pro 旨在捕捉、导入和编辑影片。After Effects 旨在创建运动图形、应用视觉效果、合成视觉元素、执行颜色校正以及执行影片的其他后期制作任务。

您可以在 After Effects 和 Adobe Premiere Pro 之间轻松交换项目、合成、序列、轨道和图层:

如果您安装了 Adobe Premiere Pro,则可执行以下操作:

  • 使用 Adobe Dynamic Link 在 Adobe Premiere Pro 中处理 After Effects 合成。Dynamic Link 的合成在 Adobe Premiere Pro 中显示为剪辑。
  • 使用 Adobe Dynamic Link 在 After Effects 中处理 Adobe Premiere Pro 序列。Dynamic Link 的序列在 After Effects 中显示为素材项目。
  • 从 Premiere Pro 中启动 After Effects,以及使用与您的 Premiere Pro 项目设置匹配的设置创建一个新合成。
  • 在 Adobe Premiere Pro 中选择一组剪辑并将其转换为 After Effects 合成。

有关将 Dynamic Link 与 After Effects 和 Premiere Pro 结合使用的信息,请参阅 Dynamic Link 和 After Effects 以及 Adobe Premiere Pro“帮助”的 Dynamic Link 部分。

使用 Adobe Media Encoder 和 After Effects

可以使用 Adobe Media Encoder 从 After Effects 导出视频。使用 Adobe Media Encoder 编码 H.264、MPEG-2 和 WMV 等格式。其他格式可以在 Adobe Media Encoder 中使用,但不能在 After Effects 中使用。例如,DNxHD 格式可在 Adobe Media Encoder 中使用,但不能在 After Effects 中使用。

可将 After Effects 项目文件添加到 Adobe Media Encoder 中的监视文件夹,随后该合成会自动添加到 Adobe Media Encoder 的编码队列。有关详细信息,请参阅 Adobe Media Encoder 中的使用监视文件夹导入文件部分。

有关将 Adobe Media Encoder 与 After Effects 结合使用的详细信息,请参阅 Adobe Media Encoder

请参阅此教程,学习如何使用 Adobe Media Encoder 导出 After Effects 合成。

在 Adobe Audition 中编辑

在 After Effects 中工作时,可以使用 Adobe Audition 更为全面的音频编辑功能来微调音频。可以使用“在 Adobe Audition 中编辑”命令从 After Effects 内启动 Adobe Audition。

如果在 Adobe Audition 中编辑只包含音频的文件(例如,WAV 文件),更改的是原始文件。如果编辑同时包含音频和视频(例如,AVI 文件)的图层,编辑的是源音频文件的副本。

  1. 选择包含要编辑的音频的图层。该项目必须属于能够在 Adobe Audition 中编辑的类型。

  2. 选择“编辑”>“在 Adobe Audition 中编辑”,在 Adobe Audition 的“编辑”视图中打开剪辑。

  3. 编辑文件,然后执行下列操作之一:

    • 如果编辑的是只包含音频的图层,则选择“文件”>“保存”,将所做编辑应用于原始音频文件。也可以选择“文件”>“另存为”,将所做编辑应用于音频文件的副本。如果选择“文件”>“另存为”,则将文件副本导入 After Effects 中。

    • 如果编辑的是同时包含音频和视频的图层,则选择“文件”>“另存为”。保存文件后,将文件导入 After Effects 中。然后,将它添加到合成中,并通过取消选择“时间轴”面板中的“音频”开关,将音频视频剪辑中的原始音频静音。

    注意:

    在 After Effects 中应用于音频的所有效果都不包括在发送给 Adobe Audition 的副本中。

可以从 After Effects 目标区域博客帖子中找到有关使用 Adobe Audition 从 After Effects 修改音频的教程和资源。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略