颜色深度和高动态范围颜色

颜色深度(或位深度)是用于表示像素颜色的每通道位数 (bpc)。每个 RGB 通道(红色、绿色和蓝色)的位数越多,每个像素可以表示的颜色就越多。

在 After Effects 中,您可以使用 8-bpc、16-bpc 或 32-bpc 颜色。

除色位深度之外,用于表示像素值的数字的另外一个特性是数字是整数还是浮点数。浮点数可以表示具有相同位数的更大范围的数字。在 After Effects 中,32-bpc 像素值是浮点值。

8-bpc 像素的每个颜色通道可以具有从 0(黑色)到 255(纯饱和色)的值。16-bpc 像素的每个颜色通道可以具有从 0(黑色)到 32,768(纯饱和色)的值。如果所有三个颜色通道都具有最大纯色值,则结果是白色。32-bpc 像素可以具有低于 0.0 的值和超过 1.0(纯饱和色)的值,因此 After Effects 中的 32-bpc 颜色也是高动态范围 (HDR) 颜色。HDR 值可以比白色更明亮。

设置颜色深度并修改颜色显示设置

项目的颜色深度设置确定整个项目中颜色值的位深度。

要为项目设置颜色深度,请执行以下操作之一:

  • 在“项目”面板中,按住 Alt 键单击 (Windows) 或按住 Option 键单击 (Mac OS)“项目设置”按钮。

  • 选择“文件”>“项目设置”,或单击“项目”面板中的“项目设置”按钮,然后从“深度”菜单中选择颜色深度。

您可以为每个渲染项指定颜色深度,在为最终输出进行渲染时,该颜色深度将覆盖项目颜色深度。您还可以在输出模块设置中指定要用于每个输出项的颜色深度。(请参阅渲染设置输出模块和输出模块设置。)

注意:

要更改颜色值在“信息”面板和一些效果控件中的显示格式,请从“信息”面板菜单中选择相关选项,例如“百分比”或“Web”。选择“自动颜色显示”会自动在 8 bpc、16 bpc 和 32 bpc 之间切换,具体取决于项目的颜色深度。

虽然许多效果可以使用所有颜色深度,但某些效果仅使用较低颜色深度。您可以设置“效果和预设”面板,以便仅显示使用您的当前项目颜色深度的效果。(请参阅“效果和预设”面板。)

每个颜色深度的相对优势

物理领域中的动态范围(暗区和亮区之间的比率)远远超过人类视觉可及的范围,以及纸上打印的图像或显示器上所显示图像的范围。低动态范围 8-bpc 和 16-bpc 颜色值只能表示从黑色到白色的 RGB 级别,这仅是现实世界中动态范围的一小部分。

高动态范围 (HDR) 32-bpc 浮点颜色值可以表示比白色高很多的亮度级别,其中包括与火焰或太阳一样明亮的对象。

发光效果和高斯模糊效果适用于 32-bpc 项目和 16-bpc 项目中的图像
发光效果和高斯模糊效果适用于 32-bpc 项目(左图)和 16-bpc 项目(右图)中的图像

将项目颜色深度设置为 32 bpc 可使用 HDR 素材或使用超过范围的值 — 8-bpc 或 16-bpc 模式中不支持的高于 1.0(白色)的值。超过范围的值保持高光的强度,这对合成效果(例如光照、模糊和发光)和对使用 HDR 素材同样有用。使用 32 bpc 时所提供的空间 可防止在执行颜色校正和颜色配置文件转换等操作期间发生多种数据丢失情形。

即使您正在使用 8-bpc 素材,并且正在创建 8-bpc 格式的影片,您也可以通过将项目颜色深度设置为 16 bpc 或 32 bpc 来获得更好的结果。使用较高的位深度可提高计算精度,并可大大减少量化伪像,例如渐变中的光带条纹。

注意:

如果输出格式具有较低的位深度,则仅在项目中增加颜色深度不会消除渐变。为了减少光带条纹,在将颜色转换为 8-bpc 颜色时(包括在渲染并导出为 8-bpc 格式时),After Effects 引入了仿色。没有为预览引入此仿色。要对预览强制使用仿色,请将未应用的 8-bpc 效果(例如具有默认值的算术效果)应用于调整图层。

因为 16-bpc 帧使用 32-bpc 帧的一半内存,所以在 16-bpc 项目中渲染预览会更快,并且预览比在 32-bpc 项目中的时间更长。8-bpc 帧使用更少内存,但在项目颜色深度为 8 bpc 的一些图像中,很明显需要在品质和性能之间进行权衡。

有关使用高动态范围颜色的特殊注意事项

您可以使用 HDR 压缩扩展器效果将包含 HDR 素材项目的图层的动态范围压缩为源。通过这种方式,您可以使用不支持 HDR 颜色的工具,例如 8-bpc 和 16 位效果。完成后,可使用 HDR 压缩扩展器还原动态范围压缩。HDR 高光压缩效果允许您压缩 HDR 图像中的高光值,以便这些值处于低动态范围图像的值范围内。

因为我们只能在显示器上的 HDR 图像中看到真实场景中明亮度值的子集,所以在使用 HDR 图像时,有时需要调整曝光度(在图像中捕获的光照量)。调整 HDR 图像的曝光度就像在真实世界中拍照时调整曝光度一样,它将允许您从黑暗或明亮的区域中提取细节。您可以使用曝光度效果为最终输出更改图层的颜色值,也可以为进行预览而仅在特定查看器中调整曝光度。

注意:

因为与 8-bpc 或 16-bpc 模式相比,一些操作(包括发光、模糊和一些混合模式)在 32-bpc 模式中的行为有所不同,所以在高动态范围和低动态范围项目设置之间切换时,您的合成可能看起来显著不同。

有关高动态范围颜色的其他资源

Chris Meyer 在 Lynda.com 网站上的视频概述中解释了浮点 32-bpc HDR 颜色的适用范围。

Andrew Kramer 在其 Video Copilot 网站上提供了一个视频教程,其中演示了结合使用 32-bpc 颜色和运动模糊的优势。

在他的 fnord 网站上,Brendan Bolles 解释如何使用颜色配置文件转换器效果和胶片颜色配置文件调整颜色并执行色调映射,以使 HDR 图像看起来就像是在电影胶片上拍摄的。

选择颜色或编辑渐变

在许多上下文中,您可以单击吸管按钮 来激活吸管工具,也可以单击色板来打开拾色器。如果您使用 Adobe Color 拾色器,则还可以从“Adobe Color 拾色器”对话框激活吸管。

如果您为描边单击渐变色板(“线性渐变”“填充渐变”)或填充形状图层,Adobe Color 拾色器将作为渐变编辑器打开,在该对话框的顶端包括用于编辑渐变的其他控件。也可以单击“时间轴”面板中的“编辑渐变”来打开渐变编辑器。

Andrew Devis 在 Creative COW 网站上的视频中演示了如何修改形状图层的渐变填充和笔触以及其他选项。

注意:

sampleImage 表达式方法是对颜色值采样的另一种方法。通过此方法可使用特定像素的颜色值作为表达式的输入。(请参阅图层一般属性和方法(表达式参考)。)

渐变编辑器滤色
A. 不透明度色标 B. 色标 C. 不透明度中点 D. 吸管 E. 新颜色矩形 F. 原始颜色矩形 

选择拾色器

  • 要选择系统颜色,请选择“编辑”>“首选项”>“常规”(Windows) 或“After Effects”>“首选项”>“常规”(Mac OS),然后选中“使用系统拾色器”框。
  • 要使用“Adobe Color 拾色器”,请保持“使用系统拾色器”框处于未选中状态,然后选择“窗口”>“扩展”>“Adobe Color 主题”

注意:

Jeff Almasol 在其 redefinery 网站上提供了可切换“使用系统拾色器”设置的 PickerSwitcher 脚本。当您希望对某些任务使用 Adobe Color 拾色器,但对其他任务使用操作系统拾色器,并且需要一种更改此设置的快速方式,可使用此脚本。

使用吸管工具选择颜色

  1. 单击吸管按钮,然后将指针移至要对其采样的像素。吸管按钮旁边的色板将动态更改为吸管下面的颜色。
  2. 执行以下操作之一:
    • 要选择单个像素的颜色,请单击该像素。

    • 要对 5 像素 x 5 像素区域的颜色平均值进行采样,请按住 Ctrl 键单击 (Windows) 或按住 Command 键单击 (Mac OS) 该区域。

    注意:

    在从“合成”面板的合成帧中采样时,吸管在默认情况下会忽略合成背景颜色并且仅对直接颜色通道进行采样。要对预乘了合成背景颜色的颜色通道进行采样,请在使用吸管单击时,按 Shift 键。在颜色显示在“合成”面板中的合成帧中时,按住 Shift 键并使用吸管单击可对这些颜色进行采样。

注意:

按 Esc 键可停用吸管。

使用 Adobe Color 拾色器选择颜色

在 Adobe Color 拾色器中,您可以使用其中一种颜色模型来选择颜色,或者使用颜色滑块和色域来选择颜色。

以下颜色模型可用:

  • HSB
  • RGB
  • Lab
  • CMYK
  • Hex

使用颜色滑块来选取颜色:

  • 沿颜色滑块拖动三角形,或在颜色滑块内单击可调整色谱中所显示的颜色。
  • 在大方形色谱内单击或拖动可选择颜色。圆形标记指示颜色在色谱中的位置。
  1. 单击“Windows”>“扩展”>“Adobe Color 主题”显示 Adobe Color 拾色器。

  2. (可选)要防止面板在您单击“确定”接受选定颜色之前使用此颜色选择结果进行更新,请取消选择“拾色器”对话框中的“预览”。“预览”选项并非在所有上下文中都可用。

    注意:

    选择“预览”可在您提交颜色选择结果之前轻松查看这些结果,但它也会降低性能,因为会在“合成”面板或“图层”面板中渲染用于预览的新图像。

  3. 在文本框中输入分量值。选择要用于显示色谱的分量:

    HSB

    对于 HSB,将色相 (H) 指定为与在色轮上的位置相对应的从 0° 到 360° 的角度。将饱和度 (S) 和亮度 (B) 指定为百分比 (0-100)。

    H

    在颜色滑块中显示所有色相。在颜色滑块中选择一种色相会在色谱中显示所选色相的饱和度和亮度范围,其中饱和度从左向右增加,而亮度从下向上增加。

    S

    在色谱中显示所有色相,其最高亮度位于色谱顶端,在底端减小到其最小值。颜色滑块显示在色谱中选择的颜色,其最大饱和度位于滑块顶端,其最小饱和度位于底端。

    B

    在色谱中显示所有色相,其最高饱和度位于色谱顶端,在底端减小到其最低饱和度。颜色滑块显示在色谱中选择的颜色,其最高亮度位于滑块顶端,其最低亮度位于底端。

    RGB

    对于 RGB,请指定组件值。您可以在 HDR 项目中将颜色设置为低于范围和超过范围的值(在范围 0.0-1.0 以外)。

    R

    在颜色滑块中显示红色组件,其最高亮度位于滑块顶端,其最低亮度位于底端。在颜色滑块设置为最高亮度时,色谱显示由绿色和蓝色组件创建的颜色。使用颜色滑块增加红色亮度会将更多红色混合到色谱中所显示的颜色中。

    G

    在颜色滑块中显示绿色组件,其最高亮度位于滑块顶端,其最低亮度位于底端。在颜色滑块设置为最高亮度时,色谱显示由红色和蓝色组件创建的颜色。使用颜色滑块增加绿色亮度会将更多绿色混合到色谱中所显示的颜色中。

    B

    在颜色滑块中显示蓝色组件,其最高亮度位于滑块顶端,其最低亮度位于底端。在颜色滑块设置为最低亮度时,色谱显示由绿色和红色组件创建的颜色。使用颜色滑块增加蓝色亮度会将更多蓝色混合到色谱中所显示的颜色中。

    CMYK

    在文本字段中指定各分量值作为青色、洋红、黄色和黑色的百分比,以获取特定颜色。

    Lab

    L

    表示颜色的明亮度(0 至 100)

    a

    某颜色中红色或绿色的程度(-128 至 +127)

    b

    某颜色中蓝色或黄色的程度(-128 至 +127)

    Hex

    输入十六进制形式的值。数字的范围可以从 #000000 到 #ffffff。例如,#000000 代表黑色,#ffffff 代表白色。

编辑渐变

渐变由色标不透明度色标 定义。每个色标具有一个渐变位置以及颜色或不透明度值。在色标之间插入值。默认情况下,插值是线性的,但您可以拖动两个色标之间的不透明度中点或颜色中点来改变插值。

  • 要添加色标或不透明度色标,请单击“渐变编辑器”对话框中渐变栏的下方或上方。
  • 要删除色标,请从渐变栏中拖走它,或选择该色标,然后单击“删除”。
  • 要编辑色标的值,请选择它,然后调整不透明度值,或使用渐变编辑器控件下的 Adobe Color 拾色器控件。
  • 要选择渐变类型,请单击“渐变编辑器”对话框左上角的“线性渐变”或“径向渐变”按钮。

注意:

使用“样式”属性为“渐变叠加”图层样式选择渐变类型。

学习教程

您可以创建和保存颜色主题、浏览和搜索现有主题以及使用 Adobe Creative Cloud 配置文件浏览已保存的颜色主题。请参阅此教程了解如何在 After Effects 中使用 Adobe Color。

颜色校正、颜色分级和颜色调整

在您组合合成时,通常需要调整或校正一个或多个图层的颜色。此类调整可能出于多种原因。例如:

  • 您需要使多个素材项目看起来好像是在相同条件下拍摄的,以便可以一起合成或编辑它们。

  • 您需要调整镜头的颜色,以使其看起来像是在夜晚而非白天拍摄的。

  • 您需要调整图像的曝光度,以从过度曝光的高光中恢复细节。

  • 您需要增强镜头中的一种颜色,因为您将合成其中具有该颜色的图形元素。

  • 您需要将颜色限制到特定范围,例如广播安全范围。

术语颜色校正颜色分级 通常可交替使用,但术语颜色分级 有时用于明确指代为创意目的而非校正颜色问题进行的颜色调整。在 After Effects 中,宽泛地使用术语颜色校正

After Effects 包括颜色校正的许多内置效果,其中包括“曲线”效果、“颜色深度”效果和“颜色校正”效果类别中的其他效果。您还可以使用“应用颜色 LUT”效果应用颜色查找表中的颜色映射,以进行颜色校正。(请参阅“颜色校正”效果“应用颜色 LUT”效果。)

Camera Raw 增效工具可用于校正和调整 JPEG、TIFF 和各种摄像机原始数据格式的静止图像。

After Effects 中的 Synthetic Aperture Color Finesse 增效工具包括出色的颜色校正工具。After Effects CC 和 CS6 包括 Synthetic Aperture Color Finesse 3。(请参阅合成孔径色彩技巧的资源。)

有关颜色校正和调整的其他资源

此 Adobe 博客文章收集了多个在 After Effects 和 Premiere Pro 中进行颜色校正和颜色分级的视频教程和其他资源。

John Dickinson 在其 Motionworks 网站上提供了直观的帮助内容,以阐述如何使用“曲线”和“色阶”效果进行颜色调整:

After Effects:看视频学习系列教程中的此视频演示了如何通过结合运动跟踪和动态抠像,来隔离男演员的脸部并有选择地对其进行颜色校正。

Rebel CC 动画预设是用于对影片进行染色或分级的电视电影样式的简单颜色校正工具。此动画预设使用表达式来控制“色阶(单独控件)”效果。要了解详细信息并下载动画预设,请参阅 Stu Maschwitz 的 ProLost 博客

Stu Maschwitz 在其 ProLost 博客上提供了一篇文章来讨论肤色的颜色校正,并且包括有关在矢量显示器上显示各种肤色的测试设置的一些资源的链接。

Mark Christiansen 在 Peachpit Press 网站上的 After Effects 摄影棚技术的“Adobe After Effects 中的颜色校正”一章中提供了有关颜色校正、颜色调整和颜色匹配的提示和详细技术。

使用直方图调整颜色

直方图 是图像中每个明亮度值的像素数量表示形式。每个明亮度值都不为零的直方图表示利用完整色调范围的图像。没有使用完整色调范围的直方图对应于缺少对比度的昏暗图像。

一种常见的颜色校正任务是调整图像以在直方图上从左向右更均匀地分布像素值,而不是将其集中在一端或另一端。在直方图中应用“色阶”效果并调整其“输入白色”和“输入黑色”属性是一种针对许多图像完成此任务的简单而有效的方法。

不使用完整色调范围的图像的直方图
不使用完整色调范围的图像的直方图

输入滑块已移动,以便输出使用完整色调范围
输入滑块已移动,以便输出使用完整色调范围

显示高光剪切的直方图
显示高光剪切的直方图

显示阴影剪切的直方图
显示阴影剪切的直方图

“Lumetri Scopes”面板

“Lumetri Scopes”面板为您提供用来显示视频色彩属性的内置视频示波器。视频示波器包括:

  • 矢量示波器
  • 直方图
  • 分量
  • 波形
“Lumetri Scopes”面板中的视频示波器
“Lumetri Scopes”面板中的视频示波器

每个视频帧都由像素组成,每个像素都带有色彩属性,可以将这些属性归类为色度、亮度和饱和度。您可以评估色彩属性,从而对视频进行颜色校正并确保镜头间的一致性。

针对广播工作流程的“Lumetri Scopes”支持

“Lumteri 范围”面板专为广播色彩工作流程而设计。此面板在 Rec. 601、Rec. 709 和 Rec. 2020 色彩空间中测量颜色。要打开色彩空间,请右键单击“Lumetri Scopes”面板,然后选择“色彩空间”

  • Rec. 601:此色彩空间用于以数字视频格式为模拟视频信号编码。
  • Rec. 709:此色彩空间用于 HDTV 常规工作流程。
  • Rec 2020:此色彩空间用于 HDR 和 UHDTV(UHD 4k 和 UHD 8k)。

如果为 After Effects 项目设置了不同的色彩空间,此示波器会按照您的色彩空间呈现合成的外观,但会转换为在“Lumetri Scopes”面板中设置的色彩空间(601、709 或 2020)。

有关广播色彩工作流程的更多信息,请参阅广播安全色彩

与色彩工具配合使用的工作区

After Effects 中有一个名为“色彩”的新工作区,可以与“Lumetri Scopes”面板和 Lumetri Color 效果配合使用。要打开工作区,请选择“窗口”>“工作区”菜单

打开与色彩工具配合使用的工作区
打开与色彩工具配合使用的工作区

同步当前查看器面板

“Lumetri Scopes”面板分析和显示在当前查看器面板中所做的更改。它从当前“合成”“图层”“素材”面板测量色彩。您可以将当前查看器更改为查看不同结果。要将“Lumetri Scopes”显示锁定到特定查看器面板,请在查看器面板中启用“主要查看器”选项。例如,当您修改合成的 RGB 色彩曲线时,波形会拾取此色彩并显示变化的色彩信息。

有关面板的更多信息,请参阅面板和工作区

使用“Lumetri Scopes”读取色彩信息之前
使用“Lumetri Scopes”读取色彩信息之前

按照“Lumetri Scopes”色彩信息更改合成之后
按照“Lumetri Scopes”色彩信息更改合成之后

After Effects 中的“Lumetri Scopes”面板

After Effects 中的“Lumetri Scopes”面板
观看此视频,了解关于使用 After Effects 中的“Lumetri Scopes”面板改进颜色的信息

After Effects 中的“Lumetri Scopes”面板与 Premiere Pro 中的“Lumetri Scopes”面板相同。有关此面板的更多信息,请参阅 Premiere Pro 中的 Lumetri Scopes

Synthetic Aperture Color Finesse 的相关资源

After Effects 中的 Synthetic Aperture Color Finesse 增效工具包括出色的颜色校正工具。Synthetic Aperture 在其网站上提供了有关使用 Color Finesse 的教程和其他信息。

Color Finesse 将其文档安装在“增效工具”文件夹中对应的子文件夹中。After Effects 包括 Synthetic Aperture Color Finesse 3。(请参阅增效工具。)

颜色模型和色彩空间

颜色模型 是使用数字描述颜色以便计算机可以操作它们的方式。在 After Effects 中使用的颜色模型是 RGB 颜色模型,在这种模型中,根据共同组成每种颜色的红色、绿色和蓝色的光量描述该颜色。其他颜色模型包括 CMYK、HSB、YUV 和 XYZ。

色彩空间 是颜色模型的变体。可通过色域(颜色范围)、一组基色(基色)、白场色调响应 来区分色彩空间。例如,RGB 颜色模型中具有多个色彩空间,包括 ProPhoto RGB、Adobe RGB、sRGB IEC61966-2.1 和 Apple RGB(按色域大小的降序顺序排列)。虽然其中每个色彩空间均使用相同的三个轴(R、G 和 B)定义颜色,但它们的色域和色调响应曲线却不相同。

虽然许多设备都使用红色、绿色和蓝色组件来记录或表达颜色,但这些组件具有不同特性,例如,一个摄像机的蓝色与另一个摄像机的蓝色不完全相同。记录或表达颜色的每台设备均具有自己的色彩空间。在将图像从一台设备移至另一台设备时,由于每台设备会按照自己的色彩空间解释 RGB 值,因此,图像颜色可能会看起来有所不同。

色彩管理使用颜色配置文件将颜色从一个色彩空间转换为另一个色彩空间,因此颜色在一台设备和另一台设备之间看起来相同。

灰度系数和色调响应

色彩空间的色调响应 表示光照强度与创建或记录(感觉)光照的信号的关系。

人类的视觉系统不会对光照做出线性响应。换句话说,当在给定时间中两倍之多的光子到达我们的眼睛中时,我们感觉到的光照亮度不会加倍。类似地,在应用两倍高的电压时,CRT 显示器的显示元素不会发出两倍亮度的光照。光照强度与显示设备的信号强度的关系由幂函数表示。此幂函数的指数称为灰度系数。一般来说,光照强度与输入设备的信号强度的关系和光照强度与输出设备的信号强度的关系是相反的,但输入和输出设备的灰度系数值可能不同以适应场景照明和观看环境的照明之间的差异。

注意:

在颜色校正直方图中移动中间色调滑块(例如“色阶”效果的“灰度系数”控件)与修改灰度系数、更改色调响应曲线而不移动白场具有相同的结果。修改“曲线”效果中的曲线也会修改色调响应,但对于灰度系数曲线不一定如此。

Charles Poynton 在他的网站上提供了一系列与灰度系数和其他色彩技术相关的丰富资源。

线性色调响应:在灰度系数等于 1 时

任何数的 1 次幂提供原始数作为结果。灰度系数 1.0 用于表示光照在我们的非线性感知系统的上下文外部的自然界中的行为。灰度系数为 1.0 的系统有时被认为在线性光 中操作,而使用非 1.0 的灰度系数编码以匹配人类视觉系统的系统称为感知系统

如果您启用了色彩管理(通过指定工作色彩空间),则可以通过线性化工作色彩空间在线性光中执行所有颜色操作。线性化色彩空间使用与非线性版本相同的基色和白场;色调响应曲线仅转变为直线。

注意:

可在线性色彩空间中执行许多合成操作(例如使用混合模式组合颜色)。要以最自然逼真的方式混合颜色,请使用线性色彩空间。如果您没有启用色彩管理,则仍可以使用灰度系数 1.0 执行混合操作。(请参阅线性化工作区和启用线性混合。)

系统灰度系数、设备灰度系数以及场景和观看环境之间的差异

整个系统(从捕获到制作,再到在观看环境中显示)的灰度系数值是系统中每个阶段所使用的灰度系数值的积。此乘积不总是 1.0,因为它将在为编码执行的操作与为解码执行的操作完全匹配(反转)时为 1.0。系统灰度系数不为 1.0 的一个原因是,在其中捕获场景的光照条件和在其中观看场景的光照条件之间通常存在差异。(考虑您通常在暗淡的环境中观看影片,但场景通常不是在暗淡的环境中拍摄的。)

例如,HD 摄像机的设备灰度系数 大约为 1/1.9,而 HD 显示器的设备灰度系数大约为 2.2。这些值相乘提供的系统灰度系数 大约为 1.15,这适合典型起居室的有点暗淡的电视观看条件。电影制作的系统灰度系数高很多(大约为 1.5-2.5),以适应电影院中较暗的观看环境。负片的灰度系数大约为 1/1.7,而投影胶片的灰度系数大约为 3-4。

如果颜色配置文件的色调响应曲线基于典型场景中的条件,则将这些颜色配置文件称为场景引用。如果颜色配置文件的色调响应曲线基于典型观看环境中的条件,则将这些颜色配置文件称为输出引用

默认情况下,如果您使用色彩管理,则在场景引用的颜色配置文件和输出引用的颜色配置文件之间转换时,After Effects 会自动调整图像的对比度。此自动转换(图像状态调整)基于 HDTV 视频标准中所指定的灰度系数值。

  • 要禁用此自动颜色变换,请取消选择“项目设置”对话框(“文件”>“项目设置”)中的“补偿场景引用的配置文件”。

Adobe Photoshop CS4 及更高版本中也具有“补偿场景引用的配置文件”功能,但其他应用程序不具有此功能。要与其他应用程序(包括 After Effects CS3 及更低版本)中的颜色匹配,请禁用此自动转换。在您打开在 After Effects CS3 或更低版本中创建的项目时,请取消选择“补偿场景引用的配置文件”选项。

“颜色配置文件转换器”效果的每个实例也可以设置为补偿场景引用的配置文件,不补偿场景引用的配置文件,或使用项目的“补偿场景引用的配置文件”选项所指示的设置。(请参阅“颜色配置文件转换器”效果。)

有关补偿场景引用的配置文件的其他信息,请参阅 Adobe 网站上由 Todd Kopriva 和 Peter Constable 撰写的这篇博客文章

非色彩管理的项目中的 QuickTime 和灰度系数

After Effects 7.0 及更低版本使用 QuickTime 编解码器来对多种媒体进行解码,并且由 Windows 上的 QuickTime 执行的灰度系数调整与在 Mac OS 上执行的灰度系数调整不同。After Effects CS3 及更高版本所执行的灰度系数调整与这些 QuickTime 编解码器所执行的灰度系数调整不同。Windows 上的 After Effects CS3 及更高版本所执行的灰度系数调整与 Mac OS 上的 After Effects CS3 及更高版本所执行的灰度系数调整相同。此外,如果不使用 QuickTime 编解码器,After Effects 将保留 32-bpc 项目中超过范围的值。

选择“项目设置”对话框中的“与旧版 After Effects QuickTime 灰度系数调整匹配”可实现以下任何目的:

  • 在使用在 After Effects 7.0 或更低版本中创建的项目时,避免颜色变化

  • 与在 After Effects 7.0 或更低版本中创建的项目中的颜色匹配

  • 确保“合成”面板中的颜色与 QuickTime 播放器中的颜色匹配

默认情况下,为在 After Effects 7.0 或更低版本中创建的项目选择“与旧版 After Effects QuickTime 灰度系数调整匹配”选项。您应该在没有选择此选项的情况下创建新项目。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略