用户指南 取消(C)

分类动画工具

  1. After Effects 用户指南
  2. Beta 版
    1. Beta 版项目概述
    2. After Effects Beta 版主页
  3. 快速入门
    1. After Effects 快速入门
    2. After Effects 的新增功能 
    3. 发行说明 | After Effects
    4. After Effects 系统要求
    5. After Effects 中的键盘快捷键
    6. 支持的文件格式 | After Effects
    7. 硬件建议
    8. 适用于 Apple Silicon 的 After Effects
    9. 规划和设置
  4. 工作区
    1. 常规用户界面项
    2. 了解 After Effects 界面
    3. 工作流程
    4. 工作区、面板和查看器
  5. 项目与合成
    1. 项目
    2. 合成基础知识
    3. 预合成、嵌套和预渲染
    4. 使用合成分析器查看详细的性能信息
    5. CINEMA 4D 合成渲染器
  6. 导入素材
    1. 准备并导入静止图像
    2. 从 After Effects 和 Adobe Premiere Pro 导入
    3. 导入和解释视频与音频
    4. 准备和导入 3D 图像文件
    5. 导入和解释素材项目
    6. 使用素材项目
    7. 使用“场景编辑检测”检测编辑点
    8. XMP 元数据
  7. 文本和图形
    1. 文本
      1. 设置字符格式和“字符”面板
      2. 文本效果
      3. 创建和编辑文本图层
      4. 设置段落格式和“段落”面板
      5. 凸出文本和形状图层
      6. 为文本设置动画
      7. 文本动画的示例和资源
      8. 实时文本模板
    2. 动态图形
      1. 在 After Effects 中使用动态图形模板
      2. 使用表达式在动态图形模板中创建下拉列表
      3. 使用“基本属性”创建动态图形模板
      4. 替换动态图形模板和基本属性中的图像和视频
      5. 使用“属性”面板更快、更轻松地制作动画
  8. 绘图、绘画和路径
    1. 形状图层、路径和矢量图形的概述
    2. 绘画工具:笔刷、仿制图章和橡皮擦
    3. 将形状描边椎体化
    4. 形状图层的形状属性、绘画操作和路径操作
    5. 使用“位移路径”形状效果更改形状
    6. 创建形状
    7. 创建蒙版
    8. 使用内容识别填充面板,移除视频中的对象
    9. Roto 笔刷和调整遮罩
  9. 图层、标记和摄像机
    1. 选择和排列图层
    2. 混合模式和图层样式
    3. 3D 图层
    4. 图层属性
    5. 创建图层
    6. 管理图层
    7. 图层标记和合成标记
    8. 摄像机、光和目标点
  10. 动画、关键帧、运动跟踪和抠像
    1. 动画
      1. 动画基础知识
      2. 使用人偶工具制作动画
      3. 管理形状路径和蒙版并对其进行动画制作
      4. 使用 After Effects 为 Sketch 和 Capture 形状制作动画
      5. 分类动画工具
      6. 使用数据驱动的动画
    2. 关键帧
      1. 关键帧插值
      2. 设置、选择和删除关键帧
      3. 编辑、移动和复制关键帧
    3. 运动跟踪
      1. 跟踪和稳定运动
      2. 人脸跟踪
      3. 蒙版跟踪
      4. 蒙版引用
      5. 速度
      6. 时间拉伸和时间重映射
      7. 时间码和时间显示单位
    4. 抠像
      1. 抠像
      2. 抠像效果
  11. 透明度与合成
    1. 合成和透明度概述及资源
    2. Alpha 通道和遮罩
    3. 轨道遮罩和移动遮罩
  12. 调整颜色
    1. 颜色基础知识
    2. 色彩管理
    3. 颜色校正效果
    4. OpenColorIO 和 ACES 色彩管理
  13. 效果和动画预设
    1. 效果和动画预设概述
    2. 效果列表
    3. 效果管理器
    4. 模拟效果
    5. 风格化效果
    6. 音频效果
    7. 扭曲效果
    8. 透视效果
    9. 通道效果
    10. 生成效果
    11. 过渡效果
    12. 果冻效应修复效果
    13. 模糊和锐化效果
    14. 3D 通道效果
    15. 实用效果
    16. 遮罩效果
    17. 杂色和颗粒效果
    18. 保留细节放大效果
    19. 旧版效果
  14. 表达式和自动化
    1. 表达式
      1. 表达式基础知识
      2. 了解表达式语言
      3. 使用表达式控件
      4. JavaScript 与旧版 ExtendScript 表达式引擎之间的语法差别
      5. 正在编辑表达式
      6. 表达式错误
      7. 使用表达式编辑器
      8. 使用表达式编辑和访问文本属性
      9. 表达式语言引用
      10. 表达式示例
    2. 自动化
      1. 自动化
      2. 脚本
  15. 沉浸式视频、VR 和 3D
    1. 在 After Effects 中构造 VR 环境
    2. 应用沉浸式视频效果
    3. 用于 VR/360 视频的合成工具
    4. 高级 3D 渲染器
    5. 将 3D 模型导入并添加到合成中
    6. 从 Creative Cloud Libraries 导入3D 模型
    7. 基于图像的光照
    8. 从 3D 模型中提取光线和相机并为其制作动画
    9. 跟踪 3D 摄像机运动
    10. 投影和接受阴影
    11. 使用 3D 设计空间
    12. 3D 变换 Gizmo
    13. 使用 3D 动画执行更多操作
    14. 使用 Mercury 3D 引擎实时预览对 3D 设计的更改
    15. 向图形添加响应式设计
  16. 视图和预览
    1. 预览
    2. 使用 Mercury Transmit 进行视频预览
    3. 修改和使用视图
  17. 渲染和导出
    1. 渲染和导出基础知识
    2. After Effects 中的 H.264 编码
    3. 将 After Effects 项目导出为 Adobe Premiere Pro 项目
    4. 转换影片
    5. 多帧渲染
    6. 自动渲染和网络渲染
    7. 渲染和导出静止图像及静止图像序列
    8. 在 After Effects 中使用 GoPro CineForm 编解码器
  18. 使用其他应用程序
    1. Dynamic Link 和 After Effects
    2. 使用 After Effects 和其他应用程序
    3. After Effects 中的同步设置
    4. After Effects 中的 Creative Cloud Libraries
    5. 增效工具
    6. Cinema 4D 和 Cineware
  19. 协作:Frame.io 和团队项目
    1. 在 Premiere Pro 和 After Effects 中协作
    2. Frame.io
      1. 安装和激活 Frame.io
      2. 将 Frame.io 与 Premiere Pro 和 After Effects 搭配使用
      3. 常见问题解答
    3. 团队项目
      1. 开始使用团队项目
      2. 创建团队项目
      3. 使用团队项目进行协作
  20. 内存、存储、性能
    1. 内存和存储
    2. After Effects 处理预览时内存不足问题的方式    
    3. 提高性能
    4. 首选项
    5. After Effects 的 GPU 和 GPU 驱动程序要求
  21. 知识库
    1. 已知问题
    2. 已修复的问题
    3. 常见问题解答
    4. After Effects 和 macOS Ventura
    5. After Effects 处理预览时内存不足问题的方式

了解 After Effects 中的各种动画工具,它们可让您快速、高效地创建流畅且风格化的动画。

运动路径

当您为空间属性(包括位置锚点和效果控制点属性)添加动画时,运动将显示为运动路径。运动路径显示为一连串的点,其中每个点标记图层中每个帧的位置。路径中的方框标记关键帧的位置。

除了使用时间轴面板中的属性外,还可以使用运动路径作为查看和处理空间属性及其关键帧的备选直观方式。您可以通过更改现有关键帧或添加关键帧,来修改运动路径。还可以通过更改运动路径的关键帧的空间插值方法,来修改其形状。

运动路径中方框之间的点密度表示图层或效果控制点的相对速度。点密度越大表示速度越低;点密度越小表示速度越高。

注意:

右键单击 (Windows) 或按住 Command 单击 (macOS) 关键帧可打开其上下文菜单。

合成图层面板中使用钢笔工具或选择工具编辑某个空间属性的关键帧就像在形状图层上修改蒙版或形状的贝塞尔曲线路径

当您使用较少关键帧描述路径时,运动路径不太复杂且通常更易于修改。您可以使用平滑器从运动路径中移除多余的关键帧。

显示运动路径控件

位置运动路径显示在合成面板中。锚点和效果控制点运动路径显示在图层面板中。

  • 要在合成面板中显示运动路径控件,请选择视图 > 视图选项,然后选择效果控件关键帧运动路径运动手柄。要在合成面板中查看位置运动路径,则必须选择位置属性。
  • 要在图层面板中显示运动路径控件,请在图层面板底部的视图菜单中选择属性或效果。
  • 要指定针对运动路径显示多少关键帧,请选择编辑 > 首选项 > 显示 (Windows),或者选择 After Effects > 首选项 > 显示 (macOS),然后选择运动路径部分中的选项。
  • 要指定运动路径贝塞尔曲线方向手柄的大小,请选择编辑 > 首选项 > 常规 (Windows),或者选择 After Effects > 首选项 > 常规 (macOS),然后编辑路径点和手柄大小值。

移动运动路径关键帧

  1. 时间轴面板中,选择要修改其运动路径的图层。

  2. 如果您在合成面板或图层面板中无法看到要修改的关键帧,则将当前时间指示器移至该关键帧。

  3. 合成面板或图层面板中,使用选择工具拖动关键帧或其手柄。

    注意:

    在您拖动关键帧之前,当前时间指示器不需要位于该关键帧上。

    位置关键帧是在“合成”面板中选择的。
    在“合成”面板中选择位置关键帧。

    移动选定位置关键帧的方式是在“合成”面板中拖动它。
    通过在“合成”面板中拖动选定的位置关键帧来移动它。

    合成面板或图层面板中拖动关键帧之前,可以通过在时间轴面板中选中它们,然后一次移动多个关键帧。要移动整个运动路径,请在合成面板中拖动关键帧之前,在时间轴面板中通过单击属性名称来选择所有关键帧。

    所有位置关键帧均在“合成”面板中选择。
    在“合成”面板中选择所有位置关键帧。

    移动选定位置关键帧的方式是在“合成”面板中拖动它。
    将运动路径上的所有关键帧拖动一个关键帧。

使用钢笔工具向运动路径中添加关键帧

  1. 合成面板或图层面板中显示要修改的运动路径。

  2. 选择钢笔工具   或添加顶点工具 (从工具面板中)。

  3. 合成面板中,将钢笔工具置于要添加新关键帧的运动路径上并选择,然后单击以添加关键帧。

    新的关键帧将显示在运动路径上和时间轴面板中您所选择的帧上。要移动关键帧,请使用选择工具。

    注意:

    虽然结果不同,但使用钢笔工具操纵运动路径曲线的技术与用于创建和修改其他贝塞尔曲线路径(例如蒙版和形状路径)的技术几乎一样。

使用动态草图绘制运动路径

您可以使用动态草图绘制选定图层的运动路径,动态草图记录图层的位置和绘制的速度。在绘制时,每个帧处都将生成一个位置关键帧。

动态草图不影响您为其他属性设置的关键帧。例如,如果您为球体图像设置旋转关键帧,则可以使用动态草图生成位置关键帧,以便使球体看起来沿着您创建的路径滚动。

  1. 在“合成”或“时间轴”面板中,选择您想为其绘制运动路径的图层。
  2. 时间轴面板中,对您想要绘制运动路径的时间区间设置工作区域标记(图层 > 标记 > 添加标记)。

  3. 如果您想在绘制草图时在合成中保持音频播放,请确保静音 按钮未在预览面板中选中。

  4. 选择窗口 > 动态草图

  5. 选择适当的动态草图选项:

    捕获速度为

    所记录运动的速度与播放速度的比率。如果捕获速度为 100%,则运动按记录它的速度播放。如果捕获速度大于 100%,则运动按低于记录它的速度播放。

    平滑

    从运动路径中清除不需要的关键帧。此设置与使用容差设置和平滑器的结果相同。值越高生成的曲线越平滑,但太高的值可能无法保持您所绘制的曲线的形状。

    注意:

    您可以在创建运动路径后,通过使用平滑表达式或平滑器来平滑该运动路径。

    显示线框

    绘制运动路径时显示图层的线框视图。

    显示背景

    显示绘制时您在合成面板中开始绘制的帧的静态内容。如果您希望相对于合成中的其他图像绘制运动路径,则此选项很有用。

  6. 选择开始捕获,然后拖入合成面板以创建运动路径。通过释放鼠标按钮停止捕获。

    注意:

    After Effects 在捕获时间到达工作区域的末端(默认情况下为合成持续时间)时自动结束捕获。

从蒙版、形状或已绘制路径创建运动路径。

您可以从多种类型的路径创建运动路径。

  • 蒙版路径属性

  • 形状图层的形状路径属性

  • 绘画描边的路径属性

  • 从 Illustrator 或 Photoshop 复制的路径

您可以将任意这些路径粘贴到图层的位置锚点属性,或粘贴到效果控制点的位置属性。除了第一个或最后一个关键帧,这些已粘贴的关键帧将设置为在时间点处漂浮以创建沿路径的恒定速度。

默认情况下,已粘贴运动路径的持续时间为 2 秒。您可以通过在时间轴面板中拖动第一个关键帧或最后一个关键帧来调整持续时间。

  1. 将路径复制到剪贴板:
    • 时间轴面板中选择路径属性,然后选择编辑 > 复制

    • 选择 Illustrator 或 Photoshop 中的路径,然后选择编辑 > 复制

  2. 时间轴面板中,选择要向其中粘贴路径的属性。

  3. 将当前时间指示器置于运动路径中第一帧的时间点位置。
  4. 选择编辑 > 粘贴

运动模糊

在您查看包含运动对象的动作影片或视频的一帧时,图像通常是模糊的,因为一帧表示时间的一个样本(在电影中,一帧是 1/24 秒)。在该时间内,运动对象在跨帧行进时占据多个位置,因此它看起来不是一个清晰的静止对象。对象移动越快,越模糊。摄像机快门角度和快门相位也影响模糊的外观,因此,需要确定快门保持打开状态多长时间,以及相对于帧的开始打开快门的时间。

相比之下,在计算机生成的动画的单帧中,您可能无法分辨哪些对象正在移动,因为所有移动对象都看起来与未移动对象一样清晰。如果不使用运动模糊,图层动画将在各个步骤中生成类似于笔触的效果,而不是显示连续的变化。将运动模糊添加到您要在 After Effects 中制作动画的图层中可以使运动看起来更平滑且更自然。

您可以单独为每个图层启用运动模糊,另外还可确定是否针对预览和最终输出渲染运动模糊。使用时间轴面板顶部的启用运动模糊合成开关 可针对预览启用或禁用运动模糊渲染。在渲染队列面板中修改渲染设置可针对最终输出启用或禁用运动模糊渲染。如果启用常规首选项类别中的开关影响嵌套的合成首选项,则嵌套合成将采用包含它们的合成的设置。

运动模糊会使渲染速度变慢,因此您可能需要在工作时禁用合成开关,并仅在查看完成后的结果时才启用它。

要为图层启用运动模糊,请执行以下任一操作:

  • 时间轴面板中选择该图层的运动模糊  图层开关。
  • 选择该图层并选择图层 > 开关 > 运动模糊

根据该图层的运动,After Effects 用于计算运动模糊的采样数与各图层相匹配。该自适应性可提供高品质的运动模糊,并且不需要像对快速移动图层运动采样那样频繁地对慢速移动图层运动采样。高采样率会降低渲染性能。

当针对合成启用运动模糊时,时间轴面板将放大以便您可以查看各个帧,当前时间指示器周围的浅灰色区域指示快门相位和快门角度。列宽度显示快门角度,而列偏移则显示快门相位。这种直观的表示指明如何对各个帧进行采样,以计算该合成中的运动模糊。

当您制作动画图层时(例如跨屏幕移动文本图层),可以使用运动模糊。您不能通过运动模糊图层开关和启用运动模糊开关,来为图层中已存在的运动添加运动模糊。

如果您想要平滑为其指定了比原始值低得多或高得多的帧速率的实景视频,可使用帧混合,而非运动模糊。

要创建假运动模糊,请参阅应用运动模糊

合成设置“高级”选项卡中的运动模糊设置

会打开“合成设置”对话框,其中包含用于配置运动模糊的选项,包括快门角度、调整器相位等。
使用“运动模糊”部分下的选项来自定义运动模糊并实现逼真的效果。

每帧采样数

最小采样数。此最小数是用于 After Effects 不能根据图层运动确定其自适应采用率的帧的采样数。此采样率用于 3D 图层和形状图层。

自适应采样限制

最大采样数。

快门角度

快门角度的单位是度,模拟旋转快门所允许的曝光。快门角度使用素材帧速率确定影响运动模糊量的模拟曝光。例如,为 24-fps 的素材输入 90°(360°的 25%)将创建 1/96 秒(1/24 秒的 25%)的有效曝光。输入 1° 时几乎不应用任何运动模糊,而输入 720° 则会应用大量模糊效果。

快门相位

快门相位的单位也是度。它定义一个相对于帧开始位置的偏移量,用于确定快门何时打开。如果应用了运动模糊的对象看起来滞后于未应用运动模糊的对象的位置,则调整此值可能会有帮助。

注意:

对于使用运动跟踪数据在其他图层上合成的图层,最好使快门相位值为快门角度值的 -1/2。(例如,快门相位 = -90,快门角度 = 180。)此设置组合会导致原始对象的中心位置模糊。

将运动模糊应用于蒙版

运动模糊根据合成中蒙版的运动创建模糊。您可以对单个蒙版应用运动模糊。在每个合成中,必须为所有图层或图层内的所有蒙版启用运动模糊开关才能应用运动模糊。

  1. 选择一个或多个蒙版。
  2. 选择图层 > 蒙版 > 运动模糊,然后选择以下选项之一:

    与图层相同

    仅在为图层启用运动模糊开关时,蒙版才能应用运动模糊。

    不管图层的启用运动模糊开关的设置如何,蒙版都将应用运动模糊。

    不会对蒙版应用运动模糊。

有关运动模糊的其他资源

当您拍摄一个快速运动的对象时,对它进行渲染会产生运动模糊。此外,如果用高快门速度拍摄运动对象,这些对象会在帧之间跳动,导致频闪运动。

After Effects 中的像素运动模糊效果可跟踪帧间像素的运动。此效果会分析剪辑以确定运动中的各个部分、创建一组运动矢量,然后使用这些信息在帧内添加运动模糊。

如果对象移动太快,请提高快门采样值,创建更多的中间帧。提高矢量细节值,最大限度降低在帧间分析像素组时出现错误的可能性。

通过移除额外关键帧平滑运动和速度

使用添加关键帧或删除不需要关键帧的平滑器可平滑运动路径、值曲线和速度曲线,从而移除不平整的地方或多余的关键帧。

注意:

您也可以使用平滑表达式方法实现该目的,但不能移除关键帧。请参阅属性特性和方法(表达式参考)了解更多信息。

虽然您可以平滑任何属性的曲线,但平滑器在应用于动态草图自动生成的曲线时最有用,因为在该曲线中可能有多余的关键帧。将平滑器应用于手动设置的关键帧可能会导致曲线出现意外变化。

注意:

要避免对由动态草图生成的路径使用平滑器,请在绘制运动路径之前,在动态草图面板中设置平滑选项。

当您将平滑器应用于空间变化的属性(如位置)时,您只能平滑空间曲线(由运动定义的曲线)。当您将平滑器应用于仅在时间上变化的属性(如不透明度)时,您只能平滑值和速度曲线(由值或速度定义的曲线)。

除添加关键帧或移除不必要的关键帧之外,平滑器还可以在平滑时间曲线时对每个关键帧应用贝塞尔曲线插值

  1. 时间轴面板中,选择属性的所有关键帧可平滑整条曲线,或至少选择三个关键帧以便仅平滑部分曲线。

  2. 选择窗口 > 平滑器。在应用到菜单中,平滑器自动选择空间路径时间图表,这取决于您在第 1 步中为其选择关键帧的属性类型。

  3. 设置容差值。

    容差的单位与您进行平滑处理的属性的单位相同。新关键帧值的变化不会超过原始曲线指定的值。值越高,生成的曲线越平滑,但过高的值可能无法保持曲线的原始形状。

  4. 单击应用并预览结果。

  5. 必要时,选择编辑 > 还原平滑器以重置关键帧,调整容差的值,然后重新应用平滑器

使用摇摆器对属性应用随机性

您可以使用摇摆器在属性随时间变化时对该属性应用随机性。

注意:

您也可以使用 wiggle 表达式方法实现此目的。通常情况下,使用表达式比使用摇摆器更简单。

根据您指定的属性和选项,摇摆器通过添加关键帧并随机化进入或离开现有关键帧的插值,将一定数量的偏离添加到属性中。您至少需要两个关键帧才能使用摇摆器。

使用摇摆器,您可以在规定的限制内更准确地模拟自然运动。例如,在蝴蝶动画中应用随机性以产生飞舞的感觉。通过将其添加到亮度或不透明度来模拟旧投影仪的闪烁。

  1. 选择属性的一定范围的关键帧。
  2. 选择窗口 > 摇摆器

    会打开“运动模糊”面板,其中包含用于自定义模糊效果的选项。
    使用“运动模糊”面板中的选项自定义合成中的模糊效果。

  3. 对于应用到,选择您希望摇摆器更改的曲线类型。如果选择空间变化属性的关键帧,则可以选择空间路径以将偏离添加到运动中,或选择时间图表将偏离添加到速度中。如果选择非空间变化的属性的关键帧,则仅可以选择时间图表

  4. 选择杂色类型选项以指定因随机分布的像素值(杂色)而产生的偏离类型:

    平滑杂色

    生成更为平缓的偏离,没有突兀的变化。

    成锯齿状的杂色

    生成突兀的变化。

  5. 选择您想影响的属性的维度:

    X、Y 或 Z

    将偏离仅添加到选定属性的一个 维度中。从菜单中选择维度。

    全部独立

    将不同组的偏离单独添加到每个维度中。

    所有相同

    将同一组偏离添加到所有维度中。

  6. 设置频率以指定 After Effects 每秒向选定关键帧中添加多少偏离(关键帧)。较低的值仅偶尔生成偏离,而较高的值会生成更不规则的结果。小于 1 的值以不到每秒一个的间隔创建关键帧。例如,值 0.5 每 2 秒创建一个关键帧。

  7. 设置数量级以指定偏离的最大大小。After Effects 对选定属性的单位设置指定的数量级,因此某个属性的值在其他属性中可能生成不同的结果。

  8. 选择应用并预览结果。

  9. 必要时,选择编辑 > 还原摇摆器以重置关键帧,调整频率数量级的值,然后重新应用摇摆器

将音频转换为关键帧

将音频转换为关键帧关键帧助手可分析工作区域中的音频振幅并为音频振幅创建关键帧。

  1. 当合成在合成面板或时间轴面板中处于活动状态时,选择动画 > 关键帧助手 > 将音频转换为关键帧

此关键帧助手可创建表示合成中所有音源的音频振幅图层,其中的三个表达式控制效果具有包含以下关键帧的滑块属性:左声道右声道双声道

要使用此关键帧助手创建的关键帧,请将音频振幅中的变化与其他图层属性链接。例如,使用表达式将音频关键帧与图层的缩放属性链接,以使图层随着振幅的增大和减小进行扩展和收缩。

 Adobe

更快、更轻松地获得帮助

新用户?