使用此文档了解关于 After Effects 中项目类型的信息。

关于项目

After Effects 项目是一个文件,用于存储合成以及该项目中素材项目所使用的全部源文件的引用。合成是图层的集合。许多图层使用素材项目(例如影片或静止图像)作为源,但某些图层(例如形状图层和文本图层)包含您在 After Effects 中创建的图形。

项目文件使用文件扩展名 .aep.aepx。使用 .aep 文件扩展名的项目文件是二进制项目文件。使用 .aepx 文件扩展名的项目文件是基于文本的 XML 项目文件。

当前项目的名称显示在应用程序窗口的顶部。

模板项目文件使用文件扩展名 .aet。(请参阅模板项目和示例项目。)

XML 项目文件

基于文本的 XML 项目文件将一些项目信息包含为十六进制编码的二进制数据,但是其中多数信息在 string 元素中公开为可读文本。您可以在文本编辑器中打开 XML 项目文件,并编辑该项目的一些详细信息,而无需在 After Effects 中打开该项目。您甚至可以编写脚本,作为自动化的工作流的一部分修改 XML 项目文件中的项目信息。

您可以在 XML 项目文件中修改的项目的元素:

  • 标记属性,包括注释、章节点参数和提示点参数

  • 源素材项目的文件路径,包括代理

  • 合成、素材项目、图层以及文件夹名称和注释

注意:

只有当已自定义素材项目名称时,这些名称才会显示在 XML 项目文件的字符串元素中。自动从源文件名称和纯色名称派生的素材项目名称不会显示在字符串元素中

诸如工作区和视图名称之类的一些字符串会显示为可读字符串,但在 After Effects 打开项目文件时,不会考虑对这些字符串所做的修改。

注意:

请勿将 XML 项目文件格式用作您的主要文件格式。After Effects 的主要项目文件格式是二进制项目文件 (.aep) 格式。使用 XML 项目文件格式来保存项目的副本并作为自动工作流的中间格式。

注意:

要将 XML 项目 (.aepx) 文件另存为二进制项目 (.aep) 文件,请选择“文件”>“另存为”并输入一个以 .aep(不含 x)结束的文件名。(请参阅在 After Effects 中保存和备份项目。)

在 QuickTime、Video for Windows 文件中嵌入项目链接

当您渲染影片并将其导出为容器格式时,您可以在容器文件中嵌入一个指向 After Effects 项目的链接。

要导入项目,请导入容器文件,并从“导入文件”对话框的“导入为”菜单中选择“项目”。如果容器文件包含指向已移动的项目的链接,则您可以通过浏览找到该项目。

创建和打开项目

一次只能打开一个项目。如果您在一个项目打开时创建或打开其他项目文件,After Effects 会提示您保存打开的项目中的更改,然后将其关闭。在创建项目之后,您可以向该项目中导入素材。

  • 要创建项目,请选择“文件”>“新建”>“新建项目”。

  • 要打开项目,请选择“文件”>“打开项目”,找到项目,然后单击“打开”。

您还可以从“开始”屏幕创建和打开项目。

  • 要创建项目,请单击“新建项目”
  • 要打开项目,请单击“打开项目”并导航到项目位置。

Jeff Almasol 在其 redefinery 网站上提供了一个脚本,用于为当前项目中的每个选定合成创建并保存一个新项目。

模板项目和示例项目

模板项目是使用文件扩展名 .aet 的文件。您可以根据项目创建模板。

注意:

After Effects CC 未安装模板项目。

当您打开模板项目时,After Effects 会基于该模板创建一个新的未命名项目。保存对此新项目的更改不会影响模板项目。

注意:

查看高级用户如何使用 After Effects 的一种很好的方法是打开随 After Effects 提供的模板项目之一,打开合成以将其激活,并按 UUU 以便仅显示经过动画处理或修改的图层属性。查看经过动画处理或修改的属性将向您显示模板项目的设计者为创建模板所做的更改。

通常,模板项目的创建者会锁定应保持未修改的图层,并将应修改的图层保持为未锁定状态。这是防止意外或不恰当修改的便捷方式。

有关 After Effects 示例项目和模板项目的更多来源,请参阅 Adobe 网站上的 After Effects 社区资源

请观看 Andrew Devis 在 Creative Cow 网站上提供的此视频教程,了解有关在何处查找 After Effects 随附的模板项目和示例表达式的信息。

打开模板项目

  • 要打开模板项目,请选择“文件”>“打开项目”。在 Windows 上,从“文件类型”菜单中选择“Adobe After Effects 项目模板”。

创建模板项目

  • 要将项目转换为模板项目,请将文件扩展名从 .aep 更改为 .aet。
  • 要将项目副本另存为模板项目,请选择“文件”>“保存副本”,然后用文件扩展名 .aet 重命名该副本。

为新项目设置模板

您可以用喜欢的项目设置(例如色彩管理和文件夹结构)来创建模板,并将它用作每个新创建项目的基础。

要为您的 After Effects 新项目设置模板,请执行以下操作:

  1. 选择“编辑”>“首选项”>“新建项目”
  2. 启用“新项目加载模板”复选框。
  3. 单击“选择项目模板”并选择一个模板文件。

注意:

模板项目的格式可以是 .aet、.aep 或 .aex。

团队项目

团队项目是面向 CC 企业和 CC 团队用户的一项托管协作服务,可让编辑人员在编辑工作流程中无缝实时协作。使用团队项目,编辑人员和动态图形艺术家可在 Adobe Premiere Pro CC、After Effects CC 和 Adobe Prelude CC 内的共享团队项目中同时工作,而无需任何额外的硬件。

在云端安全跟踪项目更新,源文件保存在本地或轻量级共享代理中。团队项目还包括版本控制和智能解决冲突等深入协作功能。

  • 要创建团队项目,请选择“文件”>“新建”>“新建团队项目”
  • 要打开团队项目,请选择“文件”>“打开团队项目”。

有关如何在协作工作流程中使用团队项目的详细信息,请参阅在共享视频项目中同时工作

将团队项目转换为 Adobe After Effects 项目

您可以将团队项目转换为本地 Adobe After Effects 项目 (.aep)。选择“编辑”>“团队项目”>“将团队项目转换为项目”

将团队项目转换为 Adobe After Effects 项目
将团队项目转换为 Adobe After Effects 项目

在 After Effects 中保存和备份项目

  • 要保存项目,请选择“文件”>“保存”
  • 要用自动生成的新名称保存项目副本,请选择“文件”>“递增和保存”,或者按 Ctrl+Alt+Shift+S (Windows) 或 Command+Option+Shift+S (Mac OS)。
  • 当前项目的副本保存在与原始项目相同的文件夹中。副本的名称是原始项目的名称后跟一个数字。如果原始项目的名称以数字结尾,则该数字将增加 1。
  • 要用其他名称保存项目或将项目保存到其他位置,请选择“文件”>“另存为”>“另存为”。打开的项目将采用新的名称和位置;原始文件将保持不变。
  • 要将项目另存为 XML 项目文件格式的副本,请选择“文件”>“另存为”>“将副本另存为 XML”。(请参阅关于项目。)
  • 要用其他名称保存项目副本或将项目副本保存到其他位置,请选择“文件”>“另存为”>“保存副本”。打开的项目保留其原始名称和位置,而且将使用新设置创建一个副本但不会打开该副本。
  • 若要保存项目副本,以便可以通过以前的主版本打开,请选择“文件”>“另存为”>“将副本另存为 <以前的主版本号>”。(有关更多信息,请参阅此博客)。

注意:

项目中所使用的 After Effects 当前版本的新增功能会在以 After Effects 旧版格式保存的项目中被忽略。

要将项目副本以及项目中所用的资源的副本保存到磁盘上的单个文件夹,请使用“收集文件”命令。(请参阅将文件收集到一个位置部分了解详细信息)。

“流程图”面板

在每个项目或合成的流程图中,单个框(或拼贴)代表每个合成、素材项目和图层。方向箭头表示组件之间的关系。

注意:

“流程图”面板仅向您显示现有关系。不能用它来更改元素之间的关系。

构成合成的嵌套的合成和其他元素会在您展开合成拼贴时显示。

流程图中的拼贴之间的中灰线表示这些项目的视频或音频开关在“时间轴”面板中为取消选中状态。黑线或浅灰线表示开关为选中状态,具体取决于“外观”首选项中的“亮度”设置。

  • 要打开项目流程图,请按 Ctrl+F11 (Windows) 或 Command+F11 (Mac OS),或者单击“项目”面板右边缘的垂直滚动条顶部的“项目流程图” 按钮。
  • 要打开合成流程图,请选择合成并选择“合成”>“合成流程图”,或者单击“合成”面板底部的“合成流程图” 按钮。
  • 要激活(选择)某项目,请单击“流程图”面板中该项目的拼贴。

    当您单击流程图中的合成时,该合成在“项目”面板和“时间轴”面板中将变为活动状态。当您单击某图层时,该图层在“时间轴”面板中将变为活动状态。当您单击某素材项目时,该素材项目在“项目”面板中将变为活动状态。

  • 要自定义流程图的外观,请使用“流程图”面板菜单以及该面板底部的按钮

注意:

有关标识“流程图”面板中的按钮的工具提示,请将您的指针悬停于按钮之上,直到工具提示显示。

  • 要删除元素,请选择元素并按 Delete 键。如果所选的元素是素材项目或合成,则该元素将从项目中删除并且不再显示在“时间轴”和“项目”面板中。如果所选的元素是图层,则将从显示该图层的合成中将其删除。
  • 要访问所选元素的上下文菜单,请右键单击 (Windows) 或按 Control 键并单击 (Mac OS) 元素拼贴中名称左侧的图标。图标有各种各样的外观,具体取决于元素类型,例如图层 和合成 。例如,您可以使用图层的上下文菜单以便使用蒙版和效果,或者更改开关、应用变换以及调整图层图像质量。

注意:

当您在“流程图”面板中更改元素属性时,请注意通过上下文菜单单击拼贴中的图标,而不是元素的名称。与元素图标相关的上下文菜单不同于从元素名称打开的那一个。

Rich Young 在 After Effects Portal 网站上提供了有关“流程图”面板和“合成微型流程图”的附加信息。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略