用户指南 取消(C)

人脸跟踪

  1. After Effects 用户指南
  2. Beta 版
    1. Beta 版项目概述
    2. After Effects Beta 版主页
    3. Beta 版中的功能
      1. “属性”面板(Beta 版)
  3. 快速入门
    1. After Effects 快速入门
    2. After Effects 的新增功能 
    3. 发行说明 | After Effects
    4. After Effects 系统要求
    5. After Effects 中的键盘快捷键
    6. 支持的文件格式 | After Effects
    7. 硬件建议
    8. 适用于 Apple Silicon 的 After Effects
    9. 规划和设置
    10. 设置和安装
  4. 工作区
    1. 常规用户界面项
    2. 了解 After Effects 界面
    3. 工作流程
    4. 工作区、面板和查看器
  5. 项目与合成
    1. 项目
    2. 合成基础知识
    3. 预合成、嵌套和预渲染
    4. 使用合成分析器查看详细的性能信息
    5. CINEMA 4D 合成渲染器
  6. 导入素材
    1. 准备并导入静止图像
    2. 从 After Effects 和 Adobe Premiere Pro 导入
    3. 导入和解释视频与音频
    4. 准备和导入 3D 图像文件
    5. 导入和解释素材项目
    6. 使用素材项目
    7. 使用“场景编辑检测”检测编辑点
    8. XMP 元数据
  7. 文本和图形
    1. 文本
      1. 设置字符格式和“字符”面板
      2. 文本效果
      3. 创建和编辑文本图层
      4. 设置段落格式和“段落”面板
      5. 凸出文本和形状图层
      6. 为文本设置动画
      7. 文本动画的示例和资源
      8. 实时文本模板
    2. 动态图形
      1. 在 After Effects 中使用动态图形模板
      2. 使用表达式在动态图形模板中创建下拉列表
      3. 使用“基本属性”创建动态图形模板
      4. 替换动态图形模板和基本属性中的图像和视频
  8. 绘图、绘画和路径
    1. 形状图层、路径和矢量图形的概述
    2. 绘画工具:笔刷、仿制图章和橡皮擦
    3. 将形状描边椎体化的方法
    4. 形状图层的形状属性、绘画操作和路径操作
    5. 使用“位移路径”形状效果更改形状
    6. 创建形状
    7. 创建蒙版
    8. 使用内容识别填充面板,移除视频中的对象
    9. Roto 笔刷和调整遮罩
  9. 图层、标记和摄像机
    1. 选择和排列图层
    2. 混合模式和图层样式
    3. 3D 图层
    4. 图层属性
    5. 创建图层
    6. 管理图层
    7. 图层标记和合成标记
    8. 摄像机、光和目标点
  10. 动画、关键帧、运动跟踪和抠像
    1. 动画
      1. 动画基础知识
      2. 使用人偶工具制作动画
      3. 管理形状路径和蒙版并对其进行动画制作
      4. 使用 After Effects 为 Sketch 和 Capture 形状制作动画
      5. 分类动画工具
      6. 使用数据驱动的动画
    2. 关键帧
      1. 关键帧插值
      2. 设置、选择和删除关键帧
      3. 编辑、移动和复制关键帧
    3. 运动跟踪
      1. 跟踪和稳定运动
      2. 人脸跟踪
      3. 蒙版跟踪
      4. 蒙版引用
      5. 速度
      6. 时间拉伸和时间重映射
      7. 时间码和时间显示单位
    4. 抠像
      1. 抠像
      2. 抠像效果
  11. 透明度与合成
    1. 合成和透明度概述及资源
    2. Alpha 通道、蒙版和遮罩
  12. 调整颜色
    1. 颜色基础知识
    2. 使用 Adobe Color Themes 扩展
    3. 色彩管理
    4. 颜色校正效果
  13. 效果和动画预设
    1. 效果和动画预设概述
    2. 效果列表
    3. 模拟效果
    4. 风格化效果
    5. 音频效果
    6. 扭曲效果
    7. 透视效果
    8. 通道效果
    9. 生成效果
    10. 过渡效果
    11. 果冻效应修复效果
    12. 模糊和锐化效果
    13. 3D 通道效果
    14. 实用效果
    15. 遮罩效果
    16. 杂色和颗粒效果
    17. 保留细节放大效果
    18. 旧版效果
  14. 表达式和自动化
    1. 表达式
      1. 表达式基础知识
      2. 了解表达式语言
      3. 使用表达式控件
      4. JavaScript 与旧版 ExtendScript 表达式引擎之间的语法差别
      5. 正在编辑表达式
      6. 表达式错误
      7. 使用表达式编辑器
      8. 使用表达式编辑和访问文本属性
      9. 表达式语言引用
      10. 表达式示例
    2. 自动化
      1. 自动化
      2. 脚本
  15. 沉浸式视频、VR 和 3D
    1. 在 After Effects 中构造 VR 环境
    2. 应用沉浸式视频效果
    3. 用于 VR/360 视频的合成工具
    4. 跟踪 3D 摄像机运动
    5. 使用 3D 设计空间
    6. 3D 变换 Gizmo
    7. 使用 3D 动画执行更多操作
    8. 使用实时引擎实时预览对 3D 设计的更改
    9. 向图形添加响应式设计 
  16. 视图和预览
    1. 预览
    2. 使用 Mercury Transmit 进行视频预览
    3. 修改和使用视图
  17. 渲染和导出
    1. 渲染和导出基础知识
    2. 将 After Effects 项目导出为 Adobe Premiere Pro 项目
    3. 转换影片
    4. 多帧渲染
    5. 自动渲染和网络渲染
    6. 渲染和导出静止图像及静止图像序列
    7. 在 After Effects 中使用 GoPro CineForm 编解码器
  18. 使用其他应用程序
    1. Dynamic Link 和 After Effects
    2. 使用 After Effects 和其他应用程序
    3. After Effects 中的同步设置
    4. After Effects 中的 Creative Cloud Libraries
    5. 增效工具
    6. CINEMA 4D 和 Cineware
  19. 协作:Frame.io 和团队项目
    1. 在 Premiere Pro 和 After Effects 中协作
    2. Frame.io
      1. 安装和激活 Frame.io
      2. 将 Frame.io 与 Premiere Pro 和 After Effects 配合使用
      3. 常见问题解答
    3. 团队项目
      1. 开始使用团队项目
      2. 创建团队项目
      3. 使用团队项目进行协作
  20. 内存、存储、性能
    1. 内存和存储
    2. 提高性能
    3. 首选项
    4. After Effects 的 GPU 和 GPU 驱动程序要求

人脸跟踪概述

人脸跟踪可以精确地检测和跟踪人脸。简单蒙版跟踪可让您只将效果快速应用于人脸,如选择性颜色校正或模糊人的脸部等等。

然而,通过人脸跟踪,您可以跟踪人脸上的特定点,如瞳孔、嘴和鼻子,从而让您更精细地隔离和处理这些脸部特征。例如,更改眼睛的颜色或夸大嘴的移动,而不必逐帧调整。

After Effects 还可以测量脸部特征。跟踪面部测量值可告诉您一些详细信息,例如嘴或眼睛的张开程度。每个数据点相互隔离,从而可以极大地优化内容。此外,您也可以将详细的跟踪数据导出到 Adobe Character Animator,以创作基于表演的角色动画。

人脸跟踪器在很大程度上可以自动工作,不过,在显示人脸正面垂直视图的帧上开始分析,您可以实现更好的效果。脸上光线充足可改善人脸检测的精确度。

在“跟踪器”面板中,有两个人脸跟踪选项:

  • 人脸跟踪(仅限轮廓):如果您要跟踪的只是脸部轮廓,请使用此选项。
  • 人脸跟踪(细节特征):如果您要检测眼睛(包括眉毛和瞳孔)、鼻子和嘴的位置,并选择提取各种特征的测量值,请使用此选项。如果您要在 Character Animator 中使用跟踪数据,则需要此选项。

    如果您使用“细节功能”选项,人脸跟踪点效果则会应用于该图层。该效果在关键帧中包含若干 2D 效果控制点,每个控制点附着到已检测到的面部特征(例如,眼角和嘴角、瞳孔位置以及鼻尖)。

跟踪脸部轮廓

  1. 在 After Effects 中,选择“文件”>“导入”>“文件”。浏览到素材所在的位置,并将其添加到项目。

    “项目”面板

  2. 将素材从“项目”面板拖到合成上,以添加图层。

    将图层添加到合成

  3. 将当前时间指示器 (CTI) 定位到一个帧上,该帧显示您要跟踪的人脸的正面垂直视图。

    注意:

    如果要跟踪的初始帧是正面和垂直方向的人脸,人脸检测效率会得到提高。

    人脸检测

  4. 围绕脸(含眼睛和嘴)松散地绘制一个封闭蒙版。蒙版用于定义查找脸部特征的搜索区域。如果选定了多个蒙版,则使用最上方的蒙版。

    绘制蒙版

  5. 选定蒙版后,选择“窗口”>“跟踪器”来打开“跟踪器”面板。将跟踪方法设置为脸部跟踪(仅限轮廓)

    选择一种跟踪方法

  6. 在“跟踪器”面板中,每次向前或向后跟踪一帧以确保跟踪正常运行,然后单击 按钮开始分析所有帧。

  7. 完成分析后,人脸跟踪数据将可以在合成中使用。

跟踪细节特征和提取面部测量值

  1. 在 After Effects 中,选择“文件”>“导入”>“文件”。浏览到素材所在的位置,并将其添加到项目。

  2. 将素材从“项目”面板拖到合成上,以添加图层。

  3. 将当前时间指示器定位到一个帧上,该帧显示您要跟踪的人脸的正面垂直视图。

    注意:

    如果要跟踪的初始帧是正面和垂直方向的人脸,人脸检测效率会得到提高。

  4. 围绕脸(含眼睛和嘴)松散地绘制一个封闭蒙版。蒙版用于定义查找脸部特征的搜索区域。如果选定了多个蒙版,则使用最上方的蒙版。

  5. 选定蒙版后,选择“窗口”>“跟踪器”来打开“跟踪器”面板。将跟踪方法设置为人脸跟踪(细节特征)

  6. 在“跟踪器”面板中,每次向前或向后跟踪一帧以确保跟踪正常运行,然后单击 按钮开始分析所有帧。

  7. 完成分析后,跟踪数据将可以在称为人脸跟踪点的新效果中使用。您可以选择在合成或“效果”(“窗口”>“效果控件”)面板中访问人脸跟踪数据。

    人脸跟踪点效果控件

  8. 将当前时间指示器移到显示脸部中性表情(静止姿势)的帧。其他帧上的脸部测量值与静止姿势帧相关。在“跟踪器”面板中,单击“设置静止姿势”

  9. 在“跟踪器”面板中,单击“提取并复制脸部测量值”。脸部测量值效果将添加到该图层,并根据脸部跟踪点关键帧数据进行的计算来创建关键帧。脸部测量值关键帧数据将复制到系统剪贴板,以便在 Character Animator 中使用。

    注意:

    脸部测量值的关键帧基于脸部跟踪点关键帧数据生成,与静止姿势相关(参阅第 8 步)。

    脸部测量值效果控件

人脸跟踪数据参考

脸部跟踪点

人脸跟踪器效果为多个面部特征创建效果控制点,您可以在“时间轴”面板中查看这些特征。

脸部测量值

如果您使用“细节特征”选项,则可以脸部特征参数测量值的形式提取更多的信息,称为“面部测量值”。针对您所跟踪的人脸显示的所有测量值都与静止姿势帧相关。

脸部偏移

指示人脸的位置,在静止姿势帧上偏移为 0%。提供以下数据点,分别表示 x、y 和 z 轴上的偏移值:

  • 偏移 X
  • 偏移 Y
  • 偏移 Z

脸部方向

表示人脸的三维方向。方向通过以下数据点来测量,分别表示 x、y 和 z 轴:

  • 方向 X
  • 方向 Y
  • 方向 Z

左眼

表示左眼的各个测量点,并包含以下数据点:

  • 左眉距离
  • 左眼睑开度
  • 左眼视线 X
  • 左眼视线 Y

右眼

表示右眼的各个测量点,并包含以下数据点:

  • 右眉距离
  • 右眼睑开度
  • 右眼视线 X
  • 右眼视线 Y

表示嘴巴的各个测量点,并包含以下数据点:

  • 嘴偏移 X
  • 嘴偏移 Y
  • 嘴缩放宽度
  • 嘴缩放高度
Adobe 徽标

登录到您的帐户