创建摄像机图层并更改摄像机设置

您可以使用摄像机图层从任何角度和距离查看 3D 图层。就像在现实世界中,在场景之中和周围移动摄像机比移动和旋转场景本身容易一样,通过设置摄像机图层并在合成中来回移动它来获得合成的不同视图通常最容易。

您可以通过修改摄像机设置并为其制作动画来配置摄像机,使其与用于记录要与其合成的素材的真实摄像机和设置匹配。您还可以使用摄像机设置将类似摄像机的行为(包括景深模糊以及平移和移动镜头)添加到合成效果和动画中。

摄像机仅影响其效果具有“合成摄像机”属性的 3D 图层和 2D 图层。借助具有“合成摄像机”属性的效果,您可以使用活动合成摄像机或光照从各种角度查看或照亮效果,以模拟更复杂的 3D 效果。

您可以选择通过活动摄像机或通过指定的自定义摄像机来查看合成。活动摄像机是“时间轴”面板中在当前时间为其选择了“视频”开关 的最顶端摄像机。活动摄像机视图是用于创建最终输出和嵌套合成的视点。如果您没有创建自定义摄像机,则活动摄像机与默认合成视图相同。

所有摄像机都列在“合成”面板底部的“3D 视图”菜单中,您可以随时从其中访问它们。

在使用自定义 3D 视图之一时调整摄像机通常最容易。当然,在您通过摄像机本身查看时,您无法查看摄像机操作。

摄像机示例
摄像机示例

A. 目标点 B. 帧 C. 摄像机 

创建摄像机图层

  1. 选择“图层”>“新建”>“摄像机”,或按 Ctrl+Alt+Shift+C (Windows) 或 Command+Option+Shift+C (Mac OS)。

    注意:

    默认情况下,新图层从合成持续时间的开头开始。通过取消选择“在合成开始时创建图层”首选项(“编辑”>“首选项”>“常规”(Windows) 或“After Effects”>“首选项”>“常规”(Mac OS)),您可以选择让新图层从当前时间开始。

更改摄像机设置

您可以随时更改摄像机设置。

  1. 在“时间轴”面板中双击摄像机图层,或选择图层,然后选择“图层”>“摄像机设置”。

注意:

默认情况下选中“摄像机设置”对话框中的“预览”选项。当您在“摄像机设置”对话框中进行更改时,该选项在合成中显示更改。

摄像机设置

通过在“时间轴”面板中双击图层或选择图层并选择“图层”>“摄像机设置”,您可以随时更改摄像机设置。

注意:

在“摄像机设置”对话框中选择“预览”可在您在该对话框中修改设置时在“合成”面板中显示相关结果。

注意:

影响景深的三个属性是焦距、光圈和焦点距离。浅(小)景深是长焦距、短焦点距离和较大光圈(较小 F-Stop)的结果。较浅的景深意味着较大的景深模糊效果。浅景深的对立面是深焦点,这意味着较小的景深模糊,因为更多处于焦点中。

与摄像机镜头模糊和形状有关的摄像机属性包括“光圈形状”、“光圈旋转”、“光圈圆度”、“光圈长宽比”、“光圈衍射条纹”、“高光增益”、“高光阈值”和“高光饱和度”。

类型

单节点摄像机或双节点摄像机。单节点摄像机围绕自身定向,而双节点摄像机具有目标点并围绕该点定向。使摄像机成为双节点摄像机与将摄像机的自动定向选项(“图层”>“变换”>“自动定向”)设置为“定向到目标点”相同。(请参阅“自动方向”选项。)

名称

摄像机的名称。默认情况下,“摄像机 1”是您在合成中创建的第一个摄像机的名称,并且所有后续摄像机按升序顺序编号。为多个摄像机选择不同的名称以便区分它们。

预设

要使用的摄像机设置的类型。根据焦距命名预设。每个预设旨在表示具有特定焦距的镜头的 35 毫米摄像机的行为。因此,预设还设置“视角”、“缩放”、“焦点距离”、“焦距”和“光圈”值。默认预设为 50 毫米。您也可以通过为任何设置指定新值来创建自定义摄像机。

变焦

从镜头到图像平面的距离。换句话说,距离为焦距的图层显示为其全大小,距离为焦距两倍的图层显示为高度和宽度的一半,依此类推。

视角

在图像中捕获的场景的宽度。“焦距”、“胶片大小”和“变焦”值确定视角。较广的视角创建与广角镜头相同的结果。

景深

对“焦点距离”、“光圈”、“F-Stop”和“模糊层次”设置应用自定义变量。使用这些变量,您可以操作景深来创建更逼真的摄像机聚焦效果。(景深是图像在其中聚焦的距离范围。位于距离范围之外的图像将变得模糊。)

焦点距离

从摄像机到平面的完全聚焦的距离。

注意:

要将焦平面锁定到摄像机的目标点,以便目标点处于焦点中,请将以下表达式添加到“焦点距离”属性中:length(position, pointOfInterest)

锁定到变焦

使“焦点距离”值与“变焦”值匹配。

注意:

如果您在“时间轴”面板中更改“变焦”或“焦点距离”选项的设置,则“焦点距离”值将与“变焦”值解除锁定。如果您需要更改值并希望值保持锁定,请使用“摄像机设置”对话框,而非“时间轴”面板。或者,您可以在“时间轴”面板中向“焦点距离”属性中添加表达式:选择“焦点距离”属性,然后选择“动画”>“添加表达式”;然后将表达式关联器拖动到“变焦”属性中。(请参阅表达式基础知识。)

光圈

镜头孔径的大小。“光圈”设置也影响景深,增加光圈会增加景深模糊度。在您修改光圈时,F-Stop 的值会更改以匹配它。

注意:

在真实摄像机中,增大光圈还允许进入更多光,这会影响曝光度。与大多数 3D 合成和动画应用程序一样,After Effects 忽略此光圈值更改的结果。

F-Stop

表示焦距与光圈的比例。大多数摄像机使用 f-stop 测量指定光圈大小;因此,许多摄影师喜欢以 f-stop 单位设置光圈大小。在您修改 F-Stop 时,光圈会更改以匹配它。

模糊层次

图像中景深模糊的程度。设置为 100% 将创建摄像机设置指示的自然模糊。降低值可减少模糊。

胶片大小

胶片的曝光区域的大小,它直接与合成大小相关。在您修改胶片大小时,“变焦”值会更改以匹配真实摄像机的透视性。

焦距

从胶片平面到摄像机镜头的距离。在 After Effects 中,摄像机的位置表示镜头的中心。在您修改焦距时,“变焦”值会更改以匹配真实摄像机的透视性。此外,“预设”、“视角”和“光圈”值会相应更改。

单位

表示摄像机设置值所采用的测量单位。

量度胶片大小

用于描绘胶片大小的尺寸。

注意:

要获得最佳结果,请插入 32-bpc 并在项目设置中选择“线性化工作空间”。

摄像机命令

After Effects 具有既可单独使用也可与“创建立体 3D 设备”功能结合使用的摄像机命令。要使用摄像机命令,请选择摄像机图层,然后选择“图层”>“摄像机”。

将焦距链接到目标点

在选定摄像机图层的“焦距”属性上创建一个表达式,将该属性的值设置为摄像机与其目标点之间的距离。

将焦距链接到图层

在选定摄像机图层的“焦距”属性上创建一个表达式,属性的值为摄像机位置与另一图层之间的距离。此方法允许焦点自动跟随其他图层。

将焦距设置为图层

将当前时间的“焦距”属性的值设置为当前时间摄像机与选定图层之间的距离。

有关摄像机的在线资源

有关演示如何创建和修改摄像机以及使用“摄像机”工具的视频教程,请参阅 Adobe 网站

Dale Bradshaw 在 Creative Workflow Hacks 网站上提供了用于自动化摄像机设备的脚本和示例项目。

Mark Christiansen 在 Peachpit Press 网站上的 After Effects Studio Techniques 的“Virtual Cinematography in After Effects”一章中提供了有关使用摄像机的技巧和详细技术。此章包括有关匹配镜头扭曲、移动摄像机、进行摄像机投影(摄像机映射)、使用机架焦点、创建 boke 模糊、使用颗粒以及选择符合您的叙事手法的帧速率的信息。

Trish 和 Chris Meyer 在他们的《After Effects Apprentice》一书(位于 Focal Press 网站上)的 PDF 摘录中提供了如何使用 3D 图层、光和摄像机的教程。

Andrew Kramer 在其 Video Copilot 网站上提供了演示基本摄像机映射和摄像机投影的两部分视频教程。此教程演示如何使用光照和透光率属性将图像投影到 3D 图层上。

创建光照并更改光照设置

光照图层可影响它照射到的 3D 图层的颜色,具体取决于光照的设置和 3D 图层的“材质选项”属性。默认情况下,每束光照指向其目标点

光照可用于照亮 3D 图层并投影。您可以使用光照来匹配您在其中合成的场景的光照条件或创建更有趣的视觉效果。例如,您可以使用光照图层来创建射入视频图层的光线的外观,就好像它是由染色玻璃制成的一样。

除光照类型和“投影”属性之外,您还可以为光照的所有其他设置制作动画。

光照类型:聚光(左上图);点(右上图);平行(左下图);环境(右下图)
光照类型:聚光(左上图);点(右上图);平行(左下图);环境(右下图)

A. 目标点 B. “光照”图标 

您可以通过将光照指定为调整图层来指定光照影响哪些 3D 图层:在“时间轴”面板中,将光照置于希望它照射到的图层的上方。在“时间轴”面板中,位于图层堆积顺序中光照调整图层上方的图层不接收光照,而不管图层在“合成”面板中的位置如何。

创建光照

  1. 选择“图层”>“新建”>“光照”,或按 Ctrl+Alt+Shift+L (Windows) 或 Command+Option+Shift+L (Mac OS)。

    您创建的光包括光的类型名称。例如,如果添加聚光,则命名为“聚光 1”。

    如果更改光类型,光类型的名称会自动更改。如果未修改光名称,只有未在“时间轴”面板中更改光类型时,光名称才会更改。例如,如果将“聚光 1”改为点光,After Effects 会将光重命名为“点光 1”。

    注意:

    默认情况下,新图层从合成持续时间的开头开始。通过取消选择“在合成开始时创建图层”首选项(“编辑”>“首选项”>“常规”(Windows) 或“After Effects”>“首选项”>“常规”(Mac OS)),您可以选择让新图层从当前时间开始。

更改光照设置

  1. 在“时间轴”面板中双击光照图层,或选择图层,然后选择“图层”>“光照设置”。

    注意:

    在“光照设置”对话框中选择“预览”可在您在该对话框中修改设置时在“合成”面板中显示相关结果。

光照设置

光照类型

“平行”从无限远的光源处发出无约束的定向光,接近来自太阳等光源的光线。“聚光”从受锥形物约束的光源(例如剧场中使用的闪光灯或聚光灯)发出光线。“点”发出无约束的全向光(例如来自裸露的电灯泡的光线)。“环境”创建没有光源,但有助于提高场景的总体亮度且不投影的光照。

注意:

因为在环境光空间中的位置不影响它对其他图层的影响,所以环境光在“合成”面板中没有图标。

强度

光照的亮度。负值创建无光效果。无光照时将从图层中减去颜色。例如,如果图层已照亮,则使用负值创建也指向该图层的定向光会使图层上的区域变暗。

颜色

光照的颜色。

锥形角度

光源周围锥形的角度,这确定远处光束的宽度。仅当选择“聚光”作为“光照类型”时,此控制才处于活动状态。“聚光”光照的锥形角度由“合成”面板中光照图标的形状指示。

注意:

在 After Effects CS6 或更高版本中,所选聚光的锥形可以扩展到目标点。

锥形羽化

聚光光照的边缘柔化。仅当选择“聚光”作为“光照类型”时,此控制才处于活动状态。

衰减

平行光、聚光或点光的衰减类型。衰减描述光的强度如何随距离的增加而变小。

有关光衰减的详细信息、教程和资源,请参阅 Adobe 网站上的此文章

衰减类型包括:

在图层和光照之间的距离增加时,光亮不减弱。

平滑

指示从“衰减开始”半径开始并扩展由“衰减距离”指定的长度的平滑线性衰减。

反向平方限制

指示从“衰减开始”半径开始并按比例减少到距离的反向平方的物理上准确的衰减。

半径

指定光照衰减的半径。在此距离内,光照是不变的。在此距离外,光照衰减。

衰减距离

指定光衰减的距离。

投影

指定光源是否导致图层投影。“接受阴影”材质选项必须为“打开”,图层才能接收阴影;该设置是默认设置。“投影”材质选项必须为“打开”,图层才能投影;该设置不是默认设置。

注意:

按 Alt+Shift+C (Windows) 或 Option+Shift+C (Mac OS) 可为所选图层切换“投影”。要在“时间轴”面板中查看“材料选项”属性,请按 AA

阴影深度

设置阴影的深度。仅当选择了“投影”时,此控制才处于活动状态。

阴影扩散

根据阴影与阴影图层之间的视距,设置阴影的柔和度。较大的值创建较柔和的阴影。仅当选择了“投影”时,此控制才处于活动状态。

有关光的在线资源

Eran Stern 在 Creative COW 网站上提供了一个视频教程,其中演示了如何将光用作调整图层,以精确地控制哪些光影响哪些图层。

Chris 和 Trish Meyer 在 ProVideo Coalition 网站上的文章中提供了有关 3D 中的阴影和光照的提示。

Trish 和 Chris Meyer 在他们的《After Effects Apprentice》一书(位于 Focal Press 网站上)的 PDF 摘录中提供了如何使用 3D 图层、光和摄像机的教程。

Chris 和 Trish Meyer 在 Artbeats 网站上提供了一个教程,其中演示了如何使用光和 3D 图层将视频投影到其他图层上,例如墙上。

调整 3D 视图或移动摄像机、光照或目标点

摄像机图层和光照图层均包括“目标点”属性,该属性指定摄像机或光照指向的合成中的点。默认情况下,目标点位于合成的中心。您可以随时移动目标点。

单节点摄像机忽略目标点。(请参阅摄像机设置。)

要使光忽略其目标点,请选择光的“自动方向”选项中除“定向到目标点”之外的选项。(请参阅“自动方向”选项。)

注意:

与所有属性一样,您也可以直接在“时间轴”面板中修改摄像机或光的属性。

使用“选择”和“旋转”工具移动摄像机、光照或目标点

  1. 选择摄像机或光照图层。
  2. 使用“选择”或“旋转”工具,执行以下操作之一:
    • 要移动摄像机或光照及其目标点,请将指针置于要调整的轴上并拖动。

    • 要沿单个轴移动摄像机或光照而不移动目标点,请按住 Ctrl 键 (Windows) 或 Command 键 (Mac OS) 并拖动轴。

    • 要自由移动摄像机或光而不移动目标点,请拖动摄像机图标 或光图标。

    • 要移动目标点,请拖动目标点图标

使用“摄像机”工具移动或调整摄像机或 3D 工作视图

通过使用“合成”面板中的“摄像机”工具,您可以调整摄像机图层的“位置”和“目标点”属性。

您也可以使用“摄像机”工具来调整 3D 工作视图,这是不与摄像机图层关联的 3D 视图。您可以将 3D 视图视为可通过其查看和预览合成的虚拟摄像机。3D 工作视图包括自定义视图和固定的正视图(正面、左侧、顶部、后面、右侧或底部)。3D 工作视图用于在 3D 场景中放置和预览元素。如果您使用“摄像机”工具来调整 3D 工作视图,则不会影响任何图层属性值。

在您修改 3D 视图之后,您可以通过选择“视图”>“重置 3D 视图”来重置它。

您无法在固定的正视图上使用“轨道摄像机”工具。

有关选择和使用 3D 视图的信息,请参阅选择 3D 视图

  1. 在“合成”面板底部的“3D 视图”菜单中,选择要调整的摄像机或 3D 视图。
  2. 激活“摄像机”工具。

    您可以通过在“工具”面板中选择“摄像机”工具或按 C 循环切换“摄像机”工具来激活“摄像机”工具。在各种“摄像机”工具之间切换的最简便方法是选择“统一摄像机” 工具,然后使用三键鼠标上的按钮。

    轨道摄像机

    通过围绕目标点移动来旋转 3D 视图或摄像机。(要在选择“统一摄像机”工具时临时激活“轨道摄像机”工具,请按住鼠标左键。)

    注意:

    按住 Shift 键并使用临时选择的“统一摄像机”工具拖动可激活“轨道摄像机”工具并将旋转限制在一个轴上。

    跟踪 XY 摄像机

    水平或垂直调整 3D 视图或摄像机。(要在选择“统一摄像机”工具时临时激活“轨道 XY 摄像机”工具,请按住鼠标中键。)

    跟踪 Z 摄像机

    沿直线将 3D 视图或摄像机调整到目标点。如果您使用正视图,该工具将调整视图的缩放。(要在选择“统一摄像机”工具时临时激活“轨道 Z 摄像机”工具,请按住鼠标右键。)

  3. 在“合成”面板中拖动。在该面板中开始拖动后,您可以在该面板外继续执行拖动操作。

在您修改 3D 视图之后,您可以通过选择“视图”>“重置 3D 视图”来重置它。

移动或调整摄像机或 3D 工作视图来查看图层

您也可以移动摄像机或调整 3D 视图来查看所选图层或所有图层。After Effects 可更改视角和视图的方向以包括您选择的图层。

  • 要调整 3D 视图或移动摄像机以查看所选图层,请选择“视图”>“查看选定图层”。
  • 要调整 3D 视图或移动摄像机以查看所有图层,请选择“视图”>“查看所有图层”。

有关这些命令的键盘快捷键,请参阅 3D 图层(键盘快捷键)

有关移动摄像机和光照并为其制作动画的技巧和在线资源

在移动摄像机之前,请选择除“活动摄像机”之外的视图。如果您使用“活动摄像机”视图,将通过摄像机查看,这将加大管理难度。

默认情况下,摄像机的线框仅在选择摄像机时可见。要始终显示摄像机线框,请设置“合成”面板的视图选项(“视图”>“视图选项”)。(请参阅在“合成”面板中显示或隐藏图层控制。)

在使用摄像机或光照图层时,可创建空对象图层并使用表达式将摄像机或光照的“目标点”属性链接到空图层的“位置”属性。然后,您可以通过移动空对象来为“目标点”属性制作动画。通常,选择并查看空对象比选择并查看目标点容易。

在 After Effects 中,提供了摄像机命令“创建空轨道”。这使新的空图层成为所选摄像机图层的父级。可基于摄像机的名称附加空轨道来重命名新的空图层

Trish 和 Chris Meyer 在 Adobe TV 上的此视频教程中演示如何使用“创建空轨道”摄像机命令。

有关演示如何创建和修改摄像机以及使用“摄像机”工具的视频教程,请参阅 Adobe 网站

Trish 和 Chris Meyer 在他们的《After Effects Apprentice》一书(位于 Focal Press 网站上)的 PDF 摘录中提供了如何使用 3D 图层、光和摄像机的教程。

Mark Christiansen 在 Peachpit Press 网站上的 After Effects Studio Techniques 的“Virtual Cinematography in After Effects”一章中提供了有关使用摄像机的技巧和详细技术。此章包括有关匹配镜头扭曲、移动摄像机、进行摄像机投影(摄像机映射)、使用机架焦点、创建 boke 模糊、使用颗粒以及选择符合您的叙事手法的帧速率的信息。

Rich Young 在其 AE Portal 网站上提供了一系列使用 toWorld 方法将摄像机和光与包含 CC 球面效果的图层相连的表达式。

Creative Cow 的 Andrew Devis 创作了有关制作摄像机动画的 3 个教程系列:

video2brain 中的此视频演示用于创建空摄像机轨道的命令。

“材质选项”属性

3D 图层具有“材质选项”属性,以确定 3D 图层与光照和阴影交互的方式。

投影

指定图层是否在其他图层上投影。阴影的方向和角度由光源的方向和角度决定。如果您希望图层不可见但仍投影,请将“投影”设置为“仅投影”。

注意:

使用“仅投影”设置和非零“透光率”设置可将不可见图层的颜色投影到其他图层上。Steve Holmes 在 Artbeats 网站上提供了一个视频教程,其中演示了如何使用“投影”设置为“仅投影”的图层在 3D 场景中投射特定形状的阴影。

透光率

透过图层的光照的百分比,将图层的颜色投射在其他图层上作为阴影。0% 指定没有光照透过图层,从而投射黑色阴影。100% 指定将投影图层的全部颜色值投影到接受阴影的图层上。

注意:

使用部分透光率可创建透过染色玻璃窗户的光照外观。

接受阴影

指定图层是否显示其他图层在它之上投射的阴影。“接受阴影”中有一个“仅限”选项,当您想在图层上仅渲染阴影时可使用该选项。

接受光线

指定到达它的光线是否影响图层的颜色。此设置不影响阴影。

环境

图层的环境(非定向)反射。100% 指定最多的反射;0% 指定无环境反射。

漫射

图层的漫(全向)反射。将漫反射应用于图层就像在它之上放置暗淡的塑料片材。落在该图层上的光照向四面八方均匀反射。100% 指定最多的反射;0% 指定无漫反射。

镜面

图层的镜面(定向)反射。镜面光照从图层反射就好像从镜子反射一样。100% 指定最多的反射;0% 指定无镜面反射。

反光度

确定镜面高光的大小。仅当“镜面”设置大于零时,此值才处于活动状态。100% 指定具有小镜面高光的反射。0% 指定具有大镜面高光的反射。

金属质感

图层颜色对镜面高光颜色的贡献。100% 指定高光颜色是图层的颜色。例如,如果“金属质感”值为 100%,则金戒指的图像反射金光。0% 指定镜面高光的颜色是光源的颜色。例如,“金属质感”值为 0% 的位于白色光照下的图层具有白色高光。

指定用于渲染阴影的分辨率

高级 3D 渲染增效工具用于渲染包含相交的 3D 图层的合成。为了渲染阴影,该增效工具使用阴影图,这是从每个光源的视角渲染的图像。通常,自动根据图层的合成分辨率和品质设置计算阴影分辨率。如果普通分辨率没有达到您需要的品质,或者渲染速度太慢,您可以调整阴影图分辨率。例如,如果阴影模糊,并且“阴影扩散”材质选项设置为 0,请增加阴影图分辨率。或者,如果阴影渲染太慢,请降低阴影图分辨率。

在投影图层与其他图层相交时,有时本应带阴影的交叉后面会出现小间隙。要减小间隙的大小,请增加阴影图分辨率。

立体 3D

您可以使用 Adobe After Effects 创建立体 3D 视频。

有关立体 3D 的教程、详细信息和资源,请参阅 Adobe 网站上的此文章

有关 After Effects 中的立体 3D 工作流程的概述,请参阅了解 After Effects 中的立体 3D

Mark Christiansen 展示了如何合成立体 3D 素材(使用Art Beats 中的免费剪辑)

立体 3D 摄像机装备

After Effects 具有“创建立体 3D 设备”菜单命令,从而允许您将 3D 合成转换为立体 3D 合成。立体 3D 设备可为您创建所有元素,包括“3D 眼镜”效果。

通过首先创建其中具有 3D 元素的合成可创建立体 3D 摄像机设备。其中包含 3D 折叠预合成或 3D 元素等项目的合成的效果较好。如果您已使用摄像机,则可以在创建立体 3D 摄像机设备时选择它。如果没有选择任何摄像机,则会创建新摄像机(命名为“主摄像机”)。选择“图层”>“摄像机”>“创建立体 3D 设备”。该设备仅可与双节点摄像机一起使用。

该设备是通过创建主摄像机或通过使用合成中的现有所选摄像机生成的。可进行左眼 [比较左眼] 和右眼 [比较右眼] 合成。每个合成均具有链接到主摄像机的摄像机、嵌套在其中的原始合成和输出立体 3D 合成 [比较立体 3D]。输出立体 3D 合成嵌套了左右眼合成并包含称为立体 3D 控件的图层。此图层包含用于控制设备的“立体 3D 控件”效果,以及将左眼和右眼合成组合到立体图像中的“3D 眼镜”效果。(请参阅“3D 眼镜”效果。)

注意:

“立体 3D 控件”效果是作为立体 3D 设备的一部分构建并且不位于“效果和预设”面板中的效果。

“立体 3D 控件”效果具有有关摄像机分离和聚合的以下设置:

配置

中央将左摄像机和右摄像机置于主摄像机的两侧。左边对象将左摄像机置于与主摄像机相同的位置,将右摄像机置于右侧。相反地,右边对象将右摄像机置于主摄影机位置,将左摄像机置于左侧。

立体场景深度

按合成宽度的百分比控制摄像机之间的轴间分离。因此,如果调整合成大小,则分离量不变。此设置从低值 3% 开始以保持精细效果。理想情况下,为获得有效的 3D 素材,此值无需增加到 14%-30% 以上。不过,可以根据场景内容(对象非常接近)和摄像机视场等因素提高该设置。

注意:

更改此值会影响立体 3D 进入和退出场景的深度。将此值设置过高可能引起视觉疲劳。

聚合摄像机

在关闭时,摄像机与主摄像机保持平行,但偏移到任一侧。在打开时,位置保持偏移。不过,左摄像机和右摄像机的目标点重叠在基于以下两个属性的位置。

“聚合到”和“聚合 Z 偏移”

确定在通过 3D 眼镜观看时,屏幕在视觉上与摄像机间隔的 Z 距离。Z 空间中较远的所有内容似乎推动到屏幕中,而较近的所有内容似乎从屏幕中弹出。如果在工作时没有选中“聚合摄像机”复选框,并且摄像机是平行的,则更改场景聚合与更改 Z 偏移具有相同的效果。在这种情况下,可使用差值模式将场景中的不同元素设置为屏幕空间。(请参阅“3D 眼镜”效果。)

开始使用立体 3D

如果您使用立体 3D,则不一定需要 3D 电视。例如,您可以直接在“合成”面板中使用立体照片(红蓝)3D 眼镜并观看 3D 立体素材。不过,您也可以使用 3D 电视来通过 3D 电视和主动快门眼镜进行实时编辑。对于该工作流程,您需要在开始前准备以下设备:

  • 支持 3D 立体观看的显示器或电视。
  • 用于观看立体 3D 电视的眼镜。

注意:

对于该工作流,可使用需要发射器设备的主动快门眼镜。确保您使用的是电视制造商推荐的眼镜。

  • 立体素材或 3D 合成。

在您收集了这些项目后,请执行以下操作:

  1. 使用 HDMI 电缆(如果 HDMI 不可用,也可使用 DVI)将 3D TV 连接到您的计算机。

  2. 在 After Effects 中创建 3D 合成。确保合成大小匹配您的输出显示器的当前分辨率。

  3. 为立体 3D 合成创建新的“合成”面板。锁定合成,然后将其拖动到您的 3D TV 显示器中。

  4. 确保“合成”面板设置为 100%。

  5. 键入 Control + \(反斜线)两次,以便为 3D TV 将合成设置为全屏。将合成和 3D TV 的大小设置为相同值。

  6. 将“3D 眼镜”效果中的 3D 视图切换为以下项之一:

    • 立体图像对

    • 上下格式

    • 交错

  7. 打开您的 3D TV 的 3D 模式,并使格式与“3D 眼镜”效果的 3D 视图中设置的内容相符。(大多数 3D TV 支持“立体图像对”和“上下格式”。)

  8. 戴上 3D 眼镜,然后在真实的立体 3D 图像中编辑合成。

立体 3D 技巧

  • 如果您在“合成”面板中使用 3D 立体素材,并且您没有 3D 电视,则可以使用立体照片格式。普通的红蓝立体照片 3D 眼镜最适用于此 3D 立体工作流。

  • 增加或减小“立体场景深度”可更改 3D 环境的视觉深度。

  • 启用“聚合摄像机”并更改“聚合 Z 偏移”可向屏幕的后面和前面移动不同对象。与摄像机的距离比 Z 偏移近的对象看起来在屏幕的前面,而距离较远的对象看起来在屏幕的后面。

  • 通过执行以下任一操作,您可以使合成的景深与立体摄像机的聚合相匹配:

    • 在对主摄像机和设备的聚合摄像机使用“将焦距链接到目标点”时,使景深和立体 3D 聚合相匹配。

    • 如果您希望景深随时间变化,则可以为主摄像机的焦点距离制作动画。然后,将聚合点设置为从“摄像机位置”聚合,并且设置将聚合 Z 偏移链接到主摄像机的焦点距离的表达式

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略