用户指南 取消(C)

选择和排列图层

  1. After Effects 用户指南
  2. Beta 版
    1. Beta 版项目概述
    2. After Effects Beta 版主页
    3. Beta 版中的功能
      1. “属性”面板(Beta 版)
  3. 快速入门
    1. After Effects 快速入门
    2. After Effects 的新增功能 
    3. 发行说明 | After Effects
    4. After Effects 系统要求
    5. After Effects 中的键盘快捷键
    6. 支持的文件格式 | After Effects
    7. 硬件建议
    8. 适用于 Apple Silicon 的 After Effects
    9. 规划和设置
    10. 设置和安装
  4. 工作区
    1. 常规用户界面项
    2. 了解 After Effects 界面
    3. 工作流程
    4. 工作区、面板和查看器
  5. 项目与合成
    1. 项目
    2. 合成基础知识
    3. 预合成、嵌套和预渲染
    4. 使用合成分析器查看详细的性能信息
    5. CINEMA 4D 合成渲染器
  6. 导入素材
    1. 准备并导入静止图像
    2. 从 After Effects 和 Adobe Premiere Pro 导入
    3. 导入和解释视频与音频
    4. 准备和导入 3D 图像文件
    5. 导入和解释素材项目
    6. 使用素材项目
    7. 使用“场景编辑检测”检测编辑点
    8. XMP 元数据
  7. 文本和图形
    1. 文本
      1. 设置字符格式和“字符”面板
      2. 文本效果
      3. 创建和编辑文本图层
      4. 设置段落格式和“段落”面板
      5. 凸出文本和形状图层
      6. 为文本设置动画
      7. 文本动画的示例和资源
      8. 实时文本模板
    2. 动态图形
      1. 在 After Effects 中使用动态图形模板
      2. 使用表达式在动态图形模板中创建下拉列表
      3. 使用“基本属性”创建动态图形模板
      4. 替换动态图形模板和基本属性中的图像和视频
  8. 绘图、绘画和路径
    1. 形状图层、路径和矢量图形的概述
    2. 绘画工具:笔刷、仿制图章和橡皮擦
    3. 将形状描边椎体化的方法
    4. 形状图层的形状属性、绘画操作和路径操作
    5. 使用“位移路径”形状效果更改形状
    6. 创建形状
    7. 创建蒙版
    8. 使用内容识别填充面板,移除视频中的对象
    9. Roto 笔刷和调整遮罩
  9. 图层、标记和摄像机
    1. 选择和排列图层
    2. 混合模式和图层样式
    3. 3D 图层
    4. 图层属性
    5. 创建图层
    6. 管理图层
    7. 图层标记和合成标记
    8. 摄像机、光和目标点
  10. 动画、关键帧、运动跟踪和抠像
    1. 动画
      1. 动画基础知识
      2. 使用人偶工具制作动画
      3. 管理形状路径和蒙版并对其进行动画制作
      4. 使用 After Effects 为 Sketch 和 Capture 形状制作动画
      5. 分类动画工具
      6. 使用数据驱动的动画
    2. 关键帧
      1. 关键帧插值
      2. 设置、选择和删除关键帧
      3. 编辑、移动和复制关键帧
    3. 运动跟踪
      1. 跟踪和稳定运动
      2. 人脸跟踪
      3. 蒙版跟踪
      4. 蒙版引用
      5. 速度
      6. 时间拉伸和时间重映射
      7. 时间码和时间显示单位
    4. 抠像
      1. 抠像
      2. 抠像效果
  11. 透明度与合成
    1. 合成和透明度概述及资源
    2. Alpha 通道、蒙版和遮罩
  12. 调整颜色
    1. 颜色基础知识
    2. 使用 Adobe Color Themes 扩展
    3. 色彩管理
    4. 颜色校正效果
  13. 效果和动画预设
    1. 效果和动画预设概述
    2. 效果列表
    3. 模拟效果
    4. 风格化效果
    5. 音频效果
    6. 扭曲效果
    7. 透视效果
    8. 通道效果
    9. 生成效果
    10. 过渡效果
    11. 果冻效应修复效果
    12. 模糊和锐化效果
    13. 3D 通道效果
    14. 实用效果
    15. 遮罩效果
    16. 杂色和颗粒效果
    17. 保留细节放大效果
    18. 旧版效果
  14. 表达式和自动化
    1. 表达式
      1. 表达式基础知识
      2. 了解表达式语言
      3. 使用表达式控件
      4. JavaScript 与旧版 ExtendScript 表达式引擎之间的语法差别
      5. 正在编辑表达式
      6. 表达式错误
      7. 使用表达式编辑器
      8. 使用表达式编辑和访问文本属性
      9. 表达式语言引用
      10. 表达式示例
    2. 自动化
      1. 自动化
      2. 脚本
  15. 沉浸式视频、VR 和 3D
    1. 在 After Effects 中构造 VR 环境
    2. 应用沉浸式视频效果
    3. 用于 VR/360 视频的合成工具
    4. 跟踪 3D 摄像机运动
    5. 使用 3D 设计空间
    6. 3D 变换 Gizmo
    7. 使用 3D 动画执行更多操作
    8. 使用实时引擎实时预览对 3D 设计的更改
    9. 向图形添加响应式设计 
  16. 视图和预览
    1. 预览
    2. 使用 Mercury Transmit 进行视频预览
    3. 修改和使用视图
  17. 渲染和导出
    1. 渲染和导出基础知识
    2. 将 After Effects 项目导出为 Adobe Premiere Pro 项目
    3. 转换影片
    4. 多帧渲染
    5. 自动渲染和网络渲染
    6. 渲染和导出静止图像及静止图像序列
    7. 在 After Effects 中使用 GoPro CineForm 编解码器
  18. 使用其他应用程序
    1. Dynamic Link 和 After Effects
    2. 使用 After Effects 和其他应用程序
    3. After Effects 中的同步设置
    4. After Effects 中的 Creative Cloud Libraries
    5. 增效工具
    6. CINEMA 4D 和 Cineware
  19. 协作:Frame.io 和团队项目
    1. 在 Premiere Pro 和 After Effects 中协作
    2. Frame.io
      1. 安装和激活 Frame.io
      2. 将 Frame.io 与 Premiere Pro 和 After Effects 配合使用
      3. 常见问题解答
    3. 团队项目
      1. 开始使用团队项目
      2. 创建团队项目
      3. 使用团队项目进行协作
  20. 内存、存储、性能
    1. 内存和存储
    2. 提高性能
    3. 首选项
    4. After Effects 的 GPU 和 GPU 驱动程序要求

选择图层

在“时间轴”面板中,使用空心高光来指示还选择了属性的所选图层。使用实心高光来指示没有选择任何属性的所选图层。

选择了顶端图层,但没有选择任何属性;选择了底部图层并选择了属性
选择了顶端图层,但没有选择任何属性;选择了底部图层并选择了属性。

注意:

要将最顶端的所选图层滚动到“时间轴”面板的顶端,请按 X。

  • 要选择图层,请在“合成”面板中单击该图层,在“时间轴”面板中单击其名称或持续时间条,或在“流程图”面板中单击其名称。
  • 要在“合成”面板中选择被遮挡的图层,请在“合成”面板中该图层的上方右键单击 (Windows) 或按住 Control 键并单击 (Mac OS),然后选择“选择”>“[图层名称]”。
  • 要选择在自己的“图层”面板中打开的图层,请从“窗口”菜单或“图层”面板查看器菜单中选择图层名称。
  • 要通过位置编号选择图层,请在数字键盘上键入图层编号。如果图层编号具有多个数字,请快速键入数字,以便 After Effects 可以将它们识别为一个编号。
  • 要选择堆积顺序中的下一个图层,请按 Ctrl+向下箭头键 (Windows) 或 Command+向下箭头键 (Mac OS)。要选择上一个图层,请按 Ctrl+向上箭头键 (Windows) 或 Command+向上箭头键 (Mac OS)。
  • 要将所选图层扩展到堆积顺序中的下一个图层,请按 Ctrl+Shift+向下箭头键 (Windows) 或 Command+Shift+向下箭头键 (Mac OS)。要将所选图层扩展到堆积顺序中的上一个图层,请按 Ctrl+Shift+向上箭头键 (Windows) 或 Command+Shift+向上箭头键 (Mac OS)。
  • 要选择所有图层,请在“时间轴”或“合成”面板处于活动状态时选择“编辑”>“全选”。要取消选择所有图层,请选择“编辑”>“取消全选”。如果选择了合成的“隐藏隐蔽图层”开关,则在“时间轴”面板处于活动状态时使用“全选”不会选择隐蔽图层。(请参阅在“时间轴”面板中显示和隐藏图层。)
  • 要取消选择任何当前所选图层并选择所有其他图层,请在至少选择了一个图层的情况下,从“合成”或“时间轴”面板中的上下文菜单中选择“反向选择”。
  • 要选择使用相同颜色标签的所有图层,请单击“时间轴”面板中的颜色标签,然后选择“选择标签组”,或选择具有该颜色标签的图层,然后选择“编辑”>“标签”>“选择标签组”。
  • 要选择分配给父图层的所有子图层,请选择该父图层,然后从“合成”或“时间轴”面板中的上下文菜单中选择“选择子项”。子图层将添加到现有所选图层中。
  • 您可以在“合成”面板中选择多个图层。使用选择工具拖动可在图层周围创建用于选择这些图层的选择框(选取框)。在单击或拖动时按住 Shift 键可选择其他图层或取消选择图层。

Lloyd Alvarez 在其 After Effects Scripts 网站上提供了一个脚本,您可以使用该脚本标记图层,然后根据它们的标记选择、隐蔽和独奏图层。标记将附加到“时间轴”面板中“注释”字段的注释中。

更改选定图层的堆积顺序

图层在“时间轴”面板中的垂直排列称为图层堆积顺序,它与渲染顺序直接相关。您可以通过更改图层堆积顺序来更改图层相互合成的顺序。

注意:

由于 3D 图层具有深度属性,因此 3D 图层在“时间轴”面板中的堆积顺序不一定指示它们在合成中的空间位置。 

  • 在“时间轴”面板中,将图层名称拖动到图层堆积顺序中的新位置。
  • 要在图层堆积顺序中将所选图层向上移动一级,请按 Ctrl+Alt+向上箭头键 (Windows) 或 Command+Option+向上箭头键 (Mac OS);要将所选图层向下移动一级,请按 Ctrl+Alt+向下箭头键 (Windows) 或 Command+Option+向下箭头键 (Mac OS)。
  • 要将所选图层移动到图层堆积顺序顶端,请按 Ctrl+Alt+Shift+向上箭头键 (Windows) 或 Command+Option+Shift+向上箭头键 (Mac OS);要将所选图层移动到底部,请按 Ctrl+Alt+Shift+向下箭头键 (Windows) 或 Command+Option+Shift+向下箭头键 (Mac OS)。
  • 选择“图层”>“排列”,然后选择“使图层前移一层”、“使图层后移一层”、“将图层置于顶层”或“将图层置于底层”。
注意:

在您复制(或剪切)并粘贴图层时,将粘贴这些图层,以便它们按在执行复制(或剪切)操作之前选择它们的顺序,从上到下显示在“时间轴”面板中。您可以按住 Ctrl 键 (Windows) 或 Command 键 (Mac OS) 并单击图层来以任意顺序选择、剪切它们,然后立即粘贴以按选择这些图层的顺序重新排列它们。

Jeff Almasol 在其 _cnredefinery 网站上提供了一个脚本,您可以使用该脚本通过按入点、出点、选择顺序、图层名称或随机顺序排序,来更改合成中图层的堆积顺序。

坐标系:合成空间和图层空间

每个图层的坐标系是其图层空间。每个合成的坐标系是其合成空间。图层中存在的项目的属性值(例如效果控制点和锚点)位于图层空间中,并从该图层的图层空间中的原点进行测量。不过,图层的“位置”属性描述图层在合成中的位置,因此在该合成的合成空间中进行测量。

在您将指针移动到“图层”面板中的图层帧之上时,“信息”面板将显示指针下的像素在图层空间中的坐标。X 坐标表示在水平轴上的位置,Y 坐标表示在垂直轴上的位置。这些坐标的值以像素为单位。X 和 Y 坐标相对于原点 (0,0),它固定在图层的左上角。

您可以修改标尺的零点,但不能修改图层空间的原点。如果零点不同于原点,则 X' 和 Y' 坐标将显示在“信息”面板中的 X 和 Y 坐标下,以指示基于标尺的零点的坐标。

在您将指针移动到“合成”面板中的合成帧之上时,“信息”面板将显示合成空间中的坐标。在您拖动图层时,“信息”面板的下半部分将显示图层锚点的坐标。

在空间中移动图层

在空间中移动图层时,将修改其“位置”属性。

您可以将“位置”属性的组件分割成单个属性(X 位置、Y 位置和(对于 3D 图层)Z 位置),以便您可以单独修改每个属性或为其添加动画。(请参阅分离位置维度以逐个为组件添加动画。)

Jeff Almasol 在其 _cnredefinery 网站上提供了一个脚本,该脚本在两个所选图层的锚点之间的线上放置一个新的空图层;您可以使用空图层上的滑块控制沿此线调整空图层的位置。

注意:

要移动所选图层,使其锚点位于当前视图的中心,请选择“图层”>“变换”>“视点居中”,或按 Ctrl+Home (Windows) 或 Command+Home (Mac OS)。

注意:

要移动图层,使其锚点位于合成的中心,请右键单击 (Windows) 或按住 Control 键并单击 (Mac OS)“位置”属性,选择“编辑值”,在“单位”菜单中选择“合成的 %”,并为“位置”属性的每个组件输入 50。

为避免柔化未移动的图像,请确保图层的“位置”值不是小数值。这将避免在将图像品质设置为“最佳”的图层放置在子像素上时重新采样。

通过在“合成”面板中拖动来移动图层

注意:

要在拖动时使图层的边缘与网格或参考线对齐,请选择“视图”>“对齐到网格”或“视图”>“对齐到参考线”。

  • 选择一个或多个图层,然后使用选择工具 拖动所选图层。

    当您通过在“合成”面板中拖动图层来移动该图层时,“信息”面板将显示在您拖动时“位置”属性的更改。

通过直接修改“位置”属性来移动图层

  1. 选择一个或多个图层。
  2. 按 P 以在“时间轴”面板中显示“位置”属性。
  3. 在“时间轴”面板中修改“位置”属性。

使用箭头键移动图层

  1. 选择一个或多个图层。
  2. 要将所选图层向左、向右、向上或向下移动一个像素,请按箭头键。要移动 10 个像素,请在按箭头键时按住 Shift 键。
    注意:

    箭头键按当前放大率将图层移动一个像素。要使用箭头键更准确地移动图层,请在“合成”面板中进行缩放。(请参阅缩放图像进行预览。)

分离位置的维度以逐个为组件添加动画

默认情况下,每个“位置”属性具有两个或三个组件,其中每个组件拥有空间维度()之一的值。您可以将“位置”属性的组件分割成单个属性(X 位置、Y 位置和(对于 3D 图层)Z 位置)。分割维度允许您分别沿 x 轴、y 轴和 z 轴对图层的位置进行修改或进行动画制作。

要将所选“位置”属性分解为单个“X 位置”、“Y 位置”和(对于 3D 图层)“Z 位置”属性,请执行以下任一操作:

  • 选择“动画”>“单独尺寸”。
  • 右键单击 (Windows) 或按住 Control 键并单击 (Mac OS)“位置”属性,然后从上下文菜单中选择“单独尺寸”。
  • 单击图表编辑器底部的“单独尺寸” 按钮。

要将一组单独“位置”属性重新合成为具有多个组件的单个“位置”属性,请使用用于分割维度的相同命令。 

注意:

在您将单独的“位置”属性重新合成为单个“位置”属性时,将丢失有关运动路径和速度的一些信息,因为用于表示各个组件的多个贝塞尔曲线在每个关键帧上折叠为单个贝塞尔曲线。在您分割维度时,将丢失有关速度的一些信息,但运动路径没有更改。您应该对整个项目的每个属性使用或不使用单独的维度,而不是来回切换。

是否使用单独维度的决策取决于您尝试实现的目的。使用位置的一个属性有利于更轻松地提供平滑运动。此外,使用位置的单个属性将允许使用可提供匀速运动的浮动关键帧。使用位置的单独维度会牺牲一些此类自动平滑,以获得对空间动画的更大控制。使用单独维度还使一些模拟更容易,尤其在作用于图层的模拟力相互成直角(垂直)的情况下。

例如,如果要为水平飞行并垂直弹起的球体添加动画,您可以通过分割维度来更轻松地实现此目的。可以使用两个关键帧为“X 位置”属性添加动画,一个关键帧用于开始位置,一个关键帧用于结束位置。此水平动画表示投掷的速度。可以使用一个模拟由重力产生的加速度和从地面垂直弹起的表达式对“Y 位置”属性添加动画。类似示例是在可变侧风下顺河漂流的船只。

注意:

After Effects CS3 包括完成类似于“单独尺寸”功能的操作的“分离 XYZ 位置”动画预设,但此动画预设并不可靠。

在 2D 空间中对齐或分布图层

使用“对齐”面板可排列或均匀分隔所选图层。您可以竖直或水平地对齐或分布图层。

  1. 选择要对齐或分布的图层。
  2. 从“将图层对齐到”菜单中选择“选择”或“合成”。

    选择

    根据所选图层的图层边界对齐所选图层。

    合成

    根据合成帧的边界对齐所选图层。

  3. 在“对齐”面板中,单击表示所需对齐或分布类型的按钮。
  • 要分布图层,您必须选择三个或更多个图层。在“将图层对齐到”菜单中选择了“选择”时,您必须选择要对齐的两个或更多个图层。在“将图层对齐到”菜单中选择了“合成”时,您必须选择要对齐的一个或更多个图层。

  • 在“将图层对齐到”菜单中选择了“选择”时,每个对齐选项会将所选图层与最能表示新对齐方式的图层对齐。例如,对于右边缘对齐方式,所有所选图层将与边缘离右边最远的所选图层对齐。

  • 分布选项在两侧最远的图层之间均匀分隔所选图层。例如,对于垂直分布选项,所选图层分布在最上面和最下面的所选图层之间。

  • 在您分布不同大小的图层时,图层之间的空间可能不一致。例如,按图层的中心分布图层将在中心之间创建相等空间,但不同大小的图层会按不同数量延伸到图层之间的空间中。

  • 对齐或分布选项无法移动锁定的图层。

  • “对齐”面板不影响文本图层中字符的对齐方式。

注意:

要移动所选图层,使其锚点位于当前视图的中心,请选择“图层”>“变换”>“视点居中”,或按 Ctrl+Home (Windows) 或 Command+Home (Mac OS)。

Charles Bordenave (nab) 在 After Effects Scripts 网站上提供了一个脚本,您可以使用该脚本在 3D 空间中分布图层。

修剪、扩展或滑动编辑图层

图层持续时间的开始是其入点,结束是其出点。持续时间是入点和出点之间的跨度,而从入点延伸到出点的条是图层持续时间条

修剪图层是指修改其入点或出点,以便图层具有不同的持续时间。在修剪基于移动源素材的图层时,会影响在图层中显示源素材项目的哪些帧;要显示的第一帧位于入点,要显示的最后一帧位于出点。修剪图层不会剪切素材项目中的帧;它仅影响播放图层上的哪些帧。

在“时间轴”面板中修剪图层
在“时间轴”面板中修剪图层

A. 原始入点 B. 静止图像图层的负图层时间指示器 C. 原始入点 D. 滑动编辑条,表示运动素材图层的排除帧 E. 新入点 

在使用素材项目作为不同图层的源时,您可以以不同方式修剪每个图层以显示源的不同部分。修剪图层不会更改素材项目或最初的源文件。

您可以通过在“图层”面板或“时间轴”面板中更改入点和出点来修剪图层。(您还可以在使用素材项目创建图层之前修剪素材项目。请参阅从素材项目创建图层或更改图层源。)

图层的入点 、出点 和持续时间 值显示在“图层”面板的底部。要在“时间轴”面板中显示所有图层的此类信息,请单击“时间轴”面板左下角的“入点/出点/持续时间/伸缩”按钮 。所选图层的持续时间、入点和出点还显示在“信息”面板中。

在“图层”面板中,入点和出点以图层时间表示。在“时间轴”面板中,入点和出点以合成时间表示。持续时间在这两种情况下是相同的(除非为图层启用了时间重映射或时间伸缩)。

您可以基于任何持续时间扩展许多种类的图层,以便将它们的入点和出点向外扩展,使其超过它们的原始时间。此功能适用于时间重映射图层、形状图层、基于静止图像素材项目的图层、摄像机图层、光照图层以及文本图层。如果您向过去的时间扩展图层,使其延伸到负图层时间(超过图层时间零),则图层条底部的一系列哈希标记将指示处于负图层时间的图层部分。如果您已将使用图层时间计算其结果的效果(例如“粒子运动场”或“碎片”)应用于图层,则此指示很有用。

有关修剪、扩展和编辑图层的在线资源

Jeff Almasol 在其 redefinery 网站上提供了一个脚本,该脚本可创建一个面板,其中包含用于按时间移动项目的各种组合的控件:图层入点、图层出点、图层源帧、关键帧和标记。

在“时间轴”面板中修剪或扩展图层

拖动图层持续时间条的出点
拖动图层持续时间条的出点。

  1. 在“时间轴”面板中选择一个或多个图层。
  2. 执行以下操作之一:
    • 拖动图层持续时间条的任一端。

    • 将当前时间指示器移动到要设置入点或出点的时间。要将入点设置为当前时间,请按 Alt+[ (Windows) 或 Option+[ (Mac OS)。要将出点设置为当前时间,请按 Alt+] (Windows) 或 Option+] (Mac OS)。

在“图层”面板中修剪或扩展图层

  • 在“图层”面板中打开图层,然后拖动图层持续时间条的任一端。
  • 将“图层”面板中的当前时间指示器移动到希望素材开始或结束的时间,然后单击“入点”或“出点” 按钮以将入点或出点设置为当前时间。

滑动编辑图层

在您修剪了基于移动素材的图层之后,灰白色的滑动编辑条将显示要从合成中排除的素材项目的帧。不为基于静止素材项目的已修剪图层显示此灰白色矩形。您可以通过拖动滑动编辑条来选择在修剪的持续时间中播放哪些帧。图层的入点和出点不受影响。

仅移动图层的入点或出点不会移动关键帧。拖动图层持续时间条会移动所有关键帧。拖动滑动编辑条会移动所选关键帧,但不会移动未选择的关键帧。

注意:

在执行滑动编辑时,您可能需要移动一些具有源素材的关键帧,例如蒙版关键帧。其他关键帧应停留在所处的时间。按 Shift+F2 可取消选择关键帧并保留选择的图层。

  • 向左或向右拖动滑动编辑条。
  • 使用向后平移(锚点)工具向左或向右拖动图层。

删除图层持续时间的一部分

  1. 在“时间轴”面板中,设置工作区域以仅包括要删除的图层持续时间部分:将当前时间指示器移动到工作区域要开始的时间,然后按 B。将当前时间指示器移动到工作区域要结束的时间,然后按 N。
  2. 执行以下操作之一:
    • 选择要从中删除部分时间的图层。

    • 为您不希望其受提取影响的图层选择“锁定”开关 。按 F2 以取消选择所有图层。

    注意:

    如果没有选择任何图层,则以下步骤将从所有未锁定图层中删除部分时间。

  3. 执行以下任一操作:
    • 要删除部分时间并保留持续时间与已删除部分相同的间隙,请选择“编辑”>“提升工作区域”。

    • 要删除时间部分,请选择“编辑”>“提取工作区域”。通过波纹删除来关闭间隙。

按时间放置或移动图层

图层持续时间条直观地表示了图层持续时间。“时间轴”面板中的“入点”、“出点”和“持续时间”列用数字表示图层持续时间。

注意:

要选择在“时间轴”面板中显示哪些列,请从面板菜单中选择“列”,或右键单击 (Windows) 或按住 Control 键并单击 (Mac OS) 列标题。

这些过程按时间移动整个图层。

  • 要用数字设置入点或出点,请在“时间轴”面板中单击图层的“入点”或“出点”列中的数字。
  • 要将入点或出点移动到当前时间,请在“时间轴”面板中,按住 Alt 键 (Windows) 或 Option 键 (Mac OS) 并单击图层的“入点”或“出点”列中的数字。
  • 要将所选图层的入点移动到合成的开头,请按 Alt+Home (Windows) 或 Option+Home (Mac OS)。
  • 要将所选图层的出点移动到合成的末尾,请按 Alt+End (Windows) 或 Option+End (Mac OS)。
  • 要将所选图层向后移动一个帧,请按 Alt+Page Down (Windows) 或 Option+Page Down (Mac OS)。要将所选图层向后移动 10 个帧,请按 Alt+Shift+Page Down (Windows) 或 Option+Shift+Page Down (Mac OS)。
  • 要将所选图层向前移动一个帧,请按 Alt+Page Up (Windows) 或 Option+Page Up (Mac OS)。要将所选图层向前移动 10 个帧,请按 Alt+Shift+Page Up (Windows) 或 Option+Shift+Page Up (Mac OS)。
  • 要通过拖动来按时间移动整个图层,请向左或向右拖动图层持续时间条。要使图层持续时间条与重要的时间点(例如标记,或合成的开始或结束)对齐,请按住 Shift 键并拖动图层持续时间条。
注意:

在“时间轴”面板中拖动图层时,“信息”面板将显示图层的名称、持续时间、时间更改以及入点和出点。 

拖动持续时间条之前和之后

Jeff Almasol 在其 _cnredefinery 网站上提供了一个脚本,您可以使用该脚本将所选图层作为一个组移动,从而将该组与合成中的特定时间对齐。

按时间顺序排列图层

使用“序列图层”关键帧辅助可自动按顺序排列图层。在您应用关键帧辅助时,所选的第一个图层保留在其初始时间,而其他所选图层将根据您选择它们的顺序移动到“时间轴”面板中的新时间。

在“时间轴”面板中选择的图层
在“时间轴”面板中选择的图层(上图),以及通过应用“序列图层”关键帧辅助按顺序排列的图层(下图)

叠加图层
重叠图层可以自动设置“不透明度”关键帧以创建交叉溶解。

对于要放入序列中的图层,其持续时间必须小于合成的长度,以便它为其他图层留下时间。(请参阅修剪、扩展或滑动编辑图层。)

  1. 在“时间轴”面板中,按下 Ctrl 键 (Windows) 或 Command 键 (Mac OS) 并按顺序选择图层,首先选择要第一个显示的图层。
  2. 选择“动画”>“关键帧辅助”>“序列图层”。
  3. 在“序列图层”对话框中,执行以下操作之一:
    • 要首尾相连地排列图层,请保留“重叠”选项处于未选择状态。

    • 要重叠图层,请选择“重叠”,为重叠的持续时间输入持续时间值,然后选择过渡。选择“交叉溶解前景和背景图层”可使用所选图层的透明度;否则,请选择“溶解前景图层”。

    • 要在图层之间保留间隙,请选择“重叠”并输入负持续时间值。

复制图层

在复制图层时,可复制其所有属性,包括效果、关键帧、表达式和蒙版。

复制图层是一个快捷方式,通过它,您可以使用一个命令复制并粘贴图层。复制具有轨道遮罩的图层会保持图层及其轨道遮罩的相对顺序。

在您粘贴图层时,将按您在复制之前选择它们的顺序放置它们。所选的第一个图层是最后放置的图层,以使其位于图层堆积顺序的顶端。如果您首先从顶端选择图层,则在粘贴时,这些图层采用相同的堆积顺序。

注意:

如果您在复制时选择了图层的组件(例如蒙版或关键帧),将仅复制该组件。在复制之前,按 Shift+F2 可取消选择图层的所有组件并始终选择图层本身。

  • 要复制所选图层并将副本的入点置于当前时间,请选择“编辑”>“复制”,然后按 Ctrl+Alt+V (Windows) 或 Command+Option+V (Mac OS)。
  • 要复制所选图层并将副本置于与原图层相同的时间,请选择“编辑”>“复制”,然后选择“编辑”>“粘贴”。
注意:

要将副本置于“时间轴”面板中的图层堆栈顶端,而非紧挨原图层之上,请在粘贴之前按 F2 以取消选择原图层。

  • 要复制所选图层,请选择“编辑”>“复制”,或按 Ctrl+D (Windows) 或 Command+D (Mac OS)。

拆分图层

在“时间轴”面板中,您可以随时拆分图层,从而创建两个独立的图层。拆分图层是复制并修剪图层的省时的替代方法,在您要更改合成中间的图层的堆积顺序位置时,可能需要这么做。

注意:

要使新拆分图层在“时间轴”面板中显示在原图层之上,请选择“在原始图层上创建拆分图层”(“编辑”>“首选项”>“常规”(Windows) 或“After Effects”>“首选项”>“常规”(Mac OS))。取消选择该选项可使图层显示在原图层之下。

  1. 选择一个或多个图层。
  2. 将当前时间指示器移动到拆分图层时所处的时间。
  3. 选择“编辑”>“拆分图层”。

在您拆分图层时,生成的两个图层包含原始图层中它们的原始位置处的所有关键帧。任何已应用的轨道遮罩保持它们在图层顶端的顺序。

在您拆分图层之后,原始图层的持续时间将在拆分点结束,并且新图层将从该时间点开始。

如果在您选择“编辑”>“拆分图层”时没有选择任何图层,将在当前时间拆分所有图层。

Paul Tuersley 在 AE Enhancers 论坛上提供了一个用于在图层标记处拆分图层的脚本。

Lloyd Alvarez 在其 After Effects Scripts 网站上提供了一个脚本,该脚本自动检测素材图层中的编辑,并针对每个编辑将它拆分为单独的图层(或在每个编辑处放置图层标记)。

自动定向选项

每个图层的自动定向选项(“图层”>“变换”>“自动定向”)指定其方向如何取决于运动路径、目标点和摄像机。

图层自由旋转,独立于运动路径、目标点或其他图层。

沿路径定向

图层面向运动路径的方向。例如,对摄像机使用该选项可描绘在开车时查看前方道路的司机的视角。

定位于摄像机

始终对图层进行定向,以使其面向活动的摄像机。此选项可用于 3D 图层;此选项不可用于 2D 图层、摄像机或光照。3D 文本图层还具有一个选项“独立定向每个字符”,该选项根据每个字符的各自锚点定向每个字符。选择“独立定向每个字符”会启用文本图层的逐字符 3D 化属性(如果尚未启用它们)。(请参阅逐字符 3D 化文本属性。)

定向到目标点

摄像机或光照总是指向其目标点。该选项不可用于除摄像机和光照之外的图层。(请参阅摄像机、光照和目标点。)

注意:

如果您为图层指定了自动定向选项,然后更改其“方向”或“X 轴旋转”、“Y 轴旋转”或“Z 轴旋转”属性,则图层方向将按新值偏移。例如,您可以使用“沿路径定向”设置摄像机,然后将摄像机向右旋转 90 度,以描绘在汽车移动时朝窗户一侧外观看的乘客的视角。

在应用“旋转”和“方向”变换之前,会执行自动定向以指向目标点。要使用“定向到目标点”选项使摄像机或光照动态显示,以便暂时离开目标点,请为“旋转”和“方向”变换属性添加动画设置。

Dan Ebberts 在其 MotionScript 网站上提供了一个仅沿一个轴自动定向图层的表达式。例如,这可用于在保持垂直时让字符从一侧移到另一侧以跟随摄像机。

有关选择和排列图层的其他资源

Jeff Almasol 在其 redefinery 网站上提供了一个脚本,该脚本可创建一个面板,其中包含用于按时间移动项目的各种组合控件:图层入点、图层出点、图层源帧、关键帧和标记。

Adobe 徽标

登录到您的帐户

[Feedback V2 Badge]