使用此文档了解 After Effects 中的合成基础知识

关于合成

合成是影片的框架。每个合成均有其自己的时间轴。典型合成包括代表诸如视频和音频素材项目、动画文本和矢量图形、静止图像以及光之类的组件的多个图层。您可通过创建素材项目是源的图层,将素材项目添加到合成中。然后在合成内,在空间和时间方面安排各个图层,并使用透明度功能进行合成来确定底层图层的哪些部分将穿过堆叠在其上的图层进行显示。(请参阅图层和属性以及透明度和合成。)

After Effects 中的合成类似于 Flash Professional 中的影片剪辑或者 Premiere Pro 中的序列。

对合成进行渲染以创建最终输出影片的帧,该影片将被编码和导出为任意数目的格式。(请参阅渲染和导出基础知识。)

简单项目可能只包括一个合成;复杂项目可能包括数百个合成以组织大量素材或多个效果。

在 After Effects 用户界面的某些位置,合成缩写为 comp

每个合成在“项目”面板中都有一个条目。双击“项目”面板中的合成条目可在其自己的“时间轴”面板中打开合成。要在“项目”面板中选择合成,请在“合成”面板或“时间轴”面板中右键单击 (Windows) 或按住 Control 键并单击 (Mac OS) 合成并从上下文菜单中选择“在项目中显示合成”。

使用“合成”面板来预览合成并手动修改其内容。“合成”面板包含合成帧以及帧外部的一个剪贴板区域,您可使用该区域将图层移到合成帧中和从中移出图层。图层的背景范围(不在合成帧中的部分)显示为矩形轮廓。只会为预览和最终输出渲染合成帧内的区域。

After Effects 中“合成”面板中的合成帧类似于 Flash Professional 中的“舞台”。

当处理复杂项目时,您可能会发现通过嵌套 合成(将一个或多个合成置于其他合成中)来组织项目是最简便的方法。您可以通过对任意数量的图层进行预合成来根据这些图层创建合成。修改合成的某些图层后,可以预合成这些图层,然后预渲染该预合成,将其替换为一个已渲染的影片。(请参阅预合成、嵌套和预渲染。)

您可以使用“合成导航器”和“合成微型流程图”在嵌套合成的层次结构中进行导航。(请参阅打开并导航嵌套的合成。)

使用“流程图”面板可查看复杂合成的结构或合成的网络。

“时间轴”按钮

 单击“合成”面板底部的此按钮,可激活用于当前合成的“时间轴”面板。

注意:

按反斜线 (\) 键可为当前合成切换激活“合成”面板与“时间轴”面板。

“合成”按钮

 单击“时间轴”面板右上角的此按钮,可激活当前合成的“合成”面板。

“流程图”按钮

 单击“合成”面板底部的电钮,可激活当前合成的“流程图”面板。

创建合成

您可以随时更改合成设置。但考虑到您的最终输出,最好是在您创建合成时指定帧长宽比和帧大小等设置。因为 After Effects 根据这些合成设置进行特定计算,所以在您的工作流中稍后对其进行更改可能会影响您的最终输出。

注意:

当渲染到最终输出时,您可以覆盖一些合成设置。例如,您可以为同一影片使用不同的帧大小。有关更多信息,请参阅渲染设置以及输出模块和输出模块设置

当您在不更改“合成设置”对话框中的设置的情况下创建合成时,新合成将使用以前设置合成设置时的设置。

注意:

新合成不会继承以前的“在嵌套时或在渲染队列中,保留帧速率”和“在嵌套时保留分辨率”设置。

Jeff Almasol 在他的 redefinery 网站上提供了一个脚本,该脚本用于为当前项目中选定的每个合成创建并保存一个新项目。如果在创建新合成时在“项目”面板中选择了一个文件夹,则新合成将被放置在该选定的文件夹中。

创建合成并手动设置合成设置

  1. 选择“合成”>“新建合成”,或者按 Ctrl+N (Windows) 或 Command+N (Mac OS)。

根据单个素材项目创建合成

  1. 将素材项目拖到位于“项目”面板底部的“新建合成”按钮 上或选择“文件”>“基于所选项新建合成”。

    包括帧大小(宽度和高度)和像素长宽比的合成设置会自动设置为与素材项目的特性相匹配。

根据多个素材项目创建单个合成

  1. 在“项目”面板中选择素材项目。
  2. 将选定的素材项目拖到位于“项目”面板底部的“新建合成”按钮 上或选择“文件”>“基于所选项新建合成”。
  3. 在“基于所选项新建合成”对话框中选择“单个合成”和其他设置:

    使用尺寸来自

    选择新合成从中获取合成设置(包括帧大小(宽度和高度)和像素长宽比)的素材项目。

    静止持续时间

    将要添加的静止图像的持续时间。

    添加到渲染队列

    将新合成添加到渲染队列中。

    序列图层、重叠、持续时间以及过渡

    按顺序排列图层,可以选择使其在时间上重叠,设置过渡的持续时间以及选择过渡类型。

根据多个素材项目创建多个合成

  1. 在“项目”面板中选择素材项目。
  2. 将选定的素材项目拖到位于“项目”面板底部的“新建合成”按钮 上或选择“文件”>“基于所选项新建合成”。
  3. 在“基于所选项新建合成”对话框中选择“多个合成”和其他设置:

    静止持续时间

    根据静止图像创建的合成的持续时间。

    添加到渲染队列

    将新合成添加到渲染队列中。

注意:

如果您选择多个素材项目,则会显示“基于所选项新建合成”对话框。您可以选择是使用所有素材项目创建单个合成,还是为每个单独的素材项目创建多个合成。

合成选择
合成选择

复制合成

  1. 在“项目”面板中选择合成。
  2. 选择“编辑”>“复制”或者按 Ctrl+D (Windows) 或 Command+D (Mac OS)。

“时间轴”面板

每个合成都有其自己的“时间轴”面板。您可使用“时间轴”面板来执行许多任务,例如动态化图层属性、在时间上排列图层以及设置混合模式。“时间轴”面板中图层堆积顺序底部的图层会首先进行渲染,对于 2D 图像图层,将显示在“合成”面板的最深层以及最终合成中。

注意:

要向前循环切换“时间轴”面板,请按 Alt+Shift+句点 (.)(Windows) 或 Option+Shift+句点 (.)(Mac OS)。要向后循环切换“时间轴”面板,请按 Alt+Shift+逗号 (,) (Windows) 或 Option+Shift+逗号 (,) (Mac OS)。

合成的当前时间由当前时间指示器 (CTI)(即时间图形中的垂直红线)指示。合成的当前时间还显示在“时间轴”面板左上角的当前时间显示中。有关移动当前时间指示器的更多信息,请参阅移动当前时间指示器

“时间轴”面板的左侧包括图层控制的列。“时间轴”面板的右侧(时间图形)包含图层的时间标尺、标记、关键帧、表达式、持续时间条(在图层条模式下)以及图表编辑器(在图表编辑器模式下)。

Timeline Panel AE

注意:

按反斜线 (\) 键可为当前合成切换激活“合成”面板与“时间轴”面板。

合成设置

您可以手动输入合成设置,也可以使用合成设置预设将帧大小(宽度和高度)、像素长宽比以及帧速率自动设置为多种常见输出格式。您也可以创建并保存您自己的自定义合成设置预设以供稍后使用。“分辨率”、“开始时间码”(或“开始帧”)、“持续时间”以及“高级”合成设置不会随合成设置预设一起保存。

注意:

合成持续时间的限制为三个小时。您可以使用比三个小时长的素材项目,但是三个小时后的时间无法正确显示。最大的合成大小为 30,000x30,000 像素。30,000x30,000 8-bpc 图像需要大约 3.5 GB;您的最大合成大小可能更低,具体取决于您的操作系统和可用 RAM。

使用合成设置

  • 要打开“合成设置”对话框以更改合成设置,请执行以下操作之一:

    • 在“项目”面板中选择某个合成或者激活某个合成的“时间轴”或“合成”面板,然后选择“合成”>“合成设置”,或者按 Ctrl+K (Windows) 或 Command+K (Mac OS)。

    • 在“项目”面板或“合成”面板中(不是在图层上)右键单击 (Windows) 或在按住 Control 键的同时单击 (Mac OS) 某个合成,然后从上下文菜单中选择“合成设置”。

  • 要保存自定义的合成设置预设,请在“合成设置”对话框中设置“宽度”、“高度”、“像素长宽比”和“帧速率”值,然后单击“保存”按钮

  • 要删除合成设置预设,请从“合成设置”对话框的“预设”菜单中选择它,然后单击“删除”按钮

  • 要恢复默认的合成设置预设,请在按住 Alt 键的同时单击 (Windows) 或在按住 Option 键的同时单击 (Mac OS)“合成设置”对话框中的“删除”按钮 或“保存”按钮

注意:

您无法将自定义合成设置预设从一个系统移动到另一个系统,因为它们嵌入在首选项文件中。

  • 要缩放整个合成,请选择“文件”>“脚本”>“Scale Composition.jsx”。

注意:

请确保所有图层在选定的合成中未被锁定,否则脚本将失败。

Jeff Almasol 在其 redefinery 网站上提供了一个脚本,可设置当前合成的帧速率和持续时间以及其中嵌套的所有合成。

Christopher Green 在其网站上提供了一个脚本 (Selected_Comps_Changer.jsx),可用于更改“项目”面板中所选合成的合成设置。

基本合成设置

开始时间码或开始帧

分配给合成的第一个帧的时间码或帧编号。此值不影响渲染;它仅会指定开始计数的位置。

背景颜色

使用色板或吸管可选取合成背景颜色。(请参阅选择颜色或编辑渐变。)

:当您将一个合成添加到另一个合成(嵌套)时,将保留作为包含方的合成的背景颜色,嵌套合成的背景将变为透明。要保留嵌套合成的背景颜色,请创建一个纯色图层以用作嵌套合成中的背景图层。

有关此处未列出的特定的“基本”合成设置的信息,请参阅相关章节:

“高级”合成设置

锚点

单击箭头按钮可在调整图层大小时,将图层固定到合成的角或边缘。

“在嵌套时保留分辨率”“在嵌套时或在渲染队列中,保留帧速率”

用于要保留其自身的分辨率或帧速率,而不从所含合成中继承那些设置的合成。例如,如果特意在合成中使用了较低的帧速率来创建不规则的手工动画结果,您必须在嵌套该合成时保留该合成的帧速率。同样,当转换为其他帧速率或分辨率时,动态抠像的结果可能看起来是错误的。使用此设置而不是效率较低的“色调分离时间”效果。

运动模糊设置

  • 快门角度:快门角度的单位是度,模拟旋转快门所允许的曝光。快门角度使用素材帧速率确定影响运动模糊量的模拟曝光。例如,为 24-fps 的素材输入 90°(360°的 25%)将创建 1/96 秒(1/24 秒的 25%)的有效曝光。输入 1°时几乎不应用任何运动模糊,而输入 720°则会应用大量模糊效果。
  • 快门相位:快门相位的单位也是度。它定义一个相对于帧开始位置的偏移量,用于确定快门何时打开。如果应用了运动模糊的对象看起来滞后于未应用运动模糊的对象的位置,则调整此值可能会有帮助。
  • 每帧采样数:最小采样数。此最小数是用于 After Effects 不能根据图层运动确定其自适应采用率的帧的采样数。此采样率用于 3D 图层和形状图层。
  • 自适应采样限制:最大采样数。

有关此处未列出的特定的“高级”合成设置的信息,请参阅相关章节:

3D 渲染器设置

可以使用 3D 渲染器选项卡中的选项为合成选择正确的 3D 渲染器。可从“渲染器”菜单中选择以下渲染器:

  • 经典 3D
  • CINEMA 4D
  • 光线追踪 3D

CINEMA 4D 合成渲染器与光线追踪 3D 渲染器的 3D 功能几乎等同于 3D 文本和形状图层的凸出以及将其他 3D 图层(纯色和素材等)弯成曲面。但是,因为它们使用不同的渲染器生成效果并且支持不同的功能集,渲染结果可能会有所不同。例如,在 3D 图层材质选项和其他图层行为中存在差异。

CINEMA 4D 合成渲染器渲染的 3D 图层包括凸出文本和形状以及 2D 曲面,以便于从头开始对 3D 文本和徽标进行动画制作。CINEMA 4D 渲染器的性能比光线追踪 3D 渲染器的仅 CPU 性能要快得多。

3D 渲染器选项卡
3D 渲染器选项卡

经典 3D 渲染器

经典 3D 是传统的默认渲染器。图层在 3D 空间中作为平面放置。

CINEMA 4D 合成渲染器选项

品质:您在滑块上设置的质量级别会影响决定 CINEMA 4D 合成渲染器如何绘制 3D 图层的参数。您可以在“选项”、“消除锯齿”和“反射率”框中看到生成的渲染器参数。单个品质设置便于您选择渲染速度和可接受 3D 渲染品质的平衡组合,而无需了解和修改各种渲染品质参数。

当您调整品质滑块时,会修改以下参数

  • 光线阈值:此值可帮助优化渲染时间。
  • 光线深度:光线深度决定渲染器可以穿透多少透明对象(或使用 Alpha 通道隐藏的区域)。
  • 反射深度:当光线发送到场景时,可以由反射表面进行反射。反射深度越高,光线跟入场景和渲染的结果就越深入。
  • 阴影深度:阴影深度的行为类似于反射深度。“阴影深度”设置定义计算可见阴影光线时使用的阴影深度。

消除锯齿:“几何”是平滑所有对象边缘的默认消除锯齿设置(自动使用 16x16 子像素)。

反射率:图层采样是定义遮罩反射品质的默认反射率设置。

当您在渲染器下拉框中选择 CINEMA 4D 时,“启用”列显示启用的 3D 选项,“禁用”列显示不可用的 3D 选项。

CINEMA 4D 渲染器选项
CINEMA 4D 渲染器选项

要为 3D 渲染选择一种质量级别,请在选择 CINEMA 4D 作为渲染器之后,单击“选项”按钮并使用“品质”滑块设置质量级别。光线阈值、光线深度、反射深度、阴影深度、消除锯齿和反射值会相应地改变。

“品质”滑块设置
“品质”滑块设置

After Effects 在您的计算机上安装默认渲染器。如果已安装,您可以将渲染器更改为完整零售版 CINEMA 4D。

默认编辑器是最新安装的 CINEMA 4D 或 CINEMA 4D Lite 版本。

要选择另一种 CINEMA 4D 安装,请单击“选择安装”,在“渲染和编辑”框中选择安装程序的路径。

选择 CINEMA 4D 安装
选择 CINEMA 4D 安装

光线追踪 3D 渲染器选项

单击“选项”按钮以启动“光线追踪 3D 渲染器选项”对话框。您还可以在按住 Ctrl 键的同时单击 (Windows) 或在按住 Command 键的同时单击 (Mac OS)“合成”面板右上角的“当前渲染器指示器”按钮来启动该对话框。

在该对话框中,您可以选择:

  • 光线追踪品质:单击光线追踪品质设置可根据您的工作流更改该设置。
    • 较高的光线追踪品质值可以降低噪声,但是会大大增加渲染时间。
      光线追踪品质控制每像素发射的光线数(例如,值为 4 表示发射 16 或 4x4 束光线,值为 8 表示发射 64 束光线)。
    • 较大的数目会产生更准确的像素,但是会增加计算时间。
    • 值为 1 将提供较好的性能,但是不会有任何反射模糊(例如,它始终是锐利的)、柔和阴影、景深或运动模糊。

增大光线追踪品质值不会增大锐度。相反,它会减少点采样中的固有噪声。使用将产生可接受的噪声量或不产生噪声的最低值。

  • 消除锯齿滤镜:控制为每个像素对发射的光线进行均分的方法。“无”会将所有光线发射在像素的边界内,而其他选项会将所发射的光线的一部分分散到相邻像素内以产生更好的平均值。“框”、“帐篷”和“立方”(不是双立方)分别按品质从低到高列出。
    • 帐篷
    • 立方

消除锯齿滤镜控制模糊度的量。“无”将会产生最清晰的结果,但是投影捕手的边缘可能看起来呈锯齿状,使用“框”模糊、“三角形”和“立方”将产生更模糊的结果。

注意:

光线追踪 3D 图层使用光线追踪品质来控制运动模糊的外观。

光线追踪 3D 中的景深计算比在经典 3D(以前在高级 3D 中)更准确。

合成缩览图图像

您可以选择要在“项目”面板中显示为合成的缩览图图像(海报帧)的合成帧。默认情况下,缩览图图像是合成的第一个帧,透明的部分显示为黑色。

  • 要为合成设置缩览图图像,请在“时间轴”面板中将当前时间指示器移动到合成的所需帧中,然后选择“合成”>“设置海报时间”。
  • 要将透明网格添加到缩览图视图中,请从“项目”面板菜单中选择“缩览图透明网格”。
  • 要在“项目”面板中隐藏缩览图图像,请选择“编辑”>“首选项”>“显示”(Windows) 或“After Effects”>“首选项”>“显示”(Mac OS) 并选择“在‘项目’面板中禁用缩览图”。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略