用户指南 取消(C)

杂色和颗粒效果

  1. After Effects 用户指南
  2. Beta 版
    1. Beta 版项目概述
    2. After Effects Beta 版主页
    3. Beta 版中的功能
      1. “属性”面板(Beta 版)
  3. 快速入门
    1. After Effects 快速入门
    2. After Effects 的新增功能 
    3. 发行说明 | After Effects
    4. After Effects 系统要求
    5. After Effects 中的键盘快捷键
    6. 支持的文件格式 | After Effects
    7. 硬件建议
    8. 适用于 Apple Silicon 的 After Effects
    9. 规划和设置
    10. 设置和安装
  4. 工作区
    1. 常规用户界面项
    2. 了解 After Effects 界面
    3. 工作流程
    4. 工作区、面板和查看器
  5. 项目与合成
    1. 项目
    2. 合成基础知识
    3. 预合成、嵌套和预渲染
    4. 使用合成分析器查看详细的性能信息
    5. CINEMA 4D 合成渲染器
  6. 导入素材
    1. 准备并导入静止图像
    2. 从 After Effects 和 Adobe Premiere Pro 导入
    3. 导入和解释视频与音频
    4. 准备和导入 3D 图像文件
    5. 导入和解释素材项目
    6. 使用素材项目
    7. 使用“场景编辑检测”检测编辑点
    8. XMP 元数据
  7. 文本和图形
    1. 文本
      1. 设置字符格式和“字符”面板
      2. 文本效果
      3. 创建和编辑文本图层
      4. 设置段落格式和“段落”面板
      5. 凸出文本和形状图层
      6. 为文本设置动画
      7. 文本动画的示例和资源
      8. 实时文本模板
    2. 动态图形
      1. 在 After Effects 中使用动态图形模板
      2. 使用表达式在动态图形模板中创建下拉列表
      3. 使用“基本属性”创建动态图形模板
      4. 替换动态图形模板和基本属性中的图像和视频
  8. 绘图、绘画和路径
    1. 形状图层、路径和矢量图形的概述
    2. 绘画工具:笔刷、仿制图章和橡皮擦
    3. 将形状描边椎体化的方法
    4. 形状图层的形状属性、绘画操作和路径操作
    5. 使用“位移路径”形状效果更改形状
    6. 创建形状
    7. 创建蒙版
    8. 使用内容识别填充面板,移除视频中的对象
    9. Roto 笔刷和调整遮罩
  9. 图层、标记和摄像机
    1. 选择和排列图层
    2. 混合模式和图层样式
    3. 3D 图层
    4. 图层属性
    5. 创建图层
    6. 管理图层
    7. 图层标记和合成标记
    8. 摄像机、光和目标点
  10. 动画、关键帧、运动跟踪和抠像
    1. 动画
      1. 动画基础知识
      2. 使用人偶工具制作动画
      3. 管理形状路径和蒙版并对其进行动画制作
      4. 使用 After Effects 为 Sketch 和 Capture 形状制作动画
      5. 分类动画工具
      6. 使用数据驱动的动画
    2. 关键帧
      1. 关键帧插值
      2. 设置、选择和删除关键帧
      3. 编辑、移动和复制关键帧
    3. 运动跟踪
      1. 跟踪和稳定运动
      2. 人脸跟踪
      3. 蒙版跟踪
      4. 蒙版引用
      5. 速度
      6. 时间拉伸和时间重映射
      7. 时间码和时间显示单位
    4. 抠像
      1. 抠像
      2. 抠像效果
  11. 透明度与合成
    1. 合成和透明度概述及资源
    2. Alpha 通道、蒙版和遮罩
  12. 调整颜色
    1. 颜色基础知识
    2. 使用 Adobe Color Themes 扩展
    3. 色彩管理
    4. 颜色校正效果
  13. 效果和动画预设
    1. 效果和动画预设概述
    2. 效果列表
    3. 模拟效果
    4. 风格化效果
    5. 音频效果
    6. 扭曲效果
    7. 透视效果
    8. 通道效果
    9. 生成效果
    10. 过渡效果
    11. 果冻效应修复效果
    12. 模糊和锐化效果
    13. 3D 通道效果
    14. 实用效果
    15. 遮罩效果
    16. 杂色和颗粒效果
    17. 保留细节放大效果
    18. 旧版效果
  14. 表达式和自动化
    1. 表达式
      1. 表达式基础知识
      2. 了解表达式语言
      3. 使用表达式控件
      4. JavaScript 与旧版 ExtendScript 表达式引擎之间的语法差别
      5. 正在编辑表达式
      6. 表达式错误
      7. 使用表达式编辑器
      8. 使用表达式编辑和访问文本属性
      9. 表达式语言引用
      10. 表达式示例
    2. 自动化
      1. 自动化
      2. 脚本
  15. 沉浸式视频、VR 和 3D
    1. 在 After Effects 中构造 VR 环境
    2. 应用沉浸式视频效果
    3. 用于 VR/360 视频的合成工具
    4. 跟踪 3D 摄像机运动
    5. 使用 3D 设计空间
    6. 3D 变换 Gizmo
    7. 使用 3D 动画执行更多操作
    8. 使用实时引擎实时预览对 3D 设计的更改
    9. 向图形添加响应式设计 
  16. 视图和预览
    1. 预览
    2. 使用 Mercury Transmit 进行视频预览
    3. 修改和使用视图
  17. 渲染和导出
    1. 渲染和导出基础知识
    2. 将 After Effects 项目导出为 Adobe Premiere Pro 项目
    3. 转换影片
    4. 多帧渲染
    5. 自动渲染和网络渲染
    6. 渲染和导出静止图像及静止图像序列
    7. 在 After Effects 中使用 GoPro CineForm 编解码器
  18. 使用其他应用程序
    1. Dynamic Link 和 After Effects
    2. 使用 After Effects 和其他应用程序
    3. After Effects 中的同步设置
    4. After Effects 中的 Creative Cloud Libraries
    5. 增效工具
    6. CINEMA 4D 和 Cineware
  19. 协作:Frame.io 和团队项目
    1. 在 Premiere Pro 和 After Effects 中协作
    2. Frame.io
      1. 安装和激活 Frame.io
      2. 将 Frame.io 与 Premiere Pro 和 After Effects 配合使用
      3. 常见问题解答
    3. 团队项目
      1. 开始使用团队项目
      2. 创建团队项目
      3. 使用团队项目进行协作
  20. 内存、存储、性能
    1. 内存和存储
    2. 提高性能
    3. 首选项
    4. After Effects 的 GPU 和 GPU 驱动程序要求

颗粒效果的运用

从实际环境捕获的几乎每个数字图像都包含颗粒或可视杂色,这些颗粒或可视杂色是由录制、编码、扫描或复制过程以及创建图像所用的设备造成的。其示例包括模拟视频的模糊静态、数字摄像机的压缩人为标记、扫描打印的半调图案、数字图像传感器的 CCD 杂色以及化学摄影的典型斑点图案(被称为胶片颗粒)。

杂色未必不好;通常,可将其添加到图像,以创建基调或等效元素,如将胶片颗粒添加到计算机生成的对象,使其合并到摄影场景中。然而,出于审美原因,杂色是不受欢迎的。档案素材或高速摄影可能会出现使人不愉快的粒状效果;数字压缩人为标记或半调图案可能会损坏图像;杂色也可能会妨碍技术进程,如蓝屏合成。

此外,出于技术原因,也需要减低杂色深度。例如,如果输入材料不那么嘈杂,压缩算法通常可实现较小的文件大小,因此对于 DVD 创建和视频数据流等工作,杂色深度减低是重要的预处理步骤。

添加颗粒、匹配颗粒和移除颗粒效果使您可以处理或多或少均匀地出现在整个图像上的颗粒。颗粒效果不能校正仅影响若干像素(如灰尘)、椒盐杂色或模拟视频缺失信息的图像问题。

添加颗粒效果可从头开始生成新颗粒;不能从现有颗粒中采样。而不同类型的胶片的参数和预设可用于合成不同类型的颗粒。

移除颗粒和匹配颗粒效果使用两步式过程来处理颗粒,而不影响图像的边缘、锐度或高光。首先,对颗粒自动或手动采样;其次,通过数学模型分析和描绘颗粒,此效果会使用此数学模型来添加、移除或匹配颗粒。

三种类型的颗粒效果:匹配(左上图)、添加(左下图)和移除(右下图)
三种类型的颗粒效果:匹配(左上图)、添加(左下图)和移除(右下图)

应用颗粒效果

每个颗粒效果均使用默认设置进行应用,并显示在“预览”查看模式中,此模式的预览区域以白色边界为框架,并居中显示在图像上。出于速度和比较目的,预览区域将显示部分图像上的颗粒效果结果。颗粒效果的操作几乎是全自动的,但也提供了许多控件,用于实现精确的结果。使用每个效果附带的大量“与原始图像混合”功能,还可以有选择地将颗粒效果应用到部分图像。

  1. 选择图层,然后选择“效果”>“杂色和颗粒”>“[效果]”
  2. 从“效果控件”面板的“查看模式”控件中选择查看方法:

    预览

    在 200x200 像素区域中显示应用效果的当前设置。

    混合遮罩

    显示当前颜色遮罩或蒙版,或二者的组合,具体显示内容根据“与原始图像混合”控件组的当前设置生成。

    最终输出

    使用效果的当前设置,渲染全部活动帧。

  3. 在“效果控件”面板中调整效果的控件。

    “合成”面板的预览区域将反映您做出的所有更改。

  4. 从“查看模式”控件中选择“最终输出”。

将颗粒效果应用到所选区域

“与原始图像混合”控件组使您可以通过对所需区域使用蒙版和遮罩,将颗粒效果精确应用到图像的特定区域。您可以在两种选区技术之间选择,也可以使用二者的组合:

颜色匹配

排除与选定颜色匹配的所有图像区域。通过反转遮罩,也可以有选择地处理这样的区域。

蒙版图层

使用当前合成中的任何图层作为蒙版,以有选择地处理或排除当前图层或轨道的区域。

在首次应用任何颗粒效果时,“与原始图像混合”控件组的“数量”值均设置为 0%;此值可确定原始图像和处理版本之间的混合百分比。值为 0%,则不混合,并将所选效果全力应用到整个图像;值为 100%,则混合遮罩的白色区域与原始图像一样。

所有蒙版或遮罩均以相似方式工作:其中的白色像素使颗粒效果不处理原始图像的相应区域;通常黑色像素使其处理原始图像的相应区域。“数量”值为 100%,则白色区域与原始图像完全混合,以使效果完全不处理这些区域。在反转匹配时,此特性仍然存在。不管使用什么“数量”值,始终要处理遮罩或蒙版的黑色区域。“数量”滑块仅影响遮罩或蒙版中白色像素的区域。它仅影响每个颗粒效果如何处理遮罩或蒙版的白色区域。

  1. 将颗粒效果应用到图像。
  2. 在“效果控件”面板中执行下列任一操作:
    • 要在要应用或排除颗粒效果的区域周围创建遮罩,请使用“与原始图像混合”控件组中的“颜色匹配”控件。

    • 要借助其他图层或轨道对当前图层使用蒙版,请使用“蒙版图层”控件。

  3. 调整“模糊遮罩”值,以柔化遮罩,并在受影响和未受影响的图像区域之间产生更柔和的过渡。
  4. 如果同时使用颜色遮罩和图层蒙版,则从“结合匹配和蒙版使用”菜单中选择以下选项之一:

    滤色

    在蒙版或颜色匹配是白色时,使遮罩变为白色。

    相乘

    在两个输入都是白色时,使遮罩变为白色。

  5. 减少“数量”值,以使原始图像的更多区域隐约显出颗粒。
  6. 从“查看模式”控件中选择“最终输出”。

生成颜色匹配遮罩

在首次应用颗粒效果时,中性灰色用于生成默认的颜色匹配遮罩,以便在大多数图像中显示可见遮罩。“颜色匹配”控件组使用颜色匹配功能精确定义遮罩。在使用颗粒效果的图层与输入混合时,遮罩可隔离部分图像。

  1. 将颗粒效果应用到图像。
  2. 要选择从效果中排除或仅限效果使用的颜色,请在“与原始图像混合”和“颜色匹配”控件组的“匹配颜色”控件旁执行以下操作之一:
    • 单击色板,并在“拾色器”对话框中选择颜色。

    • 单击吸管 ,然后在屏幕上的任意位置单击一种颜色。

  3. 执行以下操作之一:
    • 要防止颗粒效果影响所选颜色,请确保取消选择“反转匹配”控件。

    • 要限制颗粒效果只使用所选颜色,请使图像其余部分不受影响后,选择“反转匹配”。

  4. 如果要排除与匹配颜色相似的颜色,则增加“匹配容差”值,它可为颜色匹配设置阈值。随着此值的增加,遮罩包含的像素颜色与匹配颜色的差别越来越大。
  5. 如果要更改用于确定颜色与匹配颜色是否相似的默认条件 (RGB),则从“匹配颜色使用”控件中选择一个选项。
  6. 调整“匹配柔和度”控件,以确定完全匹配和完全不匹配的像素之间的过渡带的宽度,或受影响区域与原始图像混合的平滑程度。
  7. 如果要反转遮罩,以使白色区域变为黑色,黑色区域变为白色,则选择“反转匹配”。(在遮罩中,匹配颜色是黑色,不管使用什么“数量”设置,颗粒效果都会处理匹配颜色。反转不会影响任何其他设置。)
  8. 如果同时使用颜色遮罩和图层蒙版,则从“结合匹配和蒙版使用”菜单中选择以下选项之一:

    滤色

    在蒙版或颜色匹配是白色时,使遮罩变为白色。

    相乘

    在两个输入都是白色时,使遮罩变为白色。

  9. 从“查看模式”控件中选择“最终输出”。

生成图层遮罩

在某些情况下,可能要使用不同的图层或轨道,作为使用颗粒效果的图层的蒙版。使用这种类型的蒙版,可以最大限度地控制具体修改图像的哪些部分以及修改程度。

  1. 将颗粒效果应用到图像。
  2. 在“效果控件”面板中,从“与原始图像混合”和“蒙版图层”控件组的“蒙版图层”控件中选择要用作蒙版的图层。
  3. 从标准轨道遮罩模式选项之一中选择一种蒙版模式。
  4. 如果蒙版图层的大小与当前图层不同,则从“蒙版图层”控件的“如果蒙版大小不同”弹出菜单中选择以下选项之一:

    居中对齐

    将蒙版图层居中放置在当前图层上。

    拉伸以适合

    调整蒙版图层的大小,以匹配当前图层的尺寸。

  5. 如果同时使用颜色遮罩和图层蒙版,则从“结合匹配和蒙版使用”菜单中选择以下选项之一:

    滤色

    在蒙版或颜色匹配是白色时,使遮罩变为白色。

    相乘

    在两个输入都是白色时,使遮罩变为白色。

  6. 从“查看模式”控件中选择“最终输出”。

更改预览区域

您可以使用“预览区域”控件组来更改颗粒效果预览区域的位置或大小。

因为添加或移除颗粒会影响细节的锐度,所以您可能需要预览精细细节区域,如人的面孔或一些文本。在使用移除颗粒效果移除颗粒时,最好的做法是预览颗粒最清晰可见或最令人不快的区域,如极广阔的纯色区域。

您可通过以下方法获得最佳结果:进行试验,将小增量分别应用到“效果控件”面板的几个控件中,并在每次调整后查看“合成”面板中的结果。

  1. 在应用颗粒效果后,在“效果控件”面板的“预览区域”控件组中,单击“中心”按钮

    十字线将居中放置在“合成”面板中。

  2. 在图像中,单击预览区域的所需中心。

    预览区域将重新绘制,以新位置为中心。

  3. 要更改预览区域的尺寸,请将“效果控件”面板中的“宽度”和“高度”值更改为所需大小(以像素为单位)。(预览区域越大,渲染速度越慢。)
  4. 如果要描绘预览区域轮廓的颜色,则选择“显示方框”。如果要更改轮廓颜色,则在“方框颜色”旁执行以下操作之一:
    • 单击色板,并在“拾色器”对话框中选择颜色。

    • 单击吸管按钮,然后在屏幕上的任意位置单击一种颜色。

  5. 查看结果:
    • 要查看杂色结构的精细细节,请将其放大到预览区域中。

    • 要在每个通道中单独检查杂色,请在“合成”面板中单击相应的颜色通道图标。

    • 要加快交互速度和增加 预览持续时间,请在“合成”面板中使用“目标区域”功能来减少处理的区域。(请参阅目标区域 (ROI)。)

    • 要保留当前帧图像的当前状态,请在“合成”面板中单击“拍摄快照”。然后可以单击“显示快照”,以查看最新快照而非活动合成,并在预览区域的当前状态和先前状态之间切换。此技术极适用于评估微调。(请参阅快照。)

    • 要比较含颗粒效果的预览区域和不含颗粒效果的预览区域,请单击“效果控件”面板中颗粒效果名称旁的“效果”开关 ,以暂时禁用效果。单击“合成”面板中的“拍摄快照”,再次单击“效果”开关以重新启用效果,然后单击并按住“显示快照”,以显示不含此效果的图像的快照。

颗粒效果杂色样本的运用

在以下过程中,杂色采样是首要步骤,也是最重要的步骤:从图像移除杂色,或在一个图像中匹配另一个图像的杂色。通常,此过程是完全自动的。要进行精细控制,可以切换到“手动”模式,并使用“效果控件”面板中的“采样”控件组调整样本。

杂色样本应为统一颜色的纯色块,可清晰显示图像中呈现的杂色图案。其目标是提取纯杂色的样本,其中不含算法可能将其误认为颗粒的任何图像特征。例如,从一片天空、背景墙或肤色区域提取样本。所有样本均应从胶片、DV 或视频材料的正常范围中进行选择。避免提取缺乏信息的曝光不足区域或曝光过度区域,特别是将像素值已修剪为纯黑色或纯白色的区域。在正常的曝光范围内,最好选择具有各种 RGB 值和颜色的样本,例如,在明亮区域中选择一个样本,在黑暗区域中选择一个样本,以及在中间调区域中选择一个样本。

自动模式中的样本数量较高,可确保算法有足够好的杂色数据,即使很难在特定图像中查找好样本也是如此。此外,如果效果找不到足够好的样本,则自动模式可能会覆盖您已设置的样本数。您可以在自动或手动模式下改变样本的大小;但是,增加样本大小不能保证获得更好的结果,特别是在生成样本的 RGB 值包含更多明显差别的情况下。如果特定图像不包含足够大区域的常量颜色值,则应减小样本大小。相反,如果图像包含大量无特征的区域,则增大采样大小可能会提供更好的结果。

以手动方式重新定位杂色样本

自动颗粒或样本选择通常可为匹配颗粒或移除颗粒效果提供可接受的结果,但您可以选择手动定位每个样本和调整每个样本的大小,或更改样本数量。例如,如果自动采样选择曝光不足或曝光过度,且缺乏颗粒结构相关信息的统一区域,则可能需要重新定位样本。

匹配颗粒和移除颗粒效果的杂色样本始终从源图层中提取,而不考虑已应用到此图层的任何效果或蒙版;此方法使采样更准确。如果希望样本包含现有效果,则使用这些效果预合成或预渲染源图层,然后将颗粒效果应用到生成的源图层。

避免提取具有以下特征的样本区域:锐化边缘、颜色渐变、高光、纹理(如草或水波纹)、精细细节(如头发或树叶)、缺乏信息的曝光过度或曝光不足区域。

  1. 在“效果控件”面板中,从“查看模式”菜单中选择“杂色样本”。

    这些样本显示为覆盖在源图像上的白色小正方形(24x24 像素)。

  2. 从“采样”控件组的“样本选择”弹出菜单中选择“手动”。
  3. 要从图像中移除最不合意的样本,请尽量降低“样本数量”值。
  4. 要移动杂色样本,请执行以下操作之一:
    • 在“杂色样本点”控件组中,单击杂色样本点参数 。十字线将显示在合成中,并在该样本上居中显示。在“合成”面板中,单击所需位置以放置样本。

    • 使用选择工具 ,将“合成”面板中的样本点拖到所需位置。

    • 在“效果控件”面板中,输入所需横坐标和纵坐标。

    注意:

    启用的样本点的数量相当于“样本数量”的当前值。

  5. 对要移动的每个样本点重复以上步骤。

更改采样源帧

默认情况下,移除颗粒和匹配颗粒效果从图层的第一帧采集杂色样本,但可以选择从其他帧对杂色采样。如果图层中的各帧之间出现较大的照明或曝光变化,则更改帧可能有用。

  1. 确定要对哪个帧采样;确保项目设置“显示样式”设置为“帧数”,从零开始编号。当前帧的编号随后以蓝色显示在“时间轴”面板的左上角。在“采样”控件组中,输入该帧的编号作为“源帧”值。
  2. 从“查看模式”菜单中选择“杂色样本”。

    所选帧将显示在“合成”面板中,其自动样本将显示在图像上。

更改杂色样本框颜色

您可以将移除颗粒或匹配颗粒效果的查看模式设置为“杂色样本”,以查看效果采样的区域。采样区域自动使用白色轮廓作为框架。您可以根据喜好更改这些杂色样本框的颜色。

  1. 在“采样”控件组的“采样框颜色”控件旁,执行以下操作之一:
    • 单击色板,并在“拾色器”中选择颜色。

    • 单击吸管,然后在应用窗口中的任意位置单击一种颜色。

添加或匹配颗粒的运用

添加颗粒效果可在图像中创建新颗粒或新杂色,具体方法是从头开始生成新颗粒,或使颗粒属性基于预设。匹配颗粒效果也可通过在其他图像中匹配颗粒来在图像中创建新颗粒。这两种效果可共享“效果控件”面板中的几个控件,这些控件使您可以控制颗粒的颜色、色调范围、混合模式和动画属性。

调整添加或匹配颗粒的色调

胶片任何帧中的精确颗粒图案在整个帧中并不一致,而可能取决于每个像素内容的色调值。例如,在化学胶片颗粒中,卤化银晶体的大小根据曝光水平的不同有所不同。

通过添加颗粒和匹配颗粒效果,您可使用“应用”控件组中的“阴影”、“中间调”、“高光”和“中点”控件在整个图像区域中再生这些精细的颗粒图案变化。这些控件使您可以定义添加到图像中的每个色调区域以及图像的每个通道的颗粒数量。例如,您可以将更多的颗粒添加到蓝色通道的曝光过度区域,以使天空的图像呈现更多颗粒。

您可以对添加颗粒或匹配颗粒效果使用“应用”控件组,用于执行以下操作:

  • 要定义添加到图像中的每个色调区域的颗粒数量,请调整“阴影”、“中间调”和“高光”值。

  • 要为颗粒应用定义图像色调范围的中点,请调整“中点”滑块。默认情况下,此滑块中置在 0.5 位置,此位置表示像素值范围的中间位置,127 适用于 8-bpc 图像,16384 适用于 16-bpc 图像。

  • 要进行更精细的控制,请使用“通道平衡”控件在每个通道的阴影、中间调和高光区域中单独调整颗粒。

为添加或匹配的颗粒设置动画

默认情况下,添加颗粒和匹配颗粒效果生成的颗粒或杂色以与源材质相同的速度移动,以精确模拟实际杂色。减缓杂色进程可能对美学效果很有用,也可用于避免添加的杂色快速移动和注意自身。这些效果具有内部随机函数发生器,后者可改变杂色像素在各帧之间的位置。但是,您也可以更改杂色在同一帧上的各图层之间的外观,同时使其他每个参数保持不变。

您可以对添加颗粒或匹配颗粒效果使用“动画”控件组,用于执行以下操作:

  • 要以目标帧速率的倍数形式指定添加颗粒的帧速率,请在“效果控件”面板的“动画”控件组中调整“动画速度”值。“动画速度”值越高,颗粒的寿命越短。值为 1(默认值),颗粒以与帧相同的速率移动。值越低,颗粒改变的速度越慢,这种设置可用于提供胶片颗粒外观。值为零,颗粒随时间的推移保持固定不动。

  • 要使用插值法在生成的杂色帧之间创建平滑过渡,请选择“动画流畅”。仅当“动画速度”小于 1 时,此控件才有意义。

  • 要更改杂色在同一帧上各图层之间的外观,请调整“随机植入”值。每个“随机植入”值均表示 100 种可能的外观变化之一;更改此值不能使随机程度增强或减弱。

混合和调整添加或匹配颗粒的颜色

您可以调整添加颗粒或匹配颗粒效果生成的颗粒的颜色、饱和度和混合特性。

若干因素会影响这些效果生成的颗粒的外观颜色,包括以下因素:

  • 源图像底层像素的颜色值。

  • 杂色的“饱和度”值。

  • “色调颜色”和“色调量”值(如果已在默认设置中修改这些设置)。

  • “应用”控件组中的“混合模式”值。

  • 使用“通道强度”控件组对每个通道单独应用的杂色(如果有)数量。

使用“效果控件”面板中的“颜色”控件组,可以调整以下任何设置:

单色

为添加的杂色提供单一色调。默认情况下,色调是黑白的,但可以更改“色调颜色”,以使其成为任何颜色的渐变。(如果选择“单色”,则“饱和度”和“通道强度”控件不可用。)

色调量

控制颜色转移的深度和强度。

色调颜色

控制添加的杂色转向的颜色。

饱和度

控制颜色的数量和鲜明程度。

“应用”控件中的“混合模式”可确定生成杂色的颜色值与每个像素底层源图层的颜色值合并的方式:

胶片

使生成的颗粒看起来像嵌入图像一样。与较亮的颜色相比,此模式对较暗颜色的影响更大,就像胶片底片中的颗粒显示一样。

相乘

使杂色和源图像的颜色值相乘。但是,结果可能比原始图像更亮或更暗,这是因为杂色可能有正值或负值。

相加

将源图像像素的颜色值与杂色合并。但是,结果并非始终比原始图像亮,这是因为颗粒效果创建的杂色可能有正值或负值。

滤色

使杂色和源图像的反向亮度值相乘。此效果就像使用多次曝光在底片上打印一样。结果始终比原始图像亮。

叠加

合并“胶片”和“相乘”特性:阴影和高光获得的颗粒较少,而中间调可获得完整应用的颗粒。

添加颗粒效果

添加颗粒效果可从头开始生成新杂色,但不能从现有杂色中采样。而不同类型的胶片的参数和预设可用于合成许多不同类型的杂色或颗粒。您可以修改此杂色的几乎每个特性,控制其颜色,以几种方法将其应用到图像,甚至为其设置动画或有选择地将其仅应用到图像的一部分。

此效果适用于 8-bpc 和 16-bpc 颜色。

添加颗粒效果:原始图像(左图)和应用效果后的图像(右图)
原始图像(左图)、应用效果后的图像(右图)

添加的杂色在颜色通道上的分布确实会影响生成图像的总体颜色。使用黑暗的背景时,在视觉效果上往往是在图像上添加杂色,因此红色色调或红色通道中的更多杂色使图像具有微红的色相。使用明亮的背景时,在视觉效果上往往是从图像上减少杂色,因此红色色调或红色通道中的更多杂色使图像具有青色。结果还取决于“应用”控件组中的“混合模式”控件。

注意:

由于曝光和扫描分辨率等因素,图像的实际颗粒可能与胶片预设不同。

您可以对添加颗粒效果使用这些控件,用于执行以下操作:

  • 要再生特定胶片或摄影材料的颗粒,请从“效果控件”面板中添加颗粒效果的“预设”菜单中选择胶片类型。

  • 要调整应用颗粒的强度和大小并引入模糊,请调整“效果控件”面板中添加颗粒效果的“微调”控件组。

  • 要修改添加杂色的颜色,请调整“颜色”控件。

  • 要定义生成杂色的颜色值与每个像素底层目标图层的颜色值合并的方式,请在“应用”控件组中选择“混合模式”。

  • 要定义添加到图像中的每个色调区域和中点的颗粒数量,请调整“应用”控件组中的“阴影”、“中间调”、“高光”和“中点”的值。

  • 要为添加的颗粒设置动画,请调整“动画”控件组中的属性。

  • 要将效果应用到整个图像,请从“查看模式”菜单中选择“最终输出”。

颗粒效果的“微调”控件

匹配颗粒和添加颗粒效果共享一组“微调”控件。您可以使用这些控件来修改杂色的强度和大小并引入模糊,可以跨三个通道执行所有这些操作,也可以对单个通道单独执行这些操作。此外,也可以更改应用颗粒的长宽比。

注意:

“微调”控件的值与源图层中采样的杂色有关:值为 1.0,则使源杂色的该属性保持不变,而较高和较低的值都会改变应用的杂色。

在“微调”控件组中可调整以下任一控件:

强度

控制生成杂色的像素之间的亮度和颜色强度的变化量,此控件可确定杂色的可见性。增加此值不会改变每个颗粒的位置或大小,而会使其似乎更突出;较低的值将提供更精细的柔和外观。

通道强度

为每个通道单独控制生成杂色的像素之间的对比度。例如,可能要将更多颗粒添加到蓝色通道,以模拟胶片。

大小

调整生成颗粒的大小,以像素为单位。

通道大小

单独为每个通道调整生成颗粒的大小,以像素为单位。

柔和度

设置颗粒的柔和度数量。

长宽比

控制生成颗粒的宽度与固定高度 1 的比率;此设置可用于模拟变形镜头的效果或用于美学效果。值高于 1,则水平伸展颗粒;值低于 1,则水平挤压颗粒。

蒙尘与划痕效果

蒙尘与划痕效果将位于指定半径之内的不同像素更改为更类似邻近的像素,从而减少杂色和瑕疵。为了实现图像锐度与隐藏瑕疵之间的平衡,请尝试不同组合的半径和阈值设置。

此效果适用于 8-bpc 和 16-bpc 颜色。

有划痕的原始图像(左上图)、放大的划痕视图(左下图)、移除划痕且清晰度降低的图像(右下图)
有划痕的原始图像(左上图)、放大的划痕视图(左下图)、移除划痕且清晰度降低的图像(右下图)

半径

该效果搜索像素间差异的距离。较高的值会使图像模糊。请使用能够消除瑕疵的最小值。

阈值

像素能够与其邻近像素在多大程度上不同而不被效果更改。使用能够消除瑕疵的最高值。

分形杂色效果

分形杂色效果可使用柏林杂色创建用于自然景观背景、置换图和纹理的灰度杂色,或模拟云、火、熔岩、蒸汽、流水或蒸气等事物。

此效果适用于 8-bpc、16-bpc 和 32-bpc 颜色。

“演化”控件用于创建分形杂色形状的精细变化。为这些控件设置动画可使杂色随时间平滑改变,从而创建类似的结果,例如,行云或流水。

Chris Zwar 在 Creative COW 网站上提供了一篇文章,用于介绍分形杂色效果的工作原理,包括有关效果内部工作的许多细节和图像。

Stu Maschwitz 在其 ProLost 博客上提供了一个示例项目,该项目使用分形杂色效果创建太阳的光环。

湍流杂色效果本质上是分形杂色效果的现代高性能实现。湍流杂色效果需要的渲染时间较短,且更易于用于创建平滑动画。湍流杂色效果还可以更准确地对湍流系统建模,并且较小的杂色要素比较大的杂色要素移动得更快。使用分形杂色效果代替湍流杂色效果的主要原因是,前者适合创建循环动画,因为湍流杂色效果没有“循环”控件。

注意:

由于这两个效果的控件几乎相同,因此可以使用为分形杂色效果创建的大多数说明和教程来指导您使用湍流杂色效果。(请参阅湍流杂色效果。)

控件

分形类型

分形杂色是通过为每个杂色图层生成随机编号的网格来创建的。“复杂度”设置用于指定杂色图层的数量。“分形类型”设置用于确定此网格的特性。

杂色类型

在杂色网格中的随机值之间使用的插值的类型。

反转

反转杂色。黑色区域变为白色,而白色区域变为黑色。

对比度

默认值为 100。较高的值可创建较大的、定义更严格的杂色黑白区域,通常显示不太精细的细节。较低的值可生成更多灰色区域,以使杂色柔和。

溢出

使用以下选项之一,重映射 0–1.0 范围之外的颜色值:

剪切

重映射值,以使高于 1.0 的所有值显示为纯白色,低于 0 的所有值显示为纯黑色。“对比度”值用于影响图像的多大部分超出此范围。较高的值可生成大部分黑色和/或白色的图像,以及较少的灰色区域。因此,对比度设置越高,细节越不精细。在用作亮度遮罩时,图层的透明度区域更明显、更明确。

柔和固定

在无穷曲线上重映射值,以使所有值均在范围内。此选项会降低对比度,使杂色显示为灰色,且几乎没有纯黑色或纯白色的区域。在用作亮度遮罩时,图层包含精细的透明度区域。

反绕

三角形式的重映射,以使高于 1.0 的值或低于 0 的值退回到范围内。在“对比度”设置为高于 100 时,此选项可显示精细的细节。在用作亮度遮罩时,图层将显示纹理更详细的透明度区域。

允许 HDR 结果

不执行重映射。保留 0-1.0 范围以外的值。

变换

用于旋转、缩放和定位杂色图层的设置。如果选择“透视位移”,则图层看起来像在不同深度一样。

复杂度

为创建分形杂色合并的(根据“子设置”)杂色图层的数量。增加此数量将增加杂色的外观深度和细节数量。

注意:

增加“复杂度”会增加渲染时间。在适当的情况下,尝试减少“大小”,而不是增加“复杂度”来达到相似的结果,并避免使用更长的渲染时间。增加表面的复杂度,而不增加渲染时间的技巧是:使用负数或很高的“对比度”/“亮度”设置,并选择“反绕”作为“溢出”值。

子设置

分形杂色是通过合并杂色图层生成的。“子设置”用于控制此合并方式,以及杂色图层的属性彼此偏移的方式。缩小连续图层可创建更精细的细节。

子影响

每个连续图层对合并杂色的影响。值为 100%,所有迭代的影响均相同。值为 50%,每个迭代的影响均为前一个迭代的一半。值为 0%,则使效果看起来就像“复杂度”为 1 时的效果一样。

子缩放、旋转和位移

相对于前一个杂色图层的杂色图层的缩放百分比、角度和位置。

中心辅助比例

从与前一个图层相同的点计算每个杂色图层。此设置可生成彼此堆叠的重复杂色图层的外观。

演化

使用渐进式旋转,以继续使用每次添加的旋转更改图像。此方法与典型旋转不同,后者参考转盘控件上的设置,对于 360° 的每个倍数,其结果均相同。对于“演化”,值为 0° 的外观与 1 次旋转的外观不同,后者与 2 次旋转的外观不同,等等。要使“演化”设置返回其原始状态(例如,创建无缝循环),请使用“循环演化”选项。

您可以通过为“演化”设置动画来指定杂色在一段时间内演化的数量。在给定时间内旋转次数越多,杂色更改的速度越快。在一段短时间内“演化”值的较大变化可能导致闪光。

要创建无缝循环,请使用“循环演化”,并使用没有度数的完全旋转(部分旋转可能会中断循环)设置“演化”关键帧。

演化选项

“演化”的选项。

注意:

通过重复使用以前创建的“演化”循环,并仅更改“随机植入”值,可轻松创建新的分形杂色动画。使用新的“随机植入”值可改变杂色图,而不扰乱“演化”动画。

注意:

不用在整个合成上为“演化”设置动画,通过在所需持续时间内预渲染和循环一个较短的“演化”循环可节省渲染时间。

循环演化

创建在指定时间内循环的演化循环。此选项可使“演化”状态返回其起始点,从而创建平滑的渐进循环、非重复循环或循环段。

要确保循环完成完全旋转,请选择“循环”值,该值可与为“演化”设置的旋转次数一致,或可被此旋转次数除尽。

循环(旋转次数)

指定重复前杂色循环使用的旋转次数。“演化”关键帧之间的时间可确定这些“演化”循环的速度。此选项仅影响杂色的演化,而不影响“变换”或其他控件。例如,如果查看“大小”或“位移”设置不同的杂色的两个相同状态,它们看起来不同。

注意:

仅当选择“循环演化”时,“循环”才可用。

随机植入

设置生成杂色使用的随机值。为“随机植入”属性设置动画会导致以下结果:从一组杂色闪光到另一组杂色(在该分形类型内),此结果通常不是您需要的结果。为实现平滑的杂色动画效果,请为“演化”属性设置动画。

不透明度

杂色的不透明度。

混合模式

分形杂色和原始图像之间的混合操作。除以下设置外,这些混合模式与“时间轴”面板的“模式”列中的混合模式相同:

仅渲染分形杂色,不在原始图层上合成。

色相

按色相值而非灰度值渲染分形杂色。将保留原始图层的“饱和度”和“亮度”。如果原始图层是灰度图层,则不执行任何操作。

饱和度

按饱和度值而非灰度值渲染分形杂色。保留原始图层的“色相”和“亮度”。如果原始图层是灰度图层,则不执行任何操作。

使用分形杂色效果创建无缝循环

  1. 在“时间轴”面板中选择图层,然后选择“效果”>“杂色和颗粒”>“分形杂色”。
  2. 为“演化”设置两个关键帧。
  3. 调整关键帧之间的时间和“演化”旋转的次数,直至您对杂色动画满意为止。
  4. 选择“循环演化”。
  5. 设置“循环”的值。

    演化将在“演化”关键帧之间的距离确定的时间内完成您为“循环”指定的旋转次数。通过考虑重复之前此循环中需要渲染的数量,确定“循环”值。选择适合项目的最短长度,以节省渲染时间。

    最初,循环的最后一帧与第一帧相同。要创建无缝循环,请跳过最后一帧,具体方法是将图层的出点设置在循环最后一帧的前一帧:

  6. 将当前时间指示器移至循环完成的时间。例如,如果“循环”设置为 2,则找到“演化”值为 2 时的帧。
    注意:

    如果为其他“分形杂色”控件设置关键帧,则使其返回循环在时间轴中开始重复时的初始设置,否则这些控件不会循环。

  7. 将当前时间指示器回移一帧。
  8. 将图层的出点修剪到此帧。
  9. 预渲染此图层,并将预渲染的影片导入项目。
  10. 在“项目”面板中选择导入的素材项目,然后选择“文件”>“解释素材”。然后将“循环”设置为项目中图层持续时间内需要的循环次数。

匹配颗粒效果

匹配颗粒效果可匹配两个图像之间的杂色。此效果对合成和蓝屏/绿屏工作特别有用。匹配颗粒效果只能添加杂色,不能移除杂色,因此如果目标图像的杂色比源图像多,则不能实现精确匹配。在此情况下,可以先使用移除颗粒效果清理目标图像,然后将匹配颗粒效果应用到结果,以此实现完美匹配。

匹配颗粒效果先从杂色采样这一步开始。基本上,通过合成整帧新杂色来匹配杂色样本。您可以在此效果应用到新图象之前以许多方式修改杂色,例如,从某图像复制杂色,在将杂色应用到其他图像之前,使其更大、更红。

匹配颗粒效果与添加颗粒效果共享某些控件。(请参阅添加颗粒效果。)

注意:

匹配颗粒效果在对应于目标图层第一帧的源图层的帧上对杂色采样。如果源图层未呈现在该帧上,或者杂色样本包含透明区域,则不对任何杂色采样,也不应用任何杂色。

此效果适用于 8-bpc 和 16-bpc 颜色。

匹配颗粒效果:在应用效果之前和之后
原始图像(左图)、应用效果后的图像(右图)

匹配图像之间的杂色或颗粒

  1. 确保源图层和目标图层位于同一合成中。
  2. 选择要向其添加颗粒的目标图层。
  3. 选择“效果”>“杂色和颗粒”>“匹配颗粒”。
  4. 从“效果控件”面板的“杂色源图层”控件中选择图层,以指定要从中对颗粒采样的源图层。(“杂色源图层”控件仅列出“时间轴”面板中的图层。)

    系统会对颗粒自动采样,并将其应用到目标图层上的预览区域。如果需要自动匹配,可以跳过剩余的步骤。

  5. 如果在选择杂色源图层之前,目标图层中已有明显杂色,此情况使颗粒不匹配,则调整“补偿现有杂色”滑块以避免颗粒累积。
  6. 执行以下任一操作:
    • 要调整应用颗粒的强度和大小并引入模糊,请调整“微调”控件。

    • 要修改添加杂色的颜色,请调整“颜色”控件。

    • 要确定生成杂色的颜色值与每个像素底层目标图层的颜色值合并的方式,请在“应用”控件组中选择“混合模式”。

    • 要定义添加到图像中的每个色调区域和中点的颗粒数量,请调整“应用”控件组中的“阴影”、“中间调”、“高光”和“中点”的值。

  7. 如果要更改效果视图,请从“效果控件”面板的“查看模式”菜单中选择以下任一选项:

    杂色样本

    显示为提取当前杂色模型已进行采样的区域。选择源图层会使其显示在“合成”面板中,并显示其杂色样本方形。

    补偿范例

    显示已从目标图像自动提取的杂色样本。

    预览

    在 200x200 像素区域中显示应用效果的当前设置。

    混合遮罩

    显示当前颜色遮罩或蒙版,或二者的组合,具体显示内容根据“与原始图像混合”控件组的当前设置生成。

    最终输出

    使用效果的当前设置,渲染全部活动帧。

  8. 根据需要,为添加的颗粒设置动画。
  9. 从“查看模式”控件中选择“最终输出”。

在匹配杂色时补偿现有杂色

如果尝试使用匹配颗粒效果匹配图像之间的颗粒,而目标图层已经有自己的可见颗粒,则可能发生颗粒不匹配或颗粒累积的情况。为防止出现这些问题,“补偿现有杂色”控件会从源图层和目标图层提取杂色模型,然后在将源图层的杂色应用到目标图层之前,对其进行修改,以处理目标图层中已有的杂色。

要自动使用此控件,请将“补偿现有杂色”滑块设置为 100%。然后可通过在“查看模式”菜单中选择“补偿范例”,在目标图层中查看杂色样本。也可以通过将“采样模式”设置为“手动”,在目标图像中重新定位样本,以使“补偿样本点”可用于手动重新定位。

  1. 将匹配颗粒效果应用到目标图层。
  2. 在“效果控件”面板中,根据需要调整“匹配颗粒”效果下的“补偿现有杂色”值。对源图层的杂色和目标图层的杂色进行采样,计算其差值,以便仅将使目标图层和源图层匹配的足够杂色应用到目标图层。
  3. 要修改杂色样本,请从“查看模式”菜单中选择“杂色样本”,将“采样”>“样本选择”控件更改为“手动”,然后展开“补偿样本点”。“样本数量”的当前值可确定可用的点数。
  4. 要重新定位每个样本点,请执行以下任一操作:
    • 在“合成”面板中将每个样本点拖到新位置。

    • 在“效果控件”面板中“补偿样本点”控件下的样本点旁输入新的 X 和 Y 坐标。

    • 在“效果控件”面板中,单击“补偿样本点”的点参数 ,然后单击要在“合成”面板中将该点移动到的位置。

  5. 从“查看模式”控件中选择“最终输出”。

中间值效果

中间值效果将每个像素替换为另一像素,此像素具有指定半径的邻近像素的中间颜色值。当“半径”值较低时,此效果可用于减少某些类型的杂色。在“半径”值较高时,此效果为图像提供绘画风格的外观。

此效果适用于 8-bpc 和 16-bpc 颜色。

中间值效果:在应用效果之前和之后
原始图像(左图)、应用效果后的图像(右图)

杂色效果

杂色效果随机更改整个图像中的像素值。

此效果适用于 8-bpc、16-bpc 和 32-bpc 颜色。

杂色效果:在应用效果之前和之后
原始图像(左图)、应用效果后的图像(右图)

杂色数量

要添加的杂色的数量。

杂色类型

“使用杂色”可将随机值单独添加到红色、绿色和蓝色通道中。否则,将同一随机值添加到每个像素的所有通道。

剪切

剪切颜色通道值。取消选择此选项可导致更明显的杂色。此控件在 32-bpc 项目中不起作用。

杂色 Alpha 效果

杂色 Alpha 效果将杂色添加到 Alpha 通道。

此效果适用于 8-bpc 颜色。

杂色

杂色的类型。“唯一随机”创建等量的黑白杂色。“方形随机”创建高对比度杂色。“均匀动画”创建动画化的杂色,而“方形动画”创建动画化的高对比度杂色。

数量

杂色的强度。

原始 Alpha

如何将杂色应用于 Alpha 通道:

相加

在剪辑的透明和不透明区域产生等量的杂色。

固定

仅在不透明区域产生杂色。

缩放

按不透明度的比例增加杂色量,并在 100% 透明区域不产生杂色。

边缘

仅在部分透明区域(如 Alpha 通道的边缘)产生杂色。

溢出

效果如何重新映射位于灰度范围 0-255 之外的值。

剪切

大于 255 的值映射到 255。小于 0 的值映射到 0。

反绕

大于 255 或小于 0 的值被反射回 0-255 范围。例如,将值 258 (255+3) 反射到 252 (255-3),将值 ‑3 反射到 3。

回绕

大于 255 和小于 0 的值被回绕到 0-255 范围内。例如,将 258 回绕至 2,将 256 回绕至 0,将 3 回绕至 253。

随机植入

杂色的随机数字生成器的输入值。仅当选择“均匀随机”或“方形随机”后,此控控件才处于活动状态。

注意:

要产生闪光杂色,请为“随机植入”控件设置动画。要创建平滑动画杂色,请为“杂色相位”值设置动画。

杂色相位

指定杂色的位置。仅当选择“均匀动画”或“方形动画”后,此控控件才处于活动状态。

杂色选项(动画)

动画化杂色的方式。

改变“杂色相位”关键帧的时间安排,以调整“杂色相位”循环的速度。

注意:

要节省为“杂色相位”值设置动画的时间,请使用“循环杂色”选项来创建无缝杂色循环。然后,渲染图层,并将其重新导入为新的源素材项目。  

循环杂色

产生在指定时间内循环一次的杂色循环。

循环

指定重复前杂色循环使用的“杂色相位”的旋转次数(仅当选择“循环杂色”时可用)。

杂色 HLS 效果和杂色 HLS 自动效果

杂色 HLS 效果和杂色 HLS 自动效果可将杂色添加到图像的色相、亮度和饱和度分量。杂色 HLS 自动效果生成的杂色是自动设置动画的杂色;您可以选择动画的速度。要为杂色 HLS 效果设置动画,请使用关键帧或表达式。除控制杂色动画的“杂色相位”或“杂色动画速度”控件外,这些效果的控件都相同。

这些效果适用于 8-bpc 颜色。

杂色 HLS 效果和杂色 HLS 自动效果
原始图像(左图)、应用效果后的图像(右图)

杂色

杂色的类型。“统一”用于产生统一杂色。“方形”用于创建高对比度杂色。“颗粒”用于产生类似于胶片颗粒的颗粒状杂色。

色相

添加到色相值的杂色量。

亮度

添加到亮度值的杂色量。

饱和度

添加到饱和度值的杂色量。

颗粒大小

此控件仅对“颗粒”类型的杂色有效。

杂色相位(仅杂色 HLS)

杂色的随机数字生成器的输入值。设置杂色相位的关键帧时,该效果会进行相位循环来创建动画化的杂色。关键帧之间存在较大的值差时可加快杂色动画的速度。

杂色动画速度(仅杂色 HLS 自动)

杂色动画的速度。要加快或减慢杂色动画,请动画化此属性。

移除颗粒效果

要移除颗粒或可见杂色,请使用移除颗粒效果。此效果可使用复杂信号处理和统计评估技术,尝试将图像恢复到没有颗粒或杂色的外观。虽然许多技术(如应用适度的高斯模糊效果或中间值效果)可降低图像杂色的可见度,但也会不可避免地损失锐度和高光。相比之下,移除颗粒效果可将精细的图像细节与颗粒和杂色区分开,并尽可能多地保留图像细节。

移除颗粒效果提供几个选项,以使图像中的杂色深度减低和锐度保留达到精确平衡。此外,移除颗粒效果可分析各帧之间的差异,以进一步改善杂色深度减低和锐度保留;因为此过程随着时间的推移起作用,所以被称为临时过滤

注意:

良好的颗粒移除效果取决于良好的杂色采样。自动采样的结果取决于图像内容和杂色类型。您也可以为特定图像更改样本的数量、大小和位置,以获得最佳结果。

移除颗粒效果的“临时过滤”控件使用统计算法来混合当前帧与上一帧和下一帧。这些控件对从 DV 或视频素材移除压缩人为标记特别有效。

为正确评估此过滤的结果,必须实时查看结果,查看方式包括预览或查看渲染到文件的影片。

注意:

要加快移除颗粒效果预览的速度,请在“效果控件”面板中按顺序调整“移除颗粒”控件。具体而言,最有效的工作流程是:先找到有效的颗粒移除设置,最后调整后三个控件。

此效果适用于 8-bpc 和 16-bpc 颜色。

移除颗粒效果:原始图像和应用效果后的图像
原始图像(左图)、应用效果后的图像(右图)

移除图像中的杂色或颗粒

  1. 选择图层,然后选择“效果”>“杂色和颗粒”>“移除颗粒”。
  2. 使用“杂色深度减低设置”控件组调整以下任一项:
    • 要调整图像的杂色总数量,请调整“杂色深度减低”值。

    • 要单独调整每个通道的杂色数量,请调整“通道杂色深度减低”控件中的“红色杂色深度减低”、“绿色杂色深度减低”和“蓝色杂色深度减低”值。

    注意:

    通过重复使用以前创建的“演化”循环,并仅更改“随机植入”值,可轻松创建新的分形杂色动画。使用新的“随机植入”值可改变杂色图,而不扰乱“演化”动画。

  3. 调整“成功”值,以控制可以检测到的最大杂色半径:
    • 如果颗粒又大又厚,则尝试增加“成功”值。“成功”数量较高,可减低较大的杂色的深度。

    • 如果因为文件大,渲染时间超过预期时间,则尝试降低“成功”数量来减少内存使用率和渲染时间。

    注意:

    在应用最适宜的“成功”数量后,其他成功数量无效。

  4. 从“模式”弹出菜单中选择以下选项之一:

    多声道

    一起移除颜色图像所有通道的颗粒,此操作通常可产生最佳的颜色图像结果。此模式利用通道之间的关联来提高杂色移除过程的准确度。

    单通道

    单独移除每个通道的颗粒。对单色图像使用此模式,在“多通道”导致出现令人不快的颜色人为标记时,也可以使用此模式。

  5. 在“微调”控件组中调整以下任一选项,以改善杂色深度减低和锐度保留之间的平衡:

    色度抑制

    抑制杂色中的某些色度,以清理图像。如果杂色鲜明,则增加此控件值有助于移除杂色。此数量设置得过高可能会消除图像本身的一些色度。(“色度抑制”对灰度图像没有影响,在“杂色深度减低设置”模式为“单通道”时,此控件不可用。)

    纹理

    控制传递到输出的深度级较低的杂色的数量。此设置特别有助于减少令人不快的人为标记,或保留精细纹理区域,如木材颗粒或砖块颗粒。值较低,可产生更平滑的人为结果。值较高,可使输入和输出一样。

    杂点大小偏见

    控制杂色深度减低过程对同一图像中杂色大小变化的响应方式。默认值为零,用于平等处理各种大小。负值用于保留较大的剩余杂色,并更大力度地移除较小的颗粒。正值用于保留较小的杂色,并更大力度地移除较大的杂色。

    清洁纯色面积

    控制通过杂色深度减低过程弄平值变化较低的邻近像素的程度。此设置对需要尽可能清洁的大纯色区域有帮助。过高的设置可弄平接近纯色的图像区域,从而生成人为外观。

  6. 调整“钝化蒙版”控件,以返回移除颗粒移除效果的精细边缘细节。
  7. 使用“临时过滤”控件可执行帧间杂色深度减低操作。
  8. 要更改效果视图,请从“查看模式”弹出菜单中选择以下任一选项:

    杂色样本

    显示为提取当前杂色模型已进行采样的区域。

    预览

    在 200x200 像素区域中显示应用效果的当前设置。

    混合遮罩

    显示当前颜色遮罩或蒙版,或二者的组合,具体显示内容根据“与原始图像混合”控件组的当前设置生成。

  9. 从“查看模式”控件中选择“最终输出”。

在图层中添加临时过滤

  1. 将移除颗粒效果应用到图像。
  2. 将“移除颗粒”预览区域放置在图像中具有最精细帧变化或具有最多移动图像细节的区域上。
  3. 在“临时过滤”控件中选择“启用”。
  4. 将“数量”值调整到 100%。
  5. 渲染合成并将其导出。

  6. 如果在移动对象周围看到不需要的条纹或模糊区域,则减少“运动敏感度”值,然后再次预览或渲染它。
  7. 如果要改善结果,请尝试以下技术:
    • 要快速减低有大量快速移动的杂色的影片中的杂色深度,请将“杂色深度减低”值设置为 0,将“临时过滤”数量设置为 100%,然后渲染影片。

    • 要加速预览,请在调整单帧的所有设置后,将临时过滤应用到图层。

    • 要保留图层上的效果,同时将临时过滤应用到图层,请预合成所选图层(选择“图层”>“预合成”),然后将移除颗粒效果应用到该图层。

使用“钝化蒙版”控件锐化图像

移除颗粒效果包含“钝化蒙版”控件,这些控件可增加边缘和精细细节的对比度,以帮助恢复可能在颗粒减少过程中损失的一些锐度。

  1. 执行以下任一操作:
    • 增加“钝化蒙版”控件的“数量”值,以实现可接受的锐化,而不生成不需要的人为标记,或带回过多颗粒。

    • 增加“阈值”值,以移除锐化时生成的所有不需要的人为标记。

    • 调整“半径”,以更改“钝化蒙版”在其中查找细节的区域。

    • 调整“杂色深度减低”值,直至图像开始损失锐度;然后将该值减小一点,之后应用“钝化蒙版”控件来锐化图像。

湍流杂色效果

湍流杂色效果可使用柏林杂色创建用于自然景观背景、置换图和纹理的灰度杂色,或模拟云、火、熔岩、蒸汽、流水或蒸气等事物。

湍流杂色效果本质上是分形杂色效果的现代高性能实现。湍流杂色效果需要的渲染时间较短,且更易于用于创建平滑动画。湍流杂色效果还可以更准确地对湍流系统建模,并且较小的杂色要素比较大的杂色要素移动得更快。使用分形杂色效果代替湍流杂色效果的主要原因是,前者适合创建循环动画,因为湍流杂色效果没有“循环”控件。

注意:

由于这两个效果的控件几乎相同,因此可以使用为分形杂色效果创建的大多数说明和教程来指导您使用湍流杂色效果。(请参阅分形杂色效果。)

“演化”控件用于创建杂色形状的精细变化。为这些控件设置动画可使杂色随时间平滑改变,从而创建类似的结果,例如,行云或流水。

此效果适用于 8-bpc、16-bpc 和 32-bpc 颜色。

控件

分形类型

分形杂色是通过为每个杂色图层生成随机编号的网格来创建的。“复杂度”设置用于指定杂色图层的数量。“分形类型”设置用于确定此网格的特性。

杂色类型

在杂色网格中的随机值之间使用的插值的类型。

反转

反转杂色。黑色区域变为白色,而白色区域变为黑色。

对比度

默认值为 100。较高的值可创建较大的、定义更严格的杂色黑白区域,通常显示不太精细的细节。较低的值可生成更多灰色区域,以使杂色柔和。

溢出

使用以下选项之一,重映射 0–1.0 范围之外的颜色值:

剪切

重映射值,以使高于 1.0 的所有值显示为纯白色,低于 0 的所有值显示为纯黑色。“对比度”值用于影响图像的多大部分超出此范围。较高的值可生成大部分黑色和/或白色的图像,以及较少的灰色区域。因此,对比度设置越高,细节越不精细。在用作亮度遮罩时,图层的透明度区域更明显、更明确。

柔和固定

在无穷曲线上重映射值,以使所有值均在范围内。此选项会降低对比度,使杂色显示为灰色,且几乎没有纯黑色或纯白色的区域。在用作亮度遮罩时,图层包含精细的透明度区域。

反绕

三角形式的重映射,以使高于 1.0 的值或低于 0 的值退回到范围内。在“对比度”设置为高于 100 时,此选项可显示精细的细节。在用作亮度遮罩时,图层将显示纹理更详细的透明度区域。

允许 HDR 结果

不执行重映射。保留 0-1.0 范围以外的值。

变换

用于旋转、缩放和定位杂色图层的设置。如果选择“透视位移”,则图层看起来像在不同深度一样。

复杂度

为创建杂色合并的(根据“子设置”)杂色图层的数量。增加此数量将增加杂色的外观深度和细节数量。

注意:

增加“复杂度”会增加渲染时间。在适当的情况下,尝试减少“大小”,而不是增加“复杂度”来达到相似的结果,并避免使用更长的渲染时间。增加表面的复杂度,而不增加渲染时间的技巧是:使用负数或很高的“对比度”/“亮度”设置,并选择“反绕”作为“溢出”值。

子设置

杂色是通过合并杂色图层生成的。“子设置”用于控制此合并方式,以及杂色图层的属性彼此偏移的方式。缩小连续图层可创建更精细的细节。

子影响

每个连续图层对合并杂色的影响。值为 100%,所有迭代的影响均相同。值为 50%,每个迭代的影响均为前一个迭代的一半。值为 0%,则使效果看起来就像“复杂度”为 1 时的效果一样。

子缩放

相对于前一个杂色图层的杂色图层的缩放百分比。

演化

使用渐进式旋转,以继续使用每次添加的旋转更改图像。此方法与典型旋转不同,后者参考转盘控件上的设置,对于 360° 的每个倍数,其结果均相同。对于“演化”,值为 0° 的外观与 1 次旋转的外观不同,后者与 2 次旋转的外观不同,等等。

您可以通过为“演化”设置动画来指定杂色在一段时间内演化的数量。在给定时间内旋转次数越多,杂色更改的速度越快。在一段短时间内“演化”值的较大变化可能导致闪光。

演化选项

湍流因素

较小杂色的要素速度与较大杂色的要素速度相差的数量。值为 0,则使此杂色的移动与分形杂色效果生成的杂色相似,在分形杂色效果中,较小杂色的要素以与较大杂色的要素相同的速度移动。值较大,则使杂色的多个图层看起来像翻腾一样,其方式更像流体自然湍流翻腾一样。

随机植入

设置生成杂色使用的随机值。为“随机植入”属性设置动画会导致以下结果:从一组杂色闪光到另一组杂色(在该分形类型内),此结果通常不是您需要的结果。为实现平滑的杂色动画效果,请为“演化”属性设置动画。

注意:

通过重复使用以前创建的“演化”循环,并仅更改“随机植入”值,可轻松创建新的杂色动画。使用新的“随机植入”值可改变杂色图,而不扰乱“演化”动画。

不透明度

杂色的不透明度。

混合模式

杂色和原始图像之间的混合操作。除以下设置外,这些混合模式与“时间轴”面板的“模式”列中的混合模式相同:

有关每个混合模式的说明,请参阅混合模式参考

仅渲染分形杂色,不在原始图层上合成。

色相

按色相值而非灰度值渲染分形杂色。将保留原始图层的“饱和度”和“亮度”。如果原始图层是灰度图层,则不执行任何操作。

饱和度

按饱和度值而非灰度值渲染分形杂色。保留原始图层的“色相”和“亮度”。如果原始图层是灰度图层,则不执行任何操作。

Adobe 徽标

登录到您的帐户

[Feedback V2 Badge]