用户指南 取消(C)

预合成、嵌套和预渲染

  1. After Effects 用户指南
  2. Beta 版
    1. Beta 版项目概述
    2. After Effects Beta 版主页
    3. Beta 版中的功能
      1. “属性”面板(Beta 版)
      2. 可选轨道遮罩图层(Beta 版)
      3. 原生 H.264 编码(Beta 版)
  3. 快速入门
    1. After Effects 快速入门
    2. After Effects 的新增功能 
    3. 发行说明 | After Effects
    4. After Effects 系统要求
    5. After Effects 中的键盘快捷键
    6. 支持的文件格式 | After Effects
    7. 硬件建议
    8. 适用于 Apple Silicon 的 After Effects
    9. 规划和设置
    10. 设置和安装
  4. 工作区
    1. 常规用户界面项
    2. 了解 After Effects 界面
    3. 工作流程
    4. 工作区、面板和查看器
  5. 项目与合成
    1. 项目
    2. 合成基础知识
    3. 预合成、嵌套和预渲染
    4. 使用合成分析器查看详细的性能信息
    5. CINEMA 4D 合成渲染器
  6. 导入素材
    1. 准备并导入静止图像
    2. 从 After Effects 和 Adobe Premiere Pro 导入
    3. 导入和解释视频与音频
    4. 准备和导入 3D 图像文件
    5. 导入和解释素材项目
    6. 使用素材项目
    7. 使用“场景编辑检测”检测编辑点
    8. XMP 元数据
  7. 文本和图形
    1. 文本
      1. 设置字符格式和“字符”面板
      2. 文本效果
      3. 创建和编辑文本图层
      4. 设置段落格式和“段落”面板
      5. 凸出文本和形状图层
      6. 为文本设置动画
      7. 文本动画的示例和资源
      8. 实时文本模板
    2. 动态图形
      1. 在 After Effects 中使用动态图形模板
      2. 使用表达式在动态图形模板中创建下拉列表
      3. 使用“基本属性”创建动态图形模板
      4. 替换动态图形模板和基本属性中的图像和视频
  8. 绘图、绘画和路径
    1. 形状图层、路径和矢量图形的概述
    2. 绘画工具:笔刷、仿制图章和橡皮擦
    3. 将形状描边椎体化
    4. 形状图层的形状属性、绘画操作和路径操作
    5. 使用“位移路径”形状效果更改形状
    6. 创建形状
    7. 创建蒙版
    8. 使用内容识别填充面板,移除视频中的对象
    9. Roto 笔刷和调整遮罩
  9. 图层、标记和摄像机
    1. 选择和排列图层
    2. 混合模式和图层样式
    3. 3D 图层
    4. 图层属性
    5. 创建图层
    6. 管理图层
    7. 图层标记和合成标记
    8. 摄像机、光和目标点
  10. 动画、关键帧、运动跟踪和抠像
    1. 动画
      1. 动画基础知识
      2. 使用人偶工具制作动画
      3. 管理形状路径和蒙版并对其进行动画制作
      4. 使用 After Effects 为 Sketch 和 Capture 形状制作动画
      5. 分类动画工具
      6. 使用数据驱动的动画
    2. 关键帧
      1. 关键帧插值
      2. 设置、选择和删除关键帧
      3. 编辑、移动和复制关键帧
    3. 运动跟踪
      1. 跟踪和稳定运动
      2. 人脸跟踪
      3. 蒙版跟踪
      4. 蒙版引用
      5. 速度
      6. 时间拉伸和时间重映射
      7. 时间码和时间显示单位
    4. 抠像
      1. 抠像
      2. 抠像效果
  11. 透明度与合成
    1. 合成和透明度概述及资源
    2. Alpha 通道和遮罩
  12. 调整颜色
    1. 颜色基础知识
    2. 色彩管理
    3. 颜色校正效果
  13. 效果和动画预设
    1. 效果和动画预设概述
    2. 效果列表
    3. 模拟效果
    4. 风格化效果
    5. 音频效果
    6. 扭曲效果
    7. 透视效果
    8. 通道效果
    9. 生成效果
    10. 过渡效果
    11. 果冻效应修复效果
    12. 模糊和锐化效果
    13. 3D 通道效果
    14. 实用效果
    15. 遮罩效果
    16. 杂色和颗粒效果
    17. 保留细节放大效果
    18. 旧版效果
  14. 表达式和自动化
    1. 表达式
      1. 表达式基础知识
      2. 了解表达式语言
      3. 使用表达式控件
      4. JavaScript 与旧版 ExtendScript 表达式引擎之间的语法差别
      5. 正在编辑表达式
      6. 表达式错误
      7. 使用表达式编辑器
      8. 使用表达式编辑和访问文本属性
      9. 表达式语言引用
      10. 表达式示例
    2. 自动化
      1. 自动化
      2. 脚本
  15. 沉浸式视频、VR 和 3D
    1. 在 After Effects 中构造 VR 环境
    2. 应用沉浸式视频效果
    3. 用于 VR/360 视频的合成工具
    4. 跟踪 3D 摄像机运动
    5. 使用 3D 设计空间
    6. 3D 变换 Gizmo
    7. 使用 3D 动画执行更多操作
    8. 使用实时引擎实时预览对 3D 设计的更改
    9. 向图形添加响应式设计 
  16. 视图和预览
    1. 预览
    2. 使用 Mercury Transmit 进行视频预览
    3. 修改和使用视图
  17. 渲染和导出
    1. 渲染和导出基础知识
    2. 将 After Effects 项目导出为 Adobe Premiere Pro 项目
    3. 转换影片
    4. 多帧渲染
    5. 自动渲染和网络渲染
    6. 渲染和导出静止图像及静止图像序列
    7. 在 After Effects 中使用 GoPro CineForm 编解码器
  18. 使用其他应用程序
    1. Dynamic Link 和 After Effects
    2. 使用 After Effects 和其他应用程序
    3. After Effects 中的同步设置
    4. After Effects 中的 Creative Cloud Libraries
    5. 增效工具
    6. CINEMA 4D 和 Cineware
  19. 协作:Frame.io 和团队项目
    1. 在 Premiere Pro 和 After Effects 中协作
    2. Frame.io
      1. 安装和激活 Frame.io
      2. 将 Frame.io 与 Premiere Pro 和 After Effects 搭配使用
      3. 常见问题解答
    3. 团队项目
      1. 开始使用团队项目
      2. 创建团队项目
      3. 使用团队项目进行协作
  20. 内存、存储、性能
    1. 内存和存储
    2. After Effects 处理预览时内存不足问题的方式    
    3. 提高性能
    4. 首选项
    5. After Effects 的 GPU 和 GPU 驱动程序要求

关于预合成和嵌套

如果要对合成中已存在的某些图层进行分组,可以预合成 这些图层。预合成图层会将这些图层放置在新合成中,这将替换原始合成中的图层。新的嵌套合成将成为原始合成中单个图层的源。新合成将显示在“项目”面板中并且可用于渲染或者在其他任何合成中使用。您可以通过将现有合成添加到其他合成中来嵌套合成,正如您将其他任何素材项目添加到合成中一样。预合成单个图层可用于向图层添加变换属性以及影响渲染合成元素的顺序。

嵌套是一个合成包含在另一个合成中。嵌套合成显示为包含的合成中的一个图层。

嵌套合成有时称为预合成,在非正式使用时偶尔缩写为 precomppre-comp。当预合成用作某个图层的源素材项目时,该图层称为预合成图层

在渲染期间,图像数据和其他信息可以认为是从每个嵌套合成到包含该合成的合成中的。因此,嵌套合成有时称为是包含这些合成的合成的上游,包含的合成称为是这些合成包含的嵌套合成的下游。通过嵌套相连的一系列合成称为合成网络。您可以使用“合成导航器”和“微型流程图”在合成网络中导航。(请参阅打开并导航嵌套的合成。)

After Effects 中的预合成类似于 Adobe Photoshop 中的智能对象。

用于预合成和嵌套

预合成和嵌套可用于管理和组织复杂合成。通过预合成和嵌套,您可以执行以下操作:

  • 将复杂更改应用到整个合成 - 可以创建包含多个图层的合成,在整个合成中嵌套该合成,并对嵌套合成进行动画制作以及应用效果,以便所有图层在同一时间段内以相同方式更改。
  • 重新使用您构建的任何内容 - 您可以在自己的合成中构建动画,然后根据需要将该合成多次拖动到其他合成中。
  • 一步完成更新 - 当您对嵌套合成进行更改时,这些更改将影响其中使用嵌套合成的每个合成,正如对源素材项目所做的更改将影响其中使用源素材项目的每个合成一样。
  • 更改图层的默认渲染顺序 - 您可以指定 After Effects 在渲染效果之前渲染变换(如旋转),以便将效果应用于旋转的素材。
  • 向图层添加另一组变换属性 - 除了所含图层的属性之外,代表合成的图层还拥有自己的属性。这样,您能够将其他系列的变换应用于图层或图层系列。

影响嵌套合成的首选项和合成设置

因为预合成本身是一个图层,所以您可以在“时间轴”面板中使用图层开关和合成开关控制其行为。您可以选择对包含的合成中的开关所做的更改是否传播到嵌套合成。要防止图层开关影响嵌套合成,请选择“编辑”>“首选项”>“常规”(Windows) 或“After Effects”>“首选项”>“常规”(Mac OS),然后取消选择“开关影响嵌套的合成”。

在“合成设置”对话框(“合成”>“合成设置”)的“高级”选项卡中,选择“在嵌套时保留分辨率”或“在嵌套时或在渲染队列中,保留帧速率”以使合成保留其自己的分辨率或帧速率,而不是从包含的合成中继承这些设置。例如,如果特意在合成中使用了较低的帧速率来创建不规则的手工动画结果,则您应该在嵌套该合成时保留该合成的帧速率。同样,当转换为其他帧速率或分辨率时,动态抠像的结果可能看起来是错误的。使用此设置而不是效率较低的“色调分离时间”效果。

注意:

Jeff Almasol 在其 redefinery 网站上提供了一个脚本,可以更方便地切换“在嵌套时保留分辨率”或“在嵌套时或在渲染队列中,保留帧速率”首选项设置。

在一个面板中更改当前时间会更新与该合成关联的其他面板中的当前时间。默认情况下,还会为通过嵌套与当前合成相关的所有合成更新当前时间。要防止通过嵌套相关的合成在您更改一个合成中的当前时间时更新自己的当前时间,请取消选择“同步所有相关项目的时间”首选项(“编辑”>“首选项”>“常规”(Windows) 或“After Effects”>“首选项”>“常规”(Mac OS))。

关于预合成和嵌套的在线资源

Chris 和 Trish Meyer 在 ProVideo Coalition 网站上提供了本文,其中分享了关于设置合成层次的技巧,以便更轻松地在项目中进行更改。

请参阅请参阅 aescripts网站上的此页面,了解将从预合成中提取图层的 Un-Precompose脚本。

请参阅aescripts网站上的此页面,了解 Zorro-The Layer Tagger 脚本,该脚本允许您使用标记而不是预合成对您的合成中的图层进行分组。

预合成图层

预合成图层会将这些图层放置在新合成(有时称为预合成)中,这将替换原始合成中的图层。预合成单个图层可用于向图层添加变换属性以及影响渲染合成元素的顺序。

  1. 在“时间轴”面板中选择图层,并选择“图层”>“预合成”或者按 Ctrl+Shift+C (Windows) 或 Command+Shift+C (Mac OS)。
  2. 选择以下选项之一:

    保留其中的所有属性

    保留原始合成中预合成图层的属性和关键帧,这些属性和关键帧应用于表示预合成的新图层。新合成的帧大小与所选图层的大小相同。当您选择多个图层、一个文本图层或一个形状图层时,此选项不可用。

    将所有属性移动到新合成

    在合成层次结构中将预合成图层的属性和关键帧从根合成进一步移动一个层次。在使用此选项时,您应用于图层属性的更改也将应用于预合成中的各个图层。新合成的帧大小与原始合成的帧大小相同。

效果可以包含其他图层的蒙版和效果

将图层用作输入的效果(如设置遮罩和置换图),可以将输入图层的蒙版和效果作为目标。您可以直接使用这些图层,而不必为了让效果对其引用而进行预合成。 

此控件的作用与“图层查看器”面板底部“视图”菜单的功能类似,您可从渲染顺序中的不同位置渲染图层:从源、从蒙版或者从单个效果渲染图层。
对于带图层属性的效果,请打开图层选择项右侧的“输入参数”菜单,选择以下目标输入图层:

  • 源:仅将图层的源作为目标。而忽略蒙版和效果。
  • 蒙版:将应用蒙版后的图层作为目标。忽略效果。
  • 效果和蒙版:将应用蒙版和效果后的图层作为目标。

 

打开并导航嵌套的合成

嵌套合成有时称为是包含这些合成的合成的上游,包含的合成称为是这些合成包含的嵌套合成的下游根合成是最下游;最深的嵌套合成是最上游。合成流路径是通过彼此包含或嵌套彼此关联的一系列合成。合成网络是通过嵌套彼此关联的整个合成系列。

After Effects 提供了多种打开嵌套合成(预合成)的方法:

  • 在“项目”面板中双击合成条目。
  • 在“时间轴”面板中双击预合成图层。按住 Alt 键并双击 (Windows) 或按住 Option 键并双击 (Mac OS) 可在“图层”面板中将预合成图层作为图层打开。
注意:

当绘画工具或 Roto 笔刷工具处于活动状态时,双击预合成图层将在“图层”面板中打开该图层。

  • 要在当前活动的合成所在的同一合成网络中打开最近活动的合成,请按 Shift+Esc。

  • 使用“合成导航器”。

  • 使用“合成微型流程图”。

合成导航器

“合成导航器”是沿“合成”面板上边缘的一个条,可显示该查看器中与同一合成网络中的其他合成相关的活动合成。显示的合成是当前活动的合成的流路径中最近活动的合成。

合成导航器

A. 活动(当前)合成 B. 用于打开“合成微型流程图”的箭头 C. 面板菜单按钮 D. 省略号 

合成名称之间的箭头表示此流路径下像素信息流动的方向。在“合成导航器”条中显示合成的默认方式是,下游合成显示在左侧,上游合成显示在右侧。此默认方式由“合成”面板菜单中的“从右向左流动”选项指示。要按其他顺序显示合成,请选择“从左向右流动”。此设置是全局首选项;它适用于所有合成以及“合成微型流程图”视图。

下游合成的名称显示为灰色,以指示其内容未用在或显示在活动合成中。

  • 要显示或隐藏“合成导航器”条,请从“合成”面板菜单中选择“显示合成导航器”。

  • 要激活“合成导航器”条中显示的任何合成,请单击合成名称。

  • 如果流路径太长而无法在“合成”面板中显示,则“合成导航器”条的左边缘或右边缘将显示省略号 按钮。要暂时显示整个流路径,请单击省略号按钮。

注意:

要滚动显示较长的流路径,请将指针置于“合成导航器”中的合成按钮上方并滚动鼠标滚轮。

合成微型流程图

“合成微型流程图”是一个可用于在合成网络中快速导航的瞬态控制。当您打开“合成微型流程图”时,它将立即显示所选合成上游和下游的合成。

“合成微型流程图”中的颜色基于分配给“项目”面板中的合成的标签颜色。如果某合成在一个合成中使用了多次,则嵌套合成的多个实例将显示为一个带有表示实例数目的数字(位于括号中)的条目。

要打开“合成微型流程图”,请执行以下任一操作:

合成微型流程图

A. 指示合成不会流动到其他合成中的指示器 B. 流程方向 C. 活动(当前)合成 

  • 在“合成”、“图层”或“时间轴”面板处于活动状态时按 Tab 键。
  • 单击“合成导航器”条中合成名称右侧的箭头。

  • 从“合成”菜单、“合成”面板菜单或“时间轴”面板菜单中选择“合成微型流程图”。

  • 单击“时间轴”面板顶部的“合成微型流程图” 按钮。

与“合成导航器”一样,您可以选择是从左到右还是从右到左显示流方向。指示流方向的箭头。如果合成旁边有一个 而不是箭头,则该合成不具有任何流向其中的合成或者该合成不会流向任何合成中。

“合成微型流程图”中的上游合成按字母顺序或按图层顺序从上到下进行排序。要在这些排序顺序之间切换,请在“合成微型流程图”打开时按 S 键。在按图层顺序排序时,多次使用的合成将根据该合成的堆积顺序最靠上的实例进行排序。下游合成始终按字母顺序进行排序。

要在“合成微型流程图”中的合成之间进行导航以及选择合成,请使用箭头键或者单击箭头或合成任一侧的 按钮。要激活所选合成,请按空格键或者 Enter 键 (Windows) 或 Return 键 (Mac OS)。要关闭“合成微型流程图”而不采取任何操作,请按 Esc 键,点击 Shift 键,或者单击“合成微型流程图”外部。

Rich Young 在 After Effects Portal 网站上提供了有关“流程图”面板和“合成微型流程图”的更多信息。

预渲染嵌套合成

复杂的嵌套合成可能需要很长时间来为预览或最终输出进行渲染。如果您有一个无需进一步处理的嵌套合成,您可以通过将嵌套合成预渲染到影片中并将合成替换为渲染的影片来在每个渲染操作过程中节省时间。您仍可以修改原始嵌套合成,因为它仍位于“项目”面板中。如果您对原始嵌套合成做出重大更改,请再次渲染它。

当您将在项目中多次使用嵌套合成时,预渲染嵌套合成特别有益。

注意:

在您预渲染嵌套合成时应用您的最终输出设置。

  1. 在“项目”或“合成”面板中选择合成。
  2. 选择“合成”>“预渲染”。

    “预渲染”命令会向渲染队列添加合成并设置“导入和替换用法”渲染后动作以将合成替换为渲染的影片。

  3. 在“渲染队列”面板中,根据需要调整设置,然后单击“渲染”按钮以渲染合成。
注意:

将合成替换为影片的一种替代方法是使用渲染的影片作为嵌套合成的代理。

渲染顺序和折叠变换

合成由“时间轴”面板中彼此堆叠的图层组成。在为进行预览或者最终输出渲染合成时,首先将渲染底部图层。在每个栅格(非矢量)图层中,将按以下顺序应用元素:蒙版、效果、变换以及图层样式。对于连续栅格化的矢量图层,默认渲染顺序是蒙版,紧接着是变换,然后是效果。

变换是对在“时间轴”面板中的“变换”类别下分组的属性(包括“锚点”、“位置”、“缩放”、“旋转”以及“不透明度”)所做的更改。您在“图层”面板中看到的是在执行变换之前渲染的结果。

注意:

要对何时执行变换进行额外控制,您可以应用“变换”效果并相对于其他效果对其重新排序。

在一组效果或蒙版中,将自上而下处理各项目。例如,如果您应用“圆形”效果,然后应用“放大”效果,则将放大圆形。然而,如果您在“效果控件”或“时间轴”面板中将“放大”效果拖动到“圆形”效果上方(之前),则将在放大后绘制圆形且不会放大圆形。

在渲染完某个图层之后,将开始渲染下个图层。下面的渲染图层可能用作上面的图层渲染的输入,例如用于确定混合模式的结果。

如果合成包含在其之内嵌套的其他合成,则将在包含的合成中的其他图层之前渲染嵌套合成。

注意:

某些效果将忽略其应用于的图层上的蒙版。要在带蒙版的图层上运行此类效果,请使用应用的蒙版预合成该图层,然后将该效果应用于预合成的图层。(请参阅关于预合成和嵌套。)

折叠变换

如果为嵌套合成选择“折叠变换”开关 ,则直到渲染包含的合成的蒙版和效果后才会执行嵌套合成的变换。此渲染顺序允许合并(或折叠)嵌套合成和包含的合成的变换,并一起执行这些变换。对于未连续栅格化的矢量图层同样如此。

注意:

矢量图层在同一位置具有一个“连续栅格化”开关,而不是“折叠变换”开关。矢量图层包括形状图层、文本图层以及将矢量图形文件用作源素材的图层。文本图层和形状图层始终会连续栅格化。

例如,当图层在嵌套合成中缩小一半时,折叠变换可以保持分辨率,且嵌套合成在包含的合成中将增大两倍。在此情况下,可以执行一次变换(不用执行任何操作),而无需执行两种变换以及丢掉正在处理的图像数据,这是因为各个变换将相互抵消。

如果不折叠变换,则会使用默认的合成摄像机将包含 3D 图层的嵌套合成渲染为 3D 排列的 2D 图像。此渲染可防止嵌套合成与 3D 图层相交,在 3D 图层上投影,以及从包含的合成中的 3D 图层中接受阴影。嵌套的合成同样不受包含的合成的摄像机和光的控制。

如果变换已折叠,则嵌套合成中图层的 3D 属性将对包含的合成公开。因此,嵌套合成可与 3D 图层相交,在 3D 图层上投影,以及从包含的合成中的 3D 图层中接受阴影。包含的合成的摄像机和光还可以控制嵌套合成。

本质上,嵌套合成的折叠变换会告知 After Effects 不要拼合和裁剪预合成中的图层。因为调整图层适用于同一合成中该图层下的所有图层的合成,所以具有折叠变换的嵌套合成中的调整图层将强制折叠变换通常会阻止的拼合和裁剪。

当关闭的蒙版(具有“无”之外的蒙版模式)、图层样式或效果应用于具有折叠变换的嵌套合成时,嵌套合成中的图层首先会独立进行渲染,然后应用蒙版和效果,然后将结果合成到主合成中。此渲染顺序意味着嵌套图层的混合模式没有应用于主合成中的任何底层图层,且折叠图层上方和下方的 3D 图层不能相交或彼此投影。

在线资源

Chris 和 Trish Meyer 在 ProVideo Coalition 网站上的这篇文章中介绍了折叠变换和连续栅格化。

Adobe 徽标

登录到您的帐户