组织、查看、管理和修剪素材项目

“项目”面板中列出了合成和素材项目。与“时间轴”面板和“效果控件”面板中的项目不同,“项目”面板中的项目顺序对您所创建的影片的外观无影响。但是,如果您愿意,您可以组织素材项目和合成,包括使用文件夹组织它们。纯色素材项目将自动放在“纯色”文件夹中。

您在“项目”面板中创建的文件夹只位于“项目”面板中。可以展开一个文件夹来显示其中的内容,也可以将一个文件夹放在其他文件夹内。要将一个文件或文件夹移至“项目”面板的顶层,请将其拖动到面板顶端的灰色信息区域。

可以使用“项目”面板中的搜索字段来查找符合各种条件的素材项目,如缺少源文件的素材项目。请参阅在“时间轴”、“项目”以及“效果和预设”面板中搜索和过滤

如需关于在“项目”面板中组织资源的有用视频教程,请参阅由 Jeff Sengstack 和 Infinite Skills 提供的此视频教程

用于管理素材项目的脚本

Jeff Almasol 在他的 redefinery 网站上提供了一个脚本,该脚本可以将有关素材项目或图层的指定信息自动写入“项目”面板或“时间轴”面板中各个项的“注释”字段。

Christopher Green 在他的网站上提供了一个脚本 (Project_Items_Renamer.jsx),您可以使用该脚本重命名在“项目”面板中选择的合成和素材项目。您可以搜索和替换名称中的文本,在名称的开头或结尾附加字符,或者从名称的开头或结尾修剪掉指定的字符数。

Lloyd Alvarez 在 After Effects Scripts 网站上提供了一个脚本,您可以使用该脚本搜索 After Effects 项目以及替换素材项目源的文件路径。这便于交换出源文件,在移动源后更新项目,或者在将项目移至不同的计算机系统后更新项目。

显示项目信息

  • 要显示某个素材项目或合成的信息,请在“项目”面板中选择它。“项目”面板顶端缩略图的旁边将显示相关信息。
  • 要显示某个素材项目的文件创建者 ID,请在“项目”面板中按住 Alt 键 (Windows) 或按住 Option 键 (Mac OS) 并单击该项目。

创建文件夹

  1. 选择“文件”>“新建”>“新建文件夹”,或单击“项目”面板底部的“新建文件夹”图标

重命名和排序项目

  • 要重命名合成、素材项目或文件夹,请执行以下操作之一:
    • 在“项目”面板中选择该项目,按 Enter 键 (Windows) 或 Return 键 (Mac OS),输入新名称。

    • 右键单击 (Windows) 或按住 Control 键并单击 (Mac OS) 该项目,选择“重命名”,输入新名称。

  • 要重命名“注释”列,请右键单击 (Windows) 或按住 Control 键并单击 (Mac OS) 列标题,然后选择“重命名此项”。

注意:

可以使用“注释”列创建自定义排序选项。重命名该列,针对每个项目(例如,摄像机编号)输入相应信息,然后依照该列排序。

  • 要按照任何列中的条目排序各个项目,请在“项目”面板中单击列名称。

复制项目

  • 要重复或复制“项目”面板中的某个项目,请选择该项目,选择“编辑”>“重复”或“编辑”>“复制”。
  • 要将某个素材项目复制到 Windows 资源管理器 (Windows) 或 Finder (Mac OS) 中,请从“项目”面板将该素材项目拖动到桌面。

显示素材项目

  • 要显示某个素材项目在合成中的使用位置,请在“项目”面板中右键单击 (Windows) 或按住 Control 键并单击 (Mac OS) 该项目,选择“在合成中显示”;然后选择您希望显示的特定实例(合成名称图层名称)。
  • 要在“项目”面板中显示某个图层的源素材项目,请在“时间轴”面板中右键单击 (Windows) 或按住 Control 键并单击 (Mac OS) 该图层,然后选择“在项目中显示图层源”。
  • 要在 Adobe Bridge、Windows 资源管理器或 Finder 中显示某个素材项目的位置,请在“项目”面板中右键单击 (Windows) 或按住 Control 键并单击 (Mac OS) 该素材项目,选择“在 Bridge 中显示”、“在 Windows 资源管理器中显示”或“在 Finder 中显示”。

刷新素材项目

  1. 要刷新在“项目”面板中选择的素材项目以使用源素材文件的当前版本,请选择“文件”>“重新加载素材”。

在“素材”面板中查看素材项目或操作系统分配的媒体播放器

在“素材”面板中预览项目时,这些项目将显示素材解释操作的结果。(请参阅解释素材项目。)

  • 要在“素材”面板中打开一个素材项目,请在“项目”面板中双击该素材项目。
  • 要在“素材”面板中打开选定的素材项目,请在“项目”面板处于活动状态时按数字键盘上的 Enter 键。

注意:

要使用与该文件类型关联的播放器应用程序打开素材项目的源,请在“项目”面板中按住 Alt 键并双击 (Windows) 或按住 Option 键并双击 (Mac OS) 该素材项目。请参阅您的操作系统文档,了解有关更改应用程序与文件类型之间的关联的说明。

在“素材”面板中修剪素材项目

您可以在“素材”面板中使用“设置入点” 、“设置出点” 、“波纹插入编辑” 和“叠加编辑” 控件修剪素材项目并将其插入合成中。与在合成中添加素材项目,然后在“时间轴”面板中修剪其图层相比,在“素材”面板中进行修剪更容易。

增强的纯色文件夹组织

您可以通过增强的纯色文件夹组织来更好地组织纯色、调整图层和空值。您可以执行以下任务:

  • 重命名纯色文件夹:您可以重命名现有纯色文件夹,所有新纯色都在重命名的文件夹(而非名为“纯色”的单独文件夹)内创建。
    要重命名文件夹,请执行以下任一选项:

选项 1:

  1. 选择文件夹并按 Enter (Win) 或 Return (Mac)。

  2. 在名称字段内输入新名称。

选项 2:

  1. 右键单击并选择“重命名”。例如,将文件夹重命名为“色彩方块”。

  2. 重命名文件夹之后,当您尝试创建一种纯色时,会显示一条警告消息。

  3. 单击“是”并使用“色彩方块”来继续使用重命名的文件夹。

  4. 如果想在新的纯色文件夹内创建纯色,请单击“否”并使用“纯色”。

  • 为纯色文件夹设置默认名称:您可以为新项目中创建的纯色文件夹更改默认名称。
    要更改名称,请执行以下步骤:
  1. 要打开“首选项”窗口,请选择“首选项”>“新建项目”

  2. “首选项”窗口的“新建项目纯色文件夹”文本框中输入新名称,然后单击“确定”

注意:

这些设置会应用于您创建的新文件夹。不会影响您的当前项目。

  • 将纯色文件夹嵌套在其他文件夹中:您可以将纯色文件夹嵌套在其他文件夹中。将纯色文件夹拖到当前项目中的其他文件夹内,以进行嵌套。嵌套文件夹之后,将继续在嵌套文件夹内创建新的纯色。

注意:

您不能在团队项目中嵌套文件夹。

  • 将任意文件夹设置为纯色文件夹:您可以将文件夹设置为纯色文件夹。要将文件夹设置为纯色文件夹,请执行以下步骤:
  1. “项目”面板中右键单击首选文件夹。

  2. 从菜单中选择文件夹,将它设置为纯色文件夹。

注意:

一次只能将一个文件夹设置为纯色文件夹。

有关更多信息,请参阅纯色图层和纯色素材项目

在素材的原应用程序中编辑素材

您可以直接从 After Effects 项目中用创建素材项目的应用程序打开和编辑该素材项目。您所使用的计算机上必须安装该原始应用程序,而且必须具有足够的可用 RAM 以便其运行。在该原始应用程序中编辑并保存对素材的更改后,这些更改将在 After Effects 成为活动应用程序时应用于素材的所有实例。

注意:

如果您正在编辑具有 Alpha 通道的素材,请确保可在其他应用程序中查看和编辑所有通道(包括该 Alpha 通道)。否则,您所做的更改或许不能应用于该 Alpha 通道,而它可能变得与其他颜色通道不一致。

编辑在“时间轴”或“合成”面板中选定的静止图像序列时,将打开目前显示的单个图像。编辑在“项目”面板中选定的静止图像序列时,将打开序列中的第一个图像。

  1. 在“项目”面板、“合成”面板或“时间轴”面板中,选择将该素材项目用作源的素材项目或图层。如果从“合成”或“时间轴”面板中选择静止图像序列,请将当前时间指示器移到显示您要编辑的静止图像的帧处。
  2. 选择“编辑”>“编辑原稿”。
  3. 在素材的原应用程序中编辑素材并保存更改。

从项目中移除项

在精简项目、移除未使用的素材或整合素材前,应考虑先通过递增和保存项目来制作备份。(请参阅在 After Effects 中保存和备份项目。)

Carl Larsen 在 Creative COW 网站(该网站演示如何组织、整合和存档项目文件和素材)的一个视频教程中演示了“收集文件”命令和“整合所有素材”命令的用法。

  • 要从项目中移除某项,请在“项目”面板中选择该项并按 Delete 键。
  • 要从项目中移除所有未使用的素材项目,请选择“文件”>“删除未用过的素材”。
  • 要从项目中移除所有重复的素材项目,请选择“文件”>“整合所有素材”。仅当素材项目使用相同的“解释素材”设置时,After Effects 才将其视为重复项。

    在移除重复项时,引用该重复项的图层将更新为引用其余的副本。

  • 要在“项目”面板中移除未选择的合成以及选定合成中未使用的素材项目,请选择“文件”>“减少项目”。仅当“项目”面板处于活动状态时,此命令才可用。

    此命令既移除未使用的素材项目,也移除不作为嵌套(下级)合成包括在某个选定合成中的其他所有合成。

    如果选定合成包括已关闭的项目(即在“时间轴”面板上取消选择了视频或音频开关),则“减少项目”命令不移除这些项目。

    如果选定合成中的表达式引用非下级合成中的元素,“减少项目”将移除该非下级合成和应用的表达式。当您选择“减少项目”后会出现一条消息,提醒您这一可能性,以便您可以根据需要撤消此命令。要避免从非下级合成中移除表达式,可将非下级合成拖至引用它的合成上。然后,对添加的合成取消选择音频和视频开关。

占位符和代理

如果您希望临时使用某内容代替素材项目,可使用占位符代理

占位符

一个静止的彩条图像,用来临时代替缺失的素材项目。当您构建合成并且想检验一下尚不可用的素材项目的相关想法时,可以使用占位符。After Effects 自动生成占位符,所以您无需提供占位符素材项目。

代理

用来临时代替素材项目的任何文件,但通常用现有素材项目的低分辨率或静止版本来代替原始素材项目。通常使用故事板图像作为代理。您可以在选择最终素材前使用代理,也可以在选择实际素材项目,但希望加快测试影片的预览或渲染速度时使用代理。您必须具有可用作代理的文件。

用最终素材项目替换图层的占位符或代理时,将保留应用到图层的任何蒙版、属性、表达式、效果和关键帧。

在“项目”面板中,After Effects 通过标记素材名称来指出目前使用的是实际素材项目,还是其代理。

  • 实心框表示整个项目目前在使用代理项目。当选定素材项目后,将在“项目”面板的顶端用粗体显示代理的名称。

  • 空心框表示虽然已分配了代理,但整个项目目前在使用素材项目。

  • 无框表示未向素材项目分配代理。

处理占位符和缺失的素材项目

为获得最佳效果,应将占位符设置为与实际素材具有相同的大小、持续时间和帧速率。

如果在您打开项目时,After Effects 找不到源素材,则素材项目在“项目”面板中标记为“缺失”,缺失的素材的名称用斜体显示。使用该项目的任何合成将用一个占位符来取代它。您仍然可以处理项目中的缺失项目,而您应用于原始素材的任何效果将保持不变。当您用源素材替换占位符时,After Effects 会将该素材置于使用它的所有合成中的正确位置。

注意:

要查找哪些素材项目的源项目缺失,请在“项目”面板的搜索字段中键入 missing。请参阅在“时间轴”、“项目”以及“效果和预设”面板中搜索和过滤

  • 要使用占位符,请选择“文件”>“导入”>“占位符”。
  • 要用占位符替换选定的素材项目,请选择“文件”>“替换素材”>“占位符”。
  • 要用实际的素材项目替换占位符,请在“项目”面板中选择要替换的占位符,选择“文件”>“替换素材”>“文件”,并且找到实际的素材。

处理素材项目代理

当您使用代理时,After Effects 会在使用实际素材项目的所有合成中用代理替换实际素材。完成工作后,您可以转回到项目列表中的实际素材项目。After Effects 然后在所有合成中将代理替换成实际素材项目。

在将合成渲染为影片时,您可以选择使用所有实际的高分辨率素材项目或其代理。例如,如果您只想用快速渲染的粗糙影片测试运动,则可以对渲染的影片使用代理。

为获得最佳效果,可将代理设置为与实际素材项目具有相同的帧长宽比。例如,如果实际素材项目是 640x480 像素影片,则创建并使用 160x120 像素代理。当导入代理项目时,After Effects 会缩放该项目,直到它与实际素材具有相同的大小和持续时间。如果使用与实际素材项目不同的帧长宽比来创建代理,则缩放时间会更长。

  1. 在“项目”面板中,执行以下任一操作:
    • 要找到并使用代理,请选择素材项目,选择“文件”>“设置代理”>“文件”,找到并选择要用作代理的文件,单击“打开”。

    • 要在使用原始素材还是其代理之间进行切换,请单击素材名称左侧的代理指示器。

    • 要停止使用代理,请选择原始素材项目,选择“文件”>“设置代理”>“无”。

创建代理

使用“创建代理”命令可从在“项目”面板或“时间轴”面板中选择的素材或合成创建代理。此命令将选定的素材添加到“渲染队列”面板中,并将“渲染后动作”选项设置为“设置代理”。

  1. 在“项目”或“时间轴”面板中打开一个素材项目或合成。
  2. 在“素材”面板中将当前时间指示器移到要用作代理静止项目的帧上,对于影片素材项目,则移到标识帧上。
  3. 执行下列命令之一:
    • 要创建静止图像代理,请单击“文件”>“创建代理”>“静止图像”。

    • 要创建活动图像代理,请单击“文件”>“创建代理”>“影片”。

  4. 指定代理的名称和输出目标。
  5. 在“渲染队列”面板中,指定渲染设置,单击“渲染”。

创建输出占位符

您可以创建能在不同合成中使用的占位符文件。例如,可以为渲染队列中将创建 24 fps 影片的项目创建一个占位符,然后将该占位符拖入 30 fps 合成中。然后,当您渲染 30 fps 合成时,After Effects 首先会按 24 fps 渲染占位符,然后在渲染 30 fps 合成时使用该渲染版本。

  1. 将排队项目的“输出模块”标题从“渲染队列”面板拖至“项目”面板。After Effects 在“项目”面板中为输出创建一个占位符,并将项目的“渲染后动作”选项设置为“导入和替换用法”。

其他有关处理占位符和代理的资源

Andrew Kramer 在 Video Copilot 网站上提供了一个视频教程,其中包含有关处理代理、输出模块和输出模块模板的提示。

Jeff Almasol 在他的 redefinery 网站上提供了一个脚本,您可以使用该脚本创建、设置和取消设置代理和占位符。

Charles Bordenave (nab) 在 After Effects Scripts 网站上提供了一个脚本,您可以使用该脚本为多个选定项创建代理。

请参阅 Video2Brain 网站上的此视频教程(由 Todd Kopriv 提供),了解有关在 After Effects 中通过预渲染和使用代理来节省时间的信息。

循环素材项目

如果您准备在项目中连续循环某个可视素材项目,只需在 After Effects 中为该素材项目创建循环。

  1. 在“项目”面板中,选择要循环的素材项目。
  2. 选择“文件”>“解释素材”>“主要”。
  3. 为“循环”键入一个整数值,单击“确定”。

Lloyd Alvarez 在 After Effects Scripts 网站上提供了一个脚本,可用来自动循环素材项目、合成或图层。

在最后一帧上冻结

您现在可以冻结图层的最后一帧,直到合成末尾。After Effects 设置图层中的时间重映射关键帧,将图层持续时间延长到合成末尾。

要将合成冻结在素材的最后一帧上,请选择“图层”>“时间”>“在最后一帧上冻结”

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略