用户指南 取消(C)

形状图层、路径和矢量图形概述

  1. After Effects 用户指南
  2. Beta 版
    1. Beta 版项目概述
    2. After Effects Beta 版主页
  3. 快速入门
    1. After Effects 快速入门
    2. After Effects 的新增功能 
    3. 发行说明 | After Effects
    4. After Effects 系统要求
    5. After Effects 中的键盘快捷键
    6. 支持的文件格式 | After Effects
    7. 硬件建议
    8. 适用于 Apple Silicon 的 After Effects
    9. 规划和设置
  4. 工作区
    1. 常规用户界面项
    2. 了解 After Effects 界面
    3. 工作流程
    4. 工作区、面板和查看器
  5. 项目与合成
    1. 项目
    2. 合成基础知识
    3. 预合成、嵌套和预渲染
    4. 使用合成分析器查看详细的性能信息
    5. CINEMA 4D 合成渲染器
  6. 导入素材
    1. 准备并导入静止图像
    2. 从 After Effects 和 Adobe Premiere Pro 导入
    3. 导入和解释视频与音频
    4. 准备和导入 3D 图像文件
    5. 导入和解释素材项目
    6. 使用素材项目
    7. 使用“场景编辑检测”检测编辑点
    8. XMP 元数据
  7. 文本和图形
    1. 文本
      1. 设置字符格式和“字符”面板
      2. 文本效果
      3. 创建和编辑文本图层
      4. 设置段落格式和“段落”面板
      5. 凸出文本和形状图层
      6. 为文本设置动画
      7. 文本动画的示例和资源
      8. 实时文本模板
    2. 动态图形
      1. 在 After Effects 中使用动态图形模板
      2. 使用表达式在动态图形模板中创建下拉列表
      3. 使用“基本属性”创建动态图形模板
      4. 替换动态图形模板和基本属性中的图像和视频
      5. 使用“属性”面板更快、更轻松地制作动画
  8. 绘图、绘画和路径
    1. 形状图层、路径和矢量图形的概述
    2. 绘画工具:笔刷、仿制图章和橡皮擦
    3. 将形状描边椎体化
    4. 形状图层的形状属性、绘画操作和路径操作
    5. 使用“位移路径”形状效果更改形状
    6. 创建形状
    7. 创建蒙版
    8. 使用内容识别填充面板,移除视频中的对象
    9. Roto 笔刷和调整遮罩
  9. 图层、标记和摄像机
    1. 选择和排列图层
    2. 混合模式和图层样式
    3. 3D 图层
    4. 图层属性
    5. 创建图层
    6. 管理图层
    7. 图层标记和合成标记
    8. 摄像机、光和目标点
  10. 动画、关键帧、运动跟踪和抠像
    1. 动画
      1. 动画基础知识
      2. 使用人偶工具制作动画
      3. 管理形状路径和蒙版并对其进行动画制作
      4. 使用 After Effects 为 Sketch 和 Capture 形状制作动画
      5. 分类动画工具
      6. 使用数据驱动的动画
    2. 关键帧
      1. 关键帧插值
      2. 设置、选择和删除关键帧
      3. 编辑、移动和复制关键帧
    3. 运动跟踪
      1. 跟踪和稳定运动
      2. 人脸跟踪
      3. 蒙版跟踪
      4. 蒙版引用
      5. 速度
      6. 时间拉伸和时间重映射
      7. 时间码和时间显示单位
    4. 抠像
      1. 抠像
      2. 抠像效果
  11. 透明度与合成
    1. 合成和透明度概述及资源
    2. Alpha 通道和遮罩
    3. 轨道遮罩和移动遮罩
  12. 调整颜色
    1. 颜色基础知识
    2. 色彩管理
    3. 颜色校正效果
    4. OpenColorIO 和 ACES 色彩管理
  13. 效果和动画预设
    1. 效果和动画预设概述
    2. 效果列表
    3. 效果管理器
    4. 模拟效果
    5. 风格化效果
    6. 音频效果
    7. 扭曲效果
    8. 透视效果
    9. 通道效果
    10. 生成效果
    11. 过渡效果
    12. 果冻效应修复效果
    13. 模糊和锐化效果
    14. 3D 通道效果
    15. 实用效果
    16. 遮罩效果
    17. 杂色和颗粒效果
    18. 保留细节放大效果
    19. 旧版效果
  14. 表达式和自动化
    1. 表达式
      1. 表达式基础知识
      2. 了解表达式语言
      3. 使用表达式控件
      4. JavaScript 与旧版 ExtendScript 表达式引擎之间的语法差别
      5. 正在编辑表达式
      6. 表达式错误
      7. 使用表达式编辑器
      8. 使用表达式编辑和访问文本属性
      9. 表达式语言引用
      10. 表达式示例
    2. 自动化
      1. 自动化
      2. 脚本
  15. 沉浸式视频、VR 和 3D
    1. 在 After Effects 中构造 VR 环境
    2. 应用沉浸式视频效果
    3. 用于 VR/360 视频的合成工具
    4. 高级 3D 渲染器
    5. 将 3D 模型导入并添加到合成中
    6. 从 Creative Cloud Libraries 导入3D 模型
    7. 基于图像的光照
    8. 从 3D 模型中提取光线和相机并为其制作动画
    9. 跟踪 3D 摄像机运动
    10. 投射和接受阴影
    11. 嵌入的 3D 模型动画
    12. 阴影捕手
    13. 3D 深度数据提取
    14. 修改 3D 图层的素材属性
    15. 使用 3D 设计空间
    16. 3D 变换 Gizmo
    17. 使用 3D 动画执行更多操作
    18. 使用 Mercury 3D 引擎实时预览对 3D 设计的更改
    19. 向图形添加响应式设计
  16. 视图和预览
    1. 预览
    2. 使用 Mercury Transmit 进行视频预览
    3. 修改和使用视图
  17. 渲染和导出
    1. 渲染和导出基础知识
    2. After Effects 中的 H.264 编码
    3. 将 After Effects 项目导出为 Adobe Premiere Pro 项目
    4. 转换影片
    5. 多帧渲染
    6. 自动渲染和网络渲染
    7. 渲染和导出静止图像及静止图像序列
    8. 在 After Effects 中使用 GoPro CineForm 编解码器
  18. 使用其他应用程序
    1. Dynamic Link 和 After Effects
    2. 使用 After Effects 和其他应用程序
    3. After Effects 中的同步设置
    4. After Effects 中的 Creative Cloud Libraries
    5. 增效工具
    6. Cinema 4D 和 Cineware
  19. 协作:Frame.io 和团队项目
    1. 在 Premiere Pro 和 After Effects 中协作
    2. Frame.io
      1. 安装和激活 Frame.io
      2. 将 Frame.io 与 Premiere Pro 和 After Effects 搭配使用
      3. 常见问题解答
    3. 团队项目
      1. 开始使用团队项目
      2. 创建团队项目
      3. 使用团队项目进行协作
  20. 内存、存储、性能
    1. 内存和存储
    2. After Effects 处理预览时内存不足问题的方式    
    3. 提高性能
    4. 首选项
    5. After Effects 的 GPU 和 GPU 驱动程序要求
  21. 知识库
    1. 已知问题
    2. 已修复的问题
    3. 常见问题解答
    4. After Effects 和 macOS Ventura
    5. After Effects 处理预览时内存不足问题的方式

关于矢量图形和位图

矢量图形由名为矢量的数学对象定义的直线和曲线组成,矢量根据图像的几何特征对图像进行描述。After Effects 中的矢量图形元素的示例包括蒙版路径、形状图层的形状和文本图层的文本。

位图使用图片元素(像素)的矩形网格来代表图像。每个像素都分配有特定的位置和颜色值。视频素材、从胶片传递的图像序列,以及导入到 After Effects 中的许多其他类型的图像是位图。

矢量图形维持清晰的边缘并在调整大小时不丢失细节,因为它们与分辨率不相关。此分辨率不相关性使得矢量图形成为视觉元素(如徽标)的良好选择,因为徽标将以各种尺寸使用。

不同放大级别的矢量图形示例
不同放大级别的矢量图形示例

每个位图都包含固定数量的像素,因此依赖于分辨率。如果放大位图,可能会丢失细节,并看起来呈锯齿状(像素化)。

不同放大级别的栅格图像示例
不同放大级别的位图示例

有些图像是在其他应用程序中作为矢量图形创建的,但在导入 After Effects 时被转换为像素(栅格化)。如果图层连续进行栅格化,After Effects 将在调整图层大小时,将矢量图形恢复为像素,并保留锐化边缘。SWF、PDF、EPS 以及 Illustrator 文件的矢量图形可连续进行栅格化。

关于路径

After Effects 的一些功能(其中包括蒙版、形状、绘画笔触以及运动路径)依赖于路径的概念。用于创建和编辑各种路径重叠的工具和技术,但每种路径都有各自独特的方面。

路径包括顶点。段是连接顶点的直线或曲线。顶点定义路径的各段开始和结束的位置。一些 Adobe 应用程序使用术语锚点路径点来指代顶点。

通过拖动路径顶点、每个顶点的方向线(或切线)末端的方向手柄,或路径段自身,更改路径的形状。

当路径退出顶点时,该顶点的传出方向线的角度和长度将决定路径。当路径接近下一顶点时,路径受前一顶点的传出方向线的影响较少,受下一顶点的传入方向线的影响较大。

路径组件
路径组件

A. 选定顶点 B. 选定顶点 C. 未选定顶点 D. 曲线路径段 E. 方向线(切线) F. 方向手柄 

路径可以有两类顶点:边角点和平滑点。在平滑点上,路径段被连接成一条光滑曲线;传入和传出方向线在同一直线上。在边角点上,路径突然更改方向;传入和传出方向线在不同直线上。您可以使用边角点和平滑点的任意组合绘制路径。如果您绘制的点类型有误,以后可以更改。

路径上的点
路径上的点

A. 四个角点 B. 四个平滑点 C. 角点和平滑点的组合 

在移动平滑点的方向线时,将同时调整该点两侧的曲线。相反,当移动边角点的方向线时,则只调整该点在方向线一侧的曲线。

调整平滑点上的方向线(左图)和角点上的方向线(右图)
调整平滑点上的方向线(左图)和边角点上的方向线(右图)

路径可以是开放的,也可以是闭合的。开放路径的开始点与结束点不一样;例如,直线是开放路径。封闭路径是连续的,并且没有开始或结束;例如,圆是封闭路径。

您可以通过形状工具采用普通几何形状(其中包括多边形、椭圆形和星形)绘制路径,或者可以使用钢笔工具来绘制任意路径。使用钢笔工具绘制的路径是手动贝塞尔曲线路径或旋转贝塞尔曲线路径。旋转贝塞尔曲线和手动贝塞尔曲线路径之间的主要差异在于,会自动计算旋转贝塞尔曲线路径的方向线,使得绘制路径更容易和快速。

在使用形状工具(矩形、圆角矩形、椭圆、多边形或星形)在形状图层上绘制形状路径时,您可以创建两种类型的路径:参数形状路径或贝塞尔曲线形状路径。(请参阅关于形状和形状图层。)

您可以使用表达式来链接蒙版路径、绘画描边路径和贝塞尔曲线形状路径。您还可以在蒙版路径、绘画描边路径、贝塞尔曲线形状路径、运动路径以及 Adobe Illustrator、Photoshop 和 Adobe Fireworks 路径之间复制和粘贴。(请参阅创建形状和蒙版。)

对于形状路径,您可以使用“合并路径”路径操作(类似于 Adobe Illustrator 中的路径查找器 (Pathfinder) 效果)将多个路径合并为一个路径。(请参阅合并路径选项。)

如果您想让文本或效果追随某个路径,该路径必须是蒙版路径。

路径自身在渲染的输出中没有视觉外观;它本质上是关于如何放置或修改其他视觉元素的信息集合。要使路径可视,应对其应用描边。如果是蒙版路径,可以应用“描边”效果。如果是形状图层对象的路径,默认是要使用“时间轴”面板中的路径属性组后的描边属性组(属性)创建的路径。

应用于路径所限制区域内的区域的颜色或渐变是填充

注意:

要为蒙版和形状指定贝塞尔曲线方向手柄和顶点的大小,请选择“编辑”>“首选项”>“常规”(Windows) 或“After Effects”>“首选项”>“常规”(Mac OS),然后编辑“路径点大小”值。

关于形状和形状图层

形状图层包含称为形状的矢量图形对象。默认情况下,形状包括路径、描边和填充。(请参阅关于路径形状的描边和填充。)

可以通过使用形状工具或钢笔工具在“合成”面板中进行绘制来创建形状图层。(请参阅创建形状和蒙版。)

形状路径有两种形式:参数形状路径和贝塞尔曲线形状路径。通过绘制后可以在“时间轴”面板中修改和进行动画制作的属性,用数值定义参数形状路径。由您可以在“合成”面板中修改的顶点(路径点)和段的集合定义贝塞尔曲线形状路径。按与使用蒙版路径相同的方式使用贝塞尔曲线形状路径。所有蒙版路径都是贝塞尔曲线路径。

您可以通过应用路径操作(如“摆动路径”和“收缩和膨胀”)修改形状路径。可以通过应用绘画操作将描边应用于路径,或者用颜色填充由路径定义的区域。(请参阅形状图层的形状属性、绘画操作和路径操作。)

形状的形状路径、绘画操作和路径操作统称为形状属性。使用“工具”面板或“时间轴”面板中的“添加”菜单添加形状属性。每个形状属性均表示为“时间轴”面板中的一个属性组,并具有您可以动画显示的属性,就像处理任何其他图层属性一样。(请参阅关于动画、关键帧和表达式。)

形状图层的色位深度与整个项目的位深度相同:8、16 或 32 bpc。(请参阅颜色深度和高动态范围颜色。)

形状图层并非基于素材项目。不基于素材项目的图层有时称为合成图层。文本图层也是合成图层,并也由矢量图形对象组成,因此适用于文本图层的许多规则和指南也适用于形状图层。例如,正如您无法在“图层”面板中打开文本图层一样,您也无法在“图层”面板中打开形状图层。

注意:

您可以将您最喜欢的形状保存为动画预设。(请参阅保存动画预设。)

形状图层的在线资源

有关从矢量图层创建形状图层的视频教程,请访问学习教程页面

Trish 和 Chris Meyer 在他们的书籍使用 After Effects 创建动态图形(第 5 版)的“形状图层”一章中的 PDF 摘要中,简要介绍了形状图层。

Chris Zwar 在他的网站上提供了动画预设,可使用一个形状图层创建目标十字,具有使控制和修改十字动画变得容易和明显的各种自定义属性。

形状及形状属性的组和渲染顺序

虽然形状默认由一个路径、一个描边和一个填充组成(在“时间轴”面板中从上到下排列),但是形状图层的大部分能力和灵活性来自您添加和重新排列形状属性以及创建更复杂的复合形状的能力。

您可以对单个形状图层内相同分组级别的形状或形状属性进行分组。

是形状属性的集合:路径、填充、描边、路径操作以及其他组。每个组都有各自的混合模式及一套各自的变换属性。通过将形状分为组,可以同时处理多个形状,例如将组中的所有形状缩放相同量,或将相同描边应用于每个形状。您甚至可以将各个形状或形状属性放置在其各自组内,以独立变换。例如,通过使某一路径单独成组,您可以在不缩放其描边的情况下缩放该路径。

在使用“工具”面板或“时间轴”面板中的“添加”菜单添加形状属性时,该属性会添加到选定的组内。可以通过拖动组和属性来在“时间轴”面板中对其重新排序。通过对形状和形状属性重新排序和分组,可以影响其相对于其他形状和形状属性的渲染顺序。

形状的组和渲染顺序及形状属性

A. 两个形状一组 B. 复合形状中的两个路径 C. 应用了摆动路径的圆形路径 D. 一个描边应用于它上方的所有路径 E. 单独分为一组的星形路径 F. 一个填充应用于它上方的所有路径 G. 一个路径带有两个描边 

形状图层中形状的渲染顺序

渲染形状图层的规则类似于渲染包含嵌套合成的合成的规则:

  • 在组内,首先渲染在“时间轴”面板堆积顺序底部的形状。

  • 组中的所有路径操作在绘画操作时之前执行。这意味着描边遵循由“摆动路径”路径操作造成的路径扭曲。组中的路径操作按从上到下的顺序执行。(请参阅使用路径操作改变形状。)

  • 组中的绘画操作按“时间轴”面板堆积顺序从下到上执行。这意味着,一个描边会在“时间轴”面板中后一个描边的上方(前方)进行渲染。要为特定填充或描边覆盖此默认行为,请在“时间轴面板中选择填充或描边的“合成”属性的“在同组中前一个之上”。(请参阅形状的描边和填充。)

路径操作和绘画操作适用于同一组中高于它们的所有路径。

变换形状组和形状路径的属性

每个组都有各自的变换属性组。此“变换”属性组在“时间轴”面板中用名为“变换”的属性组表示:[组名称],在“合成”面板中表示为具有手柄的虚线框。您可以对路径单独分组,并仅使用它的新“变换”属性组对路径进行变换。

为单个路径引入其他“变换”属性组非常有用,例如,创建复杂运动,如旋转约一个锚点,同时也沿着轨道绕转。组的变换影响该组内的所有形状;此行为与建立图层父子关系的行为相同。(请参阅父图层和子图层。)

同时,每个形状路径都有影响该路径的位置和形状的固有属性。对于参数形状路径,这些属性(如“位置”和“大小”)是显示在“时间轴”面板中的参数。对于贝塞尔曲线形状路径,对每个顶点定义这些属性,但其包含“路径”属性之中。在使用自由变换定界框修改贝塞尔曲线路径时,将会修改构成该路径的顶点的这些固有属性。(请参阅关于形状和形状图层。)

组合形状或形状属性

  1. 选择一个或多个形状或形状属性,并执行以下操作之一:
    • 选择“图层”>“蒙版和形状路径”>“组合形状”。
    • 按 Ctrl+G (Windows) 或 Command+G (Mac OS)。

在对形状进行分组时,组的锚点位于组的定界框中心。

取消组合形状或形状属性

  1. 选择一个组,并执行以下操作之一:
    • 选择“图层”>“蒙版和形状路径”>“取消组合形状”。
    • 按 Ctrl+Shift+G (Windows) 或 Command+Shift+G (Mac OS)。

创建空的形状组

  1. 从“工具”面板或“时间轴”面板的“添加”菜单中选择“组(空)”。

 Adobe

更快、更轻松地获得帮助

新用户?

Adobe MAX 2024

Adobe MAX
创意大会

10 月 14 日至 16 日迈阿密海滩及线上

Adobe MAX

创意大会

10 月 14 日至 16 日迈阿密海滩及线上

Adobe MAX 2024

Adobe MAX
创意大会

10 月 14 日至 16 日迈阿密海滩及线上

Adobe MAX

创意大会

10 月 14 日至 16 日迈阿密海滩及线上