用户指南 取消(C)

混合模式和图层样式

  1. After Effects 用户指南
  2. Beta 版
    1. Beta 版项目概述
    2. After Effects Beta 版主页
    3. Beta 版中的功能
      1. “属性”面板(Beta 版)
  3. 快速入门
    1. After Effects 快速入门
    2. After Effects 的新增功能 
    3. 发行说明 | After Effects
    4. After Effects 系统要求
    5. After Effects 中的键盘快捷键
    6. 支持的文件格式 | After Effects
    7. 硬件建议
    8. 适用于 Apple Silicon 的 After Effects
    9. 规划和设置
    10. 设置和安装
  4. 工作区
    1. 常规用户界面项
    2. 了解 After Effects 界面
    3. 工作流程
    4. 工作区、面板和查看器
  5. 项目与合成
    1. 项目
    2. 合成基础知识
    3. 预合成、嵌套和预渲染
    4. 使用合成分析器查看详细的性能信息
    5. CINEMA 4D 合成渲染器
  6. 导入素材
    1. 准备并导入静止图像
    2. 从 After Effects 和 Adobe Premiere Pro 导入
    3. 导入和解释视频与音频
    4. 准备和导入 3D 图像文件
    5. 导入和解释素材项目
    6. 使用素材项目
    7. 使用“场景编辑检测”检测编辑点
    8. XMP 元数据
  7. 文本和图形
    1. 文本
      1. 设置字符格式和“字符”面板
      2. 文本效果
      3. 创建和编辑文本图层
      4. 设置段落格式和“段落”面板
      5. 凸出文本和形状图层
      6. 为文本设置动画
      7. 文本动画的示例和资源
      8. 实时文本模板
    2. 动态图形
      1. 在 After Effects 中使用动态图形模板
      2. 使用表达式在动态图形模板中创建下拉列表
      3. 使用“基本属性”创建动态图形模板
      4. 替换动态图形模板和基本属性中的图像和视频
  8. 绘图、绘画和路径
    1. 形状图层、路径和矢量图形的概述
    2. 绘画工具:笔刷、仿制图章和橡皮擦
    3. 将形状描边椎体化的方法
    4. 形状图层的形状属性、绘画操作和路径操作
    5. 使用“位移路径”形状效果更改形状
    6. 创建形状
    7. 创建蒙版
    8. 使用内容识别填充面板,移除视频中的对象
    9. Roto 笔刷和调整遮罩
  9. 图层、标记和摄像机
    1. 选择和排列图层
    2. 混合模式和图层样式
    3. 3D 图层
    4. 图层属性
    5. 创建图层
    6. 管理图层
    7. 图层标记和合成标记
    8. 摄像机、光和目标点
  10. 动画、关键帧、运动跟踪和抠像
    1. 动画
      1. 动画基础知识
      2. 使用人偶工具制作动画
      3. 管理形状路径和蒙版并对其进行动画制作
      4. 使用 After Effects 为 Sketch 和 Capture 形状制作动画
      5. 分类动画工具
      6. 使用数据驱动的动画
    2. 关键帧
      1. 关键帧插值
      2. 设置、选择和删除关键帧
      3. 编辑、移动和复制关键帧
    3. 运动跟踪
      1. 跟踪和稳定运动
      2. 人脸跟踪
      3. 蒙版跟踪
      4. 蒙版引用
      5. 速度
      6. 时间拉伸和时间重映射
      7. 时间码和时间显示单位
    4. 抠像
      1. 抠像
      2. 抠像效果
  11. 透明度与合成
    1. 合成和透明度概述及资源
    2. Alpha 通道、蒙版和遮罩
  12. 调整颜色
    1. 颜色基础知识
    2. 使用 Adobe Color Themes 扩展
    3. 色彩管理
    4. 颜色校正效果
  13. 效果和动画预设
    1. 效果和动画预设概述
    2. 效果列表
    3. 模拟效果
    4. 风格化效果
    5. 音频效果
    6. 扭曲效果
    7. 透视效果
    8. 通道效果
    9. 生成效果
    10. 过渡效果
    11. 果冻效应修复效果
    12. 模糊和锐化效果
    13. 3D 通道效果
    14. 实用效果
    15. 遮罩效果
    16. 杂色和颗粒效果
    17. 保留细节放大效果
    18. 旧版效果
  14. 表达式和自动化
    1. 表达式
      1. 表达式基础知识
      2. 了解表达式语言
      3. 使用表达式控件
      4. JavaScript 与旧版 ExtendScript 表达式引擎之间的语法差别
      5. 正在编辑表达式
      6. 表达式错误
      7. 使用表达式编辑器
      8. 使用表达式编辑和访问文本属性
      9. 表达式语言引用
      10. 表达式示例
    2. 自动化
      1. 自动化
      2. 脚本
  15. 沉浸式视频、VR 和 3D
    1. 在 After Effects 中构造 VR 环境
    2. 应用沉浸式视频效果
    3. 用于 VR/360 视频的合成工具
    4. 跟踪 3D 摄像机运动
    5. 使用 3D 设计空间
    6. 3D 变换 Gizmo
    7. 使用 3D 动画执行更多操作
    8. 使用实时引擎实时预览对 3D 设计的更改
    9. 向图形添加响应式设计 
  16. 视图和预览
    1. 预览
    2. 使用 Mercury Transmit 进行视频预览
    3. 修改和使用视图
  17. 渲染和导出
    1. 渲染和导出基础知识
    2. 将 After Effects 项目导出为 Adobe Premiere Pro 项目
    3. 转换影片
    4. 多帧渲染
    5. 自动渲染和网络渲染
    6. 渲染和导出静止图像及静止图像序列
    7. 在 After Effects 中使用 GoPro CineForm 编解码器
  18. 使用其他应用程序
    1. Dynamic Link 和 After Effects
    2. 使用 After Effects 和其他应用程序
    3. After Effects 中的同步设置
    4. After Effects 中的 Creative Cloud Libraries
    5. 增效工具
    6. CINEMA 4D 和 Cineware
  19. 协作:Frame.io 和团队项目
    1. 在 Premiere Pro 和 After Effects 中协作
    2. Frame.io
      1. 安装和激活 Frame.io
      2. 将 Frame.io 与 Premiere Pro 和 After Effects 配合使用
      3. 常见问题解答
    3. 团队项目
      1. 开始使用团队项目
      2. 创建团队项目
      3. 使用团队项目进行协作
  20. 内存、存储、性能
    1. 内存和存储
    2. 提高性能
    3. 首选项
    4. After Effects 的 GPU 和 GPU 驱动程序要求

使用图层混合模式

图层的混合模式控制每个图层如何与它下面的图层混合或交互。After Effects 中的图层的混合模式(以前称为图层模式,有时称为传递模式)与 Adobe Photoshop 中的混合模式相同。

大多数混合模式仅修改源图层的颜色值,而非 Alpha 通道。“Alpha 添加”混合模式影响源图层的 Alpha 通道,而轮廓和模板混合模式影响它们下面的图层的 Alpha 通道。

您无法通过使用关键帧来直接为混合模式制作动画。要在某一特定时间更改混合模式,请在该时间拆分图层,并将新混合模式应用于图层的延续部分。您也可以使用“复合运算”效果,其结果类似于混合模式的结果,但可以随着时间的推移而更改。

每个图层均具有混合模式,即使该混合模式是默认的“常规”混合模式。

注意:

要使用灰度系数值 1 混合颜色,请选择“文件”>“项目设置”,然后选择“使用 1.0 灰度系数混合颜色”。取消选择该选项可在项目的工作颜色空间中混合颜色。(请参阅线性化工作区和启用线性混合。)

单个图层上多个蒙版的混合模式称为蒙版模式

一些效果包括其自己的混合模式选项。有关详细信息,请参阅各种效果的说明。

  • 要循环查看所选图层的混合模式,请按住 Shift 键并按主键盘上的 -(连字符)或 =(等号)。
注意:

这些快捷方式提供了体验各种混合模式的外观的便捷方式。

  • 要将混合模式应用于所选图层,请从“时间轴”面板中“模式”列中的菜单中,或从“图层”>“混合模式”菜单中选择混合模式。
  • 要显示“时间轴”面板中的“模式”列,请从该面板菜单中选择“列”>“模式”,或单击“时间轴”面板左下角的“展开或折叠‘转换控制’”按钮

Trish 和 Chris Meyer 在 Artbeats 网站上的此 PDF 文档中提供了有关使用混合模式实现影片外观的提示和技巧。

Trish 和 Chris Meyer 在 Artbeats 网站的一篇名为《Writing on the Wall》的 PDF 文章中说明了如何使用混合模式、图层样式和置换图效果使文本混入特定表面,使文本看起来像该表面的一部分。

混合模式参考

以下说明使用这些术语:

  • 源颜色是应用混合模式的图层或画笔的颜色。
  • 基础颜色是“时间轴”面板中图层堆积顺序中源图层或画笔下面的合成图层的颜色。
  • 结果颜色是混合操作的输出;合成的颜色。

本节中介绍的所有混合模式都可用于图层之间的混合。其中一些选项可用于画笔、图层样式和效果。

有关某些 Adobe 应用程序中实施的这些混合模式背后的概念和算法的深入信息,请参阅 Adobe 网站上的 PDF 参考 1.7 版的第 7.2.4 节。

根据混合模式结果之间的相似性,混合模式菜单细分为八个类别。类别名称不显示在界面中;类别只是通过菜单中的分隔线来分隔。

“正常”类别

选项包括:正常、溶解、动态抖动溶解。除非不透明度小于源图层的 100%,否则像素的结果颜色不受基础像素的颜色影响。“溶解”混合模式使源图层的一些像素变成透明的。

“减少”类别

选项包括:变暗、相乘、颜色加深、经典颜色加深、线性加深、深色。这些混合模式往往会使颜色变暗,其中一些混合颜色的方式与在绘画中混合彩色颜料的方式大致相同。

“添加”类别

选项包括:相加、变亮、滤色、颜色减淡、经典颜色减淡、线性减淡、浅色。这些混合模式往往会使颜色变亮,其中一些混合颜色的方式与混合投影光的方式大致相同。

“复杂”类别

选项包括:叠加、柔光、强光、线性光、亮光、点光、实色混合。这些混合模式对源和基础颜色执行不同的操作,具体取决于颜色之一是否比 50% 灰色浅。

“差异”类别

选项包括:差值、经典差值、排除、相减、相除。这些混合模式基于源颜色和基础颜色值之间的差异创建颜色。

“HSL”类别

选项包括:色相、饱和度、颜色、明度。这些混合模式将颜色的 HSL 表示形式的一个或多个组件(色相、饱和度和发光度)从基础颜色传递到结果颜色。

“遮罩”类别

选项包括:模板 Alpha、模板亮度、轮廓 Alpha、轮廓亮度。这些混合模式实质上将源图层转换为所有基础图层的遮罩。

模板和轮廓混合模式使用图层的 Alpha 通道或亮度值来影响该图层下面的所有图层的 Alpha 通道。使用这些混合模式不同于使用轨道遮罩,后者仅影响一个图层。模板模式断开所有图层,以便您可以通过模板图层的 Alpha 通道显示多个图层。轮廓模式封闭图层下面应用了混合模式的所有图层,以便您可以同时在多个图层中剪切一个洞。要阻止轮廓和模板混合模式断开或封闭下面的所有图层,请预合成要影响的图层并将它们嵌套在您的合成中。

模板(左图)通过模板图层的 Alpha 通道的帧显示模板图层下面的所有图层;轮廓(右)在轮廓图层下面的所有图层中剪切了一个洞。

“实用工具”类别

选项为“Alpha 添加”和“冷光预乘”。这些混合模式用于专门的实用工具函数。

混合模式说明

注意:

下面说明中的一些颜色值是根据从黑色到白色的 0.0-1.0 比例提供的。

正常

结果颜色是源颜色。此模式忽略基础颜色。“正常”是默认模式。

溶解

每个像素的结果颜色是源颜色或基础颜色。结果颜色是源颜色的概率取决于源的不透明度。如果源的不透明度是 100%,则结果颜色是源颜色。如果源的不透明度是 0%,则结果颜色是基础颜色。“溶解”和“动态抖动溶解”对 3D 图层不起作用。

动态抖动溶解

除了为每个帧重新计算概率函数外,与“溶解”相同,因此结果随时间而变化。

变暗

每个结果颜色通道值是源颜色通道值和相应的基础颜色通道值中的较低者(较深者)。

相乘

对于每个颜色通道,将源颜色通道值与基础颜色通道值相乘,再除以 8-bpc、16-bpc 或 32-bpc 像素的最大值,具体取决于项目的颜色深度。结果颜色决不会比原始颜色明亮。如果任一输入颜色是黑色,则结果颜色是黑色。如果任一输入颜色是白色,则结果颜色是其他输入颜色。此混合模式模拟在纸上用多个记号笔绘图或将多个彩色透明滤光板置于光照前面。在与除黑色或白色之外的颜色混合时,具有此混合模式的每个图层或画笔将生成深色。

颜色加深

结果颜色是源颜色变暗,以通过增加对比度来反映基础图层颜色。原始图层中的纯白色不会更改基础颜色。

经典颜色加深

After Effects 5.0 和更低版本中的“颜色加深”模式已重命名为“经典颜色加深”。使用它可保持与早期项目的兼容性;也可使用“颜色加深”。

线性加深

结果颜色是源颜色变暗以反映基础颜色。纯白色不会生成任何变化。

较深的颜色

每个结果像素是源颜色值和相应的基础颜色值中的较深颜色。“深色”类似于“变暗”,但是“深色”不对各个颜色通道执行操作。

相加

每个结果颜色通道值是源颜色和基础颜色的相应颜色通道值的和。结果颜色绝不会比任一输入颜色深。

变亮

每个结果颜色通道值是源颜色通道值和相应的基础颜色通道值中的较高者(较亮者)。

滤色

乘以通道值的补色,然后获取结果的补色。结果颜色绝不会比任一输入颜色深。使用“滤色”模式类似于同时将多个照片幻灯片投影到单个屏幕上。

颜色减淡

结果颜色是源颜色变亮,以通过减小对比度来反映基础图层颜色。如果源颜色是纯黑色,则结果颜色是基础颜色。

经典颜色减淡

After Effects 5.0 和更低版本中的“颜色减淡”模式已重命名为“经典颜色减淡”。使用它可保持与早期项目的兼容性;也可使用“颜色减淡”。

线性减淡

结果颜色是源颜色变亮,以通过增加亮度来反映基础颜色。如果源颜色是纯黑色,则结果颜色是基础颜色。

浅色

每个结果像素是源颜色值和相应的基础颜色值中的较亮颜色。“浅色”类似于“变亮”,但是“浅色”不对各个颜色通道执行操作。

叠加

将输入颜色通道值相乘或对其进行滤色,具体取决于基础颜色是否比 50% 灰色浅。结果保留基础图层中的高光和阴影。

柔光

使基础图层的颜色通道值变暗或变亮,具体取决于源颜色。结果类似于漫射聚光灯照在基础图层上。对于每个颜色通道值,如果源颜色比 50% 灰色浅,则结果颜色比基础颜色浅,就好像减淡一样。如果源颜色比 50% 灰色深,则结果颜色比基础颜色深,就好像加深一样。具有纯黑色或白色的图层明显变暗或变亮,但是没有变成纯黑色或白色。

强光

将输入颜色通道值相乘或对其进行滤色,具体取决于原始源颜色。结果类似于耀眼的聚光灯照在图层上。对于每个颜色通道值,如果基础颜色比 50% 灰色浅,则图层变亮,就好像被滤色一样。如果基础颜色比 50% 灰色深,则图层变暗,就好像被相乘一样。此模式用于在图层上创建阴影外观。

线性光

通过减小或增加亮度来加深或减淡颜色,具体取决于基础颜色。如果基础颜色比 50% 灰色浅,则图层变亮,因为亮度增加。如果基础颜色比 50% 灰色深,则图层变暗,因为亮度减小。

亮光

通过增加或减小对比度来加深或减淡颜色,具体取决于基础颜色。如果基础颜色比 50% 灰色浅,则图层变亮,因为对比度减小。如果基础颜色比 50% 灰色深,则图层变暗,因为对比度增加。

点光

根据基础颜色替换颜色。如果基础颜色比 50% 灰色浅,则替换比基础颜色深的像素,而不改变比基础颜色浅的像素。如果基础颜色比 50% 灰色深,则替换比基础颜色浅的像素,而不改变比基础颜色深的像素。

纯色混合

提高源图层上蒙版下面的可见基础图层的对比度。蒙版大小确定对比区域;反转的源图层确定对比区域的中心。

差值

对于每个颜色通道,从浅色输入值中减去深色输入值。使用白色绘画会反转背景颜色;使用黑色绘画不会生成任何变化。

注意:

如果要对齐两个图层中的相同视觉元素,请将一个图层放置在另一个图层上面,并将顶端图层的混合模式设置为“差值”。然后,您可以移动一个图层或另一个图层,直到要排列的视觉元素的像素都是黑色,这意味着像素之间的差值是零,因此一个元素完全堆积在另一个元素上面。

经典差值

After Effects 5.0 和更低版本中的“差值”模式已重命名为“经典差值”。使用它可保持与早期项目的兼容性;也可使用“差值”。

排除

创建与“差值”模式相似但对比度更低的结果。如果源颜色是白色,则结果颜色是基础颜色的补色。如果源颜色是黑色,则结果颜色是基础颜色。

相减

从基础颜色中减去源颜色。如果源颜色是黑色,则结果颜色是基础颜色。在 32-bpc 项目中,结果颜色值可以小于 0。

相除

基础颜色除以源颜色。如果源颜色是白色,则结果颜色是基础颜色。在 32-bpc 项目中,结果颜色值可以大于 1.0。

色相

结果颜色具有基础颜色的发光度和饱和度以及源颜色的色相。

饱和度

结果颜色具有基础颜色的发光度和色相以及源颜色的饱和度。

颜色

结果颜色具有基础颜色的发光度以及源颜色的色相和饱和度。此混合模式保持基础颜色中的灰色阶。此混合模式用于为灰度图像上色和为彩色图像着色。

发光度

结果颜色具有基础颜色的色相和饱和度以及源颜色的发光度。此模式与“颜色”模式相反。

模板 Alpha

使用图层的 Alpha 通道创建模板。

模板亮度

使用图层的亮度值创建模板。图层的浅色像素比深色像素更不透明。

轮廓 Alpha

使用图层的 Alpha 通道创建轮廓。

轮廓亮度

使用图层的亮度值创建轮廓。在图层的绘画区域中创建透明度,从而允许您查看基础图层或背景。混合颜色的亮度值确定结果颜色中的不透明度。源的浅色像素导致比深色像素更透明。使用纯白色绘画会创建 0% 不透明度。使用纯黑色绘画不会生成任何变化。

Alpha 添加

通常合成图层,但添加色彩互补的 Alpha 通道来创建无缝的透明区域。用于从两个相互反转的 Alpha 通道或从两个接触的动画图层的 Alpha 通道边缘删除可见边缘。

注意:

有时,在图层边对边对齐时,图层之间会出现接缝。这尤其是在边缘处相互连接以生成 3D 对象的 3D 图层的问题。在图层的边缘消除锯齿时,边缘具有某种部分透明度。在两个 50% 透明区域重叠时,结果不是 100% 不透明,而是 75% 不透明,因为默认操作是乘法。(光照的 50% 通过一个图层,然后剩余光照的 50% 通过下一个图层,因此 25% 通过系统。)这类似于现实世界中的部分透明度。但是,在某些情况下,您不需要此默认混合。您希望两个 50% 不透明区域组合以进行无缝的不透明连接。您希望添加 Alpha 值。在这些情况下,可使用“Alpha 添加”混合模式。

冷光预乘

在合成之后,通过将超过 Alpha 通道值的颜色值添加到合成中来防止修剪这些颜色值。用于使用预乘 Alpha 通道从素材合成渲染镜头或光照效果(例如镜头光晕)。在从其他制造商提供的修边软件合成素材时,也可以改善结果。在应用此模式时,您可以通过将预乘 Alpha 源素材的解释更改为直接 Alpha 来获得最佳结果。

图层样式

Photoshop 提供了各种图层样式(例如阴影、发光和斜面)来更改图层的外观。在导入 Photoshop 图层时,After Effects 可以保留这些图层样式。您也可以在 After Effects 中应用图层样式并为其属性制作动画。

注意:

您可以在 After Effects 中复制并粘贴任何图层样式,包括以 PSD 文件形式导入 After Effects 中的图层样式。

除了添加视觉元素的图层样式(例如投影或颜色叠加)之外,每个图层的“图层样式”属性组还包含“混合选项”属性组。您可以使用“混合选项”设置来实现对混合操作的强大而灵活的控制。

虽然图层样式在 Photoshop 中称为效果,但它们的行为更像 After Effects 中的混合模式。图层样式在标准渲染顺序中位于变换之后,而效果位于变换之前。另一个区别是每个图层样式直接与合成中的基础图层混合,而效果在它所应用于的图层上渲染,然后其结果作为一个整体与基础图层交互。

在导入包括图层的 Photoshop 文件作为合成时,您可以保留可编辑图层样式或将图层样式合并到素材中。在您仅导入一个包括图层样式的图层时,您可以选择忽略图层样式或将图层样式合并到素材中。您可以随时将合并的图层样式转换为基于 Photoshop 素材项目的每个 After Effects 图层的可编辑图层样式。

After Effects 可以保留导入的 Photoshop 文件中的所有图层样式,但您只能在 After Effects 中添加和修改一些图层样式和控制。

注意:

有关各个图层样式及其属性的详细信息,请参阅Photoshop 帮助

您可以在 After Effects 中应用和编辑的图层样式

投影

添加落在图层后面的阴影。

内阴影

添加落在图层内容中的阴影,从而使图层具有凹陷外观。

外发光

添加从图层内容向外发出的光线。

内发光

添加从图层内容向里发出的光线。

斜面和浮雕

添加高光和阴影的各种组合。

注意:

例如,如果您要对斜面的高光和阴影应用不同的混合模式,请使用“斜面和浮雕”图层样式而非“斜面 Alpha”效果。

光泽

应用创建光滑光泽的内部阴影。

颜色叠加

使用颜色填充图层的内容。

渐变叠加

使用渐变填充图层的内容。

描边

描画图层内容的轮廓。

添加、删除和转换图层样式

  • 要将合并的图层样式转换为可编辑图层样式,请选择一个或多个图层,然后选择“图层”>“图层样式”>“转换为可编辑样式”。
  • 要将图层样式添加到所选图层中,请选择“图层”>“图层样式”,然后从菜单中选择图层样式。
  • 要删除图层样式,请在“时间轴”面板中选择它,然后按 Delete 键。
  • 要删除所选图层中的所有图层样式,请选择“图层”>“图层样式”>“全部移除”。

在将图层样式应用于矢量图层(例如文本图层、形状图层或基于 Illustrator 素材项目的图层)时,应用于图层的内容边缘的视觉元素将应用于矢量对象(例如文本字符或形状)的轮廓。在将图层样式应用于基于非矢量素材项目的图层时,该图层样式将应用于图层的范围或蒙版的边缘。

您可以将图层样式应用于 3D 图层,但具有图层样式的图层无法与其他 3D 图层相交或与其他 3D 图层交互以投射和接收阴影。具有图层样式的图层的任一侧的 3D 图层无法相交或在其他图层上投影。

在您对 Photoshop 文件中的文本图层使用“图层”>“转换为可编辑文本”命令时,该图层上的任何图层样式也会转换为可编辑图层样式。

图层样式设置

每个图层样式均在“时间轴”面板中具有自己的属性集合。

与图层对齐

使用图层的定界框来计算渐变填充。

高度

对于“斜面和浮雕”图层样式,指定图层上方光源的高度,以度为单位。

阻塞

在模糊之前收缩“内阴影”或“内发光”的遮罩边界。

距离

指定“阴影”或“光泽”图层样式的偏移距离。

高光模式,阴影模式

指定斜面或浮雕高光或阴影的混合模式。

抖动

改变渐变的颜色和不透明度的应用,以减少光带条纹。

图层镂空投影

控制半透明图层中投影的可见性。

反向

翻转渐变的方向。

缩放

调整渐变大小。

扩展

在模糊之前扩大遮罩边界。

使用全局光

将此选项设置为“打开”以对每个单独图层样式使用“混合选项”属性组中的“全局光角度”和“全局光高度”,而非“角度”和“高度”设置。如果您将多个图层样式应用于同一图层,并且要对所有这些样式的光照位置进行动画制作,则此选项很有用。

图层样式的混合选项

每个图层样式均具有自己的混合模式,这决定它与基础图层交互的方式。此上下文中的基础图层可能包括或不包括图层样式应用于的图层。例如,投影不与它应用于的图层混合,因为阴影落在图层后面;而内阴影确实与它应用于的图层混合。

图层样式可以分类为内部图层样式或外部图层样式。内部图层样式影响它们应用于的图层的不透明像素。内部图层样式包括“内发光”、“内阴影”、“颜色叠加”、“渐变叠加”、“光泽”以及“斜面和浮雕”。外部图层样式不与它们应用于的图层的像素混合,而仅与基础图层交互。外部图层样式包括“外发光”和“投影”。

如果将“混合内部样式为组”设置为“打开”,则内部图层样式使用图层的混合模式。

如果修改图层的“不透明度”属性,则图层内容的不透明度和图层样式的不透明度都会受影响。不过,如果您修改“混合选项”属性组中的“填充不透明度”属性,则图层样式的不透明度不受影响。例如,如果文本图层应用了“投影”图层样式,则将“填充不透明度”减小到 0 会使文本消失,但投影始终可见。

通过“源的混合范围”选项可使用为 Photoshop 文件设置的高级混合选项,这些选项根据输入图层的颜色特性确定要执行何种混合操作。

有关图层样式的在线资源

Dave Scotland 在 CG Swot 网站上提供了一个视频教程,其中演示了如何在 After Effects 中使用图层样式创建有金属纹理的徽标

在含有基础图像的“合成”、“图层”和“素材”面板中混合快照

使用“经典差值”混合模式,可在含有基础图像的“合成”“图层”“素材”面板中混合快照。要混合快照,请在单击“显示快照”按钮的同时按住 Option(macOS) 键或 Alt(Windows) 键。

从混合中排除通道

您可以从混合操作中排除图层的一个或多个颜色通道。

注意:

仅为其中添加了图层样式的图层包括“混合选项”属性组。要添加“混合选项”属性组而不添加图层样式,请添加任意图层样式,然后立即删除它;“混合选项”属性组及其包含的“图层样式”属性组将保留。

  1. 在“时间轴”面板中的“图层样式”属性组中扩展图层的“混合选项”属性组。
  2. 要从混合中排除通道,请在“高级混合”属性组中将“红色”、“绿色”或“蓝色”设置为“关闭”。

    您可以为这些属性制作动画,以便可以在一些时间从混合中排除某通道,但在其他时间包括该通道。

Adobe 徽标

登录到您的帐户