将 Sketch 和 Capture 中的形状转换为 Illustrator 文件,并使用 After Effects 制作动画

无论何时何地,只要有了灵感,就可利用 Adobe Sketch 和 Adobe Capture(以前称为“Adobe Shape CC”)移动应用创作图稿。使用这些应用,可创建能够直接导入 After Effects 或发送到 Illustrator 或 Photoshop 的形状,以便进一步编辑或最后调整。然后可以在 Adobe After Effects 合成中使用这些形状。

形状图层包含称为形状的矢量图形对象。默认情况下,形状包括路径、描边和填充。(请参阅关于路径形状的描边和填充。)

您可以将形状导入 After Effects,或通过在“合成”面板中用形状工具或钢笔工具绘制来创建形状图层。(请参阅创建形状和蒙版。)

在 Sketch 中创建形状

  1. 在 iPhone、iPad 或 iPad Pro 中打开 Adobe Photoshop Sketch,然后使用 Adobe ID 登录。

  2. 点击 + 开始新项目,点击空白画布开始新草图。

    sketch-layer-1
  3. 要将 Stock 图像用作图稿背景,请点击“图像”图标,然后在“图像”菜单中选择 Adobe Stock

    sketch-image-source-1
  4. 如果要将图像用作描摹参考,请使用堆积图标将图像放在图稿下方并降低不透明度,然后在方框外单击以应用更改。

  5. 使用内置笔刷、形状、颜色工具和透视绘制草图。

    sketch-draw-with-brush-1
  6. 将形状保存到集合中适合的 Creative Cloud Library 中,或使用“发送至 Photoshop”或“发送至 Illustrator”选项,将形状转换为图层矢量图像。

    sketch-publish-to-lib-1

    要了解有关使用 Adobe Sketch 的更多信息,请观看教程在 Adobe Photoshop Sketch 中绘制和共享概念

在 Capture 中创建形状

  1. 在 iPhone、iPad 或 iPad Pro 中打开 Adobe Capture,然后使用 Adobe ID 登录。

  2. 点击“形状”菜单选项,然后点击 + 图标。 

  3. 将摄像机对准对象,使用滑块添加细节或从图像中移除细节。点击屏幕并尝试使用这些选项,以查看哪种选项为您提供最好的效果。

    Capture-point-camera-1
  4. 点击“捕捉”按钮以进行捕捉。

  5. 点击“取消全选”并将指针拖动到要移除的形状部分的上方。

    capture- preview-1
  6. 完成操作并让“捕捉”绘制组成形状的平滑轮廓后,点击“下一步”

  7. 审核绘图,然后点击“下一步”并为形状输入名称。

  8. 在“Creative Cloud Library”面板中选择适合的库,然后点击“保存形状”

    要了解关于 Capture 的信息,请参阅 Adobe Capture 常见问题解答

有关更多信息,请参阅准备和导入 Illustrator 文件

将形状导入 After Effects 并制作为 2D 或 3D 动画

您可以直接从移动应用程序中将形状导入为本地文件或保存在 CC Library 中的资源。如果已从移动应用程序中发送它们,还可以将它们导入为 Photoshop 或 Illustrator 文件,以便做出进一步的更改。 

例如,要倾斜和凸出矢量,请从矢量插画素材图层创建一个形状图层,然后修改该形状图层。将矢量图层转换为形状图层之后,可以倾斜和凸出。凸出的对象是显示为三维的对象。当移动对象时或者围绕对象移动摄像机时,3D 外观最明显。斜面是对凸出的对象的边缘的控制。

在下面的步骤中,您可以了解如何着手将形状制作为 2D 和 3D 动画:

  1. 要导入 PNG 格式的矢量文件或形状,或者导入为 Illustrator 或 Photoshop 文件,请将图形拖放到合成中,或者选择“文件”>“导入”>“文件”,选择文件并单击“导入”

  2. 如果已导入分层的矢量图形文件,请右键单击矢量图层并从“矢量图层”中选择“创建形状”。After Effects 将矢量图层转换为可以制作动画的形状图层。

    AE-import
  3. 要用导入的形状创建简单的动画,请展开图层和图层下方的“变换”选项。例如,若要旋转形状,可执行以下操作:

    1. 将形状拖放到合成中。After Effects 会创建一个新的形状图层。
    2. 将当前时间指示器移动到要完成旋转的位置。
    3. 按 R 键,“旋转”属性将显示在形状图层的下方。
    4. 单击秒表图标启用旋转。
    5. 通过单击“旋转”属性左侧的关键帧图标,可在目标点插入关键帧。
    6. 在合成中旋转形状或在“旋转”属性中更改要让形状旋转的次数和旋转角度。 
    7. 依次选择“合成”>“预览”>“播放当前预览”
    animate-shape-rotate
  4. 选择“合成”>“合成设置”将合成转换为供动画制作使用的光线追踪 3D 合成。

  5. 在“3D 渲染器”选项卡中,将渲染器选为光线追踪 3D。现在,您的合成已成为支持凸出文本和形状的光线追踪 3D 合成。

    raytraced-3d
  6. 要将形状图层转换为 3D 图层,请执行以下操作之一:

    • 要将图层转换为 3D 图层,请在“时间轴”面板中选择用于图层的“3D 图层”开关,或者选择该图层,然后选择“图层”>“3D 图层”
    • 要将文本图层转换为启用了逐字符 3D 属性的 3D 图层,请选择“动画”>“为文本制作动画”>“启用逐字符 3D”
  7. 从 After Effects 提供的各种 3D 动画工具中选择一项或多项。例如:

    • 要在“时间轴”面板中旋转或标定 3D 图层的方向,请选择该 3D 图层,然后在“时间轴”面板中修改“旋转”或“方向”属性值。按下 R 键可显示“旋转”和“方向”属性。 
    • 要移动 3D 图层,请在“合成”面板中使用“选择”工具拖动 3D 轴图层控件的箭头,该箭头对应于您要沿其移动图层的轴,然后按住 Shift 键并拖动,以便更快地移动图层。还可以通过在“时间轴”面板中修改“位置”属性来做到这一点。要了解有关制作 3D 图层动画的更多信息,请参阅制作 3D 图层动画
    • 要用各种观看角度和距离制作 3D 图层动画,就像通过一台或多台摄像机观看一样,请使用摄像机选项。选择“图层”>“新建”>“摄像机”,或按 Ctrl+Alt+Shift+C (Windows) 或 Command+Option+Shift+C (Mac OS)。将当前时间指示器移动到目标时间,插入关键帧,然后移动形状。要了解更多信息,请参阅摄像机、光和目标点

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略