用户指南 取消(C)

导入和解释视频与音频

  1. After Effects 用户指南
  2. Beta 版
    1. Beta 版项目概述
    2. After Effects Beta 版主页
    3. Beta 版中的功能
      1. “属性”面板(Beta 版)
  3. 快速入门
    1. After Effects 快速入门
    2. After Effects 的新增功能 
    3. 发行说明 | After Effects
    4. After Effects 系统要求
    5. After Effects 中的键盘快捷键
    6. 支持的文件格式 | After Effects
    7. 硬件建议
    8. 适用于 Apple Silicon 的 After Effects
    9. 规划和设置
    10. 设置和安装
  4. 工作区
    1. 常规用户界面项
    2. 了解 After Effects 界面
    3. 工作流程
    4. 工作区、面板和查看器
  5. 项目与合成
    1. 项目
    2. 合成基础知识
    3. 预合成、嵌套和预渲染
    4. 使用合成分析器查看详细的性能信息
    5. CINEMA 4D 合成渲染器
  6. 导入素材
    1. 准备并导入静止图像
    2. 从 After Effects 和 Adobe Premiere Pro 导入
    3. 导入和解释视频与音频
    4. 准备和导入 3D 图像文件
    5. 导入和解释素材项目
    6. 使用素材项目
    7. 使用“场景编辑检测”检测编辑点
    8. XMP 元数据
  7. 文本和图形
    1. 文本
      1. 设置字符格式和“字符”面板
      2. 文本效果
      3. 创建和编辑文本图层
      4. 设置段落格式和“段落”面板
      5. 凸出文本和形状图层
      6. 为文本设置动画
      7. 文本动画的示例和资源
      8. 实时文本模板
    2. 动态图形
      1. 在 After Effects 中使用动态图形模板
      2. 使用表达式在动态图形模板中创建下拉列表
      3. 使用“基本属性”创建动态图形模板
      4. 替换动态图形模板和基本属性中的图像和视频
  8. 绘图、绘画和路径
    1. 形状图层、路径和矢量图形的概述
    2. 绘画工具:笔刷、仿制图章和橡皮擦
    3. 将形状描边椎体化的方法
    4. 形状图层的形状属性、绘画操作和路径操作
    5. 使用“位移路径”形状效果更改形状
    6. 创建形状
    7. 创建蒙版
    8. 使用内容识别填充面板,移除视频中的对象
    9. Roto 笔刷和调整遮罩
  9. 图层、标记和摄像机
    1. 选择和排列图层
    2. 混合模式和图层样式
    3. 3D 图层
    4. 图层属性
    5. 创建图层
    6. 管理图层
    7. 图层标记和合成标记
    8. 摄像机、光和目标点
  10. 动画、关键帧、运动跟踪和抠像
    1. 动画
      1. 动画基础知识
      2. 使用人偶工具制作动画
      3. 管理形状路径和蒙版并对其进行动画制作
      4. 使用 After Effects 为 Sketch 和 Capture 形状制作动画
      5. 分类动画工具
      6. 使用数据驱动的动画
    2. 关键帧
      1. 关键帧插值
      2. 设置、选择和删除关键帧
      3. 编辑、移动和复制关键帧
    3. 运动跟踪
      1. 跟踪和稳定运动
      2. 人脸跟踪
      3. 蒙版跟踪
      4. 蒙版引用
      5. 速度
      6. 时间拉伸和时间重映射
      7. 时间码和时间显示单位
    4. 抠像
      1. 抠像
      2. 抠像效果
  11. 透明度与合成
    1. 合成和透明度概述及资源
    2. Alpha 通道、蒙版和遮罩
  12. 调整颜色
    1. 颜色基础知识
    2. 使用 Adobe Color Themes 扩展
    3. 色彩管理
    4. 颜色校正效果
  13. 效果和动画预设
    1. 效果和动画预设概述
    2. 效果列表
    3. 模拟效果
    4. 风格化效果
    5. 音频效果
    6. 扭曲效果
    7. 透视效果
    8. 通道效果
    9. 生成效果
    10. 过渡效果
    11. 果冻效应修复效果
    12. 模糊和锐化效果
    13. 3D 通道效果
    14. 实用效果
    15. 遮罩效果
    16. 杂色和颗粒效果
    17. 保留细节放大效果
    18. 旧版效果
  14. 表达式和自动化
    1. 表达式
      1. 表达式基础知识
      2. 了解表达式语言
      3. 使用表达式控件
      4. JavaScript 与旧版 ExtendScript 表达式引擎之间的语法差别
      5. 正在编辑表达式
      6. 表达式错误
      7. 使用表达式编辑器
      8. 使用表达式编辑和访问文本属性
      9. 表达式语言引用
      10. 表达式示例
    2. 自动化
      1. 自动化
      2. 脚本
  15. 沉浸式视频、VR 和 3D
    1. 在 After Effects 中构造 VR 环境
    2. 应用沉浸式视频效果
    3. 用于 VR/360 视频的合成工具
    4. 跟踪 3D 摄像机运动
    5. 使用 3D 设计空间
    6. 3D 变换 Gizmo
    7. 使用 3D 动画执行更多操作
    8. 使用实时引擎实时预览对 3D 设计的更改
    9. 向图形添加响应式设计 
  16. 视图和预览
    1. 预览
    2. 使用 Mercury Transmit 进行视频预览
    3. 修改和使用视图
  17. 渲染和导出
    1. 渲染和导出基础知识
    2. 将 After Effects 项目导出为 Adobe Premiere Pro 项目
    3. 转换影片
    4. 多帧渲染
    5. 自动渲染和网络渲染
    6. 渲染和导出静止图像及静止图像序列
    7. 在 After Effects 中使用 GoPro CineForm 编解码器
  18. 使用其他应用程序
    1. Dynamic Link 和 After Effects
    2. 使用 After Effects 和其他应用程序
    3. After Effects 中的同步设置
    4. After Effects 中的 Creative Cloud Libraries
    5. 增效工具
    6. CINEMA 4D 和 Cineware
  19. 协作:Frame.io 和团队项目
    1. 在 Premiere Pro 和 After Effects 中协作
    2. Frame.io
      1. 安装和激活 Frame.io
      2. 将 Frame.io 与 Premiere Pro 和 After Effects 配合使用
      3. 常见问题解答
    3. 团队项目
      1. 开始使用团队项目
      2. 创建团队项目
      3. 使用团队项目进行协作
  20. 内存、存储、性能
    1. 内存和存储
    2. 提高性能
    3. 首选项
    4. After Effects 的 GPU 和 GPU 驱动程序要求

隔行视频和分离场

隔行是针对使用有限带宽传送电视信号而开发的一种技术。在隔行系统中,每次只传送每个视频帧的一半水平行数。由于传送速度、显示器余辉和视觉暂留方面的原因,查看器以完全分辨率感知每个帧。所有模拟电视标准都使用隔行技术。数字电视标准同时包括隔行非隔行模式。通常,从隔行扫描生成隔行信号,从逐行扫描生成非隔行信号。

每个隔行视频帧由两个组成。每个场包含帧中的一半水平行数,高场(或场 1)包含奇数行,而低场(或场 2)包含偶数行。隔行视频监视器先绘制一个场中的所有行,再绘制另一个场中的所有行,以此来显示每个帧。场序指定先绘制哪个场。在 NTSC 视频中,新场以近 60 次/秒的速度绘制到屏幕上,对应于接近 30 帧/秒的帧速率。

非隔行视频帧不分离为场。逐行扫描监视器通过自上向下绘制一遍所有水平行来显示非隔行视频帧。计算机显示器几乎都是逐行扫描监视器,而计算机显示器上显示的大多数视频都是非隔行的。

因此,术语逐行非隔行密切相关,且常常可交替使用。但是,逐行扫描指通过摄像机或监视器录制或绘制扫描行,而非隔行指视频数据本身不分离为场。

隔行视频场的隔行扫描与非隔行视频帧的逐行扫描之比较
隔行视频场的隔行扫描与非隔行视频帧的逐行扫描之比较。

A. 对于隔行视频,先自上向下在屏幕上绘制一遍整个高场(奇数行)。 B. 然后,自上向下在屏幕上绘制一遍整个低场(偶数行)。 C. 对于非隔行视频,自上向下在屏幕上绘制一遍整个帧(采用计数顺序的所有行)。 

分离视频场

如果要在 After Effects 项目中使用隔行或场渲染的素材(如 NTSC 视频),那么在导入素材时分离视频场可以获得最佳结果。After Effects 通过从每个场创建完整帧,并且保留原始素材中的所有图像数据,来分离视频场。

如果您准备对图像做出重要改动,分离场很关键。在对隔行视频进行缩放、旋转或应用效果时,常常会引入不需要的伪影(比如交叉场)。通过分离场,After Effects 能够准确地将视频中的两个隔行帧转化为非隔行帧,同时保持最高水平的图像品质。使用非隔行帧,After Effects 可以持续地以最高质量应用编辑和效果。

After Effects 通过将原来的单个隔行帧拆分成两个独立帧,来从该隔行帧创建场分离素材。每个新帧只包含原始帧的一半信息,所以在“草图”品质下查看时,一些帧看起来似乎比其他帧的分辨率低。当渲染最终合成时,After Effects 会重现高质量的隔行帧以供输出。在“最佳”品质下渲染影片时,After Effects 会在场的扫描行间插入值,以生成最高图像品质。

如果不进行隔行输出,则最好使用非隔行源素材,这样就不必分离场。但是,如果您的源素材的非隔行版本不可用,则适合用隔行素材。

始终对隔行素材分离场。永远不要对非隔行素材项目分离场。

分离场之后才能移除 Pulldown。

在渲染包含场分离素材的合成时,请将“场渲染”选项设置为与您的视频设备具有相同的场序。如果没有对合成进行场渲染,或者使用错误设置执行场渲染,则最终影片可能显得过于松散、抖动或变形。

注意:

要使视频素材快速具有类似影片的外观,可导入两遍素材,并使用不同的场序解释每个素材项目。然后,将二者添加到同一合成中并混合它们。被误解释的图层增添了一些类似影片的模糊效果。

After Effects 可为 D1 和 DV 视频素材项目自动分离场。您可以在“解释素材”对话框中为所有其他类型的视频素材手动分离场。

  1. 在“项目”面板中选择素材项目。

  2. 选择“文件”>“解释素材”>“主要”。

  3. 从“分离场”菜单中选择一个选项。

  4. 在“最佳”品质下渲染图像时,单击“保留边缘(仅最佳品质)”以提高非移动区域的图像品质。然后单击“确定”。

注意:

如果“解释素材”对话框中的场设置对于输入素材是正确的,并且“渲染设置”对话框中的场设置对于输出设备也是正确的,则可以将不同场序的素材项目混合在一个合成中。然而,如果其中某个设置不正确,则帧的顺序虽然正确,但场序可能反转,从而导致无法接受的抖动图像。

确定原始场序

隔行视频素材项目的场序决定按何种顺序显示两个视频场(高场和低场)。先绘制高场线后绘制低场线的系统称为高场优先,先绘制低场线后绘制高场线的系统称为低场优先。许多标清格式(如 DV NTSC)为低场优先,而许多高清格式(如 1080i DVCPRO HD)则为高场优先。

按何种顺序显示场很重要,尤其是当场中包含运动时。如果按错误的场序分离视频场,则运动看起来不平滑。

当渲染隔行视频文件时,一些程序(包括 After Effects)会为场序添加标签。当导入带标签的视频文件时,After Effects 自动接受场序标签。您可以通过应用不同的素材解释设置来覆盖此场序。

如果文件中不包含场序标签,您可以匹配素材的原始场序。如果您不确定使用了哪个场序来隔行扫描素材项目,可使用以下过程确定场序。

  1. 在“项目”面板中选择项。

  2. 选择“文件”>“解释素材”>“主要”。

  3. 在“解释素材”对话框中,从“分离场”菜单中选择“高场优先”,然后单击“确定”。

  4. 在“项目”面板中,按住 Alt 键 (Windows) 或 Option 键 (Mac OS) 并双击素材以在“素材”面板中打开它。

  5. 如果看不到“预览”面板,请选择“窗口”>“预览”。

  6. 在“素材”面板中,查找包含一个或多个运动区域的片段。

  7. 使用“预览”面板中的“下一帧”按钮 ,在“素材”面板中以至少五帧的步长前进。运动区域应向一个方向不停地运动。如果运动区域每隔一个帧向后运动,则说明应用于素材的场分离选项错误。

关于场和隔行视频的在线资源

Chris Pirazzi 在他的 Lurker's Guide to Video 网站上提供了场和隔行的技术细节。

Trish 和 Chris Meyer 提供了有关隔行、场序、场控制、场渲染和分离场的各种材料:

从视频中移除 3:2 或 24Pa Pulldown

当您传送 24 fps 影片到 29.97 fps 视频时,可使用一个称为 3:2 Pulldown 的过程,在该过程中,影片帧以重复的 3:2 模式跨视频场分布。影片的第一个帧复制到视频的第一个帧的场 1 和场 2,同时也复制到第二个视频帧的场 1。影片的第二个帧随后在视频的下两个场(即第二个视频帧的场 2 和视频的第三个帧的场 1)中传播。一直重复这种 3:2 模式,直到影片的四个帧传播到视频的五个帧上,接着继续重复该模式。

3:2 Pulldown 过程将导致产生全帧(用 W 表示)和拆分场帧(用 S 表示)。这三个全视频帧包含来自相同影片帧的两个场。其余两个拆分场帧包含来自两个不同影片帧的一个视频帧。两个拆分场帧始终彼此相邻。所谓 3:2 Pulldown 相位是指两个拆分场帧位于素材前五个帧上的阶段。

相位是在 3:2 Pulldown 期间发生的两个转换的结果:24 fps 影片通过 30 fps 视频重新分布,于是 24 fps 影片的所有四个帧都传播到 30(29.97) fps 视频的五个帧上。首先,影片减速 0.1% 来匹配 29.97 fps 和 30 fps 之间的速度差。然后,每个影片帧以特定模式重复并与视频场匹配。

从视频中移除 3:2 或 24Pa Pulldown
在将 3:2 Pulldown 应用于素材时,影片 (A) 的一个帧分离成两个或三个隔行视频场 (B),视频场组成视频帧,每个视频帧包含两个场。

在导入最初来自影片的隔行视频时,可将传送期间(从影片到视频)为确保 After Effects 中应用的效果不致变形而分离场时所应用的 3:2 Pulldown 移除。

从最初为影片的视频素材中移除 3:2 Pulldown 很重要,这样可使您在 After Effects 中添加的效果与影片最初的帧速率完美同步。移除 3:2 Pulldown 可减少 1/5 帧速率,即从 30 降低到 24 fps,或者从 29.97 降低到 23.976 fps,同时还将减少您必须更改的帧数。要移除 3:2 Pulldown,还必须指出 3:2 Pulldown 的相位。

After Effects 也支持 Panasonic DVX100 24p DV 摄像机 Pulldown,称为 24P Advance (24Pa)。有些摄像机使用该格式来捕捉采用标准 DV 磁带的 23.976 逐行扫描图像。

在移除 3:2 Pulldown 之前,先将场分离为高场优先或低场优先。一旦分离了场,After Effects 就可以分析素材,并确定正确的 3:2 Pulldown 相位和场序。如果您已经知道相位和场序,请从“解释素材”对话框的“分离场”菜单和“移除”菜单中选择它们。

  1. 在“项目”面板中,选择要从中移除 3:2 Pulldown 的素材项目。
  2. 选择“文件”>“解释素材”>“主要”。
  3. 在“场和 Pulldown”部分,从“分离场”菜单中选择“高场优先”或“低场优先”。
  4. 执行以下任一操作并单击“确定”:
    • 如果您知道 3:2 或 24Pa Pulldown 的相位,则从“移除”菜单中选择它。

    • 要让 After Effects 来确定正确设置,请单击“猜测 3:2 Pulldown”或“猜测 24Pa Pulldown”。

    注意:

    如果您的素材文件包含来自不同源的帧,则相位可能不一致。如果相位不一致,请多次导入素材,为每个相位导入一次,并使用不同的设置解释每个素材项目。然后,将每个素材项目添加到合成中,修剪每个图层以便只使用适当的帧。换言之,如果您的资源具有多个 Pulldown 相位,则您需要将该资源剪切为块并为每个块分别移除 Pulldown。如果该资源是一个已在 NLE 中从多个源编辑在一起的影片,就会出现这种情况。

导入 Panasonic P2 格式的资源

P2 卡是插在 Panasonic P2 摄像机的 PCMCIA 插槽内的一种固态存储器。摄像机中的数字视频和音频数据采用一种称为 MXF(Media eXchange Format,媒体交换格式)的结构化的编解码器独立格式录制到该卡上。具体讲,Adobe Premiere Pro 和 After Effects 支持 Panasonic Op-Atom 型号的 MXF 格式,其视频为 AVC-Intra 50、AVC-Intra 100、DV、DVCPRO、DVCPRO50 和 DVCPRO HD 格式。如果某剪辑的音频和视频包含在 Panasonic Op-Atom MXF 文件中,并且这些文件位于一个特定文件夹结构内,则称该剪辑为 P2 格式文件。

P2 文件夹结构的根目录是 CONTENTS 文件夹。每个要素项目(视频或音频项目)包含在一个单独的 MXF 包装器文件内;视频 MXF 文件位于 VIDEO 子文件夹中,音频 MXF 文件位于 AUDIO 子文件夹中。由 CLIP 子文件夹中的 XML 文件负责跟踪要素文件和与其相关的元数据之间的关系。

注意:

Adobe Premiere Pro 和 After Effects 不支持 P2 卡 PROXY 文件夹中由 Panasonic P2 便携式摄像机录制的代理。

P2 卡上的视频和音频已经是数字格式,就好像 P2 卡是硬盘一样,因此从 P2 卡导入媒体时不涉及捕捉步骤。这种从卡中读取数据并将其转换为可在项目中使用的格式的过程有时也称为收录

为使您的计算机能够读取 P2 卡,您必须安装适当的驱动程序,可从 Panasonic 网站上下载该程序。Panasonic 还提供 P2 Viewer 应用程序,可利用该应用程序浏览和播放 P2 卡上存储的媒体。

因为 Panasonic P2 卡使用 FAT32 文件系统,所以每个文件的大小不超过 4 GB。当录制超过 4 GB 的镜头时,P2 摄像机会另外创建一个文件,而拍摄连续不断地录制到这一新文件中。此过程称为剪辑跨接,因为镜头跨越多个文件或剪辑。同样,一台摄像机可以跨不同 P2 卡上的文件连续拍摄一个镜头:如果该摄像机上装载了多个 P2 卡,它会一直录制,直到用完第一个 P2 卡上的空间,然后在下一个包含可用空间的 P2 卡上创建新文件,并继续将镜头录制到该卡上。虽然可以将一个镜头录制到多个跨接剪辑组中,但在视频编辑应用程序中,多文件镜头将被作为单个剪辑或素材项目进行处理。要使 After Effects 能够自动地同时导入一组跨接剪辑并将它们合并为一个素材项目,必须已将这些剪辑全都录制到同一 P2 卡上,而且不能缺少任何文件,包括关联的 XML 元数据文件。

  1. (可选)将 P2 卡中的整个内容复制到硬盘。

    虽然可以直接从 P2 卡将资源导入 Adobe Premiere Pro 或 After Effects,但是,先将 P2 卡的内容复制到硬盘然后再导入通常更为有效。

  2. 选择“文件”>“导入”。
  3. 导航到 CONTENTS 文件夹。
  4. 选择一个或多个 MXF 文件:
    • 要导入某视频要素项目及其关联的音频要素项目,请从 VIDEO 文件夹中选择 MXF 文件。

    • 要仅仅导入音频要素项目,请从 AUDIO 文件夹中选择 MXF 文件。

    • 要导入一组已录制到同一 P2 卡上的跨接镜头剪辑,请从 VIDEO 文件夹的组中只选择一个 MXF 文件。该组作为单个素材项目导入,其持续时间等于它包括的所有跨接剪辑的总持续时间。如果您选择了多个此类跨接剪辑,则会重复导入整组跨接剪辑,它们将作为“项目”面板中的重复素材项目。

    不能将跨越两个不同卡的镜头中的跨接剪辑作为单个素材项目导入。确切地说,您必须选择一个属于每个卡中镜头的 MXF 文件,才能为每个卡上录制的镜头部分创建一个单独的素材项目。例如,如果某个镜头的一组跨接剪辑本身跨越两个卡,则您必须在卡 1 上从该组中选择一个跨接剪辑,并在卡 2 上从该组中选择另一个跨接剪辑。这会将拍摄的内容导入“项目”面板的两个素材项目中。

“项目”面板中的“日期”列显示获得每个源剪辑的时间。导入跨接剪辑后,可以使用日期值来判断它们在镜头中的正确年月日次序。

注意:

After Effects 不能直接导出为 P2 格式。要渲染和导出为 P2 格式,请使用 Adobe Media Encoder 或 Premiere Pro。

有关 Panasonic P2 格式和 Adobe 数字视频软件工作流的更多信息,请访问 Adobe 网站:

Adobe 徽标

登录到您的帐户

[Feedback V2 Badge]