渲染和导出概述

什么是渲染?

渲染是从合成创建影片帧的过程。帧的渲染是依据构成该图像模型的合成中的所有图层、设置和其他信息,创建合成的二维图像的过程。影片的渲染是构成影片的每个帧的逐帧渲染。有关如何渲染每个帧的更多信息,请参阅渲染顺序和折叠变换

谈到渲染时通常指最终输出。不过,创建在“素材”、“图层”和“合成”面板中显示的预览的过程也属于渲染。事实上,可以将预览另存为影片,然后将其用作最终输出。(请参阅预览视频和音频。)

在渲染合成以生成最终输出之后,它由一个或多个输出模块处理,这些模块将渲染的帧编码到一个或多个输出文件中。将渲染的帧编码到输出文件中的过程是导出的一种。

  • 请参阅项目设置,了解有关项目设置的更多信息,这些设置确定如何在项目中显示时间、如何在项目中处理颜色数据以及对音频使用哪种采样率。
  • 请参阅合成设置,了解如何为您的最终渲染输出指定合成设置,例如分辨率、帧大小和像素长宽比。

完成合成后,可输出影片文件。输出影片文件有两种不同的方法。根据需要选择其一。

出于以下原因,您可能需要影片文件:

  • 您需要高品质影片(带或不带 Alpha 通道)或图像序列,以便将其放入 Premiere Pro 序列,或用于其他视频编辑、合成或 3D 图形应用程序。

    要创建一个高品质影片文件,请使用“渲染队列”对其进行渲染。请参阅使用“渲染队列”面板渲染和导出

  • 您需要经压缩的影片,以便在 Web 上播放、制作 DVD 或蓝光光盘。

    若要创建为 Web、DVD 或蓝光光盘压缩的高品质影片文件,请使用 Adobe Media Encoder 为其编码。请参阅 Adobe Media Encoder。

注意:

有些种类的导出不涉及渲染,针对的是工作流程中的中间阶段,而不是针对最终输出。例如,您可以通过选择“文件”>“导出”>“Adobe Premiere Pro 项目”,将项目导出为 Adobe Premiere Pro 项目。系统将保存项目信息而不进行渲染。通常不会渲染通过 Dynamic Link 传输的数据。

影片可以制成包含所有已渲染帧的单个输出文件,也可以制成静止图像序列(就像为胶片记录器创建输出时一样)。

要生成输出,您可以使用 After Effects 渲染队列渲染合成,或者使用您在“渲染队列”面板中选择的渲染设置,将您的合成添加到 Adobe Media Encoder 队列。

对于“渲染队列”,After Effects 使用嵌入版本的 Adobe Media Encoder,以通过“渲染队列”面板对大多数影片格式进行编码。在使用“渲染队列”面板管理渲染和导出操作时,将自动调用 Adobe Media Encoder 的嵌入版本。Adobe Media Encoder 仅以“导出设置”对话框的形式出现,您可在该对话框中指定一些编码和输出设置。(请参阅影片的编码和压缩选项。)

注意:

用于管理 After Effects 输出模块中的导出设置的 Adobe Media Encoder 嵌入版本只提供完整单机版 Adobe Media Encoder 应用程序的部分功能。

From an expert: Using the Render Queue to export files

From an expert: Using the Render Queue to export files
Ian Robinson

使用“渲染队列”面板渲染和导出

从 After Effects 渲染和导出影片的主要方式是使用“渲染队列”面板。

在将合成放入“渲染队列”面板后,它将变成渲染项。您可以将许多渲染项添加到渲染队列中,After Effects 可以在无人参与的情况下成批渲染多个项目。单击“渲染队列”面板右上角的“渲染”按钮时,将按项在“渲染队列”面板中列出的顺序渲染所有状态为“已加入队列”的项。

注意:

您不需要多次渲染某个影片,即可使用同一渲染设置将它导出为多种格式。您可以通过将输出模块添加到“渲染队列”面板中的渲染项,导出同一渲染影片的多个版本。

在处理多个渲染项时,在“渲染队列”面板中的“注释”列中添加注释通常比较有用。如果“注释”列不可见,请右键单击 (Windows) 或按住 Control 键单击 (Mac OS) 列标题,然后选择“列”>“注释”。

管理渲染项

在“渲染队列”面板中,您可以同时管理多个渲染项,每个渲染项都有它自己的渲染设置和输出模块设置。

渲染设置确定以下特征:

  • 输出帧速率
  • 持续时间
  • 分辨率
  • 图层品质

在渲染设置之后应用的输出模块设置确定以下渲染后特征:

  • 输出格式
  • 压缩选项
  • 裁剪
  • 是否在输出文件中嵌入项目链接

您可以创建包含常用渲染设置和输出模块设置的模板。

使用“渲染队列”面板,您可以将同一合成渲染成不同的格式或使用不同的设置进行渲染,只需单击一下“渲染”按钮即可完成所有这些操作:

  • 可以输出为静止图像序列(例如 Cineon 序列),然后可以将该序列转换为影片以便在电影院放映。

  • 可以使用无损压缩(或不进行压缩)输出到 QuickTime 容器,以转换到非线性编辑 (NLE) 系统进行视频编辑。

您可以使用处理图层和其他项时使用的许多相同的键盘快捷键来选择、复制和重新排序渲染项。请参阅常规(键盘快捷键)

注意:

要将从 After Effects 渲染的输出转换为影片或视频,您必须具有用于影片或视频转换的适当硬件,或者与可以提供转换服务的服务机构合作。

使用渲染队列渲染和导出影片

  1. 在“项目”面板中选择要制成影片的合成,然后执行以下操作之一,将合成添加到渲染队列中:
    • 选择“合成”>“添加到渲染队列”。

    • 将合成拖到“渲染队列”面板中。

    注意:

    要从素材项目创建合成并立即将该合成添加到渲染队列中,请将素材项目从“项目”面板拖到“渲染队列”面板。这是将素材项目从一种格式转换为另一种格式的便捷方法。

  2. 单击“渲染队列”面板中“输出到”标题旁边的三角形,以便基于命名惯例选择输出文件的名称,然后选择位置;或者单击“输出到”标题旁边的文本以输入任何名称。(请参阅指定渲染输出的文件名和位置。)
  3. 单击“渲染设置”标题右侧的三角形,选择渲染设置模板,或者单击“渲染设置”标题右侧带下划线的文本以自定义设置。(请参阅渲染设置)。
  4. 从“日志”菜单中选择日志类型。

    在已写入日志文件时,日志文件的路径出现在“渲染设置”标题和“日志”菜单下。

  5. 单击“输出模块”标题右侧的三角形,选择输出模块设置模板,或者单击“输出模块”标题右侧带下划线的文本以自定义设置。可使用输出模块设置来指定输出影片的文件格式。有些情况下,在您选择某个格式后,将会打开该格式特定的对话框,可在其中选择格式特定的设置。(请参阅输出模块和输出模块设置影片的编码和压缩选项。)

    在设置输出名称和位置,并且已选择渲染设置和输出模块后,“渲染”列中的条目将自动变为选定状态(由复选标记指示),并且状态更改为“已加入队列”。“已加入队列”状态意味着渲染项已位于渲染队列中。

    注意:

    在开始渲染之前按 Caps Lock 可防止“合成”面板显示渲染帧。通过不更新“合成”面板,After Effects 处理包含许多帧的简单渲染项所需的时间就会缩短。

  6. 单击“渲染队列”面板右上角的“渲染”按钮。

将合成渲染到影片可能需要几秒钟或数小时,具体取决于合成的帧大小、品质、复杂性以及压缩方法。当 After Effects 渲染项时,您无法在程序中工作。渲染完成时,会响起一声提示音。

请参阅此教程了解如何使用渲染队列导出文件。

在渲染项的渲染完成时,它仍然位于“渲染队列”面板中,状态更改为“完成”,直到您从“渲染队列”面板中将其移除。您不能再次渲染已完成的项,但是可以复制它以使用相同的设置或使用新设置在队列中创建新项。

注意:

在某个项完成渲染之后,您可以导入完成的影片作为素材项,方法是将其输出模块从“渲染队列”面板拖动到“项目”面板。(请参阅导入素材项目。)

渲染项状态

每个渲染项都有状态,它出现在“渲染队列”面板中的“状态”列中:

未加入队列

渲染项在“渲染队列”面板中列出,但没有准备好渲染。确认您已选择所需的渲染设置和输出模块设置,然后选择“渲染”选项将渲染项加入队列。

已加入队列

渲染项准备好渲染。

需要输出

尚未指定输出文件名。从“输出到”菜单中选择值,或单击“输出到”标题旁边带下划线的“尚未指定”文本,以指定文件名和路径。

失败

After Effects 在渲染渲染项时失败。使用文本编辑器查看日志文件,以了解有关渲染失败原因的特定信息。在已写入日志文件时,日志文件的路径出现在“渲染设置”标题和“日志”菜单下。

用户已停止

用户已停止渲染进程。

完成

项目的渲染进程已完成。

管理渲染项和更改渲染状态

  • 为“项目”面板中的渲染项选择源合成:右键单击 (Windows) 或按住 Control 键单击 (Mac OS) 渲染项,然后从上下文菜单中选择“在项目中显示合成”
  • 从渲染队列中移除渲染项(将其状态从“已加入队列”更改为“未加入队列”):在“渲染”列中取消选择其条目。项依然保留在“渲染队列”面板中。
  • 将渲染项的状态从“未加入队列”更改为“已加入队列”:在“渲染”列中选择项。
  • 从“渲染队列”面板中移除渲染项:选择该项,然后按 Delete 键,或者选择“编辑”>“清除”
  • 重新排列“渲染队列”面板中的项:将项在队列中上下拖动。渲染项之间出现一条粗较的黑线,指示将放置项的位置。您也可以通过选择“图层”>“排列”,然后选择“将渲染项前移一层”“将渲染项置于底层”“将渲染项置于顶层”“将渲染项后移一层”,对选定渲染项重新排序。
  • 在渲染队列中将选定渲染项上移(向前移):按 Ctrl+Alt+向上箭头键 (Windows) 或按 Command+Option+向上箭头键 (Mac OS)。
  • 将选定渲染项下移(向后移):按 Ctrl+Alt+向下箭头键 (Windows) 或按 Command+Option+向下箭头键 (Mac OS)。
  • 将选定渲染项移动到渲染队列的顶部:按 Ctrl+Alt+Shift+向上箭头键 (Windows) 或按 Command+Option+Shift+向上箭头键 (Mac OS)。
  • 将选定渲染项移动到渲染队列的底部(结尾):按 Ctrl+Alt+Shift+向下箭头键 (Windows) 或 Command+Option+Shift+向下箭头键 (Mac OS)。
  • 复制渲染项:右键单击 (Windows) 或按住 Control 键单击 (Mac OS) 渲染项,然后从上下文菜单中选择命令:
    • 使用相同文件名渲染:选择“与文件名一起复制”
    • 使用新文件名渲染:选择“复制”,单击“输出到”旁边带下划线的文件名,输入新文件名,然后单击“保存”

暂停或停止渲染

如果磁盘(输出模块所写入的磁盘)空间不足,After Effects 将暂停渲染操作。您可以清除额外的磁盘空间,然后继续渲染和导出。

  • 要暂停渲染,请单击“暂停”。要恢复渲染,请单击“继续”。

    在渲染处于暂停状态时,您无法以任何其他方式更改设置或使用 After Effects。

  • 要以再次开始同一渲染为目的停止渲染,请按住 Alt 键单击 (Windows) 或按住 Option 键单击 (Mac OS)“停止”。

    系统会为对其停止渲染的渲染项分配状态“用户已停止”,将状态为“已加入队列”的新项添加到“渲染队列”面板中。新项使用相同的输出文件名,并且与原始渲染项具有相同的持续时间。

  • 要以恢复同一渲染为目的停止渲染,请单击“停止”。

    系统会为对其停止渲染的渲染项分配状态“用户已停止”,将状态为“未加入队列”的新项添加到“渲染队列”面板中。新项使用递增的输出文件名,并在渲染停止处的帧之前继续渲染,因此新项的第一帧是已停止项最后一个成功渲染的帧。

为当前渲染操作显示的信息

有关当前批渲染的基本信息显示在“渲染队列”面板的底部:

消息

状态消息。例如,渲染进度为 1/4。

RAM

可供渲染进程使用的内存。

渲染已开始

当前批渲染开始的日期和时间。

已用总时间

自当前批渲染开始以来经过的渲染时间(不计算暂停)。

最近错误

日志文件所在的路径。

注意:

要查看有关当前渲染操作的详细信息,请单击“当前渲染”标题左侧的三角形。“当前渲染”窗格在一小段时间后折叠(关闭)。要防止暂停期后折叠,请按住 Alt 键 (Windows) 或 Option 键 (Mac OS) 并单击“当前渲染”标题旁边的三角形。要查看已完成的渲染的详细信息,请查看日志文件。在已写入日志文件时,日志文件的路径出现在“渲染设置”标题和“日志”菜单下。

更改渲染完成时的声音

当渲染队列中的所有项目均已渲染和导出时,将播放一声钟鸣声;如果渲染操作失败,将播放不同的声音。您可以通过替换声音文件夹中名为 rnd_okay.wavrnd_fail.wav 的文件,来更改渲染完成时的声音。声音文件夹位于以下位置:

  • Program Files\Adobe\Adobe After Effects CC 2015\Support Files (Windows)

  • Applications/Adobe After Effects CC/Contents/Resources (Mac OS)

使用渲染队列渲染和导出的在线资源

Lloyd Alvarez 在其 After Effects Scripts 网站上提供了一个脚本,该脚本将已经准备好渲染的项收集到渲染队列中,并发送它们以便使用 aerender 在后台渲染。

Jeff Almasol 在其 redefinery 网站上提供了一个用于单独渲染和导出每个选定图层的脚本。如果您希望将图层表示的效果的不同版本或不同部分作为单独的“一次操作”渲染,以提高合成方法的灵活性,您会发现此脚本非常有用。

Christopher Green 在他的网站上提供了一个脚本 (Queue_Comp_Sections.jsx),利用该脚本,您可以使用多个引导层来指定要通过渲染队列分别渲染和导出的多个时间跨度。

使用 Adobe Media Encoder 渲染和导出

From an expert: Export a composition from After Effects to Adobe Media Encoder

From an expert: Export a composition from After Effects to Adobe Media Encoder
Jeff Sengstack

也可将 After Effects 合成直接导出至 Adobe Media Encoder,这样就可在处理文件的同时,继续在 After Effects 中进行操作。使用 Adobe Media Encoder 时,还可以使用 After Effects“渲染队列”中不可用的其他预设和选项。

可通过以下方法之一将您的合成添加到 Adobe Media Encoder 队列:

  • “添加到 Adobe Media Encoder 队列”“合成”>“添加到 Adobe Media Encoder 队列”“文件”>“导出”>“添加到 Adobe Media Encoder 队列”):使用在 Adobe Media Encoder 中指定的预设和设置进行最终渲染。
  • 渲染队列中的“在 AME 中排入队列”按钮(“窗口”>“渲染队列”):使用在渲染队列中指定的渲染设置渲染合成的草稿副本,同时您可以继续处理合成。

有关使用 Adobe Media Encoder 进行渲染的信息,请参阅在 Adobe Media Encoder 中对视频或音频项目进行编码

当您选择“在 AME 中排入队列”选项时,输出模块设置(例如,格式设置或颜色通道选择)不会传输到 Adobe Media Encoder 中。但是会传输输出文件名称和位置,Adobe Media Encoder 不使用文件名称和位置模板,这些模板可能会导致图像序列编号不匹配。

直接将合成添加到 Adobe Media Encoder

要将合成添加到 Adobe Media Encoder,请执行以下操作:

  1. 将包含待编码合成的 After Effects 项目拖动到 Adobe Media Encoder 中的“编码队列”。

    可以从 After Effects 将合成添加到 Adobe Media Encoder。执行以下操作之一:

    • 选择“合成”>“添加到 Adobe Media Encoder 队列”

    • 选择“文件”>“导出”>“添加到 Adobe Media Encoder 队列”

    • Ctrl+Alt+M (Windows) 或 Command+Option+M (Mac OS)

  2. 此时将打开“导入 After Effects 合成”对话框。选择要编码的合成。

  3. 根据在 Adobe Media Encoder 中选择的预设和输出位置,照常对文件进行编码。

从渲染队列将合成添加到 Adobe Media Encoder

要使用渲染设置将合成添加到 Adobe Media Encoder 进行草稿渲染,请执行以下操作:

  1. 选择“合成”>“添加到渲染队列”,或者按键盘快捷键 Control + M (Windows) 或 Command + M (Mac)。

  2. 在“渲染队列”面板中,单击“在 AME 中排入队列”按钮。

选择格式和输出设置

After Effects 提供各种输出格式和压缩选项。要选择哪种格式和压缩选项取决于您的输出的使用方式。例如,如果您从 After Effects 渲染的影片是将直接向观众播放的最终产品,则您需要考虑将用于播放影片的媒体,以及文件大小和数据传输速率的限制。相比之下,如果您从 After Effects 创建的影片是将用作输入到视频编辑系统的半成品,则您应当输出到与视频编辑系统兼容的格式而不进行压缩。(请参阅规划您的工作。)

Aharon Rabinowitz 在 Creative COW 网站上提供了一篇文章,其中介绍了如何规划您的项目以及如何决定要对最终输出使用的格式和设置。

请记住您可以对工作流程的不同阶段使用不同的编码和压缩方案这一事实。例如,如果您需要客户审批某个画面中的颜色,您可以选择导出几个帧作为完整分辨率的静止图像(例如,TIFF 文件);而在您需要客户审批动画的时间安排时,则可以使用有损编码方案(例如,H.264)导出影片。

支持的输出格式

您可以通过安装由 Adobe 之外的其他方提供的增效工具或脚本,来添加导出其他类型数据的功能。例如,Paul Tuersley 在 AE Enhancers 论坛上提供了一个脚本,利用该脚本,您可以将 After Effects 合成数据作为 Cinema 4D 项目数据导出。Mark Christiansen 在 ProVideo Coalition 网站上发布了一篇文章,该文章链接到可从 After Effects 中导出用于 Cinema 4D、Maya、Lightwave 和其他 3D 应用程序的脚本和增效工具。(请参阅增效工具。)

除非另有说明,否则所有图像文件格式均按每通道 8 个位 (bpc) 导出。

视频和动画格式

  • QuickTime (MOV)

  • Video for Windows(AVI;仅限 Windows)

注意:

要创建动画 GIF 格式的影片,请首先从 After Effects 渲染和导出 QuickTime 影片。然后,将 QuickTime 影片导入 Photoshop,并且将影片导出为动画 GIF。

视频项目格式

  • Adobe Premiere Pro 项目 (PRPROJ)

静止图像格式

  • Adobe Photoshop (PSD)

  • Cineon(CIN、DPX)

  • Maya IFF (IFF)

  • JPEG(JPG、JPE)

  • OpenEXR (EXR)

  • PNG (PNG)

  • Radiance(HDR、RGBE、XYZE)

  • SGI(SGI、BW、RGB)

  • Targa(TGA、VBA、ICB、VST)

  • TIFF (TIF)

仅音频格式

  • 音频交换文件格式 (AIFF)

  • MP3

  • WAV

将文件收集到一个位置

“收集文件”命令将项目或合成中所有文件的副本收集到一个位置。在渲染之前使用此命令,用于存档或将项目移至不同的计算机系统或用户帐户。

在使用“收集文件”命令时,After Effects 会创建一个新文件夹,以下信息将保存到此新文件夹中:

  • 项目的新副本
  • 素材文件的副本
  • 指定的代理文件
  • 一个报告,其中描述重新创建项目和渲染合成所必需的文件、效果和字体。

在收集文件之后,您可以继续更改项目,但请注意,所做更改会随原始项目(而不是新收集的版本)一起存储。

  1. 选择“文件”>“依赖项”>“收集文件”。

  2. 在“收集文件”对话框中,为“收集源文件”选择适当的选项。

    全部

    收集所有素材文件,包括未使用的素材和代理。

    对于所有合成

    收集项目内的任何合成中使用的所有素材文件和代理。

    对于所选合成

    收集“项目”面板内当前选定的合成中使用的所有素材文件和代理。

    对于队列合成

    收集在“渲染队列”面板中的状态为“已加入队列”的任何合成中直接或间接使用的所有素材文件和代理。

    无(仅项目)

    将项目复制到新位置,而不收集任何源素材。

  3. 根据需要选择其他选项:

    仅生成报告

    选择此选项将不复制文件和代理。

    服从代理设置

    对包括代理的合成使用此选项,以指定您是否希望复制当前代理设置。如果选择此选项,将仅复制合成中使用的文件。如果不选择此选项,将同时复制代理和源文件,因此稍后您可以更改收集的版本中的代理设置。

    注意:

    如果您在“收集源文件”对话框中选择“对于队列合成”,After Effects 将使用渲染设置(而不是合成)中的代理设置。

    减少项目

    在“收集源文件”菜单中选择以下选项时,从收集的文件中移除所有未使用的素材项和合成:“对于所有合成”、“对于选定合成”和“对于队列合成”。

    将渲染输出为

    用来重定向输出模块,以便将文件渲染到收集的文件文件夹中指定的文件夹。此选项可确保,在您从其他计算机渲染项目时,您能够访问已渲染的文件。渲染状态必须有效(“已加入队列”、“未加入队列”或“将继续”),输出模块才能将文件渲染到此文件夹。

    启用“监视文件夹”渲染

    您可以使用“收集文件”命令将项目保存到指定的监视文件夹,然后通过网络启动监视文件夹渲染。After Effects 还包括一个名为“[project name]_RCF.txt”的渲染控制文件,它向监视计算机发出项目可供渲染的信号。然后 After Effects 和任何已安装的渲染引擎可以跨网络一起渲染项目。(请参阅设置监视文件夹渲染。)

    计算机的最大数目

    用来指定想要分配以渲染收集项目的渲染引擎或 After Effects 许可副本的数目。在此选项下,After Effects 报告将使用多个计算机渲染项目中的多少项。

    注意:

    如果渲染时间异常长,您可能将“计算机的最大数目”设置得太高,在所有计算机之间跟踪渲染进度所需的网络开销与渲染帧实际所花的时间不成比例。最佳数目取决于与网络配置和网站上的计算机有关的许多可变因素;应通过实验确定适合您的网络的最佳数目。

  4. 要将自己的信息添加到将生成的报告中,请单击“注释”,输入您的注释,然后单击“确定”。注释出现在报告末尾。
  5. 单击“收集”。命名文件夹,并指定用来存放收集的文件的位置。

    一旦开始文件收集,After Effects 即会创建文件夹并将指定的文件复制到其中。文件夹层次结构与项目中的文件夹和素材项的层次结构相同。新文件夹包括一个“(素材)”文件夹,并且可能包括一个输出文件夹(如果您选择了“将渲染输出为”)。

这些文件夹的名称出现在圆括号内,以告知任何参加渲染的引擎,它们不应在这些文件夹中搜索项目。

Carl Larsen 在 Creative COW 网站(该网站演示如何组织、整合和存档项目文件和素材)的一个视频教程中演示了“收集文件”命令和“整合所有素材”命令的用法。

David Torno 在 After Effects Scripts 网站上提供了一个脚本,可用于导出项目的指定信息。

指定渲染输出的文件名和位置

注意:

您可以通过展开“渲染队列”面板中的“输出模块”组,然后单击带下划线的文件路径,或者通过右键单击 (Windows) 或按住 Control 键并单击 (Mac OS)“输出模块”标题,来找到先前渲染的项或检查已进入队列的渲染项的目标位置。

指定单个渲染项的文件名和位置

  • 要手动输入文件名和目标文件夹,请单击“输出到”标题旁边带下划线的文本。
  • 要使用文件命名模板命名文件,请单击“输出到”标题旁边的三角形,然后从菜单中选择模板。

创建并使用自定义文件命名模板

您可以使用自定义模板,根据合成和项目的属性来命名输出。

注意:

要将文件命名模板设为默认模板,请按住 Ctrl 键 (Windows) 或 Command 键 (Mac OS) 的同时从“输出到”菜单中选择模板。

  1. 在“渲染队列”面板中,从“输出到”菜单中选择“自定义”。
  2. 如果您想以现有模板为基础创建新文件命名模板,请从“预设”菜单中选择现有模板。

  3. 在您想插入文件命名规则的“模板”框中单击,然后执行以下任一操作:

    • 要向文件名中添加预设属性,请从“添加属性”菜单中选择属性。

    • 在“模板”框中输入文本。

    注意:

    确保插入点位于预设属性的方括号 ([ ]) 外部。

  4. 执行以下任一操作:
    • 要将文件命名模板另存为预设以便以后在“输出到”菜单中使用,请单击“保存”按钮 。在“选择名称”对话框中,输入文件命名模板的名称,然后单击“确定”。

    • 要始终使用选定的文件命名模板,请选择“默认”。

    • 要向当前输出模块应用选定的文件命名模板,请单击“确定”。

自动命名输出文件

“使用默认文件名和文件夹”首选项可确保为添加到渲染队列的所有合成自动分配唯一的输出文件名(通过保存 预览创建的文件除外,它们仍然使用合成名称)。如果选择此选项,将为每个渲染项分配与前一个渲染项相同的文件夹名称,直到您更改路径。如果合成得到多次渲染,After Effects 会向文件名中添加一个数字(例如,composition_name_1)。

注意:

对于要在不同平台上使用,或使用监视文件夹渲染的项目,应避免在文件名中使用高位 ASCII 字符或其他扩展字符。

  1. 选择“编辑”>“首选项”>“输出”(Windows) 或“After Effects”>“首选项”>“输出”(Mac OS)。
  2. 选择“使用默认文件名和文件夹”。

在模板中支持路径

您可以将路径添加到模板。绝对路径可以在模板中定义。例如,您可以定义并保存始终将渲染后文件放在 E:\Output\[合成名称].[扩展名] 中的模板。请参阅 After Effects CC 12.2 的新增功能中的“文件名称和位置模板”部分,了解有关 After Effects CC 12.2 版中新模板的信息。

渲染设置

渲染设置应用于每个渲染项,并确定如何渲染该特定渲染项的合成。默认情况下,渲染项的渲染设置基于当前项目设置、合成设置以及该渲染项所基于的合成的切换设置。不过,您可以修改每个渲染项的渲染设置来覆盖这些设置中的其中一些设置。

渲染设置应用于渲染项的根合成,以及所有嵌套合成。

注意:

渲染设置仅影响与它们关联的渲染项的输出;合成本身不受影响。

渲染设置
渲染设置

更改渲染设置

  • 要更改渲染项的渲染设置,请单击“渲染队列”面板中“渲染设置”标题旁边的渲染设置模板名称,然后在“渲染设置”对话框中选择设置。
  • 要将渲染设置模板应用于选定的渲染项,请单击“渲染队列”面板中“渲染设置”标题旁边的三角形,然后从菜单中选择模板。您可以选择自定义渲染设置模板或预设的渲染设置模板之一:

    最佳设置:通常用于渲染到最终输出。

    草图设置:通常适用于审阅或测试运动。

    DV 设置:与“最佳设置”类似,但打开了“场渲染”,并设置为“低场优先”。

    多机设置:与“最佳设置”类似,但选择了“跳过现有文件”以启用多机渲染。

注意:

在创建渲染项时,将为其分配默认渲染设置模板。要更改默认渲染设置模板,请在从菜单中选择渲染设置模板时,按住 Ctrl 键 (Windows) 或 Command 键 (Mac OS)。

创建、编辑和管理渲染设置模板

可在“渲染设置模板”对话框中执行以下任务。要打开“渲染设置模板”对话框,请选择“编辑”>“模板”>“渲染设置”,或单击“渲染队列”面板中“渲染设置”标题旁边的三角形,然后选择“创建模板”。

  • 要创建新的渲染设置模板,单击“新建”,指定渲染设置,然后单击“确定”。输入新模板的名称。
  • 要编辑现有渲染设置模板,请从“设置名称”菜单中选择模板,单击“编辑”,然后指定渲染设置。

注意:

对现有模板所做的更改不影响已经在渲染队列中的渲染项。

  • 要指定在渲染影片、单个帧、预渲染影片或代理时将使用的默认渲染设置模板,请从“渲染设置模板”对话框的“默认”区域的菜单中选择一个模板。
  • 要将当前已加载的所有渲染设置模板保存到文件,请单击“全部保存”。
  • 要加载保存的渲染设置模板文件,请单击“加载”,选择渲染设置模板文件,然后单击“打开”。

渲染设置参考

以下每个设置都会覆盖合成设置、项目设置或图层交换设置。

日志

您可以选择 After Effects 写入渲染日志文件的信息量。如果选择“仅错误”,After Effects 仅在渲染期间遇到错误时创建文件。如果选择“增加设置”,将创建日志文件,其中列出当前渲染设置。如果选择“增加每帧信息”,将创建日志文件,其中列出当前渲染设置和有关每个帧的渲染信息。在已写入日志文件时,日志文件的路径出现在“渲染设置”标题和“日志”菜单下。

品质

用于所有图层的品质设置。(请参阅图层图像质量和子像素定位。)

分辨率

渲染合成的分辨率,相对于原始合成大小。(请参阅分辨率。)

注意:

如果您以降低的分辨率渲染,请将“品质”选项设置为“草图”。在降低分辨率的情况下以“最佳”品质渲染会产生不清楚的图像,并且花费的时间也比“草图”品质所花的时间长。

磁盘缓存

确定渲染期间是否使用磁盘缓存首选项。“只读”不会在 After Effects 渲染期间向磁盘缓存写入任何新帧。“当前设置”(默认)使用在“媒体和磁盘缓存”首选项中定义的磁盘缓存设置。(请参阅磁盘缓存。)

代理使用

确定渲染时是否使用代理。“当前设置”将使用每个素材项目的设置。(请参阅占位符和代理。)

效果

“当前设置”(默认)使用“效果”开关 的当前设置。“全部开启”渲染所有应用的效果。“全部关闭”不渲染任何效果。

独奏开关

“当前设置”(默认)将使用每个图层的独奏开关 的当前设置。“全部关闭”按所有独奏开关均关闭时的情形渲染。(请参阅独奏图层。)

引导层

“当前设置”渲染最顶层合成中的引导层。“全部关闭”(默认设置)不渲染引导层。永远不渲染嵌套合成中的引导层。(请参阅引导层。)

颜色深度

“当前设置”(默认)使用项目位深度。(请参阅颜色深度和高动态范围颜色。)

帧混合

“对选中图层打开”只对设置了“帧混合”开关 的图层渲染帧混合,无论合成的“启用帧混合”如何设置。(请参阅帧混合。)

场渲染

确定用于渲染合成的场渲染技术。如果您正在为电影或为了在计算机屏幕上显示而渲染,请选择“关闭”。(请参阅隔行视频和分离场。)

3:2 Pulldown

指定 3:2 Pulldown 的相位。(请参阅 3:2 Pulldown 简介。)

运动模糊

“当前设置”将使用“运动模糊”图层开关 和“启用运动模糊”合成开关的当前设置。“对选中图层打开”只对设置了“运动模糊”图层开关的图层渲染运动模糊,无论合成的“启用运动模糊”如何设置。无论图层开关和合成开关如何设置,“对所有图层关闭”都在没有运动模糊的情况下渲染所有图层。(请参阅运动模糊。)

时间跨度

要渲染合成中的多少内容。要渲染整个合成,请选择“合成长度”。要仅渲染由工作区域标记指示的合成部分,请选择“仅工作区域”。要渲染自定义时间范围,请选择“自定义”。(请参阅工作区域。)

帧速率

渲染影片时使用的采样帧速率。选择“使用合成的帧速率”以使用在“合成设置”对话框中指定的帧速率,或选择“使用此帧速率”以使用不同的帧速率。合成的实际帧速率保持不变。经过编码的最终影片的帧速率由输出模块设置决定。(请参阅帧速率。)

跳过现有文件

允许您渲染一系列文件的一部分,而不在先前已渲染的帧上浪费时间。在渲染一系列文件时,After Effects 会找到属于当前序列的一部分的文件,识别缺失的帧,然后仅渲染那些帧,在它们在序列中所处的位置插入它们。您也可以使用此选项在多个计算机上渲染图像序列。(请参阅使用多个计算机渲染静止图像序列。)

注意:

当前图像序列必须与现有图像序列具有相同名称,起始帧编号、帧速率和时间范围也必须相同。您必须渲染到包含先前已渲染的帧的文件夹。

输出模块和输出模块设置

输出模块设置应用于每个渲染项,并确定如何针对最终输出处理渲染的影片。可使用输出模块设置来指定最终输出的文件格式、输出颜色配置文件、压缩选项以及其他编码选项。

也可以使用输出模块设置来裁剪、拉伸或收缩渲染的影片;在从单个合成生成多种类型的输出时,在渲染之后执行此操作非常有用。

输出模块设置应用于根据渲染设置生成的渲染输出。

对于有些格式,当您在“输出模块设置”对话框中选择格式时,会额外打开一个对话框。您可以修改这些设置,并使用设置预设来指定格式特定的选项,如压缩选项。

您可以将多个输出模块应用于每个渲染项,当您希望通过一次渲染创建影片的多个版本时,这非常有用。例如,您可以自动创建影片及其 Alpha 遮罩,也可以创建影片的高分辨率和低分辨率版本。

注意:

在渲染之前,检查“输出模块设置”对话框中的“音频输出”设置,确保它们正确。要渲染音频,必须选择“音频输出”。如果您的合成不包括音频,请不要选择“音频输出”,以免渲染文件的大小不必要地增加。

渲染设置

可同时设置多个渲染队列项目的输出模块。选择渲染队列项,然后从“输出模块设置”菜单中为其中一个项选择输出模块模板。

您可以将输出模块拖到“项目”面板中,以便将完成的影片或占位符导入项目,用作素材项。(请参阅导入素材项目。)

Andrew Kramer 在 Video Copilot 网站上提供了一个视频教程,其中包含有关处理代理、输出模块和输出模块模板的提示。

更改输出模块设置

  • 要更改渲染项的输出模块设置,请单击“渲染队列”面板中“输出模块”标题旁边带下划线的输出模块设置模板名称,然后在“输出模块设置”对话框中选择设置。
  • 要将输出模块设置模板应用于选定的渲染项,请单击“渲染队列”面板中“输出模块”标题旁边的三角形,然后从菜单中选择模板。

    您可以选择自定义输出模块设置模板或预设的输出模块设置模板之一。系统提供了多个模板,包括用于创建影片以传输到视频、电影或 NLE 系统的无损模板。

注意:

在创建渲染项时,将为其分配默认输出模块设置模板。要更改默认输出模块模板,请在从菜单中选择输出模块模板时,按住 Ctrl 键 (Windows) 或 Command 键 (Mac OS)。

注意:

要同时更改多个输出模块的输出模块设置,请选择输出模块,然后选择输出模块模板。模板应用于所有选定的输出模块。

创建、管理和编辑输出模块模板

可在“输出模块模板”对话框中执行以下任务。要打开“输出模块模板”对话框,请选择“编辑”>“模板”>“输出模块”,或单击“渲染队列”面板中“输出模块”标题旁边的三角形,然后选择“创建模板”。

  • 要创建新的输出模块设置模板,请单击“新建”,指定输出模块设置,然后单击“确定”。输入新模板的名称。
  • 要编辑现有输出模块设置模板,请从“设置名称”菜单中选择模板,单击“编辑”,然后指定输出模块设置。

注意:

对现有模板所做的更改不影响已经在渲染队列中的渲染项。

  • 要指定在处理影片、单个帧、预览、预渲染影片或代理时将使用的默认输出模块设置模板,请从“输出模块模板”对话框的“默认”区域的菜单中选择一个模板。
  • 要将当前已加载的所有输出模块模板保存到文件,请单击“全部保存”。
  • 要加载保存的输出模块模板文件,请单击“加载”,选择输出模块模板文件,然后单击“打开”。

将输出模块添加到渲染项或从渲染项中移除输出模块

  • 要向单个渲染项中添加具有默认设置的新输出模块,请单击渲染项的最后一个输出模块的“输出到”标题左侧的加号 (+)。
  • 要从渲染项中移除输出模块,请单击输出模块的“输出到”标题左侧的减号 (-)。
  • 要向选定渲染项中添加具有默认设置的新输出模块,请选择“合成”>“添加输出模块”。
  • 要复制选定的输出模块,请按 Ctrl+D (Windows) 或 Command+D (Mac OS)。

输出模块设置

有关使用“输出模块设置”对话框“色彩管理”区域中的控件的信息,请参阅分配输出颜色配置文件

格式

为输出文件或文件序列指定格式。

包括项目链接

指定是否在输出文件中包括链接到源 After Effects 项目的信息。在其他应用程序(如 Adobe Premiere Pro)中打开输出文件时,您可以使用“编辑原稿”命令在 After Effects 中编辑源项目。

包括源 XMP 元数据

指定是否在输出文件中包括用作渲染合成的源文件中的 XMP 元数据。XMP 元数据可以通过 After Effects 从源文件传递到素材项、合成,再传递到渲染和导出的文件。对于所有默认输出模块模板,“包括源 XMP 元数据”默认处于取消选择状态。(请参阅从 After Effects 导出 XMP 元数据。)

渲染后动作

指定 After Effects 在渲染合成之后要执行的动作。(请参阅渲染后动作。)

格式选项

打开一个对话框,可在其中指定格式特定的选项。

通道

输出影片中包含的输出通道。如果您选择“RGB + Alpha”,After Effects 将创建具有 Alpha 通道的影片,表示深度为“数百万种以上颜色”。并非所有编解码器均支持 Alpha 通道。

注意:

使用“数百万种以上颜色”、“数万亿种以上颜色”或“浮点+”颜色深度创建的所有文件都带有 Alpha 通道标记;描述 Alpha 通道的信息存储在文件中。因此,不必每次导入在 After Effects 中创建的项时都指定 Alpha 解释。

深度

指定输出影片的颜色深度。某些格式可能限制深度和颜色设置。

颜色

指定使用 Alpha 通道创建颜色的方式。从“预乘(遮罩)”或“直接(无遮罩)”中选择。(请参阅 Alpha 通道解释:预乘或直接。)

开始 #

指定序列起始帧的编号。例如,如果此选项设置为 38,After Effects 会将第一帧命名为 [file_name]_00038。“使用合成帧编号”选项会将工作区域的起始帧编号添加到序列的起始帧中。

调整大小

指定您的输出影片的大小。如果希望在调整帧大小时保持现有帧长宽比,请选择“锁定长宽比为”。在渲染测试时选择“调整大小后的品质: 低”,在创建最终影片时选择“调整大小后的品质: 高”。(请参阅缩小影片放大影片。)

裁剪

用于在输出影片的边缘减去或增加像素行或列。您可以指定要在影片的顶部、左侧、底部和右侧添加或减去的像素行或列数。使用正值进行裁剪,使用负值添加像素行或列。选择“目标区域”仅导出在“合成”或“图层”面板中选择的目标区域。(请参阅目标区域 (ROI)。)

注意:

通过向影片顶部添加一行像素,并从影片底部减去一行像素,您可以更改场序。

音频输出

指定采样率、采样深度(8 位或 16 位)和播放格式(单声道或立体声)。选择与输出格式的功能对应的采样率。选择 8 位采样深度用于计算机播放,选择 16 位采样深度用于 CD 和数字音频播放或用于支持 16 位播放的硬件。

注意:

有些格式的规范会对音频参数施加限制。在此情况下,“输出模块设置”对话框中的音频选项可能无法修改。此外,有些格式的音频选项在该格式的“导出设置”对话框中设置。例如,要设置 Windows Media 的音频输出选项,请单击“输出模块设置”对话框中的“格式选项”。

帧速率或帧尺寸不匹配警告

某些格式强制对帧尺寸和帧速率施加限制。

如果您选择此类受限制的输出格式,而您的合成、其渲染设置或其输出模块设置与限制不匹配,则 After Effects 将在“输出模块设置”对话框的底部显示一个黄色警告图标 以及“设置不匹配”消息。

单击警告图标可查看详细消息,其中描述应如何修改输出文件来满足格式限制。如果您不希望 After Effects 在输出模块中自动进行更改,可以返回去自己更改合成设置、渲染设置和输出模块设置。

有关输出模块限制以及帧速率、帧尺寸和像素长宽比不匹配警告的更多信息,请访问 Adobe 网站

影片的编码和压缩选项

压缩的本质是减小影片的大小,从而便于人们高效存储、传输和回放它们。压缩由编码器实现;解压缩由解码器实现。编码器和解码器共同称为编解码器。没有哪个编解码器或一组设置对于所有情况都是最好的。例如,最适合压缩卡通动画的编解码器对于压缩实景真人视频通常没什么效果。同样,最适合在慢速网络连接上播放的编解码器通常不是生产工作流程的中间阶段的最佳编解码器。有关以最终输出为目标规划您的工作的信息,请参阅规划您的工作

After Effects 使用 Adobe Media Encoder 的嵌入版本通过“渲染队列”面板对大多数影片格式进行编码。在使用“渲染队列”面板管理渲染和导出操作时,将自动调用 Adobe Media Encoder 的嵌入版本。Adobe Media Encoder 仅以“导出设置”对话框的形式出现,您可在该对话框中指定一些编码和输出设置。

注意:

用于管理 After Effects 输出模块中的导出设置的 Adobe Media Encoder 嵌入版本只提供完整单机版 Adobe Media Encoder 应用程序的部分功能。有关完整单机版 Adobe Media Encoder 应用程序的信息,请参阅 Adobe Media Encoder 帮助

对于大多数输出格式,您可以指定格式特定的编码和压缩选项。许多情况下,在您选择导出格式,或单击“输出模块设置”对话框中的“格式选项”按钮时,将打开一个对话框并显示这些选项。(请参阅输出模块和输出模块设置。)

QuickTime (MOV) 编码和压缩设置

  1. 在“渲染队列”面板中,单击带下划线的输出模块名称。
  2. 从“格式”菜单中选择“QuickTime”。
  3. 单击“视频输出”部分的“格式选项”。
  4. 在“QuickTime 选项”对话框中,根据特定的编解码器和您的需要,选择编解码器并设置选项:

    品质

    “品质”设置越高,图像品质越好,但影片文件会越大。

    关键帧间隔

    在 QuickTime 术语中,术语关键帧不同于在 After Effects“时间轴”面板中放置的随时间更改的关键帧。在 QuickTime 中,关键帧是影片中按固定间隔出现的帧。在压缩期间,它们作为完整帧存储。分隔这些关键帧的每个中间帧都会与前一帧比较,只有更改的数据会被存储。使用关键帧可大幅减小影片大小,同时大幅增大编辑和渲染影片时所需的内存。关键帧之间的间隔越短,搜寻和倒序播放的速度越快,但会显著增大文件的大小。

    帧重新排序

    有些编解码器允许不按顺序对帧进行编码和解码,以提高存储效率。

    注意:有关 QuickTime 的更多信息,请参阅 Apple 网站

     

  5. 单击“确定”。
  6. 在“输出模块设置”对话框中指定其他设置。

渲染后动作

您可以使用渲染后动作来自动执行在合成得到渲染之后发生的简单任务。

使用渲染后动作的常见示例是通过预渲染使用:选择“合成”>“预渲染”将选定合成添加到渲染队列中,并将“渲染后动作”选项设置为“导入和替换用法”。

注意:

在“输出模块”组中选择“渲染后动作”选项,因此请注意,更改输出模块模板也可能会更改渲染后动作选项。(请参阅输出模块和输出模块设置。)

  1. 通过单击“输出模块”标题左侧的箭头,在“渲染队列”面板中展开“输出模块”组。
  2. 从“渲染后动作”菜单选择以下选项之一:

    不执行任何渲染后动作。此选项是默认值。

    导入

    在渲染完成时将渲染的文件作为素材项导入项目。

    导入和替换用法

    将渲染的文件导入项目,并将其替换为指定的项。将关联器拖到“项目”面板项中要替换的项上以指定该项。

    注意:

    使用“导入和替换用法”选项以创建一系列相关的渲染项。例如,您可以将一个渲染项设置为使用监视文件夹和多个计算机来创建静止图像序列,然后下一个渲染项就可以从该静止图像序列渲染单个影片文件。(请参阅使用监视文件夹和渲染引擎进行网络渲染。)

    设置代理

    将渲染的文件设置为指定项的代理。将关联器拖到“项目”面板中的项上以指定该项。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略