图层概述

图层是构成合成的元素。如果没有图层,合成就只是一个空帧。可根据需要使用许多图层来创建合成。某些合成包含数千个图层,而某些图层仅包含一个图层。

After Effects 中的图层类似于 Adobe Premiere Pro 中的轨道。主要差异是每个 After Effects 图层不能以多个素材项目作为其源,而一个 Premiere Pro 轨道通常包含多个剪辑。After Effects 中的图层还类似于 Photoshop 中的图层,尽管用于操作图层的接口不同。在 After Effects 中的“时间轴”面板中操作图层类似于在 Photoshop 中的“图层”面板中操作图层。

您可以创建多种图层:

  • 基于您导入的素材项目(例如,静止图像、影片和音频轨道)的视频和音频图层

  • 您在 After Effects 内创建的用来执行特殊功能(例如,摄像机、光照、调整图层和空对象)的图层

  • 基于您在 After Effects 内创建的纯色素材项目的纯色图层

  • 包含您在 After Effects 内创建的可视元素的合成图层,例如,形状图层和文本图层

  • 预合成图层,它们使用合成作为其源素材项目

在修改图层时,您不会影响其源素材项目。您可以将同一个素材项目用作多个图层的源并在每个实例中以不同的方式使用素材。(请参阅导入和解释素材项目。)

对一个图层所做的更改不会影响其他图层,除非您明确关联了这些图层。例如,您可以为一个图层移动、旋转和绘制蒙版,而不会干扰合成中的任何其他图层。

After Effects 会自动对合成中的所有图层进行编号。默认情况下,这些编号显示在“时间轴”面板中,位于图层名称旁边。编号对应于该图层在堆叠顺序中的位置。当堆叠顺序更改时,After Effects 会相应地更改所有编号。图层堆叠顺序影响渲染顺序,因此会影响针对预览以及最终输出对合成进行渲染的方式。(请参阅渲染顺序和折叠变换。)

“图层”、“合成”和“时间轴”面板中的图层

在将图层添加到合成之后,您可以在“合成”面板中重新放置图层。在“时间轴”面板中,您可以更改图层的持续时间、开始时间和图层在图层堆叠顺序中的位置。您还可以在“时间轴”面板中更改图层的任何属性。(请参阅“时间轴”面板中的图层属性。)

您可以在“合成”面板或“图层”面板中执行许多任务,例如绘制蒙版。不过,其他任务(例如跟踪运动和使用绘画工具)必须在“图层”面板中执行。

“图层”面板显示在向某个图层应用任何变换之前的该图层。例如,“图层”面板不显示修改图层的“缩放”属性后的结果。要在包含其他图层和变换结果的上下文中查看某个图层,请使用“合成”面板。

未基于源素材项目的图层是合成图层。合成图层包括文本图层和形状图层。您无法在“图层”面板中打开合成图层。不过,您可以在“图层”面板中预合成某个合成图层以及打开预合成。

注意:

要在“图层”面板中查看对图层的更改(例如蒙版或效果),请在“图层”面板中选择“渲染”。取消选择“渲染”可查看原始的未更改的图层。

打开图层和图层源

  • 要在“图层”面板中打开预合成图层之外的图层,请双击该图层,或者选中该图层并选择“图层”>“打开图层”。

  • 要在“合成”面板中打开预合成图层的源合成,请双击该图层,或选择该图层并选择“图层”>“打开合成”。

  • 要打开图层的源素材项目,请按住 Alt 键 (Windows) 或 Option 键 (Mac OS) 并双击该图层,或选择该图层并选择“图层”>“打开图层源”。

注意:

如果您右键单击 (Windows) 或在按住 Control 键的同时单击 (Mac OS) 某个图层,则可以选择“打开素材”或“打开合成”来打开图层的源项目。

  • 要在“图层”面板中打开某个预合成图层,请在按住 Alt 键的同时双击 (Windows) 或在按住 Option 键的同时双击 (Mac OS) 该图层,或者选中该图层并选择“图层”>“打开图层”。

从素材项目创建图层或更改图层源

您可以在“项目”面板中基于任何素材项目(包括其他合成)来创建图层。在将素材项目添加到合成后,您可以修改生成的图层以及使其动态化。

在将某个合成添加到另一个合成时,您实际上是创建了使用您添加的合成作为其源的一个图层。(请参阅预合成、嵌套和预渲染。)

“静止素材”首选项设置(“首选项”>“导入”)控制使用静止素材项目作为其源的图层的默认持续时间。默认情况下,在您创建以静止图像作为其源的图层时,该图层的持续时间是合成的持续时间。在创建图层后,您可以通过修剪图层来更改其持续时间。

注意:

默认情况下,新图层从合成持续时间的开头开始。您还可以通过取消选择“在合成开始时创建图层”首选项(“编辑”>“首选项”>“常规”(Windows) 或“After Effects”>“首选项”>“常规”(Mac OS))来选择让新图层在当前时间开始。

通常,在将图层添加到合成之后的下一个步骤是对图层进行缩放和定位以使其适合帧。(请参阅缩放或翻转图层。)

基于一个或多个素材项目创建图层

当基于多个素材项目创建图层时,图层将按照在“项目”面板中选择它们的顺序显示在“时间轴”面板中的图层堆叠顺序中。

  1. 在“项目”面板中选择一个或多个素材项目和文件夹。
  2. 执行以下操作之一:
    • 将所选的素材项目拖到“合成”面板中。

    注意:

    在拖动时按住 Shift 键可以将图层对齐到合成的中心或边缘。

    • 将所选的素材项目拖到“时间轴”面板中。将素材项目拖到图层轮廓中时,一个高亮条将指示当您释放鼠标按钮时图层的外观。如果您将素材项目拖到时间图表区域上方,一个时间标记将指示当您释放鼠标按钮时图层入点的位置。

    注意:

    在拖动时按住 Shift 键可将入点对齐到当前时间指示器。

    • 将所选素材项目拖到“项目”面板中的合成名称或图标,或者按 Ctrl+/ (Windows) 或 Command+/ (Mac OS)。新图层会立即在选定图层上方创建,且位于合成中心。如果未选择任何图层,则新图层会在图层堆栈的最上方创建。

基于修剪的素材项目创建图层

在将基于移动的图像素材项目的图层插入到合成中之前,您可以在“素材”面板中修剪该素材项目。

  1. 在“项目”面板中双击某个素材项目以在“素材”面板中将其打开。(请参阅在“素材”面板中查看素材项目。)

  2. 将“素材”面板中的当前时间指示器移到要用作图层入点的帧,然后单击“素材”面板底部的“设置入点”按钮。

  3. 在“素材”面板中将当前时间指示器移动到您希望用作图层的出点的帧,并单击位于“素材”面板底部的“设置出点”按钮。
  4. 要基于此修剪的素材项目创建图层,请单击位于“素材”面板底部的“编辑”按钮:

    叠加编辑

    在图层堆叠顺序的顶部创建图层,入点设置为“时间轴”面板中的当前时间。

    波纹插入编辑

    也可以在图层堆叠顺序的顶部创建图层,入点设置为“时间轴”面板中的当前时间,但拆分所有其他图层。新创建的拆分图层在时间上将后移,以便其入点与插入图层的出点位于相同的时间。

使用对另一个素材项目的引用替换图层源

  1. 在“时间轴”面板中选择一个或多个图层
  2. 按住 Alt 键 (Windows) 或 Option 键 (Mac OS) 将“项目”面板中的素材项目拖动到“时间轴”面板中的所选图层上。

纯色图层和纯色素材项目

您可以创建任何纯色和任何大小(最大 30,000x30,000 像素)的图层。纯色图层以纯色素材项目作为其源。纯色图层和纯色素材项目通常都称作纯色

纯色与任何其他素材项目一样工作:您可以添加蒙版、修改变换属性,以及向使用纯色作为其源素材项目的图层应用效果。使用纯色为背景着色,作为复合效果的控制图层的基础,或者创建简单的图形图像。

纯色素材项目自动存储在“项目”面板中的“纯色”文件夹中。

要了解如何修改纯色文件夹以更好地组织项目,请参阅增强的纯色文件夹组织

Jeff Almasol 在其 redefinery 网站上提供了一个脚本,您可以使用它在“项目”面板中重命名所选纯色素材项目。例如,您可以使用该脚本在名称中包括像素尺寸、长宽比和 RGB 颜色值。

注意:

在 After Effects CS6 和更高版本中,新的纯色图层为 17% 灰色 (45/255),因此它们可以与新的默认的较暗用户界面亮度形成对比

创建纯色图层或纯色素材项目

  • 要创建纯色素材项目,但不在合成中为其创建图层,请选择“文件”>“导入”>“纯色”。
  • 要创建纯色素材项目并在当前合成中为其创建一个图层,请选择“图层”>“新建”>“纯色”或者按 Ctrl+Y (Windows) 或 Command+Y (Mac OS)。

    在创建纯色图层时,要创建适合合成的图层,请选择“制作合成大小”。

修改纯色图层和纯色素材项目的设置

  • 要为选定的纯色图层或素材项目修改设置,请选择“图层”>“纯色设置”。

    要向使用素材项目的所有纯色图层应用更改,请选择“影响使用此纯色的所有图层”。如果不选择此选项,则会创建一个素材项目,这将成为所选图层的源。

调整图层

在向某个图层应用效果时,该效果将仅应用于该图层,不应用于其他图层。不过,如果您为某个效果创建了一个调整图层,则该效果可以独立存在。应用于某个调整图层的任何效果会影响在图层堆叠顺序中位于该图层之下的所有图层。位于图层堆叠顺序底部的调整图层没有可视结果。

因为调整图层上的效果应用于位于其下的所有图层,所以它们非常适用于同时将效果应用于许多图层。在其他方面,调整图层的行为与其他图层一样,例如,您可以将关键帧或表达式与任何调整图层属性一起使用。

注意:

更准确的描述是,调整图层将效果应用于基于图层堆叠顺序中位于调整图层之下的所有图层创建的合成。因此,与分别将相同的效果应用于各个底层图层相比,将效果应用于调整图层可以改进渲染性能。

注意:

如果希望将某个效果或变换应用于许多图层,则可以预合成这些图层,然后将效果或变换应用于预合成图层。(请参阅预合成图层。)

在调整图层上使用蒙版可以将效果仅应用于部分底层图层。您可以使蒙版动态化以跟随底层图层中的移动主体。

  • 要创建调整图层,请选择“图层”>“新建”>“调整图层”,或者按 Ctrl+Alt+Y (Windows) 或 Command+Option+Y (Mac OS)。
  • 要将选定的图层转换为调整图层,请在“时间轴”面板中选择图层的“调整图层”开关 ,或者选择“图层”>“开关”>“调整图层”。

注意:

要将调整图层转换为普通图层,您可以取消选择图层的“调整图层”开关。

关于调整图层的在线资源

Andrew Kramer 在他的 Video Copilot 网站上提供了一个视频教程,他通过该视频教程展示了如何使用调整图层将效果仅应用较短的持续时间以及仅应用于影片的特定部分。

Eran Stern 在 Creative COW 网站上提供了一个视频教程,其中演示了如何将光用作调整图层,以精确地控制哪些光影响哪些图层。

Lloyd Alvarez 在他的 After Effects Scripts 网站上提供了一个脚本,该脚本用于在每个选定的图层上创建一个调整图层,将每个新调整图层修剪为选定图层的持续时间。

创建图层和新的 Photoshop 素材项目

当您从 After Effects 创建 Adobe Photoshop 文件时,Photoshop 将启动并创建一个 PSD 文件。该 PSD 文件包含一个空的 Photoshop 图层,该图层具有与您的合成相同的尺寸,具有合适的标题安全和动作安全参考线。PSD 文件的色位深度与您的 After Effects 项目的色位深度相同。

新创建的 PSD 文件作为素材项目自动导入到 After Effects 中。您在 Photoshop 中保存的任何更改将出现在 After Effects 的素材项目中。

  • 要创建 Photoshop 素材项目并将其用作当前合成中某个新图层的源,请选择“图层”>“新建”>“Adobe Photoshop 文件”。Photoshop 图层将添加为您的合成中的顶部图层。
  • 要使用最近打开的合成的设置创建 Photoshop 素材项目,且不将其添加到合成中,请选择“文件”>“新建”>“Adobe Photoshop 文件”。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略