关于 XMP 元数据

简单来说,元数据就是有关数据的数据。实际上,元数据是关于文件的一组标准化信息,如作者姓名、分辨率、色彩空间、版权以及应用于文件的关键字。例如,多数摄像机会在视频文件中附加一些基本信息,如日期、持续时间和文件类型。您还可以在 OnLocation 中或 Adobe Premiere Pro 的捕获阶段输入其他的元数据作为拍摄清单信息。您可以添加具有位置、作者姓名和版权等属性的其他元数据。因为您可以跨 Adobe Creative Suite 应用程序共享、查看和使用该元数据,所以您可以使用该信息来简化工作流和组织文件。

可扩展元数据平台 (XMP) 是 Adobe 应用程序使用的元数据标准。以其他格式(例如 Exif、IPTC (IIM)、GPS 和 TIFF)存储的元数据是用 XMP 同步和描述的,因此您可以更加轻松地查看和管理元数据。例如,使用 Adobe Camera Raw 对图像进行的调整便存储为 XMP 元数据。XMP 标准基于 XML。

元数据架构是一个由特定于给定工作流的属性构成的集合。例如,“动态媒体”架构包括为数字视频项目定制的场景和拍摄位置等属性。与之相对,Exif 架构则包括为数字摄影定制的曝光时间和光圈值等属性。Dublin Core 架构中提供了更多常规属性(如日期和标题)。要查看包含特定架构或属性相关信息的工具提示,请在“元数据”面板中,将鼠标指针置于相应架构或属性的上方。您可以使用“元数据”面板中的命令创建自己的架构,并且可以导入架构并将其作为 XML 文件与他人共享。

元数据分为两个常规类别:静态元数据时间元数据。静态元数据是应用于整个资源的元数据。例如,视频剪辑的版权和作者信息便应用于整个剪辑。时间元数据是与动态媒体资源中的特定时间相关联的元数据。例如,Soundbooth 中的节拍标记,以及由 Soundbooth 和 Premiere Pro 中的“语音搜索”功能生成的元数据都是时间元数据。

Adobe Story 也可将来自电影脚本(脚本)的信息转换为 XMP 元数据,该数据可以实现拍摄手稿、拍摄清单等内容的自动创建。

注意:

要从 After Effects 内部启动 Adobe Story 服务,请选择“文件”>“转到 Adobe Story”。

您可以在 Adobe Bridge 中查看文件的静态 XMP 元数据。

After Effects 脚本和表达式可以读取和使用存储在标记中的数据。因为源素材项目的 XMP 元数据可以转换为图层标记,所以表达式和脚本可以与 XMP 元数据结合使用。脚本也可以在 After Effects 上下文外部对文件的 XMP 元数据进行操作,以便自动执行常见任务和创建新任务。

包含在 F4V 或 FLV 文件中的 XMP 元数据可由 ActionScript 读取和使用,因此您可以使用 XMP 元数据向在 Flash Player 中播放的视频中添加交互设置。此功能的一个应用是在 FLV 文件中搜索时间元数据,以允许用户在对话提到某个特定单词时或与特定时间元数据元素关联的某个其他时间开始播放。

注意:

要有选择地添加和移除文件的(精简)XMP 元数据,请使用导出模板和 Adobe Media Encoder 中的“元数据导出”对话框。

嵌入 XMP 元数据与在 Sidecar 文件中包括 XMP 元数据

大多数情况下,文件的 XMP 元数据存储在该文件本身中。如果不能将信息直接写入文件,XMP 元数据将存储在一个称为 Sidecar 文件的单独文件中,其文件扩展名为 .xmp。有关 After Effects 可将 XMP 元数据直接写入哪些文件格式的信息,请参阅 After Effects 中的 XMP 元数据

大多数情况下,即使将文件转换为其他格式(例如,从 PSD 转换为 JPG),XMP 元数据仍与该文件保存在一起。在将文件置于 Adobe Creative Suite 应用程序的文档或项目中时,XMP 元数据也会保留下来。

有关 XMP 元数据的在线资源

有关 XMP 规范、将 XMP 元数据与您的软件和工作流集成、XMP SDK(软件开发工具包)以及与 XMP 元数据有关的论坛等信息,请访问 Adobe 网站的 XMP 开发人员中心部分。

After Effects 中的 XMP 元数据

有关 XMP 元数据的介绍,请参阅关于 XMP 元数据

在 After Effects 导入包含关联 XMP 元数据的文件时,您可以在“元数据”面板中查看静态元数据、将时间元数据转换为图层标记、使用元数据加快您在 After Effects 中的工作进度,以及在输出文件中包括元数据。

After Effects 脚本界面提供了使用 XMP 元数据以及与其交互的其他工具。

将包含 XMP 元数据的文件导入 After Effects

After Effects 可以下列多种格式导入 XMP 元数据:

  • 摄像机格式:AVCHD、HDV、P2、XDCAM、XDCAM EX

  • 图像格式:GIF、JPEG、PNG、PostScript、TIFF

  • 普通多媒体容器格式:FLV、F4V、QuickTime (MOV)、Video for Windows (AVI)、Windows Media(ASF、WAV)

  • 创作格式:InDesign 文档、Photoshop 文档 (PSD)、适用于 Adobe 应用程序的其他本机文档格式

  • MPEG 格式(MP3、MPEG-2、MPEG-4)

  • SWF

在您导入包含 XMP 元数据的文件时,After Effects 将在从源文件读取元数据期间显示“从素材读取 XMP 元数据”状态消息。

与每个资源都有关的一条特别有用的元数据就是其唯一的 ID 号码,它是一个将该资源与工作流的各个阶段中的所有其他资源区分开来的值。即使文件名已经更改,应用程序也可以借助唯一 ID 值将某个文件识别为以前遇到过的同一文件。使用这些唯一 ID 值的一个好处是,每个应用程序可以使用该信息管理缓存的预览和匹配的音频文件,从而不再进行额外的渲染和匹配。

XMP 所用的 ID 值是全局唯一标识符 (GUID),它们是 16 字节随机数,常用于确保值的唯一性。

如果在“媒体和缓存”首选项类别中选择“导入时将 XMP ID 写入文件”首选项,则在 After Effects 导入 XMP ID 值 时,会将它们写入源文件。此首选项设置也影响其他 Adobe 应用程序;有关详细信息,请参阅“首选项”对话框中的帮助文本。如果文件已具有 XMP ID,则 After Effects 不会写入新 ID,也不会进行任何更改。通常,由最新版本的 Adobe 应用程序创建的文件已具有 XMP ID。

默认情况下启用“导入时将 XMP ID 写入文件”首选项。

注意:

“导入时将 XMP ID 写入文件”首选项仅控制在导入唯一 ID 值时是否自动将这些值写入文件。该首选项并不控制在其他情况下(例如,当您在“元数据”面板中编辑元数据时)是否将 XMP 元数据写入文件。

注意:

因为将 ID 写入文件被认为是一项修改操作,所以在首次导入源文件时,可能更新该文件的修改日期。

在 After Effects 中处理 XMP 元数据

元数据面板

在 After Effects 中,“元数据”面板(“窗口”>“元数据”)仅显示静态元数据。项目元数据显示在该面板的顶部,文件元数据显示在底部。时间元数据仅作为图层标记显示在 After Effects 中。

当您打开“元数据”面板时,该面板中将显示项目元数据。您可以在任何类别的元数据中添加和更改信息。如果选择“包括源 XMP 元数据”输出模块选项,则当选择项目文件并且该文件还嵌入使用渲染队列渲染和导出的文件中时,该信息将显示在 Bridge 中。

要在“元数据”面板中查看文件元数据,您必须首先在“项目”面板中选择文件。然后您便可以在任何类别的元数据中添加或更改信息。如果您选择多个文件,则将对所有选定文件应用您所进行的更改。对源文件元数据进行的任何更改将立即写入源文件。

要更改在“元数据”面板中显示的元数据类别和字段,请从“元数据”面板菜单中选择“项目元数据显示”首选项或“文件元数据显示”首选项。

将 XMP 元数据转换为图层标记

在您基于包含 XMP 元数据的素材项目创建图层时,可以将时间元数据转换为图层标记。

  1. 要将 XMP 元数据自动转换为图层标记,请在“媒体和磁盘缓存”首选项类别中选择“从素材 XMP 元数据创建图层标记”首选项。

在此转换期间,After Effects 将显示“从素材读取 XMP 标记”状态消息。

与任何其他图层标记一样,这些图层标记是完全可编辑的。(请参阅图层标记和合成标记。)

根据源文件的 XMP 元数据对图层标记所做的更改不影响源文件中的 XMP 元数据。

注意:

要将某图层的图层标记还原为从该图层的源 XMP 元数据读取的图层标记,请右键单击 (Windows) 或按住 Control 键并单击 (Mac OS) 该图层上的任何标记,然后选择“从源更新标记”。该命令还会移除您已经添加到该图层中的任何标记。如果您在创建图层时没有选择“从素材 XMP 元数据创建图层标记”首选项,则可以使用该命令从 XMP 元数据手动创建图层标记。

有关结合使用表达式和图层标记内容的信息,请参阅 MarkerKey 属性(表达式引用)

从 After Effects 导出 XMP 元数据

在渲染和导出某合成时,您可以将 XMP 元数据写入输出文件,该输出文件包括该合成的源文件中的所有 XMP 元数据。其中包括合成中的所有合成标记和图层标记、合成中图层所基于的源文件中的所有 XMP 元数据、“时间轴”面板和“项目”面板的“注释”列中的注释,以及合成所属项目的项目级 XMP 元数据。将以递归方式处理嵌套合成中的 XMP 元数据并将其包含在输出中。

要将所有 XMP 元数据写入输出文件,请在输出文件的输出模块设置中选择“包括源 XMP 元数据”。如果取消选择“包括源 XMP 元数据”,则写入输出文件的唯一 XMP 元数据将只有唯一 ID。(请参阅输出模块和输出模块设置。)

注意:

当“包括源 XMP 元数据”启动时,在某些情况下,渲染和导出时间会较长,原因是读取和组装源文件中的 XMP 元数据很费时。因此,默认情况下关闭该选项。

除了在 After Effects 项目(.aep、.aepx)文件以及供 Adobe 应用程序使用的源文档(如 .psd)中存储 XMP 元数据之外,After Effects 还可将 XMP 元数据直接写入具有以下众多容器格式的文件:

  • QuickTime (.mov)

  • Video for Windows (.avi)

  • Windows Media (.wmv)

注意:

对于某些 MPEG 格式,XMP 元数据将写入 sidecar (.xmp) 文件。

对于其他类型的文件,“包括源 XMP 元数据”选项不可用。

当您渲染和导出文件并在输出文件中包括源 XMP 元数据时,XMP 元数据是在渲染合成的第一帧之前写入输出文件的。如果“渲染队列”面板的“渲染细节”部分已打开,After Effects 会在对要渲染的合成中使用的源文件中的元数据进行编译时显示“从源搜集 XMP 元数据”状态消息。

写入文件的 XMP 元数据将插入一个与音频和视频数据本身分离的 XML 数据结构中。就像查看其他任何纯文本数据一样,您可以查看该纯文本 XML 数据,并且可以通过各种脚本使用和操作该数据。

注意:

After Effects 将 startTimecodealtTimecode 值写入 XMP 元数据中。您可以在“元数据”面板的“动态媒体”架构中的“开始时间码”和“替代时间码”字段中查看这些值。

将 XMP 元数据重新导入 After Effects

在将已使用“包括源 XMP 元数据”选项从 After Effects 渲染和导出的文件导入 After Effects 时,如果该文件用作合成中图层的源,则写入输出文件的所有 XMP 元数据可作为图层标记。该 XMP 元数据在“元数据”面板中不可见。

注意:

在导入包含 XMP 元数据的文件并使用该文件作为图层源时,After Effects 将过滤多余的 XMP 元数据。这样在 After Effects 中使用从同一项目渲染和导出的文件时(例如,在对项目的一部分进行预渲染时),可防止积累重复的标记。

关于文件、剪辑和项目 XMP 元数据

大体上,各 Adobe 视频和音频应用程序处理 XMP 元数据的方式非常相似。不过,有一些小差别,这反映了每个应用程序解决的唯一工作流阶段。当搭配使用多个应用程序时,了解这些方法的细微差别有助于您充分利用元数据。

Adobe OnLocation 和 Encore 针对所有资源提供了一组元数据属性。但是,Adobe Premiere ProAfter Effects 和 Soundbooth 将“元数据”面板分成了若干个单独部分,用于不同的资源类型。

Adobe Premiere Pro

将元数据分为以下部分:

剪切

显示您在“项目”面板或“时间轴”面板中选择的剪辑实例的属性。此元数据存储在项目文件中,因此它只显示在 Adobe Premiere Pro 中。

文件

显示您在“项目”面板中选择的源文件的属性。此元数据直接存储在源文件中,因此,它显示在其他应用程序中,包括 Adobe Bridge。

After Effects

将元数据分为以下部分:

项目

显示整个项目的属性。如果在“输出模块设置”对话框中选择“包含源 XMP 元数据”,此信息将嵌入从“渲染队列”输出的文件。

文件

显示您在“项目”面板中选择的源文件的属性。(如果选择一个代理,会显示实际文件的属性。)

对于 After Effects,“项目”和“文件”属性均直接存储在文件中,因此您可以在 Adobe Bridge 中访问此元数据。

文件

显示当前所示音频或 ASND 文件的属性。此元数据会直接存储在这些文件中,因此将显示在其他应用程序中。(但是,Adobe Bridge 不会显示 ASND 文件的元数据。)

剪切

显示在“编辑器”面板中选择的多轨道剪辑的属性。此元数据存储在包含的 ASND 文件中,因此只显示在 Soundbooth 中。

显示或隐藏 XMP 元数据

要为您的工作流优化“元数据”面板,请显示或隐藏整个架构或单个属性,仅显示那些需要的项。

  1. 从“元数据”面板的选项菜单 ,选择“元数据显示”。

  2. 要显示或隐藏架构或属性,请在列表中选择或取消选择。

保存、切换或删除元数据组

如果您使用多个工作流,每个工作流需要不同的显示元数据组,您可以保存这些组并在它们之间进行切换。

  1. 从“元数据”面板的选项菜单 ,选择“元数据显示”。

  2. 执行以下任一操作:

    • 要保存一组自定义显示元数据,请单击“保存设置”。然后输入名称,单击“确定”。

    • 要显示以前保存的一组元数据,请从菜单中选择。

    • 要删除以前保存的一组元数据,请从菜单中选择,然后单击“删除设置”。

创建架构和属性

如果您有默认元数据选项不能满足要求的唯一自定义工作流,请创建您自己的架构和属性。

  1. 从“元数据”面板的选项菜单 ,选择“元数据显示”。

  2. 单击“新建架构”,然后输入名称。

  3. 在列表中,单击架构名称右侧的“添加属性”。

  4. 输入属性名称,然后选择以下类型之一:

    整数

    显示您通过拖动或单击来更改的整数。

    实数

    显示您通过拖动或单击来更改的分数。

    文本

    显示文本框(用于类似于“地点”的属性)。

    布尔值

    显示复选框(用于“打开”或“关闭”属性)。

编辑 XMP 元数据

在 Adobe 视频应用程序中,“元数据”面板和“项目”面板中所链接的属性名称相似。但是,“元数据”面板提供了更加广泛的属性,可让您同时为多个文件编辑这些属性。

注意:

Soundbooth 使用“文件”面板,而不是“项目”面板。

  1. 选择所需的文件或剪辑。

  2. 在“元数据”面板中,编辑文本或调整所需的值。

    如果选择了多个项目,此面板按如下方式显示属性:

    • 如果所有项目的某个属性都匹配,则显示匹配条目。

    • 如果属性不同,则显示<Multiple Values>。要应用匹配值,请单击文本框,然后进行键入。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略