用户指南 取消(C)

图层属性

  1. After Effects 用户指南
  2. Beta 版
    1. Beta 版项目概述
    2. After Effects Beta 版主页
    3. Beta 版中的功能
      1. “属性”面板(Beta 版)
  3. 快速入门
    1. After Effects 快速入门
    2. After Effects 的新增功能 
    3. 发行说明 | After Effects
    4. After Effects 系统要求
    5. After Effects 中的键盘快捷键
    6. 支持的文件格式 | After Effects
    7. 硬件建议
    8. 适用于 Apple Silicon 的 After Effects
    9. 规划和设置
    10. 设置和安装
  4. 工作区
    1. 常规用户界面项
    2. 了解 After Effects 界面
    3. 工作流程
    4. 工作区、面板和查看器
  5. 项目与合成
    1. 项目
    2. 合成基础知识
    3. 预合成、嵌套和预渲染
    4. 使用合成分析器查看详细的性能信息
    5. CINEMA 4D 合成渲染器
  6. 导入素材
    1. 准备并导入静止图像
    2. 从 After Effects 和 Adobe Premiere Pro 导入
    3. 导入和解释视频与音频
    4. 准备和导入 3D 图像文件
    5. 导入和解释素材项目
    6. 使用素材项目
    7. 使用“场景编辑检测”检测编辑点
    8. XMP 元数据
  7. 文本和图形
    1. 文本
      1. 设置字符格式和“字符”面板
      2. 文本效果
      3. 创建和编辑文本图层
      4. 设置段落格式和“段落”面板
      5. 凸出文本和形状图层
      6. 为文本设置动画
      7. 文本动画的示例和资源
      8. 实时文本模板
    2. 动态图形
      1. 在 After Effects 中使用动态图形模板
      2. 使用表达式在动态图形模板中创建下拉列表
      3. 使用“基本属性”创建动态图形模板
      4. 替换动态图形模板和基本属性中的图像和视频
  8. 绘图、绘画和路径
    1. 形状图层、路径和矢量图形的概述
    2. 绘画工具:笔刷、仿制图章和橡皮擦
    3. 将形状描边椎体化的方法
    4. 形状图层的形状属性、绘画操作和路径操作
    5. 使用“位移路径”形状效果更改形状
    6. 创建形状
    7. 创建蒙版
    8. 使用内容识别填充面板,移除视频中的对象
    9. Roto 笔刷和调整遮罩
  9. 图层、标记和摄像机
    1. 选择和排列图层
    2. 混合模式和图层样式
    3. 3D 图层
    4. 图层属性
    5. 创建图层
    6. 管理图层
    7. 图层标记和合成标记
    8. 摄像机、光和目标点
  10. 动画、关键帧、运动跟踪和抠像
    1. 动画
      1. 动画基础知识
      2. 使用人偶工具制作动画
      3. 管理形状路径和蒙版并对其进行动画制作
      4. 使用 After Effects 为 Sketch 和 Capture 形状制作动画
      5. 分类动画工具
      6. 使用数据驱动的动画
    2. 关键帧
      1. 关键帧插值
      2. 设置、选择和删除关键帧
      3. 编辑、移动和复制关键帧
    3. 运动跟踪
      1. 跟踪和稳定运动
      2. 人脸跟踪
      3. 蒙版跟踪
      4. 蒙版引用
      5. 速度
      6. 时间拉伸和时间重映射
      7. 时间码和时间显示单位
    4. 抠像
      1. 抠像
      2. 抠像效果
  11. 透明度与合成
    1. 合成和透明度概述及资源
    2. Alpha 通道、蒙版和遮罩
  12. 调整颜色
    1. 颜色基础知识
    2. 使用 Adobe Color Themes 扩展
    3. 色彩管理
    4. 颜色校正效果
  13. 效果和动画预设
    1. 效果和动画预设概述
    2. 效果列表
    3. 模拟效果
    4. 风格化效果
    5. 音频效果
    6. 扭曲效果
    7. 透视效果
    8. 通道效果
    9. 生成效果
    10. 过渡效果
    11. 果冻效应修复效果
    12. 模糊和锐化效果
    13. 3D 通道效果
    14. 实用效果
    15. 遮罩效果
    16. 杂色和颗粒效果
    17. 保留细节放大效果
    18. 旧版效果
  14. 表达式和自动化
    1. 表达式
      1. 表达式基础知识
      2. 了解表达式语言
      3. 使用表达式控件
      4. JavaScript 与旧版 ExtendScript 表达式引擎之间的语法差别
      5. 正在编辑表达式
      6. 表达式错误
      7. 使用表达式编辑器
      8. 使用表达式编辑和访问文本属性
      9. 表达式语言引用
      10. 表达式示例
    2. 自动化
      1. 自动化
      2. 脚本
  15. 沉浸式视频、VR 和 3D
    1. 在 After Effects 中构造 VR 环境
    2. 应用沉浸式视频效果
    3. 用于 VR/360 视频的合成工具
    4. 跟踪 3D 摄像机运动
    5. 使用 3D 设计空间
    6. 3D 变换 Gizmo
    7. 使用 3D 动画执行更多操作
    8. 使用实时引擎实时预览对 3D 设计的更改
    9. 向图形添加响应式设计 
  16. 视图和预览
    1. 预览
    2. 使用 Mercury Transmit 进行视频预览
    3. 修改和使用视图
  17. 渲染和导出
    1. 渲染和导出基础知识
    2. 将 After Effects 项目导出为 Adobe Premiere Pro 项目
    3. 转换影片
    4. 多帧渲染
    5. 自动渲染和网络渲染
    6. 渲染和导出静止图像及静止图像序列
    7. 在 After Effects 中使用 GoPro CineForm 编解码器
  18. 使用其他应用程序
    1. Dynamic Link 和 After Effects
    2. 使用 After Effects 和其他应用程序
    3. After Effects 中的同步设置
    4. After Effects 中的 Creative Cloud Libraries
    5. 增效工具
    6. CINEMA 4D 和 Cineware
  19. 协作:Frame.io 和团队项目
    1. 在 Premiere Pro 和 After Effects 中协作
    2. Frame.io
      1. 安装和激活 Frame.io
      2. 将 Frame.io 与 Premiere Pro 和 After Effects 配合使用
      3. 常见问题解答
    3. 团队项目
      1. 开始使用团队项目
      2. 创建团队项目
      3. 使用团队项目进行协作
  20. 内存、存储、性能
    1. 内存和存储
    2. 提高性能
    3. 首选项
    4. After Effects 的 GPU 和 GPU 驱动程序要求

“时间轴”面板中的图层属性

每个图层均具有属性,您可以修改其中许多属性并为其添加动画设置。每个图层具有一个基本属性组“变换”组,其中包括“位置”和“不透明度”属性。在您将某些功能添加到图层中时(例如,通过添加蒙版或效果,或通过将图层转换为 3D 图层),该图层将获得收集在属性组中的其他属性。

所有图层属性都是时间性的,它们会随着时间的推移更改图层。一些图层属性(例如“不透明度”)仅具有时间组件。一些图层属性(例如“位置”)还具有空间性,它们可以跨合成空间移动图层或其像素。

您可以扩展图层轮廓以显示图层属性并更改属性值。

大多数属性具有秒表 。可以为具有秒表的任何属性制作动画,也就是说,随着时间的推移更改这些属性。(请参阅关于动画、关键帧和表达式。)

图层缩略图中的扩展属性组

图层缩略图中的折叠属性组

“效果”属性组中的属性(效果属性)也是图层属性。也可在“效果控件”面板中修改许多效果属性。

在“时间轴”面板中显示或隐藏属性

  • 要展开或折叠属性组,请单击图层名称或属性组名称左侧的三角形。
  • 要展开或折叠某属性组及其所有子组,请按住 Ctrl 键 (Windows) 或 Command 键 (Mac OS),并单击三角形。
  • 要展开或折叠所选图层的所有组,请按 Ctrl+`(重音标记)(Windows) 或 Command+`(重音标记)(Mac OS)。
  • 要在“时间轴”面板中显示效果属性,请在“效果控件”面板中双击属性名称。
  • 要隐藏属性或属性组,请在“时间轴”面板中按住 Alt+Shift (Windows) 或 Option+Shift (Mac OS) 并单击相应名称。
  • 要在“时间轴”面板中仅显示所选属性或属性组,请按 SS。
注意:

使用画笔时,SS 快捷方式尤其有用。在“图层”面板中选择画笔,然后按 SS 可在“时间轴”面板中打开该画笔的属性组。

  • 要仅显示特定属性或属性组,请按其快捷键。(请参阅显示“时间轴”面板中的属性和组(键盘快捷键)。)
  • 要将属性或属性组添加到“时间轴”面板中所显示的属性中,请在按属性或属性组的快捷键时按住 Shift 键。
  • 要仅显示已根据其默认值修改的属性,请按 UU,或选择“动画”>“显示修改的属性”。
  • 要仅显示具有关键帧或表达式的属性,请按 U,或选择“动画”>“显示动画属性”。
注意:

U 和 UU 命令尤其适用于了解动画预设、模板项目或其他动画项目的工作方式,因为它们隔离了这些项目的设计人员所修改的属性。

您还可以在“时间轴”面板中筛选图层,以便仅显示其属性与搜索字符串匹配的图层。请参阅在“时间轴”、“项目”以及“效果和预设”面板中搜索和过滤

在“时间轴”面板中选择属性或属性组

选中的锚点

  • 要选择属性或属性组(包括所有值、关键帧和表达式),请在“时间轴”面板中单击图层轮廓中的名称。

在“时间轴”面板中复制属性或属性组

  • 要将属性从一个图层或属性组复制到另一个图层或属性组,请选择相应图层、属性或属性组,按 Ctrl+C (Windows) 或 Command+C (Mac OS),选择目标图层、属性或属性组,然后按 Ctrl+V (Windows) 或 Command+V (Mac OS)。
  • 要复制属性组,请选择属性组,然后按 Ctrl+D (Windows) 或 Command+D (Mac OS)。

    您只能复制一些属性组,其中包括形状、蒙版和效果。不过,您无法复制顶层属性组,例如“内容”、“蒙版”、“效果”和“变换”。如果您尝试复制顶层属性组,将复制整个图层。

从不包含任何关键帧的图层属性复制值

您可以将图层属性的当前值复制到另一个图层,即使原始图层不包含任何关键帧也是如此。

  1. 在“时间轴”面板中,显示包含要复制的值的图层属性。
  2. 单击图层属性的名称以选择它。
  3. 选择“编辑”>“复制”。
  4. 选择要将值粘贴到其中的图层。
  5. 如果目标图层包含关键帧,请将当前时间指示器移动到要将值粘贴到的时间。如果目标图层不包含任何关键帧,则新值将应用于图层的整个持续时间。
  6. 选择“编辑”>“粘贴”。

设置属性值

如果选择了多个图层,并且您更改了一个图层的属性,将为所有所选图层更改此属性。滑块、角度控制和其他一些属性控制仅在“效果控件”面板中可用。

注意:

要更改属性的单位,请右键单击 (Windows) 或按住 Control 键并单击 (Mac OS) 带下划线的值,选择“编辑值”,然后从“单位”菜单中进行选择。不同的属性类型具有不同的可用单位。您无法更改一些属性的单位。

  • 将指针置于带下划线的值上,然后向左或向右拖动。
  • 单击带下划线的值,输入新值,然后按 Enter 键 (Windows) 或 Return 键 (Mac OS)。
注意:

您可以为属性值和其他数字项输入简单算术表达式。例如,您可以输入 2*3 代替 6,输入 4/2 代替 2,输入 2e2 代替 200。在按特定数量从其原始值增加值时,此类项尤其有用。

  • 右键单击 (Windows) 或按住 Control 键并单击 (Mac OS) 带下划线的值并选择“编辑值”。
  • 向左或向右拖动滑块。
  • 单击角度控件中的一点,或拖动角度控制线。
注意:

在角度控制中单击之后,您可以拖动到它的外部以获得更高精度。

  • 要将属性值增加或减少 1 个单位,请单击带下划线的值,然后按向上箭头键或向下箭头键。要增加或减少 10 个单位,请在按向上箭头键或向下箭头键时按住 Shift 键。要增加或减少 0.1 个单位,请在按向上箭头键或向下箭头键时按住 Ctrl 键 (Windows) 或 Command 键 (Mac OS)。
  • 要将属性组中的属性重置为其默认值,请单击属性组名称旁边的“重置”。要重置单个属性,请右键单击 (Windows) 或按住 Control 键并单击 (Mac OS) 属性名称(不是值),然后从上下文菜单中选择“重置”。

    如果属性包含关键帧,则在当前时间中添加具有默认值的关键帧。

注意:

Alan Shisko 在其 Motion Graphics 'n Such 博客上提供了一个视频教程,其中演示了如何使用标签颜色和多个选项来同时快速更改多个图层的属性。

Charles Bordenave (nab) 在 After Effects Scripts 网站上提供了一个脚本,该脚本将所选图层的“变换”组中的属性设置为您设置的约束中的随机值。

可从 After Effects Scripts 网站上获得的 LockProperties 脚本仅锁定指定的属性,以便您可以防止意外更改。

图层锚点

变换围绕图层的锚点(有时称为变换点变换中心)发生(例如旋转和缩放)。默认情况下,大多数图层类型的锚点 位于图层的中心。

虽然有时您希望为锚点制作动画,但在开始进行动画制作之前,通常需要设置图层的锚点。例如,如果您要对每个身体部分组成一个图层的人的图像制作动画,则可能需要将每只手的锚点移动到手腕区域,以便手在整个动画期间围绕该点旋转。

注意:

平移和扫描大图像的最简单方法是对“锚点”和“缩放”属性制作动画。

Alan Shisko 在他的网站上提供了详细的视频教程,演示如何从简单的 2D 资源开始,通过 3D 图层创造复杂的 3D 环境。操作图层锚点是该教程的重要组成部分。

位于文本图层中心的锚点(左图)和移动到文本图层末尾的锚点(右图)的比较

在您使用向后平移(锚点)工具在“合成”面板中移动锚点时(左图),After Effects 会自动补偿移动,以便图层保持其与合成帧的相对位置(右图)。

注意:

如果您没有在“图层”面板中看到锚点,请从“图层”面板右下角区域的“视图”菜单中选择“锚点路径”。

移动图层锚点

  • 使用“图层”面板中的选择工具拖动锚点。
注意:

一些类型的图层(例如文本图层和形状图层)无法在“图层”面板中打开。

  • 要移动图层锚点 1 个像素,请从“图层”面板右下角区域的“视图”菜单中选择“锚点路径”,然后按箭头键。要移动 10 个像素,请在按箭头键时按住 Shift 键。像素测量采用“图层”面板中的当前放大率。
  • 要在“合成”面板中移动图层锚点而不移动图层,请选择图层,并使用向后平移(锚点)工具 来拖动锚点
注意:

使用向后平移(锚点)工具移动锚点会更改“位置”和“锚点”值,以便图层保持它在您移动锚点之前在合成中的位置。要仅更改“锚点”值,请使用向后平移(锚点)工具按住 Alt 键拖动 (Windows) 或按住 Option 键拖动 (Mac OS)。

Charles Bordenave (nab) 在 After Effects Scripts 网站上提供了一个脚本,该脚本移动所选图层的锚点,而不在合成帧中移动图层。

重置图层锚点

  • 要将锚点重置到它在图层中的默认位置,请双击“工具”面板中的向后平移(锚点)工具 按钮。
  • 要将锚点重置到它在图层中的默认位置,请按住 Alt 键 (Windows) 或 Option 键 (Mac OS) 并双击向后平移(锚点)工具按钮。图层将移动到合成的中心

将图层锚点设置为内容的中心

可通过以下方式之一设置要放在图层内容中心的锚点:

  • 选择“图层”>“变换”>“在图层内容中居中放置锚点”
  • 使用键盘快捷键 Ctrl+Alt+Home (Windows) 或 Command+Option+Home (Mac OS)
  • 按住 Ctrl 并双击 (Windows) 或按住 Command 并双击 (Mac OS)“向后平移”(锚点)工具

以下是此命令的几种用途:

  • 将形状图层的锚点设置为单个形状的中心或形状图层中一组形状图层的矩心
  • 将文本图层的锚点设置为文本内容的中心
  • 将图层的锚点设置为蒙蔽区域内可见区域的中心

缩放或翻转图层

与其他变换一样,将围绕图层的锚点执行图层的缩放。如果您将锚点从图层的中心移开,则在翻转图层时,图层可能会移动。一些图层(例如摄像机、光照和仅音频图层)没有“缩放”属性。

您可以将图层缩放到合成帧之外。

有关缩放指数(与缩放镜头相同),请参阅使用指数比例来更改缩放的速度

有关缩放或重新调整整部影片而非单个图层大小的信息,请参阅放大影片缩小影片

翻转图层是将其“缩放”属性值的水平或垂直组件乘以 -1。图层将围绕其锚点翻转。

  • 要翻转所选图层,请选择“图层”>“变换”>“水平翻转”或“图层”>“变换”>“垂直翻转”。
  • 要在“合成”面板中按比例缩放图层,请按住 Shift 键并拖动任何图层手柄。
  • 要在“合成”面板中自由缩放图层,请拖动边角图层手柄。
  • 要在“合成”面板中仅缩放一个维度,请拖动一侧的图层手柄。
  • 要将所选图层的“缩放”增加或减少 1%,请在按数字键盘上的 + 或 - 时按下 Alt 键 (Windows) 或 Option 键 (Mac OS)。
  • 要将所选图层的“缩放”增加或减少 10%,请在您按数字键盘上的 + 或 - 时按下 Alt+Shift (Windows) 或 Option+Shift (Mac OS)。
  • 要缩放整个合成,请选择“文件”>“脚本”>“Scale Composition.jsx”。
  • 要缩放所选图层并使其居中以适合合成帧,请选择“图层”>“变换”>“适合复合”。
  • 要缩放所选图层并使其居中以适合合成帧的宽度或高度,同时保持图层的长宽比,请选择“图层”>“变换”>“适合复合宽度”或“图层”>“变换”>“适合复合高度”。
  • 要在“时间轴”面板中按比例缩放图层,请选择该图层,按 S 以显示“缩放”属性,单击“缩放”值左侧的“约束比例”图标 ,然后为 x、y 或 z 缩放输入新值。
注意:

要激活“约束比例”图标并使高度与宽度相匹配,请按住 Alt 键 (Windows) 或 Options 键 (Mac OS) 并单击它。

  • 要缩放到一组特定像素尺寸,请在“时间轴”面板中右键单击 (Windows) 或按住 Control 键并单击 (Mac OS)“缩放”值,选择“编辑值”,然后在“缩放”对话框中将单位更改为像素。选择“包括像素长宽比”来查看尺寸并根据合成的像素长宽比调整尺寸。

缩小栅格(非矢量)图层有时会导致图像轻微柔化或模糊。按大因素扩大栅格图层可能会导致图像看起来成块状或像素化。

保留细节放大效果

利用保留细节放大效果,可以在大幅放大图像的同时保留图像中的细节。

有关更多信息,请参阅保留细节放大效果

双线性和双立方采样

可以为所选图层选择双立方或双线性采样,这决定了缩放和使用“变换”效果应用的所有变换的采样像素。

有关更多信息,请参阅图层图像品质和子像素定位

用于缩放的其他工具和资源

注意:

Adobe Photoshop 提供了对用于缩放图像的重新采样方法的精细控制。要精细控制重新采样,您可以将帧导出到 Photoshop 来更改图像大小,然后将帧导回到 After Effects 中。

虽然这不太适合影片,但 Photoshop 中的内容识别缩放功能对于扩展和缩放静止图像仍十分有用。重新使用为标清格式创建的宽银幕格式图像时,此功能会很有用。

有关同时缩放多个合成的脚本,请访问 AE Enhancers 论坛

Lloyd Alvarez 在 After Effects Scripts 网站上提供了一个脚本,该脚本缩放所选图层以适合合成帧,并提供用于进行裁剪或信箱状处理的选项。

Aharon Rabinowitz 在 Creative COW 网站上提供了一个视频教程,其中演示了如何更改 3D 图层的“缩放”属性并为其制作动画,包括仅更改“缩放”的 z 维度。

旋转 2D 图层

与其他变换一样,旋转图层时将围绕图层的锚点。

注意:

要在“时间轴”面板中显示所选图层的“旋转”属性值,请按 R 键。

“旋转”属性值的第一部分是完整旋转的数目;第二部分是部分旋转的度数。

有关旋转 3D 图层的信息,请参阅旋转或定位 3D 图层

  • 要通过在“合成”面板中拖动来旋转图层,请使用旋转工具 拖动图层。要将旋转限制为 45° 增量,请在拖动时按住 Shift 键。
  • 要将所选图层旋转 1 度,请按数字键盘上的加号 (+) 或减号 (-)。
  • 要将所选图层旋转 10 度,请按住 Shift 键并按数字键盘上的加号 (+) 或减号 (-)。

调整音频音量级别

在您使用包含音频的素材时,播放的默认音频级别是 0 dB,这意味着不在 After Effects 中调整该级别。设置正分贝级别会增加音量,而设置负分贝级别会减小音量。

注意:

双击“音频电平”关键帧会激活“音频”面板。

在播放音频时,“音频”面板中的 VU 指示器会显示音频的音量范围。指示器顶端的红色块表示您的系统的音量限制。

注意:

要通过拖动滑块来更精确地设置音频级别,请增加“音频”面板的高度。

  1. 在“音频”面板中,要调整音量,请执行以下任一操作:
    • 要一起设置左声道和右声道的级别,请向上或向下拖动中心滑块。

    • 要设置左声道的级别,请向上或向下拖动左滑块,或在左滑块底部的级别框中键入新值。

    • 要设置右声道的级别,请向上或向下拖动右滑块,或在右滑块底部的级别框中键入新值。

父图层和子图层

要通过将某个图层的变换分配给其他图层来同步对图层所做的更改,请使用父级。在一个图层成为另一个图层的父级之后,另一个图层称为子图层。在您分配父级时,子图层的变换属性将与父图层而非合成有关。例如,如果父图层向其开始位置的右侧移动 5 个像素,则子图层也会向其位置的右侧移动 5 个像素。父级类似于分组;对组所做的变换与父级的锚点相关。

父级影响除“不透明度”以外的所有变换属性:“位置”、“缩放”、“旋转”和(针对 3D 图层)“方向”。

注意:

为图层分配父级时,将在鼠标位置下面的图层栏和“信息”面板中显示描述替代父级行为的帮助文本。

图层只能具有一个父级,但图层可以是同一合成中任意数量的图层的父级。

您可以独立于父图层为子图层制作动画。您还可以使用空对象分配父级,空对象是隐藏图层。

您无法为分配和取消父级分配的操作制作动画,也就是说,您无法在一个时间点将图层指定为父级并在不同的时间点将它指定为普通图层。

在创建父级关系时,您可以选择是让子级具有父级的变换属性值,还是保持其自己的变换属性值。如果您选择让子级具有父级的变换属性值,则子图层将跳跃到父级的位置。如果您选择让子级保持其自己的变换属性值,则子级停留在原位。在这两种情况下,对父级的变换属性值所做的后续更改将应用于子级。类似地,在删除父级关系时,您可以选择子级是否跳跃

注意:

在为图层分配父级时,您可以使用 Shift 键将子图层移动到父级的位置。在您希望将图层附加到空对象,但让该图层移到到父级空对象的位置(例如,将 3D 文本图层附加到从 3D 摄像机跟踪器创建的空图层)时,这会很有用。

拖动形状图层 1(子图层)时间轴面板中的关联器,以指定形状图层 2 作为父图层

注意:

要在“时间轴”面板中显示或隐藏“父级”列,请从“时间轴”面板菜单中选择“列”>“父级”。

  • 要为图层分配父级,请在“父级”列中,将关联器从将成为子图层的图层拖动到将成为父图层的图层。
  • 要为图层分配父级,请在“父级”列中,单击要成为子级的图层的菜单,然后从菜单中选择父图层名称。
  • 要从图层中删除父级,请在“父级”列中,单击要从中删除父级的图层的菜单,然后选择“无”。
  • 要扩展所选项,使其包括所选父图层的所有子图层,请在“合成”或“时间轴”面板中右键单击 (Windows) 或按住 Control 键并单击 (Mac OS) 图层,然后选择“选择子项”。
  • 要在分配或删除父级时使子图层跳跃,请在分配或删除父级时按住 Alt 键 (Windows) 或 Option 键 (Mac OS)。
  • 要从图层中删除父级(也就是说,将“父级”设置为“无”),请在“时间轴”面板中按住 Ctrl 键 (Windows) 或 Command 键 (Mac OS) 并单击子图层的父级关联器。按住 Alt+Ctrl (Windows) 或 Option+Command (Mac OS) 并单击子图层的父级关联器可删除父级并使子图层跳跃。

有关父图层和子图层的在线资源

Paul Tuersley 在 AE Enhancers 论坛上提供了一个脚本,该脚本可复制父图层及其所有子级,同时保持父级层次结构。

Carl Larsen 在 Creative COW 网站上提供了一个视频教程,其中演示如何使用表达式以及进行父处理将一组轮的旋转与车辆的水平运动相关联。

Robert Powers 在 Slippery Rock NYC 网站上提供了一个视频教程,其中演示了如何使用父级关系和操控工具为字符添加动画。

空对象图层

要分配父图层,但阻止该图层成为您的项目中的可见元素,请使用空对象。空对象是具有可见图层的所有属性的不可见图层,因此,它可以是合成中任何图层的父级。可以像对待任何其他图层一样调整空对象并为其制作动画。可使用与用于纯色图层相同的命令来修改空对象的设置(“图层”>“纯色设置”)。

注意:

您可以将“表达式控制”效果应用于空对象,然后使用空对象作为其他图层中效果和动画的控制图层。例如,在使用摄像机或光照图层时,可创建一个空对象图层并使用表达式将摄像机或光照的“目标点”属性链接到空图层的“位置”属性。然后,您可以通过移动空对象来为“目标点”属性制作动画。通常,选择并查看空对象比选择并查看目标点容易。

合成可以包含任意数量的空对象。空对象仅在“合成”和“图层”面板中可见,并在“合成”面板中显示为具有图层手柄的矩形轮廓。效果在空对象上不可见。

  1. 要创建空对象,请选择“时间轴”或“合成”面板,然后选择“图层”>“新建”>“空对象”。
注意:

新的空对象图层的锚点显示在图层的左上角,并且图层的锚点定位在合成的中心。可以像对待任何其他图层一样更改锚点。

注意:

如果合成帧中的空对象分散您的视觉注意力,请考虑将它从帧中拖出到粘帖板上。

Andrew Kramer 在其 Video Copilot 网站上提供了一个视频教程,其中演示了如何使用空对象为 3D 描边制作动画。

引导层

您可以在“合成”面板中根据现有图层创建引导层作为参考,以帮助您定位和编辑元素。例如,您可以将引导层用于视觉参考、音频计时、时间码参考或存储注释。

引导层图标 显示在“时间轴”面板中引导层或其源的名称旁边。

默认情况下,在您创建输出时不渲染引导层,但可以在需要时通过更改合成的渲染设置来渲染引导层。

注意:

无法在包含合成中查看嵌套合成中的引导层。

  • 要将所选图层转换为引导层,请选择“图层”>“引导层”。
  • 要渲染合成及其可见引导层,请单击“渲染队列”面板中的“渲染设置”,然后从“渲染设置”对话框中的“引导层”菜单中选择“当前设置”。
  • 要渲染合成而不渲染引导层,请单击“渲染队列”面板中的“渲染设置”,然后从“渲染设置”对话框中的“引导层”菜单中选择“全部关闭”。
Adobe 徽标

登录到您的帐户