用户指南 取消(C)

预览

  1. After Effects 用户指南
  2. Beta 版
    1. Beta 版项目概述
    2. After Effects Beta 版主页
  3. 快速入门
    1. After Effects 快速入门
    2. After Effects 的新增功能 
    3. 发行说明 | After Effects
    4. After Effects 系统要求
    5. After Effects 中的键盘快捷键
    6. 支持的文件格式 | After Effects
    7. 硬件建议
    8. 适用于 Apple Silicon 的 After Effects
    9. 规划和设置
  4. 工作区
    1. 常规用户界面项
    2. 了解 After Effects 界面
    3. 工作流程
    4. 工作区、面板和查看器
  5. 项目与合成
    1. 项目
    2. 合成基础知识
    3. 预合成、嵌套和预渲染
    4. 使用合成分析器查看详细的性能信息
    5. CINEMA 4D 合成渲染器
  6. 导入素材
    1. 准备并导入静止图像
    2. 从 After Effects 和 Adobe Premiere Pro 导入
    3. 导入和解释视频与音频
    4. 准备和导入 3D 图像文件
    5. 导入和解释素材项目
    6. 使用素材项目
    7. 使用“场景编辑检测”检测编辑点
    8. XMP 元数据
  7. 文本和图形
    1. 文本
      1. 设置字符格式和“字符”面板
      2. 文本效果
      3. 创建和编辑文本图层
      4. 设置段落格式和“段落”面板
      5. 凸出文本和形状图层
      6. 为文本设置动画
      7. 文本动画的示例和资源
      8. 实时文本模板
    2. 动态图形
      1. 在 After Effects 中使用动态图形模板
      2. 使用表达式在动态图形模板中创建下拉列表
      3. 使用“基本属性”创建动态图形模板
      4. 替换动态图形模板和基本属性中的图像和视频
      5. 使用“属性”面板更快、更轻松地制作动画
  8. 绘图、绘画和路径
    1. 形状图层、路径和矢量图形的概述
    2. 绘画工具:笔刷、仿制图章和橡皮擦
    3. 将形状描边椎体化
    4. 形状图层的形状属性、绘画操作和路径操作
    5. 使用“位移路径”形状效果更改形状
    6. 创建形状
    7. 创建蒙版
    8. 使用内容识别填充面板,移除视频中的对象
    9. Roto 笔刷和调整遮罩
  9. 图层、标记和摄像机
    1. 选择和排列图层
    2. 混合模式和图层样式
    3. 3D 图层
    4. 图层属性
    5. 创建图层
    6. 管理图层
    7. 图层标记和合成标记
    8. 摄像机、光和目标点
  10. 动画、关键帧、运动跟踪和抠像
    1. 动画
      1. 动画基础知识
      2. 使用人偶工具制作动画
      3. 管理形状路径和蒙版并对其进行动画制作
      4. 使用 After Effects 为 Sketch 和 Capture 形状制作动画
      5. 分类动画工具
      6. 使用数据驱动的动画
    2. 关键帧
      1. 关键帧插值
      2. 设置、选择和删除关键帧
      3. 编辑、移动和复制关键帧
    3. 运动跟踪
      1. 跟踪和稳定运动
      2. 人脸跟踪
      3. 蒙版跟踪
      4. 蒙版引用
      5. 速度
      6. 时间拉伸和时间重映射
      7. 时间码和时间显示单位
    4. 抠像
      1. 抠像
      2. 抠像效果
  11. 透明度与合成
    1. 合成和透明度概述及资源
    2. Alpha 通道和遮罩
    3. 轨道遮罩和移动遮罩
  12. 调整颜色
    1. 颜色基础知识
    2. 色彩管理
    3. 颜色校正效果
    4. OpenColorIO 和 ACES 色彩管理
  13. 效果和动画预设
    1. 效果和动画预设概述
    2. 效果列表
    3. 效果管理器
    4. 模拟效果
    5. 风格化效果
    6. 音频效果
    7. 扭曲效果
    8. 透视效果
    9. 通道效果
    10. 生成效果
    11. 过渡效果
    12. 果冻效应修复效果
    13. 模糊和锐化效果
    14. 3D 通道效果
    15. 实用效果
    16. 遮罩效果
    17. 杂色和颗粒效果
    18. 保留细节放大效果
    19. 旧版效果
  14. 表达式和自动化
    1. 表达式
      1. 表达式基础知识
      2. 了解表达式语言
      3. 使用表达式控件
      4. JavaScript 与旧版 ExtendScript 表达式引擎之间的语法差别
      5. 正在编辑表达式
      6. 表达式错误
      7. 使用表达式编辑器
      8. 使用表达式编辑和访问文本属性
      9. 表达式语言引用
      10. 表达式示例
    2. 自动化
      1. 自动化
      2. 脚本
  15. 沉浸式视频、VR 和 3D
    1. 在 After Effects 中构造 VR 环境
    2. 应用沉浸式视频效果
    3. 用于 VR/360 视频的合成工具
    4. 高级 3D 渲染器
    5. 将 3D 模型导入并添加到合成中
    6. 从 Creative Cloud Libraries 导入3D 模型
    7. 基于图像的光照
    8. 从 3D 模型中提取光线和相机并为其制作动画
    9. 跟踪 3D 摄像机运动
    10. 投射和接受阴影
    11. 嵌入的 3D 模型动画
    12. 阴影捕手
    13. 3D 深度数据提取
    14. 修改 3D 图层的素材属性
    15. 使用 3D 设计空间
    16. 3D 变换 Gizmo
    17. 使用 3D 动画执行更多操作
    18. 使用 Mercury 3D 引擎实时预览对 3D 设计的更改
    19. 向图形添加响应式设计
  16. 视图和预览
    1. 预览
    2. 使用 Mercury Transmit 进行视频预览
    3. 修改和使用视图
  17. 渲染和导出
    1. 渲染和导出基础知识
    2. After Effects 中的 H.264 编码
    3. 将 After Effects 项目导出为 Adobe Premiere Pro 项目
    4. 转换影片
    5. 多帧渲染
    6. 自动渲染和网络渲染
    7. 渲染和导出静止图像及静止图像序列
    8. 在 After Effects 中使用 GoPro CineForm 编解码器
  18. 使用其他应用程序
    1. Dynamic Link 和 After Effects
    2. 使用 After Effects 和其他应用程序
    3. After Effects 中的同步设置
    4. After Effects 中的 Creative Cloud Libraries
    5. 增效工具
    6. Cinema 4D 和 Cineware
  19. 协作:Frame.io 和团队项目
    1. 在 Premiere Pro 和 After Effects 中协作
    2. Frame.io
      1. 安装和激活 Frame.io
      2. 将 Frame.io 与 Premiere Pro 和 After Effects 搭配使用
      3. 常见问题解答
    3. 团队项目
      1. 开始使用团队项目
      2. 创建团队项目
      3. 使用团队项目进行协作
  20. 内存、存储、性能
    1. 内存和存储
    2. After Effects 处理预览时内存不足问题的方式    
    3. 提高性能
    4. 首选项
    5. After Effects 的 GPU 和 GPU 驱动程序要求
  21. 知识库
    1. 已知问题
    2. 已修复的问题
    3. 常见问题解答
    4. After Effects 和 macOS Ventura
    5. After Effects 处理预览时内存不足问题的方式

了解 After Effects 中的预览和渲染,包括如何预览素材、图层和合成,以及影响预览速度的因素。

预览视频和音频

尽管在谈到渲染时通常指最终输出,但为素材图层合成面板创建预览的过程也属于渲染。

在工作时可以预览整个或部分合成,而无需渲染到最终输出。用于预览的许多控件位于预览面板中。

使用预览播放视频和音频

After Effects 可在时间轴图层素材面板中以实时速度分配内存以播放视频和音频。用于实时回放的可存储帧数取决于可用的内存量和预览面板中的设置。

配置默认的预览行为,以生成一个代表实时回放的预览。当您按空格键(默认键盘快捷键)时,After Effects 会启动带音频的预览并缓存帧,直到可用内存被填满为止。

要启动视频和音频的预览,请执行以下任一操作:

  • 按任何“预览”键盘快捷键:空格键Shift + 空格键数字小键盘-0Shift + 数字小键盘-0Option/Alt + 数字小键盘-0。根据分配给各快捷键的预览设置,使用各键盘快捷键会产生不同预览行为。您可以通过修改预览面板中的设置,配置各键盘快捷键的预览行为。
提示:

了解有关配置 After Effects 预览行为的更多信息。

  • 选择预览面板中的播放   按钮。选择播放按钮时,将使用当前显示在预览面板中分配给快捷键的设置。
  • 选择合成 > 预览 > 播放。选择播放选项时,将使用当前显示在预览面板中分配给快捷键的设置。

配置预览行为

您可根据自己的工作风格配置最适合的预览选项。通过预览面板中的控件,您可以为每个键盘快捷键(空格键Shift + 空格键数字小键盘-0Shift + 数字小键盘-0数字小键盘- 或 Option/Alt + 数字小键盘-)配置音频、循环、缓存、范围和图层控件的预览行为。

要配置预览的设置,请执行以下操作:

  1. 在 After Effects 的大部分工作区中,会默认打开预览面板。但是如果预览面板处于关闭状态,则可通过选择窗口 > 预览将其打开。

  2. 预览面板中,可以修改以下设置以配置预览行为:

    快捷键

    选择用于播放/停止预览的键盘快捷键:空格键Shift + 空格键数字小键盘-0Shift + 数字小键盘-0Option/Alt + 数字小键盘-0预览行为取决于为当前选定键盘快捷键指定的设置。

    重置

    恢复所有快捷键的默认预览设置。

    注意:

    要恢复所有键盘快捷键的预览设置以密切匹配这些快捷键在旧版本(After Effects CC 2014 和更早版本)中的行为,请按住 Option (macOS) 或 Alt (Windows),并选择重置按钮。

    静音

    在预览期间静音音频。

    包含视频

    启用后,预览会播放视频。 

    包含音频

    启用后,预览会播放音频。 

    包括叠加和图层控件

    若启用,预览将显示叠加(如网格和参考线)和所选图层的图层控件,如视图 > 视图选项对话框中所定义。不管是否启用了包含视频,此选项均可启用。

    查看器面板叠加包括导线、安全边距、网格和 3D 参考轴。要选择为当前查看器显示哪些叠加,请打开查看器面板底部的选择网格和导线选项菜单。

    回放预览时,可使用快捷键动态显示或隐藏图层控件:Cmd + Shift + H (macOS) 或 Control + Shift + H (Windows)

    循环

    指定是否要循环播放预览。

    注意:

    在预览期间显示或隐藏图层控件并不会影响预览面板中的图层控件选项的状态。

    您不能同时禁用全部三个包括按钮。须至少有一个按钮保持启用状态。禁用第三个按钮时,其他按钮之一便会启用。

    在回放前缓存:如果您启用该选项,After Effects 会在开始回放前缓存帧。对于任何预览快捷键,默认情况下不会启用此选项。如果您按住 Option- (macOS) 或 Alt- (Windows) 并选择预览面板中的重置按钮,则会针对数字小键盘-0 启用在回放前缓存

    范围

    定义要预览的帧的范围:

    • 工作区:只有工作区内的帧。
    • 工作区 - 按当前时间扩展:工作区参照当前时间指示器 (CTI) 的位置动态扩展。
      • 如果 CTI 被置于工作区之前,则范围长度是从当前时间到工作区终点。
      • 如果 CTI 被置于工作区之后,则范围长度为从起始点到当前时间。如果启用“从当前时间”,则范围长度为从起始点到合成、图层或素材的最后一帧。
      • 如果 CTI 被置于工作区内,则范围就是工作区域,没有扩展。
    • 整个持续时间:合成、图层或素材的所有帧。
    • 围绕当前时间播放:在启用围绕当前时间播放的情况下启动预览时,将从当前时间中减去预卷值,并向当前时间添加过卷值,从而预览二者之间的帧。

      设置预卷和过卷值:

      1. 选择“范围”>“围绕当前时间播放”
      2. 围绕当前时间播放设置对话框中,设置所需的预卷和过卷值(以秒为单位)。
      3. 选择确定

    帧速率

    指定预览的帧速率。如果要让预览和合成的帧速率相等,请选择自动

    跳过

    选择预览时要跳过的帧数,以提高回放性能。

    分辨率

    指定预览分辨率。分辨率下拉菜单中指定的值将覆盖合成的分辨率设置。

    选择当您使用当前快捷键或播放按钮停止预览时发生的一个或多个以下行为:

    • 如果缓存,则播放缓存的帧:若启用此选项并使用此快捷键在完成缓存前停止预览,则只停止缓存。回放缓存的帧将从范围开头重新开始播放。启用此选项后,使用此快捷键停止预览会同时停止缓存和回放。
    • 将时间移到预览时间:若启用此选项并使用此快捷键停止预览,当前时间将移到预览时间的位置。

停止预览

可使用以下任一方式停止预览:

  • 按任何“预览”键盘快捷键(空格键Shift + 空格键数字小键盘-0Shift + 数字小键盘-0Option/Alt + 数字小键盘-0)。
  • 选择“预览”面板中的播放/停止按钮。
  • 依次选择“合成”>“预览”>“播放当前预览”
  • Esc 键。

以下操作也可以让 After Effects 停止预览:

  • 选择预览查看器面板。选择查看器面板的选项卡不会停止预览。
  • 调整时间的属性,如工作区栏或时间导航栏。
  • 拖动当前时间指示器 (CTI) 或者在时间标尺中选择,无需按下 Option (macOS) 或 Alt (Windows)。此操作也会更改当前时间。
  • 更改预览合成的合成设置。
  • 将预览查看器面板隐藏在工作区内的另一个面板后方。例如,选择相同组中的另一个面板,或在相同组中打开新的查看器面板。
  • 启动渲染队列。

预览面板中的播放/停止按钮和合成 > 预览 > 播放当前预览的行为,与当前显示在预览面板中的快捷键关联。使用这些操作停止预览,其结果与按下当前显示的键盘快捷键相同。

默认预览设置

以下是各预览键盘快捷键的默认预览设置:

空格键

Shift+空格键

数字小键盘 0

  • 在预览中播放视频:打开
  • 在预览中播放音频:打开
  • 显示叠加和图层控件:关闭
  • 在回放前缓存:关闭
  • 范围:按当前时间扩展的工作区域
  • 播放起点:当前时间
  • 帧速率:自动.
  • 跳过:0
  • 分辨率:自动
  • 全屏:禁用

空格键用于停止预览时:

  • 如果缓存,则播放缓存的帧:启用
  • 将时间移到预览时间:启用
  • 在预览中播放视频:打开
  • 在预览中播放音频:打开
  • 显示叠加和图层控件:关闭
  • 在回放前缓存:关闭
  • 范围:按当前时间扩展的工作区域
  • 播放起点:当前时间
  • 帧速率:自动
  • 跳过:0
  • 分辨率:自动
  • 全屏:禁用

Shift+空格键用于停止预览时:

  • 如果缓存,则播放缓存的帧:启用
  • 将时间移到预览时间:禁用
  • 在预览中播放视频:打开
  • 在预览中播放音频:打开
  • 显示叠加和图层控件:关闭
  • 在回放前缓存:关闭
  • 范围:工作区
  • 播放起点:范围的起点
  • 帧速率:自动
  • 跳过:0
  • 分辨率:自动
  • 全屏:禁用

数字小键盘 0 用于停止预览时:

  • 如果缓存,则播放缓存的帧:启用
  • 将时间移到预览时间:禁用

Shift + 数字小键盘 0

数字小键盘 0

Alt + 数字小键盘-0

  • 在预览中播放视频:打开
  • 在预览中播放音频:打开
  • 显示叠加和图层控件:关闭
  • 在回放前缓存:关闭
  • 范围:按当前时间扩展的工作区域
  • 播放起点:范围的起点
  • 帧速率:自动
  • 跳过:1
  • 分辨率:自动
  • 全屏:禁用

Shift+数字小键盘-0 用于停止预览时:

  • 如果缓存,则播放缓存的帧:启用
  • 将时间移到预览时间:禁用
  • 在预览中播放视频:关闭
  • 在预览中播放音频:打开
  • 显示叠加和图层控件:关闭
  • 在回放前缓存:关闭
  • 范围:按当前时间扩展的工作区
  • 播放起点:当前时间
  • 帧速率:自动
  • 跳过:0
  • 分辨率:自动
  • 全屏:禁用

数字小键盘+0 用于停止预览时:

  • 如果缓存,则播放缓存的帧:启用
  • 将时间移到预览时间:禁用
  • 在预览中播放视频:关闭
  • 在预览中播放音频:打开
  • 显示叠加和图层控件:打开
  • 在回放前缓存:关闭
  • 范围:工作区
  • 播放起点:范围的起点
  • 帧速率:自动
  • 跳过:0
  • 分辨率:自动
  • 全屏:禁用

Alt+数字小键盘-0 用于停止预览时:

  • 如果缓存,则播放缓存的帧:启用
  • 将时间移到预览时间:禁用

仅预览音频

仅预览音频时,它将立即以实时速度播放,除非已应用立体声混合器之外的音频效果,在此情况下,可能必须等待音频先渲染,然后才能播放。

项目设置对话框(文件 > 项目设置)中设置整个项目的音频采样率。

音频硬件音频输出映射首选项可确定音频预览的行为。输出模块设置确定最终输出中的音频质量。在首选项对话框的音频硬件窗格(编辑 > 首选项 > 音频硬件)中,可以选择设备类别,映射默认输出并更改设置,以及设置延迟。

手动预览(划动)视频和音频

  • 要在时间轴面板中手动预览(划动)视频,或转到特定帧,请拖动当前时间指示器。
  • 要在时间轴面板中划动音频,请按住 Ctrl + Alt 键并拖动 (Windows) 或按住 Command + Option 键 (macOS) 并拖动当前时间指示器 (CTI)。
  • 要在时间轴面板中划动音频与视频,请按住 Ctrl 并拖动 (Windows) 或按住 Command 并拖动 (macOS) 当前时间指示器 (CTI)。

如果在划动音频时按下鼠标按钮来停止移动当前时间指示器 (CTI),则会循环音频的一小部分。

注意:

要仅手动预览(划动)已渲染并缓存到内存缓存的帧,请在拖动当前时间指示器 (CTI) 之前按下 Caps Lock 键。这将防止 After Effects 在您拖过这些帧时,尝试渲染其他帧。在您希望手动预览使用预览设置(这些设置使用选项来跳过所有其他帧)渲染的一些帧时,此方法十分有用。

音频面板选项

在预览期间,音频面板音量单位 (VU) 计量器动态地显示音频音量级别。在 VU 计量器的顶端,信号表示剪辑音频的时间,这是当音频信号超过音频设备允许的最高级别时,发生的一种扭曲。

要更详细地查看 VU 计量器和音量级别控件,请增加音频面板的高度。

音频面板菜单中选择选项以指定下列选项:

单位

选择是以分贝为单位还是按百分比显示音频电平。100% 等于 0 分贝 (0 dB)。

滑块最小值

要在音频面板中显示的最小音频电平。

预览的其他的技巧和选项

  • 对于所有预览方法(与渲染到最终输出一样),仅当已选择视频图层开关,图层才能在渲染的预览中显示。
  • 以下是影响预览渲染速度的一些因素:
    • 图层开关
    • 快速预览设置
    • 首选项设置
    • 合成设置

使用“分辨率/向下采样系数”设置菜单,这是预览设置控件中最简单但影响最大的控件之一。选择此菜单中除“完全”之外的值,可以较低分辨率查看所有预览。

分辨率设置
设置预览的分辨率

注意:

要打开或关闭像素长宽比校正进行预览,请选择面板底部的切换像素长宽比校正按钮。像素长宽比校正的质量由缩放质量首选项决定。了解有关在 After Effects 中查看品质首选项的更多信息。

  • 如有可能,请在观众用来查看最终输出的同一种设备上预览。例如,可以在外部视频监视器上预览。
  • 如果已启用色彩管理,则可以预览合成、图层或素材项目在输出色彩空间中的外观。了解如何在 After Effects 中模拟颜色在不同输出设备上的显示方式
注意:

选择在信息面板和流程图中显示渲染进度编辑 > 首选项 > 显示 (Windows) 或 After Effects > 首选项 > 显示 (macOS))可在渲染(用于预览或最终输出)期间查看“信息”面板或项目流程图面板中的其他信息。

移动当前时间指示器 (CTI)

“时间轴”面板具有会突出显示的当前时间指示器 (CTI)。
通过移动或拖动“时间轴”面板中的当前时间指示器 (CTI) 来手动预览。

预览帧的最基本方式是通过移动或拖动当前时间指示器 (CTI) 进行手动预览。

时间标尺以可视方式表示合成、图层或素材项的时间维度。在图层素材面板中,时间标尺显示在面板底部附近。对于合成面板,时间标尺显示在相应的时间轴面板中。不同面板中的时间标尺表示不同的持续时间。图层素材面板的时间标尺表示该面板内容的持续时间;时间轴面板的时间标尺表示整个合成的持续时间。

在时间标尺上,当前时间指示器指示正在查看或修改的帧。

  • 要前进或后退一个帧,请选择预览面板中的下一帧上一帧按钮,或者按 Page DownPage Up 键。

  • 要前进或后退十个帧,请按住 Shift 键并单击下一帧上一帧按钮,或按 Shift + Page DownShift + Page Up

  • 要前进特定时间段或帧数,请选择当前时间显示,然后输入加号 (+) 和要前进的时间码或帧数。例如,输入 +20 可前进 20 帧,或输入 1:00 可前进一秒。在该值前加减号 (-) 可后退。例如,输入 +-20 可后退 20 帧,或输入 +-1:00 可后退一秒。

  • 要转到第一个或最后一个帧,请选择预览面板中的第一帧 最后一帧 按钮,或者按 HomeEnd 键。

  • 要转到工作区域的第一个或最后一个帧,请按 Shift + HomeShift + End

  • 要转到特定帧,请选择时间标尺;选择素材图层合成时间轴面板中的当前时间;或按 Alt + Shift + J (Windows) 或 Option + Shift + J (macOS)。还可以在时间轴面板中拖动当前时间显示以修改值。

  • 按住 Shift 并拖动当前时间指示器以对齐到关键帧、标记、进出点、合成的开始或结尾、或工作区域的开始或结尾。
  • Shift 添加到 JK 热键,可在选定图层和属性上的关键帧和标记之间快速跳转。
  • 要在选择多个图层时将 CTI 移至最早的 ,请对最后的点使用键盘快捷键  IO
注意:

如果在播放预览时拖动 CTI,预览将会停止。要拖动 CTI 而不停止预览,请在按住 Option/Alt 的同时拖动。

放大或缩小合成的时间

  • 时间轴面板中,选择按钮 缩小按钮 ,或拖动按钮之间的缩放滑块。
  • 在主键盘上,按 =(等号)键可放大时间,按 (连字符)键可缩小时间。
  • 拖动时间导航器开始时间导航器结束括号可放大或缩小合成时间标尺的一部分。
注意:

在单击时间轴面板的时间导航器时,“信息”面板将显示时间导航器持续时间的开始和结束时间。

  • 要缩小以显示整个合成持续时间,请按 Shift + ; (分号)并保持合成面板或时间轴面板处于活动状态。再次按 Shift + ; 可重新放大到由时间导航器指定的持续时间。
  • 要缩小以显示整个合成持续时间,请按住 Shift 键并双击“时间导航器”。再次按住 Shift 键并双击,可重新放大到由时间导航器指定的持续时间。
  • 要放大以显示时间标尺中的各个帧,请双击时间导航器。再次双击时间导航器可缩小以显示整个合成持续时间。
  • 要使用两指多点触控手势在合成图层素材时间轴面板中进行缩放,合拢手指即可缩小,张开手指即可放大。

有关使用鼠标滚轮缩放和滚动时间的其他方法,请参阅使用鼠标滚轮滚动或缩放

注意:

在放大时间时,按 D 键可使时间图表在当前时间居中。

选择始终用于预览的查看器

在您有表示最终输出的合成查看器,并且总是希望预览该查看器时,甚至要在其他面板中更改设置时,将查看器指定为进行预览的默认面板十分有用。

设置为总是预览的面板显示在预览持续时间的最前面。

  • 选择面板左下角的始终预览此视图  按钮。
  • 选择左下角的主查看器 按钮。

“主查看器”按钮

主查看器按钮位于合成图层素材查看器面板左下角的始终预览此视图按钮旁边。

主查看器的功能类似于始终预览此视图,不同之处是主查看器只定义哪个查看器或视图用于音频和外部视频预览。

  • 仅可将一个视图设置为主查看器;针对一个查看器或视图启用它,则会在之前启用它的任何其他查看器或视图中禁用它。
  • 主查看器被禁用时,将使用最近的活动查看器或视图进行音频和外部视频预览。
  • 当您切换到其他查看器或视图时,该查看器或视图将控制音频和外部视频预览。
注意:

在多个视图打开时,预览对 2D 合成使用最前面的合成视图,对 3D 合成使用“活动摄像机”视图。要关闭活动摄像机,请取消选择预览面板菜单中的预览支持活动摄像机

“预览”模式和“查看器质量”首选项

After Effects 提供了几个预览选项,以在速度和保真度之间进行各种权衡。

“预览”模式和“快速预览”首选项

每个预览模式为回放和交互期间的图像更新提供了质量和速度之间的不同平衡,例如在拖动合成面板中的图层时,或者修改时间轴面板中的属性值时。

草图 3D实时更新模式适用于合成的所有视图。

草图 3D

禁用摄像机的光、阴影和景深模糊。要打开或关闭草图 3D 模式,请选择时间轴面板顶部的草图 3D 按钮。

实时更新

交互期间在合成图层面板中更新图像。在取消选择实时更新后,After Effects 会在交互期间显示线框表示形式。

注意:
  • 要暂时切换实时更新模式,请在拖动移动图层、修改属性值或移动当前时间指示器 (CTI) 时按住 Alt (Windows) 或 Option (macOS)。
  • 要防止 After Effects 更新素材图层合成面板中的图像,请按 Caps Lock。在进行可能在面板中显示的更改时,After Effects 将向面板底部添加一个红色条,附有图像刷新被禁用的文本提示。在您移动面板控件(例如运动路径、锚点和蒙版轮廓)时,After Effects 会继续更新这些控件。要恢复面板更新和显示所有更改,请再次按 Caps Lock。按 Caps Lock  是防止在渲染最终输出期间为每个帧刷新视图的好方法。
  • 如果您使用 OpenGL 渲染预览,并在视频监视器上进行预览,您与合成的元素交互时,显示在视频监视器上的预览不会更新,直到交互结束时松开鼠标。了解关于使用 After Effects 在外部视频监视器上进行预览的更多信息。

快速预览

快速预览选项范围包括从高品质低性能(关闭)到低品质高性能(线框)的选项。

关(最终品质)

快速预览处于关闭状态。在预览合成的最终质量时使用此模式。

自适应分辨率

尝试在拖动图层或划动属性值时降低素材采样速率。对于光线追踪 3D 合成,自适应分辨率将基于当前的自适应分辨率降低光线追踪质量:

  • 在 1/2 时,光线追踪质量值减少了一半。
  • 在 1/4 时,它将至多减少到 4。
  • 在 1/8 或 1/16 时,它将至多减少到 2。

您可以在编辑 > 首选项 > 预览 (Windows) 或 Premiere Pro > 首选项 > 预览 (macOS) 中更改自适应分辨率限制。

草图

仅在光线追踪 3D 合成中可用。此选项将光线追踪质量(光线追踪器发出的光线数)降低到 1。

快速绘图

在布局复杂场景时,或如果您正在使用光线追踪 3D 合成,可以将快速绘图模式用于预览。在光线追踪 3D 合成中,快速绘图模式可渲染斜面、凸出和弯曲的 3D 图层。在预览时,会降低场景采样速率,从而加快将纹理加载到 GPU 的速度。在快速绘图模式下,仍会根据需要将视频的每个帧读入渲染器。降低采样率因数设置为 1/4 分辨率,效果以及跟踪遮罩处于打开状态。

线框

对设置和预览复杂合成有用。

  • 草图快速绘图线框模式中,当前渲染器菜单按钮的闪电图标显示为橙色。在自适应分辨率中,降低合成采样速率后,它会显示为橙色。在这些模式下,模式的名称显示在合成视图的右上角。
  • 如果在最终质量自适应分辨率草图模式中通过时间轴调整属性或划动需要很长时间,场景将暂时切换为显示线框。停止移动鼠标时,帧渲染结束。
  • 如果处于草图模式中的光线追踪 3D 合成中,然后将其切换到经典 3D 合成,快速预览模式将自动切换到自适应分辨率
  • 如果希望在划动时更新多个活动视图,请按住 Ctrl (Windows) 或 Command (macOS),在选择视图布局弹出菜单中,启用共享视图选项选项。
  • 选择合成面板右上角的当前渲染器菜单按钮,可快速打开合成设置对话框的当前渲染器设置。此方法适用于 3D 图层、摄像机或合成中的光线。
注意:

快速预览模式更改为与工作流程匹配很重要,特别是在与光线追踪 3D 合成一起使用时。

快速预览的键盘快捷键

品质名称

快捷键

关(最终品质)

Ctrl + Alt + 1 (Windows) 或 Cmd + Option + 1 (macOS)

自适应分辨率

Ctrl + Alt + 2 (Windows) 或 Cmd + Option + 2 (macOS)

草图

Ctrl + Alt + 3 (Windows) 或 Cmd + Option + 3 (macOS)

快速绘图

Ctrl + Alt + 4 (Windows) 或 Cmd + Option + 4 (macOS)

线框

Ctrl + Alt + 5 (Windows) 或 Cmd + Option + 5 (macOS)

“查看器质量”首选项

“预览”首选项类别中,您可以选择预览中使用的色彩管理的质量和速度以及缩放操作。

“缩放品质”“色彩管理品质”菜单中,选择以下其中一项:

  • 更快
  • 除缓存预览之外更准确
  • 更准确

“缩放品质”首选项会影响在“合成”“图层”面板中为像素长宽比校正执行的缩放的质量。

注意:

显示通道菜单设置为显示直接颜色(RGB 直通、Alpha 叠加或 Alpha 边界)的选项时,将忽略查看器质量首选项,并将创建预览,就像查看器质量设置是“更快”一样。

目标区域 (ROI)

目标区域 (ROI) 是渲染以供预览的合成、图层或素材项目的区域。创建更小的目标区域,以在预览时使用更少的处理能力和内存,从而提高交互速度并增加预览持续时间。

默认情况下,更改目标区域不影响文件输出。您可以更改合成的大小,并通过裁剪到目标区域来选择要进行渲染的部分。

注意:

在选择目标区域后,“信息”面板会显示该区域的顶 (T)、左 (L)、底 (B) 和右 (R) 边缘到合成的左上角的水平和垂直距离。

  • 要绘制目标区域,请选择合成图层素材面板底部的目标区域按钮,然后拖动以选择面板的可视区域。
注意:

要使用选框工具重新开始,请按住 Alt (Windows) 或 Option (macOS) 并选择目标区域按钮。

  • 要在使用目标区域和使用完全合成、图层或素材帧之间进行切换,请选择目标区域按钮。
  • 要移动或重新调整目标区域的大小,请拖动其边缘或手柄。按住 Shift 并拖动边角手柄可调整大小,同时保留长宽比。
  • 要将合成裁剪到目标区域,请选择合成 > 裁剪合成到目标区域
  • 要将输出裁剪到目标区域,请在输出模块设置 对话框的裁剪部分中选择使用目标区域
注意:

要为一个图层创建目标区域的等效项,可以在您正在处理的图层部分的周围绘制临时蒙版。不会渲染蒙版外部的区域。这可以更快地处理大图层的小部分。但请小心,因为不渲染蒙版外的像素可能会显著更改合成的外观。了解有关在 After Effects 中创建蒙版的更多信息。

将合成裁剪至目标区域

工作区域

工作区域属于为预览或最终输出渲染的合成的持续时间。在时间轴面板中,工作区域以浅灰色阴影表示。

  • 要将工作区域开始时间或结束时间设置为当前时间,请分别按 B(开始)或 N(结束)。
  • 要设置工作区域,请在时间标尺中移动开始和结束工作区域标记。
  • 要移动工作区域,请向左或向右拖动工作区域条的中心。
  • 为将工作区域扩展到合成的大小,请双击工作区域条的中心。

  • 要在“信息”面板中显示工作的持续时间及其开始和结束的时间,请选择工作区栏。

快照

当希望在合成图层素材面板中将一个视图与另一个进行比较时,请拍摄快照。例如,您可能希望比较影片中不同时间的两个帧。

在一种面板中拍摄的快照可在另一种面板中显示。例如,您可以拍摄图层面板的快照,并在合成素材面板中显示该快照。显示快照不会替换面板的内容。如果与显示快照的面板相比,快照的大小或长宽比不一样,请调整快照大小以适合当前视图。

快照仅供参考,并不变成图层、合成,或已渲染影片的一部分。

在您拍摄快照时,会生成一个声音。

  • 要拍摄快照,请选择面板底部的拍摄快照按钮   或按 Shift + F5Shift + F6Shift + F7Shift + F8
  • 要查看最近使用拍摄快照按钮或 Shift + F5 拍摄的快照,请选择并按住面板底部的显示快照按钮。
  • 要查看特定快照,请按住 F5F6F7F8
  • 要清理快照,请按住 Ctrl + Shift (Windows) 或 Command + Shift (macOS),然后按 F5F6F7F8
  • 要释放用于存储快照所用的所有内存,请选择编辑 > 清理 > 快照

在外部视频监视器上预览

您可以在外部视频监视器上预览图层素材合成面板的内容。在视频监视器上预览需要其他硬件,例如视频捕捉卡或 FireWire 端口。

可以在与显卡(例如,DVI、DisplayPort 或 HDMI)相连的其他监视器上显示预览。如果使用视频捕捉卡连接外部视频监视器,请安装相应的驱动程序并连接监视器,以查看预览。如果您正在使用 FireWire 端口,首先将数码摄像机或类似装置连接到端口;然后将视频监视器连接到设备。有关设置 FireWire 预览的更多信息,请参阅数码摄像机、VCR 或其他设备的文档。

  1. 选择编辑 > 首选项 > 视频预览 (Windows) 或 After Effects > 首选项 > 视频预览 (macOS)。

  2. 要允许视频输出到某个外部设备,请选择以下选项之一:

    • Adobe DV:这是 FireWire 选项。
    • Adobe 监视器 x:这些是您连接的、可通过显卡接收视频预览数据的计算机监视器。
    • 第三方视频硬件:这些项取决于所连接的第三方硬件类型。典型示例有 AJA Kona 3GBlackmagic PlaybackMatrox Player
  3. 选择在后台时禁用视频输出选项以避免在 After Effects 并非前景应用程序时,视频帧被发送至外部监视器。

  4. 选择渲染队列输出期间预览视频选项,可在 After Effects 对渲染队列中的帧进行渲染时,将视频帧发送至外部监视器。

使用 Mercury Transmit 发送到外部监视器的视频预览是进行过颜色管理的(将外部视频预览监视器视为 HDTV Rec.709 设备)。有关更多信息,请参阅使用 Mercury Transmit 预览视频一文。

注意:

“线框”预览模式从不预览视频预览监视器。(请参阅预览模式选择工作色彩空间并启用色彩管理。)

更多此类内容

 Adobe

更快、更轻松地获得帮助

新用户?

Adobe MAX 2024

Adobe MAX
创意大会

10 月 14 日至 16 日迈阿密海滩及线上

Adobe MAX

创意大会

10 月 14 日至 16 日迈阿密海滩及线上

Adobe MAX 2024

Adobe MAX
创意大会

10 月 14 日至 16 日迈阿密海滩及线上

Adobe MAX

创意大会

10 月 14 日至 16 日迈阿密海滩及线上