用户指南 取消(C)

Dynamic Link 和 After Effects

  1. After Effects 用户指南
  2. Beta 版
    1. Beta 版项目概述
    2. After Effects Beta 版主页
    3. Beta 版中的功能
      1. “属性”面板(Beta 版)
  3. 快速入门
    1. After Effects 快速入门
    2. After Effects 的新增功能 
    3. 发行说明 | After Effects
    4. After Effects 系统要求
    5. After Effects 中的键盘快捷键
    6. 支持的文件格式 | After Effects
    7. 硬件建议
    8. 适用于 Apple Silicon 的 After Effects
    9. 规划和设置
    10. 设置和安装
  4. 工作区
    1. 常规用户界面项
    2. 了解 After Effects 界面
    3. 工作流程
    4. 工作区、面板和查看器
  5. 项目与合成
    1. 项目
    2. 合成基础知识
    3. 预合成、嵌套和预渲染
    4. 使用合成分析器查看详细的性能信息
    5. CINEMA 4D 合成渲染器
  6. 导入素材
    1. 准备并导入静止图像
    2. 从 After Effects 和 Adobe Premiere Pro 导入
    3. 导入和解释视频与音频
    4. 准备和导入 3D 图像文件
    5. 导入和解释素材项目
    6. 使用素材项目
    7. 使用“场景编辑检测”检测编辑点
    8. XMP 元数据
  7. 文本和图形
    1. 文本
      1. 设置字符格式和“字符”面板
      2. 文本效果
      3. 创建和编辑文本图层
      4. 设置段落格式和“段落”面板
      5. 凸出文本和形状图层
      6. 为文本设置动画
      7. 文本动画的示例和资源
      8. 实时文本模板
    2. 动态图形
      1. 在 After Effects 中使用动态图形模板
      2. 使用表达式在动态图形模板中创建下拉列表
      3. 使用“基本属性”创建动态图形模板
      4. 替换动态图形模板和基本属性中的图像和视频
  8. 绘图、绘画和路径
    1. 形状图层、路径和矢量图形的概述
    2. 绘画工具:笔刷、仿制图章和橡皮擦
    3. 将形状描边椎体化的方法
    4. 形状图层的形状属性、绘画操作和路径操作
    5. 使用“位移路径”形状效果更改形状
    6. 创建形状
    7. 创建蒙版
    8. 使用内容识别填充面板,移除视频中的对象
    9. Roto 笔刷和调整遮罩
  9. 图层、标记和摄像机
    1. 选择和排列图层
    2. 混合模式和图层样式
    3. 3D 图层
    4. 图层属性
    5. 创建图层
    6. 管理图层
    7. 图层标记和合成标记
    8. 摄像机、光和目标点
  10. 动画、关键帧、运动跟踪和抠像
    1. 动画
      1. 动画基础知识
      2. 使用人偶工具制作动画
      3. 管理形状路径和蒙版并对其进行动画制作
      4. 使用 After Effects 为 Sketch 和 Capture 形状制作动画
      5. 分类动画工具
      6. 使用数据驱动的动画
    2. 关键帧
      1. 关键帧插值
      2. 设置、选择和删除关键帧
      3. 编辑、移动和复制关键帧
    3. 运动跟踪
      1. 跟踪和稳定运动
      2. 人脸跟踪
      3. 蒙版跟踪
      4. 蒙版引用
      5. 速度
      6. 时间拉伸和时间重映射
      7. 时间码和时间显示单位
    4. 抠像
      1. 抠像
      2. 抠像效果
  11. 透明度与合成
    1. 合成和透明度概述及资源
    2. Alpha 通道、蒙版和遮罩
  12. 调整颜色
    1. 颜色基础知识
    2. 使用 Adobe Color Themes 扩展
    3. 色彩管理
    4. 颜色校正效果
  13. 效果和动画预设
    1. 效果和动画预设概述
    2. 效果列表
    3. 模拟效果
    4. 风格化效果
    5. 音频效果
    6. 扭曲效果
    7. 透视效果
    8. 通道效果
    9. 生成效果
    10. 过渡效果
    11. 果冻效应修复效果
    12. 模糊和锐化效果
    13. 3D 通道效果
    14. 实用效果
    15. 遮罩效果
    16. 杂色和颗粒效果
    17. 保留细节放大效果
    18. 旧版效果
  14. 表达式和自动化
    1. 表达式
      1. 表达式基础知识
      2. 了解表达式语言
      3. 使用表达式控件
      4. JavaScript 与旧版 ExtendScript 表达式引擎之间的语法差别
      5. 正在编辑表达式
      6. 表达式错误
      7. 使用表达式编辑器
      8. 使用表达式编辑和访问文本属性
      9. 表达式语言引用
      10. 表达式示例
    2. 自动化
      1. 自动化
      2. 脚本
  15. 沉浸式视频、VR 和 3D
    1. 在 After Effects 中构造 VR 环境
    2. 应用沉浸式视频效果
    3. 用于 VR/360 视频的合成工具
    4. 跟踪 3D 摄像机运动
    5. 使用 3D 设计空间
    6. 3D 变换 Gizmo
    7. 使用 3D 动画执行更多操作
    8. 使用实时引擎实时预览对 3D 设计的更改
    9. 向图形添加响应式设计 
  16. 视图和预览
    1. 预览
    2. 使用 Mercury Transmit 进行视频预览
    3. 修改和使用视图
  17. 渲染和导出
    1. 渲染和导出基础知识
    2. 将 After Effects 项目导出为 Adobe Premiere Pro 项目
    3. 转换影片
    4. 多帧渲染
    5. 自动渲染和网络渲染
    6. 渲染和导出静止图像及静止图像序列
    7. 在 After Effects 中使用 GoPro CineForm 编解码器
  18. 使用其他应用程序
    1. Dynamic Link 和 After Effects
    2. 使用 After Effects 和其他应用程序
    3. After Effects 中的同步设置
    4. After Effects 中的 Creative Cloud Libraries
    5. 增效工具
    6. CINEMA 4D 和 Cineware
  19. 协作:Frame.io 和团队项目
    1. 在 Premiere Pro 和 After Effects 中协作
    2. Frame.io
      1. 安装和激活 Frame.io
      2. 将 Frame.io 与 Premiere Pro 和 After Effects 配合使用
      3. 常见问题解答
    3. 团队项目
      1. 开始使用团队项目
      2. 创建团队项目
      3. 使用团队项目进行协作
  20. 内存、存储、性能
    1. 内存和存储
    2. 提高性能
    3. 首选项
    4. After Effects 的 GPU 和 GPU 驱动程序要求

关于 Dynamic Link

过去,在后期制作应用程序之间共享媒体资源要求您从一个应用程序中渲染并导出您的工作,然后再将其导入另一个应用程序。此工作流效率低下且耗时。如果要更改原始资源,您需要再次渲染并导出该资源。资源的多个渲染和导出版本会占用磁盘空间,因此可能带来文件管理难题。

Dynamic Link 提供了此工作流的一种替代方法。您可以在 After Effects 和 Adobe Premiere Pro 之间创建 Dynamic Link。创建 Dynamic Link 与导入任何其他类型的资源一样简单。Dynamic Link 的资源显示有独特的图标和标签颜色,以帮助您加以识别。Dynamic Link 保存在这些应用程序所生成的项目中。

创建 After Effects 合成并使用 Dynamic Link 链接到这些合成

您可以创建新的 After Effects 合成,然后从 Adobe Premiere Pro 中动态链接到这些合成。您也可以从 Adobe Premiere Pro 中动态链接到现有的 After Effects 合成。

从 Adobe Premiere Pro 中的剪辑创建合成图像

您可以将 Adobe Premiere Pro 中的选定剪辑替换为基于这些剪辑的 After Effects 动态链接合成。新合成将从 Adobe Premiere Pro 继承序列设置。

  1. 打开 Premiere Pro 并选择要替换的剪辑。

  2. 右键单击任何所选剪辑。
  3. 选择“使用 After Effects 合成替换”

    此时将打开 After Effects(如果尚未打开)并创建一个新的链接合成。

从 Adobe Premiere Pro 创建动态链接合成

从 Adobe Premiere Pro 中创建一个新的动态链接合成会启动 After Effects。After Effects 随后使用来源项目的尺寸、像素长宽比、帧速率和音频采样率来创建项目和合成。(如果 After Effects 已经在运行,则在当前项目中创建一个合成。)新合成名称基于 Adobe Premiere Pro 项目名称,后接 Linked Comp [x]

  1. 在 Adobe Premiere Pro 中,选择“文件”>“Adobe Dynamic Link”>“新建 After Effects 合成”。在 Premiere Pro 2014 版中,可以使用媒体浏览器导入合成。有关更多信息,请参阅 Premiere Pro 中的以下部分:

  2. 如果出现 After Effects“另存为”对话框,请为 After Effects 项目输入名称和位置,然后单击“保存”。

    注意:

    创建 After Effects Dynamic Link 合成时,合成持续时间设置为 30 秒。要更改持续时间,请在 After Effects 中选择该合成,然后选择“合成”>“合成设置”。单击“基本”选项卡,然后为“持续时间”指定新值。

为获得最佳效果,请将合成设置(如尺寸、像素长宽比和帧速率)匹配到 Adobe Premiere Pro 项目中的相应设置。

  1. 执行以下操作之一:
    • 在 Adobe Premiere Pro 中,选择文件 > Adobe Dynamic Link > 导入 After Effects 合成。选择 After Effects 项目文件 (.aep),然后选择一个或多个合成。

    • 在 Adobe Premiere Pro 中,选择一个 After Effects 项目文件,然后单击“打开”。然后在显示的对话框中选择一个合成并单击“确定”。

    • 将一个或多个合成从 After Effects“项目”面板拖到 Adobe Premiere Pro“项目”面板中。

    • 将一个 After Effects 项目文件拖到 Premiere Pro“项目”面板中。如果 After Effects 项目文件包含多个合成,“导入合成”对话框则会打开。

注意:

您可以在单个 Adobe Premiere Pro 项目中多次链接到单个 After Effects 合成。

在 After Effects 中修改动态链接合成

在 Adobe Premiere Pro 中使用编辑原稿命令来修改链接的 After Effects 合成。当合成在 After Effects 中打开后,您可以更改合成,而无需再次使用“编辑原稿”命令。

  1. 在 Adobe Premiere Pro 中选择 After Effects 合成,或者在时间轴中选择链接剪辑,然后选择“编辑”>“编辑原稿”

  2. After Effects 中更改合成。然后,切换回 Adobe Premiere Pro 查看您所做的更改。

在 After Effects 中所做的更改显示在 Adobe Premiere Pro 中。Adobe Premiere Pro 停止使用在更改前为剪辑渲染的任何预览文件。

注意:

从 Adobe Premiere Pro 中创建与 After Effects 合成的动态链接后,您可以在 After Effects 中更改该合成的名称。Adobe Premiere Pro 不会在“项目”面板中更新链接合成名称。但是,Adobe Premiere Pro 确实会保留该动态链接。

删除动态链接的合成或剪辑

您可以随时从 Adobe Premiere Pro 项目中删除链接合成,即使该合成在某个项目中使用。

您可以从 Adobe Premiere Pro 序列的时间轴或时间轴中随时删除链接剪辑。

  1. 在 Adobe Premiere Pro 中,选择链接的合成或剪辑并按 Delete 键。

使用 Dynamic Link 在 Adobe Premiere Pro 中创建链接序列

从 After Effects 创建 Adobe Premiere Pro 序列会启动 Adobe Premiere Pro。Adobe Premiere Pro 随后使用来源项目的尺寸、像素长宽比、帧速率和音频采样率来创建项目和序列。(如果 Adobe Premiere Pro 已经在运行,则会在当前项目中创建一个序列。)

  1. 在 After Effects 中,选择“文件”>“Adobe Dynamic Link”>“新建 Premiere Pro 序列”

为获得最佳效果,请将 Adobe Premiere Pro 中的序列设置和项目设置(如尺寸、像素长宽比和帧速率)匹配到 After Effects 项目中的相应设置。

执行以下操作之一:

  • 在 After Effects 中,选择“文件”>“Adobe Dynamic Link”>“导入 Premiere Pro 序列”。选择一个 Adobe Premiere Pro 项目,然后选择一个或多个序列。

  • 将一个或多个序列从 Adobe Premiere Pro“项目”面板拖到 After Effects“项目”面板中。

Dynamic Link 性能

链接剪辑可以引用复杂源合成。根据复杂程度,您在源合成上执行的操作需要额外的处理时间。After Effects 应用这些操作,并利用全局性能缓存和持续磁盘缓存功能使最终数据可用于 Adobe Premiere Pro。当 Premiere Pro 需要帧时,这些功能通过使用缓存的帧来提高 After Effects 性能。

要降低播放延迟,请执行以下任一操作:

  • 使链接合成脱机

  • 禁用链接剪辑以暂时停止引用合成

  • 在 Premiere Pro 中使用“渲染并替换”功能(“剪辑”>“渲染并替换”),用渲染后的文件替换动态链接的合成。 

如果您常使用复杂的源合成,请增加您的 RAM 或升级为更快的处理器。

注意:

链接的 After Effects 合成将不支持“同时渲染多个帧”多重处理。请参阅通过优化内存、缓存和多重处理设置来提高性能

导出到 Adobe Media Encoder

若要对 After Effects 合成进行编码,您必须在 Adobe Media Encoder 中将项目添加到编码队列,然后选择编码预设或创建您自己的自定义渲染设置。在 After Effects 中,使用以下选项之一,可将合成添加到 Media Encoder 队列:

  • “文件”>“导出”>“添加到 Media Encoder 队列”
  • “合成”>“添加到 Media Encoder 队列”

当您将合成或项目添加到 Adobe Media Encoder 队列时,After Effects 会启动 Adobe Media Encoder,此时合成在队列中列出。

以下文章中介绍了编码流程:

Adobe 徽标

登录到您的帐户

[Feedback V2 Badge]