关于导入的文件和素材项目

可将源文件作为素材项目的基础导入某项目中,进而将其作为图层源。同一文件可以作为多个素材项目的源,而每个素材项目具有各自的解释设置。每个素材项目可作为一个或多个图层的源。可在合成中处理图层集合。

首先在“项目”面板中处理素材项目。可以使用“素材”面板评估素材并执行简单的编辑任务,例如修剪素材项目的持续时间。

您可以导入各种文件、文件集合或文件组件作为单个素材项目的源,包括移动图像文件、静止图像文件、静止图像序列和音频文件。甚至可以在 After Effects 中创建素材项目,如纯色和预合成。您可以随时将素材项目导入项目中。

在导入文件时,After Effects 不是将图像数据本身复制到项目中,而是创建指向素材项目的源文件的引用链接,以保持项目文件相对较小。

如果删除、重命名或移动导入的源文件,将断开指向该文件的引用链接。当断开链接后,源文件的名称在“项目”面板中显示为斜体,而“文件路径”列会显示该文件缺失。如果素材项目可用,可以重新建立链接,通常只需双击该素材项目并再次选择文件即可。

注意:

要查找哪些素材项目的源项目缺失,请在“项目”面板的搜索字段中键入 missing。请参阅在“时间轴”、“项目”以及“效果和预设”面板中搜索和过滤

为缩短渲染时间以提高性能,通常最好在将素材导入 After Effects 前先准备好素材。例如,最好先在 Photoshop 中缩放或裁剪静止图像,然后再将其导入 After Effects,而不是在 After Effects 中进行缩放和裁剪。最好是在 Photoshop 中执行操作一次,而不是在 After Effects 中每秒多次执行相同的操作,即对显示该图像的每个帧都执行一次。

为节约时间并尽可能减小项目的大小和降低复杂度,应将源项目作为单个素材项目导入,然后在合成中多次使用它。但偶尔也需要复制素材项目并对其分别做出解释。例如,可以在两个不同帧速率下使用同一个素材。

如果您使用另一个应用程序修改在项目中使用的素材项目,那么您所进行的更改将在下次打开该项目或选择该素材项目并选择“文件”>“重新加载素材”时,显示在 After Effects 中。

注意:

要用另一个素材项目替换某图层的源素材项目,而不影响对图层属性所做的更改,请在“时间轴”面板中选择该图层,然后按住 Alt 键拖动 (Windows) 或按住 Option 键拖动 (Mac OS),将新素材项目拖到该图层上。

注意:

要将使用的所有选定素材项目替换为另一个素材项目,请在“项目”面板上选择素材项目,然后按住 Alt 键拖动 (Windows) 或按住 Option 键拖动 (Mac OS),将新素材项目拖到“项目”面板中的选定素材项目上。

当 After Effects 导入某些格式的视频和音频时,它会对这些导入项的各个版本进行处理并缓存,以便在生成预览时能够易于访问。这种缓存可以大大提高预览性能,因为在每次预览时无需对视频和音频项目进行重新处理。

有关导入资源的更多信息,请参阅 Creative COW 网站上由 Andrew Devis 提供的此视频教程

QuickTime 文件的原生编码与解码

After Effects 可使用 GoPro CineForm 编解码器,对 Mac OS 和 Windows 上的本机 QuickTime (.mov) 文件进行解码和编码。这意味着,您不再需要安装用于创建和使用此类文件的其他编解码器。

在 MOV 中,After Effects 具有对以下未压缩格式的本机导入支持:

  • DV、IMX、MPEG2、XDCAM、h264、JPEG、Avid DNxHD、Avid DNxHR、Apple ProRes、AVCI 和 GoPro CineForm

本机导出支持适用于以下未压缩格式:

  • Avid DNxHD、Avid DNxHR、DV 和 GoPro CineForm

注意:

由于 After Effects 可以本机导入和导出许多编解码器(如上列出),Windows 不要求安装 QuickTime。有关兼容性问题的更多详细信息,请阅读博客帖子 Windows 上的 QuickTime

支持的导入格式

一些文件扩展名(如 MOV、AVI、MXF、FLV 和 F4V)表示容器文件格式,而不表示特定的音频、视频或图像数据格式。容器文件可以包含使用各种压缩和编码方案编码的数据。After Effects 可以导入这些容器文件,但导入其所包含的数据的能力则取决于所安装的编解码器(具体讲就是解码器)。

通过安装额外的编解码器,您可以将 After Effects 的能力扩展为导入额外的文件类型。必须在操作系统(Windows 或 Mac OS)中安装许多编解码器,并将其用作 QuickTime 或 Video for Windows 格式的组件。有关可与您的特定设备或应用程序创建的文件配合使用的编解码器的更多信息,请联系您的硬件或软件制造商。

导入和使用某些文件需要安装额外的导入增效工具。(请参阅增效工具。)

Adobe Premiere Pro 可以捕捉和导入 After Effects 本身不能导入的许多格式。可以通过多种方式将 Adobe Premiere Pro 数据导入 After Effects 中。(请参阅使用 Adobe Premiere Pro 和 After Effects。)

音频格式

  • Adobe Sound Document(ASND;作为合并的单轨文件导入的多轨文件)

  • 高级音频编码(AAC、M4A)

  • 音频交换文件格式(AIF、AIFF)

  • MP3(MP3、MPEG、MPG、MPA、MPE)

  • Video for Windows(AVI;在 Mac OS 上需要 QuickTime)

  • Waveform (WAV)

静止图像格式

  • Adobe Illustrator(AI、AI4、AI5、EPS、PS;连续栅格化)
  • Adobe PDF(PDF;仅限首页;连续栅格化)
  • Adobe Photoshop (PSD)
  • 位图(BMP、RLE、DIB)
  • Camera Raw(TIF、CRW、NEF、RAF、ORF、MRW、DCR、MOS、RAW、PEF、SRF、DNG、X3F、CR2、ERF)
  • Cineon/DPX(CIN、DPX 和 8、10、12 和 16-bpc DPX 文件,包括含 Alpha 通道和时间码的文件)
  • Discreet RLA/RPF(RLA、RPF;16bpc;导入摄像机数据)
  • EPS
  • GIF
  • JPEG(JPG、JPE)
  • Maya 摄像机数据 (MA)
  • Maya IFF(IFF、TDI;16bpc
  • OpenEXR(EXR、SXR、MXR;32bpc
  • PICT (PCT)
  • 可移植网络图形(PNG;16 bpc)
  • Radiance(HDR、RGBE、XYZE;32 bpc)
  • SGI(SGI、BW、RGB;16 bpc)
  • Softimage (PIC)

注意:

After Effects 中包括 fnord 软件中的 3D 通道增效工具,可用来访问 OpenEXR 文件的多个图层和通道。(请参阅使用 OpenEXR 文件中的通道。)

注意:

After Effects 也可以读取与导入的 PIC 文件对应的 ZPIC 文件。请参阅导入和使用来自其他应用程序的 3D 文件。)

  • Targa(TGA、VDA、ICB、VST)

  • TIFF (TIF)

注意:

您可以按序列导入任何静止图像格式的文件。请参阅准备和导入静止图像

视频和动画格式

  • 动画 GIF (GIF)
  • Avid DNxHR
  • HEVC (H.265) MPEG-4
  • 支持来自 ARRI ALEXA 或 ARRIFLEX D-21 摄像机的 ARRIRAW 文件
    有关 ARRIRAW 文件的更多信息,请参阅 ARRI Group 网站上的 ARRIRAW 常见问题解答
  • CinemaDNG

注:CinemaDNG 是 Camera Raw 的子集。可通过“解释素材”对话框中的“更多选项”访问 Camera RAW 设置的子集。CinemaDNG 的色彩管理包括与 After Effects 的现有 Camera RAW 相同的色彩空间:Adobe RGB、sRGB IEC619662.1、ColorMatch RGB 以及 ProPhoto RGB。

  • DV(在 MOV 或 AVI 容器中,或作为无容器 DV 流)
  • Electric Image(IMG、EI)
  • FLV、F4V
  • QuickTime(MOV;16bpc,只针对没有任何本机解码器的编码器)
  • Video for Windows(AVI、WAV;在 Mac OS 上需要 QuickTime)

  • Windows 媒体文件(WMV、WMA、ASF;仅限 Windows)

  • XDCAM HD 和 XDCAM EX

  • RED (R3D)
  • 媒体交换格式 (MXF)

MXF 是一种容器格式。After Effects 只能导入 MXF 文件中包含的某些种类的数据。After Effects 可以导入 Panasonic 摄像机用于录制到 Panasonic P2 媒体上的 Op-Atom 类型的 MXF 文件。After Effects 可以使用 AVC-Intra 50、AVC-Intra 100、DV、DVCPRO、DVCPRO50 和 DVCPRO HD 编解码器从这些 MXF 文件导入视频。After Effects 还可导入 MXF 格式、MXF OP1 格式的 XDCAM HD 文件,其中符合 XDCAM HD 格式的 MPEG-2 视频。

  • MPEG-1、MPEG-2 和 MPEG-4 格式:MPEG、MPE、MPG、M2V、MPA、MP2、M2A、MPV、M2P、M2T、M2TS (AVCHD)、MP4、M4V、M4A
  • SWF(连续栅格化)

项目格式

  • Adobe Premiere Pro 1.0、1.5、2.0、CS3、CS4、CS5、CS6 和 CC(PRPROJ;仅限 1.0、1.5 和 2.0 Windows)以及以后的项目

  • After Effects CS5 中的 Adobe After Effects 6.0 和更高版本二进制项目(AEP、AET)

  • After Effects 7 可以打开来自 After Effects 3.0 - After Effects 7 的项目。

  • Adobe After Effects CS4 和更高版本中的 XML 项目 (AEPX)

Automatic Duck Pro Import AE 增效工具现在与应用程序捆绑在一起,称为“Pro Import After Effects”。使用该工具,您可以导入来自 Avid 系统的 AAF 和 OMF 文件,来自 Final Cut Pro 7 或更低版本的 XML 文件,以及来自 Motion 4 或更低版本的项目文件。有关使用 Pro Import After Effects 的更多信息,请参阅其用户指南(通过选择“文件”>“导入”>“Pro Import After Effects”,然后单击“帮助”按钮可查看该指南)。

您也可以将 Final Cut Pro 项目导入 Premiere Pro,然后将该项目的组件导入 After Effects。


注意:

 

  • After Effects 还可读取与导入的 EI 文件对应的 EIZ 文件。请参阅导入和使用来自其他应用程序的 3D 文件
  • 有些 MPEG 数据格式存储为 After Effects 无法识别其文件扩展名的容器格式,例如 .vob 和 .mod。在某些情况下,您可以将文件扩展名更改为某种可识别的扩展名,然后再将这些文件导入 After Effects。由于在实现这些容器格式方面存在差异,所以不能保证兼容性。
  • 有关 MPEG 格式的信息,请参阅 MPEG 网站Wikipedia 网站上的 MPEG 页面。
  • 使用 QuickTime 之前,请阅读美国计算机应急准备小组于 2016 年 4 月发布的警报,该警报建议 Windows 用户从计算机上卸载 Apple QuickTime
  • R3D 文件被解释为在非线性 HDTV (Rec. 709) 色彩空间包含 32-bpc 颜色。“RED R3D 源设置”颜色调整不保留过亮值。在使用 32-bpc(位/通道)时,在 After Effects 中完成的颜色调整会保留过亮颜色。为避免剪切,请在 After Effects 中处理曝光度,而不要在素材解释阶段在“RED R3D 源设置”对话框中进行处理。
  • After Effects 可以导入录制为 MXF 文件的 Sony XDCAM HD 资源。After Effects 不能以 IMX 格式导入 XDCAM HD 资源。After Effects 可以导入在 BPAV 目录中以文件扩展名 .mp4 存储为要素文件的 Sony XDCAM EX 资源。有关 XDCAM 格式的信息,请参阅 Sony 网站上的此 PDF 文档
  • 导入的 SWF 文件附带一个 Alpha 通道。不保留音频。不保留交互内容和脚本动画。保留主要的顶级影片中关键帧所定义的动画。

导入素材项目

通过使用“导入”对话框或拖动,可以将媒体文件导入项目。导入的素材项目出现在“项目”面板中。

如果在导入素材项目之后出现“解释素材”对话框,则其中将包含一个未标记的 Alpha 通道,并且您必须选择 Alpha 通道解释方法,或单击“猜测”让 After Effects 来决定如何解释该 Alpha 通道。(请参阅 Alpha 通道解释:预乘或直接。)

使用“导入”对话框导入素材项目

  1. 选择“文件”>“导入”>“文件”,选择“文件”>“导入”>“多个文件”,或双击“项目”面板上的空白区域。

    如果选择“导入多个文件”,则可以多次执行下一步,而不需要多次选择“导入”命令。

    注意:

    要只显示支持的素材文件(不包括项目文件),请从“文件类型”(Windows) 或“启用”(Mac OS) 菜单中选择“所有素材文件”。

  2. 执行以下操作之一:
    • 选择一个文件,单击“打开”。

    • 按住 Ctrl 键 (Windows) 或按住 Command 键 (Mac OS) 并单击多个文件来选择它们,然后单击“打开”。

    • 单击一个文件,然后按住 Shift 键并单击另一个文件来选择一系列文件,然后单击“打开”。

    • (仅限 Windows)选择整个文件夹,然后单击“导入文件夹”。

    注意:

    如果选择了“序列”选项,则会将该文件夹中的多个文件导入为一系列静止图像。

通过拖动导入素材项目

注意:

如果您希望拖入 After Effects 的分层静止图像文件总是作为合成导入,请选择“编辑”>“首选项”>“导入”(Windows) 或“After Effects”>“首选项”>“导入”(Mac OS),然后从“通过拖动将多个项目导入为”菜单中选择“合成”或“合成 - 保持图层大小”。(请参阅将静止图像序列作为合成导入。)

  • 要导入单个文件,请从 Windows 资源管理器 (Windows) 或 Finder (Mac OS) 将其拖动到“项目”面板中。
  • 要将文件夹内容作为静止图像序列导入,并使这些图像在“项目”面板中显示为单个素材项目,请从 Windows 资源管理器 (Windows) 或 Finder (Mac OS) 将文件夹拖动到“项目”面板中。
  • 要将文件夹内容作为单个素材项目导入,并使这些项目显示在“项目”面板中的相应文件夹中,请按住 Alt 键从 Windows 资源管理器 (Windows) 或按住 Option 键从 Finder (Mac OS) 将该文件夹拖动到“项目”面板中。
  • 要从“渲染队列”面板导入渲染的输出文件,请从“渲染队列”面板拖动相应的输出模块到“项目”面板中。

注意:

如果将未经渲染的输出模块从“渲染队列”面板拖动到“项目”面板,After Effects 将创建一个占位符素材项目。渲染该输出模块后,会自动替换对占位符素材项目的引用,但不替换占位符素材项目本身。

解释素材项目

After Effects 利用一套内部规则,根据它对源文件的像素长宽比、帧速率、颜色配置文件和 Alpha 通道类型的最佳猜测,来解释您导入的每个素材项目。如果 After Effects 的猜测是错误的,或者您想以不同方式使用素材,则可以通过编辑解释规则文件(解释规则.txt)来针对特殊类型的所有素材项目修改这些解释规则,或者使用“解释素材”对话框修改特定素材项目的解释。

解释设置将告知 After Effects 关于每个素材项目的以下内容:

注意:

在所有这些情况中,以上信息用来决定如何解释导入的素材项目中的数据,即告知 After Effects 有关输入素材的情况。“解释素材”对话框中的解释设置应与用于创建源素材文件的设置相符。不要试图用解释设置来为您的最终渲染输出指定设置。

通常,您无需更改解释设置。但是,如果某个素材项目不属于常见类型,After Effects 可能需要您提供额外信息以便正确解释它。

您可以使用“解释素材”对话框中“色彩管理”部分中的控件来告知 After Effects 如何解释素材项目中的颜色信息。通常,仅在素材项目中不包含嵌入的颜色配置文件时才需要执行该步骤。

在“素材”面板中预览时,您可以查看素材解释操作的结果。

Jeff Almasol 在他的 redefinery 网站上提供了一个脚本,可帮助您更方便地猜测 3:2 Pulldown、24Pa Pulldown 或 Alpha 通道解释。

注意:

在接受更改前,在“解释素材”对话框中选择“预览”可预览在该对话框中所做设置的结果。

使用“解释素材”对话框解释单个素材项目

  1. 在“项目”面板中选择一个素材项目并执行以下操作之一:
    • 单击“项目”面板底部的“解释素材” 按钮。

    • 将该素材项目拖到“解释素材”按钮上。

    • 选择“文件”>“解释素材”>“主要”。

    • 按 Ctrl+Alt+G (Windows) 或 Command+Option+G (Mac OS)。

使用“解释素材”对话框解释代理

  1. 在“项目”面板中选择原始素材项目并执行以下操作之一:
    • 按住 Alt 键 (Windows) 或 Option 键 (Mac OS) 并单击“项目”面板底部的“解释素材” 按钮。

    • 按住 Alt 键 (Windows) 或 Option 键 (Mac OS) 将素材项目拖动到“解释素材”按钮上。

    • 选择“文件”>“解释素材”>“代理”。

将“解释素材”设置应用于多个素材项目

通过复制一个素材项目的解释设置并将其应用于其他项目,可以确保不同的素材项目使用相同的设置。

  1. 在“项目”面板中,选择具有您要应用的解释设置的素材项目。
  2. 选择“文件”>“解释素材”>“记住解释”。
  3. 在“项目”面板中选择一个或多个素材项目。
  4. 选择“文件”>“解释素材”>“应用解释”。

编辑特定类型的所有项目的解释规则

解释规则文件包含指定 After Effects 如何解释素材项目的规则。大多数情况下,您不需要自定义解释规则文件。当您导入素材项目时,After Effects 会在解释规则文件中查找匹配项,然后确定适用于该素材项目的解释设置。导入后,您可以使用“解释素材”对话框覆盖这些设置。

大多数情况下,解释规则文件的名称为解释规则.txt;但是,After Effects 的一些更新安装了一个新的解释规则文件,其名称中指出更新的版本号,而更新的应用程序使用这一新文件。如果您对旧解释规则文件进行了更改,则可能还需对新文件应用这些更改。

After Effects CC 中解释规则文件的位置:

  • (Windows) <驱动器>\Users\<用户名>\AppData\Roaming\Adobe\After Effects <15.1>
  • (Mac OS) <驱动器>/Users/<用户名>/Library/Preferences/Adobe/After Effects <15.1>

早期版本的 After Effects CC 中解释规则文件的位置:

  • (Windows) <驱动器>\Users\<用户名>\AppData\Roaming\Adobe\After Effects <14.x>
  • (Mac OS) <驱动器>/Users/<用户名>/Library/Preferences/Adobe/After Effects <14.x>
  1. 退出 After Effects。
  2. 作为预防措施,应对解释规则文件进行备份。默认情况下,该文件与 After Effects 应用程序位于相同位置。
  3. 在文本编辑器中打开解释规则文件。
  4. 根据文件中的说明修改设置。

    注意:

    您必须提供每种素材类型或编解码器的四字符文件类型代码。如果您不知道项目中某个文件或编解码器的代码,请在“项目”面板中选择文件并按 Alt 键 (Windows) 或 Option 键 (Mac OS)。文件类型代码和编解码器代码(如果文件被压缩)显示在“项目”面板顶端文件说明的最后一行中。

  5. 保存“解释规则.txt”。

Alpha 通道解释:预乘或直接

具有 Alpha 通道的图像文件通过下面两种方式之一存储透明度信息:直接或预乘。虽然 Alpha 通道相同,但颜色通道不同。

使用直接(或无遮罩)通道,透明度信息只存储在 Alpha 通道中,而不存储在任何可见的颜色通道中。使用直接通道时,仅在支持直接通道的应用程序中显示图像时才能看到透明度结果。

使用预乘(或有遮罩)通道,透明度信息既存储在 Alpha 通道中,也存储在可见的 RGB 通道中,后者乘以一个背景颜色。预乘通道有时也称为有彩色遮罩。半透明区域(如羽化边缘)的颜色偏向于背景颜色,偏移度与其透明度成比例。

一些软件允许您指定用于预乘通道的背景色;否则背景色通常为黑色或白色。

直接通道比预乘通道保留更准确的颜色信息。预乘通道可以与多种程序兼容,如 Apple QuickTime Player。通常,在您收到用于编辑和合成的资源之前,已经选定了是使用具有直接通道的图像还是具有预乘通道的图像。Adobe Premiere Pro 和 After Effects 可同时识别直接通道和预乘通道,但只是它们在包含多个 Alpha 通道的文件中所遇到的第一个 Alpha 通道。

正确地设置 Alpha 通道解释可以避免在导入文件时发生问题,如图像边缘出现杂色,或者 Alpha 通道边缘的图像品质下降。例如,如果通道实际是预乘通道而被解释成直接通道,则半透明区域将保留一些背景颜色。如果颜色不准确,例如在一个合成中沿着半透明边缘出现光晕,请试着更改解释方法。

预乘通道
具有预乘通道的素材项目(上图)被解释为“直接 - 无遮罩”(左下图)时出现黑色光晕。当素材项目被解释为“预乘 - 有彩色遮罩”并且背景颜色指定为黑色时没有出现光晕(右下图)。

您可以使用“移除颜色遮罩”效果,通过取消相乘图层而从该图层的半透明区域移除条纹。

设置素材项目的 Alpha 通道解释

  1. 在“项目”面板中,选择一个素材项目。
  2. 选择“文件”>“解释素材”>“主要”。
  3. 如果要转换图像的不透明和透明区域,请选择“反转 Alpha”。
  4. 在“Alpha”部分,选择解释方法:

    猜测

    尝试确定图像中使用的通道类型。如果 After Effects 无法确信,则发出嘟嘟声。

    忽略

    忽视 Alpha 通道内包含的透明度信息。

    直接 - 无遮罩

    将通道解释为直接通道。

    预乘 - 有彩色遮罩

    将通道解释为预乘通道。使用吸管或拾色器指定预乘通道的背景颜色。

设置默认 Alpha 通道首选项

  1. 选择“编辑”>“首选项”>“导入”(Windows) 或“After Effects”>“首选项”>“导入”(Mac OS)。
  2. 从“将未标记的 Alpha 解释为”菜单中选择选项。该菜单中的选项类似于“解释素材”对话框中的选项。“询问用户”指定每次在导入具有未标记的 Alpha 通道的素材项目时打开“解释素材”对话框。

帧速率

合成帧速率确定每秒显示的帧数,以及在时间标尺和时间显示中如何将时间划分给帧。换言之,合成帧速率指定每秒从源素材项目对图像进行多少次采样,以及设置关键帧时所依据的时间划分方法。

注意:

After Effects 在“合成设置”对话框中包含一个有关丢帧或无丢帧时间码的菜单。在早期版本中,该选项是每个项目的全局设置。

合成帧速率通常由您的目标输出类型决定。NTSC 视频的帧速率为 29.97 帧/秒 (fps),PAL 视频的帧速率为 25 fps,运动图片影片的帧速率通常为 24 fps。根据广播系统,DVD 视频的帧速率可以与 NTSC 视频或 PAL 视频相同,或者为 23.976。卡通和 CD-ROM 视频或 Web 视频通常为 10–15 fps。

注意:

将合成帧速率设置为输出格式速率的两倍会导致 After Effects 在“合成”面板中将隔行源素材的每个场显示为其各自的单独帧。该过程使您可以在各个场中设置关键帧并在制作蒙版动画时获得精确度。

在为最终输出渲染影片时,您可以选择使用合成帧速率或其他帧速率。当您使用相同的合成创建多媒体输出时,这种为每个输出模块设置帧速率的功能很有用。

针对高帧速率素材的支持

您可以在 2017 年 4 月版 After Effects CC 中,将任何帧速率字段设置为最高 999 fps。这项更新可让您为渲染使用更高的帧速率,与早期版本不同,后者只能将合成的最高帧速率设置为 99 fps。

合成中的每个运动素材项目也可以有自己的帧速率。素材项目帧速率和合成帧速率之间的关系决定图层播放的平滑度。例如,如果素材项目帧速率为 30 fps,并且合成帧速率为 30 fps,则每当合成前进一帧时,都会显示素材项目中的下一帧。如果素材项目帧速率为 15 fps,而合成帧速率为 30 fps,则素材项目的每个帧显示在合成的两个连续帧中。(当然,这里假定的是简单情况,即没有时间伸缩或帧混合应用于图层。)

理想情况下,应使用与最终输出帧速率相匹配的源素材。这样,After Effects 会渲染每个帧,而最终输出不会漏掉、重复或插入帧。然而,如果源素材的帧速率与您希望输出到的帧速率稍有不同(例如,30 fps 素材和 29.97 fps 最终输出),您可以通过进行匹配使素材帧速率与合成帧速率相一致。

匹配素材项目帧速率不会改变原始文件,只改变 After Effects 使用的引用。匹配后,After Effects 将改变帧的内部持续时间,而不改变帧内容。之后,在不同速度下播放素材。例如,如果将帧速率从 15 fps 匹配为 30 fps,则素材播放速度将加快一倍。在大多数情况下,当素材帧速率和输出帧速率之间的差异很小时,只匹配帧速率。

注意:

匹配可以改变具有音频轨道的可视化素材的同步,因为更改帧速率会改变视频的持续时间,而使音频保持不变。如果您要同时伸缩音频和视频,请使用“时间伸缩”命令。(请参阅图层时间伸缩。)应用于源素材的关键帧仍在其原来的位置(从而在合成内而非图层的可视化内容中保持同步)。匹配素材项目后,您可能需要调整关键帧的位置。

您可以更改任何影片或静止图像序列的帧速率。例如,您可以导入一个包含十个静止图像的序列,并指定该素材项目的帧速率为 5 帧/秒 (fps);当在合成中使用时,该序列将具有两秒的持续时间。

注意:

当导入静止图像序列时,采用“导入”类别中“序列素材”首选项所指定的帧速率。默认速率为 30 帧/秒 (fps)。导入后,可以通过重新解释素材项目来更改帧速率。(请参阅解释素材项目。)

较低的帧速率往往给人以虚幻飘逸的感觉,所以很多人宁愿使用较低的帧速率,比如对于创意性工作采用 24 帧/秒,而不是 29.97 帧/秒(NTSC 视频标准)。

注意:

如果从隔行视频素材中移除 3:2 Pulldown,After Effects 会自动将结果素材项目的帧速率设置为原帧速率的五分之四。从 NTSC 视频中移除 3:2 Pulldown 时,结果帧速率是 24 fps。

合成的帧速率应与最终输出格式的帧速率相符。大多数情况下,只需选择一个合成设置预设。相反,应将每个素材项目的帧速率设置为原始源素材的帧速率。

Trish 和 Chris Meyer 在 Artbeats 网站上的一篇文章(PDF 格式)中提供了有关将素材项目与特定帧速率相匹配的提示和技巧。

更改素材项目的帧速率

  1. 在“项目”面板中选择素材项目。
  2. 选择“文件”>“解释素材”>“主要”。
  3. 选择“匹配帧速率”,在“每秒帧数”中输入新的帧速率,然后单击“确定”。

注意:

可以不使用“解释素材”更改素材项目的帧速率,而是基于素材项目对图层进行时间伸缩处理。例如,按 100.1% 对图层进行时间伸缩处理,以在 30 fps 和 29.97 fps 之间转换。时间伸缩可修改音频和视频的速度。(请参阅图层时间伸缩。)

更改合成的帧速率

  1. 选择“合成”>“合成设置”。
  2. 执行以下操作之一:
    • 从“预设”菜单中选择合成设置预设。

    • 设置帧速率值。

注意:

Jeff Almasol 在 redefinery 网站上提供了一个脚本,可用来设置当前合成以及其中嵌套的所有合成的帧速率和持续时间。

像素长宽比和帧长宽比

像素长宽比 (PAR) 指图像中一个像素的宽与高之比。帧长宽比(有时也称图像长宽比IAR)指图像帧的宽与高之比。

帧长宽比
4:3 帧长宽比(左图)和较宽的 16:9 帧长宽比(右图)

多数计算机显示器使用方形像素,但许多视频格式(包括 ITU-R 601 (D1) 和 DV)使用非方形的矩形像素。

一些视频格式输出相同的帧长宽比,但使用不同的像素长宽比。例如,一些 NTSC 数字器生成 4:3 帧长宽比,使用方形像素(1.0 像素长宽比),帧的像素尺寸为 640x480。D1 NTSC 生成相同的 4:3 帧长宽比,但使用非方形像素(0.91 像素长宽比),帧的像素尺寸为 720x486。D1 像素始终为非方形,在生成 NTSC 视频的系统中为垂直方向,在生成 PAL 视频的系统中为水平方向。

如果在方形像素监视器上显示非方形像素,而不做任何改变,则图像和运动会出现扭曲,例如,圆形扭曲为椭圆形。但是,如果在视频监视器上显示,则图像显示正常。将 D1 NTSC 或 DV 源素材导入 After Effects 时,图像看起来比在 D1 或 DV 系统上稍微宽一些。(D1 PAL 素材看起来稍微窄一些。)当使用 D1/DV NTSC 宽银幕或 D1/DV PAL 宽银幕导入变形素材时,情况正相反。宽银幕视频格式使用 16:9 帧长宽比。

注意:

要在计算机监视器上预览非方形像素,请单击“合成”面板底部的“切换像素长宽比校正”按钮 。预览的像素长宽比校正的质量受“预览”类别下“缩放质量”首选项的影响。(请参阅“查看器质量”首选项。)

方形和非方形像素
方形和非方形像素

A. 方形像素以及 4:3 帧长宽比 B. 非方形像素以及 4:3 帧长宽比 C. 显示在方形像素监视器上的非方形像素 

如果素材项目使用非方形像素,则 After Effects 在“项目”面板中素材项目的缩略图旁显示像素长宽比。可以在“解释素材”对话框中更改各个素材项目的像素长宽比解释。通过确保所有素材项目得到正确解释,您可以在相同合成中合并具有不同像素长宽比的素材项目。

After Effects 直接从 QuickTime 影片读取和写入像素长宽比。例如,如果您导入捕捉为宽银幕 (16:9 DV) 的影片,After Effects 会自动正确地标记它。同样,AVI 和 PSD 文件包含明确指出图像像素长宽比的信息。

如果素材项目不包含明确指出图像像素长宽比的信息,After Effects 将使用素材项目帧的像素尺寸来进行推测。当导入具有 720x486 D1 像素尺寸或 720x480 DV 像素尺寸的素材项目时,After Effects 会自动将该素材项目解释为 D1/DV NTSC。当导入具有 720x576 的 D1 或 DV 像素尺寸的素材项目时,After Effects 会自动将该素材项目解释为 D1/DV PAL。然而,您可以通过查看“项目”面板或“解释素材”对话框来确保所有文件都得到正确解释。

注意:

当导入恰好具有 D1 或 DV 像素尺寸的方形像素文件(例如像素尺寸恰好为 720x480 的非 DV 图像)时,请确保将像素长宽比重置为“方形像素”。

合成的像素长宽比设置应与最终输出格式的像素长宽比相符。大多数情况下,只需选择一个合成设置预设。相反,应将每个素材项目的像素长宽比设置为原始源素材的像素长宽比。

Trish 和 Chris Meyer 在 Artbeats 网站上的两个 PDF 文档中提供了有关像素长宽比的提示和技巧:

Chris Pirazzi 在他的 Lurker's Guide to Video 网站上提供了关于长宽比的技术细节。

将像素长宽比升级为正确值

After Effects CS3 和更低版本将像素长宽比用于忽略干净光圈概念的标清视频格式。由于没有考虑到在标清视频中,干净光圈不同于作品光圈的事实,After Effects CS3 和更低版本使用的像素长宽比稍有些不准确。错误的像素长宽比会导致一些图像看起来略显扭曲。

注意:

干净光圈是图像中不受图像边缘上出现的失真和扭曲影响的部分。作品光圈是整个图像。

Todd Kopriva 在 Adobe 网站上的一篇文章中总结了有关校正的像素长宽比的信息。

下表提供了有关 After Effects 中像素长宽比值的详细信息:

格式

After Effects CS4 和更高版本中的值

以往值

D1/DV NTSC

0.91

0.9

D1/DV NTSC 宽银幕

1.21

1.2

D1/DV PAL

1.09

1.07

D1/DV PAL 宽银幕

1.46

1.42

此偏差仅限于这些较旧的干净光圈不同于作品光圈的标清格式。较新的格式中不存在该偏差。

默认情况下,在 After Effects CS4 和更高版本中创建的新项目和合成使用正确的像素长宽比值。

在 After Effects CS4 和更高版本中打开用 After Effects CS3 或更低版本创建的项目和合成时,这些项目将升级为使用正确的像素长宽比。

注意:

如果您使用自定义解释规则文件,则应使用正确的像素长宽比值更新它。

如果您使用的方形像素素材项目设计为用非方形像素填充合成中的帧,则您可能会发现像素长宽比的变化会导致出现不同行为。例如,如果您以前创建了 768x576 方形像素素材项目以在 PAL D1/DV 合成中使用,则现在应使用 788x576 方形像素尺寸创建这些项目。

标清格式的方形像素等效项的合成设置预设已更改为如下:

格式

After Effects CS4 和更高版本中的像素尺寸

以往像素尺寸

NTSC D1 方形像素等效项

720x534

720x540

NTSC D1 宽银幕方形像素等效项

872x486

864x486

PAL D1/DV 方形像素等效项

788x576

768 x 576

PAL D1/DV 宽银幕方形像素等效项

1050x576

1024x576

更改素材项目的像素长宽比解释

  1. 在“项目”面板中选择素材项目。
  2. 选择“文件”>“解释素材”>“主要”。
  3. 从“像素长宽比”菜单中选择一个比率,然后单击“确定”。

更改合成的像素长宽比

  1. 选择“合成”>“合成设置”。
  2. 执行以下操作之一:
    • 从“预设”菜单中选择合成设置预设。

    • 从“像素长宽比”菜单中选择一个值。

常见像素长宽比

像素长宽比

何时使用

方形像素

1.0

素材的帧大小为 640x480 或 648x486;素材为 1920x1080 HD(非 HDV 或 DVCPRO HD);素材为 1280x720 HD 或 HDV;或者素材是从不支持非方形像素的应用程序导出的。此设置也适用于从影片传递的素材或自定义项目。

D1/DV NTSC

0.91

素材的帧大小为 720x486 或 720x480,并且所需结果为 4:3 帧长宽比。此设置也适用于从使用非方形像素的应用程序导出的素材,如 3D 动画应用程序。

D1/DV NTSC 宽银幕

1.21

素材的帧大小为 720x486 或 720x480,并且所需结果为 16:9 帧长宽比。

D1/DV PAL

1.09

素材的帧大小为 720x576,并且所需结果为 4:3 帧长宽比。

D1/DV PAL 宽银幕

1.46

素材的帧大小为 720x576,并且所需结果为 16:9 帧长宽比。

变形 2:1

2.0

使用变形胶片镜头拍摄的素材,或者从长宽比为 2:1 的胶片帧变形传递的素材。

HDV 1080/DVCPRO HD 720、HD Anamorphic 1080

1.33

素材的帧大小为 1440x1080 或 960x720,并且所需结果为 16:9 帧长宽比。

DVCPRO HD 1080

1.5

素材的帧大小为 1280x1080,并且所需结果为 16:9 帧长宽比。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略