用户指南 取消(C)

使用动态图形模板

  1. After Effects 用户指南
  2. Beta 版
    1. Beta 版项目概述
    2. After Effects Beta 版主页
    3. Beta 版中的功能
      1. “属性”面板(Beta 版)
  3. 快速入门
    1. After Effects 快速入门
    2. After Effects 的新增功能 
    3. 发行说明 | After Effects
    4. After Effects 系统要求
    5. After Effects 中的键盘快捷键
    6. 支持的文件格式 | After Effects
    7. 硬件建议
    8. 适用于 Apple Silicon 的 After Effects
    9. 规划和设置
    10. 设置和安装
  4. 工作区
    1. 常规用户界面项
    2. 了解 After Effects 界面
    3. 工作流程
    4. 工作区、面板和查看器
  5. 项目与合成
    1. 项目
    2. 合成基础知识
    3. 预合成、嵌套和预渲染
    4. 使用合成分析器查看详细的性能信息
    5. CINEMA 4D 合成渲染器
  6. 导入素材
    1. 准备并导入静止图像
    2. 从 After Effects 和 Adobe Premiere Pro 导入
    3. 导入和解释视频与音频
    4. 准备和导入 3D 图像文件
    5. 导入和解释素材项目
    6. 使用素材项目
    7. 使用“场景编辑检测”检测编辑点
    8. XMP 元数据
  7. 文本和图形
    1. 文本
      1. 设置字符格式和“字符”面板
      2. 文本效果
      3. 创建和编辑文本图层
      4. 设置段落格式和“段落”面板
      5. 凸出文本和形状图层
      6. 为文本设置动画
      7. 文本动画的示例和资源
      8. 实时文本模板
    2. 动态图形
      1. 在 After Effects 中使用动态图形模板
      2. 使用表达式在动态图形模板中创建下拉列表
      3. 使用“基本属性”创建动态图形模板
      4. 替换动态图形模板和基本属性中的图像和视频
  8. 绘图、绘画和路径
    1. 形状图层、路径和矢量图形的概述
    2. 绘画工具:笔刷、仿制图章和橡皮擦
    3. 将形状描边椎体化的方法
    4. 形状图层的形状属性、绘画操作和路径操作
    5. 使用“位移路径”形状效果更改形状
    6. 创建形状
    7. 创建蒙版
    8. 使用内容识别填充面板,移除视频中的对象
    9. Roto 笔刷和调整遮罩
  9. 图层、标记和摄像机
    1. 选择和排列图层
    2. 混合模式和图层样式
    3. 3D 图层
    4. 图层属性
    5. 创建图层
    6. 管理图层
    7. 图层标记和合成标记
    8. 摄像机、光和目标点
  10. 动画、关键帧、运动跟踪和抠像
    1. 动画
      1. 动画基础知识
      2. 使用人偶工具制作动画
      3. 管理形状路径和蒙版并对其进行动画制作
      4. 使用 After Effects 为 Sketch 和 Capture 形状制作动画
      5. 分类动画工具
      6. 使用数据驱动的动画
    2. 关键帧
      1. 关键帧插值
      2. 设置、选择和删除关键帧
      3. 编辑、移动和复制关键帧
    3. 运动跟踪
      1. 跟踪和稳定运动
      2. 人脸跟踪
      3. 蒙版跟踪
      4. 蒙版引用
      5. 速度
      6. 时间拉伸和时间重映射
      7. 时间码和时间显示单位
    4. 抠像
      1. 抠像
      2. 抠像效果
  11. 透明度与合成
    1. 合成和透明度概述及资源
    2. Alpha 通道、蒙版和遮罩
  12. 调整颜色
    1. 颜色基础知识
    2. 使用 Adobe Color Themes 扩展
    3. 色彩管理
    4. 颜色校正效果
  13. 效果和动画预设
    1. 效果和动画预设概述
    2. 效果列表
    3. 模拟效果
    4. 风格化效果
    5. 音频效果
    6. 扭曲效果
    7. 透视效果
    8. 通道效果
    9. 生成效果
    10. 过渡效果
    11. 果冻效应修复效果
    12. 模糊和锐化效果
    13. 3D 通道效果
    14. 实用效果
    15. 遮罩效果
    16. 杂色和颗粒效果
    17. 保留细节放大效果
    18. 旧版效果
  14. 表达式和自动化
    1. 表达式
      1. 表达式基础知识
      2. 了解表达式语言
      3. 使用表达式控件
      4. JavaScript 与旧版 ExtendScript 表达式引擎之间的语法差别
      5. 正在编辑表达式
      6. 表达式错误
      7. 使用表达式编辑器
      8. 使用表达式编辑和访问文本属性
      9. 表达式语言引用
      10. 表达式示例
    2. 自动化
      1. 自动化
      2. 脚本
  15. 沉浸式视频、VR 和 3D
    1. 在 After Effects 中构造 VR 环境
    2. 应用沉浸式视频效果
    3. 用于 VR/360 视频的合成工具
    4. 跟踪 3D 摄像机运动
    5. 使用 3D 设计空间
    6. 3D 变换 Gizmo
    7. 使用 3D 动画执行更多操作
    8. 使用实时引擎实时预览对 3D 设计的更改
    9. 向图形添加响应式设计 
  16. 视图和预览
    1. 预览
    2. 使用 Mercury Transmit 进行视频预览
    3. 修改和使用视图
  17. 渲染和导出
    1. 渲染和导出基础知识
    2. 将 After Effects 项目导出为 Adobe Premiere Pro 项目
    3. 转换影片
    4. 多帧渲染
    5. 自动渲染和网络渲染
    6. 渲染和导出静止图像及静止图像序列
    7. 在 After Effects 中使用 GoPro CineForm 编解码器
  18. 使用其他应用程序
    1. Dynamic Link 和 After Effects
    2. 使用 After Effects 和其他应用程序
    3. After Effects 中的同步设置
    4. After Effects 中的 Creative Cloud Libraries
    5. 增效工具
    6. CINEMA 4D 和 Cineware
  19. 协作:Frame.io 和团队项目
    1. 在 Premiere Pro 和 After Effects 中协作
    2. Frame.io
      1. 安装和激活 Frame.io
      2. 将 Frame.io 与 Premiere Pro 和 After Effects 配合使用
      3. 常见问题解答
    3. 团队项目
      1. 开始使用团队项目
      2. 创建团队项目
      3. 使用团队项目进行协作
  20. 内存、存储、性能
    1. 内存和存储
    2. 提高性能
    3. 首选项
    4. After Effects 的 GPU 和 GPU 驱动程序要求

使用此页可了解 After Effects 中的基本图形面板以及如何使用动态图形模板和主属性。

基本图形面板可让您为动态图形创建自定义控件,并通过 Creative Cloud Libraries 将它们共享为动态图形模板或本地文件。基本图形面板就像一个容器,可在其中添加、修改不同的控件并将其打包为可共享的动态图形模板。可从工作区栏中使用一个名为基本图形的新工作区,它可以与 After Effects 中的基本图形面板配合使用。您可以从“窗口”>“工作区”访问工作区。

可通过四种主要方式使用 After Effects 中的基本图形面板:

  • 作为 After Effects 中的操纵面:使用基本图形面板作为您合成的操纵面。将参数从时间轴拖动到基本图形面板,以在您经常更改的合成中创建元素的快捷键。
  • 用于创建作为主控件工作的主属性,允许您在合成嵌套在另一个合成中时修改该合成的效果和图层属性。
  • 用于导出动态图形模板 (.mogrt):将您的 After Effects 项目封装到可直接在 Premiere Pro 中编辑的动态图形模板中。保持您设计所需的所有源图像、视频和预合成都打包在模板中。仅公开的控件可用于 Premiere Pro 中的自定义设置,以允许您保留您设计的创意控件。
  • 将控件分组、控制字体属性,以及将 CSV 和 TSV 电子表格数据源的控件添加到动态图形模板。可以通过基本图形面板中的“添加格式”菜单访问控件组。可以从此菜单访问“添加注释”命令。

在 After Effects 中创建动态图形模板

观看此视频,了解关于在 After Effects 中创建动态图形模板的信息

使用基本图形面板

基本图形面板中的合成

基本图形面板中,使用“主要”下拉菜单选择项目中的一个合成,开始构建动态图形模板。

从“主合成”菜单查看合成
从“主合成”菜单查看合成

要在 After Effects 的基本图形面板中打开合成,请执行以下任一操作:

  • 要打开当前合成,请选择“合成”>“在基本图形中打开”。
  • 要打开特定合成,请在“项目”面板中右键单击一个合成,然后选择“在基本图形中打开”
  • 要打开项目中的任一合成,请在基本图形面板中单击“主合成”菜单。

主合成

主合成是基本图形面板中的当前合成。您可以从主合成中向面板添加受支持的属性。您也可以从主合成层级中的合成添加属性。

不在主合成层次结构中的合成的属性将被视为不相关的属性。当您将无关属性添加到基本图形面板时,会显示一条警告消息。属性仍会添加到此面板中,但将以红色突出显示,在导出为动态图形模板时没有任何影响。

提示:要使用无关属性,请将包含属性的合成嵌套到主合成或层级中。

注意:

将合成导出为动态图形模板时,无关属性将不起作用。

添加和修改控件

添加控件

您可以从任何效果或任何图层属性组中添加受支持的属性,如变换蒙版材质选项

受支持的控件类型:

  • 复选框
  • 颜色
  • 数字滑块(单值数值属性),如“变换”>“不透明度”或滑块控件表达式控制效果
  • 源文本
  • 2D 点属性,例如“变换”>“锚点”、“变换”>“位置”和“点控制”表达式控制效果
  • 2D 缩放属性,例如“变换”>“缩放”
  • 角度属性,例如“变换”>“旋转”和“角度控制”表达式控制效果

如果添加不受支持的属性,After Effects 会显示警告消息:“After Effects 错误: 尚不支持将属性类型用于动态图形模板”。

要添加控件,请将一个或多个受支持的属性从时间轴拖入基本图形面板。

您还可以使用将属性添加到基本图形面板命令,将属性从“时间轴”“效果控件”面板添加到基本图形面板。使用以下步骤之一添加属性:

  • “时间轴”面板中选择一个属性,然后选择“动画”>“将属性添加到基本图形”
  • “时间轴”面板或“效果控件”面板中右键单击一个属性,然后从菜单中选择“将属性添加到基本图形”

您也可以为将属性添加到基本图形面板命令分配键盘快捷键。要了解更多步骤,请参阅可视键盘快捷键编辑器

在基本图形面板中添加控件
在基本图形面板中添加控件

查看受支持的属性

如果只想查看基本图形面板支持的属性,请在面板中单击“单独受支持属性”按钮。此按钮过滤属性并在时间轴中显示受支持的属性。

修改控件

您可以使用基本图形面板按以下方式自定义控件:

  • 重命名控件:要重命名控件,请执行以下任一操作:
    • 单击控件的名称字段,输入新名称。
    • 拖动并高亮显示当前名称,然后输入新名称。
  • 显示源属性:要在时间轴中显示控件的源属性,请右键单击控件名,然后从上下文菜单中选择“在时间轴中显示”。显示选项将打开相关合成,即使它是关闭的。
  • 重新排序控件:要重新排序控件,请在面板中向上或向下拖动控件。

您添加到基本图形面板的控件会链接到源属性。更改控件的值也会更改合成中属性的值。例如,如果在面板中将“不透明度”更改为 50%,合成中的“不透明度”值也会更改为 50%。

当您在面板中滑动数值控件的值时,合成值将同时更新。要禁用实时更新功能,请在滑动时按住 Option (Mac) 或 Alt (Win) 键。

创建控件组

可将基本图形面板中的控件分组,以更好地导航并使面板更加整洁。向面板添加了大量可编辑控件或嵌套合成主属性时,此功能尤其有用。

要创建控件组,请单击“基本图形”面板左下角的“添加格式”菜单,然后选择“添加组”

要将某个控件添加到某个组中,请将该控件拖放到该组名称上。

字体控件

向基本图形面板添加文本图层时,可修改和控制该图层在动态图形模板中的字体系列、字体样式、大小和仿样式。使用以下步骤可向面板添加字体属性控件:

  1. 将文本图层的“源文本”属性添加到“基本图形”面板。

  2. 单击控件行右侧的“编辑属性”选项。

     

  3. 在“源文本属性”对话框的以下选项中,选择要控制的字体属性:

    • 启用自定义字体选项 - 添加“字体系列”和“字体样式”控件。
    • 启用字体大小调整 - 添加“字体大小”控件。
    • 启用仿样式 - 添加“仿粗体”、“仿斜体”、“全部大写字母”和“小型大写字母”控件。

    单击“确定”。

    此对话框中还有另一个选项 -“使用图层作为回落文本框”,勾选此项后,您可以选择一个合成/子合成和一个形状或剪辑图层,以确定用于编辑 Premiere Pro 节目监视器中文本的替换文本框。这是必需的,因为很多 mogrt 都包含不可用的文本框 - 要么不在屏幕内、要么大小错误、要么布置不正确。

    替换文本框
    替换文本框

注意:

不支持字体控件作为嵌套合成的主属性。

在基本图形面板中添加注释

要添加注释,请在基本图形面板底部单击“添加注释”按钮。您可以添加多个注释,并且为它们重命名和重新排序。您还可以根据需要撤消和重做添加注释、将注释重新排序以及移除注释的操作。

  • 要重命名,请单击注释的名称字段,然后输入新名称。 
  • 要重新排序,请将注释拖到面板上方或下方。

要删除注释,请选择该注释并按 Backspace 或 Delete 键。

修改控件
修改控件

注意:

当您在“项目”面板中复制合成(Mac:cmd+D,Win:ctrl+D)时,After Effects 会复制为该合成添加到基本图形面板中的属性和注释。

导出为动态图形模板

为模板命名

要命名或重命名动态图形模板,请单击模板的名称字段,然后输入新名称。

为模板设置标志帧

您可以为模板设置标志帧。标志帧用作 Creative Cloud Libraries 中模板和 Premiere Pro 中基本图形面板的缩览图。

要设置标志帧,请执行以下步骤:

  1. 在主合成中,将当前时间指示器放在要选择的帧上。

  2. 在基本图形面板中单击“设置海报时间”按钮。

导出模板

要将合成导出为动态图形模板,请执行以下步骤:

  1. 基本图形面板底部,单击“导出动态图形模板”。模板中包含主合成层级中的合成。

  2. “导出为动态图形模板”对话框中,单击“目标”菜单。可用目标包括:

    • Creative Cloud Libraries:将模板添加到 Creative Cloud Libraries。
    • 基本图形:默认情况下,将模板添加到本地文件夹。存储在基本图形文件夹中的模板可直接在 Premiere Pro 的基本图形面板中使用。
    • 本地驱动器:将模板保存到本地目录。您保存到本地目录的模板不会自动在 Premiere Pro 的基本图形面板中提供。
  3. 导出动态图形模板
    导出动态图形模板

    选中“兼容性”下的复选框:

    • 如果此动态图形模板使用 Adobe Fonts 未提供的字体,请提醒我:如果您希望 After Effects 在合成使用任何 Adobe Fonts 未提供的字体时提醒您,请启用此选项。
    • 如果需要安装 After Effects 以自定义此动态图形模板,请提醒我:如果您仅需导出与 After Effects 无关的功能(例如任何第三方增效工具),请启用此选项。

    有关添加资源到 Creative Cloud Libraries 的更多信息,请参阅 After Effects 中的 Creative Cloud Libraries

    注意:

    这些选项仅显示警告,它们不会修改动态图形模板的内容。要编辑项目以满足要求,请取消导出并进行更改,然后再次导出动态图形模板。

  4. “目标”菜单中选择导出目标,然后单击“确定”

注意:

您可以将使用 Roto 笔刷效果的动态图形模板导入 Premiere Pro。有关更多信息,请参阅 Roto 笔刷、调整边缘和调整遮罩效果

注意:

您可以创作不要求用户在其计算机上安装 After Effects 以自定义模板的动态图形模板(.mogrt 文件)。确保您的模板符合以下要求,以保证您的 .mogrt 用户不需要安装 After Effect:

  • 仅支持经典 3D 合成渲染器;不支持 CINEMA 4D 渲染器和光线追踪 3D 渲染器。
  • 支持 After Effects 随附的所有效果,以下效果除外:摄像机抖动去模糊、Synthetic Aperture Color Finesse、Maxon CINEWARE、人偶和变形稳定器。
  • 不支持 Dynamic Link 素材,例如 After Effects 合成中的 Premiere Pro 序列或 Character Animator CC 场景。
  • 不支持 FLV 格式素材和第三方增效工具。

将动态图形模板作为项目打开

要编辑 After Effects 动态图形模板(.mogrt 文件),可以将其作为项目文件在 After Effects 中打开。编辑模板后,将其重新导出为 .mogrt 文件。

要将动态图形模板作为项目打开,请按照下列步骤操作:

  1. 选择“文件”>“打开项目”

  2. “打开项目”对话框中,选择一个 .mogrt 文件,然后单击“打开”
  3. 将 .mogrt 作为项目打开时,After Effects 将提取项目文件和资源。在提取“<filename>.mogrt”对话框中,选择用于提取 .mogrt 内容的位置,然后单击“提取”

您也可以按照以下步骤,在 Premiere Pro 12.1 中修改序列中使用的动态图形模板:

  1. 在 After Effects 中,将 .mogrt 文件作为项目打开。修改一个或多个合成,或在基本图形面板中添加或更改控件。
  2. 完成编辑后,在基本图形面板中,单击“导出动态图形模板”按钮。您可以替换原始 .mogrt 文件,或者为更新的文件选择新位置或名称。
  3. 在 Premiere Pro 中,按住 Option (MacOS) 或 Alt (Win) 键,并将新 .mogrt 或更新的 .mogrt 从基本图形面板的“浏览”选项卡拖放到序列中的现有 .mogrt 剪辑上。Premiere Pro 将使用新控件更新基本图形面板中的“编辑”选项卡。
  1. 在 After Effects 中,将 .mogrt 文件作为项目打开。修改合成,或在基本图形面板中添加或修改控件

  2. 完成编辑后,在基本图形面板中,单击“导出动态图形模板”按钮。您可以替换原始 .mogrt 文件,或者为更新的文件选择新位置或名称。

  3. 在 Premiere Pro 中,在基本图形面板的“浏览”选项卡中,按住 Opt (MacOS) 或 Alt (Win) 并将新的或更新的 .mogrt 拖动到序列中的现有 .mogrt 剪辑上。Premiere Pro 将使用新控件更新基本图形面板中的“编辑”选项卡。

使用数据驱动的动态图形模板

利用数据驱动的动态图形模板,可快速准确地自定义条形图、线形图等等,而无需手工录入或对动态图形本身有很深的造诣。

利用此功能,可将用于 CSV(逗号分隔文本)和 TSV(制表符分隔文本)电子表格数据的控件添加到基本图形面板。将带有数据控件的这些动态图形模板导出至 Premiere Pro 后,可在 Premiere Pro 中对它们进行修改或替换。

另一种使用方法,利用“基本图形”面板中的数据控件,可直接浏览或编辑合成中的 CSV 或 TSV 数据图层,而无需将合成作为模板导出。将带有电子表格数据的合成添加到面板中后,面板会显示可编辑的所有相关数据。如果使用嵌套合成,则数据控件无法当作该合成的主属性访问。

使用下列步骤向基本图形面板添加数据控件:

  1. 将 CSV 或 TSV 文件导入项目中,并将其添加到合成中。

  2. “时间轴”面板中,旋转打开数据图层的图层属性。

  3. 选择图层的数据属性组,并将其拖放到“基本图形”面板中。

可以在基本图形面板中修改电子表格数据的以下属性:

  • 电子表格属性:单击数据组右侧的“编辑属性”可修改以下属性:
    • 数据属性类型:选择针对各列之值的数据类型。使用此功能可更改电子表格值在 Premiere Pro 中的显示方式。After Effects 作者在 After Effects 中设置各个列的类型。在 Premiere Pro 中,此类型会被转化为文本字符串、数字热文本滑块或颜色的十六进制值(例如 #EE0473)。
    • 最小行数:在 Premiere Pro 中,可修改动态图形模板中所用的行数。设置允许的最小行数。
  • 行数:在 Premiere Pro 中,可修改动态图形模板中所用的行数。设置允许的最大行数。
  • 数据属性:
    • 列名称:修订动态图形模板中显示的列名称。
    • 数据值:修改电子表格单元格的值。要选择编辑的行,请修改“数据值”控件组顶部的“行”菜单。
注意:

向面板添加数据图层的“数据属性”组后,链接图层数据属性与源数据文件的表达式会被移除。这些数据属性会变成静态值。如果在 After Effects 外部修改源数据文件,则会自动更新静态数据值。

有关如何在 Premiere Pro 中使用这些模板的更多信息,请参阅使用数据驱动的动态图形模板

注意:

如使用德语版 Excel 创建 .tsv 文件(适用于使用半角逗号作为小数点的任何语言),Excel 会将 .tsv 文件保存为 .txt 文件。请手动将其扩展名更改为 .tsv,然后再将其附加到 Premiere Pro 中的动态图形模板。

或者,也可使用其他电子表格工具,例如 Open Office 或 Google 表格。

基本属性基础知识

基本属性 作为主要控件工作,允许您在合成嵌套在另一个合成中时修改该合成的图层和效果属性。当您跨多个嵌套的合成构建复杂动画时,此功能可以节省时间,因为您无需打开各个预合成以查看其属性。基本属性可以覆盖其原始值和关键帧,允许您重复使用与具有不同值的多个实例相同的合成。源合成保留不变,您的所做的编辑仅用于在编辑合成后创建可以渲染的实例。

有关详细信息,请参阅使用基本属性创建动态图形模板

在基本图形面板中使用表达式创建下拉菜单

在创作动态图形模板时,比较常见的情况,就是提供用于自定义属性的滑块和复选框,以便编辑人员在 Premiere Pro 中灵活运用 MOGRT。但是,对于具有多个选项的复杂工作流程,使用滑块或复选框有时并不直观,而且非常耗时。对于动态图形模板的作者和 Premiere Pro 的编辑人员而言,使用下拉菜单控件非常有帮助,因为菜单可轻松提供更多控制选项和更简单的参数调整体验。

有关详细信息,请参阅在基本图形面板中使用表达式创建下拉菜单

有关在 Premiere Pro 中使用该功能的更多信息,请参阅在 Premiere Pro 中使用动态图形模板

创建具有可替换媒体的 MOGRT,并在基本属性中替换媒体

在基本图形面板中工作时,Premiere Pro 编辑人员可以替换媒体,例如替换动态图形模板中的徽标、视频和其他内容。而在 After Effects 中操作时,可使用“基本属性”更改视频和图像,从而在合成上创建快速迭代。有关更多信息,请参阅在动态图形模板和基本属性中替换图像和视频

Adobe 徽标

登录到您的帐户