用户指南 取消(C)

Roto 笔刷和调整遮罩

  1. After Effects 用户指南
  2. Beta 版
    1. Beta 版项目概述
    2. After Effects Beta 版主页
  3. 快速入门
    1. After Effects 快速入门
    2. After Effects 的新增功能 
    3. 发行说明 | After Effects
    4. After Effects 系统要求
    5. After Effects 中的键盘快捷键
    6. 支持的文件格式 | After Effects
    7. 硬件建议
    8. 适用于 Apple Silicon 的 After Effects
    9. 规划和设置
  4. 工作区
    1. 常规用户界面项
    2. 了解 After Effects 界面
    3. 工作流程
    4. 工作区、面板和查看器
  5. 项目与合成
    1. 项目
    2. 合成基础知识
    3. 预合成、嵌套和预渲染
    4. 使用合成分析器查看详细的性能信息
    5. CINEMA 4D 合成渲染器
  6. 导入素材
    1. 准备并导入静止图像
    2. 从 After Effects 和 Adobe Premiere Pro 导入
    3. 导入和解释视频与音频
    4. 准备和导入 3D 图像文件
    5. 导入和解释素材项目
    6. 使用素材项目
    7. 使用“场景编辑检测”检测编辑点
    8. XMP 元数据
  7. 文本和图形
    1. 文本
      1. 设置字符格式和“字符”面板
      2. 文本效果
      3. 创建和编辑文本图层
      4. 设置段落格式和“段落”面板
      5. 凸出文本和形状图层
      6. 为文本设置动画
      7. 文本动画的示例和资源
      8. 实时文本模板
    2. 动态图形
      1. 在 After Effects 中使用动态图形模板
      2. 使用表达式在动态图形模板中创建下拉列表
      3. 使用“基本属性”创建动态图形模板
      4. 替换动态图形模板和基本属性中的图像和视频
      5. 使用“属性”面板更快、更轻松地制作动画
  8. 绘图、绘画和路径
    1. 形状图层、路径和矢量图形的概述
    2. 绘画工具:笔刷、仿制图章和橡皮擦
    3. 将形状描边椎体化
    4. 形状图层的形状属性、绘画操作和路径操作
    5. 使用“位移路径”形状效果更改形状
    6. 创建形状
    7. 创建蒙版
    8. 使用内容识别填充面板,移除视频中的对象
    9. Roto 笔刷和调整遮罩
  9. 图层、标记和摄像机
    1. 选择和排列图层
    2. 混合模式和图层样式
    3. 3D 图层
    4. 图层属性
    5. 创建图层
    6. 管理图层
    7. 图层标记和合成标记
    8. 摄像机、光和目标点
  10. 动画、关键帧、运动跟踪和抠像
    1. 动画
      1. 动画基础知识
      2. 使用人偶工具制作动画
      3. 管理形状路径和蒙版并对其进行动画制作
      4. 使用 After Effects 为 Sketch 和 Capture 形状制作动画
      5. 分类动画工具
      6. 使用数据驱动的动画
    2. 关键帧
      1. 关键帧插值
      2. 设置、选择和删除关键帧
      3. 编辑、移动和复制关键帧
    3. 运动跟踪
      1. 跟踪和稳定运动
      2. 人脸跟踪
      3. 蒙版跟踪
      4. 蒙版引用
      5. 速度
      6. 时间拉伸和时间重映射
      7. 时间码和时间显示单位
    4. 抠像
      1. 抠像
      2. 抠像效果
  11. 透明度与合成
    1. 合成和透明度概述及资源
    2. Alpha 通道和遮罩
    3. 轨道遮罩和移动遮罩
  12. 调整颜色
    1. 颜色基础知识
    2. 色彩管理
    3. 颜色校正效果
    4. OpenColorIO 和 ACES 色彩管理
  13. 效果和动画预设
    1. 效果和动画预设概述
    2. 效果列表
    3. 效果管理器
    4. 模拟效果
    5. 风格化效果
    6. 音频效果
    7. 扭曲效果
    8. 透视效果
    9. 通道效果
    10. 生成效果
    11. 过渡效果
    12. 果冻效应修复效果
    13. 模糊和锐化效果
    14. 3D 通道效果
    15. 实用效果
    16. 遮罩效果
    17. 杂色和颗粒效果
    18. 保留细节放大效果
    19. 旧版效果
  14. 表达式和自动化
    1. 表达式
      1. 表达式基础知识
      2. 了解表达式语言
      3. 使用表达式控件
      4. JavaScript 与旧版 ExtendScript 表达式引擎之间的语法差别
      5. 正在编辑表达式
      6. 表达式错误
      7. 使用表达式编辑器
      8. 使用表达式编辑和访问文本属性
      9. 表达式语言引用
      10. 表达式示例
    2. 自动化
      1. 自动化
      2. 脚本
  15. 沉浸式视频、VR 和 3D
    1. 在 After Effects 中构造 VR 环境
    2. 应用沉浸式视频效果
    3. 用于 VR/360 视频的合成工具
    4. 高级 3D 渲染器
    5. 将 3D 模型导入并添加到合成中
    6. 从 Creative Cloud Libraries 导入3D 模型
    7. 基于图像的光照
    8. 从 3D 模型中提取光线和相机并为其制作动画
    9. 跟踪 3D 摄像机运动
    10. 投影和接受阴影
    11. 使用 3D 设计空间
    12. 3D 变换 Gizmo
    13. 使用 3D 动画执行更多操作
    14. 使用 Mercury 3D 引擎实时预览对 3D 设计的更改
    15. 向图形添加响应式设计
  16. 视图和预览
    1. 预览
    2. 使用 Mercury Transmit 进行视频预览
    3. 修改和使用视图
  17. 渲染和导出
    1. 渲染和导出基础知识
    2. After Effects 中的 H.264 编码
    3. 将 After Effects 项目导出为 Adobe Premiere Pro 项目
    4. 转换影片
    5. 多帧渲染
    6. 自动渲染和网络渲染
    7. 渲染和导出静止图像及静止图像序列
    8. 在 After Effects 中使用 GoPro CineForm 编解码器
  18. 使用其他应用程序
    1. Dynamic Link 和 After Effects
    2. 使用 After Effects 和其他应用程序
    3. After Effects 中的同步设置
    4. After Effects 中的 Creative Cloud Libraries
    5. 增效工具
    6. Cinema 4D 和 Cineware
  19. 协作:Frame.io 和团队项目
    1. 在 Premiere Pro 和 After Effects 中协作
    2. Frame.io
      1. 安装和激活 Frame.io
      2. 将 Frame.io 与 Premiere Pro 和 After Effects 搭配使用
      3. 常见问题解答
    3. 团队项目
      1. 开始使用团队项目
      2. 创建团队项目
      3. 使用团队项目进行协作
  20. 内存、存储、性能
    1. 内存和存储
    2. After Effects 处理预览时内存不足问题的方式    
    3. 提高性能
    4. 首选项
    5. After Effects 的 GPU 和 GPU 驱动程序要求
  21. 知识库
    1. 已知问题
    2. 已修复的问题
    3. 常见问题解答
    4. After Effects 和 macOS Ventura
    5. After Effects 处理预览时内存不足问题的方式

使用 Roto 笔刷将前景对象与背景分离,并使用“调整遮罩”创建遮罩。

使前景对象与背景分开是许多视觉效果和合成工作流中的关键步骤。在您创建用于隔离对象的遮罩后,您可以替换背景、有选择地对前景应用效果,以及执行其他更多操作。

使用 Roto 笔刷在前景和背景元素的代表区域上绘制笔触。After Effects 使用该信息在前景和背景元素之间创建分段边界。

创建了分段边界后,请使用优化笔刷遮罩属性来改善遮罩。

提示:

也可以单独使用优化遮罩效果改进使用Roto 笔刷工具之外的功能创建的遮罩。

下一代 Roto 笔刷

下一代 Roto 笔刷由全新的 AI 模型提供支持,是 Roto 笔刷工具的最新改进版本。与 Roto 笔刷 2 相比,其在选择和跟踪素材中的对象时可以提供更高的精度。这使得遮罩复杂对象(如重叠的肢体、头发和透明物体)更加快速而简单。

将“Roto 笔刷和优化边缘”效果的版本设置为“3.0”,以使用下一代 Roto 笔刷。
将“Roto 笔刷和优化边缘”效果的版本设置为“3.0”,以使用下一代 Roto 笔刷。

以下是与 Roto 笔刷 2 的简明比较。两个示例使用相同的帧和选区。

Roto 笔刷 2

Adobe Sensei 提供支持

传统转描使用动画蒙版来隔离视频剪辑中的元素,繁琐且非常耗时。“Roto 笔刷 2”使用人工智能技术跟踪对象的运动,以便减少逐帧优化工作。

Roto 笔刷 2 的功能

在包含应用 Roto 笔刷的图层的图层面板和合成面板中,都会显示传播横幅。就算关闭图层面板并处理其他内容,仍可看到传播进度。

Roto 笔刷和优化边缘间距显示浅灰色人字形花纹,基帧在开头显示为亮绿色框。当您传播帧时,间距的中间会显示绿色人字形花纹。有关更多信息,请参阅描边、间距和基帧

默认不启用运动阈值运动阻尼等经典控件。您可以通过选择 Roto 笔刷和优化边缘效果下的启用经典控件来启用它们。您可以同时使用两个版本的“Roto 笔刷”,以更好地进行转描。

如何使用下一代 Roto 笔刷和 Roto 笔刷 2

如果您熟悉 Roto 笔刷 1,那么使用下一代 Roto 笔刷Roto 笔刷 2 传播引擎选择对象的操作基本上是相同的。

注意:

默认转描选项为下一代 Roto 笔刷。但是,如果您更喜欢旧版本 - Roto 笔刷 1Roto 笔刷 2,则可以使用 Roto 笔刷和优化边缘效果面板中的版本下拉列表进行选择。

  1. 在工具栏中选择 Roto 笔刷

    或者,您也可以使用键盘快捷键:

    • WindowsAltW 
    • macOSOption + W
    Roto 笔刷工具
    从工具栏中选择“Roto 笔刷”。

  2. 双击合成面板中的现有图层。这会在图层面板中打开该图层。

  3. 选择起始帧。

    提示:

    避免对象被场景中的其他对象隐藏的帧。例如,对于进出帧的人物,请选择其完全位于场景中的帧。

  4. 确保在效果控件面板中的 Roto 笔刷和优化边缘效果下设置版本时,为下一代 Roto 笔刷选择 3.0 版本,为 Roto 笔刷 2 选择 2.0 版本。

    在“效果控件”面板的“版本”下拉菜单中选择了 Roto 笔刷 3.0 版本。
    使用“效果控件”面板中的“版本”下拉列表选择 Roto 笔刷版本。

  5. 在尝试转描的主体、对象或区域上绘制绿色的前景描边。

    要移除的对象轮廓显示为洋红色。

    正确操作:

    • 从一个横切对象的描边开始。查看 Roto 笔刷的选择,并根据需要使用尽量少的描边来添加选区或从选区中移除选区。

    错误操作:

    • 避免在对象周围绘制轮廓。相反,应在对象中间绘制,并穿越对象内部具有不同颜色或亮度的各区域。
    • 不要跨边缘绘图,因为这可能会混淆选区。

    默认情况下,鼠标光标上有一个绿色十字。最佳做法是在进行第一笔描边之前,先设置适当的笔刷大小。在开始第一个描边之前,画笔大小以绿色显示。要更改大小,请选择窗口 > 笔刷,然后调整笔刷的直径。

    提示:

    也可以按住 Ctrl (Windows) 或 Command (macOS) 并向左和向右拖动以更改笔刷的大小。

  6. 优化选区。

    绘制额外描边,或通过按住 AltOption 并绘制背景描边以移除部分选区。在要移除部分的边缘周围绘制描边。围绕对象的洋红色线开始变得精确。

    如果剪切了少许额外描边,请松开 AltOption 键并拖动该区域以将其添加到选区。添加时光标为绿色。绘制背景描边时,Roto 笔刷工具的指针将变为中间带有减号的红色圆圈。

    前景描边,添加到选区

    背景描边,从选区中删除

  7. 设置基础帧后,开始传播。

    您可以通过以下方式开始传播:

    • 按空格键:这将触发从基帧向新帧传播遮罩。
    • 如果希望减慢传播速度以更直观地评估传播效果,还可以向前/向后逐帧传播。使用以下键盘快捷键可实现逐帧移动:
      • Page UpPage Down
      • Command + 向左/向右箭头 (macOS) 或 Ctrl + 向左/向右箭头 (Windows)
    注意:

    按空格键与移动 CTI 之间的主要区别是:使用空格键会进行传播,然后逐帧显示结果。移动 CTI 需要等待各帧传播完成,然后显示结果。

  8. 随着 Roto 笔刷将遮罩从帧传播到帧,选区可能会包含不需要的区域或“丢失”原始选区的某些部分。要纠正这种情况,请在发生意外变化的第一个帧上(按住 AltOption 键)绘制背景描边以移除不需要的区域,或绘制新的前景描边以纳入缺失的任何内容。与基帧一样,尽可能避免跨选区边缘绘制。

    注意:

    您可以调整 Roto 笔刷工具的笔尖的大小,以便更好地进行描边。粗泛描边最适合初始工作,但细化描边可用于获取细节。(请参阅 Roto 笔刷描边、间距和基帧。)

  9. 冻结传播。

    将遮罩传播到所有视频帧后,使用图层面板底部的冻结按钮冻结传播。

    冻结传播。
    选择“冻结”以冻结传播。

    冻结后,您可以继续对遮罩进行调整,而无需重新传播。如果在冻结之后必须从选区中进行添加或删除,可以使用相同的按钮取消冻结传播。

    注意:

    最好在对 Roto 笔刷遮罩感到满意后再冻结。冻结的作用是锁定遮罩的位置,这样 Roto 笔刷就不必重新传播边缘。

冻结(缓存、锁定 和保存)Roto 笔刷分段

如果在您选择冻结按钮时,After Effects 已经计算出帧的 Roto 笔刷分段信息,则将缓存此信息。如果尚未计算 Roto 笔刷间距内帧的分段,则 After Effects 必须在冻结之前计算分段。

包含冻结(缓存和锁定)分段信息的帧可表示如下:

  • 图层面板中“Roto 笔刷 1”间距视图中的蓝条。
  • “图层”面板中下一代 Roto 笔刷Roto 笔刷 2 间距视图中的紫色条。
Roto 笔刷 2 中的紫色条
下一代 Roto 笔刷和 Roto 笔刷 2 间距视图中的紫色条

注意:

如果在冻结 Roto 笔刷对话框中选择停止,则 After Effects 将停止向缓存添加帧,但是 Roto 笔刷分段仍被锁定,且分段信息仍予以缓存,直到单击停止为止。

要解冻 Roto 笔刷分段,请再次选择冻结按钮。

当 Roto 笔刷分段冻结时,可以将指针放在冻结按钮上,此时会出现一个工具提示,告知缓存信息的创建时间。

“冻结”按钮工具提示会指明缓存信息的创建时间。
“冻结”按钮工具提示会指明缓存信息的创建时间。

当 Roto 笔刷分段冻结时,Roto 笔刷工具的指针上会出现一道斜杠。

缓存和锁定的信息是由 Roto 笔刷和优化边缘效果的传播属性组中“Roto 笔刷”描边和属性而来。更改其中任何项(例如,通过进行新的 Roto 笔刷描边或修改传播属性组中的属性)对 Roto 笔刷效果的结果没有影响,除非解冻分段。不会冻结 Roto 笔刷遮罩属性组中的属性。

冻结 Roto 笔刷分段信息将在应用程序运行期间被缓存和锁定,缓存信息随项目一起保存。

调整和优化最终遮罩

  • 通过Roto 笔刷和调整边缘效果中的 Roto 笔刷遮罩组中的控件(尤其是减少震颤属性),可进一步进行优化和改进传播的结果。
“Roto 笔刷”效果中“Roto 笔刷遮罩”组中的控件。
“Roto 笔刷”效果中“Roto 笔刷遮罩”组中的控件。

  • 此外,调整边缘工具还可用于具有丰富细节的边缘(例如头发),并可在调整边缘遮罩属性组中进行进一步的控制。另外还提供了一些用于补偿运动模糊和净化边缘颜色的选项。当处理带有柔化边缘或头发之类细微细节的遮罩时,此功能非常有用。
提示:

要使用优化边缘工具,请在工具栏中选择 Roto 笔刷工具,然后选择优化边缘工具。您可以使用 Alt + W (Windows) 和 Option + W (macOS)。

运动模糊和净化边缘颜色,以处理具有柔和边缘或精细细节的遮罩。
运动模糊和净化边缘颜色,以处理具有柔和边缘或精细细节的遮罩。

  • 优化边缘工具用于其他帧,直到优化足够精细和完整为止。按住 AltOption 可擦除优化边缘描边。
  • 如果您使用了优化边缘工具,则 Roto 笔刷和优化边缘效果属性中的微调优化边缘遮罩选项会被选中。根据需要,修改优化边缘遮罩属性组中的属性。(请参阅 Roto 笔刷效果和优化遮罩效果属性。)
“Roto 笔刷和优化边缘”效果属性中的“微调优化边缘遮罩”选项。
“Roto 笔刷和优化边缘”效果属性中的“微调优化边缘遮罩”选项。

使用图层面板底部的切换开关可查看遮罩结果,也可打开合成面板以查看与其他图层组合起来的结果。

图层面板视图选项

可以通过单击图层面板中的按钮或使用键盘快捷键从图层面板的显示通道菜单中选择这些视图模式。可以使用图层面板底部的控件来更改 Alpha 边界Alpha 叠加模式中使用的叠加图层的颜色和不透明度。

使用图层面板的切换开关以查看 Alpha、Alpha 边界和 Alpha 叠加
使用图层面板的切换开关以查看 Alpha、Alpha 边界和 Alpha 叠加

Alpha

显示图层的 Alpha 通道。使用 Alt + 4 (Windows) 或 Option + 4 (macOS)。

Alpha 边界

显示前景和背景不变且分段边界覆盖为彩色轮廓的源图层。使用 Alt + 5 (Windows) 或 Option + 5 (macOS)。

注意:

如果图层面板中的视图菜单变成“Roto 笔刷”之外的内容,则Alpha 边界视图模式已关闭。

Alpha 叠加

显示前景不变且背景以纯色覆盖的源图层。使用 Alt + 6 (Windows) 或 Option + 6 (macOS)。

描边、间距和基帧

首次绘制“Roto 笔刷”描边时,绘制的帧会成为基帧。分段信息(关于什么被定义为前景和什么被定义为背景的信息)默认为图层的整个持续时间,或者如果存在多个间距,则默认为任何空持续时间的持续时间。因此受到此基帧影响的帧范围就是它的 Roto 笔刷间距图层面板中间距栏中的小箭头指示信息的传播方向。如果您在箭头指向右侧的位置进行校正描边,则该描边中的信息将向前传播;如果您在箭头指向左侧的位置进行校正描边,则该描边中的信息将向后传播。如果您在“Roto 笔刷”间距外的任何位置绘制一个描边,则将创建一个新的基帧和间距。

您可以按照您的方式从基帧一次前进一帧,以进行校正描边,同时,您不必担心描边操作会更改您已在各帧上制作的效果。也可以自一个基帧开始后退来做同样的事。

每个校正描边的影响向前或向后传播来影响间距内该方向上的所有帧,不管描边是何时绘制的。例如,如果基帧是帧 10,您在帧 20 处进行校正描边,然后在帧 15 处进行校正描边,则帧 20 将受到这两次校正描边的影响 - 就像您按其他顺序进行校正描边一样。

每在一个间距内绘制一个描边,该间距都会增长,除非由于绘制的间距邻近其他间距而不能增长:

  • 要手动更改间距持续时间,请拖动间距的任何一个末端。

  • 要删除间距,请右键单击 (Windows) 或按住 Control 并单击 (macOS) 间距,然后选择移除间距

  • 要删除所有间距,请删除 Roto 笔刷和优化边缘效果的实例。

传播横幅

下一代 Roto 笔刷Roto 笔刷 2 中,图层面板的底部有一个传播横幅,该横幅显示当前传播帧的状态。

传播横幅显示当前传播帧的状态。
传播横幅显示当前传播帧的状态。

Roto 笔刷工具、Roto 笔刷描边与绘画工具和描边的相似之处

虽然 Roto 笔刷工具在很多方面类似于绘画工具,但也存在几个重要差别。

选择 Roto 笔刷工具后,绘画面板中的控件为禁用状态。“Roto 笔刷”描边有一个帧的持续时间,但它们的影响在间距内向前或向后传播。

您可以像更改绘画工具笔刷大小那样更改“Roto 笔刷”工具笔刷大小(直径)。可使用笔刷面板中的直径控件,或在图层面板中按住 Ctrl 并拖动 (Windows) 或按住 Command 并拖动 (macOS)。笔刷面板中的其他控件确实影响“Roto 笔刷”工具,但硬度除外。

您可以复制 Roto 笔刷路径属性,然后将其粘贴到绘画效果的蒙版、形状和实例中,就像复制粘贴其他类型的路径那样。如果您复制单个描边,则不复制“Roto 笔刷”间距信息;但是,如果复制整个“Roto 笔刷”效果实例,则其中包括“Roto 笔刷”间距(和基帧)信息。

可在“Roto 笔刷”效果的路径属性中使用表达式,方式与操作“绘画”效果的路径属性相似。

使用 Roto 笔刷工具绘制描边时,即使选择了另一个描边,也会创建一个新描边。这有别于绘画工具的描边替换功能。

“Roto 笔刷”描边位于时间轴面板中 Roto 笔刷和优化边缘属性组内的描边属性组中。

“时间轴”面板中“Roto 笔刷”属性组内的“描边”属性组。
“时间轴”面板中“Roto 笔刷”属性组内的“描边”属性组。

可与绘画描边和绘画工具一起使用的许多键盘快捷键也可与 Roto 笔刷描边和 Roto 笔刷工具结合使用。请参阅绘图工具(键盘快捷键)

Roto 笔刷和优化遮罩效果属性

传播属性组中的 Roto 笔刷和优化边缘效果属性,可影响前景和背景之间的分段,以及如何将分段信息用于间距内的相邻帧。“Roto 笔刷”效果的其他属性影响基于初始分段生成的遮罩。优化边缘遮罩效果包括传播属性组之外的“Roto 笔刷”效果的所有属性(反转前景/背景除外)。

选择 Roto 笔刷版本 - 1.0(经典)2.03.0

在不同 Roto 笔刷版本之间选择并切换的选项
在不同 Roto 笔刷版本之间选择并切换的选项

选择 2.0 版时,选择边缘周围的细节质量标准选项的速度更快,并且边缘周围的细节欠佳。最佳选项会精修边缘。

可在不同 Roto 笔刷版本和质量之间选择并切换的选项。
在不同 Roto 笔刷质量之间选择和切换的选项。

传播属性组中的属性(除查看搜索区域外)影响所有“Roto 笔刷”计算。对这些属性做任何更改都需要重新计算和传播来自基帧的分段信息。此外,基帧自身上的结果不受这些属性变化的影响;因此,最好在当前时间指示器是一个帧或距离一个基帧有两单位远时更改这些属性,以便可以看到更改结果。

在“时间轴”面板中启用 Roto 笔刷经典控件。
在“时间轴”面板中启用 Roto 笔刷经典控件。

  • 搜索半径:After Effects 逐帧寻找匹配像素时的搜索区域半径。您可以使用运动阈值运动阻尼属性,通过增加或减少运动来更改搜索半径适应区域的方式。如果搜索半径太小,则可能错过一些运动;如果搜索半径太大,则可能检测到不相关的运动。
  • 查看搜索半径:选择此选项后,会在主体周围显示一个绿色框。它指示 Roto 笔刷算法在哪里搜索主体。如果主体移出了帧,Roto 笔刷和优化边缘效果将失效。您可以将百分比增加到更高的值以覆盖整个区域。速度较慢但更准确,涵盖了更多区域。
  • 启用经典控件:在下一代 Roto 笔刷Roto 笔刷 2 中,传播也有此复选框。此选项仅在版本设置为 3.02.0 时可用,并从新算法将传播结果传递通过经典算法,以便更好地控制传播和更多边缘细节。这会重新打开旧版“Roto 笔刷”选项(例如运动阈值边缘检测运动阻尼)。在 1.0 版中,这些选项默认处于启用状态,但在 3.02.0 版中,需要手动启用。如果使用标准最佳无法获得所需的分段结果,请尝试启用经典控件。利用这种混合的方式,可充分发挥下一代 Roto 笔刷Roto 笔刷 2Roto 笔刷 1 各自的优点。
    • 运动阀值和运动阻尼:(Roto 笔刷 1 中默认启用,下一代 Roto 笔刷 和 Roto 笔刷 2 中需要通过启用经典控件启用)。这两个属性控制基于运动限制搜索区域的方式。更改运动阈值用于设置一个运动水平,该水平以下的运动视为无运动,搜索区域收缩为无。运动阻尼影响被视为有运动的其余区域。增加运动阻尼时,搜索区域收紧,慢速运动区域比快速运动区域收得更紧。在有轻微运动的区域中限制搜索区域,可以减少这些区域中的边缘震颤。过分限制搜索区域会导致自动边界检测偏离对象边缘。
    • 边缘探测:在确定前景和背景之间的边缘时,选择是偏好为孤立的当前帧计算的分段边界,还是基于前一帧计算的分段。平衡选项同等考虑当前帧和周围帧。颜色与背景一致的前景对象通常将得益于预测边缘优先
    • 使用交替颜色估计:精细地改变 Roto 笔刷效果来判断什么是前景,什么是背景的过程。有时勾选它有助于分段;有时没有帮助。

Roto 笔刷和优化边缘效果的分段阶段,反转视为前景描边的描边,以及视为背景描边的描边。

使用此选项可优化边缘、减少震颤、移动边缘、处理对比度并羽化选区。

羽化

定义分段边界的柔和度。

对比度

增加对比度(有助于进一步收紧边界)。

移动边缘

扩展(正值)或减小(负值)分段边界。

减少震颤

当分段边界的边缘不规则移动时,会看到震颤。减少震颤可减少分段边界边缘的可见噪点,并使边缘更加清洁。

渲染优化边缘可用于查看 Roto 笔刷结果的优化边缘。它适用于基础帧和传播帧。

基本优化边缘半径可以扩展已使用优化边缘 Roto 笔刷工具创建的优化了边缘的区域。当使用的笔刷太小而无法帮助 After Effects 计算帧之间的优化边缘时,使用它来扩展优化边缘的区域。

启用微调优化边缘遮罩,以访问可用于对您使用优化边缘工具创建的边缘进行微调的选项。

平滑

增加此值可沿边缘进行平滑,从而降低分段边界中曲线的锐度。在隔离具有尖锐特征(如头发)的对象时,请将此数值设置为较低。

羽化

分段边界的柔和度。如果平滑0,则此属性不起作用。与平滑相比,羽化边缘应用。

对比度

增加对比度(有助于进一步收紧边界)。

移动边缘

扩展(正值)或减小(负值)分段边界。

减少震颤

增大此属性可减少边缘逐帧移动时的不规则更改。此属性确定在跨邻近帧执行加权平均以防止遮罩边缘不规则地逐帧移动时,当前帧应具有多大影响力。如果减少震颤值高,则震颤减少程度强,会较少考虑当前帧。如果减少震颤值低,则震颤减少程度弱,会较多地考虑当前帧。如果减少震颤值为 0,则仅考虑对当前帧进行遮罩优化。

提示:

如果前景对象不移动,但遮罩边缘正在移动和变化,请增加减少震颤属性的值。如果前景对象正在移动,但遮罩边缘没有移动,请降低减少震颤属性的值。

选中此选项可用运动模糊渲染遮罩。这个高质量选项虽然比较慢,但能产生更干净的边缘。您也可以控制样本数和快门角度,其意义与在合成设置的运动模糊上下文中的相同。请参阅运动模糊

扩展平滑的地方

只有在减少震颤大于 0 并选择了净化边缘颜色时才有作用。为减少震颤而移动的边缘会被清理。

增大半径

(在 Roto 笔刷 1 中名为增加净化半径):除涵盖羽化、运动模糊和扩展净化的任何清理之外,增加用于清理边缘颜色的半径值的数量(以像素为单位)。

查看地图

(在 Roto 笔刷 1 中名为查看净化图):显示哪些像素将会通过边缘颜色净化(图中的白色像素)来清理。

图层面板中的视图菜单设为“Roto 笔刷”时,图层面板右下角会出现冻结按钮。选择此按钮,可缓存并锁定合成工作区域内图层中所有 Roto 笔刷间距的分段。这将保留遮罩并将其与项目一起保存,以便在您再次打开项目或进行更改时防止 Roto 笔刷效果重新计算分段。

有关使用 Roto 笔刷的提示

在使用 Roto 笔刷工具通过绘制描边来定义前景对象时,可沿着对象特征的中心位置开始绘制描边。例如,沿骨架而不是手臂轮廓绘制描边。After Effects 然后根据这些区域推断出边界的位置。

如果在图像的错误区域绘制 Roto 笔刷描边,

可撤消该描边。(请参阅撤消更改。)但是,如果 After Effects 误解了您的描边且包含或排除了过多图像时,切勿使用“撤消”;可进行额外的描边包含或排除区域,以进一步教导“Roto 笔刷”。

在使用 Roto 笔刷工具时将分辨率设置为“完整”

快速预览模式(如自适应分辨率)不适用于 Roto 笔刷,因为切换分辨率需要重新计算分段信息。在绘制 Roto 笔刷描边时,快速预览模式会关闭。(请参阅分辨率。)

 

在帧速率设置为与图层源素材项的帧速率匹配的合成中使用 Roto 笔刷工具,

如果合成的帧速率与图层源素材项的帧速率不匹配,则合成面板中帧的底部会出现一条警告横幅。(请参阅帧速率。)

为什么应使用 Roto 笔刷 1?

  • 使用 Roto 笔刷的旧项目仍会使用 Roto 笔刷 1 打开。如果您在 17.5 版中打开使用 17.1.4 版或更早版本创建的项目,则版本会自动设置为较旧的 Roto 笔刷 1
  • 如果使用下一代 Roto 笔刷Roto 笔刷 2 无法获得所需的线条分段结果,请尝试启用经典控件。利用这种混合的方式,可充分发挥下一代 Roto 笔刷Roto 笔刷 2Roto 笔刷 1 各自的优点。此选项仅在版本设置为 3.0 2.0 时可用,并从新算法将传播结果传递通过经典算法,以便更好地控制传播和更多边缘细节。这会重新打开旧版“Roto 笔刷”选项(例如运动阈值边缘检测运动阻尼)。在 1.0 版中,这些选项默认处于启用状态,但在 3.02.0 版中,需要手动启用。

工作流程

默认情况下,Roto 笔刷 1 中可用的控件可以通过选择启用经典控件选项在下一代 Roto 笔刷Roto 笔刷 2 中激活。操作过程与下一代 Roto 笔刷和 Roto 笔刷 2 基本相同。

在“Roto 笔刷和优化边缘”控件下启用“经典控件”选项。
在“Roto 笔刷和优化边缘”控件下启用“经典控件”选项。

注释点

  • 明智地选择起始帧。帧越精确和稳定,传播越好。
  • 只能在图层面板中选择 Roto 笔刷,因此请确保已在此处打开了素材。
  • 使用 Roto 笔刷的旧项目仍会使用 Roto 笔刷 1 打开。如打开的项目创建于 17.5 版之前且使用了旧版 Roto 笔刷和调整优化边缘效果,则版本将设置为 1.0。因此,即使在新版本中打开时,旧项目也会同样呈现。

 Adobe

更快、更轻松地获得帮助

新用户?