用户指南 取消(C)

抠像效果

  1. After Effects 用户指南
  2. Beta 版
    1. Beta 版项目概述
    2. After Effects Beta 版主页
    3. Beta 版中的功能
      1. “属性”面板(Beta 版)
  3. 快速入门
    1. After Effects 快速入门
    2. After Effects 的新增功能 
    3. 发行说明 | After Effects
    4. After Effects 系统要求
    5. After Effects 中的键盘快捷键
    6. 支持的文件格式 | After Effects
    7. 硬件建议
    8. 适用于 Apple Silicon 的 After Effects
    9. 规划和设置
    10. 设置和安装
  4. 工作区
    1. 常规用户界面项
    2. 了解 After Effects 界面
    3. 工作流程
    4. 工作区、面板和查看器
  5. 项目与合成
    1. 项目
    2. 合成基础知识
    3. 预合成、嵌套和预渲染
    4. 使用合成分析器查看详细的性能信息
    5. CINEMA 4D 合成渲染器
  6. 导入素材
    1. 准备并导入静止图像
    2. 从 After Effects 和 Adobe Premiere Pro 导入
    3. 导入和解释视频与音频
    4. 准备和导入 3D 图像文件
    5. 导入和解释素材项目
    6. 使用素材项目
    7. 使用“场景编辑检测”检测编辑点
    8. XMP 元数据
  7. 文本和图形
    1. 文本
      1. 设置字符格式和“字符”面板
      2. 文本效果
      3. 创建和编辑文本图层
      4. 设置段落格式和“段落”面板
      5. 凸出文本和形状图层
      6. 为文本设置动画
      7. 文本动画的示例和资源
      8. 实时文本模板
    2. 动态图形
      1. 在 After Effects 中使用动态图形模板
      2. 使用表达式在动态图形模板中创建下拉列表
      3. 使用“基本属性”创建动态图形模板
      4. 替换动态图形模板和基本属性中的图像和视频
  8. 绘图、绘画和路径
    1. 形状图层、路径和矢量图形的概述
    2. 绘画工具:笔刷、仿制图章和橡皮擦
    3. 将形状描边椎体化的方法
    4. 形状图层的形状属性、绘画操作和路径操作
    5. 使用“位移路径”形状效果更改形状
    6. 创建形状
    7. 创建蒙版
    8. 使用内容识别填充面板,移除视频中的对象
    9. Roto 笔刷和调整遮罩
  9. 图层、标记和摄像机
    1. 选择和排列图层
    2. 混合模式和图层样式
    3. 3D 图层
    4. 图层属性
    5. 创建图层
    6. 管理图层
    7. 图层标记和合成标记
    8. 摄像机、光和目标点
  10. 动画、关键帧、运动跟踪和抠像
    1. 动画
      1. 动画基础知识
      2. 使用人偶工具制作动画
      3. 管理形状路径和蒙版并对其进行动画制作
      4. 使用 After Effects 为 Sketch 和 Capture 形状制作动画
      5. 分类动画工具
      6. 使用数据驱动的动画
    2. 关键帧
      1. 关键帧插值
      2. 设置、选择和删除关键帧
      3. 编辑、移动和复制关键帧
    3. 运动跟踪
      1. 跟踪和稳定运动
      2. 人脸跟踪
      3. 蒙版跟踪
      4. 蒙版引用
      5. 速度
      6. 时间拉伸和时间重映射
      7. 时间码和时间显示单位
    4. 抠像
      1. 抠像
      2. 抠像效果
  11. 透明度与合成
    1. 合成和透明度概述及资源
    2. Alpha 通道、蒙版和遮罩
  12. 调整颜色
    1. 颜色基础知识
    2. 使用 Adobe Color Themes 扩展
    3. 色彩管理
    4. 颜色校正效果
  13. 效果和动画预设
    1. 效果和动画预设概述
    2. 效果列表
    3. 模拟效果
    4. 风格化效果
    5. 音频效果
    6. 扭曲效果
    7. 透视效果
    8. 通道效果
    9. 生成效果
    10. 过渡效果
    11. 果冻效应修复效果
    12. 模糊和锐化效果
    13. 3D 通道效果
    14. 实用效果
    15. 遮罩效果
    16. 杂色和颗粒效果
    17. 保留细节放大效果
    18. 旧版效果
  14. 表达式和自动化
    1. 表达式
      1. 表达式基础知识
      2. 了解表达式语言
      3. 使用表达式控件
      4. JavaScript 与旧版 ExtendScript 表达式引擎之间的语法差别
      5. 正在编辑表达式
      6. 表达式错误
      7. 使用表达式编辑器
      8. 使用表达式编辑和访问文本属性
      9. 表达式语言引用
      10. 表达式示例
    2. 自动化
      1. 自动化
      2. 脚本
  15. 沉浸式视频、VR 和 3D
    1. 在 After Effects 中构造 VR 环境
    2. 应用沉浸式视频效果
    3. 用于 VR/360 视频的合成工具
    4. 跟踪 3D 摄像机运动
    5. 使用 3D 设计空间
    6. 3D 变换 Gizmo
    7. 使用 3D 动画执行更多操作
    8. 使用实时引擎实时预览对 3D 设计的更改
    9. 向图形添加响应式设计 
  16. 视图和预览
    1. 预览
    2. 使用 Mercury Transmit 进行视频预览
    3. 修改和使用视图
  17. 渲染和导出
    1. 渲染和导出基础知识
    2. 将 After Effects 项目导出为 Adobe Premiere Pro 项目
    3. 转换影片
    4. 多帧渲染
    5. 自动渲染和网络渲染
    6. 渲染和导出静止图像及静止图像序列
    7. 在 After Effects 中使用 GoPro CineForm 编解码器
  18. 使用其他应用程序
    1. Dynamic Link 和 After Effects
    2. 使用 After Effects 和其他应用程序
    3. After Effects 中的同步设置
    4. After Effects 中的 Creative Cloud Libraries
    5. 增效工具
    6. CINEMA 4D 和 Cineware
  19. 协作:Frame.io 和团队项目
    1. 在 Premiere Pro 和 After Effects 中协作
    2. Frame.io
      1. 安装和激活 Frame.io
      2. 将 Frame.io 与 Premiere Pro 和 After Effects 配合使用
      3. 常见问题解答
    3. 团队项目
      1. 开始使用团队项目
      2. 创建团队项目
      3. 使用团队项目进行协作
  20. 内存、存储、性能
    1. 内存和存储
    2. 提高性能
    3. 首选项
    4. After Effects 的 GPU 和 GPU 驱动程序要求

颜色差值键效果

注意:

虽然 After Effects 中内置的抠色效果对于某些用途来说会非常有用,但在尝试使用这些内置抠像效果之前,应先尝试使用 Keylight 抠像。某些抠像效果已被更新的效果(如 Keylight)取代。

有关抠像的常规信息,包括教程和其他资源的链接,请参阅抠像简介和资源

“颜色差值键”效果通过将图像分为“遮罩部分 A”和“遮罩部分 B”两个遮罩,在相对的起始点创建透明度。“遮罩部分 B”使透明度基于指定的主色,而“遮罩部分 A”使透明度基于不含第二种不同颜色的图像区域。通过将这两个遮罩合并为第三个遮罩(称为“Alpha 遮罩”),“颜色差值键”效果可创建明确定义的透明度值。

颜色差值键效果可为以蓝屏或绿屏为背景拍摄的所有亮度适宜的素材项目实现优质抠像,特别适合包含透明或半透明区域的图像,如烟、阴影或玻璃。

此效果适用于 8-bpc 和 16-bpc 颜色。

使用颜色差值键效果

  1. 选择要使其部分透明的图层,然后选择“效果”>“抠像”>“颜色差值键”。
    注意:

    要在“图层”面板中使用任何吸管,请从“图层”面板的“视图”菜单中选择“颜色差值键”。

  2. 在“效果控件”面板中,从“视图”菜单中选择“已校正遮罩”。要同时查看和比较源图像、两个部分遮罩和最终遮罩,请在“视图”菜单中选择“已校正[A,B,遮罩],最终”。“视图”菜单中的其他可用视图如第 10 步中所述。
  3. 选择适当的主色:要抠出蓝屏,请使用默认的蓝色。要抠出非蓝屏,请使用以下方法之一选择主色:
    • 缩览图吸管:选择“合成”面板或原始缩览图图像,然后单击此面板或此图像的相应区域。

    • 主色吸管:选择“合成”或“图层”面板,然后单击此面板的相应区域。

    • 主色色板:从指定颜色空间单击以选择颜色。

    注意:

    吸管工具可相应地移动滑块。使用第 9 步中的这些滑块可微调抠像结果。

  4. 单击 遮罩按钮以将最终合并的遮罩显示在遮罩缩览图中。
  5. 选择“黑色”吸管,然后在最亮的黑色区域的遮罩缩览图内单击,以指定透明区域。将调整缩览图和“合成”面板中的透明度值。
  6. 选择“白色”吸管,然后在最暗的白色区域的遮罩缩览图内单击,以指定不透明区域。将调整缩览图和“合成”面板中的不透明度值。
    注意:

    要实现尽可能最佳的抠像,请使黑白区域尽可能不同,以使图像保留尽可能多的灰色阴影。

  7. 从“颜色匹配准确度”菜单中选择匹配准确度。如果不使用非主要颜色(红色、蓝色或黄色)的屏幕,则选择“更快”。对于这些主要颜色屏幕,则选择“更准确”,这样会增加渲染时间,但可产生更好的结果。
  8. 要进一步调整透明度值,请对一个或两个部分遮罩重复第 5 步和第 6 步。单击“部分遮罩 B”按钮或“部分遮罩 A”按钮,以选择部分遮罩,然后重复这些步骤。
  9. 在“遮罩控件”部分拖动以下一个或多个滑块,为每个部分遮罩和最终遮罩调整透明度值:
    • “黑色”滑块用于调整每个遮罩的透明度水平。可以使用“黑色”吸管调整同样的水平。

    • “白色”滑块用于调整每个遮罩的不透明度水平。可以使用“白色”吸管调整同样的水平。

    • “灰度系数”滑块用于控制透明度值遵循线性增长的严密程度。值为 1(默认值),则增长呈线性。其他值可产生非线性增长,以供特殊调整或视觉效果使用。

  10. 在调整单独的遮罩时,可从“视图”菜单中选择选项来比较包含调整的遮罩和不含调整的遮罩:
    • 选择“未校正”可查看不含调整的遮罩。

    • 选择“已校正”可查看包含所有调整的遮罩。

  11. 在关闭“效果控件”面板之前,从“视图”菜单中选择“最终输出”。必须选择“最终输出”,After Effects 才渲染透明度。
    注意:

    要从图像中移除反射的主色痕迹,请通过对“颜色准确度”使用“更好”来应用“溢出抑制器”。如果图像仍有很多颜色,则应用简单阻塞工具或遮罩阻塞工具效果。

颜色键效果

注意:

从 2013 年 10 月版的 After Effects CC 开始,颜色抠像效果已移到旧版效果类别。另请使用 Keylight 效果等其他效果。

有关抠像的常规信息,包括教程和其他资源的链接,请参阅抠像简介和资源

颜色键效果可抠出与指定的主色相似的所有图像像素。此效果仅修改图层的 Alpha 通道。

此效果适用于 8-bpc 和 16-bpc 颜色。

使用颜色键效果抠出单色

  1. 选择要使其部分透明的图层,然后选择“效果”>“抠像”>“颜色键”。
  2. 在“效果控件”面板中,使用以下两种方法之一指定主色:
    • 单击“主色”色板以打开“颜色”对话框,并指定颜色。

    • 单击吸管,然后单击屏幕上的颜色。

  3. 拖动“颜色容差”滑块,以指定要抠出的颜色的范围。值越低,要抠出的接近主色的颜色范围越小。值越高,抠出的颜色范围越大。
  4. 拖动“薄化边缘”滑块,以调整抠像区域边界的宽度。正值用于扩大蒙版,从而增大透明区域。负值用于缩小蒙版,从而减少透明区域。
  5. 拖动“羽化边缘”滑块,以指定边缘的柔和度。值越高,边缘越柔和,但渲染时间越长。

颜色范围效果

注意:

虽然 After Effects 中内置的抠色效果对于某些用途来说会非常有用,但在尝试使用这些内置抠像效果之前,应先尝试使用 Keylight 抠像。某些抠像效果已被更新的效果(如 Keylight)取代。

有关抠像的常规信息,包括教程和其他资源的链接,请参阅抠像简介和资源

颜色范围效果可创建透明度,具体方法是在 Lab、YUV 或 RGB 颜色空间中抠出指定的颜色范围。您可以在包含多种颜色的屏幕上,或在亮度不均匀且包含同一颜色的不同阴影的蓝屏或绿屏上,使用此抠像。

此效果适用于 8-bpc 颜色。

颜色范围效果
使用颜色范围键效果合并亮度较低的绿屏图像(左上图)和背景图层(左下图)生成的图像(右下图)。

使用颜色范围效果

  1. 选择要使其部分透明的图层,然后选择“效果”>“抠像”>“颜色范围”。
  2. 从“颜色空间”菜单中选择 Lab、YUV 或 RGB。如果使用一种颜色空间难以隔离主体,则尝试使用其他颜色空间。
  3. 选择“主色”吸管,然后单击遮罩缩览图,以选择“合成”面板中要使其透明的颜色所对应的区域。通常,第一种颜色即覆盖图像最大区域的颜色。
    注意:

    要在“图层”面板中使用吸管,请从“图层”面板的“视图”菜单中选择“颜色范围”。

  4. 选择加号吸管,然后单击遮罩缩览图中的其他区域,以将其他颜色或阴影添加到为透明度抠出的颜色的范围中。
  5. 选择减号吸管,然后单击遮罩缩览图中的区域,以从抠出的颜色的范围中去除其他颜色或阴影。
  6. 拖动“模糊”滑块,以柔化透明和不透明区域之间的边缘。
  7. 使用“最小值”和“最大值”控件中的滑块,微调使用加号和减号吸管选择的颜色范围。L、Y、R 滑块可控制指定颜色空间的第一个分量;a、U、G 滑块可控制第二个分量;b、V、B 滑块可控制第三个分量。拖动“最小值”滑块,以微调颜色范围的起始颜色。拖动“最大值”滑块,以微调颜色范围的结束颜色。

差值遮罩效果

差值遮罩效果可创建透明度,具体方法是比较源图层和差值图层,然后抠出源图层中与差值图层中的位置和颜色匹配的像素。通常,此效果用于抠出移动对象后面的静态背景,然后将此对象放在其他背景上。差值图层通常只是背景帧素材(在移动对象进入此场景之前)。因此,差值遮罩效果最适用于使用固定摄像机和静止背景拍摄的场景。

此效果适用于 8-bpc 和 16-bpc 颜色。

差值遮罩键效果
差值遮罩键效果

A. 原始图像 B. 背景图像 C. 新背景图像 D. 最终合成图像 

使用差值遮罩效果

  1. 选择运动素材图层作为源图层。
  2. 在源图层中,找到仅包含背景的帧,并将此背景帧另存为图像文件。(请参阅渲染并导出单帧合成。)
  3. 将此图像文件导入 After Effects,并将其添加到合成中。

    导入的图像将成为差值图层。确保其持续时间至少像源图层的持续时间一样长。

    注意:

    如果拍摄的内容不包含完整的背景帧,则可以通过在 After Effects 或 Photoshop 中合并几个帧的部分来组合完整的背景。例如,可以使用仿制图章工具对一个帧中的背景采样,然后在另一个帧的部分背景上绘画样本。

  4. 单击“时间轴”面板中的“视频”开关,以关闭差值图层的显示。
  5. 确保选择原始源图层,然后选择“效果”>“抠像”>“差值遮罩”。
  6. 在“效果控件”面板中,从“视图”菜单中选择“最终输出”或“仅限遮罩”。(使用“仅限遮罩”视图可检查透明度的缺口。要在完成抠像过程后填充不需要的缺口,请参阅使遮罩中的缺口闭合。)
  7. 从“差值图层”菜单中选择背景文件。
  8. 如果差值图层的大小与源图层不同,请从“如果图层大小不同”菜单中选择以下控件之一:

    居中对齐

    将差值图层放在源图层的中央。如果差值图层比源图层小,则此图层的其余部分使用黑色填充。

    拉伸以适合

    将差值图层伸展或收缩到源图层的大小。背景图像可能会变扭曲。

  9. 调整“匹配容差”滑块,以根据图层之间的颜色必须匹配的严密程度,指定透明度数量。值越低,透明度越低;值越高,透明度越高。
  10. 调整“匹配柔和度”滑块,以柔化透明和不透明区域之间的边缘。值越高,匹配的像素越透明,但匹配像素的数量不会增加。
  11. 如果遮罩仍然包含外部像素,则在调整“差值”滑块之前先调整“模糊”滑块。在做出比较之前,此滑块可通过使两个图层略微变模糊来抑制杂色。
    注意:

    仅在比较时,这些图层才变模糊,不会使最终输出变模糊。

  12. 在关闭“效果控件”面板之前,确保从“视图”菜单中选择“最终输出”,以此确保 After Effects 渲染透明度。

提取效果

提取效果可创建透明度,具体方法是根据指定通道的直方图,抠出指定亮度范围。此效果最适用于在以下图像中创建透明度:在黑色或白色背景中拍摄的图像,或在包含多种颜色的黑暗或明亮的背景中拍摄的图像。

注意:

此效果的控件与 Adobe Premiere Pro 中提取效果的控件相似,但此效果的用途和结果不同。

此效果适用于 8-bpc 和 16-bpc 颜色。

要使用提取效果

在“效果控件”面板中,提取效果将显示“通道”菜单中指定的通道的直方图。此直方图描绘了图层中的亮度级别,显示了每个级别的相对像素数量。此直方图按从左到右的顺序从最暗(值为 0)扩展到最亮(值为 255)。

使用直方图下的透明度控制条,可以调整变透明的像素的范围。与直方图有关的控制条的位置和形状可确定透明度。与控制条覆盖的区域对应的像素保持不透明;与控制条未覆盖的区域对应的像素变透明。

  1. 选择要使其部分透明的图层,然后选择“效果”>“抠像”>“提取”。
  2. 如果是抠出明亮或黑暗的区域,则从“通道”菜单中选择“明亮度”。要创建视觉效果,请选择“红色”、“绿色”、“蓝色”或“Alpha”。
  3. 使用以下方法拖动透明度控制条,以调整透明度数量:
    • 拖动右上角或左上角的选择手柄,以调整控制条的长度,并缩小或增大透明度范围。也可以移动“白场”和“黑场”滑块来调整此长度。使高于白场并低于黑场的值变透明。

    • 拖动右下角或左下角的选择手柄,以使控制条变细。使左侧控制条变细会影响图像较暗区域的透明度柔和度;使右侧控制条变细会影响较亮区域的柔和度。也可以通过调整“白色柔和度”(亮区)和“黑色柔和度”(暗区)来调整柔和度水平。

    注意:

    要使透明度控制条的边缘变细,请先缩短透明度条。

    • 向左或向右拖动整个控制条,以在直方图下对其定位。

内部/外部键效果

注意:

虽然 After Effects 中内置的抠色效果对于某些用途来说会非常有用,但在尝试使用这些内置抠像效果之前,应先尝试使用 Keylight 抠像。某些抠像效果已被更新的效果(如 Keylight)取代。

有关抠像的常规信息,包括教程和其他资源的链接,请参阅抠像简介和资源

内部/外部键效果可在背景中隔离前景对象。

此效果适用于 8-bpc 和 16-bpc 颜色。

使用内部/外部键效果

要使用内部/外部键效果,请创建蒙版来定义要隔离的对象的边缘内部和外部。蒙版可以相当粗略,它不需要完全贴合对象的边缘。

除在背景中对柔化边缘的对象使用蒙版以外,内部/外部键效果还会修改边界周围的颜色,以移除沾染背景的颜色。此颜色净化过程会确定背景对每个边界像素颜色的影响,然后移除此影响,从而移除在新背景中遮罩柔化边缘的对象时出现的光环。

  1. 通过执行以下任一操作,选择要提取的对象的边界:
    • 在对象的边界附近绘制单个闭合的蒙版;然后从“前景”菜单中选择蒙版,并将“背景”菜单设置为“无”。调整“单个蒙版高光半径”以控制此蒙版周围边界的大小。(此方法仅适用于边缘简单的对象。)

    • 绘制两个闭合的蒙版:对象内部的内部蒙版和对象外部的外部蒙版。确保对象的所有模糊或不确定的区域位于这两个蒙版内。从“前景”菜单选择内部蒙版,从“背景”菜单选择外部蒙版。

    注意:

    确保所有蒙版的蒙版模式设置为“无”。

  2. 根据需要移动蒙版,以找到提供最佳结果的位置。
  3. 要提取多个对象,或在对象中创建缺口,请绘制其他蒙版,然后从“其他前景”和“其他背景”菜单中选择它们。例如,要抠出以蓝天为背景的某人随风飘动的头发,请在头部内绘制内部蒙版,在头发的外部边缘周围绘制外部蒙版,然后在您可以看到天空的头发间隙周围绘制其他蒙版。从“其他前景”菜单中选择其他蒙版,以提取间隙,并移除背景图像。
  4. 创建其他断开或闭合的蒙版以清理图像的其他区域,然后从“清理前景”或“清理背景”菜单中选择它们。“清理前景”蒙版用于沿蒙版增加不透明度;“清理背景”蒙版用于沿蒙版减少不透明度。使用“笔刷半径”和“笔刷压力”选项来控制每个描边的大小和浓度。
    注意:

    您可以选择“背景”(外部)蒙版作为“清理背景”蒙版,以清理图像背景部分的杂色。

  5. 设置“薄化边缘”以指定受抠像影响的遮罩的边界数量。正值使边缘朝透明区域的相反方向移动,从而增大透明区域;负值使边缘朝透明区域移动,可增大前景区域的大小。
  6. 增大“羽化边缘”值以柔化抠像区域的边缘。“羽化边缘”值越高,渲染时间越长。
  7. 指定“边缘阈值”,这是一个软屏蔽,用于移除使图像背景产生不需要的杂色的低不透明度像素。
  8. 选择“反转提取”,以反转前景和背景区域。
  9. 设置“与原始图像混合”,以指定生成的提取图像与原始图像混合的程度。

线性颜色键效果

注意:

虽然 After Effects 中内置的抠色效果对于某些用途来说会非常有用,但在尝试使用这些内置抠像效果之前,应先尝试使用 Keylight 抠像。某些抠像效果已被更新的效果(如 Keylight)取代。

有关抠像的常规信息,包括教程和其他资源的链接,请参阅抠像简介和资源

线性键效果可跨图像创建一系列透明度。线性键效果可将图像的每个像素与指定的主色进行比较。如果像素的颜色与主色近似匹配,则此像素将变得完全透明。不太匹配的像素将变得不太透明,根本不匹配的像素保持不透明。因此,透明度值的范围形成线性增长趋势。

线性颜色键效果可使用 RGB、色相或色度信息来创建指定主色的透明度。

此效果适用于 8-bpc、16-bpc 和 32-bpc 颜色。

应用线性颜色键效果

在“效果控件”面板中,线性颜色键效果将显示两个缩览图图像;左边的缩览图图像表示未改变的源图像,右边的缩览图图像表示在“视图”菜单中选择的视图。

您可以调整主色、匹配容差和匹配柔和度。匹配容差用于指定像素在开始变透明之前,必须匹配主色的严密程度。匹配柔和度用于控制图像和主色之间的边缘的柔和度。

您还可以重新应用此抠像,以保留第一次应用此抠像使其变透明的颜色。例如,如果抠出中蓝屏,则可能丢失主体穿着的衣物的某些或全部淡蓝色部分。您可以恢复淡蓝色,具体方法是再应用一个线性颜色键效果的实例,并从“主要操作”菜单中选择“保留此颜色”。

  1. 选择一个图层作为源图层,然后选择“效果”>“抠像”>“线性颜色键”。
  2. 在“效果控件”面板中,从“主要操作”菜单中选择“主色”。
  3. 从“匹配颜色”菜单中选择一个颜色空间。在大多数情况下,使用默认 RGB 设置。如果使用一种颜色空间难以隔离主体,则尝试使用其他颜色空间。
  4. 在“效果控件”面板中,从“视图”菜单中选择“最终输出”。选择的视图将显示在右缩览图和“合成”面板中。要查看其他结果,请使用其他视图之一工作:

    仅限源

    显示未应用抠像效果的原始图像。

    仅限遮罩

    显示 Alpha 通道遮罩。使用此视图可检查透明度的缺口。要在完成抠像过程后填充不需要的缺口,请参阅使遮罩中的缺口闭合

  5. 使用以下方法之一选择主色:
    • 选择“缩览图”吸管,然后单击“合成”面板或原始缩览图图像中的相应区域。

    • 选择“主色”吸管,然后单击“合成”或“图层”面板中的相应区域。

    • 要预览其他颜色的透明度,请选择“主色”吸管,按住 Alt 键 (Windows) 或 Option 键 (Mac OS),并将指针移至“合成”面板或原始缩览图图像中的其他区域。在其他颜色或阴影上移动指针时,“合成”面板中的图像的透明度会改变。单击以选择颜色。

    • 单击“主色”色板,以从指定颜色空间选择颜色。所选颜色将变透明。

      :吸管工具可相应地移动滑块。使用第 6 步和第 7 步中的这些滑块可微调抠像结果。要在“图层”面板中使用吸管,请从“图层”面板的“视图”菜单中选择“线性颜色键”。

  6. 使用以下方法之一调整匹配容差:
    • 选择“加号”(+) 或“减号”(-) 吸管,然后单击左缩览图图像中的颜色。“加号”吸管会将指定颜色添加到主色范围,从而增加透明度的匹配容差和级别。“减号”吸管会从主色范围减去指定颜色,从而减少透明度的匹配容差和级别。

    • 拖动匹配容差滑块。值为 0,可使整个图像不透明;值为 100,可使整个图像透明。

  7. 拖动“匹配柔和度”滑块,以通过减少容差值来柔化匹配容差。通常,20% 以下的值可产生最佳结果。
  8. 在关闭“效果控件”面板之前,确保从“视图”菜单中选择“最终输出”,以此确保 After Effects 渲染透明度。

在应用线性颜色键效果后保留颜色

  1. 在“效果控件”面板或“时间轴”面板中,取消选择抠像名称或工具名称左侧的“效果”选项,以关闭抠像或遮罩效果的当前所有实例。取消选择选项会使原始图像显示在“合成”面板中,以使您可以选择要保留的颜色。
  2. 选择“效果”>“抠像”>“线性颜色键”。第二组“线性颜色键”控件将显示在“效果控件”面板中第一组控件之下。
  3. 在“效果控件”面板中,从“主要操作”菜单中选择“保持颜色”。
  4. 选择要保持的颜色。
  5. 在线性颜色键效果的第一个应用中,从“效果控件”面板的“视图”菜单中选择“最终输出”,然后重新打开线性颜色键效果的其他实例,以检查透明度。您可能需要调整颜色,或第三次重新应用抠像来获取需要的结果。

亮度键效果

注意:

从 2013 年 10 月版的 After Effects CC 开始,亮度抠像效果已移到旧版效果类别,建议用户使用 Keylight 效果等其他效果。

有关抠像的常规信息,包括教程和其他资源的链接,请参阅抠像简介和资源

亮度键效果可抠出图层中具有指定明亮度或亮度的所有区域。图层的品质设置不会影响亮度键效果。

如果要在其中创建遮罩的对象的明亮度值与其背景显著不同,则使用此效果。例如,如果要在白色背景上为音符创建遮罩,则可抠出较亮的值;黑暗的音符将变为唯一不透明的区域。

此效果适用于 8-bpc 和 16-bpc 颜色。

亮度键效果
使用亮度键效果移除的原始图像的白色背景(左上图和左下图),在下层图层上合成的图像(右下图)。

使用亮度键效果抠出明亮度值区域

  1. 选择要使其部分透明的图层,然后选择“效果”>“抠像”>“亮度键”。
  2. 选择“抠像类型”以指定要抠出的范围。
  3. 在“效果控件”面板中拖动“阈值”滑块,以设置希望遮罩基于的明亮度值。
  4. 拖动“容差”滑块,以指定要抠出的值的范围。值越低,要抠出的阈值附近的值范围越小。值越高,要抠出的值范围越大。
  5. 拖动“薄化边缘”滑块,以调整抠像区域边界的宽度。正值用于使蒙版增大,从而增大透明区域。负值用于缩小蒙版。
  6. 拖动“羽化边缘”滑块,以指定边缘的柔和度。值越高,边缘越柔和,但渲染时间越长。

溢出抑制器效果

注意:

从 2014 年 6 月版的 After Effects CC 开始,“溢出抑制器”效果被移至“废弃”效果类别,建议用户使用“高级溢出抑制器”效果。

“抠像清除器”效果和“高级溢出抑制器”效果

抠像清除器效果

利用“抠像清除器”效果,可恢复通过典型抠像效果抠出的场景中的 Alpha 通道细节,包括恢复因压缩伪像而丢失的细节。

注意:

如果您发现本应锐化的边缘混入了半透明的效果,请使用效果蒙版(具有一些蒙版羽化效果)来限制“抠像清除器”效果影响预期的区域。

高级溢出抑制器效果

利用“高级溢出抑制器”效果,可去除用于颜色抠像的彩色背景中的前景主题颜色溢出。

“高级溢出抑制器”效果有两种溢出抑制方法:

  1. 标准 - “标准”方法比较简单, 可自动检测主要抠像颜色,需要的用户操作较少。
  2. 极致 - “极致”方法基于 Premiere Pro 中的“极致键”效果的溢出抑制。有关“极致抠像”的详细信息,请参阅 Premiere Pro 中的“极致抠像”部分

通过使用 Keylight +“抠像清除器”+“溢出抑制器”动画预设,可轻松应用这些效果。

注意:

从 2014 年 6 月版的 After Effects CC 开始,“溢出抑制器”效果被移动至“废弃”效果类别,建议用户使用“高级溢出抑制器”效果。

Keylight 效果

After Effects 包括几个内置的抠像效果,以及获得奥斯卡奖的 Keylight 效果,后者在制作专业品质的抠色效果方面表现出色。有关 Keylight 效果的信息,请参阅安装 Keylight 增效工具的文件夹中的文档。(请参阅增效工具。)

有关抠像的常规信息,包括教程和其他资源的链接,请参阅抠像简介和资源

注意:

“主色”属性已经与 Keylight 效果的“屏幕颜色”属性通过表达式相关联,因此除非需要为消除溢出的过程使用不同的颜色,否则无需更改该属性。要为消除溢出的过程使用不同的颜色,只需禁用或移除 Keylight 表达式即可。

使用 Keylight + 抠像清除器 + 高级溢出抑制器动画预设

Keylight、抠像清除器和高级溢出抑制器效果
Keylight、抠像清除器和高级溢出抑制器效果

Keylight 预设
Keylight 预设

按照以下步骤应用 Keylight 效果搭配抠像清除器高级溢出抑制器效果:

  1. 使用 Keylight + 抠像清除器 + 高级溢出抑制器动画预设(在 Image-Utlities 文件夹的“动画预设”下),将这三种效果应用于图层。默认情况下,会关闭“高级溢出抑制器”效果,使您可以在 Keylight 效果中对主色采样,或者素材中不存在任何要去除的颜色溢出。
  2. 使用 Keylight 效果的“屏幕颜色”吸管,对“合成”面板中的图层主色进行取样。和平时一样,调整 Keylight 效果设置,以获得最佳效果。
  3. 打开“高级溢出抑制器”效果的效果开关,可去除场景中的颜色溢出(如果需要)。
注意:

如果您发现本应锐化的边缘混入了半透明的效果,请使用效果蒙版(具有一些蒙版羽化效果)来限制“抠像清除器”效果影响预期的区域。

有关蒙版羽化的信息,请参阅文章《可变宽度蒙版羽化》《柔化蒙版的边缘》

使用“抠像清除器”和“高级溢出抑制器”效果搭配其他抠像效果   

按照以下步骤将抠像清除器和高级溢出抑制器效果应用到除 Keylight 效果以外的抠像效果:

  1. 将此抠像效果应用于图层。
  2. 将效果的设置设为与 Keylight 效果的“中间值结果”设置相同,这样,抠像效果无需执行其自身的溢出抑制,就可给出全 RGB 结果。
  3. 在应用抠像效果后,应用“抠像清除器”效果。
  4. 在应用“抠像清除器”效果后,应用“高级溢出抑制器”效果。

学习教程

观看此视频了解如何使用新的抠像清除器效果从压缩或拍摄不当的绿屏素材中获得更好的抠像效果,以及如何使用高级溢出抑制器控件去除颜色溢出。

溢出抑制器

Adobe 徽标

登录到您的帐户

[Feedback V2 Badge]