创建蒙版

您可以使用以下任何方法为合成中的每个图层创建一个或多个蒙版。

在图层上创建蒙版时,蒙版名称按照您创建蒙版的顺序显示在“时间轴”面板轮廓中。要组织和跟踪您的蒙版,请对其进行重命名。

注意:

要重命名某个蒙版,请将其选中并按 Enter 键 (Windows) 或 Return 键 (Mac OS),或者右键单击 (Windows) 或在按住 Control 键的同时单击 (Mac OS) 蒙版名称并选择“重命名”。

在为“图层”面板中的一个图层创建额外的蒙版时,请确保“图层”面板中的“目标”菜单设置为“无”;否则,您将替换目标蒙版而不是创建新蒙版。您还可以锁定蒙版以阻止对其进行更改。

指定一个蒙版以设置为“图层”面板中的目标的菜单选项
指定一个蒙版以设置为“图层”面板中的目标的菜单选项

A. “视图”菜单 B. “目标”菜单 

在创建或编辑蒙版时,在“信息”面板中查找蒙版名称和蒙版中的顶点数等信息。

注意:

要创建可独立于要遮蔽的主图层进行移动的蒙版,请执行以下操作:

  1. 在单独的白色纯色图层上创建蒙版,并将该纯色图层用作主图层的跟踪遮罩。
  2. 使用父子关系使该纯色图层成为主图层的子项,以便蒙版随主图层移动,就好像直接应用它一样。因为该纯色图层是一个子图层,它还可以独立于其父代出现动画效果。
  3. 您可以使用运动跟踪使纯色图层(以及蒙版)跟随主图层中的移动对象。(请参阅将图层转换为跟踪遮罩父图层和子图层。)

用数字创建矩形或椭圆蒙版

  1. 在“合成”面板中选择图层,或在“图层”面板中显示图层。
  2. 选择“图层”>“蒙版”>“新建蒙版”。新蒙版出现在“合成”面板或“图层”面板中,其手柄位于框架的外边缘。
  3. 选择“图层”>“蒙版”>“蒙版形状”。
  4. 选择“重置为”,从“形状”菜单中选择“矩形”或“椭圆”,然后指定蒙版定界框的大小和位置。

使用自动追踪基于通道值创建蒙版

  1. 通过使用“自动追踪”命令,您可以将图层的 Alpha、红、绿、蓝或亮度通道转换为一个或多个蒙版。
  2. 自动追踪会创建任意多的贝塞尔曲线蒙版,具体取决于描绘图层中指定通道值的轮廓所需的蒙版数。
  3. 在符合您选择的设置的情况下,它还会创建具有尽可能少的顶点的蒙版。
  4. 与任何其他蒙版一样,您可以修改使用自动追踪创建的蒙版,并且可以使用表达式将其路径链接到其他路径类型,例如形状图层上的形状路径。

在应用自动追踪时,受影响的图层将自动设置为“最佳品质”以确保准确结果。

注意:

要减少由自动追踪创建的蒙版数,在应用自动追踪前,请向该图层应用一个抠像效果以隔离您的主体。

  1. 在“时间轴”面板中,执行以下操作之一:
    • 要为单个帧创建蒙版关键帧,请将当前时间指示器拖到所需帧上。
    • 要跨一系列帧创建蒙版关键帧,请设置跨越该范围的工作区域。
  2. 选择一个或多个图层。
  3. 选择“图层”>“自动追踪”。
  4. 选择以下选项之一:

    当前帧

    只为当前帧创建蒙版关键帧。

    工作区域

    为工作区域内的帧创建蒙版关键帧。

  5. 设置以下任一选项:

    反转

    在搜索边缘之前反转输入图层。

    模糊

    生成描摹结果前模糊原始图像。选择此选项可在描摹结果中减轻细微的不自然感并平滑锯齿边缘。取消选择此选项可在高对比度图像中准确地描摹详细信息。以像素为单位指定用于模糊操作的区域的半径。较大的值可以产生较大的模糊。

    容差

    允许追踪的路径与通道等高线的偏离距离,以像素为单位。

    阈值

    以百分比指定像素的通道必须具有多大值,才能将该像素视为边缘的一部分。通道值高于阈值的像素将映射为白色并且是不透明的;通道值低于阈值的像素将映射为黑色并且是透明的。

    最小区域

    指定将描摹的原始图像中的最小特征。例如,值为 4 将从描摹结果中删除宽高小于 2 x 2 像素的特征。

    圆角值

    指定顶点处的蒙版曲线的圆度。要获得较平滑的曲线,请输入一个较高的值。

    应用到新图层

    将蒙版应用于与选定图层具有相同大小的新纯色图层。对于启用了“折叠变换”的图层,会自动选择此控件 - 它创建一个大小与包含该图层的合成相同的新图层。

    预览

    选择此选项可预览蒙版结果以及“自动追踪”命令的各种选项的结果。

创建形状和形状图层

您可以通过使用形状工具或钢笔工具在“合成”面板中进行绘制来创建形状图层。然后,您可以向现有形状添加形状属性,或者在该形状图层内创建新形状。默认情况下,如果您在选中了某个图层的情况下在“合成”面板中进行绘制,则会在该形状图层内创建一个新形状,它将位于选中的图层或图层组之上。如果您在选中了图像图层而非形状图层的情况下使用形状工具或钢笔工具在“合成”面板中进行绘制,则将创建一个蒙版。

注意:

在“合成”面板中绘制以创建新形状图层之前按 F2 键可取消选择所有图层。

您可以使用以下任何方法创建形状和形状图层:

在大多数情况下,新形状具有与在绘制形状时“工具”面板中的填充和描边设置相对应的一个填充和描边。在绘制某个形状后,您可以在“工具”面板中使用相同的控件来为该选中的形状更改这些属性。基于文本创建的形状是使用与原始文本的填充和描边相匹配的填充和描边创建的。

注意:

要在形状图层上创建蒙版,请在某个形状工具或钢笔工具处于活动状态的情况下单击“工具”面板中的“工具创建蒙版” 按钮。有关创建蒙版的更多信息,请参阅创建蒙版

将矢量插画素材转换为形状 | CC、CS6

在早期的 After Effects 版本中,您可以导入 Illustrator (.ai)、EPS (.eps) 或 PDF (.pdf) 文件,不过您无法修改文件。现在,您可以基于矢量插画素材图层创建形状图层,然后对其进行修改。

在 After Effects 中,能够对对象进行倾斜和凸出,因此还可以对图稿进行凸出(例如,凸出的徽标)。请参阅凸出文本和形状图层

要将矢量插画素材图层转换为形状图层,请执行以下操作:

  1. 选择“图层”>“从矢量图层创建形状”。一个匹配的形状图层将出现在素材图层上,并且素材图层将是柔色的。

    已知存在以下问题:

    • 当前不是所有的 Illustrator 文件功能都被保留。示例包括:不透明度、图像和渐变。
    • 转换的形状会忽略在“解释素材”对话框中指定的 PAR 覆盖。
    • 渐变和不受支持的类型可能会显示为 50% 灰色形状。
    • 包含数千个路径的文件可能导入非常缓慢,且不提供反馈。
    • 该菜单命令一次只对一个选定的图层起作用。
    • 如果您将某个 Illustrator 文件导入为合成(即,多个图层),则无法一次转换所有这些图层。不过,您可以将文件导入为素材,然后使用该命令将单个素材图层转换为形状。

您可以观看此视频(video2brain 提供,作者 Todd Kopriva),了解在 After Effects CS6 中如何快速将来自 Illustrator 的矢量图形转换为形状图层,以及如何快速使路径动态化。此过程比在以前的 After Effects 版本中要简单得多。

通过使用形状工具进行拖动创建形状或蒙版

形状工具有矩形 、圆角矩形 、椭圆 、多边形 和星形 工具。

注意:

要激活和循环切换形状工具,请按 Q 键。

多边形是没有“内径”属性或“内圆度”属性的星形,因此为多边形或星形创建的形状的名称相同:多边星形

在“合成”面板或“图层”面板中,您可以使用某个形状工具在选定图层上进行拖动来创建蒙版。在“合成”面板中,您可以使用某个形状工具在选定形状图层上进行拖动来创建形状。在“合成”面板中,如果在未选定图层的情况下使用某个形状工具进行拖动,则会在新的形状图层上创建一个形状。

注意:

要在形状图层上绘制蒙版,请在某个形状工具处于活动状态的情况下单击“工具”面板中的“工具创建蒙版” 按钮。

在“合成”面板中使用某个形状工具进行拖动来创建形状时,您将创建参数形状路径。要改为创建贝塞尔曲线形状路径,请在单击以开始拖动之前按住 Alt 键 (Windows) 或 Option 键 (Mac OS)。您可以在完成拖动操作之前释放该键。所有蒙版路径都是贝塞尔曲线路径。(请参阅关于形状和形状图层。)

拖动 从您在“合成”面板或“图层”面板中单击以开始拖动时开始,在您释放鼠标按键时结束。在单个拖动操作期间,在不同的时间按辅助键可获得不同的结果:

  • 要在绘制时重新放置某个形状或蒙版,请在拖动的同时按空格键或鼠标中键。

  • 如果要在拖动期间围绕圆、椭圆、正方形、圆角正方形、矩形或圆角矩形的中心对其进行缩放,请在开始拖动后按住 Ctrl 键 (Windows) 或 Command 键 (Mac OS)。在释放鼠标按键以完成绘制之前,不要释放该键。

  • 要取消绘制操作,请按 Esc 键。

注意:

每个形状工具都随该工具保留最近的绘制操作的设置。例如,如果您绘制一个星形并且将点的数目修改为 10,则绘制的下一个星形也将有 10 个点。要重置工具的设置并使用默认设置创建形状,请在“工具”面板中双击该工具。(请参阅创建图层大小的形状或蒙版。)

绘制矩形、圆角矩形、正方形和圆角正方形

  1. 选择矩形工具 或圆角矩形工具 ,并执行以下操作之一:
    • 要绘制矩形或圆角矩形,请沿对角线拖动。
    • 要绘制正方形或圆角正方形,请按住 Shift 键沿对角线方向拖动。
  2. (可选)如果绘制圆角矩形或圆角正方形,请在释放鼠标按键之前执行以下操作:
    • 要增大或减小圆角值,请按向上箭头键或向下箭头键,或者向前或向后滚动鼠标滚轮。
    • 要将圆角值设置为最小值或最大值,请按向左箭头键或向右箭头键。
  3. 释放鼠标按键以完成绘制。如果绘制正方形或圆角正方形,请在释放鼠标按钮之后释放 Shift 键。

注意:

创建的正方形是否显示为正方形取决于合成的像素长宽比。如果合成的像素长宽比不是 1,则仅当在“合成”面板的底部选择“切换像素长宽比”按钮 时,正方形才会在“合成”面板中显示为正方形。

绘制椭圆和圆

  1. 选择椭圆工具 ,然后执行以下操作之一:
    • 要绘制椭圆,请沿对角线拖动。
    • 要绘制圆,请在按住 Shift 键的同时沿对角线拖动。
  2. 释放鼠标按键以完成绘制。如果绘制圆,请在释放鼠标按钮之后释放 Shift 键。

注意:

创建的圆是否显示为圆形取决于合成的像素长宽比。如果合成的像素长宽比不是 1,则仅当在“合成”面板的底部选择“切换像素长宽比”按钮 时,圆才会在“合成”面板中显示为圆。

绘制多边形和星形

  1. 选择多边形工具 或星形工具 ,并执行以下操作之一:
    • 在绘制时进行拖动以缩放并旋转多边形或星形。
    • 绘制时在按住 Shift 键的同时缩放多边形或星形,防止旋转。
  2. (可选)在释放鼠标按键之前执行以下操作:
    • 要添加或删除点,请按向上箭头键或向下箭头键,或者向前或向后滚动鼠标滚轮。
    • 要增大或减小外圆度,请按向左箭头键或向右箭头键。
    • 要在移动鼠标以增大外径的同时使星形的内径保持不变,请按 Ctrl 键 (Windows) 或 Command 键 (Mac OS)。
    • 要增大或减小星形的内圆度,请按 Page Up 键或 Page Down 键。
  3. 释放鼠标按键以完成绘制。如果按住 Shift 键拖动以防止旋转,请在释放鼠标按钮后释放 Shift 键。

使用钢笔工具创建贝塞尔曲线形状或蒙版

您可以在“合成”面板或“图层”面板中使用钢笔工具在选定的图层上创建贝塞尔曲线蒙版。您可以在“合成”面板中使用钢笔工具在选定的形状图层上创建具有某个贝塞尔曲线路径的形状。如果在未选定图层的情况下使用钢笔工具在“合成”面板中进行绘制,则会在新的形状图层上创建一个形状。

创建旋转贝塞尔曲线路径类似于创建手动贝塞尔曲线路径。主要差别是顶点的方向线和路径段的弯度是自动计算的。

使用钢笔工具创建手动贝塞尔曲线路径

  1. 在“工具”面板中选择了钢笔工具且取消选择了“旋转贝塞尔曲线”选项的情况下,在“合成”面板中单击您希望放置第一个顶点的位置。
  2. 单击您希望放置下一个顶点的位置。要创建弯曲的段,请拖动方向线手柄以创建您需要的曲线。

    注意:

    要在单击以放置某个顶点后但在释放鼠标按键之前重新放置该顶点,请在按住空格键的情况下拖动。

    最后添加的顶点将显示为一个纯色正方形,表示它处于选中状态。随着您添加更多的顶点,以前添加的顶点将成为空的且被取消选择。

  3. 重复第 2 步,直到您准备就绪可完成路径。
  4. 通过执行以下任一操作完成路径:
    • 要闭合路径,请将指针放置在第一个顶点上,并且在一个闭合的圆图标出现在指针 旁边时,单击该顶点。

    注意:

    您还可以通过双击最后一个顶点或者选择“图层”>“蒙版和形状路径”>“已关闭”来闭合路径。

    • 要使路径保持开放状态,请激活一个不同的工具,或者按 F2 以取消选择该路径。

使用钢笔工具绘制笔直的手动贝塞尔曲线路径

使用钢笔工具可以绘制的最简单路径是直线,绘制方法是通过使用钢笔工具进行单击来创建两个顶点。通过连续单击,可以创建由通过边角点连接的直线段组成的路径。

使用钢笔工具单击将创建直线段。
使用钢笔工具单击将创建直线段。

  1. 将钢笔工具放在您希望直线段开始的位置,然后单击来放置顶点。(不要拖动。)
  2. 再次单击您希望结束线段的位置。(在按住 Shift 键的同时单击可将角点处线段之间的角度限制为 45° 的整数倍。)
  3. 继续单击,为其他的直线段设置顶点。

使用钢笔工具绘制弯曲的手动贝塞尔曲线路径

通过拖动方向线来创建弯曲的路径段。方向线的长度和方向决定了曲线的形状。

注意:

在按住 Shift 键的同时拖动可将方向线的角度限制为 45° 的整数倍。在按住 Alt 键的同时拖动 (Windows) 或在按住 Option 键的同时拖动 (Mac OS) 可以仅修改引出方向线。

  1. 将钢笔工具放置在您希望开始曲线的位置,然后按下鼠标按键。

    将出现一个顶点,并且钢笔工具指针将变为一个箭头。

  2. 拖动以修改顶点的两条方向线的长度和方向,然后释放鼠标按钮。
    绘制曲线路径中的第一个顶点
    绘制曲线路径中的第一个顶点

    A. 放置钢笔工具 B. 开始拖动(鼠标按钮按下) C. 拖动以延长方向线 
  3. 将钢笔工具放置到希望曲线段结束的位置,然后执行以下操作之一:
    • 要创建 C 形曲线,请沿与您拖动前一方向线的方向相反的方向进行拖动,然后释放鼠标按键。
    绘制曲线路径中的第二个顶点
    绘制曲线路径中的第二个顶点

    A. 开始拖动 B. 向远离前一条方向线的方向拖动,创建 C 形曲线 C. 松开鼠标按钮后的结果 
    • 要创建 S 形曲线,请按照与前一条方向线相同的方向拖动,然后松开鼠标按键。
    绘制 S 曲线
    绘制 S 曲线

    A. 开始拖动 B. 按照与前一条方向线相同的方向拖动,创建 S 形曲线 C. 松开鼠标按钮后的结果 
  4. 继续从不同的位置拖动钢笔工具以创建一系列平滑曲线。

创建图层大小的形状或蒙版

  1. 为新蒙版或形状选择目标:
    • 要在某个现有的形状图层上创建形状,请选择该形状图层。
    • 要使用合成的尺寸在一个新的形状图层上创建形状,请通过按 F2 取消选择所有图层。
    • 要创建蒙版,请在“时间轴”面板、“图层”面板或“合成”面板中选择一个图层。要在形状图层上创建蒙版,请在某个形状工具处于活动状态的情况下选择“工具”面板中的“工具创建蒙版” 按钮。
    • 要替换蒙版路径,请在“时间轴”面板、“图层”面板或“合成”面板中选择该蒙版。
    • 要替换某个形状路径,请在“合成”面板或“时间轴”面板中选择该形状路径。
  2. 在“工具”面板中,右键单击矩形 、圆角矩形 、椭圆 、多边形 或星形 工具。

基于文本字符创建形状或蒙版

“从文本创建形状”命令提取每个字符的轮廓,基于轮廓创建形状,并将形状放置在一个新的形状图层上。然后,您可以像使用任何其他形状一样使用这些形状。

“从文本创建蒙版”命令提取每个字符的轮廓,基于轮廓创建蒙版,并将蒙版放置在一个新的纯色图层上。然后,您可以像使用任何其他蒙版一样使用这些蒙版。

注意:

某些字体系列(例如 Webdings)包括图形图像形式的字符而不是文本。若要开始在形状图层中使用简单的图形元素,转换来自这些字体系列的文本将会是一个不错的方法。

从文本创建形状

  1. 选择要转换为形状的文本:
    • 要为某个文本图层中的所有字符创建形状,请在“时间轴”面板或“合成”面板中选择该文本图层。
    • 要为特定的字符创建形状,请在“合成”面板中选择字符。
  2. 执行以下操作之一:
    • 选择“图层”>“从文本创建形状”。
    • 右键单击 (Windows) 或在按住 Control 键的同时单击 (Mac OS) 图层或文本,并从上下文菜单中选择“从文本创建形状”。

文本图层的视频开关 已关闭。

将在图层堆叠顺序的顶部创建新的形状图层。新图层针对每个选定的字符包含一个形状组,并包含与文本的填充和描边匹配的填充和描边属性。

对于包含复合路径的字符(例如 ie),将创建多个路径并通过“合并路径”路径操作对其进行组合。

文本图层的变换属性组中属性的效果、蒙版、图层样式以及关键帧和表达式将被复制到新形状图层或纯色图层。

从文本创建蒙版

  1. 选择要转换为蒙版的文本:
    • 要为某个文本图层中的所有字符创建蒙版,请在“时间轴”面板或“合成”面板中选择该文本图层。
    • 要为特定的字符创建蒙版,请在“合成”面板中选择字符。
  2. 执行以下操作之一:
    • 选择“图层”>“从文本创建蒙版”。
    • 右键单击 (Windows) 或在按住 Control 键的同时单击 (Mac OS) 图层或文本,并从上下文菜单中选择“从文本创建蒙版”。

文本图层的视频开关 已关闭。

新建的纯色图层位于图层堆积顺序的顶部。

对于包含复合路径的字符(例如 ie),将创建多个蒙版并通过“相减”蒙版模式对其进行组合。

从 Illustrator、Photoshop 或 Fireworks 复制路径

您可以从 Illustrator、Photoshop 或 Fireworks 复制路径并将其作为蒙版路径或形状路径粘贴到 After Effects 中。

要使从 Illustrator 复制的数据与 After Effects 相兼容,必须在“Adobe Illustrator 首选项”对话框的“文件和剪贴板”部分中选择 AICB 选项。

要使从 Photoshop 导入的路径正确地缩放,Photoshop 文档必须具有 72 dpi 的分辨率。72 dpi 是使用“胶片和视频”预设在 Photoshop 中创建的文档的分辨率设置。

注意您还可以将复制的 Illustrator、Photoshop 或 Fireworks 路径用作 After Effects 运动路径。有关更多信息,请参阅基于蒙版、形状或绘画路径创建运动路径

在 Adobe Illustrator 中绘制(左图)并作为蒙版粘贴到 After Effects 中的路径(右图)
在 Adobe Illustrator 中绘制(左图)并作为蒙版粘贴到 After Effects 中的路径(右图)

  1. 在 Illustrator、Photoshop 或 Fireworks 中,选择某个完整路径,然后选择“编辑”>“复制”。
  2. 在 After Effects 中,执行以下任一操作来定义粘贴操作的目标:
    • 要创建新蒙版,请选择一个图层。
    • 要替换现有的蒙版路径或形状路径,请选择其“路径”属性。

    注意:

    要将某个路径粘贴为形状路径,您必须在形状图层中选择某个现有形状的“路径”属性。此选择告诉 After Effects 粘贴操作的目标是什么;如果没有以此方式指定目标,则 After Effects 会假定目标是整个图层,因此会绘制一个新蒙版。如果没有“路径”属性(可能因为形状图层为空),则可以使用钢笔工具绘制一个占位符路径,然后将路径从 Illustrator 复制到占位符路径。

  3. 选择“编辑”>“粘贴”。

    如果您将多个路径粘贴到一个形状路径中,则第一个路径将进入该形状路径,其余的路径将被粘贴到新的蒙版路径中。发生此行为的原因是,除第一个路径之外的其他路径没有明确定义的目标,因此它们将被作为蒙版添加到整个图层中。

Andrew Devis 在 Creative COW 网站上的此视频中展示了如何将来自 Illustrator 的路径用作 After Effects 中的运动路径。

基于运动路径创建蒙版或形状

您可以复制位置关键帧、锚点关键帧或效果控制点的位置关键帧并将这些关键帧粘贴到选定的蒙版路径或形状路径中。在基于运动路径创建蒙版路径或形状路径时,请确保仅从单个位置属性复制关键帧 - 不要复制任何其他属性的关键帧。

注意:

使用“动态草图”绘制一个运动路径,然后将该路径粘贴到一个蒙版路径或形状路径中。

基于运动路径创建蒙版或形状
宇宙飞船的运动路径(最上方的图)被复制到背景图层(左下图)并由勾画效果使用(右下图)。

注意:

在蒙版路径和运动路径之间复制时,请注意,蒙版路径的值在图层的坐标系(图层空间)中表示,而运动路径的值在合成的坐标系(合成空间)中表示。此差异可能会导致粘贴的路径出现偏移,这要求您在粘贴路径后重新放置该路径。(请参阅坐标系:合成空间和图层空间。)

基于运动路径创建蒙版路径

  1. 在“时间轴”面板中,单击您要从其中复制运动路径的“位置”属性或“锚点属性”的名称。(这将选择所有关键帧。要仅选择某个运动路径的某些关键帧,请在按住 Shift 键的同时单击这些关键帧。)
  2. 选择“编辑”>“复制”。
  3. 要创建新蒙版,请选择要在其上创建蒙版的图层,然后选择“图层”>“蒙版”>“新建蒙版”。
  4. 在“时间轴”面板中,单击要从运动路径将关键帧复制到其中的蒙版的“蒙版路径”属性的名称。
  5. 选择“编辑”>“粘贴”。
    选择和复制位置关键帧
    选择和复制位置关键帧(左图);然后在选定的“蒙版路径”属性中粘贴它们(右图)

从运动路径创建形状路径

  1. 在“时间轴”面板中,单击您要从其中复制运动路径的“位置”属性或“锚点属性”的名称。(这将选择所有关键帧。要仅选择某个运动路径的某些关键帧,请在按住 Shift 键的同时单击这些关键帧。)
  2. 选择“编辑”>“复制”。
  3. 要创建新的形状图层,请按 F2 取消选择所有图层,然后使用钢笔工具在“合成”面板中单击以创建一个单点贝塞尔曲线路径。
  4. 按 SS 以显示形状的“路径”属性。单击要从运动路径将关键帧粘贴到其中的“路径”属性的名称。
  5. 选择“编辑”>“粘贴”。

在变换时复制形状组

当以组选择模式选择了某个形状组时,在“合成”面板中移动、旋转或缩放该组时,您可以复制该组。

  • 在拖动以转换组时按住 Alt 键 (Windows) 或 Option 键 (Mac OS)。

    当您按住该键,并将指针放在组变换框附近时,指针将变成复制指针()。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略