用户指南 取消(C)

Alpha 通道、蒙版和遮罩

  1. After Effects 用户指南
  2. Beta 版
    1. Beta 版项目概述
    2. After Effects Beta 版主页
    3. Beta 版中的功能
      1. “属性”面板(Beta 版)
  3. 快速入门
    1. After Effects 快速入门
    2. After Effects 的新增功能 
    3. 发行说明 | After Effects
    4. After Effects 系统要求
    5. After Effects 中的键盘快捷键
    6. 支持的文件格式 | After Effects
    7. 硬件建议
    8. 适用于 Apple Silicon 的 After Effects
    9. 规划和设置
    10. 设置和安装
  4. 工作区
    1. 常规用户界面项
    2. 了解 After Effects 界面
    3. 工作流程
    4. 工作区、面板和查看器
  5. 项目与合成
    1. 项目
    2. 合成基础知识
    3. 预合成、嵌套和预渲染
    4. 使用合成分析器查看详细的性能信息
    5. CINEMA 4D 合成渲染器
  6. 导入素材
    1. 准备并导入静止图像
    2. 从 After Effects 和 Adobe Premiere Pro 导入
    3. 导入和解释视频与音频
    4. 准备和导入 3D 图像文件
    5. 导入和解释素材项目
    6. 使用素材项目
    7. 使用“场景编辑检测”检测编辑点
    8. XMP 元数据
  7. 文本和图形
    1. 文本
      1. 设置字符格式和“字符”面板
      2. 文本效果
      3. 创建和编辑文本图层
      4. 设置段落格式和“段落”面板
      5. 凸出文本和形状图层
      6. 为文本设置动画
      7. 文本动画的示例和资源
      8. 实时文本模板
    2. 动态图形
      1. 在 After Effects 中使用动态图形模板
      2. 使用表达式在动态图形模板中创建下拉列表
      3. 使用“基本属性”创建动态图形模板
      4. 替换动态图形模板和基本属性中的图像和视频
  8. 绘图、绘画和路径
    1. 形状图层、路径和矢量图形的概述
    2. 绘画工具:笔刷、仿制图章和橡皮擦
    3. 将形状描边椎体化的方法
    4. 形状图层的形状属性、绘画操作和路径操作
    5. 使用“位移路径”形状效果更改形状
    6. 创建形状
    7. 创建蒙版
    8. 使用内容识别填充面板,移除视频中的对象
    9. Roto 笔刷和调整遮罩
  9. 图层、标记和摄像机
    1. 选择和排列图层
    2. 混合模式和图层样式
    3. 3D 图层
    4. 图层属性
    5. 创建图层
    6. 管理图层
    7. 图层标记和合成标记
    8. 摄像机、光和目标点
  10. 动画、关键帧、运动跟踪和抠像
    1. 动画
      1. 动画基础知识
      2. 使用人偶工具制作动画
      3. 管理形状路径和蒙版并对其进行动画制作
      4. 使用 After Effects 为 Sketch 和 Capture 形状制作动画
      5. 分类动画工具
      6. 使用数据驱动的动画
    2. 关键帧
      1. 关键帧插值
      2. 设置、选择和删除关键帧
      3. 编辑、移动和复制关键帧
    3. 运动跟踪
      1. 跟踪和稳定运动
      2. 人脸跟踪
      3. 蒙版跟踪
      4. 蒙版引用
      5. 速度
      6. 时间拉伸和时间重映射
      7. 时间码和时间显示单位
    4. 抠像
      1. 抠像
      2. 抠像效果
  11. 透明度与合成
    1. 合成和透明度概述及资源
    2. Alpha 通道、蒙版和遮罩
  12. 调整颜色
    1. 颜色基础知识
    2. 使用 Adobe Color Themes 扩展
    3. 色彩管理
    4. 颜色校正效果
  13. 效果和动画预设
    1. 效果和动画预设概述
    2. 效果列表
    3. 模拟效果
    4. 风格化效果
    5. 音频效果
    6. 扭曲效果
    7. 透视效果
    8. 通道效果
    9. 生成效果
    10. 过渡效果
    11. 果冻效应修复效果
    12. 模糊和锐化效果
    13. 3D 通道效果
    14. 实用效果
    15. 遮罩效果
    16. 杂色和颗粒效果
    17. 保留细节放大效果
    18. 旧版效果
  14. 表达式和自动化
    1. 表达式
      1. 表达式基础知识
      2. 了解表达式语言
      3. 使用表达式控件
      4. JavaScript 与旧版 ExtendScript 表达式引擎之间的语法差别
      5. 正在编辑表达式
      6. 表达式错误
      7. 使用表达式编辑器
      8. 使用表达式编辑和访问文本属性
      9. 表达式语言引用
      10. 表达式示例
    2. 自动化
      1. 自动化
      2. 脚本
  15. 沉浸式视频、VR 和 3D
    1. 在 After Effects 中构造 VR 环境
    2. 应用沉浸式视频效果
    3. 用于 VR/360 视频的合成工具
    4. 跟踪 3D 摄像机运动
    5. 使用 3D 设计空间
    6. 3D 变换 Gizmo
    7. 使用 3D 动画执行更多操作
    8. 使用实时引擎实时预览对 3D 设计的更改
    9. 向图形添加响应式设计 
  16. 视图和预览
    1. 预览
    2. 使用 Mercury Transmit 进行视频预览
    3. 修改和使用视图
  17. 渲染和导出
    1. 渲染和导出基础知识
    2. 将 After Effects 项目导出为 Adobe Premiere Pro 项目
    3. 转换影片
    4. 多帧渲染
    5. 自动渲染和网络渲染
    6. 渲染和导出静止图像及静止图像序列
    7. 在 After Effects 中使用 GoPro CineForm 编解码器
  18. 使用其他应用程序
    1. Dynamic Link 和 After Effects
    2. 使用 After Effects 和其他应用程序
    3. After Effects 中的同步设置
    4. After Effects 中的 Creative Cloud Libraries
    5. 增效工具
    6. CINEMA 4D 和 Cineware
  19. 协作:Frame.io 和团队项目
    1. 在 Premiere Pro 和 After Effects 中协作
    2. Frame.io
      1. 安装和激活 Frame.io
      2. 将 Frame.io 与 Premiere Pro 和 After Effects 配合使用
      3. 常见问题解答
    3. 团队项目
      1. 开始使用团队项目
      2. 创建团队项目
      3. 使用团队项目进行协作
  20. 内存、存储、性能
    1. 内存和存储
    2. 提高性能
    3. 首选项
    4. After Effects 的 GPU 和 GPU 驱动程序要求

关于 Alpha 通道和遮罩

After Effects 的颜色信息包含在三个通道中:红 (R)、绿 (G)、蓝 (B)。此外,图像还包含第四个不可见通道,即包含透明度信息的 Alpha 通道。有时,此类图像称为 RGBA 图像,指示它包含 Alpha 通道。

通道概览

A. 分离的颜色通道 B. Alpha 通道表现为灰度图像 C. 使用所有四个通道的合成,背景隐约显出透明区域 

许多文件格式都可能包括 Alpha 通道,其中包括 Adobe Photoshop、ElectricImage、FLV、TGA、TIFF、EPS、PDF 以及 Adobe Illustrator。AVI 和 QuickTime(保存为“数百万种以上颜色”的位深度)也可以包含 alpha 通道,具体取决于生成这些容器中存储的图像所用的编码解码器(编码器)。对于 Adobe Illustrator EPS 和 PDF 文件,After Effects 自动将空白区域转换成 alpha 通道。

在为输出图像指定颜色深度时,加号(如同在“数百万种以上颜色”中)表示 Alpha 通道。同样,选择输出到每像素 32 位意味着四个通道 (RGBA) 中每个通道的输出深度为每通道 8 位。

某些程序可以在一个图像中存储多个 Alpha 通道,但 After Effects 仅将第四个通道视为 Alpha 通道。

注意:

从技术角度来讲,术语 Alpha 通道是指 RGBA 图像文件中的第四个 (A) 通道,不管该通道是否用于传达透明度信息。但是,因为第四个通道经常用于传达透明度信息,所以术语 Alpha透明度在常见用法中几乎已成为同义词。不过,重要的一点是记住此连接是任意的。有些格式可能使用其他通道传达透明度信息,其他一些格式可能使用第四通道传达透明度信息之外的某些信息。

Knoll Unmult 增效工具可以用于从图层的暗区创建 Alpha 通道。这对于具有您要在其他图层上面合成的光照效果(如镜头光晕或火)的图层很有效。有关详细信息,请参阅 Red Giant Software 网站

当您在“合成”面板中查看 Alpha 通道时,白色表示完全不透明,黑色表示完全透明,灰度表示部分透明。

遮罩是一个图层(或图层的任何通道),用于定义该图层或其他图层的透明区域。白色定义不透明区域,黑色定义透明区域。Alpha 通道通常用作遮罩,但是,如果您的通道或图层定义的所需透明区域比 Alpha 通道所定义的更好,或者如果源图像不包含 Alpha 通道,您可以使用遮罩,而不是 Alpha 通道。

关于蒙版

After Effects 中的蒙版是一个用作参数来修改图层属性、效果和属性的路径。蒙版的最常见用法是修改图层的 Alpha 通道,以确定每个像素的图层的透明度。蒙版的另一常见用法是用作对文本设置动画的路径。(请参阅在路径上创建文本并为其设置动画。)

有关路径的更多常规信息,请参阅关于路径

所绘制蒙版的默认行为(左图);反转后的同一蒙版(右图)

闭合路径蒙版可以为图层创建透明区域。开放路径无法为图层创建透明区域,但可用作效果参数。可以将开放或闭合蒙版路径用作输入的效果包括描边、路径文本、音频波形、音频频谱以及勾画。可以将闭合蒙版(而不是开放蒙版)用作输入的效果包括填充、涂抹、改变形状、粒子运动场以及内部/外部键。

蒙版属于特定图层。每个图层可以包含多个蒙版。

您可以使用形状工具在常见几何形状(包括多边形、椭圆形和星形)中绘制蒙版,或者使用钢笔工具来绘制任意路径。

虽然蒙版路径的编辑和插值可提供一些额外功能,但绘制蒙版路径与在形状图层上绘制形状路径基本相同。您可以使用表达式将蒙版路径链接到形状路径,这使您能够将蒙版的优点融入形状图层,反之亦然。请参阅创建形状和蒙版以及编辑和动画显示形状路径和蒙版

蒙版在“时间轴”面板上的堆积顺序中的位置会影响它与其他蒙版的交互方式。您可以将蒙版拖到“时间轴”面板中“蒙版”属性组内的其他位置。

蒙版的“蒙版不透明度”属性确定闭合蒙版对蒙版区域内图层的 Alpha 通道的影响。蒙版不透明度值 100% 对应不透明的内部区域。蒙版外部的区域始终是透明的。要反转特定蒙版的内部和外部区域,请在“时间轴”面板中选择蒙版名称旁边的“反转”。

复制、剪切、保存、重用和删除蒙版

您可以在其他图层和合成中重复使用蒙版,对于您花了很长时间来完善的贝塞尔曲线蒙版,这尤其有用。蒙版路径存储在项目文件中的合成内。

复制、剪切、重复或粘贴蒙版

注意:

在使用蒙版路径(而不是整个蒙版,包括它的其他属性)时,应选择“蒙版路径”属性。在将蒙版路径转换为形状路径、运动路径等路径时,这一点尤其重要。

  • 要将选定蒙版复制或剪切到剪贴板,请选择“编辑”>“复制”或“编辑”>“剪切”。
  • 要重复选定蒙版,请选择“编辑”>“重复”。
  • 要将蒙版粘贴到图层上,请选择该图层,然后选择“编辑”>“粘贴”。如果已选择蒙版,该操作将替换选定蒙版。

保存蒙版

  1. 在包含您要保存的图层和蒙版的合成的“时间轴”面板中,展开图层及其蒙版属性。
  2. 执行以下操作之一:
    • 要保存动画蒙版,请选择要保存的蒙版关键帧。
    • 要保存非动画蒙版,请选择该蒙版。
  3. 复制蒙版或关键帧,并将蒙版或关键帧粘贴到新图层。该新图层可以是一个简单的纯色图层。
注意:

创建一个包含仅用于存储复杂蒙版的合成的项目。要使用另一项目中的蒙版时,请将该项目导入到当前项目中。

注意:

您也可以将蒙版另存为动画预设。(请参阅动画预设。)

重用蒙版

  1. 打开包含您想重用的蒙版的合成。如果您已将该蒙版保存在其他项目中,请导入该项目,然后打开包含相应蒙版的合成。
  2. 在“时间轴”面板中,展开蒙版的图层和蒙版属性。
  3. 选择蒙版或关键帧。
  4. 复制蒙版或关键帧,并将蒙版或关键帧粘贴到要应用该蒙版的图层。

删除蒙版

  • 要删除某个蒙版,请在“时间轴”面板中选择该蒙版并按 Delete 键。
  • 要删除所有蒙版,请选择包含您想移除的蒙版的图层,然后选择“图层”>“蒙版”>“移除所有蒙版”。

控制蒙版路径颜色

为了帮助您识别和使用蒙版,“合成”和“图层”面板勾勒出一个带颜色的蒙版路径,“时间轴”面板在蒙版名称旁边显示这一相同颜色。默认情况下,After Effects 为所有蒙版使用黄色。要使每个蒙版更加与众不同,您可以使用“时间轴”面板手动更改蒙版的颜色,或者您可以设置 After Effects 对新蒙版循环应用蒙版颜色。

启用“为蒙版路径使用对比色”首选项(位于“首选项”>“外观”下)后,After Effects 会分析开始绘制蒙版的点附近的颜色。随后,After Effects 会选择与该区域颜色不同的标签颜色。同时还会避免选择上次绘制蒙版时使用的颜色。

更改蒙版路径颜色

  1. 在“时间轴”面板中选择蒙版。
  2. 单击蒙版名称左侧的色板,选取新的颜色,然后单击“确定”。

对蒙版路径循环应用颜色

  1. 选择“编辑”>“首选项”>“外观”。
  2. 选择“循环蒙版颜色”。

蒙版模式

蒙版混合模式(蒙版模式)控制图层中的蒙版如何彼此交互。默认情况下,所有蒙版均设置为“相加”,这会合并同一图层上重叠的任何蒙版的透明度值。您可以向每个蒙版分别应用一种模式,但不能为蒙版模式设置动画,也就是说,您不能为蒙版模式属性设置关键帧或表达式,以使其随着时间的推移而变化。

您可以从“时间轴”面板中蒙版名称旁的菜单中为蒙版选择蒙版模式。

您创建的第一个蒙版将与图层的 Alpha 通道交互。如果该通道未将整个图像定义为不透明,则该蒙版将与图层帧交互。您创建的其他每个蒙版都将与“时间轴”面板中在堆叠顺序中位于其上面的蒙版交互。蒙版模式的结果会发生变化,具体取决于为堆叠顺序中更高位置的蒙版设置的模式。蒙版模式仅在同一图层上的两个蒙版之间起作用。

使用蒙版模式,您可以创建包含多个透明区域的复杂的复合蒙版。例如,您可以设置一个蒙版模式,以便合并两个蒙版并将不透明区域设置为这两个蒙版的相交区域。

对圆形蒙版应用不同模式时生成的复合蒙版。此插图中的蒙版具有不同的蒙版不透明度值。

A. 原始蒙版 B. 无 C. 相加 D. 相减 E. 相交 F. 变亮 G. 变暗 H. 差值 

蒙版对图层的 Alpha 通道没有直接影响。在您仅对“描边”或“填充”等效果使用蒙版路径时,或者如果您要使用蒙版路径作为形状路径的基础,则此选项将很有用。

相加

蒙版将添加到堆叠顺序中位于其上面的蒙版中。蒙版的影响将与位于其上面的蒙版累加。

相减

将从位于该蒙版上面的蒙版中减去其影响。如果您想在另一蒙版的中心创建一个洞,则此选项将很有用。

相交

蒙版将添加到堆叠顺序中位于其上面的蒙版中。在蒙版与位于它上面的蒙版重叠的区域中,该蒙版的影响将与位于它上面的蒙版累加。在蒙版与位于它上面的蒙版不重叠的区域中,结果是完全不透明。

变亮

蒙版将添加到堆叠顺序中位于其上面的蒙版中。如果有多个蒙版相交,则使用最高透明度值。

变暗

蒙版将添加到堆叠顺序中位于其上面的蒙版中。如果有多个蒙版相交,则使用最低透明度值。

差值

蒙版将添加到堆叠顺序中位于其上面的蒙版中。在蒙版与位于它上面的蒙版不重叠的区域中,将应用该蒙版,就好像图层上仅存在该蒙版一样。在蒙版与位于它上面的蒙版重叠的区域中,将从位于它上面的蒙版中抵消该蒙版的影响。

当您绘制或修改蒙版时,请使用以下键盘快捷键来更改闭合蒙版的模式:

函数

Mac

Win

N

N

相减

S

S

相加

A

A

相交

I

I

变暗

D

D

差值

F

F

变亮

L

L

注释:

  • 当使用“矩形”“椭圆形”“形状”工具绘制新蒙版时,您可以将这些键盘快捷键与鼠标搭配使用。
  • 如果使用“钢笔”工具绘制新蒙版,则只能在闭合蒙版后按这些键盘快捷键。要将鼠标指针放在闭合顶点(通常为第一个顶点)上,请单击并按住鼠标按钮关闭蒙版,然后在释放鼠标按钮之前,按蒙版模式键盘快捷键。开放蒙版没有模式。当使用“钢笔”工具绘制开放蒙版时,这些键盘快捷键不起作用。
  • 当修改闭合蒙版时,可在按住鼠标按钮的同时,随时按这些键盘快捷键。

扩展或收缩蒙版边缘

要扩展或收缩受蒙版影响的区域,请使用“蒙版扩展”属性。

蒙版扩展影响 Alpha 通道,但不影响底层蒙版路径;蒙版扩展实际上是一个偏移量,用于确定蒙版对 Alpha 通道的影响与蒙版路径的距离,以像素为单位。

您可以将蒙版扩展值向上划动到 32000,向下划动到 -32000。早期版本的 After Effects 只能将此值划动到 1000,超过 1000 的值只能手动输入。

  1. 在“时间轴”面板中,展开您想调整的图层的“蒙版”属性。
  2. 拖动“蒙版扩展”带下划线的值。

Todd Kopriva 在 Adobe 网站的博客上提供了有关蒙版扩展的图形演示辅助和进一步说明,同时还说明了生成圆角的原因。

柔化(羽化)蒙版的边缘

通过按用户定义的距离使蒙版边缘从透明度更高逐渐减至透明度更低,可以对蒙版边缘进行柔化。使用“蒙版羽化”属性,您可将蒙版边缘变为硬边或软边(羽化)。默认情况下,羽化宽度跨蒙版边缘,一半在内一半在外。例如,如果您将羽化宽度设置为 25,羽化扩展蒙版边缘内部的 12.5 像素及其外部的 12.5 像素。

您可以使用此滑块将蒙版羽化值向上划动到 32000。

不同蒙版羽化值的结果

A. 羽化值为 5 像素的带蒙版的图层 B. 羽化值为 40 像素的带蒙版的图层 C. 羽化值为 5 像素的结果 D. 羽化值为 40 像素的结果 

您也可以使用“蒙版扩展”属性扩展或收缩蒙版边缘,以控制蒙版羽化的显示位置。(请参阅扩展或收缩蒙版边缘。)

蒙版羽化仅发生在图层的各个维度内。因此,经过羽化的蒙版的路径应始终略微小于图层区域,而且不得移动到图层的边缘。如果蒙版羽化扩展至图层区域以外,则羽化边缘将突然结束。

  1. 要对选定图层显示“蒙版羽化”属性,请按 F 键。
  2. (可选)要约束水平和垂直羽化量,以按比例更改,请选择“蒙版羽化”属性旁的“约束比例”开关
  3. 可像修改其他任何属性一样修改“蒙版羽化”属性:通过拖动带下划线的值,或者单击带下划线的值然后在文本输入字段中输入数量。
注意:

因为蒙版羽化导致不透明度随着高斯分布而变化,所以受羽化影响的区域实际超出指定的像素数。超出指定羽化范围的羽化影响的数量级非常小。与线性衰减相比,这种渐变的高斯衰减看起来更自然。

可变宽度蒙版羽化

早期版本的 After Effects 可让您将羽化边缘添加到闭合蒙版,但羽化的宽度(范围)在蒙版周围是一样的。添加了新的蒙版羽化工具(在与钢笔工具相同的工具菜单中),允许您沿着可能具有不同宽度的闭合蒙版定义点。

如要创建羽化点:

选定的羽化点的手柄上有一个小黑点。

羽化点既定义外部羽化边界,又定义内部羽化边界。如果蒙版内没有羽化范围手柄,则内部羽化边界是蒙版路径。蒙版羽化从内部扩展到外部羽化边界。

选择多个羽化点:

使用选择工具或蒙版羽化工具,按住 Shift 键并单击羽化点范围手柄。

切换羽化点的选择

按住 Shift 键并单击羽化点。

要移动羽化点,请执行以下任意操作:

  • 使用选择工具或蒙版羽化工具,拖动羽化范围手柄。

您可以通过拖动其中一个羽化点来共同移动多个选定的羽化点,并且通过拖动其中一个羽化范围手柄来缩放多个羽化范围。

您可以“扫描”蒙版上边角点周围的羽化点。

  • 蒙版羽化工具处于活动状态后,按向左或向右按箭头沿着路径移动羽化,或者按向上或向下箭头延长或缩短羽化的宽度。

您可以移动多个选定的羽化点,并按住 Shift 键移动较长的距离/宽度。

将羽化点与蒙版路径对齐:

跨蒙版路径拖动羽化范围手柄。它将停在蒙版路径上。

控制羽化的衰减:

选择“图层”>“蒙版”>“羽化衰减”,然后请从下列选项中选择一个:

  • 平滑(默认)
  • 线性

通过羽化点调整羽化边界的张力(平滑或弯度):

从羽化范围手柄拖动以调整张力时,按住 Alt (Windows) 或 Option (MacOS) 键。“信息”面板显示手柄的当前张力。

设置羽化点的定格插值(直到下一羽化点的固定羽化半径):

从羽化范围手柄拖动以调整张力时,按住 Alt (Windows) 或 Option (MacOS) 键。“信息”面板显示手柄的当前张力。

设置羽化点的定格插值(直到下一羽化点的固定羽化半径):

通过羽化点上方的上下文菜单启用“定格”选项。羽化点手柄在固定半径方向变为尖状。

快速创建特定蒙版段的羽化边缘:

单击蒙版段(在顶点之间,而非在其上方)时,按住 Shift 键。指针更改,表示您处于此模式中。从段拖动以调整范围。注意以下行为:

  • 如果仅选择两个蒙版顶点,羽化边缘将应用于它们之间的连续段。
  • 如果选择单击选定段的两个顶点(即选择该段),羽化边缘将扩展为包括连续选定的段。
  • 如果选择蒙版上的所有顶点或未选择任何顶点,或如果前两个条件不适用,羽化边缘将仅应用于单击选定的段。

删除羽化点:

使用选择工具或蒙版羽化工具,选择羽化范围手柄,然后按“删除”。您可以删除多个选定的羽化点。

注意:

悬停到蒙版顶点时,指针更改为选取模式,而非删除顶点模式。

针对可变宽度蒙版羽化的技巧(蒙版羽化工具)

  • 按住“G”快捷键在钢笔和蒙版羽化工具之间临时切换。

您可以在“编辑”>“首选项”>“常规”(Windows) 或“After Effects”>“首选项”>“常规”(Mac OS) 中关闭此行为。

  • 查看蒙版上羽化点数的相关信息,“信息”面板中羽化范围的长度、位置和张力,以及羽化衰减的相关信息。
  • 通过取消选择“视图选项”对话框中的“蒙版羽化边界”选项,隐藏特定视图的羽化边界。您仍可以与本应绘制羽化点的边界(例如,添加新羽化点)交互。
  • 通过使用“常规”首选项中的“在编辑蒙版时保持固定的顶点和羽化数”选项,控制整个“蒙版路径”关键帧的羽化点数。
  • 通过使用羽化点上下文菜单中的命令,从对话框更改羽化点的张力、半径和边角角度值。
    悬停在蒙版顶点上时按住 Ctrl (Windows) 或 Cmd (Mac OS) 键,可切换到选取工具行为。
  • 当悬停在切点手柄上按住 Ctrl (Windows) 或 Cmd (MacOS) 键,可切换到转换顶点工具。

轨道遮罩和移动遮罩

如果您希望一个图层透过另一图层定义的开口显现出来,则可设置轨道遮罩。例如,您可以使用文本图层作为视频图层的轨道遮罩,以允许视频仅透过文本字符定义的形状显现出来。底层图层(填充图层)从轨道遮罩图层的特定通道值中获取其透明度值 - 其 Alpha 通道或其像素明亮度。

如果您想使用没有 Alpha 通道的图层创建轨道遮罩,或者使用从无法创建 Alpha 通道的程序导入的图层创建轨道遮罩,则根据轨道遮罩的像素的明亮度定义图层的透明度非常有用。在这两种情况下(使用 Alpha 通道遮罩和使用明亮度遮罩),具有较高值的像素将更加透明。通常,应使用高对比度遮罩,这样区域是完全透明或完全不透明的。中间阴影应该仅出现在您希望部分或逐渐透明的位置,例如沿柔化的边缘。

移动遮罩

A. 轨道遮罩图层:将具有矩形蒙版的纯色图层设为亮度遮罩。对蒙版设置动画以便在屏幕上移动。 B. 填充图层:带有图案效果的纯色图层。 C. 结果:该图案显示在轨道遮罩形状中,然后合成到其他图像图层上方。 

轨道遮罩仅应用于位于其紧下方的图层。要将轨道遮罩应用于多个图层,请首先预合成多个图层,然后将轨道遮罩应用于预合成图层。

在您复制或拆分图层之后,After Effects 将保持该图层及其轨道遮罩的顺序。在复制或拆分的图层内,轨道遮罩图层始终位于填充图层的上方。例如,如果您的合成包含图层 A 和 B,其中 A 是轨道遮罩,B 是填充图层,则复制或拆分这两个图层将生成图层顺序 ABAB。

如果您对轨道遮罩图层的位置和其他变换设置动画,则该图层称为移动遮罩。如果您要使用相同设置对轨道遮罩和填充图层设置动画,请考虑将其进行预合成。

将图层转换为轨道遮罩

“TrkMat”菜单与“混合模式”菜单共享一列。要显示“TrkMat”菜单,请确保“模式”列可见。(请参阅。)

  1. 在“时间轴”面板中,拖动图层以将其用作轨道遮罩并位于用作填充图层的图层正上方。
  2. 通过从填充图层的“TrkMat”菜单中选择下列选项之一,为轨道遮罩定义透明度:

    没有轨道遮罩

    不创建透明度;上一个图层充当普通图层。

    Alpha 遮罩

    Alpha 通道像素值为 100% 时不透明。

    Alpha 反转遮罩

    Alpha 通道像素值为 0% 时不透明。

    亮度遮罩

    像素的亮度值为 100% 时不透明。

    亮度反转遮罩

    像素的亮度值为 0% 时不透明。

如果您选择“没有轨道遮罩”之外的选项,After Effects 会将上方接下来的图层转换为轨道遮罩,关闭轨道遮罩图层的视频,并在“时间轴”面板中轨道遮罩图层名称旁添加轨道遮罩图标

注意:

即使关闭了遮罩图层的视频,也可以选择该图层进行重新定位、缩放或旋转。在“时间轴”面板中选择图层,然后拖动“合成”面板中图层的中心(用带 X 的圆表示)。

使用轨道遮罩类似于使用“保留底层透明度”选项,这将导致图层从图层堆栈顺序在它下面的图层的合成的透明度获取其透明度。(请参阅在合成期间保留底层透明度。)

有关使用轨道遮罩的技巧

  • 使用“色阶”效果可增加遮罩图层中明暗部分之间的对比度。这将减少具有许多中点值的问题,它们可转换为部分透明。(通常,遮罩在将边缘以外的区域定义为完全透明或完全不透明时非常有用。)
  • 要将遮罩图层的 Alpha 通道以外的通道用作遮罩,请使用通道效果之一(如“转换通道”效果)来将所需通道的值传递到 Alpha 通道中。
  • 要为轨道遮罩添加动画,使其与所遮罩的图层一起移动,应使该轨道遮罩成为其所遮罩的图层的子项。(请参阅父图层和子图层。)

在合成期间保留底层透明度

“保留底层透明度”选项将使图层从图层堆积顺序中位于它下面的图层合成的透明度中获取其透明度。换句话说,选择了此选项的图层的不透明区域仅当被放置在底层图层中不透明区域的上方时才会显示出来。此行为类似于轨道遮罩的行为,只是轨道遮罩只能是单个图层,并且轨道遮罩必须高于图层堆栈顺序中的图层。(请参阅轨道遮罩和移动遮罩。)

此选项可用于创建诸如闪光或抛光表面的反射光之类的效果。

选择了“保留底层透明度”选项的图层的行为与 Adobe Photoshop 中剪切蒙版的行为类似。

  1. 在图层的“模式”列中选择“T”选项。

用于 Mocha AE 蒙版的资源

您可以使用 Boris FX 的 Mocha AE 增效工具进行平面跟踪和创建蒙版。该增效工具使用平面跟踪工作流程来驱动形状以创建蒙版。Mocha AE 样条形状还包括可变的逐点边缘羽化,用于精确控制边缘模糊。

在 Mocha AE 的早期版本中,蒙版转换流程需要使用剪贴板和 Mocha Shape 增效工具,从 Mocha AE 复制/粘贴到 After Effects。Mocha AE 增效工具可在当前工作流程中将 Mocha 形状应用或转换到 After Effects。

如需更多信息,请参阅使用 Mocha AE 进行平面跟踪

有关 After Effects 的 Mocha AE 蒙版的视频教程,请参阅Boris FX 视频教程部分

Adobe 徽标

登录到您的帐户

[Feedback V2 Badge]