Corresponder cores

Correspondência da cor em imagens diferentes

O comando Corresponder Cor corresponde cores entre várias imagens, várias camadas ou várias seleções. Também permite ajustar as cores em uma imagem alterando a luminosidade e a faixa de cores, e neutralizando a projeção de cores. O comando Corresponder Cor funciona apenas no modo RGB.

Observação:

Quando o comando Corresponder Cor é utilizado, o ponteiro se transforma na ferramenta Conta-gotas. Utilize a ferramenta Conta-gotas ao ajustar a imagem para visualizar os valores de pixels de cor no painel Informações. Esse painel fornece um feedback sobre as alterações nos valores de cor conforme o comando Corresponder cor é usado. Consulte Exibir valores de cores em uma imagem.

O comando Corresponder cor corresponde às cores de uma imagem (a imagem de origem) com as cores de outra imagem (a imagem de destino). O comando Corresponder cor é útil quando você está tentando tornar as cores consistentes em fotos diferentes ou quando determinadas cores (como tons de pele) em uma imagem devem corresponder a cores em outra imagem.

Além de corresponder a cor entre duas imagens, o comando Corresponder Cor pode corresponder a cor entre diferentes camadas na mesma imagem.

Correspondência da cor entre duas imagens

  1. (Opcional) Faça uma seleção nas imagens de origem e destino.

    Se uma seleção não for criada, o comando Corresponder Cor corresponderá as estatísticas de imagem gerais entre as imagens.

  2. Torne ativa a imagem que deseja alterar e escolha Imagem > Ajustes > Corresponder cor.

    Se estiver aplicando o comando Corresponder Cor a uma camada específica na imagem de destino, verifique se essa camada está ativa quando escolher o comando.

  3. No menu Origem da área Estatísticas de Imagem da caixa de diálogo Corresponder Cor, escolha a imagem de origem cujas cores serão correspondidas na imagem de destino. Escolha Nenhum se não quiser referenciar uma imagem diferente para calcular o ajuste de cor. Com a opção Nenhum escolhida, a imagem de destino e a imagem de origem são as mesmas.

    Se necessário, utilize o menu Camada para escolher a camada na imagem de origem cujas cores deseja corresponder. Também é possível escolher Mescladas no menu Camada para corresponder as cores de todas as camadas na imagem de origem.

  4. Se uma seleção tiver sido criada na imagem, siga um ou mais destes procedimentos:
    • Na área Imagem de Destino, selecione a opção Ignorar Seleção ao Aplicar Ajuste se estiver aplicando o ajuste à toda a imagem de destino. Essa opção ignora a seleção da imagem de destino e aplica o ajuste à toda a imagem de destino.

    • Na área Estatísticas de Imagem, selecione a opção Usar Seleção na Origem para Calcular Cores se tiver criado uma seleção na imagem de origem e quiser utilizar as cores nessa seleção para calcular o ajuste. Cancele essa opção para ignorar a seleção na imagem de origem e utilizar as cores da imagem de origem inteira para calcular o ajuste.

    • Na área Estatísticas de Imagem, selecione Usar Seleção no Destino para Calcular o Ajuste se tiver criado uma seleção na imagem de destino e quiser utilizar as cores nessa seleção para calcular o ajuste. Cancele essa opção para ignorar a seleção na imagem de destino e calcular o ajuste utilizando as cores da imagem de destino inteira.

  5. Para remover automaticamente uma projeção de cor em uma imagem de destino, selecione a opção Neutralizar. Verifique se a opção Visualizar está selecionada para que a imagem seja atualizada enquanto os ajustes forem feitos.
  6. Para aumentar ou diminuir o brilho na imagem de destino, mova o controle Luminescência. Se preferir, digite um valor na caixa de texto Luminescência. O valor máximo é 200, o valor mínimo é 1 e o padrão é 100.
  7. Para ajustar a saturação de cores na imagem de destino, ajuste o controle deslizante de Intensidade da Cor. Se preferir, digite um valor na caixa de texto Intensidade da cor. O valor máximo é 200, o valor mínimo é 1 (que produz uma imagem em tons de cinza) e o padrão é 100.
  8. Para controlar a intensidade do ajuste aplicado à imagem, mova o controle deslizante Atenuar. Mover o controle deslizante para a direita reduz o ajuste.
  9. Clique em OK.

Correspondência da cor de duas camadas na mesma imagem

  1. (Opcional) Crie uma seleção na camada que deseja corresponder. Use este método ao corresponder uma região de cores (por exemplo, tons de pele faciais) de uma camada a uma região de outra camada.

    Se uma seleção não for criada, o comando Corresponder cor corresponderá as cores da camada de origem inteira.

  2. Verifique se a camada que deseja direcionar (à qual deseja aplicar o ajuste de cor) está ativa e escolha Imagem > Ajustes > Corresponder cor.
  3. No menu Origem da área Estatísticas de Imagem da caixa de diálogo Corresponder Cor, verifique se a imagem nesse menu é igual à imagem de destino.
  4. Utilize o menu Camada para escolher a camada cujas cores deseja corresponder. Também é possível escolher Mescladas no menu Camada para corresponder as cores de todas as camadas.
  5. Se uma seleção tiver sido criada na imagem, siga um ou mais destes procedimentos:
    • Na área Imagem de Destino, selecione Ignorar Seleção ao Aplicar Ajuste se estiver aplicando o ajuste em toda a camada de destino. Essa opção ignora a seleção da camada de destino e aplica o ajuste à toda a camada de destino.

    • Na área Estatísticas de Imagem, selecione Usar Seleção na Origem para Calcular Cores se tiver criado uma seleção na imagem de origem e quiser utilizar a cor nessa seleção para calcular o ajuste. Cancele essa opção para ignorar a seleção na camada de origem e utilizar as cores em toda a camada de origem para calcular o ajuste.

    • Na área Estatísticas de Imagem, selecione Usar Seleção no Destino para Calcular o Ajuste se apenas quiser utilizar as cores na área selecionada da camada de destino para calcular o ajuste. Cancele essa opção para ignorar a seleção e utilizar as cores da camada de destino inteira para calcular o ajuste.

  6. Para remover automaticamente uma projeção de cor em uma camada de destino, selecione a opção Neutralizar. Verifique se a opção Visualizar está selecionada para que a imagem seja atualizada enquanto os ajustes forem feitos.

  7. Para aumentar ou diminuir o brilho na camada de destino, mova o controle Luminescência. Se preferir, digite um valor na caixa de texto Luminescência. O valor máximo é 200, o valor mínimo é 1 e o padrão é 100.
  8. Para ajustar a faixa dos valores de pixel da cor na camada de destino, ajuste o controle deslizante Intensidade da cor. Se preferir, digite um valor na caixa de texto Intensidade da cor. O valor máximo é 200, o valor mínimo é 1 (que produz uma imagem em tons de cinza) e o padrão é 100.
  9. Para controlar a intensidade do ajuste aplicado à imagem, mova o controle deslizante Atenuar. Mover o controle deslizante para a direita reduz a intensidade de ajuste.
  10. Clique em OK.

Como salvar e aplicar configurações no comando Corresponder Cor

  • Na área Estatísticas de Imagem da caixa de diálogo Corresponder Cor, clique no botão Salvar Estatísticas. Nomeie e salve as configurações.
  • Na área Estatísticas de Imagem da caixa de diálogo Corresponder Cor, clique no botão Carregar Estatísticas. Localize e carregue o arquivo de configurações salvo.

Substituir cores

Substituição das cores de objetos em uma imagem

O Photoshop fornece várias técnicas que permitem que você substitua as cores de objetos. Para flexibilidade e resultados excelentes, aplique um ajuste de Matiz/Saturação aos objetos selecionados. Para menos flexibilidade, mas um agrupamento conveniente de opções, use a caixa de diálogo Substituir Cor. Para velocidade, mas menos precisão, tente a ferramenta Substituição de Cor.

Tutorial em vídeo: Alterar a cor de um objeto

Tutorial em vídeo: Alterar a cor de um objeto
Deke McClelland

Aplicar um ajuste de Matiz/Saturação aos objetos selecionados

Na maioria dos casos, essa técnica flexível substitui melhor as cores. Como as máscaras e as camadas de ajuste são não destrutivas, você poderá ajustar depois os resultados com total liberdade. Uma única opção Colorir faz alterações de cor absolutas, em vez de relativas (evitando matizar a partir de cores originais).

  1. Selecione o objeto que deseja alterar. A ferramenta Seleção Rápida  geralmente produz bons resultados. Para técnicas adicionais, consulte Selecionar um intervalo de cores e Limitar bordas de seleção.

  2. No painel Ajustes, clique no ícone de Matiz/saturação.

    A seleção torna-se uma máscara na camada de ajuste.

  3. No painel Propriedades, altere as configurações de Matiz e Saturação para substituir a cor do objeto. Se a cor original matizar a nova cor, selecione Colorir, e reajuste as configurações. (Consulte Ajustar o matiz e a saturação.)

    Observação:

    Deixe a configuração Luminosidade em zero para manter o contraste. Para manter o contraste e a saturação, selecione o modo de mesclagem Matiz para a camada de ajuste.

  4. Se necessário, amplie ou reduza a área afetada pintando na máscara com branco ou preto. (Consulte Editar uma máscara de camada.)

Para obter mais informações, consulte Visão geral do painel Ajustes.

Usar a caixa de diálogo Substituir Cor

A caixa de diálogo Substituir Cor combina ferramentas para selecionar um intervalo de cores com controles deslizantes HSL para substituir a cor. É possível também escolher a cor de substituição no Seletor de cores.

Substituir Cor necessita da opção Colorir, do ajuste de Matiz/Saturação, que pode ser necessário para uma alteração de cor completa. Você pode também localizar a técnica de camada de ajuste mais fácil para alterar objetos específicos. Contudo, o comando Substituir Cor é bom para alterações globais de cores — especialmente a alteração de cores sem gamut para impressão.

  1. Escolha Imagem > Ajustes > Substituir Cor.
  2. (Opcional) Se estiver selecionando cores semelhantes e adjacentes na imagem, selecione Clusters de cor localizados para criar uma máscara mais precisa.
  3. Selecione uma opção de visualização:

    Seleção

    Exibe a máscara na caixa de visualização. As áreas mascaradas são pretas e as áreas sem máscara são brancas. Áreas com máscaras parciais (cobertas com uma máscara semitransparente) aparecem como níveis variáveis de cinza, de acordo com sua opacidade.

    Imagem

    Exibe a imagem na caixa de visualização. Essa opção é útil ao trabalhar com uma imagem ampliada ou quando existe um espaço limitado na tela.

  4. Para selecionar as cores que você deseja substituir, use a ferramenta Conta-gotas para clicar na imagem ou na caixa de visualização para selecionar as áreas expostas pela máscara.
  5. Para refinar a seleção, faça o seguinte:
    • Clique com a tecla Shift pressionada ou use a ferramenta Conta-gotas para adicionar áreas.

    • Clique com a tecla Alt pressionada (Windows), clique com a tecla Option pressionada (Mac OS), ou use a ferramenta Subtrair do Conta-gotas de Amostra para remover áreas.

    • Clique na amostra de Cor da Seleção para abrir o Seletor de cores. Use o Seletor de cores para direcionar a cor que deseja substituir. À medida que uma cor é selecionada no Seletor de Cores, a máscara na caixa de visualização é atualizada.

  6. Arraste o controle deslizante de Grau de seleção ou insira um valor de Grau de seleção para controlar grau em que as cores relacionadas são incluídas na seleção.
  7. Especifique uma cor Substituta ao fazer o seguinte:
    • Arraste os controles deslizantes de Matiz, Saturação e Luminosidade (ou digite valores nas caixas de texto).

    • Clique na amostra de Resultado e utilize o Seletor de Cores para selecionar a cor de substituição.

    Observação:

    Não é possível substituir cinza puro, preto ou branco por uma cor. Contudo, você pode alterar a configuração Luminosidade. (As configurações Matiz e Saturação estão relacionadas à cor existente, portanto, não têm nenhum efeito.)

  8. (Opcional) Clique em Salvar para armazenar as configurações que serão carregadas depois para outras imagens.

Usar a ferramenta Substituição de Cor

A ferramenta Substituição de Cor pinta sobre uma cor-alvo com uma cor de substituição. Embora essa ferramenta seja boa para edições rápidas, ela geralmente se mostra insatisfatória, particularmente com cores escuras e preto. Se não obtiver bons resultados depois de testar as opções de ferramenta, consulte Ajustar o matiz e a saturação.

A ferramenta Substituição de Cor não funciona nos modos de cores Bitmap, Indexadas ou Multicanal.

  1. Selecione a ferramenta Substituição de cor . (Se a ferramenta não for visível, acesse-a mantendo pressionada ferramenta Pincel.)
  2. Na barra de opções, escolha uma ponta de pincel. Geralmente, deve-se manter o modo de mesclagem definido como Cor.
  3. Para a opção Amostras, escolha uma das alternativas a seguir:

    Contínuo 

    Obtém amostras continuamente ao arrastar.

    Uma Vez 

    Substitui a cor de destino somente em áreas que contenham a cor na qual você clicou primeiramente.

    Amostra de Plano de Fundo 

    Substitui somente áreas que contenham a cor atual do plano de fundo.

  4. No menu Limites, selecione uma das seguintes opções:

    Não-adjacente

    Não-adjacente, para substituir a amostra de cor sempre que ela ocorrer sob o ponteiro.

    Adjacente

    Substitui as cores que são adjacentes à cor diretamente sob o ponteiro.

    Indicação de Arestas

    Substitui as áreas ligadas com a amostra de cor, preservando melhor a nitidez das arestas da forma.

  5. Para Tolerância, escolha uma porcentagem baixa para substituir cores muito semelhantes ao pixel clicado ou aumente essa porcentagem para substituir um intervalo mais amplo de cores.
  6. Para produzir uma aresta suave nas áreas corrigidas, selecione Suavização de Serrilhado.
  7. Escolha uma cor de primeiro plano para substituir a cor indesejada. (Consulte Escolher cores na caixa de ferramentas.)
  8. Clique na cor a ser substituída na imagem.
  9. Arraste na imagem para substituir a cor de destino.

Observação:

Se o intervalo de cores substituídas for muito pequeno, aumente a configuração Tolerância na barra de opções.

Misturar cores seletivamente

Como fazer ajustes de cores seletivas

A correção de cores seletivas é uma técnica utilizada por scanners de alta resolução e programas avançados de separação para alterar a intensidade de cores de processamento em cada um dos componentes de cores primárias de uma imagem. É possível modificar a intensidade de uma cor de processamento em qualquer cor primária seletivamente, sem afetar as outras cores primárias. Por exemplo, é possível utilizar a correção de cores seletivas para diminuir o ciano no componente verde de uma imagem, deixando inalterado o ciano no componente azul.

Embora a Cor Seletiva use as cores CMYK para corrigir uma imagem, é possível usá-la em imagens RGB.

  1. Verifique se o canal composto está selecionado no painel Canais. O ajuste de Cor seletiva está disponível apenas durante a visualização do canal composto.
  2. Siga um destes procedimentos:
    • Clique no ícone Cor seletiva no painel Ajustes.

    • Escolha Camada > Nova Camada de Ajuste > Cor Seletiva. Clique em OK na caixa de diálogo Nova camada.

    Observação:

    Também é possível escolher Imagem > Ajustes > Cor seletiva. Mas lembre-se de que esse método faz ajustes diretos na camada da imagem e descarta as informações da imagem.

  3. Siga um destes procedimentos:
    • Escolha a cor que deseja ajustar no menu Cores no painel Propriedades. Você também pode escolher uma Predefinição salva.

    • No Painel Propriedades, escolha uma predefinição de Cor seletiva no menu Predefinição.

  4. Selecione um método no painel Propriedades:

    Relativo

    Altera a intensidade existente de ciano, magenta, amarelo ou preto de acordo com sua porcentagem do total. Por exemplo, se você iniciar com um pixel que contenha 50% de magenta e adicionar 10%, 5% será adicionado ao magenta (10% de 50% = 5%) para obter um total de 55% de magenta. (Essa opção não ajusta o branco especular puro, que não contém componentes de cor.)

    Absoluto

    Ajusta a cor em valores absolutos. Por exemplo, se você iniciar com um pixel que contenha 50% de magenta e adicionar 10%, a tinta magenta será definida como um total de 60%.

    Observação:

    o ajuste baseia-se no grau de proximidade de uma cor em relação a uma das opções no menu Cores. Por exemplo, 50% de magenta está em um ponto intermediário entre o branco e o magenta puro e receberá uma mistura proporcional de correções definidas para as duas cores.  

  5. Arraste os controles deslizantes para aumentar ou diminuir os componentes da cor selecionada.

    É possível também salvar as configurações feitas para o ajuste de Cor seletiva e reutilizar as configurações em outras imagens.

Esta obra está licenciada sob uma licença não adaptada da Creative Commons Attribution-Noncommercial-Share Alike 3.0  As publicações do Twitter™ e do Facebook não são cobertas pelos termos do Creative Commons.

Avisos legais   |   Política de privacidade online