Scopri cosa fare per rendere Illustrator più veloce ed efficiente in macOS.

Diversi fattori influenzano la velocità e l'efficienza con cui viene eseguito Adobe Illustrator, ad esempio, il sistema operativo e la configurazione dell'hardware, il flusso di lavoro o le opzioni selezionate. Se notate che Illustrator viene eseguito più lentamente del solito, potete provare varie tecniche per ottimizzare non solo le prestazioni di Illustrator, ma anche quelle delle altre applicazioni.

I miglioramenti delle prestazioni sono evidenti soprattutto quando lavorate con file di grandi dimensioni.

Prima di iniziare

Prima di eseguire le operazioni descritte di seguito, accertati di possedere la versione più recente di Illustrator o eventuali aggiornamenti disponibili per la versione di Illustrator utilizzata. Gli aggiornamenti del software includono spesso correzioni o miglioramenti correlati alle prestazioni.

Se utilizzi Illustrator CC, puoi aggiornare Illustrator tramite l’applicazione Creative Cloud per desktop.

Ottimizza macOS

Configurare il sistema operativo in modo efficiente aumenta la memoria disponibile per le applicazioni e ne assicura un funzionamento ottimale. Prova le seguenti tecniche per ottimizzare macOS e migliorare le prestazioni di Illustrator.

Gestione dei font

Ogni font installato aumenta la quantità di RAM utilizzata da macOS. Per migliorare le prestazioni del sistema e delle applicazioni che accedono ai font, installate solo i font di cui avete bisogno. Per gestire numerosi font, utilizzate un'utilità dedicata.

Utilizzo di un driver di stampa PostScript

I driver di stampa non PostScript possono causare conflitti con Illustrator. Di conseguenza, Adobe consiglia di impostare un driver di stampa PostScript come stampante predefinita in macOS.

Passaggio 1. Impostate una stampante PostScript come stampante predefinita

Nota:

Per portare a termine questa procedura, verifica che ci sia una stampante PostScript collegata al computer direttamente o tramite rete.

  1. Dal menu Apple, scegli Preferenze di sistema, quindi fai clic su Stampanti e scanner.

  2. Se nell'elenco non è presente alcuna stampante PostScript, fai clic su +, seleziona la stampante PostScript e fai clic su Aggiungi.

  3. Seleziona una stampante PostScript nel menu a comparsa in Stampante predefinita.

Passo 2. Configurate Illustrator per la stampa su una stampante non predefinita

  1. Apri un documento in Illustrator, quindi scegli File > Stampa.

  2. Nella finestra di dialogo Stampa, scegli File Adobe PostScript o il nome della stampante nel menu Stampante.

  3. Fate clic su Salva.

Ottimizzazione della configurazione hardware

L'hardware che utilizzate influisce sulle prestazioni di Illustrator: maggiore è la velocità del processore o del disco rigido, maggiore sarà la velocità di elaborazione delle informazioni da parte di Illustrator. Potete migliorare le prestazioni apportando anche altre modifiche all'hardware, ad esempio installando RAM ulteriore, utilizzando un sistema a più processori oppure eseguendo l'ottimizzazione e la deframmentazione delle unità. Di seguito sono riportate alcune operazioni che è possibile provare per ottimizzare la configurazione dell'hardware e migliorare le prestazioni di Illustrator.

Usare un processore più veloce

La velocità di Illustrator dipende dalla velocità della CPU (Central Processing Unit, unità centrale di elaborazione) del computer utilizzato. Poiché Illustrator gestisce grandi quantità di dati ed esegue numerosi calcoli, la velocità dipende dalla potenza del processore. Valutate la possibilità di utilizzare un computer con un processore più potente.

Installazione di RAM aggiuntiva

Se Illustrator non dispone di una quantità sufficiente di RAM, utilizzerà lo spazio su disco rigido (ovvero un disco di memoria virtuale) per elaborare le informazioni. Illustrator assicura prestazioni più rapide quando è in grado di elaborare le informazioni tramite la memoria, senza utilizzare il disco rigido.

Ottimizzazione dello spazio su disco

Di seguito sono riportati alcuni modi per ottimizzare lo spazio su disco:

  • Controlla il disco rigido per verificare l'eventuale presenza di errori o deframmenta i file con un’utility disco di terze parti (ad esempio, Norton Utilities). Se utilizzi macOS, non dovrebbe essere necessaria una deframmentazione, ma potrebbe esserlo una riparazione con un’utility disco di terze parti.
  • Salvate i file su unità con maggiore velocità di accesso. Ad esempio, usate un disco rigido interno anziché un server di rete (unità di rete) o un'unità rimovibile.

Utilizzo efficace delle funzionalità di Illustrator

Il modo in cui si lavora con Illustrator e in particolar modo come visualizza la grafica, può incidere sulle prestazioni di Illustrator. Di seguito sono riportati alcuni modi per utilizzare le funzioni di Illustrator che possono servire a farlo funzionare in maniera efficiente.

Lavorare in vista Contorno

La vista Contorno nasconde gli attributi di colore e visualizza i disegni come tracciati privi di riempimento. L'utilizzo della vista Contorno accelera la visualizzazione di disegni complessi, ad esempio di quelli contenenti sfumature o motivi. Inoltre, la vista Contorno semplifica la modifica degli oggetti nascosti dietro altri oggetti con riempimento.

Per visualizzare un documento Illustrator in vista Contorno, scegli Visualizza > Contorno.

Creare viste personalizzate

Potete creare viste personalizzate di un documento. Le viste personalizzate vi consentono di cambiare rapidamente la modalità di visualizzazione, l'ingrandimento, la posizione di scorrimento e le opzioni di livello.

Per creare una vista personalizzata di un documento di Illustrator, impostate gli attributi che desiderate salvare. Quindi seleziona Visualizza > Nuova vista e digita un nome nella finestra di dialogo visualizzata. La vista personalizzata viene inclusa nel menu Visualizza.

Cambiare le impostazioni degli effetti raster

Potete modificare la risoluzione degli effetti raster per ottimizzare le prestazioni di Illustrator.

Per modificare la risoluzione degli effetti raster, scegli Effetto > Impostazioni effetti raster del documento, poi scegli una delle opzioni seguenti nell’elenco a discesaRisoluzione :

  • Se state modificando i file, fate clic su Scolora. Illustrator adotta una risoluzione di 72 ppi per gli effetti raster, che aumenta la velocità di visualizzazione.
  • Se state stampando i file, fate clic su Alta. Illustrator adotta una risoluzione di 300 ppi per gli effetti raster, che riduce la velocità di stampa ma ne aumenta la qualità.

Poi, fate clic su OK.

Nascondere livelli e rimuovere le miniature

Quando vengono nascosti i livelli che contengono disegni complessi o immagini bitmap ad alta risoluzione, Illustrator aggiorna la schermata più rapidamente.

Per nascondere un livello, fate clic sull'icona a forma di occhio a sinistra del nome del livello, deselezionate Mostra livello, poi fate clic su OK. Per nascondere tutti i livelli tranne quello selezionato, tenete premuto il tasto Alt e fate clic sull'icona a forma di occhio.

Nel pannello Livelli possono essere visualizzate miniature per livelli superiori, livelli nidificati, gruppi e oggetti. Per ridurre il numero di miniature e consentire a Illustrator di aggiornare lo schermo più velocemente, scegli Opzioni pannello dal menu del pannello Livelli, quindi riduci il numero di miniature.

  • Per rimuovere tutte le miniature dal pannello Livelli, seleziona l'opzione per Righe piccole nella sezione Dimensione riga, quindi fai clic su OK.
  • Per rimuovere le miniature di elementi specifici dal riquadro Livelli, deseleziona Livelli, Gruppi o Oggetti nella sezione delle Miniature, quindi fai clic su OK.

Disattivare l'anteprima sovrastampa

Anteprima sovrastampa offre una "anteprima a inchiostri" che simula il risultato di fusioni, trasparenze e sovrastampa nella stampa in selezione colori. Per migliorare le prestazioni, evitate di utilizzare Anteprima sovrastampa.

Per attivare e disattivare Anteprima sovrastampa, seleziona Visualizza > Anteprima sovrastampa.

Eliminazione di tavole da disegno inutilizzate

Le tavole da disegno sono le aree che possono contenere grafica stampabile. Per ottimizzare le prestazioni, valuta l'eliminazione delle tavole da disegno inutilizzate o non necessarie.

Per gestire le tavole da disegno, scegli Finestra > Tavole da disegno. Quindi, selezionate una tavola da disegno da rimuovere e fate clic su Elimina.

Modifica della selezione del disco di memoria virtuale

Se si lavora con un'immagine bitmap incorporata e il sistema non dispone di RAM sufficiente, Illustrator utilizza lo spazio su disco rigido come un disco di memoria virtuale. L'accesso alle informazioni su disco rigido richiede più tempo rispetto all'accesso su memoria. Di conseguenza, l'utilizzo di una porzione del disco rigido come memoria virtuale può diminuire le prestazioni. Se l'utilizzo di Illustrator richiede più memoria, provate a espandere la RAM.

Per impostazione predefinita, Illustrator utilizza l'unità di sistema come disco di memoria virtuale principale. Impostate il disco rigido più veloce come disco di memoria virtuale principale di Illustrator.

Per modificare la preferenza relativa al disco di memoria virtuale, effettuate le seguenti operazioni:

  1. Scegli Illustrator > Preferenze > Plug-in e disco di memoria virtuale.

  2. Scegliete un disco rigido dal menu a comparsa degli elementi principali. Se desiderate lavorare con immagini di grandi dimensioni e disponete di più di un disco rigido, scegliete un altro disco dal menu a comparsa degli elementi secondari.
  3. Fai clic su OK e riavvia Illustrator.

Rimuovere elementi non usati dai profili dei documenti

I profili per documenti di Illustrator contengono motivi, sfumature, ideogrammi, colori, librerie di colori e pennelli predefiniti che vengono visualizzati nei nuovi documenti di Illustrator. Questi file determinano inoltre il livello di zoom, la dimensione delle finestre, le preferenze di visualizzazione e la posizione di scorrimento per i nuovi documenti. Minimizzate le dimensioni del file dei nuovi documenti rimuovendo campioni e pennelli non necessari dai profili per nuovi documenti Illustrator.

Per ulteriori istruzioni su come creare profili documento personalizzati in Illustrator CS, consultate Startup Profiles: A great tool to customize your new documents.

Rimozione di elementi non usati dai modelli

I modelli consentono di creare documenti che condividono impostazioni ed elementi grafici comuni. Puoi ridurre le dimensioni dei nuovi documenti rimuovendo campioni, simboli, stili grafici e pennelli non necessari dai modelli.

Per istruzioni su come creare i file dei modelli, consulta File e modelli.

Abilitare i collegamenti alle immagini

Le immagini bitmap incorporate (ad esempio TIFF, BMP e Photoshop EPS) aumentano notevolmente le dimensioni dei documenti di Illustrator e rallentano le prestazioni del programma. Per migliorare le prestazioni, attivate l'opzione Collega al momento dell'inserimento di un'immagine bitmap. L'opzione Collega crea un riferimento nel disco rigido all'immagine inserita.

  • Seleziona File > Inserisci. Nella finestra di dialogo Inserisci, scegliete Collega.

Se un service di stampa richiede immagini integrate, salvate una copia dei file. Seleziona Includi file collegati nella finestra di dialogo delle Opzioni del formato nativo di Illustrator o in quella delle Opzioni del formato EPS.

Usare le anteprime EPS a bassa risoluzione

Se un documento contiene immagini EPS collegate e dotate di anteprime ad alta risoluzione, Illustrator aggiornare più lentamente lo schermo quando si modifica la grafica. Per consentire a Illustrator di aggiornare lo schermo più rapidamente, utilizzate anteprime EPS a bassa risoluzione. Seguite la procedura descritta di seguito.

  1. Scegli Illustrator > Preferenze > Gestione file e Appunti.

  2. Seleziona Per EPS collegati usa proxy a bassa risoluzione e fai clic su OK.

Disattivazione di Mostra interazioni trasparenza DCS

La finestra di dialogo dello opzioni del pannello Collegamenti include l'opzione Mostra interazioni trasparenza DCS. Se selezionate questa opzione, nel pannello Collegamenti viene visualizzata un'icona gialla che consente di identificare gli elementi grafici EPS DCS che sono trasparenti o si sovrappongono a oggetti trasparenti. Poiché questa opzione obbliga Illustrator a stabilire di frequente se i file EPS collegati interagiscono con la trasparenza, le prestazioni potrebbero risultare rallentate.

Per disattivare l'opzione Mostra interazioni trasparenza DCS, seguite la procedura descritta di seguito.

  1. Seleziona Finestra > Collegamenti. Scegli Opzioni pannello dal menu del pannello Collegamenti.

  2. Deseleziona Mostra interazioni trasparenza DCS e fai clic su OK.

Nascondere il pannello Navigatore

Il pannello Navigatore visualizza una miniatura del disegno corrente per facilitare la navigazione. I tempi di elaborazione relativi all'aggiornamento della miniatura ogni volta che si modifica il documento dipendono dalla complessità del disegno. Per velocizzare l'aggiornamento della schermata e migliorare le prestazioni con un documento complesso, nascondete il pannello Navigatore.

  • Nel menu Finestra, deselezionate Navigatore.

È possibile impostare visualizzazioni personalizzate°per ottenere uno zoom maggiore per particolari aree del documento.

Disattivazione grafica anti-alias

L'opzione Grafica anti-alias migliora testo e grafica mediante la fusione del colore dei pixel del bordo di un oggetto con il colore dei pixel vicini. Tuttavia, questo processo può rallentare l'aggiornamento della schermata. Per disattivare questa opzione, seguite la procedura descritta di seguito.

  1. Scegli Illustrator > Preferenze > Generali.

  2. Disattiva Grafica anti-alias e fai clic su OK.

Applicare il comando Semplifica

Il comando Semplifica riduce il numero di punti di ancoraggio in tracciati e forme dei tracciati, riducendo le dimensioni del file e migliorando le prestazioni. Per applicare il comando Semplifica, seleziona il tracciato o l'oggetto desiderato, quindi scegli Oggetto > Tracciato > Semplifica.

Per ulteriori informazioni sul comando Semplifica, consultate Percorsi di modifica.

Disattivazione delle Guide sensibili

Le Guide sensibili consentono di creare, allineare, modificare e trasformare oggetti di Illustrator in relazione ad altri oggetti. Se nel disegno sono presenti molti oggetti, la visualizzazione delle Guide sensibili richiede più tempo.

  • Per disattivare le Guide sensibili, fai clic sul menu Visualizza e deseleziona°Guide sensibili.

Scopri maggiori informazioni sulle Guide sensibili.

Questo prodotto è concesso in licenza in base alla licenza di Attribuzione-Non commerciale-Condividi allo stesso modo 3.0 Unported di Creative Commons.  I post su Twitter™ e Facebook non sono coperti dai termini di Creative Commons.

Note legali   |   Informativa sulla privacy online