Il flusso di lavoro Esporta per schermi è un nuovo modo di generare risorse di diverse dimensioni e formati file con una sola azione. La possibilità di fare esportazioni rapide rende la generazione di materiale di imaging (icone, loghi, immagini, modelli e altro ancora) più semplice e veloce, specialmente perflussi di lavoro Webe per dispositivi mobili.

Ad esempio, in uno scenario di sviluppo di applicazioni per dispositivi mobili, lo User Experience Designer potrebbe voler rigenerare frequentemente icone e loghi aggiornati. Può aggiungere tali icone e loghi al pannello Esportazione risorse, quindi esportarli in file di vari tipi e dimensioni con un semplice clic. 

Funzioni utili:

  • Esportate in più formati e dimensioni con una sola e semplice azione. 
  • Esportate in dimensioni (scale) standard o personalizzate: 1x, 2x, 3x, 0,5x, 1,5x e altro ancora.
  • L’algoritmo per generare i file PNG è stato rivisto per:
    • Generare file PNG più velocemente che mai. 
    • Produrre una migliore trasparenza nei file PNG-8.

Formati disponibili: 

  • PNG (PNG-8, PNG-24)
  • JPEG (JPEG 100%, JPEG 85%, JPEG 50%, JPEG 25%)
  • SVG
  • PDF

Export-for-screens-dialog
La finestra di dialogo Esporta per schermi (scheda Risorse).

Esportazione di risorse (flusso di lavoro Esporta per schermi)

Esportare singole grafiche o tavole da disegno intere

  1. Effettuate una delle seguenti operazioni:

    • Scelta rapida da tastiera: (Windows) Ctrl + Alt + E / (Mac OS) Comando + Opzione + E. 
    • Fate clic su File > Esporta > Esporta per schermi.
    • Selezionate l’elemento grafico e fate clic su File > Esporta selezione.
    • Fate clic con il pulsante destro del mouse sull’elemento grafico selezionato e fate clic su Raccogli per l’esportazione.

    Nella finestra di dialogo Esporta per schermi, modificate le impostazioni che desiderate usare durante l’esportazione dell’elemento grafico.

  2. Selezionate l’area che desiderate esportare. Sono disponibili due schede:

    Scheda Tavole da disegno.

    Scegliete tra le tavole da disegno disponibili per l’esportazione. Fate clic sulla tavola da disegno per selezionarla o deselezionarla. Oppure, potete usare il mouse e il tasto Maiusc per effettuare più selezioni.

    Scheda Risorse.

    Scegliete tra le risorse che avete raccolto nel pannello Esportazione risorse. Consultate la sezione sottostante sul pannello Esportazione risorse.

    Nota:

    Fate clic sulle icone dell’elenco o le miniature per visualizzare diversamente gli elementi.

    Export-for-screens-dialog_artboards-tab
    La finestra di dialogo Esporta per schermi (scheda Tavole da disegno).
  3. In base alla scheda in cui vi trovate, scegliete l’elemento da esportare come file. Un segno di spunta indica se la tavola da disegno o la risorsa è selezionata o meno.

    Scheda Tavole da disegno:

    • Tutto. Selezionate tutte le tavole da disegno. Ogni tavola da disegno viene esportata singolarmente.
    • Intervallo. Selezionate singole tavole da disegno da esportare, da quelle disponibili nel documento. Ad esempio, 1, 2, 4-6 seleziona le tavole di disegno 1, 2, 4, 5 e 6.
    • Intero documento. Consente di esportare l’intero documento come un elemento grafico.

    Scheda Risorse:

    • Tutte le risorse. Selezionate questa opzione per esportare tutte le risorse raccolte nella scheda Risorse.

    Nota:

    Per iniziare di nuovo, fate clic su Cancella selezione per deselezionare tutte le risorse raccolte. È possibile iniziare a selezionare un elemento grafico specifico facendo clic sulle miniature.

  4. Specificate le impostazioni per i file esportati.

    • Scala. Specificate il fattore di scala per il file di output.
    • Percorso. Specificate la posizione della cartella in cui verranno inseriti i file esportati.
    • Accedi alla posizione dopo l’esportazione. Selezionate questa opzione per specificare se desiderate che la cartella che contiene le risorse esportate si apra utilizzando un browser di file (Esplora risorse o Finder).
    • Suffisso. Inserite un suffisso per fare in modo che i file di output abbiano nomi univoci.
    • Formato. Specificate se desiderate file di output in .png, .svg, .jpg, o .pdf.
    • Prefisso. Inserite una stringa che costituirà l’inizio dei nomi dei file generati.
    • Pulsante Aggiungi scala. Fate clic su Aggiungi scala per aggiungere una scala o un formato di output aggiuntivi per l’esportazione.
    • Pulsante Elimina. Fate clic sul simbolo X per eliminare un tipo di output.
    • Predefiniti.
      • iOS: Fate clic per aggiungere i tipi di file di output predefiniti generalmente richiesti per i progetti di iOS.
      • Android: Fate clic per aggiungere i tipi di file di output predefiniti generalmente richiesti per i progetti con il fattore di forma per Android.
  5. (Facoltativo) Fate clic sull’icona delle impostazioni () per specificare le impostazioni di output per i formati file esportati.

  6. Fate clic sul pulsante Esporta tavole da disegno o Esportare risorse.

Pannello Esportazione risorse

Raccogliete ed esportate rapidamente.

Il pannello Esportazione risorse visualizza le risorse che raccogliete dal vostro elemento grafico. Queste risorse, in genere, sono costituite dalla grafica che esportate più di frequente.

Ad esempio, in uno scenario di sviluppo di applicazioni per dispositivi mobili, lo User Experience Designer potrebbe voler rigenerare frequentemente icone e loghi aggiornati. È facile aggiungere tali icone e loghi al pannello Esportazione risorse, quindi esportarli in file di vari tipi e dimensioni con un semplice clic. 

AssetExport_panel
Il pannello Esportazione risorse

Raccogliere la grafica per l’esportazione

Potete raccogliere oggetti nel pannello Esportazione risorse per esportarli come risorse multiple o risorsa singola.

Raccogliere la grafica per l’esportazione come risorse multiple

Web

Per raccogliere oggetti/livelli per esportarli come risorse multiple, aggiungeteli al pannello Esportazione risorse (Finestra > Esportazione risorse). Effettuate una delle seguenti operazioni:

  • Trascinare l’elemento grafico nel pannello Esportazione risorse.
  • Fate clic con il pulsante destro del mouse su una risorsa e scegliete Raccogli per l’esportazione > Come risorse multiple. In alternativa, selezionate un elemento grafico e fate clic sull’icona Genera più risorse dalla selezione () nel pannello Esportazione risorse.
  • Per aggiungere i livelli evidenziati nel pannello Livelli come risorse, fate clic sull’icona Raccogli per l’esportazione nella parte inferiore del pannello Livelli.

Nota:

Ogni volta che trascinate un elemento grafico nel pannello Esportazione risorse, viene “raccolta” una risorsa. Questo non crea un oggetto duplicato sulla tavola da disegno o nelle CC Libraries. Quando aggiornate l’elemento grafico nel documento, la risorsa corrispondente viene aggiornata automaticamente nel pannello Esportazione risorse.

Raccogliere la grafica per l’esportazione come risorsa singola

Web

Effettuate una delle seguenti operazioni:

  • Tenete premuto Alt/ Opzione mentre trascinate un elemento grafico nel pannello Esportazione risorse.
  • Fate clic con il pulsante destro del mouse su una risorsa e scegliete Raccogli per l’esportazione > Come risorsa singola. In alternativa selezionate l’elemento grafico e premete Alt/ Opzione facendo clic sull’icona Genera una risorsa singola dalla selezione () nel pannello Esportazione risorse.

Esportazione di risorse (flusso di lavoro del pannello Esportazione risorse)

Esportare risorse usando il pannello Esportazione risorse

  1. Fate clic su Finestra > Esportazione risorse per aprire il pannello Esportazione risorse.

  2. Visualizzate le risorse raccolte nel pannello Esportazione risorse. Un bordo indica se la risorsa è selezionata per l’esportazione o meno.

    Nota:

    Vengono esportate solo le risorse contrassegnate da un bordo. Fate clic su una miniatura per selezionarla o deselezionarla.

  3. Fate clic sul triangolo Esporta impostazioni per visualizzare o aggiungere i formati e le dimensioni in cui desiderate esportare i vostri file:

    • Scala. Specificate il fattore di scala per il file di output.
    • Suffisso. Inserite un suffisso per fare in modo che i file di output abbiano nomi univoci.
    • Formato. Specificate se desiderate file di output in .png, .svg, .jpg, o .pdf.
    • Pulsante Aggiungi scala. Fate clic per aggiungere una scala o un formato di output aggiuntivi per l’esportazione.
    • Pulsante Elimina. Fate clic sul simbolo X per eliminare un tipo di output.
    • Predefiniti:
      • iOS: fate clic per aggiungere i tipi di file di output predefiniti generalmente richiesti per i progetti di iOS.
      • Android: fate clic per aggiungere i tipi di file di output predefiniti generalmente richiesti per i progetti con il fattore di forma per Android.
  4. (Facoltativo) Dal menu a comparsa, scegliete Impostazioni formato per specificare le impostazioni di output per i formati file esportati.

  5. (Facoltativo) Dal menu a comparsa, fate clic su Accedi alla posizione dopo l’esportazione per visualizzare i file esportati immediatamente dopo un flusso di lavoro di esportazione.

  6. Per generare i file, fate clic su Esporta.

    Durante l’esportazione delle risorse, Illustrator crea delle sottocartelle nel percorso di esportazione per impostazione predefinita in base alle opzioni di ridimensionamento selezionate. Per esempio, se selezionate più formati di scala nel pannello Esportazione risorse, come 1x 2x, e 3x per esportare un file in formato PNG, Illustrator crea sottocartelle denominate 1x, 2x e 3x per i file esportati. Per i formati che non supportano le opzioni di ridimensionamento, Illustrator denomina le sottocartelle in base ai formati di file selezionati per l’esportazione (per esempio, SVG e PDF). 

    Per esportare i file in una cartella senza creare una sottocartella, deselezionate l’opzione Crea sottocartelle dal pannello Esportazione risorse o dalla finestra di dialogo Esporta per schermi.

    Nota:

    Per modificare il percorso della cartella della risorsa da esportare, o per specificare informazioni quali il prefisso per i file, utilizzate la finestra di dialogo Esporta per schermi.Fate clic su  per aprire la finestra di dialogo Esporta per schermi. Tutte le opzioni impostate nel pannello Esportazione risorse vengono conservate nella finestra di dialogo Esporta per schermi.

Impostazioni di output per le risorse esportate

Opzioni specifiche per il formato per le risorse esportate

La finestra di dialogo Impostazioni formato consente di specificare le impostazioni di output per ogni tipo di file in cui è possibile esportare:

  • Nella finestra di dialogo Esporta per schermi, fate clic sull’icona delle impostazioni per avviare la finestra di dialogo Impostazioni formato.
  • Nel pannello Esportazione risorse, fate clic sul menu a comparsa e scegliete Impostazioni formato.
Inserite delle impostazioni specifiche per il formato nella finestra di dialogo Impostazioni formato.
Inserite delle impostazioni specifiche per il formato nella finestra di dialogo Impostazioni formato.

Questo prodotto è concesso in licenza in base alla licenza di Attribuzione-Non commerciale-Condividi allo stesso modo 3.0 Unported di Creative Commons.  I post su Twitter™ e Facebook non sono coperti dai termini di Creative Commons.

Note legali   |   Informativa sulla privacy online