データ駆動型グラフィックの作成

Last updated on 2026年10月29日

変数とデータセットを使用して、テキストや画像が異なる複数バージョンのテンプレートを生成します。

データドリブングラフィックを使用すると、変更する要素を定義し、データセットを通じて置換コンテンツを指定することで、1 つのテンプレートから複数の画像バリエーションを生成できます。

このワークフローは、さまざまな製品向けの Web バナー、パーソナライズされた証明書、ローカライズされたマーケティング素材など、テキスト、画像、レイヤーの表示が異なる複数バージョンのデザインを生成する必要がある場合に適用されます。テンプレートでは、変更したい各要素に個別のレイヤーを使用する必要があります。外部テキストファイルからデータセットを読み込む方法については、データセットの読み込みに関する記事を参照してください。

Photoshop では、テンプレートのさまざまな側面を制御する 3 種類の変数をサポートしています。表示変数は、レイヤーコンテンツを表示するかどうかを制御します。テキスト置換変数は、テキストレイヤーの文字列を置き換えます。ピクセル置換変数は、レイヤーのピクセルを画像ファイルのコンテンツに置き換えます。1 つのテンプレートに複数の変数タイプを適用したり、複数のレイヤーを同じ変数にリンクして変更を連動させたりできます。

テンプレート要素の変数を定義

画像 > 変数 > 定義を選択します。

レイヤーメニューから、変更したいコンテンツを含むレイヤーを選択します。

表示、テキスト置換、ピクセル置換のいずれか 1 つ以上の変数タイプを選択します。

名前フィールドに、スペースを含めずに文字、アンダースコア、コロン、ピリオド、またはハイフンを使用して名前を入力します。

ピクセル置換変数のスケーリング方法 (フィット、塗りつぶし、そのまま、コンフォーム) を選択します。

アラインメント位置を選択し、バウンディングボックスでクリップをチェックします。

追加のレイヤーについても同様の操作を行い、OK を選択します。

変数を含むレイヤーは、ダイアログ内でその名前の横にアスタリスクが表示されます。変数の名前を変更するには、画像 > 変数 > 定義に戻り、レイヤーを選択して、名前フィールドに新しい名前を入力します。複数のレイヤーを同じ変数にリンクするには、追加のレイヤーの変数を定義する際に、名前ドロップダウンメニューから既存の変数名を選択します。

データセットの作成と管理

画像 > 変数 > データセット を選択します。

新規データセットアイコンを選択して、現在の値に基づいたデータセットを作成します。

名前メニューから変数を選択します。

変数データを編集します。

  • 表示変数の場合:表示または非表示を選択します。
  • ピクセル置き換え変数の場合:ファイルを選択し、置き換え用の画像を選択します
  • テキスト置き換え変数の場合:値フィールドにテキストを入力します。

データセット内の各変数についてこの操作を繰り返します。

必要なデザインバリエーションごとに追加のデータセットを作成します。

終了したら、「OK」を選択します。

画像 > データセットの適用に移動し、リストからデータセットを選択して、適用を選択すると、各データセットがデザインにどのような影響を与えるかをプレビューできます。データセットダイアログのプレビューチェックボックスをオンにすると、ダイアログを閉じずに変更を確認できます。

データセットダイアログの矢印アイコンを使用して、データセット間を移動します。既存のデータセットを変更するには、データセットメニューからデータセットを選択し、変数の値を編集します。データセットを削除するには、データセットを選択して削除アイコンを選択します。

データセットから出力ファイルを生成

ファイル > 書き出し > データセットファイルとしてを選択します。

名前フィールドに生成されるファイルのベース名を入力します。

フォルダーを選択し、保存先ディレクトリを選択します。

リストから書き出すデータセットを選択します。

OK を選択してファイルを生成します。

Photoshop は各データセットに対して個別の PSD ファイルを作成し、ベース名とデータセット名を組み合わせます。各ファイルには、データセットの値が適用されたテンプレートが含まれます。

テンプレートにデータセットを直接適用すると(画像 > データセットの適用)、元のドキュメントが上書きされます。常にコピーで作業するか、代わりにデータセットをファイルとして書き出してください。