破損した Photoshop ファイルを復元する

Last updated on 2026年10月29日

Adobe Photoshop で、バックアップ復元、複合画像としての開き方、拡張子の確認を使用してファイルの破損を解決する方法を学びます。

Photoshop ファイルが破損したり開かなくなったりする場合、通常はファイルの破損、拡張子の不一致、またはグラフィックカードの問題が原因です。ファイルの破損はまれですが、1 つのファイルのみに発生しているか、複数のファイルに発生しているかを確認することで、原因と適切な復元方法を特定しやすくなります。

PSD、PSB、またはその他の Photoshop 対応ファイルを開こうとすると、「指定の操作を完了できません。有効な Photoshop 文書ではありません」、「指定の操作を完了できません。不明または無効な JPEG マーカータイプが見つかりました」、「指定の操作を完了できません。ファイル形式モジュールがファイルを解析できません」、「指定の操作を完了できません。プログラムエラーが発生しました」、または「これは有効な Portable Document File (PDF) 文書ではありません」というエラーメッセージが表示されることがあります。開くことができません。」ファイルが完全に開けなかったり、画面上に正しく表示されなかったり、ピクセルの乱れやコンテンツの欠落などの視覚的な破損が見られたりすることがあります。

復元を試みる前に、破損が 1 つのファイルのみに発生しているか、複数のファイルに発生しているかを確認してください。複数のファイルが破損している場合は、パターンがあるかどうかを確認します。それらは同じ場所に保存されていたか、同じ時期に作成されたか、停電やソフトウェアの更新といったシステムイベントの最中に編集されていたか、などです。これにより、原因が一時的な不具合か、継続的なハードウェアまたはソフトウェアの問題かを特定しやすくなります。

以下の解決策は、発生する可能性が高い順に、ファイルの破損の一般的な原因に対応しています:

バックアップからファイルを復元する

Creative Cloud、Time Machine (macOS)、File History (Windows)、またはその他のバックアップ場所で、画像のバックアップコピーを探します。

バックアップファイルを開いて、破損していないことを確認します。

ファイル > 別名で保存 を選択して、復元したファイルを新しい名前で保存します。

保存先には、ネットワークドライブやリムーバブルドライブではなく、内部ハードディスクを選択します。

ファイルを複合画像として開く

レイヤーデータが破損していても、統合された複合プレビューは損なわれていません。この復元方法は、ファイルを最初に保存したときに「PSD および PSB ファイルの互換性を最大化」が有効になっていた場合にのみ機能します。

Photoshop を起動する際に、Shift + Option (macOS) または Shift + Alt (Windows) を押したままにします。

ファイル > 開く を選択し、破損したファイルを選択します。

ファイルが開くまでキーを押し続けます。

復元した複合画像を新しい名前で保存します。

メモ

復元されたファイルは、すべてのレイヤーが結合されて平坦化されます。今後の問題を防ぐには、環境設定 > ファイル管理 で「PSD および PSB ファイルの互換性を最大化する」を有効にします。

ファイル名の拡張子を修正

ファイルが開かない場合は、ファイル名の拡張子が実際のファイル形式と一致していない可能性があります:

ファイル名の拡張子が実際のファイルタイプと一致していないため、Photoshop がファイル形式を正しく識別できません。

ファイルを右クリックして、拡張子を含む完全なファイル名を確認します。

ファイルに複数の拡張子がある場合(例: filename.pdf.jpg)、正しい拡張子以外をすべて削除します。

拡張子が実際のファイル形式と一致していることを確認してください。Photoshop ドキュメントの場合は .psd、JPEG 画像の場合は .jpg、PNG ファイルの場合は .png となります。

修正したファイルを Photoshop で開いてみます。

うまくいかない場合は、Preview (macOS) または Photos (Windows) でファイルを開いてみて、正しい形式で保存します。

実際のファイルタイプを判断する方法については、ドキュメントのファイルタイプを確認するを参照してください。

グラフィックプロセッサーを無効にする

画面上で画像が破損しているように見えても、書き出しや印刷が正常に行われる場合は、グラフィックカードが原因である可能性があります:

グラフィックカードまたはグラフィックドライバーが、実際のファイルデータには影響しない表示の破損を引き起こしています。

Photoshop > 環境設定 > パフォーマンス (macOS) または 編集 > 環境設定 > パフォーマンス (Windows) を選択します。

グラフィックプロセッサーを使用のチェックを外します。

OK を選択し、Photoshop を再起動します。

ファイルを開いて、破損がまだ発生しているかどうかを確認します。

破損が解消された場合は、グラフィックドライバーを更新して、GPU アクセラレーションを再度有効にします。グラフィック関連の問題を完全に解決する手順については、Photoshop のグラフィックプロセッサー (GPU) およびグラフィックドライバーの問題のトラブルシューティングを参照してください。

複数のファイルが破損している場合や、復元方法が失敗する場合は、ハードウェアまたはソフトウェアの問題が原因である可能性があります。共有ハードウェア(同じドライブ、ネットワークの場所、またはリムーバブルメディア)を示すパターンを確認し、ハードウェア診断を実行して RAM やハードディスクの問題を確認し、ファイルの保存に影響する可能性がある最近インストールしたソフトウェアを確認します。システムレベルの問題を体系的にトラブルシューティングするには、ほとんどの問題を解決する基本的なトラブルシューティング手順を参照してください。

セルフサービスでの復元が失敗する場合は、サードパーティの復元ユーティリティでファイルを復旧できる場合があります。アドビはこれらのツールをテストしたり、公式にサポートしたりしていませんが、PSD Parse Online、PSD Recover、または PSD Repair を使用してファイルを復元できたユーザーもいます。

今後のファイルの損失を防ぐには、環境設定 > ファイル管理で「回復情報の自動保存の間隔」を 5 分または 10 分に設定し、自動ファイル回復を有効にします。ファイルは、最も安全な保存場所である Creative Cloud (複数のバックアップバージョンを保持)、APFS/HFS+ (macOS) または NTFS (Windows) でフォーマットされた内部ハードディスクに保存し、最終手段として USB ドライブを使用してください。保存処理中に破損しやすくなるため、ネットワークサーバーや共有フォルダーに直接保存することは避けてください。完全な防止策については、ファイル保存の環境設定を使用してください。

エラーに関する追加のトラブルシューティングについては、.psd ファイルを開く際のプログラムエラーおよび無効な JPEG マーカーエラーを使用してください。